Community discussions

Search found 55 matches

  • 1
  • 2
by raivis-v
Tue Jan 16, 2007 11:47 am
Forum: Scripting
Topic: two command in an script
Replies: 4
Views: 1967

Re: two command in an script

I am not sure of what you are asking. Could you be more specific what is wrong and what do you want to get?
by raivis-v
Mon Jan 08, 2007 8:13 am
Forum: Scripting
Topic: Configure Script
Replies: 12
Views: 7200

I suggest you to weed that script from unnecessary lines. e.g. this one. / routing bgp set enabled=no as=1 router-id=0.0.0.0 redistribute-static=no \ redistribute-connected=no redistribute-rip=no redistribute-ospf=no It is default configuration, it is even not used. Leave only those things that you ...
by raivis-v
Mon Jan 08, 2007 8:05 am
Forum: Scripting
Topic: FIND and GET not using the same values (Bug?)
Replies: 3
Views: 1411

Re: FIND and GET not using the same values

I found out that it is not a bug. It is supposed to be so. Number returned by "find" command is not the same that you see when you are doing print command.
by raivis-v
Fri Jan 05, 2007 12:26 pm
Forum: Scripting
Topic: FIND and GET not using the same values (Bug?)
Replies: 3
Views: 1411

Re: FIND and GET not using the same values (Bug?)

Try to add "*" before number. :put [get *3011853 name] It does not work in all the cases though. Sometimes you need to enter command like you did, and then again with "*", to get correct name. It shouldn't be that way. [admin@...] > file print # NAME TYPE SIZE CREATION-TIME ... 24 exp.rsc script 133...
by raivis-v
Fri Dec 22, 2006 7:58 am
Forum: General
Topic: Very Funny Bug in RouterOS
Replies: 3
Views: 819

Re: Very Funny Bug in RouterOS

Seams to happen when adding disabled users. However, you won't be able to activate more than one at a time.


Edit:
It is a feature.
by raivis-v
Fri Dec 22, 2006 7:53 am
Forum: General
Topic: forcing clients to a web server
Replies: 1
Views: 606

Re: forcing clients to a web server

dear all

can i force clients to go to a local webserver when they first use the browser?

thankx
You can redirect them to your local web server. But that will happen every time they open some web page. You can not force them to open your local web server when they use browser for the first time.
by raivis-v
Thu Dec 21, 2006 4:42 pm
Forum: General
Topic: Burst for each TCP connection
Replies: 37
Views: 20964

hi, i'm also very interesting in this advances QoS. It will be gret to find a right solution and to put it like an example in one of manual. I'll try also to post some scripts WIKIPEDIA is for examples. If you make some good example script, better place it here: http://wiki.mikrotik.com/wiki/Main_P...
by raivis-v
Thu Dec 21, 2006 10:00 am
Forum: General
Topic: Linking public ips to local needs MT reboot?
Replies: 5
Views: 934

Re: Linking public ips to local needs MT reboot?

It should work without rebooting. What version are you using? Try to ping something (for several seconds) from your router in your local network and also something on the WAN.
by raivis-v
Thu Dec 21, 2006 9:53 am
Forum: General
Topic: MT eats memory
Replies: 4
Views: 704

Version 2.9.6... I guess i have to upgrade.
More than a year old version and you GUESS you should upgrade? I'd say you have no rights complain at all unless you have upgraded :twisted:
by raivis-v
Wed Dec 20, 2006 12:17 pm
Forum: RouterOS v6 RC and v7 BETA
Topic: web proxy
Replies: 11
Views: 4272

I haven't seen anything like this before. Maybe try to use netinstall to completely reinstall routerOS. If that does not help, make supout.rif and send it to support.
by raivis-v
Wed Dec 20, 2006 9:45 am
Forum: RouterOS v6 RC and v7 BETA
Topic: New RouterOS BETA is out: v3.0beta4
Replies: 30
Views: 7197

...
I would test BETA-4 soon though, but i'm think
the feature aren't improvised yet, because t
isn't mentioned in Changelog :-)

High Regards,
Andrei
As normis once said, not all the changes are mentioned in changelog. Just most important ones.
by raivis-v
Wed Dec 20, 2006 9:40 am
Forum: General
Topic: what am I doing wrong (src-mac-addr in bridge filter) a bug?
Replies: 3
Views: 950

I've already suggested to put default mask /48 if none specified by user, as it is in winbox.
by raivis-v
Wed Dec 20, 2006 9:20 am
Forum: General
Topic: what am I doing wrong (src-mac-addr in bridge filter) a bug?
Replies: 3
Views: 950

Re: what am I doing wrong (src-mac-addr in bridge filter) a

you have to specify mac-address mask
e.g.

11:22:33:44:55:66/FF:FF:FF:FF:FF:FF
by raivis-v
Wed Dec 20, 2006 8:09 am
Forum: General
Topic: Bandwidth test TCP packet size
Replies: 6
Views: 1194

Re: Bandwidth test TCP packet size

You can not set size of TCP packet. Out going packet size will be maximum packet size that is set on the interface.
by raivis-v
Wed Dec 20, 2006 7:53 am
Forum: General
Topic: Can't Ping but passing data fine
Replies: 5
Views: 1133

Re: Can't Ping but passing data fine

Also inner network addresses or just outer network addresses? Can it ping itself?
by raivis-v
Wed Dec 20, 2006 7:48 am
Forum: RouterOS v6 RC and v7 BETA
Topic: web proxy
Replies: 11
Views: 4272

well, if it is installed and showed in package list, you have to enable it first. If I have understood you correctly then you haven't enabled it.
/system package enable webproxy-test
by raivis-v
Wed Dec 20, 2006 7:44 am
Forum: Scripting
Topic: UPS power down/up alerting 2.9.x
Replies: 15
Views: 3638

Raivis-v is a magic variable in script :lol:


Actually i am raivis-v :wink:
by raivis-v
Tue Dec 19, 2006 3:04 pm
Forum: Scripting
Topic: UPS power down/up alerting 2.9.x
Replies: 15
Views: 3638

xandor: AS far as I understand from vk7zms's post, he has 2 scripts: First script is scheduled to run every minute :global datetime ([/system clock get time] . " - " . [:pick[/system clock get date] 4 6] . "-" . [:pick [/system clock get date]0 3] . "-" . [:pick[/system clock get date] 7 11]) /syste...
by raivis-v
Tue Dec 19, 2006 2:54 pm
Forum: General
Topic: DNS Service failing
Replies: 3
Views: 709

Have you tried disabling DNS service and remote DNS requests? I mean, can clients resolve anything from public DNS server when your DNS server is disabled?
Maybe that public DNS server is down. Are you sure it is running fine?
by raivis-v
Tue Dec 19, 2006 1:56 pm
Forum: RouterOS v6 RC and v7 BETA
Topic: web proxy
Replies: 11
Views: 4272

Re: web proxy

we have updated our MT cache box 2.9.34 to MT 2.9.38 as per forum suggestion but we are still facing problem i cache.CPU ussage of 100% within short period of proxy running.
is still ttheres bugs in web proxy
Did you try web-proxy-test package as suggested in that forum thread?
by raivis-v
Tue Dec 19, 2006 12:20 pm
Forum: General
Topic: web-proxy
Replies: 6
Views: 1259

i tried to upgrade MT 2.9.34 to MT 2.9.38,i uploaded newer ver in router and rebooted the router but still is shows MT 2.9.34 any mistake in updating ? 1) Delete any package file on router 2) Download packages from the web and upload once again 3) ensure you are using x86 version 4) As macgaiver sa...
by raivis-v
Tue Dec 19, 2006 8:41 am
Forum: RouterOS v6 RC and v7 BETA
Topic: New RouterOS BETA is out: v3.0beta4
Replies: 30
Views: 7197

when open in winbox ip ->neighbour winbox closes automatically without any error :D
what OS are you using? Works in beta4 and beta5.
by raivis-v
Tue Dec 19, 2006 8:11 am
Forum: General
Topic: DNS Service failing
Replies: 3
Views: 709

Re: DNS Service failing

I am using v2.9.38 for several weeks now and have not experienced that kind of a thing. Anyway, if DNS service fails and you have public entry of DNS on client side, everything has to work.
by raivis-v
Tue Dec 19, 2006 8:05 am
Forum: General
Topic: URL based DST NAT?
Replies: 4
Views: 6485

Re: URL based DST NAT?

Nope, there is no such a feature. You can try to use src and dst address list in advanced tab. First you have to make scheduler that will periodically resolve ip address of your domain (use :resolve command) and put it in address list. But that is not the best way to do this. Better use static entry...
by raivis-v
Mon Dec 18, 2006 3:06 pm
Forum: RouterOS v6 RC and v7 BETA
Topic: Winbox: Natural Ordering 1,2,10,11 instead of 1,10,11,2
Replies: 4
Views: 1875

strange, never thought that 1,2,3 is more natural than 1,10,11,2,20,22 :oops: kind of used to that ordering in computers.
Well, 1,2,3 is more natural. If PC orders numbers like 1,10,11,2,20, it does not mean it is more natural and more readable than natural sort.
by raivis-v
Mon Dec 18, 2006 2:56 pm
Forum: General
Topic: WINBOX MAC SCAN
Replies: 4
Views: 1931

Re: WINBOX MAC SCAN

... how you can make a tcp connection using just the mac for destination.


----------------------- & Ty
Who did tell you that it is using TCP connection in MAC telnet mode? Try to use sniffer and you'll see yourself.
by raivis-v
Fri Dec 15, 2006 10:48 am
Forum: RouterOS v6 RC and v7 BETA
Topic: New RouterOS BETA is out: v3.0beta4
Replies: 30
Views: 7197

We installed it on an RB112 and it kills it. It's up and running but you can't winbox or telnet in. When you try, it reboots. well, I've tried to connect to it via telnet and winbox simultaneously. And it still runs fine. CPU usage about 5%. It has basic configuration though. edit: Do you have wire...
by raivis-v
Fri Dec 15, 2006 9:26 am
Forum: General
Topic: MT Flash IDE Drive
Replies: 8
Views: 1193

You're welcome :) :wink:
by raivis-v
Fri Dec 15, 2006 9:24 am
Forum: Scripting
Topic: hotspot 'On Login' script - username?
Replies: 2
Views: 2527

I would also like to know this. Here is what jonmansey came up with: / system script add name=queue_move source={ :foreach i in=[/queue simple find dynamic=yes ] do={ /queue simple move $i } } then / ip hotspot user profile set default name="default" idle-timeout=none keepalive-timeout=2m status-au...
by raivis-v
Thu Dec 14, 2006 10:11 am
Forum: General
Topic: MT Flash IDE Drive
Replies: 8
Views: 1193

During the bootup the bios says its no longer a bootable device. It stops right at the point where it would boot the kernal loader. I put it in another pc and it saw it under device manager. Well, check if you have plugged it in IDE1 slot and check if switch on IDE flash is set to MASTER. If that i...
by raivis-v
Thu Dec 14, 2006 8:15 am
Forum: RouterOS v6 RC and v7 BETA
Topic: Winbox Feature Request: Connection filtering
Replies: 2
Views: 1517

Re: Winbox Feature Request: Connection filtering

...
Also, is there any standard way to request features?
Cheers.
There is a thread called - BETA Testing and Feature Suggestions for next routeros
http://forum.mikrotik.com/viewtopic.php?t=6585

You can post your requests there.
by raivis-v
Thu Dec 14, 2006 8:08 am
Forum: General
Topic: winbox.exe & wine-0.9.25
Replies: 12
Views: 3984

Is this workaround available? I'm using the 2.2.10 winbox.exe with MT 2.9.38 and it's freezing under wine 0.9.24 and 0.9.27... Would really like to be able to get back to a useable winbox under wine.. ssh interface is sometimes slow to traverse... Robert As Normis already said: in upcoming RouterOS...
by raivis-v
Thu Dec 14, 2006 8:01 am
Forum: General
Topic: MT Flash IDE Drive
Replies: 8
Views: 1193

Re: MT Flash IDE Drive

It worked and now does not any more or it didn't work from the very beginning?

You can use netinstall or cdinstall. It will format IDE flash, but license will be saved. Also you can save configuration if any exists.
by raivis-v
Thu Dec 14, 2006 7:51 am
Forum: Scripting
Topic: usser traffic monitor
Replies: 1
Views: 1282

Re: usser traffic monitor

 /interface monitor-traffic aggregate
by raivis-v
Tue Dec 12, 2006 3:45 pm
Forum: General
Topic: Scheduler preset time resets at every reboot
Replies: 4
Views: 1320

Re: Scheduler preset time resets at every reboot

Problem fixed. Try version 2.9.39 when it is released.
by raivis-v
Tue Dec 12, 2006 8:35 am
Forum: Scripting
Topic: How to send #27(ESC) Char via Rs-232?? , HELP !
Replies: 3
Views: 2007

Re: How to send #27(ESC) Char via Rs-232?? , HELP !

Hello, We want to use lcd display with ROS to show many usefull informations, but to take full control on this lcd with serial controler, We must send via serial port ascii char #27 (ESC) . Now we only use : \a bell (alarm), character code 7 \b backspace, character code 8 \f form feed, character co...
by raivis-v
Mon Dec 11, 2006 7:46 am
Forum: Scripting
Topic: PPPOE default
Replies: 8
Views: 2524

Re: PPPOE default

are somebody now howe to disable default pppoe profile (default service)???? please help!... if you mean "ppp profile default" then you can not disable it. It is not default pppoe profile - it is default ppp profile for any ppp service. It can not be disabled because every ppp service needs one act...
by raivis-v
Fri Dec 08, 2006 8:22 am
Forum: General
Topic: Access list
Replies: 10
Views: 2097

Re: Access list

if you do not use web-proxy test package, you can add allow rules to sites you want to allow e.g. ip web-proxy access add url=www.google.com action=allow After that you need to add deny rule ip web-proxy access add action=deny If you use web-proxy test package, you can use dst-host and also path par...
by raivis-v
Thu Dec 07, 2006 7:36 am
Forum: Scripting
Topic: a script to execute some commands?
Replies: 19
Views: 4719

If you have linux OS, expect should be in repositories. You just need to install it. If you run MS Windows OS, try to look here: http://expect.nist.gov/ There are also examples how to do this trick.
by raivis-v
Tue Dec 05, 2006 9:40 am
Forum: Scripting
Topic: Scripts for random?
Replies: 10
Views: 2435

Re: Scripts for random?

Hi,guys

Is there any way to generate a random number(integer) with MT scripts?

thx
Nope, it is not possible to generate rundom number with MT script at this moment, but rundom number generation will be implemented later in routerOS v 3.0
by raivis-v
Mon Dec 04, 2006 10:38 am
Forum: Scripting
Topic: Need help! How can i restart automaticly Scripts after reboo
Replies: 3
Views: 1328

If they are schduled scripts on an RB532, then you need to set your 'start-date' to a date befor the RB default stratup...

I use 1970...
you can also use start-time=startup on schaduler
by raivis-v
Mon Dec 04, 2006 9:56 am
Forum: Scripting
Topic: a script to execute some commands?
Replies: 19
Views: 4719

/system telnet 0.0.0.1 :put "8975" :put "/enable" :put ":put 5552" :put ":put /clear ip" How about? Your script ends at this line /system telnet 0.0.0.1 And that is it. It stops here. /system telnet ... is a command, that has already ended when you do :put "8975". I do not understand, how do you de...
by raivis-v
Fri Dec 01, 2006 2:48 pm
Forum: Scripting
Topic: need help with my script
Replies: 1
Views: 1128

Re: need help with my script

print comand does not work in scripts neither do :put comand. Instead you can use something like that:
:global a
:set a  [/interface wireless registration-table get [/interface wireless registration-table find radio-name=your_radio_name] signal-to-noise] 
:log info $a
Then check log table.
by raivis-v
Tue Sep 26, 2006 4:10 pm
Forum: Scripting
Topic: Reboot PPPoE-Server
Replies: 2
Views: 1341

Re: Reboot PPPoE-Server

i did not try this, but should be something like this:
/system script add name=pppoe_restarter source={/interface pppoe-server server disable; /interface pppoe-server server enable}
/system scheduler add on-event=pppoe_restarter interval=1d start-time=startup
by raivis-v
Mon Sep 18, 2006 3:11 pm
Forum: Scripting
Topic: Login script
Replies: 3
Views: 1782

What users are you talking about? standard MT users ment for router administration, or PPP secrets ment for tuneling etc ?
by raivis-v
Mon Sep 18, 2006 2:47 pm
Forum: Scripting
Topic: Why dosn't work it?
Replies: 1
Views: 1144

Re: Why dosn't work it?

It is working as it should. It is returning rule number: [admin@MikroTik] > queue simple print Flags: X - disabled, I - invalid, D - dynamic 0 name="queue1" target-addresses=10.10.12.253/32 dst-address=0.0.0.0/0 interface=all parent=none direction=both priority=8 queue=default-small/default-small li...
by raivis-v
Mon Sep 18, 2006 2:37 pm
Forum: Scripting
Topic: How to upload a script using FTP?
Replies: 9
Views: 3867

Re: How to upload a script using FTP?

Try this one:
system scheduler add name=scheduler_name on-event={import script_name}
by raivis-v
Mon Sep 18, 2006 2:29 pm
Forum: Scripting
Topic: Login script
Replies: 3
Views: 1782

Re: Login script

Why don't you limit ip addresses that MT can be accessed from? Thus you wont need to disable user. Besides, if you disable user with script, you wont be able to access MT by yourself as well.
by raivis-v
Mon Sep 18, 2006 2:15 pm
Forum: Scripting
Topic: I need help
Replies: 1
Views: 953

Re: I need help

What users are you talking about? If ppp secrets than you can disable 'em all with simple comand:
/ppp secret disable [find]
by raivis-v
Wed Nov 30, 2005 2:04 pm
Forum: General
Topic: Port Forwarding
Replies: 16
Views: 2607

Re: :(

Check you firewall rules, because NAT rules are correct. Also check, if your windows remote desktop is configured properly.
  • 1
  • 2