Community discussions

MUM Europe 2020

Search found 23 matches

by Def
Fri Mar 17, 2017 12:42 pm
Forum: Scripting
Topic: e-mail "on-error="
Replies: 8
Views: 1777

Re: e-mail "on-error="

Thank you very much... this is pretty close to the goal! I suggest it will work great in most of the common cases. But I think it will fail on some special cases. I made script like this: :local attempts 0; do { :set attempts ($attempts+1); :if ($attempts > 1) do {:log info ("ERROR - last email stat...
by Def
Fri Mar 17, 2017 9:14 am
Forum: Scripting
Topic: e-mail "on-error="
Replies: 8
Views: 1777

Re: e-mail "on-error="

Thanks. I tried something like this already, but it doesn't work. Like Martins S. wrote for 23q above: E-mail tool itself does not return error in CLI and works in background. On-error is not solution for e-mail tool. Even though, I tried your suggestion like this: { :local RES 1; :do { :do { :log i...
by Def
Thu Mar 16, 2017 6:00 pm
Forum: Scripting
Topic: e-mail "on-error="
Replies: 8
Views: 1777

Re: e-mail "on-error="

Thanks for fast reply.
I'm not sure if I understand what you mean.
How could I fill global variable with result of sending an email (whether email was sent successfully or not)?
If I try:
:global RES
:set RES [/tool e-mail send to="..." body="..." subject="..."]
variable RES is empty after that.
by Def
Thu Mar 16, 2017 5:35 pm
Forum: Scripting
Topic: e-mail "on-error="
Replies: 8
Views: 1777

Re: e-mail "on-error="

Hi all, I encountered the same problem. I need to handle errors generated during sending an email. How could be possible to catch such error (if 'on-error' is not the right solution)? (My goal is detect error during sending an email and try to resend it again in that case.) Thank you all in advance.
by Def
Tue Nov 04, 2014 12:46 am
Forum: General
Topic: IGMP Snooping
Replies: 137
Views: 60660

Re: IGMP Snooping

IGMP snooping is a must for me too. It was great disappointment for me when I found out that MikroTik doesn't support it.

So +1 for IGMP snooping.
by Def
Tue May 20, 2014 2:39 pm
Forum: Scripting
Topic: Find entry with empty comment in rOS 6.1
Replies: 3
Views: 909

Re: Find entry with empty comment in rOS 6.1

Thanks for reply.
/queue simple find where comment~""
selects all entries.
/queue simple find where (comment)."" = ""
works fine.

Both commands work also without "where", but I used it anyway.

Thank you for advice :)
by Def
Tue May 20, 2014 11:29 am
Forum: Scripting
Topic: Find entry with empty comment in rOS 6.1
Replies: 3
Views: 909

Find entry with empty comment in rOS 6.1

Hi, with upgrade to rOS 6.1 my script stopped to work. I need to find entries with empty comment. Till now works: /queue simple find comment="" But in rOS 6.1 it works no more. When I put /queue simple find comment=!"" it chooses all entries (with empty and non-empty comment too). So I assume the pr...
by Def
Sat Mar 03, 2012 2:03 pm
Forum: General
Topic: Check IP status (online/offline) behind NAT
Replies: 1
Views: 596

Check IP status (online/offline) behind NAT

Hi all, so let's assume situation: Testing PC (IP: 10.10.10.10) -> MikroTik (NAT, Firewall) -> LAN {PC1 (IP: 192.168.1.10), PC2 (IP: ...11), PC3, PC4} All I need is check from testing PC whether given IP in LAN (behind NAT) is online or not. I can't do that with ping, right? (I can ping only router'...
by Def
Sun Jan 17, 2010 4:16 pm
Forum: General
Topic: Wireless BUG
Replies: 5
Views: 902

Re: Wireless BUG

Same with 4.5 and 3.30... going to contact support@mikrotik.com
by Def
Tue Jan 12, 2010 6:19 pm
Forum: General
Topic: Wireless BUG
Replies: 5
Views: 902

Re: Wireless BUG

Hi... I'm sorry for delay, but I was too busy few last weeks. So... I tested it again on 4.3 and 4.4 with same result. RB just will not start to broadcast after scan if interface is in wds mode. I tried RB433, RB433AH and cards R52, R52N, UB5, R52AH so it seems it is software bug. I think I found on...
by Def
Sun Nov 22, 2009 6:21 pm
Forum: General
Topic: Wireless BUG
Replies: 5
Views: 902

Wireless BUG

I found out strange behavior of RB433. So step by step... There is set up bridge named "bridge1" where are all interfaces including all wlan interfaces. Let's consider there is just one wlan interface. This wireless interface's mode is wds-slave with wds-mode="dynamic" and wds-default-bridge="bridge...
by Def
Sun Sep 27, 2009 8:09 pm
Forum: General
Topic: Netwatch BUG
Replies: 1
Views: 573

Re: Netwatch BUG

Fixed since 3.30 / 4rc1
by Def
Fri Sep 18, 2009 10:34 am
Forum: General
Topic: RB750 + ROS v 4.0beta4
Replies: 1
Views: 441

RB750 + ROS v 4.0beta4

Hi all, I've just got RB750 with preinstalled ROS v 3.29. I tried to install ROS v 4.0beta4 there, but RB750 didn't boot properly. I just couldn't connect to it by winbox, neither by telnet. So I reinstalled ROS by netinstall, again with v 4.0beta4, but I got the same result. When I install there v ...
by Def
Fri Sep 18, 2009 10:16 am
Forum: General
Topic: is this setup OK
Replies: 3
Views: 464

Re: is this setup OK

I use the same configuration and it works fine.
by Def
Fri Sep 18, 2009 10:13 am
Forum: General
Topic: Sending e-mail timeout
Replies: 1
Views: 673

Re: Sending e-mail timeout

I tested it on x86 platform with ROS v3.28. Same thing on RB433, ROS v3.28 and 4.0beta4.
by Def
Tue Sep 15, 2009 11:38 pm
Forum: General
Topic: Netwatch BUG
Replies: 1
Views: 573

Netwatch BUG

Hi I noticed strange behavior of RB433 when I use following configuration: /tool netwatch add disabled=no down-script=down1 host=192.168.1.1 interval=1m timeout=1s up-script=up1 add disabled=no down-script=down2 host=192.168.1.2 interval=1m timeout=1s up-script=up2 add disabled=no down-script=down3 ...
by Def
Tue Sep 15, 2009 12:57 pm
Forum: General
Topic: Sending e-mail timeout
Replies: 1
Views: 673

Sending e-mail timeout

Hello, I've set up MikroTik to send e-mails. It works fine - I can send email with attached file without any problem. But if I try to send e-mail with larger file, after 60 sec I get this error: System-Error: Error sending e-mail: abnormal termination (timeout) I checked interface's Tx/Rx while send...
by Def
Sat Sep 13, 2008 2:46 pm
Forum: General
Topic: ERROR: Gateway Timeout with proxy
Replies: 7
Views: 10219

Re: ERROR: Gateway Timeout with proxy

Thanks for responses,
now I don't get any error, but pages are still loading (waiting for http://www.google.com...) but no data are downloaded...
by Def
Sat Sep 13, 2008 1:36 pm
Forum: General
Topic: ERROR: Gateway Timeout with proxy
Replies: 7
Views: 10219

Re: ERROR: Gateway Timeout with proxy

I did... but it's the same. Dst-nat works correctly, because if I disable it, I don't get timeout error. So it is web proxy what's wrong. But I still don't know what exactly is wrong... :(
by Def
Sat Sep 13, 2008 9:57 am
Forum: General
Topic: ERROR: Gateway Timeout with proxy
Replies: 7
Views: 10219

ERROR: Gateway Timeout with proxy

Hello, I can't find out why I'm getting this error: ERROR: Gateway Timeout Your cache administrator is webmaster. Generated Sat, 13 Sep 2008 08:31:24 GMT by 10.8.15.99 (Mikrotik HttpProxy) I get this error only when I enable web proxy. With disabled proxy there's no problem... everything's going per...
by Def
Fri Sep 12, 2008 9:52 am
Forum: General
Topic: hotspot question
Replies: 2
Views: 589

Re: hotspot question

thanks for reply
by Def
Fri Sep 12, 2008 9:07 am
Forum: General
Topic: hotspot question
Replies: 2
Views: 589

hotspot question

Hi,

Is possible to use hotspot only for specified IPs without setting up the ip-binding?

Thank you in advance
by Def
Thu Sep 11, 2008 2:48 pm
Forum: General
Topic: how to block my client that not pay?
Replies: 17
Views: 4365

Re: how to block my client that not pay?

x.x.x.x = IP address of your webserver that will give the "please pay us" page. y.y.y.y = the IP address of a customer who has been suspended for nonpayment / ip firewall nat add chain=dstnat action=dst-nat to-addresses=x.x.x.x to-ports=80 \ dst-port=80 protocol=tcp src-address-list=suspended_custo...