Community discussions

MikroTik App

Search found 16 matches

by xmanuw
Fri May 24, 2013 8:51 pm
Forum: Scripting
Topic: Hotspot: Redirect on every session
Replies: 0
Views: 506

Hotspot: Redirect on every session

Hello alltogether, we have a very special problem. We'd like to have each user (registered and not yet registered) at the time, he starts browsing the web, to be redirected to a special page on our server. We use Mac authentication and to redirect him when he's not yet registered is really easy (don...
by xmanuw
Wed Dec 19, 2012 6:04 pm
Forum: RouterBOARD hardware
Topic: RB751U-2HnD - poor wireless performance & problems
Replies: 113
Views: 117566

Re: RB751U-2HnD - poor wireless performance & problems

I am really stunned that Mikrotik isn't doing anything about this topic. The problem is present in all versions and it seems Mikrotik is not even trying to fix this. Unfortunately this leaves most people no choice than to switch vendors... I'm really interested in the development here, but it seems ...
by xmanuw
Wed May 05, 2010 10:15 pm
Forum: Scripting
Topic: hotspot user registration via webpage?
Replies: 6
Views: 8996

Re: hotspot user registration via webpage?

Thanks for this quick answer.

I thought it would be this way but hoped for another solution (hoped to keep it all on the Routerboard).

Anyway. Thanks for Your help.
by xmanuw
Wed May 05, 2010 10:02 pm
Forum: Scripting
Topic: hotspot user registration via webpage?
Replies: 6
Views: 8996

hotspot user registration via webpage?

Is there a way to create a registration website on a routerboard, so that a customer can enter some data like his name, e-mail and tel. number and this information is submitted to the routerboard? Unfortunately RouterOS does not support any scripting language like php. Is there any way to get custom...
by xmanuw
Sun Sep 13, 2009 5:22 pm
Forum: Scripting
Topic: Detect all Mikrotik Routerboards
Replies: 10
Views: 2068

Re: Detect all Mikrotik Routerboards

I have no sample here for You right now, but it should not be that hard to figure out. Just use wireshark and listen to all Broadcasts on Port 5678/udp. Then use winbox click the button to search for routerboards. It should not be so hard too figure out the structure of the responses (which also go ...
by xmanuw
Tue Jul 14, 2009 8:24 pm
Forum: Scripting
Topic: Detect all Mikrotik Routerboards
Replies: 10
Views: 2068

Re: Detect all Mikrotik Routerboards

I needed a way to find all routerboards without beeing connected with one up to that point.

Luckyly the protocol isn't that hard to decipher so got it working now.

But thanks for Your post, though.
by xmanuw
Fri Jun 19, 2009 10:41 pm
Forum: Scripting
Topic: Some words about UPDATES
Replies: 4
Views: 924

Re: Some words about UPDATES

My colleague tested running a script by a scheduler which did not work (no script-run triggered).
by xmanuw
Fri Jun 19, 2009 11:05 am
Forum: Scripting
Topic: getting and setting of global variables via API?
Replies: 3
Views: 952

Re: getting and setting of global variables via API?

Then I can also create a script that does never run and then use =source= as variable.
by xmanuw
Fri Jun 19, 2009 11:02 am
Forum: Scripting
Topic: Some words about UPDATES
Replies: 4
Views: 924

Some words about UPDATES

We are developing a software solution based on MikroTik boards. This software uses quite a lot features and it controls the boards using API. Everything would be fine if there were no updates. We still have to work with version 3.17, because it is the only version that does not contain major bugs in...
by xmanuw
Thu Jun 18, 2009 11:21 am
Forum: Scripting
Topic: getting and setting of global variables via API?
Replies: 3
Views: 952

getting and setting of global variables via API?

Is there any way to access or set global variables via API?

In the terminal I can do something like this:
:global test 1

:put $test
That works fine.

Is there any equivalent API command?

Thanks in advance.
by xmanuw
Wed May 13, 2009 10:31 am
Forum: Scripting
Topic: Detect all Mikrotik Routerboards
Replies: 10
Views: 2068

Re: Detect all Mikrotik Routerboards

Ok, thank You.

Then I have to search for another way to solve my problem.

xmanuw.
by xmanuw
Wed May 13, 2009 10:21 am
Forum: Scripting
Topic: Detect all Mikrotik Routerboards
Replies: 10
Views: 2068

Re: Detect all Mikrotik Routerboards

Yes, that programs do it. My question is now how they do it. Because I need to autodetect the boards in my own application. I don't now if this is an open standard or something internal like winbox protocol. If there is any way to retrieve a list of boards with my own code, please let me know. Thank...
by xmanuw
Wed May 13, 2009 10:10 am
Forum: Scripting
Topic: Detect all Mikrotik Routerboards
Replies: 10
Views: 2068

Detect all Mikrotik Routerboards

Hello, is there any possibility to detect all Mikrotik Boards in the current network? I mean something like WinBox does when clicking the tree dots beside of Connect To. I have to connect to a new Routerboard with a clean configuration and do NOT want to do this by serial (which is working right now...
by xmanuw
Sat Apr 04, 2009 9:58 pm
Forum: Scripting
Topic: API Regressions since 3.21
Replies: 4
Views: 1040

Re: API Regressions since 3.21

I did. Even before posting to this forum.
I hope something changes in future releases.
by xmanuw
Sat Apr 04, 2009 9:09 pm
Forum: Scripting
Topic: API Regressions since 3.21
Replies: 4
Views: 1040

Re: API Regressions since 3.21

Yes I did.
It didn't work either.
=.proplist=.id,name,disabled
returns something like this
!re
=.id=*175
=name=32630
!done
by xmanuw
Sat Apr 04, 2009 12:14 pm
Forum: Scripting
Topic: API Regressions since 3.21
Replies: 4
Views: 1040

API Regressions since 3.21

Hello, I recently updated my Routerboard (Crossroads) to Version 3.22. I was curious about api queries since this is what I was waiting for. Before 3.22 I used Version 3.17. I am writing an Application using the API. In Version 3.17 I created a script like this: /ip hotspot user print where disabled...