Community discussions

MUM Europe 2020

Search found 54 matches

by XTLMeth
Fri May 25, 2018 10:50 pm
Forum: General
Topic: Can't Login After Upgrade
Replies: 7
Views: 3894

Re: Can't Login After Upgrade

That worked. Thank you!
by XTLMeth
Fri May 25, 2018 10:43 pm
Forum: General
Topic: Can't Login After Upgrade
Replies: 7
Views: 3894

Re: Can't Login After Upgrade

I only see winbox 3.13 on the download page. Is there some other location I should be looking to get 3.14?
by XTLMeth
Fri May 25, 2018 10:30 pm
Forum: General
Topic: Can't Login After Upgrade
Replies: 7
Views: 3894

Re: Can't Login After Upgrade

I did read the release notes and I knew there were changes related to hashed passwords. I just upgraded another router and I can't login in using winbox/ssh/webfig when the router comes back up. It just says wrong password.
by XTLMeth
Fri May 25, 2018 9:41 pm
Forum: General
Topic: Can't Login After Upgrade
Replies: 7
Views: 3894

Can't Login After Upgrade

After upgrading a couple routers to 6.43rc19 I can't login anymore. It's as if my accounts have been deleted. I know there were some security changes in the update but how do I fix my login issue?
by XTLMeth
Tue Apr 30, 2013 5:20 pm
Forum: General
Topic: Multihoming IPV6
Replies: 6
Views: 3942

Re: Multihoming IPV6

It is far better to run a dual stack if you can help it. One reason is when it comes time to shut ipv4 down and migrate completely to ipv6 now you have to reconfigure everything. Another reason is that using any kind of translation has the potential to break applications that don't work well with it...
by XTLMeth
Sat Feb 23, 2013 7:12 pm
Forum: RouterBOARD hardware
Topic: Cloud Core Router
Replies: 4
Views: 1272

Re: Cloud Core Router

Does the fan increase speed with load or is the speed always the same?
by XTLMeth
Sat Feb 23, 2013 6:36 am
Forum: RouterBOARD hardware
Topic: Cloud Core Router
Replies: 4
Views: 1272

Cloud Core Router

I am looking at buying a cloud core router but I am wondering how loud the fan is inside. I need to have something that has decent performance in a quiet environment.
by XTLMeth
Sun Oct 28, 2012 12:56 am
Forum: RouterBOARD hardware
Topic: Hardware Request/Idea
Replies: 3
Views: 789

Re: Hardware Request/Idea

I didn't even notice the 951 was as small as the 750 but with wireless in it. Thanks for pointing that out. :)
by XTLMeth
Sat Oct 27, 2012 8:24 pm
Forum: RouterBOARD hardware
Topic: Hardware Request/Idea
Replies: 3
Views: 789

Hardware Request/Idea

I think it be cool to have a small routerboard with 2x ethernet and a wireless radio. Kind of like what aruba has. http://www.arubanetworks.com/products/rap-2wg/ It doesn't have to have a big cpu or anything crazy but something small where you could deploy them cheaply in the field as a portable rou...
by XTLMeth
Thu Apr 08, 2010 1:08 am
Forum: General
Topic: OVPN traffic stops (Solved)
Replies: 9
Views: 10001

Re: OVPN traffic stops (Solved)

In my case I'm doing a point to point with a /30 and I don't use the set default route option. My client side is a mikrotik server and my server side is a linux openvpn server. I have other windows clients connected to the same linux server for months but the mikrotik client router stops passing tra...
by XTLMeth
Wed Apr 07, 2010 5:28 am
Forum: General
Topic: OVPN traffic stops (Solved)
Replies: 9
Views: 10001

Re: OVPN traffic stops

I have seen the exact same behavior. The sad part is this issue won't have any priority as I have said before that everyone else seems to think that they have openvpn running without any issues. I have tried several different configs and have not been successful. I use pptp connections and they stay...
by XTLMeth
Mon Apr 05, 2010 11:52 pm
Forum: General
Topic: OVPN traffic stops (Solved)
Replies: 9
Views: 10001

Re: OVPN traffic stops

I have had this problem for a while and even posted on this forum. Nobody cared. Everyone clames they have openvpn running without issues. In my case I have to reboot my routerboard about every 24 days to get it to work again.
by XTLMeth
Thu Apr 01, 2010 6:51 am
Forum: General
Topic: RB816
Replies: 2
Views: 597

Re: RB816

So I did what you said and sent the supout.rif into support. What's really interesting is after I installed the ROS5 beta the card started work but only for like 20 minutes. If I reset the routerboard it works again for a while then stops again. The macs are all wonky and resetting them doesn't put ...
by XTLMeth
Thu Apr 01, 2010 12:10 am
Forum: General
Topic: 5.0beta1
Replies: 10
Views: 1908

Re: 5.0beta1

I assumed it was on by default when it was working but it died in the middle of a connection. Where do I go in the config to turn it on/off?
by XTLMeth
Wed Mar 31, 2010 8:46 pm
Forum: General
Topic: 5.0beta1
Replies: 10
Views: 1908

Re: 5.0beta1

So much for SSH port forwarding. I tried it and the SSH session died while using it.
by XTLMeth
Tue Mar 30, 2010 5:44 am
Forum: General
Topic: RB816
Replies: 2
Views: 597

RB816

Has anyone tried this thing out? I bought one and it's not working. The ports show up but if I disabled I can't re-enable them and the macs are all weird. I tried to configure a port but doesn't show a link status.
by XTLMeth
Mon Jan 11, 2010 9:43 pm
Forum: General
Topic: 2 Dynamic Connections on same subnet.
Replies: 9
Views: 1295

Re: 2 Dynamic Connections on same subnet.

So now I restored to a previous config so all those funky routes I was playing with are gone but now I'm even more frustrated. I previously has this router setup to do PCC for 1 dynamic ip and 1 static ip. After I restored the backup config I proceeded to test the config by disabled or unplugging on...
by XTLMeth
Sun Jan 10, 2010 9:36 pm
Forum: General
Topic: 2 Dynamic Connections on same subnet.
Replies: 9
Views: 1295

Re: 2 Dynamic Connections on same subnet.

OH man you weren't kidding about messing with routes in winbox that were created from the CLI. After adding a few routes from the CLI then deleting them through winbox they are now stuck in the router. I rebooted the router and the routes that I deleted from winbox came back! So then I tried to dele...
by XTLMeth
Sun Jan 10, 2010 1:25 am
Forum: General
Topic: 2 Dynamic Connections on same subnet.
Replies: 9
Views: 1295

Re: 2 Dynamic Connections on same subnet.

Is it intentionally designed that way for a reason? If not it still seems like a bug or an incomplete feature. It would be nice to be able to modify this with winbox. I find it funny that I say that considering I love CLI based stuff. I still have to put the gateway=ip%interface thing into practice....
by XTLMeth
Sat Jan 09, 2010 6:00 am
Forum: General
Topic: 2 Dynamic Connections on same subnet.
Replies: 9
Views: 1295

Re: 2 Dynamic Connections on same subnet.

Example of what's happening. This is a mikrotik I have in the lab for playing around with. [admin@MikroTik] > ip route add gateway=24.116.80.1%ether1 routing-mark=table3 [admin@MikroTik] > ip route export /ip route add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gatewa...
by XTLMeth
Fri Jan 08, 2010 11:39 pm
Forum: General
Topic: 2 Dynamic Connections on same subnet.
Replies: 9
Views: 1295

Re: 2 Dynamic Connections on same subnet.

I am running version 4.4 on all my devices. I tried the gateway=ip%interface thing but the issue I have is when ever the router is rebooted or the interface is disabled/enabled it goes back to gateway=ip and I have redo the routes. Is there a way to make that stick? If I use just the gateway=modema ...
by XTLMeth
Fri Jan 08, 2010 6:47 pm
Forum: General
Topic: Blocking traffic based on too many attempts
Replies: 7
Views: 1651

Re: Blocking traffic based on too many attempts

add action=accept chain=input comment="SSH to box from everywhere." connection-state=new disabled=no dst-address=216.161.237.201 dst-port=22 in-interface=e1_Wan limit=2/1m,0 protocol=tcp


---->> limit=2/1m

This limits 2 new connection per 60 seconds. Keep scripties from hammering my ssh.
by XTLMeth
Fri Jan 08, 2010 8:20 am
Forum: General
Topic: MikroTik as OpenVPN client
Replies: 17
Views: 6361

Re: MikroTik as OpenVPN client

I like mikrotik a lot but the openvpn is *not* stable and it is hard to get it to work with other openvpn daemons on other platforms. I have 2 mikrotiks with openvpn running. One of them is a server for ten users to vpn to the mikrotik router and the other is a mikrotik router that connects to a lin...
by XTLMeth
Fri Jan 08, 2010 7:45 am
Forum: General
Topic: 2 Dynamic Connections on same subnet.
Replies: 9
Views: 1295

2 Dynamic Connections on same subnet.

So here's a problem I am having. I have 2 cable modems one with a 5mbit limit and one with a 10mbit limit. I have setup PCC with mikrotik before but never with 2 dynamic ips on the same subnet. Modem A: 72.24.169.111/23 with GW of 72.24.168.1 Modem B: 72.24.169.223/23 with GW of 72.24.168.1 LAN: 192...
by XTLMeth
Fri Nov 20, 2009 12:06 am
Forum: General
Topic: Need some help with dst-nat issue.
Replies: 25
Views: 3768

Re: Need some help with dst-nat issue.

You're right I didn't read it all. I jumped the gun on that one guys. Sorry.
by XTLMeth
Thu Nov 19, 2009 8:07 am
Forum: General
Topic: Need some help with dst-nat issue.
Replies: 25
Views: 3768

Re: Need some help with dst-nat issue.

http://forum.mikrotik.com/viewtopic.php?f=2&t=36232&start=0 <--- this was my post where I got it working. The issue for me was I was using PCC to load balance internet from the lan out to the internet and when I was dst-natting from the internet in the routing mark was fine but when the server respo...
by XTLMeth
Thu Nov 19, 2009 7:59 am
Forum: General
Topic: Need some help with dst-nat issue.
Replies: 25
Views: 3768

Re: Need some help with dst-nat issue.

Hey don't let that guy charge you from the above message unless you want it really really bad. :-D I did figure this out with help from this forum in another post and I would be will to help you get it working or send you my config and you may be able to work from that?
by XTLMeth
Mon Nov 09, 2009 9:32 pm
Forum: General
Topic: mangle/route question
Replies: 2
Views: 457

Re: mangle/route question

Good idea. thanks.
by XTLMeth
Sun Nov 08, 2009 9:35 pm
Forum: General
Topic: mangle/route question
Replies: 2
Views: 457

mangle/route question

So I setup PCC with 2 ISPs and it's working great. Each ISP has different bandwidth limits. The cable connection has 5meg down and the DSL has 3meg down. I setup up mangle rules so that each connection stay within it's limit and that is working fine. I now have a new problem though. When I disable o...
by XTLMeth
Fri Nov 06, 2009 9:03 am
Forum: General
Topic: Maximum bandwidth with Quad Core and PCI-E
Replies: 34
Views: 7142

Re: Maximum bandwidth with Quad Core and PCI-E

In short yes. If you are having issues with maxing out your cpu then getting a faster cpu will help you but it may not help you enough. I think you need to look at the bigger picture and that is you need to figure out where you bottlenecks are. It could be one of many things like cpu, memory, mother...
by XTLMeth
Thu Nov 05, 2009 11:53 pm
Forum: General
Topic: Maximum bandwidth with Quad Core and PCI-E
Replies: 34
Views: 7142

Re: Maximum bandwidth with Quad Core and PCI-E

There is nothing wrong with what you have setup however things like which network adapter or which motherboard can make a difference. The OS underneath is linux and unless mikrotik has changed anything in the drivers for performance you're going to find that different cards/drivers will have better ...
by XTLMeth
Thu Nov 05, 2009 11:45 pm
Forum: General
Topic: EoIP security?
Replies: 4
Views: 2678

Re: EoIP security?

BTW gre is protocol number 47 not number 43.
by XTLMeth
Fri Oct 30, 2009 8:52 pm
Forum: General
Topic: Inbound dst-nat with multiple wan interfaces
Replies: 13
Views: 7549

Re: Inbound dst-nat with multiple wan interfaces

Yep that makes sense. That was the link I have been missing the whole time. Thank you for explaining it.
by XTLMeth
Fri Oct 30, 2009 8:27 pm
Forum: General
Topic: Inbound dst-nat with multiple wan interfaces
Replies: 13
Views: 7549

Re: Inbound dst-nat with multiple wan interfaces

If I think I got this right what the no-mark does it prevent the dst-nat return traffic from getting tagged by the PCC rule which causes it to be sent out the wrong interface.
by XTLMeth
Fri Oct 30, 2009 8:23 pm
Forum: General
Topic: Inbound dst-nat with multiple wan interfaces
Replies: 13
Views: 7549

Re: Inbound dst-nat with multiple wan interfaces

Works. I also see what this does. I will keep playing around but I really appreciate your help on this. :-D Many thanks!!!
by XTLMeth
Fri Oct 30, 2009 8:03 pm
Forum: General
Topic: Inbound dst-nat with multiple wan interfaces
Replies: 13
Views: 7549

Re: Inbound dst-nat with multiple wan interfaces

ok so with those 2 forward rules in place 2 things have happened. I can't get to the router from the internet now and it always marks the connections from either interface was wan1_conn so it only works from the 72.24.x.x ip. From the conntrack table ----> 11 S protocol=tcp src-address=199.253.130.1...
by XTLMeth
Fri Oct 30, 2009 7:53 pm
Forum: General
Topic: Inbound dst-nat with multiple wan interfaces
Replies: 13
Views: 7549

Re: Inbound dst-nat with multiple wan interfaces

I added the new mangle rules for the forward table but the other PCC rules are exactly the same as what I have in there already so I didn't change them. I will try this now and see if it works.
by XTLMeth
Fri Oct 30, 2009 6:20 pm
Forum: General
Topic: Inbound dst-nat with multiple wan interfaces
Replies: 13
Views: 7549

Re: Inbound dst-nat with multiple wan interfaces

The mangle rules I have in the firewall at the moment are apart of the tutorial for PCC load balancing but I also need my dst-nat working for both wans. I will try a couple things to today to see if I can get it to work. I think the hardest part is walking through the packet flow and making sure you...
by XTLMeth
Fri Oct 30, 2009 5:05 pm
Forum: General
Topic: Inbound dst-nat with multiple wan interfaces
Replies: 13
Views: 7549

Re: Inbound dst-nat with multiple wan interfaces

OK a little more info. Here's what happening. When I'm comming in wan1 sometimes it's get's marked with wan2 marking instead so obviously the return packets are getting sent out the wrong interface on the reply. So how do I fix this??
by XTLMeth
Fri Oct 30, 2009 4:52 pm
Forum: General
Topic: Inbound dst-nat with multiple wan interfaces
Replies: 13
Views: 7549

Re: Inbound dst-nat with multiple wan interfaces

Do you think you could give me a little example. I'm struggling a little bit. Once I'm in the custom chain I have to mark my connections right?
by XTLMeth
Fri Oct 30, 2009 4:59 am
Forum: General
Topic: Inbound dst-nat with multiple wan interfaces
Replies: 13
Views: 7549

Inbound dst-nat with multiple wan interfaces

OK here goes. I setup PCC with 2 internet connections. wan1 is on ether1 with 72.24.205.34/24 as it's ip wan2 is on ether2 with 216.161.237.204/29 as it's ip lan is on ether5 with 172.16.5.12/22 as it's ip PCC is working great but now I need to get to step 2. I have a server behind the firewall and ...
by XTLMeth
Wed Oct 28, 2009 5:20 pm
Forum: General
Topic: Impossible to block DHCP Server. By design, or bug???
Replies: 36
Views: 11889

Re: Impossible to block DHCP Server. By design, or bug???

I would be careful doing any type of filtering on the bridge. As far as I known it's not stateful.
by XTLMeth
Wed Oct 28, 2009 6:15 am
Forum: General
Topic: Impossible to block DHCP Server. By design, or bug???
Replies: 36
Views: 11889

Re: Impossible to block DHCP Server. By design, or bug???

So I was sitting around watching history channel and I was thinking about this whole issue. The idea is that if the socket is raw and the netfilter rules never see the packets how do we make them see the packets and that when I came up with a pretty cheesy way but it works. typical setup ether1---->...
by XTLMeth
Tue Oct 27, 2009 11:23 pm
Forum: General
Topic: Impossible to block DHCP Server. By design, or bug???
Replies: 36
Views: 11889

Re: Impossible to block DHCP Server. By design, or bug???

This is a linux thing not a mikrotik thing. I have been building fiewalls with linux for a long time and no matter what firewall rules I put in place dhcp still gets through whether it's a client or server on that local firewall.
by XTLMeth
Sun Oct 25, 2009 6:57 am
Forum: General
Topic: IPOD Touch Doesn't Redirect after login
Replies: 3
Views: 761

Re: IPOD Touch Doesn't Redirect after login

I had the same thing happen to me. Check your NATs then filter rules. Make sure DNS is getting through. My issue was my NAT was wrong. I could log in but would sit and not do anything after that. I'm writing this from my ipod touch logged into my mtik hotspot. :)
by XTLMeth
Fri Oct 16, 2009 6:15 am
Forum: General
Topic: OpenVPN ethernet bridge requires an IP? Why?
Replies: 1
Views: 892

Re: OpenVPN ethernet bridge requires an IP? Why?

I have nothing against mikrotik but I would advise you stay away from teh openvpn server. I have it deployed with 10 users and I have to reboot the routerboard every 28 days or so because openvpn just stops working. I have seen this a couple of times with other deployments as well so I know it's not...
by XTLMeth
Fri Oct 09, 2009 9:24 pm
Forum: General
Topic: public IP for PPPoE Clients
Replies: 8
Views: 3095

Re: public IP for PPPoE Clients

Some people call proxy arp pseudo bridging. When you have packet forwarding turned on with proxy arp it's almost like having a layer2 bridge except it's not a true bridge. When your pppoe server hands out an ip to your client user that user is going to try to find the gateway out to the internet but...
by XTLMeth
Mon Sep 14, 2009 3:42 am
Forum: General
Topic: Need some help with dst-nat issue.
Replies: 25
Views: 3768

Re: Need some help with dst-nat issue.

I will give this a try. Thanks.
by XTLMeth
Sun Sep 13, 2009 6:48 pm
Forum: General
Topic: Need some help with dst-nat issue.
Replies: 25
Views: 3768

Re: Need some help with dst-nat issue.

OK I can try that out but is there a little example that someone could give me to get me on track. I have tried and failed for some reason. I only need an example for one wan and I can figure it out from there for the other internet connections.
by XTLMeth
Sat Sep 12, 2009 9:09 pm
Forum: General
Topic: Need some help with dst-nat issue.
Replies: 25
Views: 3768

Re: Need some help with dst-nat issue.

I guess no one has an answer. :(
by XTLMeth
Mon Sep 07, 2009 10:04 am
Forum: General
Topic: Need some help with dst-nat issue.
Replies: 25
Views: 3768

Re: Need some help with dst-nat issue.

this configuration below is very simaler to how my linux firewall is configured right now. It's the closest I could get for mikrotik. /ip address print detail 0 address=172.16.7.254/22 network=172.16.4.0 broadcast=172.16.7.255 interface=br_internal actual-interface=br_internal 1 D address=72.24.182....
by XTLMeth
Mon Sep 07, 2009 9:49 am
Forum: General
Topic: Need some help with dst-nat issue.
Replies: 25
Views: 3768

Re: Need some help with dst-nat issue.

So here is what is configured at the moment. This is my initial attempt. /ip address print detail 0 address=172.16.7.254/22 network=172.16.4.0 broadcast=172.16.7.255 interface=br_internal actual-interface=br_internal 1 D address=72.24.182.205/24 network=72.24.182.0 broadcast=72.24.182.255 interface=...
by XTLMeth
Mon Sep 07, 2009 7:49 am
Forum: General
Topic: openvpn 3.27
Replies: 5
Views: 1640

Re: openvpn 3.27

I had a similar issue with an openvpn server with 10 users. The server worked for 24-48hour periods then it would just stop. I found that if I went into winbox and disabled the server then re-enabled it everything started working again. I believe it's due to a memory leak or some other issue. I have...
by XTLMeth
Mon Sep 07, 2009 7:35 am
Forum: General
Topic: Need some help with dst-nat issue.
Replies: 25
Views: 3768

Need some help with dst-nat issue.

I need to know how to do dst-nat from multi-wan to servers behind the firewall. I have this working with generic linux but for some reason I can't get it to work in mikrotik. The ips have been changed for this example but it gives you the idea. example: wan1 ips: 69.164.219.25/24 35.2.245.2/25 35.2....