Community discussions

Search found 99 matches

by oreggin
Fri Aug 30, 2019 2:54 pm
Forum: General
Topic: Multiple Road Warrior L2TP/IPsec clients behind NAT - solved
Replies: 59
Views: 15004

Re: Multiple Road Warrior L2TP/IPsec clients behind NAT - solved

Meanwhile I tested a script for update ipsec policy behind NAT: :global uplinkif "ether1" :global poladdr [ /ip ipsec policy get [ find peer=HUB ] src-address ] :global polip [:pick $poladdr 0 [:find $poladdr "/"]] :global intaddr [ /ip address get [ find interface=$uplinkif and dynamic ] address ] ...
by oreggin
Tue Jun 25, 2019 7:40 am
Forum: General
Topic: IPsec Hardware acceleration on CHR?
Replies: 9
Views: 1975

Re: IPsec Hardware acceleration on CHR?

Same here, KVM with host CPU which has AES-NI flag.
Is there any solution?
by oreggin
Wed Jun 12, 2019 11:47 am
Forum: General
Topic: v6 RC and v7 BETA
Replies: 126
Views: 24534

Re: v6 RC and v7 BETA

I configured IPSec on one of my RoS devs, and that said don't configure base mode because it will removed in RoSv7 so something is cooking in the owen and i hope it wont burned up :)
by oreggin
Wed May 22, 2019 3:05 pm
Forum: General
Topic: Multiple Road Warrior L2TP/IPsec clients behind NAT - solved
Replies: 59
Views: 15004

Re: Multiple Road Warrior L2TP/IPsec clients behind NAT - solved

Off topic, what is your native language if I may ask?
Sure, my native lang is hungarian. I hope my english is not too wrong and you understand what I'd like to say. BTW we using worse, strange, mixed language in business that you shouldn't see/hear :-D
by oreggin
Wed May 22, 2019 1:33 pm
Forum: General
Topic: Multiple Road Warrior L2TP/IPsec clients behind NAT - solved
Replies: 59
Views: 15004

Re: Multiple Road Warrior L2TP/IPsec clients behind NAT - solved

Meanwhile I switched the cabelmodem to bridge mode for testing so now the spoke has public IP, but I will switch it back as cabelmodem in this mode has a reduced feature set. Another thing I tried is a static policy on spoke with UDP:1701:1701 and tunnel mode, under identity "generate-policy=none", ...
by oreggin
Tue May 21, 2019 5:12 pm
Forum: General
Topic: Multiple Road Warrior L2TP/IPsec clients behind NAT - solved
Replies: 59
Views: 15004

Re: Multiple Road Warrior L2TP/IPsec clients behind NAT - solved

Cisco have their own protocol for that (DMVPN).
Yes, high-end vendors has mGRE+NHRP based DMVPN which is good but not scalable above some thousands of tunnels and it is off topic over here.
by oreggin
Tue May 21, 2019 4:31 pm
Forum: General
Topic: Multiple Road Warrior L2TP/IPsec clients behind NAT - solved
Replies: 59
Views: 15004

Re: Multiple Road Warrior L2TP/IPsec clients behind NAT - solved

Now it comes into my mind I tried this HUB setup with cisco CPE and when it is connects to HUB it somehow generating tunnel mode policy but I can't figured out how did it do that :(
by oreggin
Tue May 21, 2019 11:43 am
Forum: General
Topic: Multiple Road Warrior L2TP/IPsec clients behind NAT - solved
Replies: 59
Views: 15004

Re: Multiple Road Warrior L2TP/IPsec clients behind NAT - solved

We have only one spoke behind every branch's ISP modem which are the NAT GWs, but spokes behind NAT with this configuration does not work. There is no need any trick to supports more spoke behind the same NAT GW. We need a trick to build tunnel mode (instead of transport mode) dynamic tunnels to wor...
by oreggin
Mon May 20, 2019 7:14 pm
Forum: General
Topic: Multiple Road Warrior L2TP/IPsec clients behind NAT - solved
Replies: 59
Views: 15004

Re: Multiple Road Warrior L2TP/IPsec clients behind NAT - solved

Here are my anonymised configs and print outputs: [oreggin@HUB] > ip ipsec export verbose # may/20/2019 17:52:51 by RouterOS 6.44.3 # software id = XXXX-XXXX # # model = XXX # serial number = XXXXXXXXXXXX /ip ipsec mode-config set [ find default=yes ] name=request-only responder=no /ip ipsec policy ...
by oreggin
Mon May 20, 2019 4:40 pm
Forum: General
Topic: Multiple Road Warrior L2TP/IPsec clients behind NAT - solved
Replies: 59
Views: 15004

Re: Multiple Road Warrior L2TP/IPsec clients behind NAT - solved

Thanks for deep explanations, good to learn something new every day. BTW your conclusion is not exactly right as our L2TP tunnels are encrypted, I checked it. Dynamic policies generated on HUB and spokes and SA counters increasing with the amount of trasmitted bytes. I don't say that I 100% understa...
by oreggin
Mon May 20, 2019 3:11 pm
Forum: General
Topic: Multiple Road Warrior L2TP/IPsec clients behind NAT - solved
Replies: 59
Views: 15004

Re: Multiple Road Warrior L2TP/IPsec clients behind NAT - solved

I didn't mentioned IPSec is the outer and L2TP is inside of it. In the reverse situation the result performance is terrible. Now I have dynamic policies on both end and it works if peers are not behind NAT. I'm not an IPSec expert, so do you say I need set static policy on spokes? On spokes because ...
by oreggin
Mon May 20, 2019 1:41 pm
Forum: General
Topic: Multiple Road Warrior L2TP/IPsec clients behind NAT - solved
Replies: 59
Views: 15004

Re: Multiple Road Warrior L2TP/IPsec clients behind NAT - solved

Under "/interface l2tp-client" I set "use-ipsec=no" as if I'm right it supports only PSK based auth. I configured dynamic policies under "/ip ipsec": /ip ipsec peer set 0 exchange-mode=ike2 /ip ipsec identity set 0 auth-method=rsa-signature generate-policy=port-override Unfortunately I didn't found ...
by oreggin
Mon May 20, 2019 12:52 pm
Forum: General
Topic: Multiple Road Warrior L2TP/IPsec clients behind NAT - solved
Replies: 59
Views: 15004

Re: Multiple Road Warrior L2TP/IPsec clients behind NAT - solved

How can I request tunnel mode, if both side has dynamic policies? I can't find this option in RoS :(
I using BGP inside L2TP to distribute (IPv4+IPv6) routes between hubs and spoke, so i think i can't drop L2TP, or can I? How?
Oh, and I missed the MPLS part inside the L2TP.
by oreggin
Fri May 17, 2019 9:10 pm
Forum: General
Topic: Multiple Road Warrior L2TP/IPsec clients behind NAT - solved
Replies: 59
Views: 15004

Re: Multiple Road Warrior L2TP/IPsec clients behind NAT - solved

Hi! I build a hub and spokes IKEv2/rsa signature auth with L2TP over IPSec setup with Tik deivces. There is one central HUB with static public address, and there are some spokes, one of them have a dynamic public address, and the other is behind NAT where NAT public address is dynamic as well. Publi...
by oreggin
Tue Apr 09, 2019 4:56 pm
Forum: General
Topic: v6 RC and v7 BETA
Replies: 126
Views: 24534

Re: v6 RC and v7 BETA

MikroTik's plan is to release RouterOS v7 :)

"Probably this year" ™
Are you sure?! :lol:
by oreggin
Tue Apr 09, 2019 3:11 pm
Forum: General
Topic: v6 RC and v7 BETA
Replies: 126
Views: 24534

Re: v6 RC and v7 BETA

Nah, please public a roadmap with public informations in a correct way. Under correct I mean correct for MTik and correct for customers too.
If I working on something my boss insist plans :) Please tell us MTik plans about RouterOS development.
by oreggin
Sat Apr 06, 2019 4:04 pm
Forum: General
Topic: v6 RC and v7 BETA
Replies: 126
Views: 24534

Re: v6 RC and v7 BETA

All I can say is that development of v7 has picked up in the last few months, more than ever. While I can't promise anything stable, it is pretty safe to say, that some kind of public test release (like beta for specific platforms) could be expected this year. The chances of that happening are now ...
by oreggin
Wed Jan 23, 2019 5:24 pm
Forum: General
Topic: v6 RC and v7 BETA
Replies: 126
Views: 24534

Re: v6 RC and v7 BETA

What is the timeline? if there is no cut-off date then it's just proof of concept for developers. Alpha is exactly that - proof of concept (in a lot of ways) They continue to work on 6.x, but 7 being a new kernel and everything means they have to make sure all existing functionality from 6.x is imp...
by oreggin
Wed Jan 23, 2019 5:18 pm
Forum: General
Topic: v6 RC and v7 BETA
Replies: 126
Views: 24534

Re: v6 RC and v7 BETA

And hopefully some new ARM64-based hardware as CCR replacement. Indeed. The CCR-line is a key product for many customers. It would be very welcomed with an refreshed version with similar number/type of interfaces. There is no need to replace the hardware if MT upgrade to the latest Linux kernel whi...
by oreggin
Mon Nov 26, 2018 2:31 pm
Forum: General
Topic: v6 RC and v7 BETA
Replies: 126
Views: 24534

Re: v6 RC and v7 BETA

I think, the first and most important step is to finish kernel transplantation at least RC state and this should has more and more priority over RoS v6.x train. After this can slowly dropping v6 and fix v7 bugs and implement the new features as a transition. I hope MT switch to the most recent LTS k...
by oreggin
Fri Nov 16, 2018 7:16 pm
Forum: General
Topic: v6 RC and v7 BETA
Replies: 126
Views: 24534

Re: v6 RC and v7 BETA

Too big silence...Santa brings some wanted surprise? :-)
by oreggin
Mon Nov 05, 2018 5:10 pm
Forum: General
Topic: v6 RC and v7 BETA
Replies: 126
Views: 24534

Re: v6 RC and v7 BETA

V7 beta seems to be already in development. You can see mrz's post:

http://forum.mikrotik.com/viewtopic.php?t=130551

Seems to be v7beta running on Virtualbox.
Then mrz has a unicorn :)
When exactly we have one too? A bugpile is better than nothing... :)
by oreggin
Fri Jul 13, 2018 11:49 am
Forum: Wireless Networking
Topic: CAPsMAN + local forwarding CAP + SSID/Vlan? [SOLVED]
Replies: 11
Views: 2180

Re: CAPsMAN + local forwarding CAP + SSID/Vlan? [SOLVED]

Thanks to all! So, the solution is disabling vlan-filtering on the CAP's bridge and then voilà! CAP drops selected SSID to its vlan what I set in CAPsMAN, so now CAPsMAN controlling the CAPs Vlan selection based on SSID. If I enabling vlan-filtering, this method is not works! As this is not a proble...
by oreggin
Thu Jul 12, 2018 12:54 pm
Forum: Wireless Networking
Topic: CAPsMAN + local forwarding CAP + SSID/Vlan? [SOLVED]
Replies: 11
Views: 2180

Re: CAPsMAN + local forwarding CAP + SSID/Vlan? [SOLVED]

Yes, this can be done in datapath. I jumped on the "do it manually per interface" train b/c you said that vlans differ from site to site for the same ssid... And this can only be done by hand ;-) I can configure as many datapath/configuration as I need and then assign it to provision and I can sepa...
by oreggin
Thu Jul 12, 2018 12:40 pm
Forum: Wireless Networking
Topic: CAPsMAN + local forwarding CAP + SSID/Vlan? [SOLVED]
Replies: 11
Views: 2180

Re: CAPsMAN + local forwarding CAP + SSID/Vlan? [SOLVED]

Thanks, but the topic started at somewhere "can capsman assign vlan to SSID on CAP instead of configuring it on every CAP by hand?" At the moment I assign vlans on CAP to SSID by hand.

Kind regards,
oreggin
by oreggin
Wed Jul 11, 2018 5:20 pm
Forum: Wireless Networking
Topic: CAPsMAN + local forwarding CAP + SSID/Vlan? [SOLVED]
Replies: 11
Views: 2180

Re: CAPsMAN + local forwarding CAP + SSID/Vlan? [SOLVED]

For using local forwarding, your CAP devices must have a bridge configured with ethernet and wlan interfaces in them. Then you set in cap settings bridge=<yourbridge> -Chris I did it: [oreggin@ap11] > interface bridge print Flags: X - disabled, R - running 0 R name="LAN" mtu=auto actual-mtu=1500 l2...
by oreggin
Wed Jul 11, 2018 4:04 pm
Forum: Wireless Networking
Topic: CAPsMAN + local forwarding CAP + SSID/Vlan? [SOLVED]
Replies: 11
Views: 2180

Re: CAPsMAN + local forwarding CAP + SSID/Vlan? [SOLVED]

You can edit this in the corresponding CAP interface under datapath. select vlan-mode = tag and then set the corresponding vlan id. A bit cumbersome, but it works. -Chris I tried it but it didn't work for me in local-forwarding mode. How to configure the CAP in this case? Now it has a bridge in MST...
by oreggin
Wed Jul 11, 2018 11:31 am
Forum: Wireless Networking
Topic: CAPsMAN + local forwarding CAP + SSID/Vlan? [SOLVED]
Replies: 11
Views: 2180

CAPsMAN + local forwarding CAP + SSID/Vlan? [SOLVED]

Hi! I found some topic under this issue but there is no clear to me if it would be possible to capsman assign vlan to ssid in local-forwarding mode where vlans specified on CAP device and not on capsman. I have a capsman device and caps devices in hub&spoke topology. CAPs are on some sites, and each...
by oreggin
Tue Jul 03, 2018 3:02 pm
Forum: General
Topic: RB1100AHx2 bridge HW-offload issue [SOLVED]
Replies: 4
Views: 629

Re: RB1100AHx2 bridge HW-offload issue [SOLVED]

Dear Samot, Thanks for your answer but I think you totally misunderstand me. I didn't wrote that there would need another page. Instead it would be clearer if it is more sectioned and not mixing switching/bridging/L3Interface configs around pre-v6.41 and post-v6.41. In the past I used pre-v6.41 with...
by oreggin
Tue Jul 03, 2018 2:00 pm
Forum: General
Topic: RB1100AHx2 bridge HW-offload issue [SOLVED]
Replies: 4
Views: 629

Re: RB1100AHx2 bridge HW-offload issue [SOLVED]

Hi CZFan! Thanks for pointing on that page. I read many times that wiki but all the times many inline "pre-v6.41", and "post-v6.41" are totally confused me, but I think I harvested the essence and now it works. As it depends on architecture, on RB1100AHx2 between ether1-5 and ether6-10 in the same v...
by oreggin
Fri Jun 29, 2018 3:26 pm
Forum: General
Topic: RB1100AHx2 bridge HW-offload issue [SOLVED]
Replies: 4
Views: 629

RB1100AHx2 bridge HW-offload issue [SOLVED]

Hi! I have an RB1100AHX2 and I would like to use it as desktop switch with hw-offload to save CPU. It works fine with vlan filtering but it disables hw-offload on all bridge port. If I disable vlan filtering (RSTP or none) then hw-offloading automatically enabled on all ports but forwarding not work...
by oreggin
Tue Dec 20, 2016 11:36 am
Forum: RouterBOARD hardware
Topic: RB450G upgrade failed with ROS 4.1 from 3.30
Replies: 38
Views: 8712

Re: RB450G upgrade failed with ROS 4.1 from 3.30

Hehe, I written many times "netinstall doesn't work without 'Clients for Microsoft Networks' option" and comes answares: "disable your firewall" LOL :D
by oreggin
Tue Dec 20, 2016 11:26 am
Forum: General
Topic: IPv6 stateless autoconfiguration, can ROS get autoconfed?
Replies: 9
Views: 5254

Re: IPv6 stateless autoconfiguration, can ROS get autoconfed?

What about this? I can't use SLAAC however I disabled IPv6 forwarding. I tried on RoS ver 6.37.3 So my box is only router(board) in its name but not in its functionality as ipv6 forwarding disabled so it is a host device. So please make it possible to can get IPv6 address with SLAAC. This would be g...
by oreggin
Wed Jul 29, 2015 10:46 pm
Forum: General
Topic: Slow VPN tunnels (SSL, PPTP, L2TP)
Replies: 40
Views: 44341

Re: Slow VPN tunnels (SSL, PPTP, L2TP)

I found this topic and I would like to correct me. L2TP client MTU/MRU is 1460 if uplink MTU is 1500byte. This because L2TP uses UDP encapsulation (UDP port 1701). IPv4 + UDP header = 20+20 = 40 byte. 1500-40=1460. With these options I can reach almost the maximum speed of the router capability @ 10...
by oreggin
Sat Jul 11, 2015 12:59 pm
Forum: General
Topic: Feature Request: PEAP-MSCHAPv2 in station mode
Replies: 6
Views: 2109

Feature Request: PEAP-MSCHAPv2 in station mode

Hi! I hope I write this to the right place. If not please excuse me. UPC Wi-Free service is getting more widespreading so it would be nice if we can use our routerboards running RoS on it as a wireless client to connect to UPC Wi-Free and share it among our PCs and Laptops. It is works with EAP-PEAP...
by oreggin
Sat Jul 11, 2015 12:50 pm
Forum: Wireless Networking
Topic: PEAP mschapv2 auth in station mode?
Replies: 18
Views: 6585

Re: PEAP mschapv2 auth in station mode?

Hi!

I faced the same problem. I can't use my RB433AH to connect UPC Wi-Free as a station, to share it for my PC and Laptop. UPC Wi-Free is getting more widespread, so it will be appreciated to implement PEAP-MSCHAPv2 in RoS.

Cheers,
oreggin
by oreggin
Thu Apr 30, 2015 1:20 am
Forum: RouterBOARD hardware
Topic: RB1100AHx2 FAN question
Replies: 0
Views: 595

RB1100AHx2 FAN question

Hi folks, I have a RB1100AHx2 and it has two fans, main + aux. At the same time only one FAN operating and I can choose between them. It has a really annoying noise :-) Can I chose an option to spin up both fans at half RPM but the same airflow and when one of them fault then the other doubling the ...
by oreggin
Mon Apr 20, 2015 9:25 pm
Forum: General
Topic: Feature Request: Hardware NAT
Replies: 18
Views: 7130

Re: Feature Request: Hardware NAT

http://www.taifatech.com/files/TF470_Product_Brief_02.pdf http://www.taifatech.com/files/TF480-Product-Brief-04-08.pdf Something like these? It is enough for 100M uplink. But if we need 1G or 10GE wire-speed NAT then we need something like this + TCAM + design + garnish: http://www.marvell.com/netw...
by oreggin
Wed Jan 28, 2015 11:55 pm
Forum: RouterBOARD hardware
Topic: CRS226
Replies: 33
Views: 10350

Re: CRS226

If i'm right, CRS is a Layer2 ASIC with CPU Layer3 support. So it can't NAT or routing in ASIC but in CPU?
Do you plan make real Layer3 switches? I mean what can does simple routing or NAT functions with TCAM or similar.
by oreggin
Wed Oct 01, 2014 12:01 pm
Forum: General
Topic: DNSSEC
Replies: 33
Views: 10329

Re: DNSSEC

+1 for feature request
by oreggin
Sat Oct 19, 2013 2:17 pm
Forum: General
Topic: IPv6 ping - "no route to host"
Replies: 7
Views: 4381

Re: IPv6 ping - "no route to host"

Did you all mentioned it to MT support?
by oreggin
Sun Oct 13, 2013 2:15 pm
Forum: General
Topic: IPv6 ping - "no route to host"
Replies: 7
Views: 4381

Re: IPv6 ping - "no route to host"

Reboot can resolve it temporarily but after a random time the router lost again their routes to own connected neigbours. It can only reach itself. Really very strange thing. It would be appreciated if someone from MT could tells something if they knows this issue and working on it or not.
by oreggin
Sun Oct 13, 2013 2:06 pm
Forum: General
Topic: IPv6 ping - "no route to host"
Replies: 7
Views: 4381

Re: IPv6 ping - "no route to host"

Same problem here. I wrote it to support for months ago, I asked they multiple times if this is a known bug or not but no answare comes back.
by oreggin
Sat Oct 12, 2013 4:42 pm
Forum: General
Topic: Slow VPN tunnels (SSL, PPTP, L2TP)
Replies: 40
Views: 44341

Re: Slow VPN tunnels (SSL, PPTP, L2TP)

Same problem here. I have a 120/10 connection, and I can only using 12-13Mbps over it with NAT on L2TP /wo compression and encryption on my RB450G: [oreggin@RB450G] > /interface monitor ether1 name: ether1 rx-packets-per-second: 2 020 rx-drops-per-second: 0 rx-errors-per-second: 0 rx-bits-per-second...
by oreggin
Wed Jul 04, 2012 2:50 pm
Forum: General
Topic: DHCPv6 client doesn't create pool at startup
Replies: 2
Views: 742

Re: DHCPv6 client doesn't create pool at startup

I think this happens because the Pool gets created and then the time gets set using ntp

I have reported this as a bug
Nick.
Me too :)
Thanks.

oreggin
by oreggin
Mon Jul 02, 2012 2:17 pm
Forum: General
Topic: DHCPv6 client doesn't create pool at startup
Replies: 2
Views: 742

DHCPv6 client doesn't create pool at startup

Hi, I testing an RB450G with RoS 5.18 on DSL and IPv6. While I configured dhcpv6 client on the router and it works but as soon as I reboot the router or turn on then dhcpv6 client doesn't make ipv6 pool: [admin@rtr.test] > /interface ethernet print Flags: X - disabled, R - running, S - slave # NAME ...
by oreggin
Mon Jul 02, 2012 10:42 am
Forum: General
Topic: /31 point to point Ethernet links not working
Replies: 4
Views: 1075

Re: /31 point to point Ethernet links not working

This is a duplicated topic:
http://forum.mikrotik.com/viewtopic.php?f=2&t=63255

@mrz: do you have any information when will be supported RFC3021 in Linux/RoS on ethernet?
by oreggin
Sun Jul 01, 2012 2:44 pm
Forum: General
Topic: /31 not useable on Mikrotik
Replies: 8
Views: 1533

Re: /31 not useable on Mikrotik

Thus the smallest functional subnetting on an interface would be /30. And nothing is broken, just working as expected.
/31 doesn't brake too. Please see RFC3021.
by oreggin
Sun Jul 01, 2012 12:43 pm
Forum: General
Topic: /31 not useable on Mikrotik
Replies: 8
Views: 1533

Re: /31 not useable on Mikrotik

Ok, but what if I need to work with non-MT/RoS devices like cisco?
by oreggin
Sat Jun 30, 2012 11:20 pm
Forum: General
Topic: /31 not useable on Mikrotik
Replies: 8
Views: 1533

Re: /31 not useable on Mikrotik

You can do /31 on Mikrotik.

Set interface to 10.99.99.1/32 and set broadcast to the remote end e.g. 10.99.99.2 do the opposite on the remote end.
It is not clear to me. Can you please give us a config example?

Thanks,
oreggin
by oreggin
Sat Jun 30, 2012 11:05 pm
Forum: General
Topic: /31 not useable on Mikrotik
Replies: 8
Views: 1533

Re: /31 not useable on Mikrotik

Same thing here, but I don't forcing this because I can live with /30s and IPv6 is coming and knocking on the window :-)
by oreggin
Sat Jun 30, 2012 12:06 pm
Forum: General
Topic: Bridge and IPv6 address unreachable
Replies: 0
Views: 566

Bridge and IPv6 address unreachable

Hi, I testing an RB450G /w RoS 5.18. I configured a bridge interface as a loopback and it seems to if i configure IPv6 address on bridge then that address can't be reachable: [admin@MikroTik] > /interface bridge print Flags: X - disabled, R - running 0 R name="loopback0" mtu=1500 l2mtu=65535 arp=ena...
by oreggin
Sat Jun 30, 2012 11:49 am
Forum: Forwarding Protocols
Topic: BGP - RoS sends bad auth after success auth?
Replies: 0
Views: 1142

BGP - RoS sends bad auth after success auth?

Hi, I testing an RB450G interoperability on our cisco based network and i see exactly six times "Invalid MD5 digest" messages on our cisco router log after every RB450G (re)boot and after it successfully authenticated the BGP session: LC/0/0/CPU0:Jun 30 10:18:30.139 MET_DST: ifmgr[186]: %PKT_INFRA-L...
by oreggin
Mon Feb 06, 2012 9:57 pm
Forum: Forwarding Protocols
Topic: Cisco 1800 series / DMVPN / connect MikroTik RB750 as client
Replies: 9
Views: 8837

Re: Cisco 1800 series / DMVPN / connect MikroTik RB750 as cl

Moreover GRE tunnel interface doesn't have IPv6 link-local address and I can't set up link-local address on GRE tunnel interface so I can't use DHCPv6 on it.
by oreggin
Mon Feb 06, 2012 9:45 pm
Forum: Forwarding Protocols
Topic: Cisco 1800 series / DMVPN / connect MikroTik RB750 as client
Replies: 9
Views: 8837

Re: Cisco 1800 series / DMVPN / connect MikroTik RB750 as cl

When will be approx. supported multipont GRE and/or NHRP in RoS? Where are these features on the roadmap?
by oreggin
Wed Apr 13, 2011 11:02 am
Forum: General
Topic: v5.1 hangs in /export
Replies: 28
Views: 5344

Re: v5.1 hangs in /export

I can't generate supout.rif :(
I was tried over SSH and serial console...
by oreggin
Tue Apr 12, 2011 3:51 pm
Forum: General
Topic: v5.1 hangs in /export
Replies: 28
Views: 5344

Re: v5.1 hangs in /export

oreggin and nz_monkey, please contact support with support output file from the router.
Ok, I will send e-mail to support soon.
by oreggin
Tue Apr 12, 2011 11:19 am
Forum: General
Topic: v5.1 hangs in /export
Replies: 28
Views: 5344

Re: v5.1 hangs in /export

I can't generate supout.rif but I will try again today...
by oreggin
Tue Apr 12, 2011 12:26 am
Forum: General
Topic: v5.1 hangs in /export
Replies: 28
Views: 5344

Re: v5.1 hangs in /export

I started the sup-output process for 2 hours. I hope it will finish till I should go to work...
It's still running...
by oreggin
Mon Apr 11, 2011 10:39 pm
Forum: General
Topic: v5.1 hangs in /export
Replies: 28
Views: 5344

Re: v5.1 hangs in /export

I started the sup-output process for 2 hours. I hope it will finish till I should go to work...
by oreggin
Sat Apr 09, 2011 9:52 pm
Forum: General
Topic: v5.1 hangs in /export
Replies: 28
Views: 5344

v5.1 hangs in /export

Hi, I have two routerboard. RB433AH and RG450G. Both hangs when I issue the /export or /interface export command: [admin@RB433AH] > /interface export # jan/02/1970 07:36:19 by RouterOS 5.1 # software id = XXXX-XXXX # /interface ethernet set 0 arp=enabled auto-negotiation=yes disabled=no full-duplex=...
by oreggin
Sun Sep 26, 2010 8:31 pm
Forum: RouterBOARD hardware
Topic: Per interface traffic shaping
Replies: 13
Views: 6849

Re: Per interface traffic shaping

Any idea?
by oreggin
Thu Sep 23, 2010 8:16 pm
Forum: RouterBOARD hardware
Topic: OpenWRT for Routerboard
Replies: 30
Views: 8451

Re: OpenWRT for Routerboard

Visit the OpenWRT site and check what boards are supported...
by oreggin
Thu Sep 23, 2010 8:04 pm
Forum: RouterBOARD hardware
Topic: Dead RB750 after upgrade to ROS5.0 rc1 ?
Replies: 2
Views: 1021

Re: Dead RB750 after upgrade to ROS5.0 rc1 ?

Did you see what happens in console?
by oreggin
Wed Sep 22, 2010 8:59 pm
Forum: RouterBOARD hardware
Topic: RB800 don't stop beeping
Replies: 6
Views: 1462

Re: RB800 don't stop beeping

It's only file you can upload to the router via serial port - *.fwf but can't use it for reinstall ROS
Ok, so it was uploaded through the serial line, not TFTP.

eth1's LEDs doesn't emit any light?
by oreggin
Wed Sep 22, 2010 8:18 pm
Forum: RouterBOARD hardware
Topic: RB800 don't stop beeping
Replies: 6
Views: 1462

Re: RB800 don't stop beeping

I can't because eth1 is broken and it's impossible do netinstall over other 2 ethernet ports...
Then how did you change the firmware?
by oreggin
Wed Sep 22, 2010 7:54 pm
Forum: RouterBOARD hardware
Topic: RB800 don't stop beeping
Replies: 6
Views: 1462

Re: RB800 don't stop beeping

Did you try format flash and reinstall ROS with netinstall from windows?
by oreggin
Wed Sep 22, 2010 3:42 pm
Forum: RouterBOARD hardware
Topic: Per interface traffic shaping
Replies: 13
Views: 6849

Re: Per interface traffic shaping

Sure. Put a queue tree rule as follows: /queue tree add name="ether2" parent=ether2 limit-at=2000000 priority=8 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s Shouldn't it actually be "max-limit"? limit-at should be empty in this case This queue is doesn't any effect with this setting: a...
by oreggin
Wed Sep 22, 2010 3:27 pm
Forum: RouterBOARD hardware
Topic: Per interface traffic shaping
Replies: 13
Views: 6849

Re: Per interface traffic shaping

I have a RB433AH with an 11n wireless miniPCI card and use 5.0rc1 ROS. If I enable any queue on wlan1 (which isn't member port of bridge1), on the ether2 and ether3 port (which are member ports of bridge1) DNS resolving is slow (~5000msec). If I disable the queue DNS resolving is fast again ~50-100m...
by oreggin
Mon Sep 13, 2010 6:44 pm
Forum: RouterBOARD hardware
Topic: Per interface traffic shaping
Replies: 13
Views: 6849

Re: Per interface traffic shaping

Sorry, I forgot: It was tested on ROS v5beta6
by oreggin
Sat Sep 11, 2010 3:13 pm
Forum: RouterBOARD hardware
Topic: Per interface traffic shaping
Replies: 13
Views: 6849

Re: Per interface traffic shaping

This isn't working on wlan1 interface for example, but works on bridge1.
by oreggin
Tue Jun 29, 2010 12:12 am
Forum: General
Topic: Feature request: convert decimal to hexadecimal format
Replies: 5
Views: 1732

Re: Feature request: convert decimal to hexadecimal format

I'd also like to have :tohex, it was just if you really needed some solution (even if not elegant) right now without waiting. :)
I had already integrated into my script, works fine :)
by oreggin
Sat Jun 26, 2010 12:53 am
Forum: General
Topic: Feature request: convert decimal to hexadecimal format
Replies: 5
Views: 1732

Re: Feature request: convert decimal to hexadecimal format

Ehh, nice work but while this script part is 25 lines long then this should be 1 line ":tohex" for example...
Nahh, ok then 5 lines with kindness :)
by oreggin
Fri Jun 25, 2010 7:47 pm
Forum: General
Topic: Feature request: convert decimal to hexadecimal format
Replies: 5
Views: 1732

Re: Feature request: convert decimal to hexadecimal format

Ehh, nice work but while this script part is 25 lines long then this should be 1 line ":tohex" for example...
I hope your work will provide inspiration to ROS developer too :)
by oreggin
Fri Jun 25, 2010 12:21 am
Forum: General
Topic: Feature request: convert decimal to hexadecimal format
Replies: 5
Views: 1732

Feature request: convert decimal to hexadecimal format

http://wiki.mikrotik.com/wiki/Manual:IPv6_Overview#6to4_.286in4.29_tunnels Link above describe howto set up an 6to4 relay on ROS but one thing is missing: Now you need to add a IPv6 address to the tunnel interface. The address should be in form "2002 + <IPv4 address in hex> + <custom id>" . A bash ...
by oreggin
Wed Jun 23, 2010 8:19 pm
Forum: Scripting
Topic: Howto convert numbers from dec to hex?
Replies: 1
Views: 785

Re: Howto convert numbers from dec to hex?

Any comment from Mikrotik team?

Converting from decimal to hexadecimal format completely missing from scripting toolset?
by oreggin
Thu Jun 17, 2010 8:35 pm
Forum: Scripting
Topic: Howto convert numbers from dec to hex?
Replies: 1
Views: 785

Howto convert numbers from dec to hex?

Hy, As my ISP doesn't support native IPv6 so I use 6to4 relay. To this I need to configure the following in the router where "1.2.3.4" is my current WAN IP: /interface 6to4 add disabled=no local-address=1.2.3.4 mtu=1472 name=6to4 remote-address=192.88.99.1 /ipv6 address add address=2002:0102:0304::1...
by oreggin
Fri Dec 18, 2009 4:34 pm
Forum: RouterBOARD hardware
Topic: Per interface traffic shaping
Replies: 13
Views: 6849

Re: Per interface traffic shaping

THX, I will try.
by oreggin
Mon Nov 30, 2009 6:32 pm
Forum: RouterBOARD hardware
Topic: RB450G upgrade failed with ROS 4.1 from 3.30
Replies: 38
Views: 8712

Re: RB450G upgrade failed with ROS 4.1 from 3.30

works for me on win7 on multiple computers. Check your settings.

Scott
Which version of Win7 do U using? I'll be check settings...
by oreggin
Mon Nov 30, 2009 5:27 pm
Forum: RouterBOARD hardware
Topic: RB450G upgrade failed with ROS 4.1 from 3.30
Replies: 38
Views: 8712

Re: RB450G upgrade failed with ROS 4.1 from 3.30

Netinstall also doesn't work on Windows 7 with default windows install config.
It produce the same thing like on WinXP without "Clients for Microsoft Networks" module :/
by oreggin
Mon Nov 30, 2009 5:18 pm
Forum: General
Topic: Wish: RB1000 more ports, SFP-Ports
Replies: 24
Views: 3397

Re: Wish: RB1000 more ports, SFP-Ports

PoweRouters do not have 10G ports, and they don't have the power to actually pump 10Gbit.. Maybe the 8-core version of the 2000 series PoweRouter does, but they do not actually provide any performance figures for that - and they don't offer 10G cards. Does anyone know which 10GbE Chipsets actually ...
by oreggin
Mon Nov 30, 2009 4:03 pm
Forum: General
Topic: Wish: RB1000 more ports, SFP-Ports
Replies: 24
Views: 3397

Re: Wish: RB1000 more ports, SFP-Ports

PoweRouters do not have 10G ports, and they don't have the power to actually pump 10Gbit.. Maybe the 8-core version of the 2000 series PoweRouter does, but they do not actually provide any performance figures for that - and they don't offer 10G cards. Does anyone know which 10GbE Chipsets actually ...
by oreggin
Thu Nov 26, 2009 2:02 pm
Forum: RouterBOARD hardware
Topic: Per interface traffic shaping
Replies: 13
Views: 6849

Per interface traffic shaping

Hi,

I have an RB450G and I would like to shape on LAN interfaces without MAC or IP address.
For example shape the whole traffic of ether3 interface to 2Mbps/4Mbps up/down.
It is possible? It could work?

Thx,
oreggin
by oreggin
Sat Nov 07, 2009 7:43 pm
Forum: RouterBOARD hardware
Topic: RB450G upgrade failed with ROS 4.1 from 3.30
Replies: 38
Views: 8712

Re: RB450G upgrade failed with ROS 4.1 from 3.30

I figured out what was the problemwhen I failed with Netinstall.
If I remove "Client for Microsoft Networks" from network settings then the Netinstall won't work.
Normis, U can test it it is possible!
by oreggin
Tue Nov 03, 2009 8:12 pm
Forum: RouterBOARD hardware
Topic: RB450G upgrade failed with ROS 4.1 from 3.30
Replies: 38
Views: 8712

Re: RB450G upgrade failed with ROS 4.1 from 3.30

I can't believe. On virgin WinXP installation Netinstall works at first time. Netinstall doesn't like me :)
Normis or anybody do you know any (experimental) settings on Windows that congest netinstall procedure?
by oreggin
Mon Nov 02, 2009 11:18 am
Forum: RouterBOARD hardware
Topic: RB450G upgrade failed with ROS 4.1 from 3.30
Replies: 38
Views: 8712

Re: RB450G upgrade failed with ROS 4.1 from 3.30

I tried the netinstall version 4.2 but the result is the same as in my previous post (at Tue Oct 20, 2009 2:22 pm) It's not possible, we tested and it works on our side. Try to run Netinstall from another PC and make sure no antivirus or firewall is running on that PC I was tested on two different ...
by oreggin
Wed Oct 28, 2009 12:10 am
Forum: RouterBOARD hardware
Topic: RB450G upgrade failed with ROS 4.1 from 3.30
Replies: 38
Views: 8712

Re: RB450G upgrade failed with ROS 4.1 from 3.30

I tried the netinstall version 4.2 but the result is the same as in my previous post (at Tue Oct 20, 2009 2:22 pm)
by oreggin
Mon Oct 26, 2009 4:37 pm
Forum: RouterBOARD hardware
Topic: RB450G upgrade failed with ROS 4.1 from 3.30
Replies: 38
Views: 8712

Re: RB450G upgrade failed with ROS 4.1 from 3.30

When will be release the new versions of netinstall in that maybe fixed the "Sending offer..." issue?
by oreggin
Tue Oct 20, 2009 3:22 pm
Forum: RouterBOARD hardware
Topic: RB450G upgrade failed with ROS 4.1 from 3.30
Replies: 38
Views: 8712

Re: RB450G upgrade failed with ROS 4.1 from 3.30

So I try Netinstall 4.0 as normis wrote. Attached screenshots, and the descriptions: booting.jpg: The router is booting the netinstalls kernel booted.jpg: The router has been booted the kernel and waiting for installation server netinstall1.jpg: Netinstall detect the router properly, package selecte...
by oreggin
Tue Oct 20, 2009 2:35 pm
Forum: RouterBOARD hardware
Topic: RB450G upgrade failed with ROS 4.1 from 3.30
Replies: 38
Views: 8712

Re: RB450G upgrade failed with ROS 4.1 from 3.30

invalid upgrade file id :(
Because you select the firmware upgrade option in RouterBOOT menu.

Select boot from ethernet after you start the netinstall, and NOT the firmware upgrade.

Reboot the router and it will boot up, and waiting for installation server...
by oreggin
Mon Oct 19, 2009 4:57 pm
Forum: RouterBOARD hardware
Topic: RB450G upgrade failed with ROS 4.1 from 3.30
Replies: 38
Views: 8712

Re: RB450G upgrade failed with ROS 4.1 from 3.30

we fixed the Netinstall upgrading issue where it's stuck at "Sending offer". It will be in next Netinstall version, right now you have to use Netinstall 4.0 http://www.mikrotik.com/download/netinstall-4.0.zip Sorry, maybe I'm too lamer but Netinstall never works for me. Not just the 4.x versions bu...
by oreggin
Mon Oct 19, 2009 4:18 pm
Forum: RouterBOARD hardware
Topic: RB450G upgrade failed with ROS 4.1 from 3.30
Replies: 38
Views: 8712

Re: RB450G upgrade failed with ROS 4.1 from 3.30

Ok, janisk was locked my topic:

viewtopic.php?f=3&t=35813

and linked this one but I don't understand why.
I was opened that topic at wrong place? I'm newby here, so sorry for offtopic :)
I searched about Netinstall but didn't found topics/posts about my issue.
by oreggin
Mon Oct 19, 2009 3:00 pm
Forum: RouterBOARD hardware
Topic: Netinstall doesn't install ROS on RBOOT formatted NAND flash
Replies: 2
Views: 2631

Re: Netinstall doesn't install ROS on RBOOT formatted NAND flash

Netinstall v3.30 indicate "Sending offer..." for only 1 second after I press the "install" button and busy for 10 seconds but the result is the same = nothing...
by oreggin
Mon Oct 19, 2009 1:51 pm
Forum: RouterBOARD hardware
Topic: RB450G upgrade failed with ROS 4.1 from 3.30
Replies: 38
Views: 8712

Re: RB450G upgrade failed with ROS 4.1 from 3.30

RouterBOOT booter 2.23
Where did you get this version of firmware? :)
by oreggin
Sat Oct 17, 2009 12:45 pm
Forum: RouterBOARD hardware
Topic: Need to install OpenWRT on a 433AH, can later restore ROS ?
Replies: 8
Views: 2309

Re: Need to install OpenWRT on a 433AH, can later restore ROS ?

He sed:

"2- The second thing we tried was to use Ros 4 virtualization and boot OpenWRT. The problem is that apparently the guest can´t see the SD as storage."
by oreggin
Sat Oct 17, 2009 12:09 am
Forum: RouterBOARD hardware
Topic: Netinstall doesn't install ROS on RBOOT formatted NAND flash
Replies: 2
Views: 2631

Netinstall doesn't install ROS on RBOOT formatted NAND flash

I was format the NAND flash and I can't restore the RouterOS on my RB450G with Netinstall. When I start the Netinstall it can boot the router and the router is wait for the installation server, Netinstall is found them and then I select it by MAC address and select package folder and package, and cl...
by oreggin
Fri Oct 16, 2009 9:31 pm
Forum: RouterBOARD hardware
Topic: Need to install OpenWRT on a 433AH, can later restore ROS ?
Replies: 8
Views: 2309

Re: Need to install OpenWRT on a 433AH, can later restore ROS ?

Hello, I was format the NAND flash and I can't restore the RouterOS on my RB450G with Netinstall. When I start the Netinstall, it can boot the router, and the router is wait for the installation server, but nothing else. I select the proper package and sometimes I select the previously saved license...