Community discussions

MikroTik App

Search found 56 matches

by spookman
Mon Nov 28, 2016 9:12 pm
Forum: General
Topic: Multi IP on WAN & Masq help needed
Replies: 15
Views: 1967

Re: Multi IP on WAN & Masq help needed

Excellent Sob, thanks for your help
by spookman
Mon Nov 28, 2016 9:02 pm
Forum: General
Topic: Multi IP on WAN & Masq help needed
Replies: 15
Views: 1967

Re: Multi IP on WAN & Masq help needed

So I have to put my hand up and apologize, and just say if I had included the complete details of my installation we might have fixed this much earlier. Sob and Kujo, I have to say thanks for your patience and effort in assisting, So to the real problem.... Well I forgot to mention that the link bet...
by spookman
Mon Nov 28, 2016 7:52 pm
Forum: General
Topic: Multi IP on WAN & Masq help needed
Replies: 15
Views: 1967

Re: Multi IP on WAN & Masq help needed

Thanks Sob, I am sure I tested ping the /29 addresses while running torch on the clan-290, but you have me questioning my self, so I give it a go again. With regards to the masquerading I am referring to our bound traffic and so currently if I masquerade the vlan-290 interface out bound internet tra...
by spookman
Mon Nov 28, 2016 3:52 pm
Forum: General
Topic: Multi IP on WAN & Masq help needed
Replies: 15
Views: 1967

Re: Multi IP on WAN & Masq help needed

If I torch the connection I am not seeing the traffic. As I said, I can disable first IP the the 2nd IP responds, if can re-enable the 1st ip and both will remain responding, after about 15mins, the 2nd ip stops responding.
by spookman
Mon Nov 28, 2016 2:58 pm
Forum: General
Topic: Multi IP on WAN & Masq help needed
Replies: 15
Views: 1967

Re: Multi IP on WAN & Masq help needed

Ok I have changed my setup, to consolidate the 2 Mikrotik's into 1 Mikrotik please see design below aswell as the config setup, I am still having an issue where only one of the ip's from the block 19.1.16.152/29 is accessible on the internet at a time. 2nd issue now is that all connection from inter...
by spookman
Mon Nov 28, 2016 1:04 pm
Forum: General
Topic: Multi IP on WAN & Masq help needed
Replies: 15
Views: 1967

Re: Multi IP on WAN not working

Thanks Kujo,

That's not the issue, traffic flows into and out of the network, the problem is the public ip block 19.1.16.152/29 , only 19.1.16.153 is accessable from the internet, rest don't respond to ICMP. or anything
by spookman
Mon Nov 28, 2016 10:47 am
Forum: General
Topic: Multi IP on WAN & Masq help needed
Replies: 15
Views: 1967

Re: Multi IP on WAN not working

So I have removed RB1 from the infrastructure and setup RB2 to act as RB1 i.e. moved the vlan290 ont RB2, Still having the same issue, can access first IP but not the rest. Do I need to instruct the upstream ISP that I am using the entire /29 range, or is there something I need to setup like RIP or ...
by spookman
Sun Nov 27, 2016 8:22 pm
Forum: General
Topic: Multi IP on WAN & Masq help needed
Replies: 15
Views: 1967

Re: Multi IP on WAN not working

Hi Sob,

To clarify, from RB1 I can ping the public IP's, but from the internet I can only ping the first one, the other 4 are not contactable.
I can see in the arp table all 5 ip's and their MAc's which is the same for all as expected, but only 1 of the IP's is ever accessible from the internet.
by spookman
Sun Nov 27, 2016 12:43 am
Forum: General
Topic: Multi IP on WAN & Masq help needed
Replies: 15
Views: 1967

Multi IP on WAN & Masq help needed

EDIT Design UPDATE please see post #8 Hi Guys hoping someone can assist I am having a problem in getting multiple IP's working on my mikrotik RB2, if a disable all of the 19.1.16.154-158/29 and cycle them 1 at time enabled and disabled only ever having 1 enabled at a time till I have done them all,...
by spookman
Mon Sep 03, 2012 9:59 am
Forum: Wireless Networking
Topic: Help - Wireless bridge non-mikrotik AP to Mikrotik Station
Replies: 0
Views: 619

Help - Wireless bridge non-mikrotik AP to Mikrotik Station

Hi Guys, I hope someone can help, I have a situation were we are using a non-mikrotik AP with DHCP Server and we are looking to extend our LAN wirelessly by connecting a Mikrotik RB751G-2HnD, to the AP, we would like the mikrotik to the AP and relay the DHCP. I can get it to working routed, but then...
by spookman
Wed Aug 15, 2012 9:42 pm
Forum: RouterBOARD hardware
Topic: Boosting RB751U-2HnD Antennas!
Replies: 91
Views: 72475

Re: Boosting RB751U-2HnD Antennas!

Quick question are these RP-SMA 5dbi antenna ?
by spookman
Thu May 31, 2012 8:51 am
Forum: RouterBOARD hardware
Topic: RB751G-2HnD - Wireless Streaming Buffering
Replies: 0
Views: 800

RB751G-2HnD - Wireless Streaming Buffering

Hey Guys, Here is the setup, I have 2 media players 1 connected physically and 1 connected via wireless and both connect to the RB71G-2Hn, The network storage device is connected directly to the router, now if I try and stream a 1080p multimedia file the physically connected works 100% but the wirel...
by spookman
Wed Feb 15, 2012 5:08 pm
Forum: RouterBOARD hardware
Topic: RB1200 ROS 5.12 bootloader 2.38 issue.
Replies: 6
Views: 2500

Re: RB1200 ROS 5.12 bootloader 2.38 issue.

Hi, I did this without success, I have since managed to put 5.13 on with netinstall. However the netinstall I hod to try atleast 20-30times, before it took, each time it failed the error was related to trying to write to teh nand. I susepect I have a buggy nand and thus will be taking the router bac...
by spookman
Tue Feb 14, 2012 9:41 pm
Forum: RouterBOARD hardware
Topic: NetInstall Help needed
Replies: 1
Views: 592

Re: NetInstall Help needed

eventually afer many attemps I have manage to get 5.13 on the RB1200, and so far seems stable
by spookman
Tue Feb 14, 2012 3:27 pm
Forum: RouterBOARD hardware
Topic: NetInstall Help needed
Replies: 1
Views: 592

NetInstall Help needed

Hey Guys, I am trying to re flash my RB1200 using netinstall 5.11 due to a corrupted nand, got to the point were the RB1200 PXE boots and get's an IP from the Netinstall, but I don't get the RB1200 showing up in netinstall. I have network cable "straight" connected directly from teh PC to the RB1200...
by spookman
Tue Feb 14, 2012 10:39 am
Forum: RouterBOARD hardware
Topic: RB1200 ROS 5.12 bootloader 2.38 issue.
Replies: 6
Views: 2500

Re: RB1200 ROS 5.12 bootloader 2.38 issue.

We have also notice that in the past when is was working that rebooting the router would result in the router going offline and not booting again, disconnecting and reconnecting the power would power it on again and start the boot cycle.
by spookman
Tue Feb 14, 2012 9:13 am
Forum: RouterBOARD hardware
Topic: RB1200 ROS 5.12 bootloader 2.38 issue.
Replies: 6
Views: 2500

RB1200 ROS 5.12 bootloader 2.38 issue.

Hi Guys, I did an upgrade last night to ROS 5.12 on my RB1200, this went fine and the router return operational again. I then notice that there was a bootloader upgrade from 2.37 to 2.38, so I issued the /system routerboard upgrade After which the the router fails to boot, I have not had chance to c...
by spookman
Tue Dec 06, 2011 8:42 am
Forum: General
Topic: 3 WAN PCC now needs QOS for VOIP - help pls
Replies: 1
Views: 1473

3 WAN PCC now needs QOS for VOIP - help pls

Hi Guys, I have currently a working setup of a 3 WAN PCC on a RB1200, everything has been running well for a while but recently we have noticed that due to growth on the network all our VOIP services are experiencing problems. I what to now implement QOS for the VOIP clients, giving them priority ov...
by spookman
Tue Oct 04, 2011 3:58 pm
Forum: General
Topic: PPTP VPN makes internet access disconnect
Replies: 3
Views: 3141

Re: PPTP VPN makes internet access disconnect

Hi fewi, here is my config /ip address add address=10.10.0.1/24 disabled=no interface=LAN network=10.10.0.0 add address=41.x.x.114/29 disabled=no interface=WAN1 network=41.x.x.112 add address=41.x.x.2/29 disabled=no interface=WAN2 network=41.x.x.0 add address=41.x.x.100/29 disabled=no interface=WAN3...
by spookman
Wed Sep 28, 2011 11:00 pm
Forum: General
Topic: PPTP VPN makes internet access disconnect
Replies: 3
Views: 3141

Re: PPTP VPN makes internet access disconnect

have exaclty the same issue,
my RB1200 is setup with PPC and std firewall rules to act as a NAT.
by spookman
Thu May 05, 2011 9:52 pm
Forum: Beginner Basics
Topic: DNS remote requests + firewall
Replies: 10
Views: 7872

Re: DNS remote requests + firewall

Ok Fewi, Thanks for putting me on the right track, I have now fixedthe issue, basically I was marking all traffic in the mangle table with a routing mark. and the only routes I had was routes with routing marks, I now looks like the router it's self doesn't do through the mangle table and thus not m...
by spookman
Thu May 05, 2011 9:21 pm
Forum: Beginner Basics
Topic: DNS remote requests + firewall
Replies: 10
Views: 7872

Re: DNS remote requests + firewall

Ok I think I have found sometinhg, the rotuer it's self has no default route, so if I add a route of 0.0.0.0/0 to WAN1 It all works, but how do I add it so that it so will failover with a failed route. Mangle rules only seem to apply to traffic not originating from the router is slef, like our dns t...
by spookman
Thu May 05, 2011 8:55 pm
Forum: Beginner Basics
Topic: DNS remote requests + firewall
Replies: 10
Views: 7872

Re: DNS remote requests + firewall

The Recirsive routes are for failover, the router is configured with PCC, we have 3 WAN (ISP) connections and then the LAN. All clients on the LAN side can resolved DNS using external DNS Servers, just not when using the router as a DNS server. All other aspects of the newtork and connectivity are f...
by spookman
Thu May 05, 2011 6:36 pm
Forum: Beginner Basics
Topic: DNS remote requests + firewall
Replies: 10
Views: 7872

Re: DNS remote requests + firewall

:put [:resolve www.google.com] failure: dns server failure /ip address print detail 0 address=10.10.0.1/24 network=10.10.0.0 interface=Local actual-interface=Local 1 address=41.x.x.114/29 network=41.x.x.112 interface=WAN1 actual-interface=WAN1 2 address=41.x.x.115/29 network=41.x.x.112 interface=WA...
by spookman
Thu May 05, 2011 8:02 am
Forum: Beginner Basics
Topic: DNS remote requests + firewall
Replies: 10
Views: 7872

Re: DNS remote requests + firewall

BUMP..... Any more help pls guys, I'm stuck here
by spookman
Tue May 03, 2011 10:21 am
Forum: Beginner Basics
Topic: DNS remote requests + firewall
Replies: 10
Views: 7872

Re: DNS remote requests + firewall

Hey Fewi, I tried that but still can't get it to work, here are all my rules /ip firewall filter add action=accept chain=input connection-state=established disabled=no add action=accept chain=input connection-state=related disabled=no add action=drop chain=input connection-state=invalid disabled=no ...
by spookman
Mon May 02, 2011 9:58 pm
Forum: Beginner Basics
Topic: DNS remote requests + firewall
Replies: 10
Views: 7872

DNS remote requests + firewall

Hi Guys, I am trying to get DNS Cache with remote requests allowed working but so far no luck, I have the RB750 setup with PCC and some forwarding rules, but I can seem to get it working these are the only relvant snipets, the rest of my mangle, firewall and nat is standard stuff. /ip firewall filte...
by spookman
Thu Apr 21, 2011 9:09 am
Forum: Beginner Basics
Topic: DNS Cache and remote request + PCC
Replies: 3
Views: 1379

Re: DNS Cache and remote request + PCC

Anybody ?
by spookman
Mon Apr 18, 2011 10:36 am
Forum: Beginner Basics
Topic: DNS Cache and remote request + PCC
Replies: 3
Views: 1379

Re: DNS Cache and remote request + PCC

Thanks for the response but this didn't work, PCC is working and if users have thier DNS addresses setup to query and external DNS server it's fine that problem I have is we have over 100 clients and some of them have thier PC's DNS set to the router. which at present is not resolving DNS, if I from...
by spookman
Sun Apr 17, 2011 9:26 pm
Forum: Beginner Basics
Topic: DNS Cache and remote request + PCC
Replies: 3
Views: 1379

DNS Cache and remote request + PCC

Hi Guys, I am trying to get DNS Cache with remote requests allowed working but so far no luck, I have the RB750 setup with PCC and some forwarding rules, but I can seem to get it working /ip firewall filter add action=accept chain=input comment="Std established" connection-state=established disabled...
by spookman
Tue Apr 12, 2011 12:50 pm
Forum: General
Topic: Hairpin NAT + Routing
Replies: 14
Views: 5793

Re: Hairpin NAT + Routing

More issue,

hitting the webpages on 41.x.x.2 which points to 10.10.0.250 works fine,
but hitting 41.x.x.3 or 41.x.x.2 is not dstnat to the respective hosts.

Also how do I enable icmp on the external interfaces ?
by spookman
Tue Apr 12, 2011 10:18 am
Forum: General
Topic: Hairpin NAT + Routing
Replies: 14
Views: 5793

Re: Hairpin NAT + Routing

Almost there just a few issues though, the hairpin nat is still not working correctly. I have had to add rules 0-3 at the top of nat to ensure that all internal mail/web traffic goes to the servers. /ip firewall address-list add address=10.10.0.232 disabled=no list=admin_hosts add address=10.10.2.10...
by spookman
Mon Apr 11, 2011 10:43 pm
Forum: General
Topic: Hairpin NAT + Routing
Replies: 14
Views: 5793

Re: Hairpin NAT + Routing

Sweet thanks fewi,

I'll test it out tomorrow and let you know.... thanks again.
by spookman
Mon Apr 11, 2011 10:10 pm
Forum: General
Topic: Hairpin NAT + Routing
Replies: 14
Views: 5793

Re: Hairpin NAT + Routing

thanks fewi /ip firewall address-list add address=10.10.0.232 disabled=no list=admin_hosts add address=10.10.2.10 disabled=no list=admin_hosts add address=10.10.0.0/24 disabled=no list=Internal add address=10.10.1.0/24 disabled=no list=Internal add address=10.10.2.0/24 disabled=no list=Internal add ...
by spookman
Mon Apr 11, 2011 9:47 pm
Forum: General
Topic: Hairpin NAT + Routing
Replies: 14
Views: 5793

Re: Hairpin NAT + Routing

Jeeez China, I hope the people who employ you are paying you well....... skillz dude, the internal part is working now thanks. Still one issue, the Hairpin NAT is still not working for me. Where do i put this in the list ? add chain=srcnat dst-address=10.10.0.250 src-address=list=Internal out-interf...
by spookman
Mon Apr 11, 2011 8:21 pm
Forum: General
Topic: Hairpin NAT + Routing
Replies: 14
Views: 5793

Re: Hairpin NAT + Routing

Ok something is not right in my config. Just to add I currently only have WAN3 connected WAN1 and WAN2 are not plugged in till I get this working. /ip route add comment="MWeb" dst-address=196.2.63.110/32 gateway=41.x.x.113 scope=10 add comment="Yahoo" dst-address=67.195.160.76/32 gateway=41.x.x.113 ...
by spookman
Mon Apr 11, 2011 7:41 pm
Forum: General
Topic: Hairpin NAT + Routing
Replies: 14
Views: 5793

Re: Hairpin NAT + Routing

Cool got it for the FQDN, I am still having a troblem with the routing though. here is the network layout. I have an internet router "RB750" @ 10.10.0.1 Various servers ftp,mail,http @ 10.10.0.0/24 we have another router "RB433" and from there out to various high sites and towers and then CPE's conn...
by spookman
Mon Apr 11, 2011 5:00 pm
Forum: General
Topic: Hairpin NAT + Routing
Replies: 14
Views: 5793

Re: Hairpin NAT + Routing

I only ask as we have around 20 subnets, which meas I'll need to add a rule for each subnet. I can see the issue with the WAN, and it would be a real issue as the server has fail to ban installed, so if 1 person get's the auth wrong then every one would be lockout out. what if I add - in-interface=L...
by spookman
Mon Apr 11, 2011 4:02 pm
Forum: General
Topic: Hairpin NAT + Routing
Replies: 14
Views: 5793

Re: Hairpin NAT + Routing

Ok I have found this article http://wiki.mikrotik.com/wiki/Hairpin_NAT And implemented like this /ip firewall nat add chain=srcnat src-address=10.10.0.0/24 dst-address=10.10.0.250 protocol=tcp dst-port=20,21,25,8,110,143,443 out-interface=LAN action=masquerade Can I note just do this ? that way ever...
by spookman
Mon Apr 11, 2011 1:10 pm
Forum: General
Topic: Hairpin NAT + Routing
Replies: 14
Views: 5793

Hairpin NAT + Routing

Hi Guys, I have setup PPC on my R750 and mostly it seems to be working fine, I have a few issues though. Previously on the the edimax router if I added a static route to one of our internal networks, all traffic originating internally to another internal network would be routed via the edimax to the...
by spookman
Wed Mar 09, 2011 7:14 am
Forum: General
Topic: Check and disable route if internet link going down
Replies: 4
Views: 2018

Re: Check and disable route if internet link going down

I found an easier way and it works without scripts, incase you are intrested

http://wiki.mikrotik.com/wiki/Advanced_ ... _Scripting
by spookman
Wed Mar 09, 2011 7:09 am
Forum: General
Topic: Load Balancing + Port Forwarding
Replies: 20
Views: 99831

Re: Load Balancing + Port Forwarding

Awesome thanks fewi.
by spookman
Tue Mar 08, 2011 10:44 am
Forum: General
Topic: Load Balancing + Port Forwarding
Replies: 20
Views: 99831

Re: Load Balancing + Port Forwarding

Thanks fewi & forne, I have managed to get it working and now understand why it works and works well. Another Question maybe for fewi or anyone that can answer. If I have multiple addresses on an interface like this (WAN1) 10.0.1.2 10.0.1.3 10.0.1.4 connection-mark & routing-mark & PCC add chain=inp...
by spookman
Tue Mar 08, 2011 9:58 am
Forum: Scripting
Topic: fail over - ping from interface
Replies: 3
Views: 20480

Re: fail over - ping from interface

Thanks for the help guys, I found a soulotion which does not even require a script

http://wiki.mikrotik.com/wiki/Advanced_ ... _Scripting
by spookman
Sun Mar 06, 2011 12:39 pm
Forum: General
Topic: Load Balancing + Port Forwarding
Replies: 20
Views: 99831

Re: Load Balancing + Port Forwarding

forne, I have had a look but I can't see how it disables the failed route in my situation I have /ip route add check-gateway=ping comment=TO_WAN1 disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.0.0.1 routing-mark=to_WAN1 scope=30 target-scope=10 add comment=WAN1_BACKUP disabled=no distance=1...
by spookman
Sun Mar 06, 2011 12:03 pm
Forum: General
Topic: Load Balancing + Port Forwarding
Replies: 20
Views: 99831

Re: Load Balancing + Port Forwarding

Cool then why when I do the same from within winbox and I specify an interface it works....? Ok here is my problem, I am trying to write a script that will fail over when a link goes down, but as I don't control the xDSL modems (ISP does) I can't use the check-gateway, becuase if the xDSL line goes ...
by spookman
Sun Mar 06, 2011 11:05 am
Forum: General
Topic: Load Balancing + Port Forwarding
Replies: 20
Views: 99831

Re: Load Balancing + Port Forwarding

Question with my setup at teh top of the post,

why does this not work

/ping 196.25.1.1 routing-table=GW1 interface=ether1

but if I omitt the interface it does
/ping 196.25.1.1 routing-table=GW1
by spookman
Sun Mar 06, 2011 9:56 am
Forum: General
Topic: Load Balancing + Port Forwarding
Replies: 20
Views: 99831

Re: Load Balancing + Port Forwarding

Awesome thanks guys,

I assume then that the routes we create we just add the relivant routing marks ?
by spookman
Sun Mar 06, 2011 9:13 am
Forum: Scripting
Topic: fail over - ping from interface
Replies: 3
Views: 20480

fail over - ping from interface

Hi all I have a RG750 configured with PCC and conencted to 2 upstream providers, every thing works great except when one the providers goes down the fail over does not happen. This is because the check-gateway only allows to check the next gateway, as I am connect to ISP controlled DSL modem I can't...
by spookman
Fri Mar 04, 2011 2:48 pm
Forum: General
Topic: Load Balancing + Port Forwarding
Replies: 20
Views: 99831

Re: Load Balancing + Port Forwarding

Ok can you give me an example ?
by spookman
Fri Mar 04, 2011 2:26 pm
Forum: General
Topic: Load Balancing + Port Forwarding
Replies: 20
Views: 99831

Re: Load Balancing + Port Forwarding

Strange, because by all the post I have read it seems that there are people out there doing this but no one can tell us how,

The routers then become useless if they can do nothing more comlpex than load balancing when you want to host servers behind them/
by spookman
Fri Mar 04, 2011 1:21 pm
Forum: General
Topic: Load Balancing + Port Forwarding
Replies: 20
Views: 99831

Re: Load Balancing + Port Forwarding

Come guys give us a hand here.

It would now seem when I try connecting to the ether2 on 443 the dst-nat is happening but it looks like it's returning on the wrong GW, I can't be sure though
by spookman
Fri Mar 04, 2011 8:03 am
Forum: Forwarding Protocols
Topic: ftp Port fowading
Replies: 23
Views: 3549

Re: ftp Port fowading

arthurmitch, I am trying to do exactly what you are, I have 2 connections 1 from MWEB and 1 VODACOM. can you help me. I need load balancing with fail over, port forwarding and also if I access the external IP from internal it needs to work. could you send me you mangle,nat,filter,routes tables. Also...
by spookman
Thu Mar 03, 2011 12:14 pm
Forum: General
Topic: Check and disable route if internet link going down
Replies: 4
Views: 2018

Re: Check and disable route if internet link going down

Did you ever figure this out ?
by spookman
Mon Feb 28, 2011 10:06 am
Forum: General
Topic: Load Balancing + Port Forwarding
Replies: 20
Views: 99831

Load Balancing + Port Forwarding

Come Guys help me out here WAN IP: (ISP xDSL modems, we can't make the RG750 pppoe as the modems/routers are locked down) ether1 : 10.0.0.100 ether2 : 10.0.1.100 LAN IP ether1 : 10.10.0.100 1. We also have an internal email and webserver on 10.10.0.250 which needs to be accessible over WAN1 and WAN2...
by spookman
Sun Nov 15, 2009 3:22 pm
Forum: General
Topic: Mikrotik + FreeRadius + Nanostation
Replies: 2
Views: 1079

Mikrotik + FreeRadius + Nanostation

Hi all, I need some help

I have intsall a RB433 and a few NanoStations as CPE's

I have now install freeradius and have it authenticating and working.

What I need to know is how do I setup the CPE's and the Mikrotik now to use the freeradius for authentication. ?

Thanks