Community discussions

MikroTik App

Search found 42 matches

by ether3al
Thu Oct 30, 2014 11:50 pm
Forum: General
Topic: Upgrade to 6.20 lost routing functionality
Replies: 1
Views: 548

Upgrade to 6.20 lost routing functionality

Hi All, Last night had a bunch of RB2011s & RB450s run a scheduled upgrade to v6.20, over the last few days I would have upgraded about 200 routers from various versions ranging from v4.13 up to about 5.22 straight up to 6.20. I have had one RB450 that has upgraded the OS and firmware just fine but ...
by ether3al
Mon Jun 23, 2014 1:43 am
Forum: Forwarding Protocols
Topic: Increasing VPLS advertised L2 MTU
Replies: 2
Views: 1338

Re: Increasing VPLS advertised L2 MTU

Hi Mrz

Thanks for the response.

Yes i am aware on how to make the config change but more so the issue around making sure MPLS MTU and L2 MTU are configured correctly to support the increased advertised L2 MTU.

Kind regards.
by ether3al
Fri Jun 20, 2014 1:18 am
Forum: Forwarding Protocols
Topic: Increasing VPLS advertised L2 MTU
Replies: 2
Views: 1338

Increasing VPLS advertised L2 MTU

Hi All,

Just hoping on getting some advise on how to go about increasing the L2 advertised MTU for VPLS tunnels on MikroTik.

Thanks

Ether3al
by ether3al
Wed Jun 18, 2014 7:05 am
Forum: General
Topic: Queue configuration best practice
Replies: 2
Views: 1619

Queue configuration best practice

Hi All, I am curious to peoples & MikroTiks thoughts around best practice for Queue configuration. We terminate a large number of customer VPLS circuits back to a MikroTik in one of our POPs. We implement a simple queue at the egress interface for each circuit. Customer---->Ether5---->MTIK------[VPL...
by ether3al
Wed Apr 23, 2014 9:26 am
Forum: Forwarding Protocols
Topic: MPLS/LDP neighbour issue
Replies: 0
Views: 816

MPLS/LDP neighbour issue

Hi All, I have two RB1000s that will not establish LDP via OSPF. In the debug logging i get no messages to show that it even tries to establish an LDP neighbourship. The config should work as each of the routers has working LDP neighbours. L2 MTU is not an issue as the working LDP neighbours travers...
by ether3al
Wed Apr 23, 2014 9:14 am
Forum: Forwarding Protocols
Topic: MPLS/VPLS with OSPF problem
Replies: 6
Views: 2792

Re: MPLS/VPLS with OSPF problem

I have experienced this issue on a few models of RouterBoard and it is has always been related to the L2 MTU in the path not being high enough.
by ether3al
Mon Apr 07, 2014 2:56 am
Forum: Forwarding Protocols
Topic: VRRP on RB1100AHx2
Replies: 1
Views: 1024

VRRP on RB1100AHx2

Hi All,

I am looking to use VRRP on a pair of RB1100AHx2 routers to provide redundancy for VPLS terminations.

I just wanted to see if anyone has either positive or negative experience doing this with MTIK.

Thanks
by ether3al
Fri Mar 28, 2014 1:34 am
Forum: General
Topic: Netflow Source Interface
Replies: 0
Views: 374

Netflow Source Interface

Hi All,

Wondering if there is a way to specify the netflow export source interface on MikroTik like you can on Cisco?

If not any MikroTik staff can we have a feature request for it?

Thanks

Ether3al
by ether3al
Mon Mar 18, 2013 2:12 am
Forum: Forwarding Protocols
Topic: MikroTik Vs Cisco VPLS
Replies: 2
Views: 1928

Re: MikroTik Vs Cisco VPLS

Finally got some time to work on this again. Thanks for the feedback, now have LDP up and running OK. Issue is now that the Cisco thinks the VC is down, however the MikroTik is showing the VPLS interface is UP. [admin@MikroTik] > interface vpls print Flags: X - disabled, R - running, D - dynamic, B ...
by ether3al
Thu Feb 28, 2013 12:36 am
Forum: Forwarding Protocols
Topic: MikroTik Vs Cisco VPLS
Replies: 2
Views: 1928

MikroTik Vs Cisco VPLS

Hi All, I am trying to get VPLS working between MikroTik & Cisco. I am using an RB2011-RM w/ ROS 6.07RC with a Cisco 6509 running IOS: Cisco IOS Software, s72033_rp Software (s72033_rp-ADVENTERPRISEK9-M), Version 15.1(1)SY I have just copied & pasted the following WIKI artical: http://wiki.mikrotik....
by ether3al
Fri Nov 16, 2012 4:45 am
Forum: Forwarding Protocols
Topic: Cisco 3825 L2VPN
Replies: 1
Views: 895

Re: Cisco 3825 L2VPN

Hi Domv,

We currently use a mix of Cisco and MikroTik for our LACs.

When we use the MikroTik we have them setup as a PPPoE server and forward RADIUS auth / acct to our RADIUS server. Works fine as long as your not using the Cisco AV-Pairs as the attributes will vary.
by ether3al
Fri Nov 16, 2012 4:42 am
Forum: Forwarding Protocols
Topic: MT & Cisco EoMPLS Config
Replies: 5
Views: 3290

Re: MT & Cisco EoMPLS Config

I have made some progress, but still not getting a usable link: 20:48:51: %LDP-5-NBRCHG: LDP Neighbor 2.2.2.2:0 (1) is DOWN (TCP connection closed by peer) 20:49:03: %LDP-5-NBRCHG: LDP Neighbor 2.2.2.2:0 (1) is UP 20:49:03: MPLS peer 2.2.2.2 vcid 173, VC UP, VC state UP Switch#sho xconnect all detai...
by ether3al
Mon Nov 12, 2012 5:52 am
Forum: Forwarding Protocols
Topic: MT & Cisco EoMPLS Config
Replies: 5
Views: 3290

Re: MT & Cisco EoMPLS Config

Hi,

I believe it is a restriction of the current IOS version I have on the 3750ME switch.

Currently trying to get my hands on the correct version. Will post an update once I make more progress.

Thanks

Ether3al
by ether3al
Sat Nov 03, 2012 1:54 am
Forum: Forwarding Protocols
Topic: MT & Cisco EoMPLS Config
Replies: 5
Views: 3290

Re: MT & Cisco EoMPLS Config

Currently just 1500, I have tried using 1526 and 1998. When increasing the system MTU on the Cisco 3750 I kept getting an MTU mismatch error which from memory i was able to resolve by changing the MTU setting of the VPLS interface on the MT.

Would have to get the info when I am back in the office.
by ether3al
Fri Nov 02, 2012 7:03 am
Forum: Forwarding Protocols
Topic: MT & Cisco EoMPLS Config
Replies: 5
Views: 3290

MT & Cisco EoMPLS Config

Hi All, We currently have a network running Cisco MPLS core with Mikrotik PE for handing off EoMPLS (VPLS) pseudo wires. At our major POIs I would like to move away from MikroTik to have a Cisco 3750ME or Cisco 6500 as our PE. I have followed this guide: http://wiki.mikrotik.com/wiki/Manual:EoMPLS_v...
by ether3al
Fri Sep 28, 2012 7:50 am
Forum: Forwarding Protocols
Topic: RB450G GUI crashes when MPLS enabled
Replies: 0
Views: 643

RB450G GUI crashes when MPLS enabled

Hi All, I have just enabled OSPF & MPLS on a couple of RB450Gs. The moment I enable the LDP interface the Winbox crashes, I can log back in and get no results when Winbox tries to load and it will crash again. I can manage the devies fine via SSH. System resources are 1% CPU 250Mb free memory. I hav...
by ether3al
Sat Jan 22, 2011 12:49 am
Forum: Forwarding Protocols
Topic: VRF and NAT Masquerade
Replies: 7
Views: 3665

Re: VRF and NAT Masquerade

So still no luck with the mangle rules... Tried to add the routing mark using the VLAN interface inbound, global interface, src-addr & dst-addr... still dont get any hits: Flags: X - disabled, I - invalid, D - dynamic 0 chain=prerouting action=mark-routing new-routing-mark=Internet passthrough=yes s...
by ether3al
Fri Jan 21, 2011 11:21 pm
Forum: Forwarding Protocols
Topic: VRF and NAT Masquerade
Replies: 7
Views: 3665

Re: VRF and NAT Masquerade

Hmm, I did have a mangle rule in place based on that logic, however was not getting any hits on it and MikroTik support told me to remove it.

I will put the mangle rules back on and post an update.

Thanks!
by ether3al
Fri Jan 21, 2011 12:32 am
Forum: Forwarding Protocols
Topic: VRF and NAT Masquerade
Replies: 7
Views: 3665

Re: VRF and NAT Masquerade

OK, I have tested further by routing a public subnet across the VRF and assigned an address from this range to the host on the LAN. I am able to ping the routers address on this subnet however the router is dropping the ICMP request on the return trip from the host across the router... I am guessing...
by ether3al
Thu Jan 20, 2011 3:01 am
Forum: Forwarding Protocols
Topic: VRF and NAT Masquerade
Replies: 7
Views: 3665

Re: VRF and NAT Masquerade

OK so upon looking over that WIKI article properly it is irrelevant to what I am trying to do, so just to clarify: I have a VPLS interface that has an Internet address on it within a VRF, I then have a VLAN interface using private addressing with a host on the VLAN also within the VRF. I have a dst-...
by ether3al
Sat Jan 15, 2011 11:26 am
Forum: Forwarding Protocols
Topic: VRF and NAT Masquerade
Replies: 7
Views: 3665

Re: VRF and NAT Masquerade

No i wasn't, thanks for the link!
by ether3al
Fri Jan 14, 2011 5:44 am
Forum: Forwarding Protocols
Topic: VRF and NAT Masquerade
Replies: 7
Views: 3665

VRF and NAT Masquerade

Hi All, I am having some trouble getting NAT masquerade to work with a VRF. I have a VPLS PW interface with the public range routed to it using a VRF. I have setup src-nat to mask from the LAN subnet outbound on the VPLS PW interface within the VRF. I have setup the NAT rules to include the routing ...
by ether3al
Fri Jan 14, 2011 5:29 am
Forum: Forwarding Protocols
Topic: OSPF problems when MD5 authentication is in use
Replies: 4
Views: 2568

Re: OSPF problems when MD5 authentication is in use

We have just completed a deployment using OSPF with MD5 authentication using Cisco 2821s and RB493G's. We found that upgrading to 4.13 helped with a lot of the OSPF issues, also I found that there would be a heap of sequence errors to start with but after a while they would stop. As we are using Ubi...
by ether3al
Fri Dec 03, 2010 12:59 am
Forum: General
Topic: MUM in Australia. Would you come?
Replies: 115
Views: 24178

Re: MUM in Australia. Would you come?

Sydney for sure!!!
by ether3al
Tue Nov 16, 2010 5:06 am
Forum: Forwarding Protocols
Topic: L2 WAN Load Balancing
Replies: 2
Views: 1352

Re: L2 WAN Load Balancing

OK, so I work for a WISP and we currently offer auto fail over to ADSL for layer 3 services. But we would like to offer DSL backup for the L2 services we provide. I was hoping to avoid using tunnelling protocols, but i think I am going to have to use them to achieve this.
by ether3al
Mon Nov 15, 2010 4:33 am
Forum: Forwarding Protocols
Topic: L2 WAN Load Balancing
Replies: 2
Views: 1352

L2 WAN Load Balancing

Hi All,

Does anyone have a way to perform L2 wan fail-over / Load balancing? The only way I can think of is to have a router at each end and setup bonding.

thnx
by ether3al
Wed Oct 20, 2010 8:26 am
Forum: General
Topic: DSL Fail over
Replies: 2
Views: 590

DSL Fail over

Hi All, I am well aware of the unfortunate fact that MikroTik does not have DSL support. We currently use MikroTik quite widely as a CPE, however with our high profile customers we are using Cisco 2800 series routers so we can have auto fail over from an Ethernet link to DSL. Now we have a large num...
by ether3al
Mon Jul 19, 2010 9:00 am
Forum: General
Topic: QoS and Btest
Replies: 0
Views: 371

QoS and Btest

Hi All, I am eager to use the API to automatically conduct regular BTests to CPEs throughout my network and graph the results. However I do not want these tests to impact the rest of the network. I am unsure if this can be done with PCQs. [MikroTik]------Wireless bridge STA (- ~~~~ -) Wireless Bridg...
by ether3al
Fri Jun 25, 2010 9:09 am
Forum: General
Topic: Hotspot without masquarade
Replies: 1
Views: 444

Hotspot without masquarade

Hi All, I have a few production systems running hotspots that are masqueraded, however due to user tracking requirements I need to change this setup to no longer use masquerading. My question is if I simply implement a pool of public IP addresses and disable the masquerade rule will the Hotspot cont...
by ether3al
Wed Jun 16, 2010 2:14 am
Forum: General
Topic: EOIP plus IPSec
Replies: 2
Views: 722

Re: EOIP plus IPSec

I believe you can as EoIP uses the GRE protocol. My thoughts would be to just configure one tunnel over the other you should be able to configure either IPSec over EoIP or EoIP over IPSec. I haven't set this up on a MikroTik before so it would be best to just mess around with it until you get it wor...
by ether3al
Thu Jun 10, 2010 7:37 am
Forum: General
Topic: Hotspot VLANs
Replies: 44
Views: 13008

Re: Hotspot VLANs

/interface bridge settings set use-ip-firewall=yes use-ip-firewall-for-vlan=yes This is slightly off your topic, but you are one of very few using the ip-firewall-for-vlan=yes command. i would like to use the above to mark packets per vlan for QoS, can some one go into some detail as to the exact o...
by ether3al
Thu Jun 10, 2010 4:36 am
Forum: General
Topic: Extra settings for RouterOS bridge
Replies: 1
Views: 453

Extra settings for RouterOS bridge

Hi All, The use-ip-firewall switch seems straightforward enough, which is to enact the IP firewall on bridged traffic for transparent shaping etc. What I need to know is what the use-ip-firewall-for-vlan option does. Whether this simply enables me to perform firewall operations on bridged VLAN inter...
by ether3al
Thu Jun 10, 2010 4:34 am
Forum: General
Topic: Hacking Hotspot
Replies: 116
Views: 69555

Re: Hacking Hotspot

Sounds like there is a need for a WIPs system!

We use AirDefence with policy based termination (wired and wireless) :)
by ether3al
Thu Jun 10, 2010 4:12 am
Forum: Forwarding Protocols
Topic: HotSpot + PPPoE Server
Replies: 1
Views: 1285

Re: HotSpot + PPPoE Server

Hi There, I have multiple sites running PPPoE and Hotspot. I have both services enabled to the same bridge interface. PPPoE has a public IP pool and the Hotspot is masqueraded behind the routers address. I use external RADIUS for both and have seen up to ~50 users online between the two services. I ...
by ether3al
Tue Feb 16, 2010 6:24 am
Forum: General
Topic: Hotspot firewall issue
Replies: 1
Views: 647

Hotspot firewall issue

Hi All, Im having some difficulties with firewall rules when I have the hotspot service running on one of my MTIK routers. I have a staff vlan and a student vlan. members of the staff vlan need to be able to RDP to a server located on the student vlan, so to do this I have a firewall rule allowing s...
by ether3al
Mon Feb 08, 2010 3:25 am
Forum: General
Topic: Hotspot page update's?
Replies: 5
Views: 1101

Re: Hotspot page update's?

Ok so i have reverted this RB to use the default MikroTik Hotspot page's and it displays them correctly. I have also loaded up a second folder with the page's I want, however it displays this page with incorrect data. When I load the page straight from my PC it is displayed correctly though... [admi...
by ether3al
Thu Feb 04, 2010 12:42 am
Forum: General
Topic: Hotspot page update's?
Replies: 5
Views: 1101

Re: Hotspot page update's?

So creating an entirely new directory for the updated content didn't work... This is really weird as the page displays as I want it too when I load it straight off my PC, however the moment it is loaded onto any Mikrotik i seem to get cached data but I cannot find where it is being cached. Cleared m...
by ether3al
Thu Feb 04, 2010 12:28 am
Forum: General
Topic: Hotspot page update's?
Replies: 5
Views: 1101

Re: Hotspot page update's?

Yes I did this by removing the content from the /hotspot folder and uploaded the new content.

I am going to see what happens when I create a whole new directory for the updated content and point the service to that.
by ether3al
Wed Jan 20, 2010 11:59 pm
Forum: Wireless Networking
Topic: Hotspot bug???
Replies: 3
Views: 569

Re: Hotspot bug???

Found my issue :D

Made a mistake in the srcnat src subnet... testing it shortly but looks good to me!

Thanks for your input.
by ether3al
Wed Jan 20, 2010 11:43 pm
Forum: Wireless Networking
Topic: Hotspot bug???
Replies: 3
Views: 569

Re: Hotspot bug???

Yes I am masquarading/srcnating on the router that is running the hotspot service. The reason I find it strange is some customers are able to use the service fine, yet others experience the issue described above. If it where a routing issue I would not be able to reach the router on the public(NATed...
by ether3al
Wed Jan 20, 2010 1:04 pm
Forum: Wireless Networking
Topic: Hotspot bug???
Replies: 3
Views: 569

Hotspot bug???

Hi All, I am experiencing some difficulties with a pair of Hotspots running RB1000's with RouterOS 4.5: Walled garden works OK Signup is OK Authentication via Radius works (using Cookie based HS) works OK Re-direct to web fails, in Ubuntu firefox the browser is unable to reach any webpage (even one ...
by ether3al
Tue Jan 19, 2010 6:22 am
Forum: General
Topic: Hotspot page update's?
Replies: 5
Views: 1101

Hotspot page update's?

Hi All, With the hotspot page i recently uploaded a fairly generic page of my own, however when I customized it to a final product and uploaded it I found that the RB was still using the old page. I rebooted the RB the other night and have not yet returned to site to check if it is using the new pag...