Community discussions

MikroTik App

Search found 20 matches

by Puffer
Sun Jul 12, 2020 11:13 pm
Forum: Scripting
Topic: sendphoto to telegram
Replies: 2
Views: 663

sendphoto to telegram

Can anyone see what I am doing wrong here? Trying to send a local .gif file to a telegram chat. /tool fetch url="https://api.telegram.org/bot###/sendPhoto\?chat_id=###" http-method=post http-header-field="content-type:photo" http-data="http://daily.gif" keep-result=no Works perfectly with sendMessag...
by Puffer
Wed Apr 29, 2020 11:59 am
Forum: Scripting
Topic: Dynamically created arrays
Replies: 3
Views: 1061

Re: Dynamically created arrays

Thanks Jotne Making those changes causes the key to become lost. I'd ideally like to retain the key functionality. My ultimate goal is a dynamic array like this : maclist={A1:B1:C1:D1:E1:F1={ firstseen=April202020; lastseen=April252020; throttled=false }; A2:B2:C2:D2:E2:F2={firstseen=April252020; la...
by Puffer
Tue Apr 28, 2020 6:19 pm
Forum: Scripting
Topic: Dynamically created arrays
Replies: 3
Views: 1061

Dynamically created arrays

Hi Folks Battling with a 2D array creation. I want to store some user detail against a device mac as the Key (In my example below 1, 2 & 3). If I manually create the structure I can change each field individually. If I create them dynamically in a loop with the "same" commands, changing one field up...
by Puffer
Thu Apr 25, 2019 8:14 am
Forum: General
Topic: Hotspot long term logging
Replies: 0
Views: 376

Hotspot long term logging

Hi Folks I'm looking for a way to discern between short term visitors, medium term volunteers and long term staff on a medium size WiFi network. (30AP's & 500 active users) Almost like a day counter for active users. Count up for each day active and decrements for each day absent. A daily report wil...
by Puffer
Sat Nov 11, 2017 5:19 am
Forum: Scripting
Topic: Failed E-Mail script error
Replies: 1
Views: 450

Re: Failed E-Mail script error

Hi all
This has been resolved in 6.41rc52 firmware.
Rgds
by Puffer
Wed Nov 08, 2017 9:26 pm
Forum: Scripting
Topic: Failed E-Mail script error
Replies: 1
Views: 450

Failed E-Mail script error

Hi Folks if the SMTP server is not available my alert emails fail. I tried to catch the error to set up a resend but it appears that the script hangs and aborts if the email fails. If the email send is successful the script carries on and completes normally. :log info start /tool e-mail send to=fred...
by Puffer
Fri Dec 23, 2016 3:12 pm
Forum: General
Topic: IP Cloud
Replies: 113
Views: 72852

Re: IP Cloud

Hi Gents
Great feature
I hope I have not missed it. Does Cloud.Mikrotik.com always resolve to the same address ?
I don't allow a default gateway so would like to allow only the addresses used by cloud.

Rgds Puffer
by Puffer
Fri Nov 07, 2014 12:33 pm
Forum: General
Topic: Switching a relay with RB750UP POE
Replies: 0
Views: 767

Switching a relay with RB750UP POE

Hi Folks Trying to remotely switch a 12V relay with a RB750UP POE out on spare port # 5 FW 6.21.1 POE FW 2.13 Device powered by 12V battery on DC jack. Relay coil resistance is 240 Ohm. Obviously can't use auto-on as the relay impedance is not in 3K-26k range but I want to script control it anyway. ...
by Puffer
Mon Sep 08, 2014 2:00 pm
Forum: General
Topic: EoIP alternative
Replies: 2
Views: 1543

EoIP alternative

Hi Folks Have a site with 8 locations surrounding a ISP AP high site. We thus have 8 PPPOE accounts on radios with a RB750 behind them and wish to have a common lan for the 8 locations. All offices for the same company. Star topology. I have 7 EoIP tunnels bridged on one router to facilitate this. W...
by Puffer
Fri Aug 09, 2013 8:30 am
Forum: General
Topic: 【Bug】6.xx Queue tree Bug
Replies: 38
Views: 15733

Re: 【Bug】6.xx Queue tree Bug

Any feedback on this ? I upgraded my RB450G to 6.2 yesterday and the 46 queue trees are not visible in Winbox. If I go to new terminal console they are all there and working. Nothing shows in the queue tree window in Winbox, even if I add a new queue tree in V6.2. Have tried disabling them all and r...
by Puffer
Thu Aug 02, 2012 9:16 pm
Forum: RouterBOARD hardware
Topic: RB433AH boot fail with serial plugged in !
Replies: 2
Views: 931

RB433AH boot fail with serial plugged in !

Hi all Just set up a 433AH and I am using the serial port to log some inbound data from a GSM device. Have several already working similarly. The unit is up a 6m pole so I made off a mylar screened cable to pins 2,3 & 5 and plugged it in. I left the other end unconnected for now to be able to cut sh...
by Puffer
Thu May 19, 2011 12:49 pm
Forum: General
Topic: Serial Port support
Replies: 0
Views: 593

Serial Port support

Please can a [/write "Text" port=serial0] be made available for sending a text string to a device connected to the Com/Serial0 port. And even better a facility to receive an "OK" from the connected device. There are many "sms" type communicators that do not comply with the int. standard for input st...
by Puffer
Mon Mar 14, 2011 7:51 am
Forum: Wireless Networking
Topic: 1 routerboard 2 radio cards & same subnet
Replies: 0
Views: 439

1 routerboard 2 radio cards & same subnet

Is is possible to have a Station and AP each on thier own radio card on the same routerboard (rb133ah) using the same subnet ? (ie back haul & Access point) The equivalent of two CPE's back to back with a crossover cable link between them. (I even tried putting AP and eth2, and Stn and eth3 in two s...
by Puffer
Tue Jan 25, 2011 1:01 pm
Forum: General
Topic: L2TP on 4.16
Replies: 0
Views: 331

L2TP on 4.16

I have 6 x RB450G boards distributed across a 3rd party network. 5 act as L2TP remote clients and the L2TP server is located at my head office. They were all on 3.25 and have worked fine. Last night I tried to upgrade to 4.16 and the links will not re-establish. You can ping the server from the remo...
by Puffer
Wed Apr 28, 2010 5:26 pm
Forum: Scripting
Topic: using a built-in variable containing a hyphen
Replies: 2
Views: 1115

using a built-in variable containing a hyphen

I am using the bandwidth-test function to test a VPN link from a script in Winbox. {/tool bandwidth-test ###.###.##.### direction=both duration=10s protocol=tcp user=admin password=#### do={ :set TxL $duration}}; :log info $TxL The above gives me the final "duration" succesfully. However I actually ...
by Puffer
Mon Apr 26, 2010 2:15 pm
Forum: General
Topic: VoIP quality with VPN
Replies: 0
Views: 558

VoIP quality with VPN

I have home network and 5 satelite stores with a L2TP VPN link between RB450 boards to each store over a 3rd party wireless network. We use VoIP telephones between all sites with the SIP server on the home network. I test each link for speed using a 30 count ping with a 64 and a 1500 packet size eve...
by Puffer
Mon Apr 26, 2010 12:39 pm
Forum: Scripting
Topic: Time stamp for emailing
Replies: 4
Views: 2039

Re: Time stamp for emailing

Thank you, now I am pushing my luck !

Is there a way to format the date retrieved from the system to "dd mmm yyyy" ?
by Puffer
Thu Apr 22, 2010 2:53 pm
Forum: Scripting
Topic: Time stamp for emailing
Replies: 4
Views: 2039

Time stamp for emailing

Is there a way of logging the actual time in a script. I know the logging records the time and date of an entry. I am sending a delayed error message of when a link went down via an email and wish to store the time in a variable to be able to add to the email. ie :set Tdown Time( Now ) or something ...
by Puffer
Tue Mar 09, 2010 7:58 am
Forum: Scripting
Topic: Selective logging to different log files
Replies: 2
Views: 632

Selective logging to different log files

I have 5 different scripts testing 5 separate vpn links. At present I have succesfully scheduled and logged (with forum help) the results of these scripts to the "info" log in memory. I would like to log these results, each in its own file on my local ftp site. To give the service provider trending ...
by Puffer
Mon Mar 08, 2010 3:16 pm
Forum: Scripting
Topic: Running scripts with scheduler
Replies: 2
Views: 3305

Running scripts with scheduler

I have written a few small scripts to test ping success. Each works when pressing "Run Script" and the test result is placed in the log. Now I want to have schedule run the scripts every 1/2 hour. I am using Winbox as the console and when I put the script name in the "on event" window scheduler incr...