Community discussions

Search found 50 matches

by Centauri
Sat May 05, 2018 4:53 pm
Forum: Beginner Basics
Topic: Grouping/Routing multiple WAN IP's into LAN IP's
Replies: 3
Views: 412

Re: Grouping/Routing multiple WAN IP's into LAN IP's

I am not using PPPoE Its a big network for at Student dorm, where i have 9 VLAN's one for each Dorm. Where each student have a small router in each room a small HAP Lite. And now for the last VLAN i want to have multiple IP's for a Room, just like some ISP are doing. Like this example i found on the...
by Centauri
Sat May 05, 2018 2:09 pm
Forum: Beginner Basics
Topic: Grouping/Routing multiple WAN IP's into LAN IP's
Replies: 3
Views: 412

Re: Grouping/Routing multiple WAN IP's into LAN IP's

I thing i maybe could be to end op with something like this IP Subnet WAN : 195.135.71.2/27 Subnet : 255.255.255.224 Gateway : 195.135.71.1 LAN Pool IP : 195.135.71.32/27 Start IP : 195.135.71.34 End IP : 195.135.71.62 Subnet : 255.255.255.224 Broadcast IP : 195.135.71.63 Gateway : 195.135.71.33 But...
by Centauri
Sat May 05, 2018 1:48 pm
Forum: Beginner Basics
Topic: Grouping/Routing multiple WAN IP's into LAN IP's
Replies: 3
Views: 412

Grouping/Routing multiple WAN IP's into LAN IP's

Hi I Have a Setup where i have about 2000 Public LAN IP's witch are routet on one single WAN IP. Where i have a CCR1016-12S-1S+ as an router. Eg. First IP : 62.147.147.26/30 With additional IP underneath routing on the first IP. 195.129.71.0/24 195.130.71.0/24 195.131.71.0/24 195.132.71.0/24 195.133...
by Centauri
Sat Apr 22, 2017 3:53 pm
Forum: Scripting
Topic: C# API - tik4net on GitHub
Replies: 148
Views: 36358

Re: C# API - tik4net on GitHub

Try this
Dim cmd As ITikCommand = connection.CreateCommandAndParameters("/interface/ethernet/switch/mac-based-vlan/add", "src-mac-address","11:22:33:44:55:66", "new-customer-vid","14")
by Centauri
Sat Apr 15, 2017 12:48 am
Forum: Scripting
Topic: C# API - tik4net on GitHub
Replies: 148
Views: 36358

Re: C# API - tik4net on GitHub

Hi i have a problem with the API and creating parameters. When i do it manuel via the command line i use tool user-manager user add customer= admin username="test007" password="nigher" tool user-manager user create-and-activate-profile test007 profile=Always customer=admin Via the API i can create t...
by Centauri
Sun Apr 09, 2017 9:14 pm
Forum: Scripting
Topic: C# API - tik4net on GitHub
Replies: 148
Views: 36358

Re: C# API - tik4net on GitHub

It all most works . Key.Chain = firewallFilter.ChainType.Forward, Error BC30451 'Key' is not declared. It may be inaccessible due to its protection level. Error BC30980 Type of 'firewallFilter' cannot be inferred from an expression containing 'firewallFilter'. Just in case you want to update yor cod...
by Centauri
Sun Apr 09, 2017 11:52 am
Forum: Scripting
Topic: C# API - tik4net on GitHub
Replies: 148
Views: 36358

Re: C# API - tik4net on GitHub

have newer have much luck with such converts. It also gives some errors withe the lines Dim logs = connection.LoadList(Of Log)() Error BC30456 'LoadList' is not a member of 'ITikConnection'. Dim firewallFilter = New FirewallFilter() With { Error BC30002 Type 'FirewallFilter' is not defined. connecti...
by Centauri
Thu Apr 06, 2017 10:58 pm
Forum: Scripting
Topic: C# API - tik4net on GitHub
Replies: 148
Views: 36358

Re: C# API - tik4net on GitHub

Any chances that ther would come a VB.NET example on how to use the DLL.
I have worked with it for some time now without any luck.
by Centauri
Thu Apr 06, 2017 7:43 pm
Forum: Scripting
Topic: VB.NET Sample project for tik4net API
Replies: 0
Views: 581

VB.NET Sample project for tik4net API

Hi
I was wondering if someone have a working project or sample project using the tik4net .NET they could share?
Thay would be a big help for me to begin with, i can onley find projects with C#
So that i can be sure ewerything is set correct up.

Thanks Kim
by Centauri
Thu Dec 03, 2015 10:08 am
Forum: General
Topic: EOIP Tunnels, only tunnel id = 0 works - Fastpath allows pings (3 - RB953GS-5HnT)
Replies: 7
Views: 2010

Re: EOIP Tunnels, only tunnel id = 0 works - Fastpath allows pings (3 - RB953GS-5HnT)

I can confirm it works by disabling a filter rule. For me it was the default rule /ip firewall filter add action=drop chain=input comment="default configuration" in-interafce=ether1-gateway But then the next question is what rule do i have to make to allow the eoip tunnel to work because i assume th...
by Centauri
Wed Dec 02, 2015 12:04 pm
Forum: General
Topic: EOIP Tunnels, only tunnel id = 0 works - Fastpath allows pings (3 - RB953GS-5HnT)
Replies: 7
Views: 2010

Re: EOIP Tunnels, only tunnel id = 0 works - Fastpath allows pings (3 - RB953GS-5HnT)

I have tried a couple of firmware versions 6.29.1 and 6.33.2 and the problem is the same. Only then ID 0 is used its possible to get traffic thru. In Firmware 6.29.1 the FastPath option is not possible and there its also only works with TunnelID 0. In 6.33.2 it also only works with TunnelID 0. I hav...
by Centauri
Thu Jul 23, 2015 3:43 pm
Forum: General
Topic: Set Admin Password via Config File (Flashfig)
Replies: 8
Views: 1439

Re: Set Admin Password via Config File (Flashfig)

I have en MySQL database with all the Individual settings for each apartment, with the WAN IP, SSID and SSID Password. Then i have a VB script reading chose information and and and passes them in to a template config and replaces {SSID} and {SSIDKEY} alt other information with the values from the Da...
by Centauri
Wed Jun 17, 2015 4:27 pm
Forum: General
Topic: Set Admin Password via Config File (Flashfig)
Replies: 8
Views: 1439

Re: Set Admin Password via Config File (Flashfig)

In my setup its not necessary.
Management is blocked from the LAN Site.
And on the WAN site ist only allowed from an specific Subnet on an separate VLAN.
But else its right its best to make a new admin account wit another username.
by Centauri
Wed Jun 17, 2015 12:24 pm
Forum: General
Topic: Set Admin Password via Config File (Flashfig)
Replies: 8
Views: 1439

Re: Set Admin Password via Config File (Flashfig)

Thanks tomaskir that solved my problem.
by Centauri
Mon Jun 15, 2015 10:14 am
Forum: General
Topic: Set Admin Password via Config File (Flashfig)
Replies: 8
Views: 1439

Set Admin Password via Config File (Flashfig)

Is it possible to set the Admin password via a configuration script ? The password at within a normal backup file but not an exportet config file. I had hoped for an hashed password ore something like that. The problem is i need to configure 850 individual hAP Lite boxes with an custom config file s...
by Centauri
Fri Mar 13, 2015 11:21 am
Forum: General
Topic: Queue for Equal bandwidth sharing among users on multiple VLAN's
Replies: 2
Views: 931

Re: Queue for Equal bandwidth sharing among users on multiple VLAN's

Not sure that the right way. I have tried some playing around with simple queue's and them seems to limit each user to the among of tragic the are assigned to and not more. But what i want is the to total bandwidth is equally shared between the total number of active users. So that if 10 active user...
by Centauri
Fri Mar 13, 2015 10:28 am
Forum: General
Topic: Queue for Equal bandwidth sharing among users on multiple VLAN's
Replies: 2
Views: 931

Queue for Equal bandwidth sharing among users on multiple VLAN's

Hi i have a setup witch i have some problems with. I have an Cloud Core Router win an 2 Gbit Internet connection witch is share between 7 locations. I have created a VLAN and a bridge for each for each of the 7 locations. The Internet Connection is comming trough one og the SFP+ Ports and the LAN co...
by Centauri
Tue Feb 24, 2015 4:02 pm
Forum: General
Topic: Problem with multible VLAN's on Interface
Replies: 2
Views: 639

Re: Problem with multible VLAN's on Interface

Tanks a lot it was the bridging between the VLAN and the Bridge i was missing. Thanks
by Centauri
Tue Feb 24, 2015 3:42 pm
Forum: General
Topic: Problem with multible VLAN's on Interface
Replies: 2
Views: 639

Problem with multible VLAN's on Interface

Hi h have a Cloud Core Router CCR-1036 RouterOS 6.27 where i have some problems vidt multiple VLAN's and DHCP Assignment on each VLAN. The configuration have 10 different VLAN's one for each co location, almost each co location has public WAN IP Adresses ut at the moment i just test with the correnc...
by Centauri
Thu Jan 30, 2014 11:23 am
Forum: Beginner Basics
Topic: RB2011 and 2 separate LAN on 2 Bridged Interfaces don't work
Replies: 10
Views: 2154

Re: RB2011 and 2 separate LAN on 2 Bridged Interfaces don't

Oh sorry havend seen that.
Then there was a good explanation that i dident work.
Sorry for the trouble.

Thanks.
by Centauri
Wed Jan 29, 2014 4:07 pm
Forum: Beginner Basics
Topic: RB2011 and 2 separate LAN on 2 Bridged Interfaces don't work
Replies: 10
Views: 2154

Re: RB2011 and 2 separate LAN on 2 Bridged Interfaces don't

No my NAT and routing is right the way it is. You dont have to make NAT for each subnet for it to work. I dont know why, but after i cleaned my my code with better names it seems to be working. Very stange. Bit is case any other get the same problem her is my config. /interface bridge add l2mtu=1598...
by Centauri
Wed Jan 29, 2014 2:49 pm
Forum: Beginner Basics
Topic: RB2011 and 2 separate LAN on 2 Bridged Interfaces don't work
Replies: 10
Views: 2154

Re: RB2011 and 2 separate LAN on 2 Bridged Interfaces don't

Again all DHCP options is right, i get the right IP, Subnet, DNS and GW informatiosn on both interfaces so thats all right. The strange thing ewerything is working on the Work bridged network On the Family bridge i still get the correct IP And ewerything for that network but the only thing working i...
by Centauri
Wed Jan 29, 2014 1:59 pm
Forum: Beginner Basics
Topic: RB2011 and 2 separate LAN on 2 Bridged Interfaces don't work
Replies: 10
Views: 2154

Re: RB2011 and 2 separate LAN on 2 Bridged Interfaces don't

Is a wrote DHCP is working as it should i get the corect IP Adresses on each bridged interface. So everything i working there. The only problem is that on my family network i dont have access to the internet. It work on the Work part. The bridged interfaces have the right IP Adresses and DHCP Settin...
by Centauri
Wed Jan 29, 2014 1:26 pm
Forum: Beginner Basics
Topic: RB2011 and 2 separate LAN on 2 Bridged Interfaces don't work
Replies: 10
Views: 2154

Re: RB2011 and 2 separate LAN on 2 Bridged Interfaces don't

This i the default config where i have just separated the 2 sides of ports of the router and made a separate bridge. No havent made anything special to nat and masquerade both IP-ranges with the WAN But shouldent the default role not take care of that [code2=ros]/ip firewall nat add action=masquerad...
by Centauri
Wed Jan 29, 2014 12:33 pm
Forum: Beginner Basics
Topic: RB2011 and 2 separate LAN on 2 Bridged Interfaces don't work
Replies: 10
Views: 2154

RB2011 and 2 separate LAN on 2 Bridged Interfaces don't work

Hi i am trying to configure a RB2011 2HnD o have to separate Subnets, so that's there one for Work and one for the Family so that i cam make separate rules for the LAN to the Family so that they only are allowed to use the internet until a specific time at night. The RB have 10 Ports Port 1 : WAN Co...
by Centauri
Sat Oct 16, 2010 9:21 pm
Forum: Beginner Basics
Topic: Blocking the use of other DNS Servers than the one in RB
Replies: 25
Views: 12935

Re: Blocking the use of other DNS Servers than the one in RB

Hi dssmiktik Your rule seems to work now, dont know that ore why since i havend made any changes. Now it uses the internal and static dns even if the client has entered a static DNS of an external server. So can only sat thanks a lot for your greate help. Now i only need to get my VPN problem http:/...
by Centauri
Thu Oct 14, 2010 10:52 pm
Forum: Beginner Basics
Topic: Blocking the use of other DNS Servers than the one in RB
Replies: 25
Views: 12935

Re: Blocking the use of other DNS Servers than the one in RB

Yes the traffic by the Nat Rule is counting so traffic is coming to it. And have found out that it’s only counting bytes then I use other DNS Servers than the RB itself, so some part of the rule works. I use a RB450G with Software Version 4.11 I am also having this config in the box Equal bandwidth ...
by Centauri
Thu Oct 14, 2010 5:51 pm
Forum: Beginner Basics
Topic: Blocking the use of other DNS Servers than the one in RB
Replies: 25
Views: 12935

Re: Blocking the use of other DNS Servers than the one in RB

Thats also the way i had created the rule, but i am still afraid its not working quite as it should. When i test it by giving at computer a static address and set the DNS Server to eg. OpenDNS 208.67.222.222 and 208.67.220.220 Then when i monitor the Firewall Connections i can se my local IP connect...
by Centauri
Thu Oct 14, 2010 10:07 am
Forum: Beginner Basics
Topic: Site 2 Site VPN from RB to other Router (Routing problem)
Replies: 2
Views: 1283

Re: Site 2 Site VPN from RB to other Router (Routing problem

Hi My configs is mate like then following 192.168.200.0/24 ------- RB450G ---------- Internet ---------- Trustgate 160 ------- 192.168.10.0/24 /ip ipsec policy add action=encrypt comment="" disabled=no dst-address=192.168.10.0/24:any \ ipsec-protocols=esp level=require priority=0 proposal=default pr...
by Centauri
Wed Oct 13, 2010 8:38 pm
Forum: Beginner Basics
Topic: Blocking the use of other DNS Servers than the one in RB
Replies: 25
Views: 12935

Re: Blocking the use of other DNS Servers than the one in RB

Thanks that solved the problem with the "Torrent" in the DNS.

Now I only need to get solved my last problem for force the users to use the RB as the DNS server so that they are now able to use any other DNS server like Open DNS ore things like that.
by Centauri
Wed Oct 13, 2010 5:34 pm
Forum: Beginner Basics
Topic: Site 2 Site VPN from RB to other Router (Routing problem)
Replies: 2
Views: 1283

Site 2 Site VPN from RB to other Router (Routing problem)

Hi I have tried to configure a VPN from my RB450G v4.11 to a Trustgate 160 Firewall using this guide witch is for a Zywall and have just changed the required configurations so that the matched in moth ends. http://www.potato-people.com/blog/2009/10/ipsec-vpns-for-mikrotik-routeros/ The Tunnel is up ...
by Centauri
Tue Oct 12, 2010 10:35 pm
Forum: Beginner Basics
Topic: Blocking the use of other DNS Servers than the one in RB
Replies: 25
Views: 12935

Re: Blocking the use of other DNS Servers than the one in RB

I actually have those entries too, forgot to mention that. I have tried to analyse my network traffic and think i have found a possible way those entries come. It seems like them comes when i eg. ping www.bittorrent.com then i get the correct IP Back Reply from 208.72.192.133: bytes=32 time=166ms TT...
by Centauri
Tue Oct 12, 2010 6:06 pm
Forum: Beginner Basics
Topic: Blocking the use of other DNS Servers than the one in RB
Replies: 25
Views: 12935

Re: Blocking the use of other DNS Servers than the one in RB

My problem is that i even as i have the above rules to block for torrents and other stuff sometimes have those entries in my DNS list of the router. With the above rules the access to utorrent should be blocked. With my own machine I can’t ping or access the website or anything and nothings shows up...
by Centauri
Tue Oct 12, 2010 5:43 pm
Forum: Beginner Basics
Topic: Blocking the use of other DNS Servers than the one in RB
Replies: 25
Views: 12935

Re: Blocking the use of other DNS Servers than the one in RB

Hi dssmiktik I have tried with your rule to only allow DNS from the clients to the Router itself But I don’t seems to work, when I enter the command it asks for chain: where I can shoes from dstnat and srcnat And I will only accept it then I chose dstnat. But the rule doesn’t seems to work. Bacause ...
by Centauri
Sat Oct 09, 2010 4:57 pm
Forum: Beginner Basics
Topic: Blocking the use of other DNS Servers than the one in RB
Replies: 25
Views: 12935

Re: Blocking the use of other DNS Servers than the one in RB

Okay Thanks

I just assumed that the blocking with those rules only were possible then using the RB as DNS server.

Must say that the strengths in the RB impress me more and more.
by Centauri
Sat Oct 09, 2010 4:49 pm
Forum: Beginner Basics
Topic: Blocking the use of other DNS Servers than the one in RB
Replies: 25
Views: 12935

Blocking the use of other DNS Servers than the one in RB

Hi I have found a config to block the access for specific websites which work well. ip firewall layer7-protocol add comment="" name=p2p_www regexp="^.*(get|GET).+\ (torrent|thepiratebay|isohunt|entertane|demonoid|btjunkie|mininova|flixflux|vertor|h33t|\ zoozle|bitnova|bitsoup|meganova|fulldls|btbot|...
by Centauri
Tue Oct 05, 2010 8:39 pm
Forum: Beginner Basics
Topic: How to setup Dual Wan with only incoming on second interface
Replies: 14
Views: 4157

Re: How to setup Dual Wan with only incoming on second inter

I have tried with the example from ” Standard Policy-Based Routing with Failover” and modified for my setup. But I doesn’t work, I then have no access out or inn. ip firewall mangle add src-address=95.154.16.0/24 action=mark-routing new-routing-mark=net2 chain=prerouting ip firewall mangle add src-a...
by Centauri
Mon Oct 04, 2010 9:43 am
Forum: Beginner Basics
Topic: How to setup Dual Wan with only incoming on second interface
Replies: 14
Views: 4157

Re: How to setup Dual Wan with only incoming on second inter

How should a VLAN and a management switch solve my problem. My problems seems to be a routing problem, to get the outgoing traffic out of the same interface on which it was received. It should be possible to solve somehow since every other Firewall with Dual ore treble WAN I have worked with has no ...
by Centauri
Sun Oct 03, 2010 10:17 pm
Forum: Beginner Basics
Topic: How to setup Dual Wan with only incoming on second interface
Replies: 14
Views: 4157

Re: How to setup Dual Wan with only incoming on second inter

It seems that the problem is that the traffic isn’t send back thru the right interface. I have tried to make a static route that all traffic from the external server I am using for testing is sending it thru the gateway to interface WAN 2. Now I can connect to my web server on the static IP of WAN 2...
by Centauri
Fri Oct 01, 2010 4:20 pm
Forum: Beginner Basics
Topic: How to setup Dual Wan with only incoming on second interface
Replies: 14
Views: 4157

Re: How to setup Dual Wan with only incoming on second inter

Hi I am not sure about what connection tracking is, but this should be the most important things in my config. I can see in the Firewall / Nat Bytes and Packages that data is received when I try to connect to my Web server on the public IP of WAN2 but it’s not able to display the page. When I do the...
by Centauri
Thu Sep 30, 2010 9:33 am
Forum: Beginner Basics
Topic: How to setup Dual Wan with only incoming on second interface
Replies: 14
Views: 4157

Re: How to setup Dual Wan with only incoming on second inter

I have 2 public IP addresses in 2 separate subnets. They are from 2 different ISP,’s. And since I have got a new and much faster connection I want to have everything to that but, since some customers still have the old address in their application I want to be able to still use my old connection jus...
by Centauri
Wed Sep 29, 2010 9:28 pm
Forum: Beginner Basics
Topic: How to setup Dual Wan with only incoming on second interface
Replies: 14
Views: 4157

How to setup Dual Wan with only incoming on second interface

I have a RB450G SW. V.4.10 I have now for the last 2 days tried to set it up to use 2 WAN interfaces with no luck. I can only get connection thru the first interface and no connection on the second. I can from external also only ping the first interface but not the second one. So was wondering if so...
by Centauri
Wed Jul 07, 2010 9:10 am
Forum: Beginner Basics
Topic: From LAN to LAN via WAN not working (Local loopback) Problem
Replies: 4
Views: 1885

Re: From LAN to LAN via WAN not working (Local loopback) Pro

Thanks Found a solution that worked with the following commands ip firewall nat add chain=dstnat action=dst-nat to-addresses=192.168.200.101 protocol=tcp dst-address=!192.168.200.0/24 dst-address-type=local dst-port=80 ip firewall nat add chain=srcnat action=masquerade src-address=192.168.200.0/24 o...
by Centauri
Tue Jul 06, 2010 1:09 pm
Forum: Beginner Basics
Topic: From LAN to LAN via WAN not working (Local loopback) Problem
Replies: 4
Views: 1885

From LAN to LAN via WAN not working (Local loopback) Problem

Hello I have a problem with my RB450G with RouterOS 4.10. I have a Domain Name where all records lead to my Public IP, where I e.g. have a Web Server. All external users can get access to my Web Server without any problem. So my routing, DNS and NAT I okay. But I have at problem when I have a machin...
by Centauri
Tue Jun 15, 2010 2:08 pm
Forum: Beginner Basics
Topic: Updates for RouterBoard 450G
Replies: 2
Views: 959

Re: Updates for RouterBoard 450G

Thanks

I just got confused about the Version numbering, but yes now I can see that this one is newer, so will try to update it to Version 4.10

So thanks.
by Centauri
Tue Jun 15, 2010 12:53 pm
Forum: Beginner Basics
Topic: Updates for RouterBoard 450G
Replies: 2
Views: 959

Updates for RouterBoard 450G

Hi I have a RouterBoard 450G Level 5 with software Version 4.5 I have around in the forum read about Software Version 4.6 and 4.9 but can’t find any ware to download them. Om Mikrotik’s download page I can only find Version 3.30, 4.10 and 5.0 beta 2 So I was wondering if there is some special I have...
by Centauri
Mon Jun 07, 2010 3:56 pm
Forum: Beginner Basics
Topic: 2 WAN Addresses in same subnet with same gateway
Replies: 6
Views: 1834

Re: 2 WAN Addresses in same subnet with same gateway

My problem is that i don’t have static IP addresses i have to use to psychical ports since they are DHCP assigned and then locked to the MAC address.
by Centauri
Mon Jun 07, 2010 3:47 pm
Forum: Beginner Basics
Topic: 2 WAN Addresses in same subnet with same gateway
Replies: 6
Views: 1834

Re: 2 WAN Addresses in same subnet with same gateway

No i have a 25/4 Mbit connection so each IP will have to share the total bandwigth. But would like to have my normal Web and Mail connection running on the WAN1 for incoming Mail and Web Server and then be able to use WAN2 for testing other system for customers where I often have to have separate MX...
by Centauri
Mon Jun 07, 2010 11:15 am
Forum: Beginner Basics
Topic: 2 WAN Addresses in same subnet with same gateway
Replies: 6
Views: 1834

2 WAN Addresses in same subnet with same gateway

Hello I have got a RouterBoard 450G with RouterOS Level 5 and software version 4.5 and must say that I am very impressed about it and how easy it is to use. So I saw a lot of new opportunities and have now got to a problem which I hope someone can help me with. My problem I that I want to use 2 port...