Community discussions

Search found 179 matches

by petrn
Tue Apr 19, 2016 8:31 pm
Forum: General
Topic: v6.35 [current] is released!
Replies: 103
Views: 24692

Re: v6.35 [current] is released!

petrn - Thank you for link to tracker. We simply did forget to turn it off. Now it is done.
You are welcome. Can make request?: Make changelog downloadable, it's primary function is documentation replacement ...
[Edit] Or at least make release notes part of documentation wiki.
by petrn
Mon Apr 18, 2016 12:54 pm
Forum: General
Topic: v6.35 [current] is released!
Replies: 103
Views: 24692

Re: v6.35 [current] is released! Torrent?

Torrent? http://www.mikrotik.com/download/routeros-ALL-6.35.torrent .. @Mikrotik any update ? For crying out loud, for the last year or even more Mikrotik is hosting download versions in the cloud (Amazon as far as i can tell from IPs), they are not making any torrents and most probably never will,...
by petrn
Mon Apr 18, 2016 12:25 pm
Forum: General
Topic: v6.35 [current] is released!
Replies: 103
Views: 24692

Re: v6.35 [current] is released! Torrent?

by petrn
Sun Feb 15, 2015 3:23 pm
Forum: Scripting
Topic: [SOLVED] How to iterate only through interfaces that have a comment set?
Replies: 4
Views: 1401

Re: How to iterate only through interfaces that have a comment set?

Since recent versions, I think you need to use "any", i.e.
find where any comment
I wonder where is documentation for this, can Mikrotik enlighten me?
by petrn
Mon Apr 15, 2013 7:51 am
Forum: Virtualization
Topic: 各位外国朋友好。
Replies: 2
Views: 2869

Re: 各位外国朋友好。

嗨来自中国的朋友。是的,这是英语语言论坛。你能介绍更多的细节问题?
by petrn
Sat Mar 30, 2013 8:43 am
Forum: General
Topic: TSIG DNS Updates via Tool-DNS-Update
Replies: 4
Views: 1520

Re: TSIG DNS Updates via Tool-DNS-Update

ros code

:local ddnsip [ /ip address get [ /ip address find interface="pppoe-out2" ] address ]
:local ddnsip [:pick $ddnsip 0 [:find $ddnsip "/" -1 ] ]
dns-update dns-server=213.208.150.185 name=martinstix zone=pluteus.net key="3wr0CDR1MaE*********" key-name=martinstix address=$ddnsip
by petrn
Sat Mar 09, 2013 8:37 pm
Forum: General
Topic: RB750 v5.4 cannot export compact
Replies: 3
Views: 610

Re: RB750 v5.4 cannot export compact

Upgrade to 5.12 or later might help
What's new in 5.12 (2012-Jan-19 14:31):
...
*) console - added support for compact export;
...
by petrn
Fri Mar 08, 2013 9:35 pm
Forum: Scripting
Topic: What is type ip-prefix
Replies: 8
Views: 2178

Re: What is type ip-prefix

What version of RouterOS are you using? I was using 5.22 for the tests above...
Interesting - i used 5.24, and yes 5.22 behaviour is different.
by petrn
Fri Mar 08, 2013 6:16 pm
Forum: Scripting
Topic: What is type ip-prefix
Replies: 8
Views: 2178

Re: What is type ip-prefix

I'm not certain, but I think the first example you gave is not valid, so it will always be false. Initially, I thought using :toip would work, but apparently not with the mask. The string is converted to a blank variable with a type of "nil" :toip converts string "192.168.0.10/32" to type ip-prefix...
by petrn
Thu Mar 07, 2013 12:00 am
Forum: General
Topic: DNS servers update fail.
Replies: 2
Views: 674

Re: DNS servers update fail.

/ip dns set servers=[[/ip dhcp-client get [/ip dhcp-client find interface=Livas-gateway] primary-dns];[/ip dhcp-client get [/ip dhcp-client find interface=Livas-gateway] secondary-dns];[/ip dhcp-client get [/ip dhcp-client find interface=LTC-gateway] primary-dns];[/ip dhcp-client get [/ip dhcp-clie...
by petrn
Mon Mar 04, 2013 12:23 pm
Forum: Forwarding Protocols
Topic: how do i configure RIP for sxt in this scenario??
Replies: 14
Views: 3520

Re: how do i configure RIP for sxt in this scenario??

But when firewalls is off or disabled, maybe will happen security problems.
I guess that ping is not a main function of clientB, and BTW you enable ping in firewall settings and have firewall on.
by petrn
Mon Mar 04, 2013 11:17 am
Forum: Forwarding Protocols
Topic: how do i configure RIP for sxt in this scenario??
Replies: 14
Views: 3520

Re: how do i configure RIP for sxt in this scenario??

Perhaps firewall in ClientB is blocking ICMP ....
by petrn
Mon Mar 04, 2013 7:29 am
Forum: Forwarding Protocols
Topic: how do i configure RIP for sxt in this scenario??
Replies: 14
Views: 3520

Re: how do i configure RIP for sxt in this scenario??

now clientA could ping 192.168.1.1 & 192.168.10.1 & 192.168.10.2 & 192.168.2.1
but could not ping 192.168.2.254 (request timed out)
why??
Well, troubleshooting 101:
Can RouterB ping 192.168.2.254? Perhaps firewall in ClientB is blocking ICMP ....
by petrn
Sun Mar 03, 2013 5:00 pm
Forum: Forwarding Protocols
Topic: how do i configure RIP for sxt in this scenario??
Replies: 14
Views: 3520

Re: how do i configure RIP for sxt in this scenario??

BTW, i found bug: normal export works fine # /export /routing rip network add disabled=no network=0.0.0.0/0 compact export strips "network=0.0.0.0/0" # /export compact /routing rip network add and here is attempt to use compact export: [admin@routerA] /routing rip network> add network: interrupted v...
by petrn
Sun Mar 03, 2013 4:38 pm
Forum: Forwarding Protocols
Topic: how do i configure RIP for sxt in this scenario??
Replies: 14
Views: 3520

Re: how do i configure RIP for sxt in this scenario??

problem not solved completly now clinet 1 have ping of router C > ether1(192.168.2.1) but can't ping of Client 4(request timed out) You have to post some configurations and outputs from your routers. Here are my testbed configurations (all are almost bare minimum, there is way to get rid of 3 lines...
by petrn
Sat Mar 02, 2013 2:56 am
Forum: General
Topic: supout.rif
Replies: 4
Views: 891

Re: supout.rif

Supout.rif file doesn't have your passwords. You can see what the file contains, log into your mikrotik.com account, and use the online supout.rif viewer to check Which passwords we are talking about? I just tryed and i can see PPPoE in export section: /interface pppoe-client add add-default-route=...
by petrn
Sat Mar 02, 2013 1:16 am
Forum: General
Topic: Suspected Spam Issue
Replies: 10
Views: 1884

Re: Suspected Spam Issue

My laptop is using Norton internet security and Windows 8 so I m pretty much sure I could not have a virus on my laptop.
if you say so ...
Could anyone please help to sort this out as I am clueless
What about to run "Torch" on "ether1" to see what traffic is there.
by petrn
Fri Mar 01, 2013 9:33 pm
Forum: Forwarding Protocols
Topic: how do i configure RIP for sxt in this scenario??
Replies: 14
Views: 3520

Re: how do i configure RIP for sxt in this scenario??

Hi router B ether1 should be 192.168.1.2 (typo?), networks on wlan segments overlap, i think RIP will be confused.Use: router A wlan1=192.168.10.1/255.255.255.252 router C wlan1=192.168.10.2/255.255.255.252 router B wlan1=192.168.10.5/255.255.255.252 router D wlan1=192.168.10.6/255.255.255.252 and R...
by petrn
Fri Jun 08, 2012 3:14 pm
Forum: General
Topic: RouterOS v5.17 released
Replies: 47
Views: 16798

Re: RouterOS v5.17 released

When IDS/IPS modules (snort , psad ,fwsnort or ..) will be added to ROS? Just as an FYI - recently on the unofficial IRC channel a Vyatta developer mentioned that IPS (i.e. snort) will be deprecated in the upcoming VC6.4 release and removed in the following release. IDS was removed from Vyatta. Opt...
by petrn
Thu Jan 12, 2012 6:33 pm
Forum: General
Topic: Logging multiple topics to remote syslog
Replies: 2
Views: 932

Re: Logging multiple topics to remote syslog

Any reason why this doesn't work: [admin@mikrotik] /system logging> print Flags: X - disabled, I - invalid # TOPICS ACTION PREFIX 0 info memory 1 error memory 2 warning memory 3 critical echo 4 info remote error warning critical in rule 4 logical AND is applied, so message need to be in same time c...
by petrn
Sat Oct 01, 2011 6:36 pm
Forum: Beginner Basics
Topic: Usb to DC plug
Replies: 2
Views: 600

Re: Usb to DC plug

standard USB port is rated for 5V/500mA, i.e. 2.5W, so you going to need upconverter to 9-10V. It might theoreticaly work with small boards like RB750, but still i think it's not enough power.
by petrn
Mon Sep 26, 2011 1:39 pm
Forum: Forwarding Protocols
Topic: port forward
Replies: 3
Views: 2028

Re: port forward

if ssh connection to radiusbox works fine, then i would suspect firewall in radius, run 'service iptables stop' and try again.
by petrn
Sun Sep 25, 2011 10:11 pm
Forum: General
Topic: please help!! Gmail mailing config
Replies: 3
Views: 678

Re: please help!! Gmail mailing config

try
/tool e-mail set from="\"<Gateway>\" <xxxxxx@gmail.com>"
by petrn
Thu Sep 08, 2011 5:13 pm
Forum: General
Topic: Feature Request: OpenVPN [ovpn] udp tunnels
Replies: 250
Views: 90537

Re: Feature Request: OpenVPN [ovpn] udp tunnels

Thank for bringing up a thread more than a year old.
What about automatically locking topic after let say 6 months of inactivity?
by petrn
Wed Sep 07, 2011 10:09 pm
Forum: General
Topic: Hairpin NAT suddenly stopped working.
Replies: 5
Views: 1353

Re: Hairpin NAT suddenly stopped working.

then it will be really interesting to know what cause sudenly changed your "working Hairpin NAT" configuration, or maybe it wasn't working fine before?
by petrn
Sun Sep 04, 2011 11:18 pm
Forum: General
Topic: Reset RB 750GL with disabled Reset Switch
Replies: 3
Views: 3675

Re: Reset RB 750GL with disabled Reset Switch

have you tried to read 'Quick Guide' from http://routerboard.com/RB750GL (http://routerboard.com/pricelist/downlo ... ile_id=295)? You might find top of second page interesting.
by petrn
Sun Aug 21, 2011 9:22 pm
Forum: General
Topic: Last activity showing too much activity
Replies: 1
Views: 564

Re: Last activity showing too much activity

What could this activity be??
Activity is 15.97 and 15.17 hours of inactivity/silence.
by petrn
Fri Aug 19, 2011 8:12 pm
Forum: General
Topic: Let 4 ports share the 1 internet port; but not see each othr
Replies: 7
Views: 905

Re: Let 4 ports share the 1 internet port; but not see each

I think you meant:
add chain=forward connection-state=invalid action=drop
by petrn
Thu Aug 18, 2011 9:50 pm
Forum: General
Topic: Webproxy: Https
Replies: 5
Views: 973

Re: Webproxy: Https

This example covers all known Facebook addresses: Not really: http://bgp.he.net/AS32934#_prefixes : 66.220.144.0/21 66.220.152.0/21 66.220.159.0/24 69.63.176.0/21 69.63.184.0/21 69.171.224.0/20 69.171.239.0/24 69.171.240.0/20 69.171.255.0/24 74.119.76.0/22 204.15.20.0/22 http://bgp.he.net/AS32934#_...
by petrn
Thu Aug 18, 2011 9:39 pm
Forum: General
Topic: Clock Reset when Rebooting RB493AH
Replies: 7
Views: 4869

Re: Clock Reset when Rebooting RB493AH

That should go in as a feature request.
Mikrotik please add a battery like a cr2302 battery.
Without RTC chip pretty useless, and for devices supposedly 24/7 powered up for many years like mine RB133c just a headache with more contacts.
by petrn
Sat Aug 06, 2011 10:11 pm
Forum: Scripting
Topic: log the correct boot time
Replies: 8
Views: 1284

Re: log the correct boot time

NTP (not SNTP) client updates time in more than 5 minutes after startup - that's why people loose their graphs. uninstall NTP package - and all should be okay Mikrotik: there is simple solution to disapearing graphs - do not do any update/delete graphs if year is 1970. At least till mass production...
by petrn
Sat Aug 06, 2011 3:49 pm
Forum: General
Topic: DHCP IP Pool Lease - In reverse??
Replies: 23
Views: 14602

Re: DHCP IP Pool Lease - In reverse??

Yes I am currently using v5.5 and the reversing is still there !
Chupaka ask about behavior after reaching lowest IP from pool. Not about first allocation.
by petrn
Mon Aug 01, 2011 4:20 pm
Forum: Beginner Basics
Topic: Failover newbie question
Replies: 12
Views: 2374

Re: Failover newbie question

Very Simple! Does this example do load balancing?
what failover has to do with load balancing?
by petrn
Sun Jul 31, 2011 9:40 pm
Forum: Wireless Networking
Topic: how can 1x1 be MIMO??
Replies: 8
Views: 4950

Re: how cn 1x1 be MIMO??

even i thought i had to be SISO but then why Mikrotik has been advertising it as 1x1 MIMO?

Can we have some explanation on the 1x1 MIMO concept?

-sid
its 2x2 MIMO with chain 1 off on both sides ..., what is unclear in this?
by petrn
Sat Jul 30, 2011 1:24 pm
Forum: Wireless Networking
Topic: how can 1x1 be MIMO??
Replies: 8
Views: 4950

Re: how cn 1x1 be MIMO??

hi.

RB711 - Supports 1x1 MIMO

How can 1x1 be a MIMO??

-sid
well preciselly it should be RB711 - Supports 1x1 SISO, ref. http://en.wikipedia.org/wiki/MIMO. But can you imagine number of questions in this forum about this "new" technology?
by petrn
Sat Jul 30, 2011 11:15 am
Forum: General
Topic: DHCP IP Pool Lease - In reverse??
Replies: 23
Views: 14602

Re: DHCP IP Pool Lease - In reverse??

AJStevens, BTW unrelated to this issue: i just installed/configured dhcpd in RHEL v5.6, dhcp is http://isc.org/products/DHCP/ version 3.0.5, so pretty huge install base. And guess what: first allocated IP was from END . I never paid attention to this, as again - it doesn't matter. And i suggest to r...
by petrn
Sat Jul 30, 2011 11:04 am
Forum: RouterBOARD hardware
Topic: AR9380
Replies: 7
Views: 2518

Re: AR9380

I found this one: http://www.sparklan.com/product.php?fun ... rod_id=180, but this is miniPCIe, i.e. miniPCI Express card.

FYI: miniPCI and miniPCIe side to side: http://en.wikipedia.org/wiki/File:MiniP ... _cards.jpg
by petrn
Sat Jul 30, 2011 10:10 am
Forum: RouterBOARD hardware
Topic: AR9380
Replies: 7
Views: 2518

Re: AR9380

i think this will require upgrade to miniPCIe bus/slots, 450mbit/s is 50% of theoretical throughput of miniPCI. BTW I didn't found any 450mbit 3x3MIMO miniPCI card, someone got/seen this?
by petrn
Sat Jul 30, 2011 12:23 am
Forum: General
Topic: DHCP IP Pool Lease - In reverse??
Replies: 23
Views: 14602

Re: DHCP IP Pool Lease - In reverse??

You've missed the point here entirely, I'm saying it's highly unlikely to break anything given the kind of change it is, the only thing less likely to break anything is a cosmetic change, such as correcting a spelling mistake on a label in the webconfig screen for example. Correcting spelling mista...
by petrn
Fri Jul 29, 2011 3:38 pm
Forum: General
Topic: DHCP IP Pool Lease - In reverse??
Replies: 23
Views: 14602

Re: DHCP IP Pool Lease - In reverse??

Wow, the hostility at wanting a feature to behave more industry standard, yikes. I can't find any requirement about IP allocation direction in current http://www.rfc-editor.org/rfc/rfc2131.txt RFC2131-Dynamic Host Configuration Protocol, so i guess MT is standard/industry compliant. If you are sure...
by petrn
Thu Jul 28, 2011 1:10 am
Forum: Scripting
Topic: Need function
Replies: 3
Views: 681

Re: Need function

by petrn
Wed Jul 27, 2011 11:00 pm
Forum: General
Topic: RB450 rest the time after each restart
Replies: 8
Views: 993

Re: RB450 rest the time after each restart

what should I put for ntp-primary and secondary IP addresses? you can use 0.<zone>.pool.ntp.org and 1.<zone>.pool.ntp.org, zone is usualy 2 character ISO code of country (like 0.us.pool.ntp.org), but not all country codes works, try to resolve them first. Here is script to update NTP servers: http:...
by petrn
Wed Jul 27, 2011 9:13 pm
Forum: General
Topic: /user ssh-keys differs in 5.5 version
Replies: 2
Views: 578

Re: /user ssh-keys differs in 5.5 version

discussed many times here in forum: http://forum.mikrotik.com/viewtopic.php?f=2&t=53546
I would suggest clicking 'search' couple of times before 'newtopic'
by petrn
Wed Jul 27, 2011 9:00 pm
Forum: RouterBOARD hardware
Topic: rb 750g hardware ram upgrade
Replies: 18
Views: 5459

Re: rb 750g hardware ram upgrade

Youi can try so sandwich same 32MB memory chip on with some chipselect logic.
by petrn
Wed Jul 27, 2011 12:28 pm
Forum: General
Topic: Eth. port flapping, when is this going to be solved?
Replies: 78
Views: 9998

Re: Eth. port flapping, when is this going to be solved?

previous versions didn't log ethernet activities at all. the events probably happened just the same, and RouterOS noticed it just the same, but there was no log entry. this was only added in v5.1 or v5.2. maybe you had this problem forever, you will never find out by downgrading, as in older versio...
by petrn
Wed Jul 27, 2011 5:31 am
Forum: General
Topic: Eth. port flapping, when is this going to be solved?
Replies: 78
Views: 9998

Re: Eth. port flapping, when is this going to be solved?

If ESD is the culprit, I'll guess I have to live with it.
Have you considered roll back to previous version at least on some affected units? I mean version before disconnect problem appeared.
by petrn
Tue Jul 26, 2011 8:39 pm
Forum: RouterBOARD hardware
Topic: rb 750g hardware ram upgrade
Replies: 18
Views: 5459

Re: rb 750g hardware ram upgrade

As little bonus, you will have Gbit ports :) instead of FastEthernet 100Mbps that are currently sported by RB750.
urbinek has gigabit already :-) (RB750G)
by petrn
Sun Jul 24, 2011 8:52 am
Forum: General
Topic: version 5.5, serious BUG with SSH and keys
Replies: 3
Views: 1027

Re: version 5.5, serious BUG with SSH and keys

http://www.mikrotik.com/download/CHANGELOG_5 What's new in 5.0beta5 (2010-Jul-23 14:50): *) email - supports multiple CCs *) fix 5&10MHz channel support for 11n cards; *) ssh - fix ssh client crash; *) ssh - password authentication is disabled for users with public keys; *) ping - fixed ping packet...
by petrn
Sat Jul 23, 2011 10:09 pm
Forum: RouterBOARD hardware
Topic: rb 750g hardware ram upgrade
Replies: 18
Views: 5459

Re: rb 750g hardware ram upgrade

by petrn
Sat Jul 23, 2011 8:14 am
Forum: RouterBOARD hardware
Topic: Router Board with 2 Lan and at least one Memory Card
Replies: 14
Views: 1729

Re: Router Board with 2 Lan and at least one Memory Card

hi, thx for you answer, but i can't found memory slot on this board :
Slot is on other side, you can see that in User Guide : rb450GugA.pdf http://routerboard.com/RB450G
by petrn
Sat Jul 23, 2011 1:51 am
Forum: General
Topic: A rather strange problem
Replies: 2
Views: 539

Re: A rather strange problem

Hi,

try to disable default IP on ether1:
/ip address disable [find address="192.168.88.1/24"]
by petrn
Sat Jul 23, 2011 1:04 am
Forum: General
Topic: Transparent Bridge itself can't access the internet
Replies: 5
Views: 939

Re: Transparent Bridge itself can't access the internet

You got me again. I guess you're the one on the forum that doesn't post anything helpful but points out what everyone is doing wrong? One "helpfull" hint: no need guessing, click on my profile button and have look. Or you reflecting my disabled karma? EDIT: and may be instead of whinning about my a...
by petrn
Sat Jul 23, 2011 12:51 am
Forum: General
Topic: Transparent Bridge itself can't access the internet
Replies: 5
Views: 939

Re: Transparent Bridge itself can't access the internet

Hi,

you are not n00b here from number of posts, so may be you might notice that questions with relevant portions of configuration and/or network diagram have better answers. It's really unnecessary to have first answer to post request for more info as fewi is frequently posting.
by petrn
Sat Jul 23, 2011 12:31 am
Forum: General
Topic: Transparent Bridge itself can't access the internet
Replies: 5
Views: 939

Re: Transparent Bridge itself can't access the internet

Hi

long story short - what about learning about how TCP/IP works and configuring dhcp client on bridge interface or assigning IP to bridge interface in "/ip address" and default gateway in "/ip routes".
by petrn
Fri Jul 22, 2011 12:41 pm
Forum: General
Topic: ROS 5.x release notes.
Replies: 13
Views: 5396

Re: ROS 5.x release notes.

For normal wifi in 2,4 they changed the name from 2.4ghz-b/g to 2ghz-b/g When they change the syntax, it should have a very strong reason. it is not just 2.4GHz, it is just 2GHz band as oyu can set 2.2GHz and up to 2.5GHz (depending on wifi module) and depending on what your regulatory domain allow...
by petrn
Fri Jul 15, 2011 12:20 pm
Forum: Wireless Networking
Topic: Wireless ACL + client-tx-limit
Replies: 2
Views: 1973

Re: Wireless ACL + client-tx-limit

Hello. I have something like that: /interface wireless access-list add ap-tx-limit=4000000 authentication=yes client-tx-limit=1000000 comment="" disabled=no forwarding=no interface=wlan1 mac-address=00:15:6D:xx:xx:xx management-protection-key="" private-algo=none private-key="" private-pre-shared-k...
by petrn
Wed Jul 13, 2011 4:58 pm
Forum: General
Topic: ROS 5.4 SSH closes SSH connection immediately?!?
Replies: 4
Views: 1309

Re: ROS 5.4 SSH closes SSH connection immediately?!?

check if you have set public key for that user you are trying to authenticate with. Most probably, you do, and since 5.0rc2 it is not allowed to used password authentication if key is set, you have to use private key to authenticate. Short message "Password authentication not allowed" will stop lot...
by petrn
Wed Jul 13, 2011 3:53 pm
Forum: General
Topic: Firewall max concurrent connections
Replies: 2
Views: 723

Re: Firewall max concurrent connections

Why do you need connection tracking at all on a core router? Maybe my definition of a core router is different.
most likely this Great Wall firewall ...
by petrn
Wed Jul 13, 2011 3:50 pm
Forum: Scripting
Topic: Run script only working day
Replies: 6
Views: 1624

Re: Run script only working day

Make 7 schedulers, one for Monday with frequency set to 7 days, another one for Tuesday with frequency set to 7 days, and so on.
brute-force (more accurately brute-scheduler) solution :-D
by petrn
Wed Jul 13, 2011 2:08 pm
Forum: Scripting
Topic: Run script only working day
Replies: 6
Views: 1624

Re: Run script only working day

i need some scripts run from mon to fri only! and sat & sun run another scripts. anyone help....Please! :) Just ideas: 1. Find/create: http://<FQDN>/is-today-working-day and use /tool fetch url=http://<FQDN>/is-today-working-day at beginning of script to test if run or skip rest ... 2. Run daily sc...
by petrn
Wed Jul 13, 2011 11:35 am
Forum: General
Topic: ROS 5.x release notes.
Replies: 13
Views: 5396

Re: ROS 5.x release notes.

Welcome to ROS! MT have stated many times that they wont release complete changlogs as they think it's impossible despite every other vendor managing to do so
Apple approach - they think you don't need it :-)
by petrn
Wed Jul 13, 2011 10:27 am
Forum: Scripting
Topic: how to stop a scheduled script after x times?
Replies: 33
Views: 6897

Re: how to stop a scheduled script after x times?

Also, scan will only show possible interference from 802.11 networks. Stuff that are just noisy in the area will not be revealed. So better look at /interface wireless spectral-scan I am not disagreeing in that a spectral-scan is doing a better job. Somebody already mentioned to have a spectrum sca...
by petrn
Tue Jul 12, 2011 12:36 am
Forum: Scripting
Topic: Please help with a very simple script [SOLVED]
Replies: 12
Views: 1644

Re: Please help with a very simple script [SOLVED]

Hello, there is still a problem:

The script didn't run on the schedule, here is a screenshot:\

Thanks for ur help//
It will run exactly as scheduled, in -41.5 years.
by petrn
Tue Jul 12, 2011 12:26 am
Forum: General
Topic: If one route stopped
Replies: 9
Views: 1571

Re: If one route stopped

Actually, I can not use PING for gateway checking as my ISP will selectively filter out ICMP echo requests in case of "network overload" and they insist that PINGing the default gateway for network condition checking is bad thing to have. and what about ARP: /ip route add disabled=no distance=1 dst...
by petrn
Sun Jul 10, 2011 11:49 am
Forum: General
Topic: Firmware goes backwards?
Replies: 7
Views: 1061

Re: Firmware goes backwards?

I have a RouterBoard 532 that I just upgraded from 4.something to 5.5. Checking the firmware level, it says: current-firmware: 2.5 upgrade-firmware: 2.18 It said the same thing before I upgraded it, too. I thought the upgrade-firmware was expected to be equal to or higher than the current-firmware....
by petrn
Sat Jul 09, 2011 9:03 pm
Forum: General
Topic: Problem with static route and bgp route
Replies: 5
Views: 636

Re: Problem with static route and bgp route

Yes. The screenshot indicated the BGP route is reachable and has a lower AD than the static route, so it should be active.

Email support.
rest of routing table is hidden, i think problem is in scope/target scope and nexthop
by petrn
Sat Jul 09, 2011 9:00 pm
Forum: RouterBOARD hardware
Topic: OmniTIK and RB711-2n
Replies: 114
Views: 54434

Re: OmniTIK and RB711-2n


I dont understand why people clamor for solutions when they already exist.
because they are lazy/don't want to search, read, think, try or pay ... or they are actually smart ?
by petrn
Sat Jul 09, 2011 8:54 pm
Forum: RouterBOARD hardware
Topic: SXT reflector - 154mbps TCP
Replies: 68
Views: 23300

Re: SXT reflector

New record with SXT 154mbps TCP.
how can u add the traffic on ether1 and wlan1 it is incorrect. ur ether1 is only recieving what ur wlan1 is transmitting.
he added wlan1 TX and RX - same way as MT do when they claim RB-SXT 200mbps

now i doubt ur case ;-)
and i doubt yours
by petrn
Sat Jul 09, 2011 6:03 pm
Forum: RouterBOARD hardware
Topic: Power use of a RB433
Replies: 23
Views: 3051

Re: Power use of a RB433

The 485m AC cable is an aside. Let's get back to the basics. The problem install has 21m of 10mm cable. DC 15V 10A PSU don't want to drive RB433 so nicely, yet DC 24V 4A PSU drives RB433 very nicely. To make things more complicated, DC 15C 10A PSU works well on the bench. On the bench with 21m of c...
by petrn
Sat Jul 09, 2011 4:39 pm
Forum: RouterBOARD hardware
Topic: Power use of a RB433
Replies: 23
Views: 3051

Re: Power use of a RB433

That is why we run thick, shielded wires (6mm or 10mm for example)... WOW! I'm not a metric wire user, but the conversion on those sizes is not logical. That is some BIG stuff. 6mm = 2 AWG (1/4" diameter conductor) 10mm = 3/0 AWG (almost 1/2" in diameter conductor) Are you sure that is the wire you...
by petrn
Sat Jul 09, 2011 1:41 pm
Forum: RouterBOARD hardware
Topic: Power use of a RB433
Replies: 23
Views: 3051

Re: Power use of a RB433

As you say, but Ampere's Law also comes into play, so even if you are running that excellent new UBNT double shielded cable, there is still a magnetic field around the cable that causes complete and utter chaos with nearby two way radio antennas. I have seen this more than once on sites. i referred...
by petrn
Sat Jul 09, 2011 1:16 pm
Forum: General
Topic: If one route stopped
Replies: 9
Views: 1571

Re: If one route stopped

how goes the line from gateway=192.168.1.1 to gateway=192.168.2.1 if 192.168.1.1 stopped route with 192.168.1.1 will become invalid, so next valid route (based on distance) will be used ... You need to post more details: Specific answers require specific questions. When in doubt, post the output of...
by petrn
Sat Jul 09, 2011 4:14 am
Forum: Wireless Networking
Topic: Home Wifi Build
Replies: 7
Views: 884

Re: Home Wifi Build

Two cards is usually overkill for home use. Also, if you are not sure what you are doing you can interfere with yourself and actually hurt your speeds more than you help them. Not necessarily: i had been using 5Ghz N-only with two chains for Macbook Air (270mbit link speed) and 2.4Ghz B/G for legac...
by petrn
Sat Jul 09, 2011 3:48 am
Forum: General
Topic: If one route stopped
Replies: 9
Views: 1571

Re: If one route stopped

not working?
working for me ....
by petrn
Sat Jul 09, 2011 3:47 am
Forum: RouterBOARD hardware
Topic: Power use of a RB433
Replies: 23
Views: 3051

Re: Power use of a RB433

Am I missing something blatantly obvious here?
Voltage drop on power wire - you can't beat Ohm's law.

Edit: May be IEEE PoE or passive PoE(used by MT) is not as bad as you think - designed to work over 100m of 4 wires of UTP.
by petrn
Sat Jul 09, 2011 3:24 am
Forum: Wireless Networking
Topic: PPPOE-Out to specific DSL router? specify by ip address?
Replies: 3
Views: 689

Re: PPPOE-Out to specific DSL router? specify by ip address?

I have two adsl routers connected to two mikrotiks. so basically both adsl routers are connected to each other. both routers are currently in Router mode. meaning the adsl routers dial the pppoe connection to my providers. Now for some weird reason, the adsl connection (to my provider) of one route...
by petrn
Fri Jul 08, 2011 11:20 am
Forum: RouterBOARD hardware
Topic: RB411UAHR 3G Antenna???
Replies: 5
Views: 1473

Re: RB411UAHR 3G Antenna???

Hi,

read DJHiPs post again, there is NO 3G radio on RB411UAHR at all
by petrn
Fri Jul 08, 2011 11:12 am
Forum: RouterBOARD hardware
Topic: SXT that we would like
Replies: 39
Views: 4148

Re: SXT that we would like

calculate it in wifi calculator. He's lying. Such signals are not real 5 km.
just tried http://www.radiolabs.com/stations/wifi_calc.html, sounds plausible to me...
May be your calc is lying.
by petrn
Fri Jul 08, 2011 10:37 am
Forum: General
Topic: Feature request: OpenFlow protocol! Cutting edge feature
Replies: 20
Views: 6904

Re: Feature request: OpenFlow protocol! Cutting edge feature

How amazing would it be to have inexpensive network gear that has these capabilities? MikroTik brought MPLS to the working man and turned up the heat on the big vendors. Why not this? If not this, what? Ever heard of Anagran? http://www.anagran.com/ guess this FR-1000 price is in 10-20k$? Why you d...
by petrn
Fri Jul 08, 2011 9:35 am
Forum: Scripting
Topic: how to stop a scheduled script after x times?
Replies: 33
Views: 6897

Re: how to stop a scheduled script after x times?

I have a new request now. that is nice I am looking for a script that can do a remote wireless scan on a CPE and print the results in either a log (and than to file) or to a file to be saved on disk (or to be send by e-mail after CPE is back on line) this is same problem as in http://forum.mikrotik...
by petrn
Fri Jul 08, 2011 8:39 am
Forum: RouterBOARD hardware
Topic: SXT that we would like
Replies: 39
Views: 4148

Re: SXT that we would like

Yes. But we need cost efficient not low cost. If I'm in need of a 20db CPE I've to
pay the price. It does not help there is a low cost 16db if I need 20db.
use RB411 and http://en.jirous.com/antenna-5ghz/JC-320 - 20dBi?
by petrn
Fri Jul 08, 2011 8:24 am
Forum: General
Topic: HELP ... What Is The Best Way to Achieve Load Balancing??
Replies: 4
Views: 619

Re: HELP ... What Is The Best Way to Achieve Load Balancing?

Hi, seeing so many post about LoadBalancing, i think it's time for MT to develop simple config option similar to /interface bridge for LB, preferably with 0 (zero) configuration parameters, just list of interfaces to balance over. Seems that "Search" in forum or in wiki is completely useless ... :-(
by petrn
Fri Jul 08, 2011 6:53 am
Forum: General
Topic: CPU load via SNMP on x86 on 5.5
Replies: 3
Views: 2262

Re: CPU load via SNMP on x86 on 5.5

Hi,
I can't pull CPU stats via SNMP on RouterOS 5.5 on the x86 platform.
you can:
.1.3.6.1.2.1.25.3.3.1.2.1
or
HOST-RESOURCES-MIB::hrProcessorLoad.1
It doesn't even show as a supported OID.
have look at output of this:
snmpwalk -v 2c -c public <router IP>
by petrn
Thu Jul 07, 2011 11:01 am
Forum: RouterBOARD hardware
Topic: Wireless N card help
Replies: 13
Views: 1319

Re: Wireless N card help

Hi!
Could you tell me which is the huge difference please?

Thanks

Regards
If you don't understand logarithmic scale, then don't use it.
Convert dBm to mW... for bigger impression
by petrn
Thu Jul 07, 2011 12:17 am
Forum: General
Topic: NTP Client
Replies: 16
Views: 2572

Re: NTP Client

Hi, i have this script scheduled once in month or two: # ROS V5.5 # once in some time lets use some other NTP servers # pick your country code (but not all works): :local region "us" :local ntp1 [:resolve ("0.".$region.".pool.ntp.org")] :local ntp2 [:resolve ("1.".$region.".pool.ntp.org")] /system n...
by petrn
Wed Jul 06, 2011 10:58 pm
Forum: General
Topic: PCoIP Dst NAT for VMWare View
Replies: 4
Views: 2975

Re: PCoIP Dst NAT for VMWare View

Additionally, but not mentioned in the instructional, is that https:443:tcp also needs forwarded also for the initial connection. I have no experience with View, but i would run this: 1. torch/sniffer on inside/outside interfaces 2. sniff communication between devices without firewall/nat this migh...
by petrn
Mon Jul 04, 2011 10:02 am
Forum: General
Topic: If one route stopped
Replies: 9
Views: 1571

Re: If one route stopped

Hi,
/ip route
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out1
add disabled=no distance=3 dst-address=0.0.0.0/0 gateway=pppoe-out2
add disabled=no distance=5 dst-address=0.0.0.0/0 gateway=pppoe-out3
add disabled=no distance=7 dst-address=0.0.0.0/0 gateway=pppoe-out4
by petrn
Wed Jun 29, 2011 8:19 pm
Forum: RouterBOARD hardware
Topic: Jumbo Frames: MIPS RB hardware support?
Replies: 13
Views: 7497

Re: Jumbo Frames: MIPS RB hardware support?

I also am happy with my 750G that I carry around because it just allows me more than 100mbit when I occasionally need it (someone plugs a laptop in at a meeting and we transfer a large file or two). You have wasted $80 - cheapest 2 port switch is patchcord or crossed cable (if nobody supports MDI-X...
by petrn
Wed Jun 29, 2011 6:41 pm
Forum: Virtualization
Topic: RB450G + openwrt Metarouter strange problem
Replies: 221
Views: 76546

Re: RB450G + openwrt Metarouter strange problem

What routerboards actually work consistently with metarouter? Any model I have ever tried it on is unstable. i have running RB433AH, RB1000, RB800 on my table that are not rebooting. All of them have at least one metarouter guest running that is RouterOS. Also, all have 32MB of RAM assigned, since ...
by petrn
Wed Jun 29, 2011 10:10 am
Forum: RouterBOARD hardware
Topic: RouterBOARD Groove
Replies: 96
Views: 23678

Re: RouterBOARD Groove

funny but most people love that these things are included in the package without any additional charge (compared to other similar products),
so it's calculated already in price, then version without should be cheaper...
by petrn
Tue Jun 28, 2011 7:14 pm
Forum: General
Topic: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and v6)
Replies: 62
Views: 15174

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

It's crazy to use 5.x this early as corerouter. We just upgraded one of our
corerouters to 4.17.
Very true, i would expand that to production networks even it makes Normis jump.
by petrn
Tue Jun 28, 2011 6:29 pm
Forum: RouterBOARD hardware
Topic: [ask] how much speed cpu ....
Replies: 5
Views: 1154

Re: [ask] how much speed cpu ....

Hi, seems nobody is interested in real testing, i've asked some numbers i am interested in this post http://forum.mikrotik.com/viewtopic.php?p=267589#p267589 but everybody is obsessed with just switching speed. Seems that i will have to setup my own testbed. I have RB450G with 100mbit/s, 100mbit/s a...
by petrn
Tue Jun 28, 2011 5:55 pm
Forum: Scripting
Topic: How to send backup files of RouterOS5 to linux tftp server ?
Replies: 6
Views: 4822

Re: How to send backup files of RouterOS5 to linux tftp serv

What i do wrong ?
You are not posting enough information, error message appears when you do backup or trying to email it?
by petrn
Tue Jun 28, 2011 5:31 pm
Forum: General
Topic: MUM in US
Replies: 1
Views: 373

Re: MUM in US

Hi,

keep eye on http://mum.mikrotik.com/ or monitor it via http://www.changedetection.com

EDIT: or get involved and organize one :-)
by petrn
Tue Jun 28, 2011 3:44 pm
Forum: Scripting
Topic: DEC to HEX script
Replies: 11
Views: 2999

Re: DEC to HEX script

Hi, one more compact version without modifiyng $dec , bit less readable: :local dec 3735928559 # set this to number of hex digit you want :local hexdigit 8 :local hex "" :for i from=0 to=(4*($hexdigit-1)) step=4 do={ :set hex ([:pick "0123456789ABCDEF" (($dec>>$i)&0xf) ((($dec>>$i)&0xf)+1)].$hex) } ...
by petrn
Tue Jun 28, 2011 3:20 pm
Forum: Scripting
Topic: DEC to HEX script
Replies: 11
Views: 2999

Re: DEC to HEX script

Hi why you messing with :if's?: :local dec 3735928559 # set this to number of hex digit you want :local hexdigit 8 :local nibble :local hex "" :for i from=1 to=$hexdigit step=1 do={ :set nibble ($dec&0xf) :set hex ([:pick "0123456789ABCDEF" $nibble ($nibble+1)].$hex) :set dec ($dec>>4) } :log info (...
by petrn
Sat Jun 25, 2011 7:31 am
Forum: Scripting
Topic: DEC to HEX script
Replies: 11
Views: 2999

Re: DEC to HEX script

Hi,

basic idea for one HEX number, byte and longer needs loop and MODULO 16:
:local nibble 13
:log info ("HEX 0x".[:pick "0123456789ABCDEF" $nibble ($nibble+1)])
by petrn
Tue Jun 21, 2011 1:28 am
Forum: Beginner Basics
Topic: Can't access any external ftp server #2
Replies: 3
Views: 2701

Re: Can't access any external ftp server #2

I had to open an another topic, because the previous had been locked (without a solution).
Have you been waiting 5 years for solution? I call that patience ... :-)
by petrn
Tue Jun 21, 2011 1:15 am
Forum: General
Topic: Multilink PPPoE, Excessive Rx Errors and Drops
Replies: 9
Views: 3072

Re: Multilink PPPoE, Excessive Rx Errors and Drops

Hi,

i am assuming that ADSL connection is to ISP, does this ISP supports PPPoE bundling by MLPPP?
Post output of /ip address, /interface pppoe-client monitor [find] and other related configs.
by petrn
Tue Jun 21, 2011 1:13 am
Forum: The User Manager
Topic: Remove false active sessions via script
Replies: 8
Views: 8382

Re: Remove false active sessions via script

Hi,

isn't $i what you looking for?
by petrn
Sun Jun 19, 2011 1:05 am
Forum: Scripting
Topic: [ASK] how to log ping time result
Replies: 10
Views: 4361

Re: [ASK] how to log ping time result

Hi,

solution is here: http://wiki.mikrotik.com/wiki/MikroTik_ ... e_Requests
Edit and pray that more people will request this feat.
by petrn
Sun Jun 19, 2011 12:59 am
Forum: Scripting
Topic: how to stop a scheduled script after x times?
Replies: 33
Views: 6897

Re: how to stop a scheduled script after x times?

Copied your script in terminal and the result is: Scheduler starts script "A" every 3 secs Script "A" runs every 3 secs filling my log with the messages (I can remove that from the script, no problem.) and counter runs up. Script "B" runs and did show the run number 1 to 5 in the log but continous ...
by petrn
Sat Jun 18, 2011 6:20 pm
Forum: Scripting
Topic: Solution: Automatically clean expired User-Manager accounts
Replies: 72
Views: 45661

Re: Solution: Automatically clean expired User-Manager accou

Finally managed to code it, after a couple of sleepless nights! # # Important: !! MAKE SURE THAT YOUR CLOCK DATE IS SET CORRECTLY, AS THIS SCRIPT USES IT AS REFERENCE !! # # END OF FILE I think much safer that warning in comment is: :if ([/system ntp client get status]="synchronized") do={"original...
by petrn
Sat Jun 18, 2011 5:06 pm
Forum: General
Topic: 433 0r 411?
Replies: 2
Views: 488

Re: 433 0r 411?

I got my main link with a 411 card. Would it be better for me to use a 433?
Good question, wrong forum. With information you have given is more less q. for oraculum.
by petrn
Sat Jun 18, 2011 4:54 pm
Forum: Scripting
Topic: CLI script to print routername in config
Replies: 3
Views: 1218

Re: CLI script to print routername in config

I have to set the /tool e-mail for all my routers. All my routers have a name I want the mail ´from´ to be "routername@mydomain.com" I want to make a script that I can past in CLI to get the settings of the e-mail done. (amongst other stuff, rest of e-mail tool setting also clear, only need help on...
by petrn
Fri Jun 17, 2011 5:25 pm
Forum: Scripting
Topic: how to stop a scheduled script after x times?
Replies: 33
Views: 6897

Re: how to stop a scheduled script after x times?

Hi WirelessRudy,

i have question, how do you know that script "ChangeBand" is working when you start it manualy, and not working when run from those scheduler scripts?
by petrn
Fri Jun 17, 2011 5:03 pm
Forum: Scripting
Topic: how to stop a scheduled script after x times?
Replies: 33
Views: 6897

Re: how to stop a scheduled script after x times?

I am so sorry for this, i was meant as joke. Assuming counter is signed 32bit integer, and you run scheduler every 20seconds, it will take 497,102 days (1,361 years) to overflow,:set counter ($counter-1) takes care of that - you can safely delete that part, script will still work. For anyone intere...
by petrn
Fri Jun 17, 2011 4:42 pm
Forum: Scripting
Topic: how to stop a scheduled script after x times?
Replies: 33
Views: 6897

Re: how to stop a scheduled script after x times?

In plain wordings: +++++ Scheduler executes after reboot script "A" every xx secs script "A" runs and should start script "B" if counter is less than 5 and if not should stop scheduler to make script run. script "B" is not running. (It is just not initiated by script "A". If initiated manually or d...
by petrn
Fri Jun 17, 2011 2:22 pm
Forum: Scripting
Topic: how to stop a scheduled script after x times?
Replies: 33
Views: 6897

Re: how to stop a scheduled script after x times?

Hi WirelessRudy, do you reboot router while testing? Or at least are you removing "counter": /system script environment remove [find name=counter] Your scripts/scheduler works fine in my ROS V4 and ROS V5. Yes, I did reboot. It still doesn't work The scheduler works fine. It executes the script nam...
by petrn
Fri Jun 17, 2011 1:55 pm
Forum: Scripting
Topic: how to stop a scheduled script after x times?
Replies: 33
Views: 6897

Re: how to stop a scheduled script after x times?

The on-event needs to be a valid ros command or commands like: log info hello /system script run "Limit_ChangeBand_to5" log info goodbye ... .. Hope this helps. Actually it can be script like you suggest, but this scheduler /system scheduler add disabled=no interval=20s name=schedule1 on-event=Limi...
by petrn
Fri Jun 17, 2011 5:23 am
Forum: Scripting
Topic: how to stop a scheduled script after x times?
Replies: 33
Views: 6897

Re: how to stop a scheduled script after x times?

Hi WirelessRudy,

do you reboot router while testing? Or at least are you removing "counter":
/system script environment remove [find name=counter]
Your scripts/scheduler works fine in my ROS V4 and ROS V5.
by petrn
Wed Jun 15, 2011 11:22 pm
Forum: General
Topic: How to check if the config was changed in time?
Replies: 12
Views: 1027

Re: How to check if the config was changed in time?

Hi,

Hmm i forgot: customer is always right.
by petrn
Wed Jun 15, 2011 11:08 pm
Forum: Scripting
Topic: how to stop a scheduled script after x times?
Replies: 33
Views: 6897

Re: how to stop a scheduled script after x times?

Hi, found major issue in V.1: # V.2 # Changelog $counter overflow after 2^31 runs :global counter :set counter ($counter+1) :if ($counter <= 5) do={:log info run} else={:set counter ($counter-1)} Ok, as being a complete dummy in this I ask you where to put your lines in our (I am not the editor) sc...
by petrn
Wed Jun 15, 2011 8:36 pm
Forum: General
Topic: How to check if the config was changed in time?
Replies: 12
Views: 1027

Re: How to check if the config was changed in time?

In line with what Feklar said I think you're approaching this completely wrong. The issue is that your client does not trust you. That is a social problem, and there isn't a technical solution for it. Particularly since the proper solution is obvious: the client purchases equipment so that the trus...
by petrn
Wed Jun 15, 2011 8:08 pm
Forum: General
Topic: Aggressive mode VPN from Mikrotik to Sonicwall
Replies: 1
Views: 1360

Re: Aggressive mode VPN from Mikrotik to Sonicwall

Hi, i have done recently site-to-sIte IPsec VPN, one end static other dynamic, MT and openswan i think it was version 2.6.5, so far only with preshared key. I might write wiki entry, but i want to do more testing: with RSA sig., policy based, route based and so on... I need to make same against Fort...
by petrn
Wed Jun 15, 2011 12:18 am
Forum: General
Topic: Several features request
Replies: 5
Views: 2220

Re: Several features request

Hi,

then probably you want to edit http://wiki.mikrotik.com/wiki/MikroTik_ ... e_Requests .
I wonder how many users are looking for those features ...
by petrn
Wed Jun 15, 2011 12:14 am
Forum: Scripting
Topic: how to stop a scheduled script after x times?
Replies: 33
Views: 6897

Re: how to stop a scheduled script after x times?

Hi,

found major issue in V.1:
# V.2 
# Changelog $counter overflow after 2^31 runs
:global counter
:set counter ($counter+1)
:if ($counter <= 5) do={:log info run} else={:set counter ($counter-1)}
by petrn
Wed Jun 15, 2011 12:00 am
Forum: General
Topic: Port forwarding PUBLIC IP
Replies: 22
Views: 6748

Re: Port forwarding PUBLIC IP

Hi

not going to comment last two post (microshift, fewi). I will be around, as i am still using MT. BTW I've discovered new fun: fewi, how many of your 6k posts are in chinese?
by petrn
Tue Jun 14, 2011 11:56 pm
Forum: General
Topic: OSPF Ignoring Link State Acknowledgment..
Replies: 9
Views: 3506

Re: OSPF Ignoring Link State Acknowledgment..

We use Trango units for our bigger wireless links. For some reason through cli the trango showed to have the correct default gateway but through the gui it had the wrong one. I was originally doing the troubleshooting from the office so I could only get to the trango unit through telnet on the rout...
by petrn
Tue Jun 14, 2011 11:54 pm
Forum: Scripting
Topic: how to stop a scheduled script after x times?
Replies: 33
Views: 6897

Re: how to stop a scheduled script after x times?

In the script check the run-count of the scheduler and then disable it. Something like the untested example below. :local cnt [/system scheduler get [/system scheduler find name=<scheduler-name>] run-count] :if(cnt>x) do={/system scheduler disable [/system scheduler find name=<scheduler-name>]} I t...
by petrn
Tue Jun 14, 2011 11:39 pm
Forum: General
Topic: 在hotspot中,广告页面出不来
Replies: 3
Views: 1237

Re: 在hotspot中,广告页面出不来

你好

Mikrotik RouterOS 在Web服务器内置没有PHP支持, 这样 $(link-redirect) 只是从简单的替代 /ip hotspot user profile 配置.
by petrn
Tue Jun 14, 2011 11:00 pm
Forum: General
Topic: Several features request
Replies: 5
Views: 2220

Re: Several features request

Hi,

i think you can have all those already now: install OpenWRT into metarouter.
by petrn
Tue Jun 14, 2011 1:15 am
Forum: Scripting
Topic: how to stop a scheduled script after x times?
Replies: 33
Views: 6897

Re: how to stop a scheduled script after x times?

Hi,

counter in :global variable?

this runs script 5 times:
:global counter
:set counter ($counter+1)
:if ($counter <= 5) do={:log info run}
by petrn
Tue Jun 14, 2011 12:26 am
Forum: General
Topic: OSPF Ignoring Link State Acknowledgment..
Replies: 9
Views: 3506

Re: OSPF Ignoring Link State Acknowledgment..

Hi,

and sharing what was wrong would harm?
by petrn
Mon Jun 13, 2011 10:23 pm
Forum: General
Topic: OSPF Ignoring Link State Acknowledgment..
Replies: 9
Views: 3506

Re: OSPF Ignoring Link State Acknowledgment..

Hi,

/routing ospf export from both routers might bring some light ...
Hint: routers need to establish neighbor relationship first.
by petrn
Mon Jun 13, 2011 10:19 pm
Forum: General
Topic: L2TP Tunel through specific interface
Replies: 18
Views: 5611

Re: L2TP Tunel through specific interface

Hi, I am interested in this as well. I have an identical setup to the OP. Is metarouter the only way? probably not only, but i guess it is safe bet. May be someone has this done with VRF, or mangle/PBR. Can outgoing filter under profile be of any use to this? Try it and let us know, but filters are ...
by petrn
Mon Jun 13, 2011 10:02 pm
Forum: General
Topic: 在hotspot中,广告页面出不来
Replies: 3
Views: 1237

Re: 在hotspot中,广告页面出不来

你好

你的意思是客户端无法解析广告网址?邮政 /ip hotspot, ip dhcp-server, /ip dns.

P.S. my very first post in chinese ...
by petrn
Mon Jun 13, 2011 7:05 am
Forum: The User Manager
Topic: Need help in Limiting Users' Daily Access
Replies: 7
Views: 2394

Re: Need help in Limiting Users' Daily Access

Hi, here what i have tested in V5.4: 1. in userman->Profiles->Limitation create limitation with "uptime: 3h" 2. in userman->Profiles->Profiles create profile and select limitation from step 1 3. create/update users with profile from step 2 4. schedule counter reset: /system schedule add disabled=no ...
by petrn
Sun Jun 12, 2011 11:22 pm
Forum: General
Topic: Mikrotik router record !!!
Replies: 22
Views: 9977

Re: Mikrotik router record !!!

Router 1: Xeon 4 cores 2400Mhz Intel Gigabit Desktop Adapter (82574L) PCI-E <-> Router 2: Core Q8400 2660Mhz Intel Gigabit Desktop Adapter (82574L) PCI-E Result: rx/tx - 950000 pps Nice result, but CPU utilization when doing bit more real world work would be more interesting. By real world i mean P...
by petrn
Sun Jun 12, 2011 10:42 pm
Forum: RouterBOARD hardware
Topic: Need for wireless Speed, higher speed than R52nM
Replies: 7
Views: 1195

Re: Need for wireless Speed, higher speed than R52nM

Hi,

From the article:
UWB uses the 3.1- to 10.6-GHz band and can achieve data rates from 53.3 Gbits/s to as much as 480 Gbits/s at a range of up to 10 meters.
so repeater every ten meters ?
by petrn
Sun Jun 12, 2011 10:15 pm
Forum: General
Topic: Port forwarding PUBLIC IP
Replies: 22
Views: 6748

Re: Port forwarding PUBLIC IP

here's the full diagram http://img863.imageshack.us/img863/4586/nat4.jpg i'm sorry, i tried to make it simple at the begining of the thread, but them it make me loose some details, which were the cause of the fail. Whole time i was wandering ho packet destined to 192.168.0.20 can reach webserver. I...
by petrn
Sat Jun 11, 2011 11:48 pm
Forum: General
Topic: Port forwarding PUBLIC IP
Replies: 22
Views: 6748

Re: Port forwarding PUBLIC IP

There's no Dst Address in rules so i guess dynamic IP's not a problem. Here's the NAT export: /ip firewall nat add action=masquerade chain=srcnat comment=Masquerade disabled=no add action=dst-nat chain=dstnat comment=WWW disabled=no dst-port=80 in-interface=ether1 protocol=tcp to-addresses=10.10.10...
by petrn
Sat Jun 11, 2011 11:28 pm
Forum: The User Manager
Topic: Password change
Replies: 1
Views: 716

Re: Password change

Hi,

just stupid idea: initial password like this "OgVijeshk7sovdefOirkOinQuoijghansOatEan(" or longer will make users definitely change it ...
by petrn
Sat Jun 11, 2011 11:23 pm
Forum: General
Topic: Port forwarding PUBLIC IP
Replies: 22
Views: 6748

Re: Port forwarding PUBLIC IP

I appreciate you're help but adding the out-interface=ether1 didn't workout. Not a single packet on that rule. this rule is used for connection initiated from server, so it's ok If i set out-interface=ether2, then it works just like before sending router IP to the destination (instead of visitor's ...
by petrn
Sat Jun 11, 2011 10:41 pm
Forum: The User Manager
Topic: Need help in Limiting Users' Daily Access
Replies: 7
Views: 2394

Re: Need help in Limiting Users' Daily Access

Hi,

give all users 3hours uptime, then reset counter by scheduled script every midnight or so ..
/tool user-manager user set [find <condition>] uptime-used=0
EDIT: seemed as good idea, looks it's not possible in V4 userman:
/tool user-manager user reset-counters [find <condition>] 
by petrn
Sat Jun 11, 2011 10:17 pm
Forum: General
Topic: Port forwarding PUBLIC IP
Replies: 22
Views: 6748

Re: Port forwarding PUBLIC IP

Hi,

you need this:
/ip firewall nat
add action=masquerade chain=srcnat comment=Masquerade disabled=no out-interface=ether1
add action=dst-nat chain=dstnat comment=WWW disabled=no dst-port=80 in-interface=ether1 protocol=tcp to-addresses=10.10.10.199 to-ports=80
by petrn
Sat Jun 11, 2011 6:40 pm
Forum: General
Topic: Port forwarding PUBLIC IP
Replies: 22
Views: 6748

Re: Port forwarding PUBLIC IP

Hi,

disable srcnat/masquerade on Ether2 or make srcnat/masquerade only on Ether1
/ip firewall nat
add action=masquerade chain=srcnat comment="Default NAT" disabled=no out-interface=ether1
by petrn
Sat Jun 11, 2011 6:33 pm
Forum: Beginner Basics
Topic: documentation have some error
Replies: 3
Views: 631

Re: documentation have some error

Hi,

ROS 3.x pretty much EoD, 'End of Development' and 'End of Download', so point to work on errors there.
Current documentation http://wiki.mikrotik.com/wiki/Category:Manual, unfortunately even this is not without errors.
by petrn
Sat Jun 11, 2011 2:08 pm
Forum: General
Topic: port forward to server with rdp port 81xx not working
Replies: 3
Views: 8171

Re: port forward to server with rdp port 81xx not working

Hi, then put back port 3389 in both servers and try this: chain=dstnat action=dst-nat to-addresses=83.111.xxx.xxz to-ports=3389 \ protocol=tcp dst-address=83.111.xxx.xx dst-port=8100 chain=dstnat action=dst-nat to-addresses=83.111.xxx.xxa to-ports=3389 \ protocol=tcp dst-address=83.111.xxx.xx dst-po...
by petrn
Sat Jun 11, 2011 8:12 am
Forum: General
Topic: IPSec Site-to-Site with ISA Server Issues (one way traffic)
Replies: 2
Views: 1831

Re: IPSec Site-to-Site with ISA Server Issues (one way traff

Hi,

monitor outgoing encrypted traffic with ping running, either with torch (look for ESP) or in winbox/IPsec/Installed SA (look for Current Bytes). If traffic is only in one direction, then problem is in ISA(firewall), other way in MT.
by petrn
Thu Jun 09, 2011 4:02 pm
Forum: General
Topic: L2TP Tunel through specific interface
Replies: 18
Views: 5611

Re: L2TP Tunel through specific interface

Hi,

use 3 metarouters, if you not scared to maintain 4 routers instead of one.
by petrn
Thu Jun 09, 2011 2:13 pm
Forum: Wireless Networking
Topic: HotSpot - Radius profiles
Replies: 4
Views: 2250

Re: HotSpot - Radius profiles

Hi,
/ip hotspot profile set [find name=<profilename>] use-radius=yes
by petrn
Thu Jun 09, 2011 9:33 am
Forum: General
Topic: port forward to server with rdp port 81xx not working
Replies: 3
Views: 8171

Re: port forward to server with rdp port 81xx not working

chain=dstnat action=dst-nat to-addresses=83.111.xxx.xxa to-ports=8200
protocol=udp dst-address=83.xxx.xxx.xx dst-port=8200
probably you want protocol=tcp
my guess ports 8100 and 8200 are firewalled in servers.
by petrn
Tue Jun 07, 2011 3:29 am
Forum: Beginner Basics
Topic: How to Create Manual Queue????
Replies: 6
Views: 2014

Re: How to Create Manual Queue????

Here is an example of my 'manual queue':
amazing
by petrn
Fri Jun 03, 2011 1:55 am
Forum: Forwarding Protocols
Topic: Quick routing question [its kinda urgent]
Replies: 3
Views: 830

Re: Quick routing question [its kinda urgent]

Hi, let me write short manual: on both routers you need: /routing ospf network add area=backbone disabled=no network=10.10.10.0/24 then check neighbors: /routing ospf neighbor print you should see other router in both, then: /routing ospf instance set default disabled=no name=default redistribute-co...
by petrn
Thu Jun 02, 2011 9:15 pm
Forum: General
Topic: Do I want masquerade or nat? Double router scenario
Replies: 16
Views: 2758

Re: Do I want masquerade or nat? Double router scenario

Hi saphear,

i have one or two ideas how to solve your problem, going to test them tomorrow. I will post result/solution later.
by petrn
Thu Jun 02, 2011 9:08 pm
Forum: Scripting
Topic: script for update ip address
Replies: 3
Views: 805

Re: script for update ip address

:local resolvedIP [:resolve "xxxxx.dyndns.org"];
:local finalIP=($resolvedIP."/32")
/ip ipsec policy set [find dst-address="<IP to match>"] sa-dst-address=$resolvedIP;
/ip ipsec peer set [find comment="myipsec"] address=$finalIP;
You cannot use item number before 'print' or 'find'.
by petrn
Thu Jun 02, 2011 7:50 am
Forum: Scripting
Topic: script for update ip address
Replies: 3
Views: 805

Re: script for update ip address

Hi,
address=($resolvedIP."/32")
by petrn
Thu Jun 02, 2011 1:14 am
Forum: General
Topic: Do I want masquerade or nat? Double router scenario
Replies: 16
Views: 2758

Re: Do I want masquerade or nat? Double router scenario

What do you mean with "1. terminate VPN on MT750G"? It is a site to site vpn, yes. But from the LANCOM behind the MT to a CISCO. well i have assumed that both MT and Lancom belongs to same entity, so it didn't mater where you terminate (read configure) VPN. It might be necessary to do bit more NATi...
by petrn
Wed Jun 01, 2011 11:37 pm
Forum: General
Topic: Do I want masquerade or nat? Double router scenario
Replies: 16
Views: 2758

Re: Do I want masquerade or nat? Double router scenario

I think you have 3 options: 1. terminate VPN on MT750G - if vpn is site-to-site 2. enable NAT-traversal (Cisco terminology) - if LANCOM supports that 3. try dstnat /ip firewall nat add action=dst-nat chain=dstnat disabled=no dst-port=500 in-interface=<WAN iface> \ protocol=udp to-addresses=192.168.1...
by petrn
Wed Jun 01, 2011 8:43 pm
Forum: General
Topic: 2400 volts (ROS 5.4 on RB750G)
Replies: 1
Views: 595

Re: 2400 volts (ROS 5.4 on RB750G)

Seems this is bug, I am getting same in ROS V4.17. There is no temp/voltage sensors support in RB750G
by petrn
Wed Jun 01, 2011 6:59 pm
Forum: Forwarding Protocols
Topic: Quick routing question [its kinda urgent]
Replies: 3
Views: 830

Re: Quick routing question [its kinda urgent]

quick answer:
What can I do? Becouse I cant use microtik as default gateway :(
you don't have to ...
And this is urgent so please help! :)
Be polite, smillies wont help. This is free forum.

Unless you change attitude, RTFM - preferably how OSPF works.
by petrn
Wed Jun 01, 2011 8:49 am
Forum: General
Topic: rb433 new pci card
Replies: 3
Views: 702

Re: rb433 new pci card

Hi,

802.11n needs ROS v4.03beta or newer
by petrn
Wed Jun 01, 2011 8:44 am
Forum: Forwarding Protocols
Topic: OSPF Routes not propagating
Replies: 9
Views: 7691

Re: OSPF Routes not propagating

Hi, ospf networks # NETWORK AREA 0 172.17.84.52/32 backbone 1 172.17.84.140/30 backbone 2 172.17.87.240/29 backbone ospf networks specifies where OSPF protocol will run, i.e. where OSPF looks for neighbors: OSPF Interfaces # INTERFACE COST PRIORITY NETWORK-TYPE AUTHENTICATION AUTHENTICATION-KEY 0 DP...
by petrn
Mon May 30, 2011 8:20 pm
Forum: Scripting
Topic: Extract part of IP address
Replies: 2
Views: 815

Re: Extract part of IP address

Hi, to parse IP from interface: :local iface "pppoe-out1" :local ip [ /ip address get [ find interface=$iface ] address ] :set ip [:pick $ip 0 [:find $ip "/" -1 ] ] :set ip [:pick $ip 0 [:find $ip "." [:find $ip "." [:find $ip "." -1 ] ] ] ] note there is difference between find and :find to set def...
by petrn
Mon May 30, 2011 7:46 pm
Forum: General
Topic: SNMPv3 problem
Replies: 5
Views: 2639

Re: SNMPv3 problem

Thanks petrn, it's working. But still cannot understand what does 80003a8c04 mean ? I like lines from off. nte-snmp web site (: I should go rambling on here about the intricate details of v3 engineIDs, INFORMs, TRAPs, engineID discovery, secret keys, passwords, localized keys, etc. But it took the ...
by petrn
Sun May 29, 2011 8:31 pm
Forum: General
Topic: SNMPv3 problem
Replies: 5
Views: 2639

Re: SNMPv3 problem

But still cannot understand what does 80003a8c04 mean ?
i didn't read RFCs, here is decode from Wireshark:
engineID="":
SNMPv3-1.png
and engineID="1234":
SNMPv3-2.png
by petrn
Sun May 29, 2011 7:44 pm
Forum: General
Topic: SNMPv3 problem
Replies: 5
Views: 2639

Re: SNMPv3 problem

Hi,

i got it working by adding
-e 80003a8c04
to snmpwalk command (engine ID not set) or
-e 80003a8c04<hexdump of engineID>
e.g. if engine-id=1234, then use -e 80003a8c0431323334
by petrn
Sat May 28, 2011 8:57 pm
Forum: Beginner Basics
Topic: Export/Import configuration file
Replies: 1
Views: 12336

Re: Export/Import configuration file

by petrn
Fri May 27, 2011 11:30 pm
Forum: Beginner Basics
Topic: PPPOE problems
Replies: 13
Views: 16923

Re: PPPOE problems

run this: /interface pppoe-client scan ether1-gateway this is service discovery without making connection here is my output: [admin@MikroTik] > /interface pppoe-client scan ether1-gateway SERVICE MAC-ADDRESS AC-NAME 00:00:5E:00:01:07 GHS04-ME60S01 -- [Q quit|D dump|C-z pause] if ether1-gateway is me...
by petrn
Fri May 27, 2011 1:08 pm
Forum: General
Topic: v5.3 released
Replies: 76
Views: 9394

Re: v5.3 released

Thank you for MikroTIK failure. Your ignore errors caused the malfunction 60 seconds.
i think V5 is in Release Candidate stage still, not ready for production, consider yourself "Beta tester"
by petrn
Fri May 27, 2011 12:35 pm
Forum: Beginner Basics
Topic: PPPOE problems
Replies: 13
Views: 16923

Re: PPPOE problems

One more observation - no response packets from PPPoE PAD in your debug log, here is mine log: May 27 13:29:03 PPP0: bridge-ftth1: sent PADI to FF:FF:FF:FF:FF:FF May 27 13:29:03 PPP0: session-id=0x0000 May 27 13:29:03 PPP0: host-uniq=0x5b May 27 13:29:03 PPP0: service-name= May 27 13:29:04 PPP0: bri...
by petrn
Fri May 27, 2011 4:40 am
Forum: General
Topic: v5.3 released
Replies: 76
Views: 9394

Re: v5.3 released

Hi,

I've been testing with v5.3 userman for few hours - seems finally production ready:
"Start at first login" in profiles is fixed, along with some other problems.
false alarm - built in radius server returns only speed limiting AV pairs, no session uptime limits or transfer limits ..
by petrn
Thu May 26, 2011 10:27 am
Forum: Beginner Basics
Topic: PPPOE problems
Replies: 13
Views: 16923

Re: PPPOE problems

Hi,

looks like service name
service-name=internet
doesn't match ISP service name, try
service-name=""
normally this parameter is not necessary.
by petrn
Wed May 25, 2011 9:29 pm
Forum: General
Topic: v5.3 released
Replies: 76
Views: 9394

Re: v5.3 released

Hi,

I've been testing with v5.3 userman for few hours - seems finally production ready:
"Start at first login" in profiles is fixed, along with some other problems.
by petrn
Tue May 24, 2011 5:37 pm
Forum: Scripting
Topic: User Manager Database automated backup
Replies: 5
Views: 3533

Re: User Manager Database automated backup

You can try this script (sorry script exports are bit uninteligible) # automated UM database backup :local ts [/system clock get time] :set ts ([:pick $ts 0 2].[:pick $ts 3 5].[:pick $ts 6 8]) :local ds [/system clock get date] :set ds ([:pick $ds 7 11].[:pick $ds 0 3].[:pick $ds 4 6]) :local fname ...
by petrn
Tue May 24, 2011 11:39 am
Forum: General
Topic: system health
Replies: 2
Views: 672

Re: system health

Problem is that I'm getting in system log result "280" but It should be 28,0.
:local v [/system health get voltage]
:local v1 ($v/10)
:local v2 ($v-($v1*10))
:log info "Voltage: $v1,$v2 V"
by petrn
Tue May 24, 2011 12:24 am
Forum: Scripting
Topic: User Manager Database automated backup
Replies: 5
Views: 3533

Re: User Manager Database automated backup

I can not find a way to have the router/usermanager automatically generate the database every day and then to have the windows machine ftp a copy of the database for safe storage.
 /tool user-manager database save name=<filename>
by petrn
Fri May 20, 2011 1:11 am
Forum: General
Topic: Blocking Facebook with Mikrotik
Replies: 4
Views: 3960

Re: Blocking Facebook with Mikrotik

Thanks for the information.I am so knew to the routerboard OS can u give me some pointers on were to get free ebooks and videos on mikrotik configurations and stuff. Video http://www.tiktube.com/ and official documentation http://wiki.mikrotik.com/wiki/Main_Page . BTW both links are on top of this ...
by petrn
Thu May 19, 2011 1:28 am
Forum: General
Topic: OpenVPN server and firewall rules
Replies: 2
Views: 930

Re: OpenVPN server and firewall rules

Hi,

use chain=forward instead of chain=input, it is bit nonintuitive. Forward chain is for traffic passing through the router and input/output chain for traffic terminated/originated in router.

If you like maze, here are couple: http://wiki.mikrotik.com/wiki/Manual:Packet_Flow
by petrn
Wed May 18, 2011 7:33 pm
Forum: General
Topic: Blocking Facebook with Mikrotik
Replies: 4
Views: 3960

Re: Blocking Facebook with Mikrotik

Hi, this blocks FB for everybody: /ip firewall address-list add address=66.220.144.0/21 comment="Facebook block AS32934" disabled=no list=\ Block-Facebook add address=66.220.152.0/21 disabled=no list=Block-Facebook add address=66.220.159.0/24 disabled=no list=Block-Facebook add address=69.63.176.0/2...
by petrn
Wed May 18, 2011 7:02 pm
Forum: The User Manager
Topic: disable logging
Replies: 3
Views: 4992

Re: disable logging

Hi,

/tool user-manager router set [ /tool user-manager router find ] log=""

and of course mouse clicking in user manager web interface -> Routers is another way.

--
Petr
by petrn
Mon May 09, 2011 6:27 pm
Forum: General
Topic: ROS as VLAN Switch on RB800+RB816 passing pppoe connections
Replies: 1
Views: 544

Re: ROS as VLAN Switch on RB800+RB816 passing pppoe connecti

Hi,

i think MAC from main server is reused for all five ADSLs and your ISPs PPPoE server don't allow that. Try to use bridge interfaces for PPPoE client in main server.

--
Petr
by petrn
Mon Apr 18, 2011 7:08 pm
Forum: General
Topic: CDP packets missing PortID TLV
Replies: 3
Views: 1164

Re: CDP packets missing PortID TLV

I have a Mikrotik 750G running RouterOS 5.0. After introducing my Mikrotik 750G into my network, I starting getting the following error logged on other network equipment (a Vyatta router). lldpd: cdp_decode: some mandatory CDP/FDP tlv are missing for frame received on eth1 it's not exactly CDP - pa...
by petrn
Thu Jul 29, 2010 4:54 am
Forum: Beginner Basics
Topic: Firewall configuration - multiple internal VPN servers
Replies: 12
Views: 2346

Re: Firewall configuration - multiple internal VPN servers

If you have just those two (IPsec on Cisco and PPTP one something else): 1. forward GRE protocol to PPTP server (connection tracking might kick in if supported by ROS, then this forward is redundant) 2. forward ESP (ipsec-esp) and AH (ipsec-ah) protocol to Cisco (those protocols are not used when NA...