Community discussions

MUM Europe 2020

Search found 25 matches

by usmc58xx
Tue Sep 07, 2010 7:45 pm
Forum: General
Topic: Sample Hotspot Page - Sticky Please
Replies: 438
Views: 311704

Re: Sample Hotspot Page - Sticky Please

Here's an installation hotspot I programmed for a fast food place.
by usmc58xx
Thu Aug 26, 2010 6:12 pm
Forum: General
Topic: Queues not working right?
Replies: 1
Views: 514

Queues not working right?

Hello, I made some changes to my router (added in load balancing for SSL using PCC) and it seems that my queue trees aren't working now. Everything is limited as 'basic-traffic', even when they are on an address list that says otherwise. Does anyone see something I am doing wrong here? It used to wo...
by usmc58xx
Wed Aug 11, 2010 8:46 am
Forum: General
Topic: How to make Queue trees
Replies: 38
Views: 6045

Re: How to make Queue trees

by usmc58xx
Wed Aug 11, 2010 7:03 am
Forum: General
Topic: Payment reminder page showing once every month on the 28th
Replies: 8
Views: 2524

Re: Payment reminder page showing once every month on the 28

Hm... yeah, a hotspot really doesn't suffice, but it's a good try.

They can just click the link and put their web browser http request in again, it was just a convenience thing.

Thanks all.
by usmc58xx
Wed Aug 11, 2010 7:01 am
Forum: Forwarding Protocols
Topic: 3 DSL lines with Cable internet connection, load balancing
Replies: 12
Views: 3363

Re: 3 DSL lines with Cable internet connection, load balanci

He did, I was at -1 because of Adrianatkins or whatnot.

Karma is always nice :)
by usmc58xx
Mon Aug 09, 2010 8:26 am
Forum: Forwarding Protocols
Topic: 3 DSL lines with Cable internet connection, load balancing
Replies: 12
Views: 3363

Re: 3 DSL lines with Cable internet connection, load balanci

Thanks a lot for you help 1) Thats a lot of good material to read and implement. I have a question. I will have in future 3 connection from the same ISP they say that i need MLPPP to have the 3 connection to work for me ant router flash with Tomatto firmware on client side to get this to work. I'm ...
by usmc58xx
Sun Aug 08, 2010 12:15 am
Forum: Forwarding Protocols
Topic: 3 DSL lines with Cable internet connection, load balancing
Replies: 12
Views: 3363

Re: 3 DSL lines with Cable internet connection, load balanci

The 6 gateways are not bonded, we use PCC to load balance between them. They sit on their own dedicated switch behind the Mikrotik Router. 6Mb per gateway is 36Mb. We have ~200 wireless customers and our average load is a mere 10Mbps. Each customer is throttled depending on their 'package' of what t...
by usmc58xx
Sun Aug 08, 2010 12:10 am
Forum: General
Topic: Bundle 2 internet link when fully loaded ?!
Replies: 10
Views: 2704

Re: Bundle 2 internet link when fully loaded ?!

The reason HTTPS and FTP are marked before everything is because most banking websites (or secure websites for that matter) require a user to keep a connection using the same ip address. If this rule is not there, the HTTPS traffic will bounce between both gateways (which have 2 different external i...
by usmc58xx
Sun Aug 08, 2010 12:03 am
Forum: General
Topic: Redirect IP address to internal IP Address
Replies: 2
Views: 1127

Re: Redirect IP address to internal IP Address

Or using telnet/SSH
/ip firewall nat
add chain=dstnat dst-address=101.101.101.101 protocol=tcp dst-port=80 \
action=dst-nat to-addresses=192.168.1.200 to-ports=80
by usmc58xx
Sat Aug 07, 2010 11:57 pm
Forum: Beginner Basics
Topic: one user effecting entire sector
Replies: 3
Views: 836

Re: one user effecting entire sector

We used to have the same problem until we bought MikroTik. We use PCC load balancing across 6 different gateways and also use PCQ to throttle them. To do this, you're going to want to use queues and you'll have to mark the incoming connections. Here we mark our connections and which package they are...
by usmc58xx
Sat Aug 07, 2010 11:49 pm
Forum: General
Topic: Bundle 2 internet link when fully loaded ?!
Replies: 10
Views: 2704

Re: Bundle 2 internet link when fully loaded ?!

Those rules mark connections as they arrive, it can be a port connection or an IP connection. Example: Connection 1 will go to gateway 1. Connection 2 will go to gateway 1 Connection 3 will go to gateway 2 Thus balancing your load 2/1 Here's our connections list so you can see what I'm talking about.
by usmc58xx
Sat Aug 07, 2010 11:46 pm
Forum: General
Topic: Firewall Help
Replies: 11
Views: 1364

Re: Firewall Help

Have you contacted your ISP to find out if that is in fact what is going on?
by usmc58xx
Sat Aug 07, 2010 11:45 pm
Forum: General
Topic: How To Block MAC adress???
Replies: 3
Views: 717

Re: How To Block MAC adress???

Like this?
/ip firewall filter
add action=drop chain=forward disabled=no src-address=10.0.0.0/8 src-mac-address=\
    00:00:00:00:00:00
by usmc58xx
Sat Aug 07, 2010 11:28 pm
Forum: General
Topic: Bundle 2 internet link when fully loaded ?!
Replies: 10
Views: 2704

Re: Bundle 2 internet link when fully loaded ?!

I'm not sure about having it work for a bit and then 'turn itself off' but you can load balance 2/1 with PCC. Here's my setup for balancing 6 gateways. /ip firewall mangle add action=mark-connection chain=prerouting comment=\ "HTTPS needs dedicated IP for security purposes." disabled=no dst-port=\ 4...
by usmc58xx
Sat Aug 07, 2010 8:52 pm
Forum: General
Topic: Transparenty Proxy doesn't work
Replies: 7
Views: 1142

Re: Transparenty Proxy doesn't work

You are not using the right configuration to forward the traffic.

You should use dst-nat instead of redirect.
/ip firewall nat
add chain=dstnat action=dst-nat to-ports=3128 protocol=tcp in-interface=ether2-local-master dst-port=80
Try that, see if it works.
by usmc58xx
Fri Aug 06, 2010 7:32 pm
Forum: General
Topic: Payment reminder page showing once every month on the 28th
Replies: 8
Views: 2524

Re: Payment reminder page showing once every month on the 28

I've actually came up with a good idea :) I'm redirecting them to a page which then has a link to another php script which uses the telnet php script on the wiki to pass a command which adds them to an address list. The problem I run into now is I'd like to send them to their original page (or link ...
by usmc58xx
Fri Aug 06, 2010 5:38 pm
Forum: General
Topic: Payment reminder page showing once every month on the 28th
Replies: 8
Views: 2524

Re: Payment reminder page showing once every month on the 28

Would it be possible to add a link on the page

[click here to continue browsing]

That would add them to an address list?

Perhaps a form that submits data to the mikrotik through the API?

That would be a surefire way to make sure that they saw it, if it's possible.
by usmc58xx
Fri Aug 06, 2010 9:54 am
Forum: General
Topic: Payment reminder page showing once every month on the 28th
Replies: 8
Views: 2524

Payment reminder page showing once every month on the 28th

Hello, I'm using monthend and oversight to make a script run on the 28th of every month but I'm having a bit of trouble figuring out how I should go about this. My idea is = on the 28th of each month, the user is sent to a page reminding them to pay their bill (via dst-nat to router proxy port 8081 ...
by usmc58xx
Thu Aug 05, 2010 9:19 am
Forum: General
Topic: Feature Request: Better Logging Manipulation
Replies: 4
Views: 1102

Re: Feature Request: Better Logging Manipulation

Seriously, are you asking a buyer of RB740, for example, to setup a server that costs 10x as much so he can sort trough logs? Nope, RouterOS on an actual machine. Tons of fun to play with. Normis: Closed minded request, I never even though of syslog and even forgot about FTP to get the log files. E...
by usmc58xx
Wed Aug 04, 2010 8:17 am
Forum: Forwarding Protocols
Topic: 3 DSL lines with Cable internet connection, load balancing
Replies: 12
Views: 3363

Re: 3 DSL lines with Cable internet connection, load balanci

I use PCC to route traffic across 6 DSL gateways and it works like a charm, you have to mark your connections as they come in
via address and port with mangle but I've never used PPPoE to do it.

Short answer, yes, it's possible, although, I can't vouch for PPPoE.
by usmc58xx
Wed Aug 04, 2010 8:05 am
Forum: General
Topic: Feature Request: Better Logging Manipulation
Replies: 4
Views: 1102

Feature Request: Better Logging Manipulation

Hello,

I would like to see better logging in the beta version.

* The ability to search logs by date/prefix/type
* The ability to manually delete logs without having to ftp into the box.
* The ability to sort logs by prefix/date.

Thanks!
by usmc58xx
Wed Aug 04, 2010 2:29 am
Forum: General
Topic: PCC Load Balancing + PCQ Throttling?
Replies: 8
Views: 5953

Re: PCC Load Balancing + PCQ Throttling?

That worked great! Thanks, you were very helpful +karma for you sir.
by usmc58xx
Tue Aug 03, 2010 10:07 pm
Forum: General
Topic: PCC Load Balancing + PCQ Throttling?
Replies: 8
Views: 5953

Re: PCC Load Balancing + PCQ Throttling?

That does make sense. Any idea why my PCQ limit has to be half of the value I wish to limit? For instance, if I want to limit them at 1024k down, I have to put in 512k. If I want to limit them at 1536k, I have to put in 768k I've tried it and the PCQ gives them up to double what I put in. Here's my ...
by usmc58xx
Tue Aug 03, 2010 7:06 pm
Forum: General
Topic: PCC Load Balancing + PCQ Throttling?
Replies: 8
Views: 5953

Re: PCC Load Balancing + PCQ Throttling?

Here are my mangle rules now and they appear to be working. PCC load balancing is definitely working across my 6 gateways, although throttling is still a bit iffy. /ip firewall mangle add action=mark-connection chain=prerouting comment="" disabled=no \ new-connection-mark=1st-conn passthrough=yes pe...
by usmc58xx
Tue Aug 03, 2010 12:47 am
Forum: General
Topic: PCC Load Balancing + PCQ Throttling?
Replies: 8
Views: 5953

PCC Load Balancing + PCQ Throttling?

Hello, I am trying to load balance 6 gateways and have done so using PCC. I also have 3 levels of subscribers, bronze, silver, gold. 1M, 1.5M, and 3M. Here are my mangle rules, routes, and queues. Mangle /ip firewall mangle add action=mark-connection chain=prerouting comment="Mark Bronze Connections...