Community discussions

Search found 26 matches

by leonix
Wed Nov 14, 2018 9:37 am
Forum: Announcements
Topic: Significant improvement for wireless Nv2 PtMP
Replies: 245
Views: 52374

Re: Significant improvement for wireless Nv2 PtMP

For my experiences the new NV2-Modes "dynamic downlink" are making the PtMP-Links more sensitive in case one of the clients is weak. After installing 6.40.9 (before 6.36.2) I was wondering about the loss on the weaker link. Ping looks like below (in case there is some MBit traffic on the other bette...
by leonix
Wed Jan 04, 2017 12:37 pm
Forum: The Dude
Topic: "get settings failed: std failure: broken path (2)"
Replies: 4
Views: 2485

Re: "get settings failed: std failure: broken path (2)"

solution: /dude set enabled=yes

Leo
by leonix
Fri Sep 23, 2016 3:06 pm
Forum: Wireless Networking
Topic: N-Devices (QRT5) perform better than AC-Devices (QRT5ac) in noisy environments
Replies: 4
Views: 1022

N-Devices (QRT5) perform better than AC-Devices (QRT5ac) in noisy environments

Hi, Recently I had a problem with a new 7km link to a tower using two QRT5ac. The overall perfomance was quite bad. After several days of tweaking (changing frequencies and parameters, I also tried to switch to N-only), I decided to mount a QRT5 (with N-only) at the tower - and all problems are gone...
by leonix
Fri Sep 23, 2016 11:11 am
Forum: Wireless Networking
Topic: mANTBox 19s and SXT Lite5 very poor Tx/RX CCQ
Replies: 20
Views: 5109

Re: mANTBox 19s and SXT Lite5 very poor Tx/RX CCQ

You should use a QRT5ac instead of the Sxt for the 4km distance. However, my experiences with AC-Technology on noisy enviroments (many other 5GHz links at the same tower) is bad. In case your environment is noisy you should exchange the AC-Router with older N-Routers (eg. QRT5 instead of a QRT5ac) a...
by leonix
Tue Jan 20, 2015 10:45 am
Forum: General
Topic: TCP performance
Replies: 74
Views: 26177

Re: TCP performance

I think is not a MikroTik problem. With these bandwidths, latency plays against. I think one main problem of NV2 is the jitter of the latency. TCP frames arrive asynchronly to the NV2 TDMA time slot, sometimes they get through within 1ms mostly within 3ms, but sometimes with 15ms (one out of 100). ...
by leonix
Mon Jan 12, 2015 1:16 pm
Forum: Forwarding Protocols
Topic: OSPF - Invalid sequence number / MD5 authentication failed
Replies: 6
Views: 3721

Re: OSPF - Invalid sequence number / MD5 authentication fail

Had the same message (and not working OSPF): Reason was not enough RAM. My older omnitik shows 7Mib free of 32Mib total RAM, this seems not enough for our 500 routes. My solution was adding an RB2011 with more RAM and switching the omnitik to bridge mode. Another messages (beside the MD5 error) in t...
by leonix
Fri Jan 02, 2015 4:27 pm
Forum: General
Topic: TCP performance
Replies: 74
Views: 26177

Re: TCP performance

For TCP-Tests I put Raspberries on our towers! exactly this same ideas I had..... what maximum speeds can raspberry pi generate for you? wget http://localhost/bigfile.bin -O /dev/null 100%[======================================>] 20.463.616 33,4M/s in 0,6s - localhost is apache2 and reading from SD...
by leonix
Fri Jan 02, 2015 12:19 pm
Forum: General
Topic: TCP performance
Replies: 74
Views: 26177

Re: TCP performance

- another point, after ros 6.19 bandwitch test for tcp is completely not working correctly, it shows bad throughoutput and mostly sinusoid type TCP Test has never been working correctly. The CPU-load goes to 100% and is limiting the bandwidth. Often the link ist not the limit. For TCP-Tests I put R...
by leonix
Tue Dec 30, 2014 12:52 pm
Forum: Wireless Networking
Topic: Low throughput question
Replies: 18
Views: 6096

Re: Low throughput question

Bad throughput can also be a problem of wrong settings of the ethernet interfaces of the wireless routers!
http://forum.mikrotik.com/viewtopic.php ... 50#p462068

Leo.
by leonix
Tue Dec 30, 2014 12:46 pm
Forum: General
Topic: TCP performance
Replies: 74
Views: 26177

Re: TCP performance

I had a very similar problem: UDP Bandwith test was super, but TCP test quite bad. Problem was a poor network cable connection. Check the statistics-page of the 100MBit FDS (the right RB711G). This was mine: /interface ethernet print stats name: ether1-local rx-fcs-error: 234 rx-align-error: 37 rx-...
by leonix
Thu Oct 23, 2014 9:39 am
Forum: General
Topic: v6.20 released!
Replies: 146
Views: 58514

OSPF Problem! Re: v6.20 released!

Upgraded a link to 6.20 with both sides doing OSPF/MPLS. After 2 days a IP subnet on one side of the link was no longer reachable. Routes are there but packets do not pass. Reboot resolved the issue. We have a similar OSPF problem. E.g. one system 6.19 the other one 6.20; OSPF does not work! (Doesn...
by leonix
Mon Mar 10, 2014 11:56 am
Forum: Wireless Networking
Topic: Low throughput question
Replies: 18
Views: 6096

Re: Low throughput question

The notation is quite confusing ;-) HT40-7 is MCS15 (40MHz BW) -> 300Mbps (using guard interval "any" which is 400ns and 2 spatial streams) .. HT40-0 is MCS08 (40MHz BW) -> 15Mbps and for small bandwidth: HT20-7 is MCS15 (20MHz BW) -> 144.4Mbps .. HT20-0 is MCS08 (20MHz BW) -> 7.2Mbps In case the sy...
by leonix
Mon Mar 10, 2014 10:09 am
Forum: Wireless Networking
Topic: Low throughput question
Replies: 18
Views: 6096

Re: Low throughput question

Borax: The CCQ during a full and massive Bandwidth test is important, the one in idle state not. More than HT40-7 is not possible, and because it is using a very sensitive modulation scheme in that case - it will do often several retransmits - which will improve the jitter of the packet latency. Jus...
by leonix
Sun Mar 09, 2014 12:54 pm
Forum: Wireless Networking
Topic: Low throughput question
Replies: 18
Views: 6096

Re: Low throughput question

leonix,

Do you think that reducing MCS rates will increase throughput over my 5m link?
(Also: my CCQ is near 100%).

I'm running v6.10.
No. In case of CCQ~100 changing the MCS settings will not improve it. (maybe they changed the behaviour of automatic MCS selection in 6.10).

M.
by leonix
Sun Mar 09, 2014 11:56 am
Forum: Wireless Networking
Topic: Low throughput question
Replies: 18
Views: 6096

Re: Low throughput question

leonix: I'm not using nv2, just straight 802.11n -- so I don't think any of the TDMA stuff applies to my situation. n21roadie: my access-point and laptop are separated by maybe 5m with line of site -- so I don't think there are any fresnel zone issues (and if there were, they would apply equally to...
by leonix
Fri Mar 07, 2014 12:27 pm
Forum: Wireless Networking
Topic: Do fog affect wireless signal connectivity?
Replies: 15
Views: 4524

Re: Do fog affect wireless signal connectivity?

Only 5km? Put a Omnitik on the top of the turbine and a Sextant at your office. This should work at lower rates. (I guess you will get about 20Mbps with no obstacles in line of sight (no trees!)). But 5km is the limit in this config.

Leo.
by leonix
Fri Mar 07, 2014 11:34 am
Forum: Wireless Networking
Topic: Low throughput question
Replies: 18
Views: 6096

Re: Improve low TCP performance on NV2 wireless links

The MCS Settings for 120MBit/s
Leo
by leonix
Fri Mar 07, 2014 10:44 am
Forum: Wireless Networking
Topic: Low throughput question
Replies: 18
Views: 6096

Re: Improve low TCP performance on NV2 wireless links

See the smokeping below of the optimized link.
* at Thu 09:00 I switched from TDMA 3ms to 1ms
* at Thu 16:00 I changed the MCS settings

Leo.
by leonix
Fri Mar 07, 2014 10:05 am
Forum: General
Topic: 6.5 released!
Replies: 185
Views: 69208

Re: 6.5 released!

Done some testing. It is still the same. TCP-Speed suffers over multiple nv2-Links. It must be something queueing related. May be reordering of packets?? While doing tcp-Bandwidth test the latency does not increase much. So there is room to send more packets. I see speeds of 16 Mbit where I can see...
by leonix
Fri Mar 07, 2014 9:53 am
Forum: Wireless Networking
Topic: Low throughput question
Replies: 18
Views: 6096

Improve low TCP performance on NV2 wireless links

TCP perfomance is very sensitive to packet latency jitter (ping jitter). Bringing the jitter down will improve TCP performance. What is ping jitter? In case you do "ping host" ping times vary much. Jitter is a real problem on wireless links. For two 5 GHz Mikrotik-Sxt's using NV2 on a link I was abl...
by leonix
Mon Oct 21, 2013 4:16 pm
Forum: General
Topic: CoDel support?
Replies: 45
Views: 13287

Re: CoDel support?

CoDel can be configured
http://linuxmanpages.net/manpages/fedor ... del.8.html
The 5ms or the number of conccurrent tcp-flows are not hardcoded and can be adjusted. So it is possibly also useful for wireless links with longer delays or more load.

Leo
by leonix
Mon Oct 21, 2013 2:18 pm
Forum: Wireless Networking
Topic: Poor throughput with rb912 PtP
Replies: 20
Views: 5471

Re: Poor throughput with rb912 PtP

You can try to increase throughput by using of bridge mode and disable encryption, however I have no experiences with the RB912...

Leo.
by leonix
Mon Sep 09, 2013 10:08 am
Forum: General
Topic: CoDel support?
Replies: 45
Views: 13287

Re: CoDel support?

I also want to see CoDel-support. I have no experiences yet (because it is not implemented in all of our ~200 mikrotik routers ); but I read a article about it in German journal ct 20/2013 (page 184/189) and they had quite good experiences with it (on a DSL connection). The basic principle of it is:...
by leonix
Tue Feb 05, 2013 9:18 am
Forum: General
Topic: TCP performance
Replies: 74
Views: 26177

Re: TCP performance

I had a very similar problem: UDP Bandwith test was super, but TCP test quite bad. Problem was a poor network cable connection. Check the statistics-page of the 100MBit FDS (the right RB711G). This was mine: /interface ethernet print stats name: ether1-local rx-fcs-error: 234 rx-align-error: 37 rx-...
by leonix
Mon Feb 04, 2013 1:08 pm
Forum: General
Topic: TCP performance
Replies: 74
Views: 26177

Re: TCP performance

I had a very similar problem: UDP Bandwith test was super, but TCP test quite bad. Problem was a poor network cable connection. Check the statistics-page of the 100MBit FDS (the right RB711G). This was mine: /interface ethernet print stats name: ether1-local rx-fcs-error: 234 rx-align-error: 37 rx-f...
by leonix
Fri Nov 26, 2010 4:19 pm
Forum: General
Topic: RB112 Slow 100% CPU
Replies: 13
Views: 3461

Re: RB112 Slow 100% CPU

I updated my RB112 from 2.9.14 to 3.3 and it was really slow also. even the prompt on the serial console was slow. After several hours it was getting faster a little bit; than I was able to uninstalled all packages this was only possible using the serial console. Simple solution: just install the pa...