Community discussions

Search found 64 matches

by diegotormes
Thu May 24, 2018 5:13 pm
Forum: Announcements
Topic: v6.43rc [release candidate] is released!
Replies: 557
Views: 111842

Re: v6.43rc [release candidate] is released!

Link to Winbox rc is in the above post, where RC is announced. Please all read the posts. It is not that hard. Indeed it was there, it does work... Thank you It is indeed not that hard but some times we are not given the "gift of time" to read all pages of all posts. I would try to edit and stick i...
by diegotormes
Sun Jan 21, 2018 2:28 pm
Forum: Wireless Networking
Topic: Bug on bridge ports (6.41)
Replies: 0
Views: 380

Bug on bridge ports (6.41)

We are experiment on severals wireless cpes, the missing wireless interface in our bridges. Using the CPE in station-bridge and using a bridge like: /interface bridge add fast-forward=no name=bridge1 protocol-mode=none /interface bridge port add bridge=bridge1 hw=no interface=ether1 add bridge=bridg...
by diegotormes
Sun Jan 21, 2018 2:18 pm
Forum: Wireless Networking
Topic: Bug in station connect algorithm.
Replies: 0
Views: 328

Bug in station connect algorithm.

Hi. I recently set in some radio bases, ACLS in my APs, some access-point accept some signals levels (good ones) an others for the "bad ones". Both APs & CPEs are Mikrotik. If I use large scan-list (56 channels) in the cpe side, the cpe continusly try to connect to the same AP (best signal for him, ...
by diegotormes
Thu Mar 30, 2017 9:18 pm
Forum: Forwarding Protocols
Topic: MPLS incorrect forwarding table
Replies: 15
Views: 2635

Re: MPLS incorrect forwarding table

upgrade to 6.38.x on all routers!
Is there a specific fix in 6.38 for this issue ?
viewtopic.php?f=14&t=116270

We had very similar issues on MPLS+TE...but maybe this is a different bug...
by diegotormes
Tue Mar 28, 2017 6:46 am
Forum: Forwarding Protocols
Topic: MPLS incorrect forwarding table
Replies: 15
Views: 2635

Re: MPLS incorrect forwarding table

upgrade to 6.38.x on all routers!
by diegotormes
Mon Mar 06, 2017 11:12 pm
Forum: Scripting
Topic: run script in API
Replies: 5
Views: 1420

Re: run script in API

when you run the script, the globals inside the script does not change at all? Or where did you expect to see the output?
I have the same issue, global variables are not accessible through api. I meant,scripts runned by api can't read or modify global variables, at least in 6.38.1
by diegotormes
Sun Feb 26, 2017 12:14 am
Forum: Announcements
Topic: v6.39rc [release candidate] is released
Replies: 391
Views: 81734

Re: v6.39rc [release candidate] is released

Version 6.39rc38 has been released.

Changes since previous version:
!) routeros - added support for new products and RouterOS features which will be announced at MUM EU (https://mum.mikrotik.com/2017/EU/info/EN);
Good call. We have a month to try it, but at least tell us where to search!
by diegotormes
Wed Jan 18, 2017 1:37 am
Forum: Forwarding Protocols
Topic: MPLS TE Broken since v6.35 (Fixed 6.38.1!!!)
Replies: 4
Views: 1255

Re: MPLS TE Broken since v6.35 (Fixed 6.38.1!!!)

The solution proposed by support is get back to 6.34x but our CCR say that it is impossible just a notice: if you want to downgrade, simple reboot after uploading files won't help. you need to press 'Downgrade' button in Packages (or execute "/system package downgrade" in Terminal) yes, I know make...
by diegotormes
Tue Jan 17, 2017 5:47 pm
Forum: Announcements
Topic: v6.39rc [release candidate] is released
Replies: 391
Views: 81734

Re: v6.39rc [release candidate] is released

mpls - fixed crash on active tunnel loss in MPLS TE setups;

Can we ask what this entails?
http://forum.mikrotik.com/viewtopic.php?f=14&t=116270
by diegotormes
Thu Dec 29, 2016 3:46 pm
Forum: Forwarding Protocols
Topic: MPLS TE Broken since v6.35 (Fixed 6.38.1!!!)
Replies: 4
Views: 1255

MPLS TE Broken since v6.35 (Fixed 6.38.1!!!)

We report to support this: This is one of the networks I have this problem (the network below is actually in production). This issue we sent it to you a few months ago, and you suggested to update to 6.36. In this case the entire network have 6.37.1, but it's still present. mpls-te.png The supout fi...
by diegotormes
Fri Mar 04, 2016 8:30 pm
Forum: Virtualization
Topic: CHR + Hyper-V + Virtual Nic in Trunk Mode = VLAN issues
Replies: 10
Views: 6592

Re: CHR + Hyper-V + Virtual Nic in Trunk Mode = VLAN issues

We have the same issue, also we are trying to know who has the problem...CHR or Hyper-v.

Diego.
by diegotormes
Wed Feb 24, 2016 7:34 pm
Forum: Scripting
Topic: C# API - tik4net on GitHub
Replies: 147
Views: 34400

Re: C# API - tik4net on GitHub

Released new version 1.8.0.0.

Whats new:
* API-SSL support (alpha)
* Additional hotspot classes (credits: D-Bullock)
* Mikrotik time helper class (credits: D-Bullock)
* nuget support

Enjoy,
D

Congrats, you guys are doing a great job on this library!

Diego.
by diegotormes
Tue Oct 15, 2013 10:07 pm
Forum: General
Topic: Reproducible crash&reboot using inject-pcap
Replies: 8
Views: 2822

Re: Reproducible crash&reboot using inject-pcap

ROS 6.4
I can't send more than ten packets, the pcap file has many packets but ROS through inject-pcap only send 10 packets to the interface.

[admin@RB2_CCR1036] /tool traffic-generator> inject-pcap pcap-file=pcap/br82.pcap interface=sfp3 once
iteration: 1
tx-packets: 10
tx-bytes: 420
by diegotormes
Sat Mar 16, 2013 2:05 am
Forum: RouterBOARD hardware
Topic: CCR
Replies: 0
Views: 496

CCR

+ for sfp ports in sfp+ version. even better with combo ports.
by diegotormes
Fri Feb 01, 2013 5:18 pm
Forum: Wireless Networking
Topic: RB800 3X3 minipci card
Replies: 46
Views: 15093

Re: RB800 3X3 minipci card

I'm interested in the adapter too.

anyone know if this card:
http://www.compex.com.sg/productdetaili ... cc1Panel=1
goes well(without any adaptor) on RB800?
by diegotormes
Fri Dec 21, 2012 4:16 pm
Forum: General
Topic: ROSV6 VPLS issue
Replies: 3
Views: 1092

Re: ROSV6 VPLS issue

check mpls mtu and max l2mtu values on interfaces.
Any suggestions except this?
by diegotormes
Thu Dec 20, 2012 5:13 pm
Forum: General
Topic: ROSV6 VPLS issue
Replies: 3
Views: 1092

Re: ROSV6 VPLS issue

check mpls mtu and max l2mtu values on interfaces. The whole MPLS cloud has 1516 as MPLS MTU. RB1100AHx2 ROS: 5.19 Firmware: 2.39 ether6 L2MTU 1598 (to RB800) to RB800 ROS: 5.22 Firmware: 3.02 ether2 L2MTU 1600 (to RB1100AHx2) WLAN L2MTU 2290 (to RB433AH) to RB433AH (ROS: 5.22 OK - ROS: 6x not work...
by diegotormes
Thu Dec 20, 2012 4:28 pm
Forum: General
Topic: ROSV6 VPLS issue
Replies: 3
Views: 1092

ROSV6 VPLS issue

I just tried the version 6.0rc6, the VPLS's tunnels are well established, but only 1472 or less bytes packets are allowed to pass, if I try with 1500 bytes packets, they don't ... this causes problems especially in TCP packets, the TCP bandwidth test is impossible! if I get back to 5.22 version, eve...
by diegotormes
Thu Dec 06, 2012 6:24 pm
Forum: RouterBOARD hardware
Topic: 2011 power cord retainer
Replies: 34
Views: 6366

Re: 2011 power cord retainer

Rubbing power cord is nearly impossible unless router sits in very shaky environment. And even then it would take a LOT of time to rub through to reach bare wire. if the power supply is broken, we must disarm router to change it? the connection with the LCD display makes the work harder! you should...
by diegotormes
Thu Dec 06, 2012 2:57 am
Forum: RouterBOARD hardware
Topic: 2011 power cord retainer
Replies: 34
Views: 6366

Re: 2011 power cord retainer

Rubbing power cord is nearly impossible unless router sits in very shaky environment. And even then it would take a LOT of time to rub through to reach bare wire. if the power supply is broken, we must disarm router to change it? the connection with the LCD display makes the work harder! you should...
by diegotormes
Wed Dec 05, 2012 6:43 pm
Forum: RouterBOARD hardware
Topic: 2011 power cord retainer
Replies: 34
Views: 6366

Re: 2011 power cord retainer

bad design!

recently I bought 100 for CPE, was an unpleasant surprise see this.
by diegotormes
Mon Nov 05, 2012 8:52 pm
Forum: Forwarding Protocols
Topic: Multiple VPLS - Different paths
Replies: 4
Views: 2546

Re: Multiple VPLS - Different paths

In this example you can fnd out how to set up two VPLS tunnels over different paths
http://wiki.mikrotik.com/wiki/Transpare ... S_extended
thanks!

let's try with BGP signalled.
by diegotormes
Mon Nov 05, 2012 4:17 pm
Forum: Forwarding Protocols
Topic: Multiple VPLS - Different paths
Replies: 4
Views: 2546

Re: Multiple VPLS - Different paths

Nobody could get up two vpls through different paths?
by diegotormes
Mon Oct 29, 2012 5:02 pm
Forum: Forwarding Protocols
Topic: Multiple VPLS - Different paths
Replies: 4
Views: 2546

Re: Multiple VPLS - Different paths

I have this scenario: http://images.eternet.cc/mpls.png This is an MPLS cloud, with OSPF, LDP and TE configured. All this is working nice and easy. I need to create 2 VPLS tunnels between 9.9.9.1 y 9.9.9.4, and I need one to go through RB2 and RB3, and the other through RB5. I've been trying to sol...
by diegotormes
Mon Oct 01, 2012 4:14 pm
Forum: General
Topic: Function Local Proxy-Arp
Replies: 5
Views: 3034

Re: Function Local Proxy-Arp

Hello! We have the technology cisco is "Local Proxy Arp". How about mikrotik? I'm NOT talking about the function of "ARP proxy". Proxy ARP - works only between interfaces. Local Proxy Arp - router responds to any ARP request to its MAC-address on this interface. https://supportforums.cisco.com/thre...
by diegotormes
Sun Jul 10, 2011 1:27 am
Forum: Forwarding Protocols
Topic: LDP flapping after changing wireless BH link.
Replies: 4
Views: 1717

Re: LDP flapping after changing wireless BH link.

If LDP adjacency is maintained fine with targeted hellos, I would say that your link is having trouble forwarding multicast packets (LDP hellos). You can check that with sniffer.

would be helpful if ldp neighbors have adjacency time like ospf neighbors ... and state changes too.
by diegotormes
Sun Jul 10, 2011 1:22 am
Forum: Forwarding Protocols
Topic: LDP flapping after changing wireless BH link.
Replies: 4
Views: 1717

Re: LDP flapping after changing wireless BH link.

We had a mikrotik to mikrotik backhaul link in operation for a few years, and it worked fine with LDP protocol between these two routers. We replaced the wireless link in between with a ubiquiti link instead (using an available ethernet port on each routerboard instead of the wifi cards), not chang...
by diegotormes
Mon Aug 02, 2010 7:34 pm
Forum: General
Topic: More close
Replies: 2
Views: 803

Re: More close

is it about beta5? =)
yes
by diegotormes
Sat Jul 31, 2010 8:10 am
Forum: General
Topic: More close
Replies: 2
Views: 803

More close

too many bugs, but it seems to be improving ...

With this version can archive 90 + 90 Mbps in a 40km link, in 4.x i get a max of 70 + 70 mbps....nice approach...
by diegotormes
Sat Jul 31, 2010 7:49 am
Forum: Forwarding Protocols
Topic: MPLS issue with packets of 1500 bytes
Replies: 0
Views: 656

MPLS issue with packets of 1500 bytes

I have 5 routers properly configured with OSPF, MPLS and LDP protocol with an MTU of 1516 on all routers, apparently the MTU would be correct as reported by the ROS in the l2mtu. traceroute from router1(rb433ah ros 5.0beta5, running ldp only over wlan1) to router5: 1to5.JPG traceroute from router2(r...
by diegotormes
Tue Jul 06, 2010 2:11 am
Forum: General
Topic: Watchdog bug
Replies: 2
Views: 874

Re: Watchdog bug

explain please Systems with these architectures are rebooting due to watchdog. The ip of the watchdog does not stop responding at any moment but also the system reboots. Not if is due to beta, I made a downgrade and still have problems ... even if I delete the ip of watchdog is still rebooting ever...
by diegotormes
Tue Jun 29, 2010 11:09 pm
Forum: General
Topic: Watchdog bug
Replies: 2
Views: 874

Watchdog bug

watchdog does not work well on rb750g, rb750 and rb450, on 450g works well apparently...in others RB i don't know
by diegotormes
Fri Apr 23, 2010 6:57 pm
Forum: Scripting
Topic: /ip hotspot active print where uptime>0 => Error!
Replies: 2
Views: 1153

Re: /ip hotspot active print where uptime>0 => Error!

looks like a bug .. we will fix it in next version.
thanks
by diegotormes
Fri Apr 23, 2010 5:09 am
Forum: Scripting
Topic: /ip hotspot active print where uptime>0 => Error!
Replies: 2
Views: 1153

/ip hotspot active print where uptime>0 => Error!

I need list every hotspot user active with an uptime greater than x, when I run the command: /ip hotspot active print where uptime>0 appear the error: cannot set uptime if i try: /ip hotspot active print where U ptime>0 the error disapear but nothing happen... this is a bug or i need write a diferen...
by diegotormes
Thu Apr 22, 2010 5:55 pm
Forum: General
Topic: hotspot feature
Replies: 4
Views: 938

Re: hotspot feature

I have also experienced a problem as well with the hotspot dynamic rules. There are random times when enabling a hotspot where the dynamic rules are placed ABOVE all other rules, locking me out remotely. It would be nice to have to ability to manually create these rules instead of being dynamically...
by diegotormes
Thu Apr 22, 2010 5:53 pm
Forum: General
Topic: hotspot feature
Replies: 4
Views: 938

Re: hotspot feature

Those NAT rules are what make the Hotspot work. Without them, there's no Hotspot. So, from your perspective ... In some environments, customers receive public IP, nat not need, and the rules for non-autorized customers, I prefer to write this myself rules in the filter table, also prefer to be cust...
by diegotormes
Wed Apr 21, 2010 11:57 pm
Forum: General
Topic: hotspot feature
Replies: 4
Views: 938

hotspot feature

simple and useful, add a checkbox to generate o not automatic filter and nat rules.....
autogenerated rules sometimes are just annoying
by diegotormes
Thu Apr 01, 2010 6:27 pm
Forum: RouterBOARD hardware
Topic: RB with 12 or more ethernet ports?
Replies: 8
Views: 1498

Re: RB with 12 or more ethernet ports?

I'm wondering if the idea of making an affordable RB like RB750 with 12 or more ethernet ports is so crazy or if MikroTik i'ts going to give me that joy in the future? i'm so sick of switches i need a powerfull bridge for my MAN network PD: Sorry for my english :P If you just need a powerful bridge...
by diegotormes
Thu Apr 01, 2010 3:37 pm
Forum: RouterBOARD hardware
Topic: RB with 12 or more ethernet ports?
Replies: 8
Views: 1498

Re: RB with 12 or more ethernet ports?

The rb816 daughterboard ($69) was just released, it will work with either a rb600 ($195) or rb800 ($359) routerboard. The rb600 is now listed as End Of Life, but a lot of Mikrotik distributors still have it in stock, some have it for sale lower than $195. $264 for 19 ports, $13.89 per port, 3 gigab...
by diegotormes
Thu Apr 01, 2010 2:15 am
Forum: RouterBOARD hardware
Topic: RB with 12 or more ethernet ports?
Replies: 8
Views: 1498

Re: RB with 12 or more ethernet ports?

i'm thinking in something more affordable with 100MB ports not giga, 1100 is a nice backbone option not what i'm looking for :P Many clients are asking for a 16-port router or more at a price of 8 / 10 dollars per port (such as rb750), this is very useful for various scenarios. Also clamoring for a...
by diegotormes
Fri Mar 05, 2010 3:07 pm
Forum: General
Topic: feature requests
Replies: 8
Views: 926

Re: feature requests

I configured ROS on my RB1000 the exact same way I have previously configured custom Linux firewalls.... Configured it the same and so far it appears to work the same.

Dunno about the RADIUS thing. Seems to me a backup RADIUS sever would be in order.
you can post your config?
by diegotormes
Fri Mar 05, 2010 3:03 am
Forum: General
Topic: feature requests
Replies: 8
Views: 926

Re: feature requests

2. there is no option to let client connect with any user password( for example while maintaining radius server) if you use mschapv2 (default for Windows) - it's impossible to do that because in that case server also should prove that he knows user's password. in other cases it's RADIUS' task - to ...
by diegotormes
Tue Feb 02, 2010 3:16 pm
Forum: General
Topic: multicast problem
Replies: 3
Views: 678

Re: multicast problem

anyone?
try to block the traffic on wan switch....
by diegotormes
Sun Jan 31, 2010 5:27 pm
Forum: General
Topic: Proxy-ARP like CISCO?
Replies: 3
Views: 1067

Re: Proxy-ARP like CISCO?

Part of RFC 925: Multi-LAN Address Resolution The idea in this memo is to extend the ARP to work in an environment of multiple interconnected LANs. To see how this could work let us imagine a "magic box" (BOX) that is connected as if it were an ordinary host to two (or more) LANs. Hosts continue to ...
by diegotormes
Sun Jan 31, 2010 5:14 pm
Forum: General
Topic: Proxy-ARP like CISCO?
Replies: 3
Views: 1067

Re: Proxy-ARP like CISCO?

but... what's problem with RouterOS Proxy-ARP?.. this is not the real scenario, but the idea is similar Proxy ARP.jpeg With ROS I have to create static routes Proxy-ARP I and ARP-Proxy II, if customers change from one router to another lose the link with 10.10.10.1, I find no way to create dynamica...
by diegotormes
Sat Jan 30, 2010 5:32 pm
Forum: General
Topic: Proxy-ARP like CISCO?
Replies: 3
Views: 1067

Proxy-ARP like CISCO?

investigating how to implement mikrotik proxy-arp, I understand that answers ARP queries based on its routing table and the need to know the path to each host, this is not acceptable in a dynamic environment, where a client moves from one router to another .... in a few words: I need to implement a ...
by diegotormes
Sat Jan 30, 2010 5:15 pm
Forum: General
Topic: Public IPs for client, not bridging
Replies: 23
Views: 4175

Re: Public IPs for client, not bridging

I have the same setup...but there is a problem: as soon as I set an extra ip on my client, I get an ip conflict message. this is while there is no such a IP in my network. I think i know why. MT checks reachable ip by route table not ARP table. when i remove default route, no conflict any more. lon...
by diegotormes
Fri Aug 28, 2009 4:29 am
Forum: General
Topic: hashlimit Support
Replies: 2
Views: 653

Re: hashlimit Support

Have in mind to update the module dstlimit by hashlimit? for us is very important to use the mode srcip

Thanks,
best regards,
Diego Tormes
any news?
by diegotormes
Sat Aug 22, 2009 7:08 pm
Forum: General
Topic: hashlimit Support
Replies: 2
Views: 653

hashlimit Support

Have in mind to update the module dstlimit by hashlimit? for us is very important to use the mode srcip

Thanks,
best regards,
Diego Tormes
by diegotormes
Tue Jun 23, 2009 11:23 pm
Forum: Virtualization
Topic: OpenWRT for MetaRouter 2.6.27. Kernel Compilation error
Replies: 0
Views: 1741

OpenWRT for MetaRouter 2.6.27. Kernel Compilation error

I'm getting two errors so far. It fails when doing "make kernel_menuconfig" with this error: if [ -s "/tmp/trunk/build_dir/linux-metarouter/linux-2.6.27.21/patches/series" ]; then (cd "/tmp/trunk/build_dir/linux-metarouter/linux-2.6.27.21"; if quilt --quiltrc=- next >/dev/null 2>&1; then quilt --qui...
by diegotormes
Fri May 29, 2009 5:43 pm
Forum: Wireless Networking
Topic: 802.11 a/n 300mbit/sec minipci card
Replies: 9
Views: 2193

Re: 802.11 a/n 300mbit/sec minipci card

ROS, has support for sr715 now?
by diegotormes
Fri Mar 27, 2009 2:35 am
Forum: Forwarding Protocols
Topic: VPLS (MK.3.20) and RB433 freezing router!
Replies: 7
Views: 3156

Re: VPLS (MK.3.20) and RB433 freezing router!

anybody help here? it's only my problem, or anybody have this problem with ROS 3.18+ This is known (old) problem. Make sure you use latest routing-test & mpls-test. mmm, I'm not sure I have the same issue, I downgrade to the version 3.17 and all is fine again I made the downgrade through netinstall...
by diegotormes
Fri Apr 25, 2008 6:46 pm
Forum: RouterBOARD hardware
Topic: RB600: finally it works fine!
Replies: 7
Views: 2781

Re: RB600: finally it works fine!

You can overclock the RB600's to 533mhz. I wouldn't recommend it for production use though.

/system routerboard settings change-frequency frequency=533MHz

-Gerard
Why?
by diegotormes
Fri Apr 25, 2008 6:46 pm
Forum: RouterBOARD hardware
Topic: RB600: finally it works fine!
Replies: 7
Views: 2781

Re: RB600: finally it works fine!

Do you have 2.13 RouterBOOT[BIOS] version ?
yes
by diegotormes
Tue Apr 01, 2008 1:34 am
Forum: RouterBOARD hardware
Topic: RB600: finally it works fine!
Replies: 7
Views: 2781

RB600: finally it works fine!

seemingly...
RB600.jpg
by diegotormes
Tue Mar 25, 2008 3:28 pm
Forum: RouterBOARD hardware
Topic: rb600 make reboot every day
Replies: 106
Views: 17701

Re: rb600 make reboot every day

anyone that has a RB600 today feels as a beta testers....
that we make with these products?
by diegotormes
Wed Mar 19, 2008 8:58 pm
Forum: RouterBOARD hardware
Topic: rb600 make reboot every day
Replies: 106
Views: 17701

Re: rb600 make reboot every day

I test ROS 3.5 and the problem persist. I run bandwidth test (between two RB600) over ethernet interface and only one RB600 rebooting without reason. exchange the power supply and I continue having the same behavior, the same RB600 has problems... I test run bandwidth en diferent routerboard, but al...
by diegotormes
Wed Mar 05, 2008 1:54 am
Forum: RouterBOARD hardware
Topic: RB 600 reboots with kernel fail
Replies: 3
Views: 1177

Re: RB 600 reboots with kernel fail

I Have this problem with ROS V3.3, this bug be solved in future releases?
by diegotormes
Tue Dec 11, 2007 6:43 pm
Forum: General
Topic: VRRP and OSPF RouterOS 3.0
Replies: 1
Views: 717

Re: VRRP and OSPF RouterOS 3.0

I Have same problem with VRRP and ROS3.x...I think that is a bug of the new implementation of VRRP
by diegotormes
Fri Apr 20, 2007 10:09 pm
Forum: Wireless Networking
Topic: XR2 / RB11 - Crashes, Lockups, Reboots
Replies: 17
Views: 3330

yes, I test the xr5 with the lastest routeros(v2.9.42) and the problem persists.
by diegotormes
Fri Apr 20, 2007 4:40 am
Forum: Wireless Networking
Topic: XR2 / RB11 - Crashes, Lockups, Reboots
Replies: 17
Views: 3330

Same problem with XR5

I have the same problem with a xr5. when I enable the xr5, the system crashes
I reproduced this failure in systems x86 and in the routerboard rb112, rb512 and rb133c. I proved with routeros v2.9.27 and v2.942
by diegotormes
Thu Feb 16, 2006 12:25 am
Forum: Wireless Networking
Topic: with nstreme good link, without nstreme very bad link
Replies: 3
Views: 1349

with nstreme good link, without nstreme very bad link

hardware: RouterBOARD 512 whith mini-pci Ubiquiti SR5(400Mw) software: mikrotik 2.9.5 distance: 32Km Configuration of routers Router 1: /interface wireless set wlan1 mode=bridge ssid=nstreme band=5ghz frequency=5805 disabled=no /interface wireless nstreme set wlan1 enable-nstreme=yes /interface eoip...