Community discussions

MikroTik App

Search found 65 matches

by forne
Wed Sep 19, 2012 3:53 am
Forum: Beginner Basics
Topic: RB 750 GL - No DNS
Replies: 11
Views: 4724

Re: RB 750 GL - No DNS

I think
/ip dns set allow-remote-requests=yes
did the trick.
by forne
Tue Sep 18, 2012 4:10 pm
Forum: Beginner Basics
Topic: RB 750 GL - No DNS
Replies: 11
Views: 4724

Re: RB 750 GL - No DNS

Is my masquradeing done right? Yes. How did you test dns? From the router or from the local network? Can you ping dns servers from a computer in the local network? If yes, try from a computer: nslookup google.com <ip-address-of-your-dns> And from the router: :put [/resolve domain-name=google.com] :...
by forne
Tue Sep 18, 2012 12:18 pm
Forum: Beginner Basics
Topic: RB 750 GL - No DNS
Replies: 11
Views: 4724

Re: RB 750 GL - No DNS

If you want to use two connections to different ISPs at the same time, most likely you will want to use external DNS servers, like google's ones:
/ip dns set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
by forne
Tue Sep 18, 2012 11:56 am
Forum: General
Topic: Question on Dual-WAN setup
Replies: 2
Views: 1606

Re: Question on Dual-WAN setup

I want to: 1. Use WAN-DSL as primary connection for my LAN (10.0.0.0/24). 2. Failover to WAN-SC upon failure of WAN-DSL. This can be easily done without any routing marks. Just make sure you have two default routes in your main routing table pointing to two ISPs with different distances. 3. Assign ...
by forne
Mon Sep 17, 2012 5:05 pm
Forum: General
Topic: Forward in mangle, htb interface and NAT
Replies: 1
Views: 556

Re: Forward in mangle, htb interface and NAT

my main router does NAT and also QOS(qt+mangle). I want to ask if I use forward and qt+ htb interface if it is ok? Yes, it will definitely work. At least with the pfifo queue type. Does that mean that pcq has no meaning? Not sure about pcq. It may take into account an src-address, but Interface HTB...
by forne
Mon Sep 17, 2012 2:51 pm
Forum: General
Topic: rb 751 getting ip address from dhcp
Replies: 2
Views: 496

Re: rb 751 getting ip address from dhcp

It shouldn't? Likely you forgot to disable dhcp-client on that interface.
by forne
Mon Sep 17, 2012 10:47 am
Forum: General
Topic: DHCP option 249
Replies: 3
Views: 2371

Re: DHCP option 249

Try to specify "add-default-route=yes" in dhcp-client. In fact, it adds not only a default route.
by forne
Mon Sep 17, 2012 10:41 am
Forum: General
Topic: RouterBoard 750up ... I want to use this as a switch?
Replies: 1
Views: 451

Re: RouterBoard 750up ... I want to use this as a switch?

Try this:
/interface ethernet
set 0 name=master
set 1,2,3,4 master-port=master
by forne
Sun Sep 16, 2012 5:26 pm
Forum: General
Topic: Please check my mangle and qt and help to make it better....
Replies: 6
Views: 1283

Re: Please check my mangle and qt and help to make it better

add action=return chain=HTTP connection-mark=no-mark disabled=no add action=return chain=FTP connection-mark=no-mark disabled=no add action=return chain=GAMES connection-mark=no-mark disabled=no add action=return chain=INTERNET-OTHER connection-mark=no-mark disabled=no add action=return chain=PRIOR...
by forne
Sun Sep 16, 2012 5:02 pm
Forum: General
Topic: Static route "auto-unistall" problem
Replies: 1
Views: 413

Re: Static route "auto-unistall" problem

Try to use an ip address as a gateway of the route instead of an interface name. Try to upgrade to 5.x if it's possible.
by forne
Sun Sep 16, 2012 4:48 pm
Forum: General
Topic: Write to file
Replies: 1
Views: 477

Re: Write to file

Does this work?
/interface wireless monitor 0 once file=status.txt
by forne
Sun Sep 16, 2012 4:36 pm
Forum: General
Topic: Connection Limit rule above/beyond Established Connections
Replies: 2
Views: 664

Re: Connection Limit rule above/beyond Established Connectio

The rule "action=accept connection-state=established" should be placed as early as possible (ideally, first) in any firewall filter chain for performance reasons. After it you should place other rules that limit the creation of new connections. Connection-limit can be used as one of the matchers in ...
by forne
Sun Sep 16, 2012 3:22 pm
Forum: General
Topic: Please check my mangle and qt and help to make it better....
Replies: 6
Views: 1283

Re: Please check my mangle and qt and help to make it better

If it helps, you can use construction "packet-mark=no-mark" to match only packets without a mark. The same is for connection marks.
by forne
Sun Sep 16, 2012 3:11 pm
Forum: General
Topic: RB751G-2HnD config file restore nightmare!
Replies: 7
Views: 1399

Re: RB751G-2HnD config file restore nightmare!

Hi, this works better, but the problem here is, it clones the MAC address, I don't want everything to have the same MAC address, and the Backup and Restore is supposed to work 100%, I think its a bug! :? I think backup/restore is intended for using on the same device. Try "/export compact". It won'...
by forne
Sun Sep 16, 2012 10:55 am
Forum: General
Topic: RB751G-2HnD config file restore nightmare!
Replies: 7
Views: 1399

Re: RB751G-2HnD config file restore nightmare!

Try to use export/import instead of backups.
by forne
Sun Sep 16, 2012 10:45 am
Forum: General
Topic: Does pptp-client interface auto start?
Replies: 1
Views: 1311

Re: Does pptp-client interface auto start?

However, shortly after creating the interface I see it starting to attempt connections. Is this normal? Do pptp-client interfaces just auto-start and keep trying forever to connect?
Yes, it's normal behavior. You don't need to monitor the connection and restart it manually.
by forne
Tue Sep 11, 2012 7:00 pm
Forum: General
Topic: PPTP Client Connection
Replies: 10
Views: 4431

Re: PPTP Client Connection

saracen , you have no rules in /ip firewall filter, right? Sorry, I don't know what else to try. I'd suggest you to restore your configuration to the initial state (remove routing stuff) and get the pptp connection working using a simple ping from the router through a static route to a remote host....
by forne
Tue Sep 11, 2012 4:52 pm
Forum: General
Topic: PPTP Client Connection
Replies: 10
Views: 4431

Re: PPTP Client Connection

Sorry, I overlooked one of your message somehow. :( This wasn't successful either. I'm guessing it might be because the "vpn" route keeps going "unreachable" though. Any idea how I can fix that? Remove "check-gateway=ping" from the static route as yet. Check whether you will get a working connection...
by forne
Tue Sep 11, 2012 6:14 am
Forum: General
Topic: PPTP Client Connection
Replies: 10
Views: 4431

Re: PPTP Client Connection

And don't forget to do NAT on the pptp interface too.
by forne
Mon Sep 10, 2012 5:00 pm
Forum: General
Topic: PPTP Client Connection
Replies: 10
Views: 4431

Re: PPTP Client Connection

If it won't work, add the following:
/ip route rule
add action=lookup table=main
add action=lookup routing-mark=vpn table=vpn
add action=lookup-only-in-table table=default

/routing filter
add action=accept chain=dynamic-in prefix=0.0.0.0/0 set-routing-mark=default
by forne
Mon Sep 10, 2012 4:41 pm
Forum: General
Topic: PPTP Client Connection
Replies: 10
Views: 4431

Re: PPTP Client Connection

What static route should I add? What configuration can I use to prevent the timeouts, ping the pptp connection's gateway and eventually, allow me to, for example, make connections to dst port 80 travel over the pptp connection? Try something like this (untested): /ip route add dst-address=0.0.0.0/0...
by forne
Sun Sep 09, 2012 4:43 am
Forum: General
Topic: Source NAT (masquerade) questions
Replies: 1
Views: 1064

Source NAT (masquerade) questions

I have one interface to the local network ("lan") and several external interfaces to ISPs. I want to do source NAT on all the external interfaces. I have a single rule in the /ip firewall nat list for that purpose: /ip firewall nat add chain=srcnat action=masquerade out-interface=!lan My questions a...
by forne
Mon Mar 14, 2011 3:09 pm
Forum: General
Topic: two l2tp client on same router
Replies: 5
Views: 826

Re: two l2tp client on same router

Make sure your l2tp server gives to every client connection not only different remote addresses, but also different local addresses.
by forne
Mon Mar 14, 2011 10:59 am
Forum: General
Topic: two l2tp client on same router
Replies: 5
Views: 826

Re: two l2tp client on same router

Make sure you have static routes to both l2tp servers.
by forne
Sat Mar 12, 2011 1:33 pm
Forum: General
Topic: Triple load balancing - same gateway - problem
Replies: 9
Views: 2563

Re: Triple load balancing - same gateway - problem

No, I'm getting addresses from provider automatically and I'm not using VRF nor proxy-arp. Hmm, that's odd for me. I haven't tried that, but wiki documentation at http://wiki.mikrotik.com/wiki/Manual:IP/Address states: Two IP addresses from the same network assigned to routers different interfaces ...
by forne
Sat Mar 12, 2011 9:32 am
Forum: General
Topic: Q to MT: Nexthop lookup for routes with gateway IP%interface
Replies: 2
Views: 1081

Q to MT: Nexthop lookup for routes with gateway IP%interface

The wiki documentation at http://wiki.mikrotik.com/wiki/Manual:IP/Route states: Routes with interface name as the value of gateway are not used for nexthop lookup. If route has both interface nexthops and active IP address nexthops, then interface nexthops are ignored. I've tested routes with a sing...
by forne
Sat Mar 12, 2011 7:31 am
Forum: General
Topic: Triple load balancing - same gateway - problem
Replies: 9
Views: 2563

Re: Triple load balancing - same gateway - problem

How do you got ip addresses from the same network on different router interfaces? Do you use VRF or proxy-arp on those interfaces?
by forne
Sat Mar 12, 2011 7:22 am
Forum: General
Topic: Feature request: routing via dynamic gateway w/out scripting
Replies: 17
Views: 4932

Re: Feature request: routing via dynamic gateway w/out scrip

If an pppoe/pptp/l2tp client on RouterOS wants to always use a static remote ip address specified in a ppp profile, can an ISP deny doing that or not? Does anyone know for certain?
by forne
Sat Mar 12, 2011 7:03 am
Forum: Scripting
Topic: Load Balancing & Fail-over job using RB750 router NetWar
Replies: 5
Views: 3972

Re: Load Balancing & Fail-over job using RB750 router NetWar

pinging gateway check only check the internet modem alive not the external gateway or dns That's not true. Read the following article: http://wiki.mikrotik.com/wiki/Advanced_Routing_Failover_without_Scripting And look at the following example: http://forum.mikrotik.com/viewtopic.php?p=252900#p252900
by forne
Thu Mar 10, 2011 4:15 pm
Forum: Beginner Basics
Topic: Add a script?
Replies: 13
Views: 1730

Re: Add a script?

Beone, the easiest way to add a script is to use WinBox for that. When I tried to copy/paste a large script body into the text editor using Windows telnet, my router got hanged.
by forne
Thu Mar 10, 2011 3:09 pm
Forum: General
Topic: ISP failover
Replies: 8
Views: 3701

Re: ISP failover

acim, the configuration in wiki is correct. Read how recursive nexthop lookup works:

http://wiki.mikrotik.com/wiki/Manual:IP ... hop_lookup
by forne
Thu Mar 10, 2011 2:19 pm
Forum: General
Topic: ISP failover
Replies: 8
Views: 3701

Re: ISP failover

You need some mangle rules as well. An example is here:

http://forum.mikrotik.com/viewtopic.php ... 00#p252900
by forne
Thu Mar 10, 2011 11:14 am
Forum: General
Topic: Feature request: routing via dynamic gateway w/out scripting
Replies: 17
Views: 4932

Re: Feature request: routing via dynamic gateway w/out scrip

It's strange not to see other comments, especially from MT team. This question has been asked many times and every time a script has been suggested as a solution: http://forum.mikrotik.com/viewtopic.php?f=9&t=40417 http://forum.mikrotik.com/viewtopic.php?f=2&t=14461 http://forum.mikrotik.com/viewtop...
by forne
Thu Mar 10, 2011 9:16 am
Forum: General
Topic: dhcp-client: problem with broadcast flag
Replies: 4
Views: 1984

Re: dhcp-client: problem with broadcast flag

It was added, thanks.
by forne
Thu Mar 10, 2011 5:10 am
Forum: General
Topic: RouterBoard 750 - Serious Problem
Replies: 2
Views: 970

Re: RouterBoard 750 - Serious Problem

Try to do the same thing via telnet/ssh. Try to upgrade the firmware to the latest 5.x version.
by forne
Thu Mar 10, 2011 4:18 am
Forum: General
Topic: Simple Queue Graphing Problem
Replies: 1
Views: 449

Re: Simple Queue Graphing Problem

They are not. Use external monitoring via SNMP if you want more control.
by forne
Wed Mar 09, 2011 5:46 pm
Forum: General
Topic: Strange work of print/find filters
Replies: 4
Views: 1144

Re: Strange work of print/find filters

I've sent a bug report to support@.
by forne
Wed Mar 09, 2011 5:26 pm
Forum: General
Topic: Strange work of print/find filters
Replies: 4
Views: 1144

Re: Strange work of print/find filters

I'm using 5.0rc10.
by forne
Sun Mar 06, 2011 1:33 pm
Forum: General
Topic: Load Balancing + Port Forwarding
Replies: 20
Views: 99847

Re: Load Balancing + Port Forwarding

In short, use the following routing as is. Just replace 127.127.127.101 and 127.127.127.102 with your real gateways and routing marks "inet1" and "inet2" with your own. Other ip addresses should not be changed. /ip route rule add action=lookup disabled=no table=main add action=lookup-only-in-table d...
by forne
Sun Mar 06, 2011 1:03 pm
Forum: General
Topic: Load Balancing + Port Forwarding
Replies: 20
Views: 99847

Re: Load Balancing + Port Forwarding

forne,
I have had a look but I can't see how it disables the failed route
could you explain ?
The setup is done according to the following article: http://wiki.mikrotik.com/wiki/Advanced_ ... _Scripting
It works in ros 5.0rc10 without any workarounds.
by forne
Sun Mar 06, 2011 12:21 pm
Forum: General
Topic: Load Balancing + Port Forwarding
Replies: 20
Views: 99847

Re: Load Balancing + Port Forwarding

Ok here is my problem, I am trying to write a script that will fail over when a link goes down, but as I don't control the xDSL modems (ISP does) I can't use the check-gateway, becuase if the xDSL line goes down the gateway will still respond. You didn't try to understand the Mikrotik setup that I ...
by forne
Sun Mar 06, 2011 5:55 am
Forum: General
Topic: Load Balancing + Port Forwarding
Replies: 20
Views: 99847

Re: Load Balancing + Port Forwarding

This is the real config used in my home router RB750G (5.0rc10) connected to two ISP over ethernet + vpn. There are 5 interfaces: lan - ethernet connection to local (home) network local-isp1 - ethernet connection to ISP1, ip address is assigned via dhcp local-isp2 - ethernet connection to ISP2, ip a...
by forne
Sat Mar 05, 2011 8:08 am
Forum: General
Topic: dhcp-client: problem with broadcast flag
Replies: 4
Views: 1984

Re: dhcp-client: problem with broadcast flag

sergejs, is this workaround not added to v5rc11 yet?
by forne
Mon Feb 28, 2011 3:02 pm
Forum: General
Topic: decrypt the pasword of pppoe client ?
Replies: 4
Views: 2381

Re: decrypt the pasword of pppoe client ?

What password are you going to decrypt? If PAP authentication is used, a password is sent over network in plain text, so there is nothing to decrypt. If CHAP authentication is used, a password is not sent over network at all. Instead a password is used to compute a hash of random sequence of bytes o...
by forne
Mon Feb 28, 2011 2:49 pm
Forum: General
Topic: Real P2P control in the New RouterOS ??
Replies: 3
Views: 1035

Re: Real P2P control in the New RouterOS ??

Generally speaking it's impossible to kill p2p.
by forne
Mon Feb 28, 2011 11:31 am
Forum: General
Topic: Routing Problem
Replies: 1
Views: 490

Re: Routing Problem

Why do you need the second router at all? Use fiber media converter that will work as bridge.
by forne
Sat Feb 26, 2011 4:46 am
Forum: General
Topic: What is faster?
Replies: 5
Views: 715

Re: What is faster?

Sorry, but I don't believe it. An explanation from MK support would be good.
by forne
Sat Feb 26, 2011 4:38 am
Forum: General
Topic: Feature request: routing via dynamic gateway w/out scripting
Replies: 17
Views: 4932

Re: Feature request: routing via dynamic gateway w/out scrip

That is true if the previous gateway is in the same network as a newly assigned ip address. Otherwise it will not work. Example of possible load balancing in the same broadcast segment: dhcp1: network=10.10.1.0/24 router=10.10.1.1 dhcp2: network=10.10.2.0/24 router=10.10.2.1 dhcp3: network=10.10.3.0...
by forne
Sat Feb 26, 2011 4:22 am
Forum: Beginner Basics
Topic: 750g PPPoE to LAN
Replies: 8
Views: 1744

Re: 750g PPPoE to LAN

Some firewalling is probably a good idea: /ip firewall filter add chain=input connection-state=established action=accept add chain=input connection-state=related action=accept add chain=input connection-state=invalid action=drop add chain=input in-interface=ether2-local-master action=accept add cha...
by forne
Fri Feb 25, 2011 4:26 pm
Forum: General
Topic: Feature request: routing via dynamic gateway w/out scripting
Replies: 17
Views: 4932

Re: Feature request: routing via dynamic gateway w/out scrip

I suppose that there are several routers in one broadcast segment running in order to do load balancing.
by forne
Fri Feb 25, 2011 3:34 pm
Forum: Scripting
Topic: Monitoring of arbitrary parameters of RouterOS
Replies: 1
Views: 566

Monitoring of arbitrary parameters of RouterOS

I wrote a couple of scripts to monitor arbitrary parameters of RouterOS and perform specified actions when parameter values are changed. Hope they will be useful. They are here:

http://wiki.mikrotik.com/wiki/Monitoring_Script
by forne
Fri Feb 25, 2011 1:00 pm
Forum: General
Topic: Strange work of print/find filters
Replies: 4
Views: 1144

Strange work of print/find filters

I have three routing tables: inet1, inet2 and main: [admin@router] /ip route> print detail Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit 0 A S dst-address=0.0.0.0/0 gateway=127.127.127.1 gatewa...
by forne
Thu Feb 24, 2011 10:40 am
Forum: General
Topic: v5rc10 released
Replies: 77
Views: 10035

Re: v5rc10 released

[admin@router] > /system script add name=test source=":global var 10" [admin@router] > /system script run test [admin@router] > /environment print "var"=10 [admin@router] > /system script environment print # USER NAME VALUE 0 admin var 10 [admin@router] > /system script environment remove 0 [admin@...
by forne
Tue Feb 22, 2011 6:08 pm
Forum: General
Topic: What is faster?
Replies: 5
Views: 715

Re: What is faster?

Both of your rules are basically going to be the same. To save resources add in connection-state=new. This way the rule only fires when a new connection is being set up and not on subsequent packets after that. Every packet coming through as part of that connection will still receive the same packe...
by forne
Tue Feb 22, 2011 4:20 pm
Forum: General
Topic: What is faster?
Replies: 5
Views: 715

What is faster?

What is faster: to mark a connection with the same mark on every packet flow or to mark it only once but every time check if it already has a mark? I.e. what does consume less CPU cycles from these two: 1. /ip firewall mangle add action=mark-connection chain=prerouting disabled=no \ in-interface=ifa...
by forne
Tue Feb 22, 2011 10:20 am
Forum: General
Topic: Feature request: routing via dynamic gateway w/out scripting
Replies: 17
Views: 4932

Feature request: routing via dynamic gateway w/out scripting

The problem There is a way to set up load balancing with failover without scripting described here: http://wiki.mikrotik.com/wiki/Advanced_Routing_Failover_without_Scripting. All is working fine. We may use "virtual" hops and rely on recursive nexthop lookup. However in order to make it working, we...
by forne
Sun Feb 20, 2011 1:53 pm
Forum: General
Topic: CPU usage "/tool profile" vs. "/system resources"
Replies: 14
Views: 15370

Re: CPU usage "/tool profile" vs. "/system resources"

3) connection tracking is disabled on this device. Any other idea?
Have you checked all the submenus under /ip firewall? Are there any nat or mangle rules, including dynamic ones (tcp mss adjustments on vpn links)?
by forne
Sat Feb 19, 2011 2:36 pm
Forum: General
Topic: How to isolate dhcp routes from two ISPs?
Replies: 1
Views: 508

Re: How to isolate dhcp routes from two ISPs?

This can be done by using different values for default-route-distance, that actually applies to the distance of all dhcp routes. Then set-routing-mark in routing filter should be used.
by forne
Sat Feb 19, 2011 2:28 pm
Forum: General
Topic: Load balancing after routing table lookup
Replies: 2
Views: 1166

Re: Load balancing after routing table lookup

greencomputing , thank you for input. I achieved the same behaviour in a slightly different way. I apply PCC mangle rules to all packets before routing decision stage and then use custom route rules: /ip firewall mangle add action=mark-routing chain=prerouting disabled=no \ in-interface=ether-local...
by forne
Wed Feb 16, 2011 2:54 pm
Forum: General
Topic: Load balancing after routing table lookup
Replies: 2
Views: 1166

Load balancing after routing table lookup

I'm trying to set up load balancing over two ISPs, but only for those outgoing packets, for which there is no route in a routing table. I can't find how to apply PCC load balancing after routing table lookup was failed. Any suggestions would be appreciated.
by forne
Tue Feb 15, 2011 4:58 pm
Forum: General
Topic: What algorithm is used if several DNS servers are specified?
Replies: 0
Views: 355

What algorithm is used if several DNS servers are specified?

If there are several DNS servers specified under /ip dns submenu, how RouterOS (v4.11) uses them? It sends a request to the first one, waits for some time and in case if no answer is received sends the request to the second server and so on? Or it sends a request to all servers simultaneously? Will ...
by forne
Tue Feb 15, 2011 3:59 pm
Forum: General
Topic: How to isolate dhcp routes from two ISPs?
Replies: 1
Views: 508

How to isolate dhcp routes from two ISPs?

I have two ISPs connected to different ethernet ports of the router. Along with the default route every ISP assigns a bunch of additional static routes via DHCP. How can I put routes gotten from the different ISPs via DHCP into different routing tables, i.e. give them different routing marks?
by forne
Tue Feb 15, 2011 3:32 pm
Forum: General
Topic: dhcp-client: problem with broadcast flag
Replies: 4
Views: 1984

dhcp-client: problem with broadcast flag

dhcp-client always sends DHCP:DISCOVER packets with the broadcast flag turned on. Some DHCP servers (not MikroTik) can't deal correctly with that flag and don't send any answer at all. So dhcp-client stays in "searching" state forever. Is there any way to not turn on the broadcast flag in the dhcp-c...