Community discussions

Search found 74 matches

by cupis
Wed Apr 24, 2013 5:29 pm
Forum: Forwarding Protocols
Topic: BGP route not advertised to ISP
Replies: 5
Views: 3044

Re: BGP route not advertised to ISP

Is there any way I can advertise the route as egp?
The routes will automatically be eBGP, because your ASN is different to the peers ASN.
by cupis
Fri Mar 08, 2013 11:09 pm
Forum: Beginner Basics
Topic: Very basic nat question
Replies: 9
Views: 1412

Re: Very basic nat question

Does anyone know how the "masquerade" action selects the src-ip for masquerading? I coudlnt find anything about this in the documentation. masquerade used the outbound interface to select the outbound IP address -so it if picked a bridge maybe this the interface your traffic is leaving via (from th...
by cupis
Fri Mar 08, 2013 5:13 pm
Forum: Beginner Basics
Topic: NAT is not blocking from outside
Replies: 4
Views: 860

Re: NAT is not blocking from outside

Is there a possibility to prevent this?
Add this firewall rule on the mikrotik:
/ip firewall filter chain=forward connection-state=new in-interface=WAN reject-with=icmp-port-unreachable
where WAN is your WAN port.
by cupis
Fri Mar 08, 2013 5:06 pm
Forum: Beginner Basics
Topic: Very basic nat question
Replies: 9
Views: 1412

Re: Very basic nat question

Instead of using src-nat, using masquerade might be more appropriate to your setup. Something like (not tested): add action=masquerade chain=srcnat src-address=192.168.1.0/24 out-interface=ISP_UP with the "masquerade" action i had the problem that it did take the private ip assigned to a bridge on ...
by cupis
Thu Mar 07, 2013 10:31 am
Forum: Beginner Basics
Topic: Help with first router configuration, possible NAT problem
Replies: 7
Views: 802

Re: Help with first router configuration, possible NAT probl

The workstation gets an IP from a DHCP service on the router, and can ping the gateway fine. I can ping google.com from inside the router, but the problem is that I can't ping google.com from the workstation. Can you ping 8.8.8.8 from the workstation? If you can, then it sounds like a DNS issue. If...
by cupis
Thu Mar 07, 2013 10:28 am
Forum: Beginner Basics
Topic: Very basic nat question
Replies: 9
Views: 1412

Re: Very basic nat question

Instead of using src-nat, using masquerade might be more appropriate to your setup. Something like (not tested):
add action=masquerade chain=srcnat src-address=192.168.1.0/24 out-interface=ISP_UP
by cupis
Tue Mar 05, 2013 10:03 pm
Forum: Forwarding Protocols
Topic: BGP Question 2 ISPs 2 Locations 1 Allocation
Replies: 6
Views: 3532

Re: BGP Question 2 ISPs 2 Locations 1 Allocation

I have over 60 routers on the network between the two. What I was thinking was running iBGP on the same AS between the two routers over the network. Then peering with the upstream and try to watch the load balance over the gateways. Does this sound more like a solid plan? Absolutely, yes. When you ...
by cupis
Mon Mar 04, 2013 11:51 pm
Forum: Forwarding Protocols
Topic: BGP Question 2 ISPs 2 Locations 1 Allocation
Replies: 6
Views: 3532

Re: BGP Question 2 ISPs 2 Locations 1 Allocation

This will be first time for me setting up BGP with 2 peers, but on two separate networks(locations). Here is a diagram of what I have, and what I am trying to accomplish.(these are dummy ips of coarse) Is this even possible to do this? Or am I on the right track? You are on the right track. The mai...
by cupis
Mon Mar 04, 2013 1:20 pm
Forum: General
Topic: Firewall on same subnet
Replies: 11
Views: 2234

Re: Firewall on same subnet

In this respect it would be no different to DHCP. The OPs problem is not to do with IP allocations, it is to do with trying to force the traffic between two devices to go through the router (where it can be firewalled) rather than directly between the two devices (because they on the same subnet an...
by cupis
Sun Mar 03, 2013 1:35 pm
Forum: General
Topic: Firewall on same subnet
Replies: 11
Views: 2234

Re: Firewall on same subnet

DHCP would not help force the traffic to go via the router, in your example. :roll: :roll: ok what about the PPPoE server... the pool will be controled by the router In this respect it would be no different to DHCP. The OPs problem is not to do with IP allocations, it is to do with trying to force ...
by cupis
Fri Mar 01, 2013 6:39 pm
Forum: General
Topic: Firewall on same subnet
Replies: 11
Views: 2234

Re: Firewall on same subnet

server + my PC + other host -> switch -> RB1000U -> internet the server, your pc and other host are connected to switch so if you use a static ip then the RB can't do any thing to you in your local network... to solve the problem you must use DHCP server in your RB to control the traffic between th...
by cupis
Wed Feb 27, 2013 11:59 am
Forum: General
Topic: internet en vlan 2
Replies: 6
Views: 3231

Re: internet en vlan 2

Is your second workstation getting an IP address correctly allocated via DHCP?
by cupis
Tue Feb 26, 2013 11:12 pm
Forum: General
Topic: internet en vlan 2
Replies: 6
Views: 3231

Re: internet en vlan 2

Can you post your configuration using /export compact? Do you have NAT rules (masquerade) setup for VLAN2 (10.0.1.0/24)? Does you second PC get an IP address via DHCP, or can it not even see the router? *** Spanish via Google Translate *** ¿Se puede publicar su configuración utilizando "/export comp...
by cupis
Mon Feb 18, 2013 6:29 pm
Forum: Forwarding Protocols
Topic: bgp filter question
Replies: 3
Views: 970

Re: bgp filter question

i want filter not to advertise any route to cllient. just default route should be advertised. help would be appreciated Setup a Routing Filter to the above specification, then apply it as the out-filter in the BGP session to your client. Something like: /routing filter add action=accept chain=DEFAU...
by cupis
Sun Feb 17, 2013 5:58 pm
Forum: General
Topic: Problem with policy routing
Replies: 4
Views: 973

Re: Problem with policy routing

The prerouting rule works for forwarded packages, but I need to enter into the router: e.g.: ssh 200.20.x.2 And this doesn't work when the main link is down, correct? If so, add something like this: /ip firewall mangle add chain=input interface=ether2 action=mark-connection new-connection-mark=poli...
by cupis
Sat Feb 16, 2013 12:50 pm
Forum: Beginner Basics
Topic: RouterOS - No Firewall - Pure Router
Replies: 10
Views: 1934

Re: RouterOS - No Firewall - Pure Router

Does 192.168.210.121 have a firewall which could be blocking the traffic?
by cupis
Fri Feb 15, 2013 11:49 pm
Forum: General
Topic: Forward only youtube traffic with user with public IP addres
Replies: 14
Views: 16580

Re: Forward only youtube traffic with user with public IP ad

I'd start with routing 173.194.0.0/16 to the cable modem and go from there.
by cupis
Fri Feb 15, 2013 11:24 pm
Forum: Beginner Basics
Topic: RouterOS - No Firewall - Pure Router
Replies: 10
Views: 1934

Re: RouterOS - No Firewall - Pure Router

Can you confirm that the devices in each subnet are using the Mikrotik as their default gateway?

You also almost certainly do not want accept-redirects on, so run:
/ip settings set accept-redirects=no
by cupis
Fri Feb 15, 2013 11:18 pm
Forum: General
Topic: Problem with policy routing
Replies: 4
Views: 973

Re: Problem with policy routing

I have a problem with policy routing This is the router configuration: /ip address add interface=ether1 address=200.10.x.2/24 add interface=ether2 address=200.20.x.2/24 /ip route add dst-address=0.0.0.0/0 gateway=200.10.x.1 pref-src=200.10.x.2 add dst-address=0.0.0.0/0 gateway=200.20.x.1 pref-src=2...
by cupis
Fri Feb 15, 2013 7:47 pm
Forum: Forwarding Protocols
Topic: Public IP's
Replies: 6
Views: 1395

Re: Public IP's

but i can't go outside, ping don't respond... ping google.com and timeout...
Maybe your ISP has not got that /24 setup to route to your router, so return traffic is not making it to you...
by cupis
Thu Feb 14, 2013 8:29 pm
Forum: General
Topic: IPv6 dual stack on vlan in couple of minutes IPv6 is down
Replies: 5
Views: 1682

Re: IPv6 dual stack on vlan in couple of minutes IPv6 is dow

I've not seen this issue, but IPv6 does not use ARP, it uses Neighbour Discovery, so you might look at your options in that menu. As a separate point, it might be worth getting more detail on the type of failure - do devices lose their IPv6 addresses/routes, are they able to ping each other, does th...
by cupis
Sat Feb 09, 2013 11:35 pm
Forum: General
Topic: Firewall filter question/help
Replies: 2
Views: 691

Re: Firewall filter question/help

The source address for the ICMP replies is not going to be your routers address. Either just allow all ICMP, or try allowing (related,established) packets through to your router.
by cupis
Sat Feb 09, 2013 4:23 pm
Forum: Forwarding Protocols
Topic: how to set local-pref in bgp
Replies: 7
Views: 2774

Re: how to set local-pref in bgp

thanks for your support. I have some queries. when i connect to different AS like 65000 and 65001 why does it shows in mikrotik <>>bgp <> advertise<>origin ---- igp. I'm not sure I understand your question, but I suspect one of your routers will show the route as originating from it's own AS (igp) ...
by cupis
Sat Feb 09, 2013 4:19 pm
Forum: Scripting
Topic: Array script
Replies: 3
Views: 3753

Re: Array script

How about:
:local ipam "";
:for i from=1 to=2 do={
 :if ( $ipam != "" ) do={ :set ipam "$ipam;"; };
 :set ipam ( $ipam . "10.15.32.$i" );
}
:put $ipam;
by cupis
Sat Feb 09, 2013 1:11 pm
Forum: Beginner Basics
Topic: Two real ip same gateway issue
Replies: 2
Views: 679

Re: Two real ip same gateway issue

You can put both WAN IPs on the interface facing your provider. You can then use src-nat to specify which IP will be used to NAT each of your private networks (assuming that that is what you want to do).
by cupis
Fri Feb 08, 2013 3:19 pm
Forum: Forwarding Protocols
Topic: OSPFv3 Missing /128 Routes in 5.1
Replies: 73
Views: 18484

Re: OSPFv3 Missing /128 Routes in 5.1

What's new in 6.0rc9 (2013-Feb-08 08:15):

*) ospf - fixed Summary-LSA prefix length check for OSPFv3, was not
accepting valid LSAs;
Does anyone know if this fix will be implemented in a 5.x version?
by cupis
Thu Feb 07, 2013 3:26 pm
Forum: Forwarding Protocols
Topic: how to set local-pref in bgp
Replies: 7
Views: 2774

Re: how to set local-pref in bgp

local-pref will not propagate between two routers configured with different AS numbers. This is not a Mikrotik issue, that is just how BGP works.
by cupis
Thu Feb 07, 2013 12:20 pm
Forum: Forwarding Protocols
Topic: how to set local-pref in bgp
Replies: 7
Views: 2774

Re: how to set local-pref in bgp

they are static routes. we had added bgp local pref = 200 in static routes. but still my peer shows no local pref
Can you show your config, please? Can you confirm that both routers are configured with the same AS?
by cupis
Wed Feb 06, 2013 8:32 pm
Forum: Forwarding Protocols
Topic: how to set local-pref in bgp
Replies: 7
Views: 2774

Re: how to set local-pref in bgp

Are you originating the route, or learning it from elsewhere? If the latter, set the localpref when you learn the route, in your inbound filter, rather than in your outbound filter. If these are static routes on the Mikrotik, you need to set localpref under IP/Route. Otherwise, could you give us mor...
by cupis
Sat Feb 02, 2013 10:25 am
Forum: Forwarding Protocols
Topic: Help regarding upload controle @ BGP
Replies: 7
Views: 2132

Re: Help regarding upload controle @ BGP

Perhaps ask them if they can send you Partial Routes so your router can use the additional information to make its routing decisions?
by cupis
Fri Feb 01, 2013 8:47 pm
Forum: General
Topic: GRE Problems
Replies: 2
Views: 635

Re: GRE Problems

To expand on the previous answer sounds like the problem is being caused by the lower MTU on your GRE tunnel.

Are you blocking ICMP at all, as ICMP can deal with this (Path MTU Discovery). The other option might be clamping MSS on your TCP traffic, but this will not help with UDP.
by cupis
Fri Feb 01, 2013 6:55 pm
Forum: Forwarding Protocols
Topic: Help regarding upload controle @ BGP
Replies: 7
Views: 2132

Re: Help regarding upload controle @ BGP

this is working as like as my code. the upload is going over one upstream.
How many routes are your learning (via BGP) from each upstream? Are they sending you anything more that just a default route?
by cupis
Fri Feb 01, 2013 2:00 pm
Forum: Forwarding Protocols
Topic: Help regarding upload controle @ BGP
Replies: 7
Views: 2132

Re: Help regarding upload controle @ BGP

Thanks. But i didn't get you as I know BGP very little :( Please explain with code. Instead of: add chain=UPSTREAM_1_IN prefix=0.0.0.0/0 action=accept bgp-local-pref=150 add chain=UPSTREAM_1_IN action=discard add chain=UPSTREAM_2_IN prefix=0.0.0.0/0 action=accept bgp-local-pref=300 add chain=UPSTRE...
by cupis
Fri Feb 01, 2013 12:00 am
Forum: General
Topic: Mikrotik 5.23 Firewall problem
Replies: 9
Views: 1836

Re: Mikrotik 5.23 Firewall problem

The SIP ports are forwarded to a device in my lan. i added this: add action=dst-nat chain=dstnat disabled=no dst-port=5060-5061 in-interface=\ pppoe-out1 protocol=tcp to-addresses=192.168.1.250 to-ports=5060-5061 But not work. testing ports from internet not work. this same rule with port 21 works ...
by cupis
Thu Jan 31, 2013 11:56 pm
Forum: Forwarding Protocols
Topic: Help regarding upload controle @ BGP
Replies: 7
Views: 2132

Re: Help regarding upload controle @ BGP

Why don't you accept more routes than just a default from your providers? If both providers gave you a full or partial routing tables then BGP route selection would hopefully result in you splitting your upload between the two providers, with automatic failover in the event of a failure of one of th...
by cupis
Sun Jan 27, 2013 11:55 pm
Forum: Forwarding Protocols
Topic: bgp error
Replies: 6
Views: 1342

Re: bgp error

that is set to 0
Can you set that to a higher value or just delete it from the configuration and see if that fixes it?
by cupis
Sun Jan 27, 2013 11:37 pm
Forum: Forwarding Protocols
Topic: bgp error
Replies: 6
Views: 1342

Re: bgp error

Do you have max-prefix-limit set in your BGP config?
by cupis
Thu Jan 17, 2013 7:28 pm
Forum: General
Topic: Firewall - allow connections in one direction
Replies: 3
Views: 2265

Re: Firewall - allow connections in one direction

Is 192.160.0.10 a host, and 192.168.0.2 your Mikrotik router? Something like this will allow access to your router 192.168.0.2 only from 192.168.0.10: /ip firewall filter add action=accept chain=input src-address=192.168.0.10 add action=reject chain=input This is probably more restrictive than you r...
by cupis
Wed Jan 16, 2013 11:40 pm
Forum: Forwarding Protocols
Topic: Static routing doesen't work
Replies: 12
Views: 2948

Re: Static routing doesen't work

Can you show us the routing table on both routers, and just double check the diagram and make sure it is correct/accurate, please?

Regards,
by cupis
Wed Jan 16, 2013 10:35 pm
Forum: Forwarding Protocols
Topic: problem route fitering a subnet
Replies: 4
Views: 1067

Re: problem route fitering a subnet

is it possible to filter all subnets 10.x.x.x/x ?
Yes, use something like:
/chain=drop10 prefix=10.0.0.0/8 prefix-len=8-32 action=discard
This will filter all routes in 10.0.0.0/8, with any prefix from /8 down to /32.

Regards,
by cupis
Wed Jan 16, 2013 9:49 pm
Forum: General
Topic: RB1100AHx2 & os 5.22 - BGP
Replies: 3
Views: 880

Re: RB1100AHx2 & os 5.22 - BGP

the problem is that my RB seems to work fine, but i have a lot of lost pings. 5-10%. to my providers peer ip. This does not necessarily indicate an issue, they could just be rate-limiting ICMP and/or their router could be dealing with them as a lower prioirity. Are you seeing any packet loss connec...
by cupis
Tue Jan 15, 2013 11:10 pm
Forum: Forwarding Protocols
Topic: problem route fitering a subnet
Replies: 4
Views: 1067

Re: problem route fitering a subnet

If you expand the filters you have above, none of them will match the routes you've listed above. Can you try the following and see if it matches, please? /chain=drop10 prefix=10.0.0.0/8 prefix-len=24 action=discard http://wiki.mikrotik.com/wiki/Manual:Routing/Routing_filters If network mask is not ...
by cupis
Fri Jan 11, 2013 6:04 pm
Forum: Forwarding Protocols
Topic: BGP Multihomed - One route INACTIVE
Replies: 12
Views: 6259

Re: BGP Multihomed - One route INACTIVE

Any idea why? prepend=3 not enough? maybe prepend=10 should do it? ... I am not receiving full routes from ISP's should I ask them to forward those to me? I'd suggest that you need to advertise your allocated /20 route (216.150.32.0/20). If your router will handle it, you can also ask your provider...
by cupis
Sat Sep 22, 2012 3:05 pm
Forum: Scripting
Topic: How get address-list in one array (php api)
Replies: 2
Views: 1365

Re: How get address-list in one array (php api)

$newarray = array();
foreach( $mikrotikarray as $a )
    $newarray[] = $a["address"];
Then look at
$newarray
.
by cupis
Wed Sep 05, 2012 11:24 am
Forum: General
Topic: subnetmask
Replies: 1
Views: 354

Re: subnetmask

I have routerboard 450g and public IP /27 and I want configration to this router to convert subnetmask IP/29 , IP/29, IP/29,.... how I can do this sipcalc will do this: $ sipcalc 192.0.2.32/27 -s29 -[ipv4 : 192.0.2.32/27] - 0 [Split network] Network - 192.0.2.32 - 192.0.2.39 Network - 192.0.2.40 - ...
by cupis
Wed Aug 22, 2012 2:26 pm
Forum: Forwarding Protocols
Topic: BGP Confederation - Not Accepting Routes
Replies: 8
Views: 2962

Re: BGP Confederation - Not Accepting Routes

I'm getting the following error,

Nexthop 202.xxx.xxx.1 is not on network shared with remote peer.
Try enabling multihop for this peer and see if this resolves the issue.

Regards,
by cupis
Mon Aug 20, 2012 10:14 am
Forum: Forwarding Protocols
Topic: Routing Issue (BGP and non BGP)
Replies: 5
Views: 1425

Re: Routing Issue (BGP and non BGP)

Hi,

You should probably start a new topic for this issue, perhaps with the subject "32-bit ASN issue".

Regards,
by cupis
Sun Aug 12, 2012 11:20 pm
Forum: Forwarding Protocols
Topic: Static routing doesen't work
Replies: 12
Views: 2948

Re: Static routing doesen't work

Based on the information you've provided, I think you need to refer this to your provider for further investigation.
by cupis
Sun Aug 12, 2012 10:21 pm
Forum: Forwarding Protocols
Topic: Static routing doesen't work
Replies: 12
Views: 2948

Re: Static routing doesen't work

It is /32 because it's the ISP interface(WAN) and i have just 1 (one) ip from the 86.x.x.176/28 (sorry it's not /27 it's /28) that's why i have 86.x.x.185/32 and even i modfy this it doesen't work: Based on the information you've given so far, it sounds to me like it should be /28, not /32, otherwi...
by cupis
Sun Aug 12, 2012 7:25 pm
Forum: Forwarding Protocols
Topic: Static routing doesen't work
Replies: 12
Views: 2948

Re: Static routing doesen't work

I have routing problem, my ISP routed to my MT a subnet 82.xx.xx.128/25 IPv4 public throught a public IP ( 86.xx.xx.185/27 ). Flags: X - disabled, I - invalid, D - dynamic # ADDRESS NETWORK INTERFACE 0 ;;; default configuration 82.x.x.130/25 82.x.x.128 eth1 1 86.x.x.185/32 86.x.x.177 WAN So shouldn...
by cupis
Sun Aug 12, 2012 6:17 pm
Forum: Forwarding Protocols
Topic: Static routing doesen't work
Replies: 12
Views: 2948

Re: Static routing doesen't work

Can you check the IP addresses allocated to your interfaces (and perhaps show the output/configuration here)? 2 ADC 86.xx.xx.177/32 86.xx.xx.185 WAN 0 From your description, I would have expected the above to be: 2 ADC 86.xx.xx.160/27 86.xx.xx.185 WAN 0 I imagine you cannot currently ping 86.x.x.177...
by cupis
Sun Jul 15, 2012 10:06 pm
Forum: Forwarding Protocols
Topic: BGP Filter help
Replies: 7
Views: 1623

Re: BGP Filter help

With this rules, it announce the three Prefixes but also the whole 213.177.64.0/19 that I don't want... I want only the 3 prefixes... But you also want it to automatically pick up any new routes without you having to update the filter? You could set prefix-length to 20-32 maybe? Otherwise can you b...
by cupis
Sun Jul 15, 2012 3:51 pm
Forum: Forwarding Protocols
Topic: BGP Filter help
Replies: 7
Views: 1623

Re: BGP Filter help

My network 213.177.64.0/19 between RB1100AH2 and Cisco 7206VXR I woudl like to redistribute connected route. It is working but I can't make a good filter from Mikrotik to control what it is send to the 7206. today I have these working lines to announce only these 3 prefixes. It working ok but when ...
by cupis
Sat Jun 30, 2012 3:39 pm
Forum: Forwarding Protocols
Topic: Routing Issue (BGP and non BGP)
Replies: 5
Views: 1425

Re: Routing Issue (BGP and non BGP)

It sounds like you need to look into "source" or "policy" routing, so that any traffic from the /29 is routed to a specific peer, rather than using your main routing table (which may cause the traffic to be sent out via the "incorrect" peer). Some online examples/documentation: http://wiki.mikrotik....
by cupis
Wed Jun 27, 2012 10:28 pm
Forum: Forwarding Protocols
Topic: BGP two providers backup
Replies: 1
Views: 887

Re: BGP two providers backup

I want to announce my networks on two ISP. I've seen the example in Wiki but i still have a question, Have i to write some new route on RIPE database? You should have a route object in the RIPE DB, with your ASN in it. What is your IP prefix and ASN? You won't need multiple route objects for a sing...
by cupis
Sun May 27, 2012 11:07 pm
Forum: Forwarding Protocols
Topic: Simple setup help - two upstream, bgp, only backup
Replies: 1
Views: 1303

Re: Simple setup help - two upstream, bgp, only backup

BGP doesn't really work quite how you want it to, but to get a good approximation: * you should have a filter on your BGP sessions limiting what prefixes you send to your suppliers (create filter under /routing/filter and then apply it to your BGP session as an "out-filter" * you can set a lower loc...
by cupis
Mon Apr 23, 2012 12:27 pm
Forum: General
Topic: Comments on 6.0b2
Replies: 15
Views: 5701

Re: Comments on 6.0b2

Is there changelog for Beta2? At the: http://www.mikrotik.com/download/CHANGELOG_6 is only: What's new in 6.0beta1 (2012-Apr-13 15:26)
6.0beta2 changelog is now at the above URL.
by cupis
Wed Apr 11, 2012 11:27 am
Forum: General
Topic: www.mikrotik.com IPv6 connectivity broken?
Replies: 5
Views: 1930

Re: www.mikrotik.com IPv6 connectivity broken?

It looks like serious trouble with 2a02:610::/32 prefix BGB delegation. Does anybody else such problems with http://www.mikrotik.com IPv6 reachability? 2a02:610::/32 does not seem to be globally visible in the global routing table the moment, testing from a few locations and third party route-serve...
by cupis
Thu Feb 23, 2012 10:17 pm
Forum: Forwarding Protocols
Topic: BGP problem (I think)
Replies: 8
Views: 1686

Re: BGP problem (I think)

Have a look at the routing tables on the affected devices - I suspect that they do not have the routes installed that you think they should. Specifically look at whether .185 and .186 have the "correct" routes for the router you are testing from and for the destination you are testing to. You say yo...
by cupis
Wed Feb 08, 2012 10:16 pm
Forum: General
Topic: How to announce client IP address space under our ASN?
Replies: 10
Views: 3206

Re: How to announce client IP address space under our ASN?

Do you have the /24 route in your own local routing table? i.e. an active route sending the traffic somewhere locally? If not then you will not announce the route as being local and you will just see the route from the internet (which you might try to advertise back out).

Regards,
by cupis
Wed Jan 18, 2012 9:58 pm
Forum: Forwarding Protocols
Topic: Redundancy using BGP+OSPF
Replies: 2
Views: 1301

Re: Redundancy using BGP+OSPF

What is your actual ASN, so we might look at the global routing tables to see the existing configuration from the point of view of "The Internet", please? Also, can you dump the routing tables on the routers whilst Telco 1 or 2 is down, so we might be able to see how your routers route around the is...
by cupis
Tue Jan 17, 2012 10:03 pm
Forum: Forwarding Protocols
Topic: Problems with IPv6, OSPF-v3 and PPPoE
Replies: 4
Views: 1846

Re: Problems with IPv6, OSPF-v3 and PPPoE

OSPFv3 is run between the BR and the two PPPoE Mikrotik routers. OSPFv3 works fine, and the BR happy advertises its default route of ::/0 to the PPPoE servers. However, this is where difficulties begin. On the PPPoE server, we can happily see the IPv6 route for the customer: 2 ADS XXXX:1800:700:100...
by cupis
Thu Sep 08, 2011 8:25 pm
Forum: Forwarding Protocols
Topic: OSPFv3 Missing /128 Routes in 5.1
Replies: 73
Views: 18484

Re: OSPFv3 Missing /128 Routes in 5.1

I hadn't heard from Mikrotik support for a while but recieved this email this morning: Thank you for the report, we will try to fix this issue in one of the nextversions. Has anyone heard anything further on this issue? The changelogs do not suggest this is fixed yet in 5.6 (still running 5.4 atm)?
by cupis
Wed Jul 13, 2011 7:21 pm
Forum: General
Topic: SNMP respond from bridge/loopback interface
Replies: 2
Views: 684

Re: SNMP respond from bridge/loopback interface

Ah, please disregard this post. SNMP polling is indeed responding from the loopback/bridge interface when it is queried against. The issue I was experiencing appears to have been routing-related.

Regards,
by cupis
Wed Jul 13, 2011 5:36 pm
Forum: General
Topic: SNMP respond from bridge/loopback interface
Replies: 2
Views: 684

SNMP respond from bridge/loopback interface

Is it possible to configure SNMP on RouterOS to respond using a specified bridge/loopback interface as a the source IP address? By default the response originates from the IP address on the outgoing interface, I think.

Regards,
by cupis
Thu Jun 30, 2011 11:07 am
Forum: Forwarding Protocols
Topic: mplsvpls in bgp of ospf ?
Replies: 4
Views: 1212

Re: mplsvpls in bgp of ospf ?

what is the most convenient way for vpls+mpls: bgp or ospf ? I think you have to use BGP for this. OSPF is an interior gateway protocol, so you would normally just use this to distribute loopbacks etc between the routers - BGP would carry all customer routes, etc. You might want to look at the guid...
by cupis
Thu Jun 23, 2011 8:44 pm
Forum: Beginner Basics
Topic: How restrikt eccess to MT
Replies: 1
Views: 647

Re: How restrikt eccess to MT

Hello, I am accessing to my MT via winbox. Yesterday I noticed that someone had many attempts to log on the MT, but in vain, as he did not guess password. Could you please advise me how prevent access via HTTP completely and allow only winbox from only my place? Look into the "IP->Services" configu...
by cupis
Tue Jun 21, 2011 11:31 pm
Forum: RouterBOARD hardware
Topic: RB1100 - Initial SETUP
Replies: 6
Views: 6965

Re: RB1100 - Initial SETUP

is there another method to configure the Routerboard initially??? You can connect via ethernet and then use telnet/ssh/winbox etc. http://wiki.mikrotik.com/wiki/Manual:First_time_startup Every router is factory pre-configured with IP address 192.168.88.1/24 on ether1 port. Default username is admin...
by cupis
Sun Jun 19, 2011 1:43 pm
Forum: Forwarding Protocols
Topic: OSPF works than STOPS by ITSELF
Replies: 19
Views: 5681

Re: OSPF works than STOPS by ITSELF

Are you saying that adding a bridge, with no physical interfaces linked to it, and adding an ip address on that bridge, solves this issue ? What would you suggest that the router id might be: the ip on the recently created bridge ? The IP you add on the loopback should be a /32 (single IP, not a ra...
by cupis
Fri Jun 17, 2011 11:26 am
Forum: Beginner Basics
Topic: IP Addressing in RouterOS
Replies: 4
Views: 765

Re: IP Addressing in RouterOS

10.10.10.1/30 on port 1 which gives one usable IP 10.10.10.2 and this 10.10.10.9/29 which gives the range 10.10.10.10-14 on port 2 the above ones are working perfectly but suppose I want to give a range of 20 IP addresses to port 3, and give all of them to one server when I create any block other t...
by cupis
Fri Jun 17, 2011 11:21 am
Forum: Forwarding Protocols
Topic: BGP ANNOUNCEMENT
Replies: 6
Views: 1268

Re: BGP ANNOUNCEMENT

You will need to provide the Cisco config defining the two prefix-lists:

"sh run | i default"
and
"sh run | i GW-OUT"

Regards,
by cupis
Thu Jun 16, 2011 11:21 am
Forum: The Dude
Topic: SNMP with PRTG problem
Replies: 7
Views: 6272

Re: SNMP with PRTG problem

How have you setup SNMP on the router and in PRTG at the moment? Can you post details of your existing configuration?
by cupis
Wed Jun 15, 2011 11:13 am
Forum: General
Topic: ipv6 arp entry issue in MT OS 5.4
Replies: 10
Views: 1699

Re: ipv6 arp entry issue in MT OS 5.4

IPv6 doesn't use ARP, it uses Neighbour Discovery.

Have a look at the options under IPv6/ND.

Regards,
by cupis
Wed Jun 08, 2011 2:23 pm
Forum: Forwarding Protocols
Topic: OSPFv3 Missing /128 Routes in 5.1
Replies: 73
Views: 18484

Re: OSPFv3 Missing /128 Routes in 5.1

I saw exactly the same thing: RouterOS will pick up everything except the /128s, and I too use those for BGP. Good to know someone else can confirm it. Hopefully Mikrotik will fix it eventually. Have you heard anything from Mikrotik on this? I am seeing the same issue with a mixed Mikrotik/Cisco ne...