Community discussions

MUM Europe 2020

Search found 189 matches

by nick3dos
Wed Mar 14, 2018 2:35 pm
Forum: General
Topic: vlan setup help ???
Replies: 1
Views: 246

vlan setup help ???

Hello, I have a network setup working. My setup is: RB from ISP: 10.10.1.1 on ether01 RB Server1 with IP: 10.10.1.2 on Bridge1 (ether01 and ether02 in Bridge1) RB Server1 on ether02 connected to RB Server2 on ether01 with IP: 10.10.1.3. Server1 and Server2 have gateway RB from ISP with pptp connecti...
by nick3dos
Thu Aug 03, 2017 5:20 pm
Forum: General
Topic: PPPoE server in rip network
Replies: 4
Views: 652

Re: PPPoE server in rip network

I want pppoe server. With other protocols i am ok .
I want to set one ccr1016 as pppoe server but as i see i cant do it for my network that is not in bridge mode.
by nick3dos
Thu Aug 03, 2017 11:12 am
Forum: General
Topic: PPPoE server in rip network
Replies: 4
Views: 652

PPPoE server in rip network

Hello all, My network is installed with 80 mikrotik devices (routers and APs), connected with rip protocol (10.10.0.0/16), in a range of 10.10.1.0/24,10.10.2.0/24,10.10.xxx.0/24,10.10.254.0/24 I have a main vpn server setup and my clients connect to it with pptp. I Also want to use vpn server as mai...
by nick3dos
Tue Nov 15, 2016 1:29 pm
Forum: General
Topic: SXT LTE: attach failed
Replies: 0
Views: 1602

SXT LTE: attach failed

I have a new SXT LTE and a have an error message: attach failed.
I can't find what that mean so i can make it work.
Anyone knows about that?
Thank you.
by nick3dos
Fri Jul 10, 2015 10:41 am
Forum: General
Topic: Dyndns script problem with auth
Replies: 5
Views: 895

Re: Dyndns script problem with auth

thank you for the answer but even with this i have again the same error: "badauth"
by nick3dos
Fri Jul 10, 2015 9:23 am
Forum: General
Topic: Dyndns script problem with auth
Replies: 5
Views: 895

Re: Dyndns script problem with auth

I tried it but i have the same error: badauth the script i user is: # Set needed variables :local username "user@gmail.com" :local password "password" :local hostname "host.dyndns.org" :global dyndnsForce :global previousIP # print some debug info :log info ("UpdateDynDNS: username = $username") :lo...
by nick3dos
Thu Jul 09, 2015 11:17 am
Forum: General
Topic: Dyndns script problem with auth
Replies: 5
Views: 895

Dyndns script problem with auth

Hello i want to use dyndns script to update one of my clients mikrotik router. the problem is, when i run the script, i get an error of auth failed. this is because clients username is "username@gmail.com" so with the fetch command, i have problem with the "@" symbol. Any idea how to make it work???...
by nick3dos
Mon May 18, 2015 8:53 am
Forum: General
Topic: HELP for PCC LoadBalaning with 2 LAN !!!
Replies: 4
Views: 680

Re: HELP for PCC LoadBalaning with 2 LAN !!!

what you mean?

i want BOTH lan networks to work in Load Balancing.

i have to replicate all rules for the second lan? or some of them (per-connection-classifier)?

also the second one will use Hotspot but the first one NOT, what do i have to change?

Thanks...
by nick3dos
Sat May 16, 2015 11:39 pm
Forum: General
Topic: HELP for PCC LoadBalaning with 2 LAN !!!
Replies: 4
Views: 680

Re: HELP for PCC LoadBalaning with 2 LAN !!!

Lan1 is in ether13 and lan2 will be in ether12

I can not bridge them. Different ip, subnet, dhcp servers, hotspots.
by nick3dos
Sat May 16, 2015 5:45 pm
Forum: General
Topic: HELP for PCC LoadBalaning with 2 LAN !!!
Replies: 4
Views: 680

HELP for PCC LoadBalaning with 2 LAN !!!

Hello, i am using PCC loadbalancing with 3 modems (MODEM1,4,5) and 1 LAN (ether13-GW_LAN), all work OK (code below) Now i want to add a second LAN network, different from the first one, it will be in ether12. How can i make it work with the 2 LAN networks together??? Thanks /ip firewall mangle add a...
by nick3dos
Tue Mar 17, 2015 4:22 pm
Forum: General
Topic: How to 'get' the error from hotspot login page ???
Replies: 2
Views: 633

Re: How to 'get' the error from hotspot login page ???

thank you for your answer but i just made it work with java script in my html login page

i want to do this because i want to play a sound erorr message for each error...

now it is working like i want... :D
by nick3dos
Mon Mar 16, 2015 11:49 am
Forum: General
Topic: How to 'get' the error from hotspot login page ???
Replies: 2
Views: 633

How to 'get' the error from hotspot login page ???

I want to get the text of the error show in hotspot login page when you get an error. I want to do that because i want to write more information below the error about each different errors. I tried the following code in my login.html but i always return in the 'else' statement. $(if error) $(if $(er...
by nick3dos
Mon Sep 08, 2014 10:57 am
Forum: Scripting
Topic: 2 ISP with RB1100
Replies: 3
Views: 703

Re: 2 ISP with RB1100

In ip -> route, your must have as you default gateway, your main ISP with distance=1 and the backup ISP with distance=2.
This will do what you want...
by nick3dos
Fri Aug 22, 2014 3:49 pm
Forum: RouterBOARD hardware
Topic: CCR-1016 Kernel Panic
Replies: 12
Views: 3842

Re: CCR-1016 Kernel Panic

I already contact my reseller for RMA.
But what if in my new CCR, happens the same?
As i see it's 6xx version the problem. 6.18 didn't fix this problem.
by nick3dos
Fri Aug 22, 2014 3:38 pm
Forum: RouterBOARD hardware
Topic: CCR-1016 Kernel Panic
Replies: 12
Views: 3842

Re: CCR-1016 Kernel Panic

Please contact support with a supout.rif file and console output attached, our developers will analyse this.
how to make support.rif if i can't login to the router?
by nick3dos
Fri Aug 22, 2014 2:45 pm
Forum: RouterBOARD hardware
Topic: CCR-1016 Kernel Panic
Replies: 12
Views: 3842

Re: CCR-1016 Kernel Panic

There was a problem in one of the earlier versions, in RouterOS v6.18 it should be fixed.
The same problem after a reboot in my CCR-1009-8G-1S-1S+
I tried with netinstall v6.18 but the same errors !!!
Please help...
by nick3dos
Thu Aug 14, 2014 9:56 am
Forum: General
Topic: Router losting password and require restart
Replies: 21
Views: 4346

Re: Router losting password and require restart

The same to me...
CCR1009-8G-1S
6.17v -3.18
I had to do a script-scheduler to make again my user accounts !!!
by nick3dos
Tue Aug 05, 2014 1:15 pm
Forum: General
Topic: Mikrotik Hotspot Bypass/Exclusion for Subnets
Replies: 12
Views: 3943

Re: Mikrotik Hotspot Bypass/Exclusion for Subnets

Try in your IP binding to delete all data from "Mac Address" and "To Address"
by nick3dos
Mon Jul 28, 2014 9:30 am
Forum: General
Topic: v6.16/v6.17
Replies: 187
Views: 47049

Re: v6.16/v6.17

After updating CCR1009-8G-1S from 6.13 to 6.17 from time to time, administration users are all reset to default 'admin' user with no password.
I had to make a script to check when the users are deleted and create them back.
I can see Nothing to log !!!
by nick3dos
Wed Jul 16, 2014 12:41 pm
Forum: General
Topic: Mikrotik Hotspot Bypass/Exclusion for Subnets
Replies: 12
Views: 3943

Re: Mikrotik Hotspot Bypass/Exclusion for Subnets

Have your tried to connect a computer to your camera network ?
If yes, does hotspot login page comes up? (it souldn't), if not maybe something else blocking your connections...
The 172.19.0.129 gateway, how it's connected to your mikrotik device?
by nick3dos
Wed Jul 16, 2014 10:29 am
Forum: General
Topic: Mikrotik Hotspot Bypass/Exclusion for Subnets
Replies: 12
Views: 3943

Re: Mikrotik Hotspot Bypass/Exclusion for Subnets

Also, add the 172.19.0.128/27 network to the Walled Garden IP List of your Hotspot.
by nick3dos
Tue Jul 15, 2014 11:45 am
Forum: General
Topic: Mangle connections Problem !!!
Replies: 6
Views: 962

Re: Mangle connections Problem !!!

ofcourse there are ip addresses in the address list.
I didn't try this because it should be no difference.
I will have a try...
by nick3dos
Mon Jul 14, 2014 1:26 pm
Forum: General
Topic: Mangle connections Problem !!!
Replies: 6
Views: 962

Re: Mangle connections Problem !!!

populated?
what you mean ???
by nick3dos
Fri Jul 11, 2014 2:53 pm
Forum: General
Topic: Mangle connections Problem !!!
Replies: 6
Views: 962

Re: Mangle connections Problem !!!

- EC list is enabled in address list
- None of these two roules working (counters empty)
- No other mangle rules
by nick3dos
Fri Jul 11, 2014 11:35 am
Forum: General
Topic: Mangle connections Problem !!!
Replies: 6
Views: 962

Mangle connections Problem !!!

Hello, After updating my CCR1009-8G-1S to v6.13 my mangle rules dont work i use: /ip firewall mangle add action=mark-connection chain=prerouting comment=EC dst-address-type="" new-connection-mark=from_EC src-address-list=EC add action=mark-routing chain=prerouting comment=EC connection-mark=from_EC ...
by nick3dos
Thu May 22, 2014 11:21 am
Forum: General
Topic: v6.13 released!
Replies: 177
Views: 49511

Re: v6.13 released!

I just recieved my new CCR1009-8G-1S Upadate to 6.12 -> OK Upadate to 6.13 -> Problem !!! PPC package for CCR box ? No, you must use the Tile packge for CCR I downloaded Tile package I tried to updated again. with the second try, all is ok now... I don't know what happened the first time (imported ...
by nick3dos
Thu May 22, 2014 10:05 am
Forum: General
Topic: v6.13 released!
Replies: 177
Views: 49511

Re: v6.13 released!

I just recieved my new CCR1009-8G-1S
Upadate to 6.12 -> OK
Upadate to 6.13 -> Problem !!!
by nick3dos
Mon May 19, 2014 9:34 am
Forum: Beginner Basics
Topic: Local IP block for Wan
Replies: 6
Views: 1188

Re: Local IP block for Wan

Example if you want to block ip: 10.0.0.150 in 10.0.0.0/24 network /ip firewall address-list add address=10.0.0.1-10.0.0.149 disabled=no list=block add address=10.0.0.151-10.0.0.254 disabled=no list=block /ip firewall nat add action=masquerade chain=srcnat disabled=no src-address-list=block Thanks....
by nick3dos
Fri May 16, 2014 3:04 pm
Forum: Beginner Basics
Topic: Local IP block for Wan
Replies: 6
Views: 1188

Re: Local IP block for Wan

Example if you want to block ip: 10.0.0.150 in 10.0.0.0/24 network
/ip firewall address-list
add address=10.0.0.1-10.0.0.149 disabled=no list=block
add address=10.0.0.151-10.0.0.254 disabled=no list=block
/ip firewall nat
add action=masquerade chain=srcnat disabled=no src-address-list=block
by nick3dos
Fri May 16, 2014 11:47 am
Forum: Scripting
Topic: Trial user / local landing page / redirect after login
Replies: 6
Views: 4517

Re: Trial user / local landing page / redirect after login

http://wiki.mikrotik.com/wiki/Manual:Cu ... ng_Hotspot
alogin.html - page shown after client has logged in. It pops-up status page and redirects browser to originally requested page (before he/she was redirected to the HotSpot login page)
by nick3dos
Fri May 16, 2014 11:21 am
Forum: Scripting
Topic: Trial user / local landing page / redirect after login
Replies: 6
Views: 4517

Re: Trial user / local landing page / redirect after login

I always use the alogin.html file for redirection after login (google or any sites). Tested with regular users and trial users, No Problem at all <html> <head> <title>Hotspot</title> <meta http-equiv="refresh" content="2; url=http://www.google.gr/"> <meta http-equiv="Content-Type" content="text/html...
by nick3dos
Fri May 16, 2014 10:13 am
Forum: General
Topic: CCR1006-12G, Hotspot ok, Hotspot + VPN server ???
Replies: 1
Views: 696

CCR1006-12G, Hotspot ok, Hotspot + VPN server ???

I have a CCR1006-12G with version 6.6 working as a hotspot gateway.

I tried to work it also as a VPN Server and i had a problem.
All vpn clients connected, couldn't load "https" url !!!

Any idea ???
by nick3dos
Tue May 13, 2014 3:19 pm
Forum: General
Topic: Auto login to hotspot when assign dhcp ???
Replies: 3
Views: 1550

Re: Auto login to hotspot when assign dhcp ???

if i can get the 'mac' and the 'ip' of each device with 'dhcp-lease script'
after that, how can i send the login command (html, java) by scripting???
by nick3dos
Tue May 13, 2014 12:29 pm
Forum: General
Topic: Auto login to hotspot when assign dhcp ???
Replies: 3
Views: 1550

Auto login to hotspot when assign dhcp ???

Is it possible to make any device automatically login to hotspot when the device connects to my wifi network and gets an ip from dhcp server?
by nick3dos
Mon Apr 07, 2014 10:12 am
Forum: Wireless Networking
Topic: How do I check if my Mikrotik is infected
Replies: 6
Views: 2018

Re: How do I check if my Mikrotik is infected

also check in System -> Users for any stored SSH Keys and SSH Private Keys and delete anything is not yours...
by nick3dos
Fri Mar 28, 2014 10:12 am
Forum: General
Topic: i have issue with force dns
Replies: 3
Views: 798

Re: i have issue with force dns

/ip hotspot walled-garden ip add action=accept comment="DNS Server" disabled=no src-address=208.67.220.220 add action=accept comment="DNS Server" disabled=no src-address=208.67.220.222 add action=accept comment="DNS Server" disabled=no dst-address=208.67.220.220 add action=accept comment="DNS Serve...
by nick3dos
Wed Mar 26, 2014 12:11 pm
Forum: Beginner Basics
Topic: Local Port Forwarding
Replies: 5
Views: 2182

Re: Local Port Forwarding

In your local roules, for the port forwarding, dont use the In. Inteface field, use the Dst. Address field and put your routers local ip address
ex:
/ip firewall nat add action=dst-nat chain=dstnat disabled=no dst-address=xxx.xxx.xxx.xxx dst-port=80 protocol=udp to-addresses=192.168.1.51 to-ports=80
by nick3dos
Wed Mar 26, 2014 11:28 am
Forum: Beginner Basics
Topic: Local Port Forwarding
Replies: 5
Views: 2182

Re: Local Port Forwarding

in Ip -> Services disable "www" or change the web port of your mikrotik.
by nick3dos
Wed Mar 26, 2014 11:14 am
Forum: General
Topic: How to leave a free subnet in hotspot
Replies: 5
Views: 1584

Re: How to leave a free subnet in hotspot

I have done exactly the same setup.
Put in Walled garden Ip List in Src.Address 10.0.0.1/24.
by nick3dos
Wed Mar 26, 2014 10:32 am
Forum: General
Topic: Load balance
Replies: 6
Views: 1736

Re: Load balance

by nick3dos
Wed Mar 19, 2014 5:04 pm
Forum: General
Topic: script to auto restart pptp interface
Replies: 14
Views: 7265

Re: script to auto restart pptp interface

you could do something like:
:if ([/ping 8.8.8.8 count=5]=0) do={} else {};
but you ping goes out via your default gateway !!! if that is your pptp, then it's ok...
by nick3dos
Wed Mar 19, 2014 3:58 pm
Forum: General
Topic: script to auto restart pptp interface
Replies: 14
Views: 7265

Re: script to auto restart pptp interface

you could check if your pptp interfaces running with this script :if ([/interface pptp-client get pptp-out1 running]=true) do={} else={:log warning "pptp-out1 NOT running"; :interface pptp-client disable pptp-out; :delay 1; :interface pptp-client enable pptp-out;}; and run it with scheduler in the t...
by nick3dos
Tue Mar 18, 2014 1:58 pm
Forum: Scripting
Topic: number of dhcp lease items print out?
Replies: 2
Views: 898

Re: number of dhcp lease items print out?

log info [/ip dhcp-server lease print count-only]
by nick3dos
Thu Mar 13, 2014 10:25 am
Forum: General
Topic: accessing devices attached to the mikrotik
Replies: 5
Views: 1086

Re: accessing devices attached to the mikrotik

You can login to your ubnt devices via ssh or telent with mikrotik terminal but you cant get a lot of information of your ubnt devices.
Best way is to make a vpn connection to your mikrotik and then you will be able to login to all your ubnt device from web browser (that's what i do).
by nick3dos
Fri Feb 21, 2014 9:32 am
Forum: General
Topic: Hotspot + DSLAM + modem
Replies: 4
Views: 1421

Re: Hotspot + DSLAM + modem

Thanks a lot for your answer.
I will check everything when my dslam is here...
by nick3dos
Wed Feb 19, 2014 9:15 am
Forum: General
Topic: Hotspot + DSLAM + modem
Replies: 4
Views: 1421

Re: Hotspot + DSLAM + modem

Good to hear that !!!

In 2 weeks i will have my dslam server that i ordered, so i cant test anything yet.
What model of dslam you had?
Is there somathing special i have to be carefull for this setup?
by nick3dos
Tue Feb 18, 2014 6:02 pm
Forum: General
Topic: Dual Mikrotik failover
Replies: 4
Views: 1119

Re: Dual Mikrotik failover

NO manual about this.
It is just something that i think it would help you as solution.
YOU have to make everything (script - scheduler)
by nick3dos
Tue Feb 18, 2014 4:35 pm
Forum: General
Topic: Dual Mikrotik failover
Replies: 4
Views: 1119

Re: Dual Mikrotik failover

one solution is: - the main rb takes a backup (every some minutes/hours) and sends it to the backup rb via ftp. - the backup rb checks the main rb with ping cmd. - if the main rb is down, then the backup rb restores the last configuration sended via ftp. - if the main rb is up again, then the backup...
by nick3dos
Tue Feb 18, 2014 3:50 pm
Forum: General
Topic: IP Route Problem
Replies: 1
Views: 475

Re: IP Route Problem

Try this /ip firewall mangle add action=mark-connection chain=prerouting new-connection-mark=from_ISP2 src-address=109.201.10.0/24 add action=mark-routing chain=prerouting connection-mark=from_ISP2 new-routing-mark=to_ISP2 passthrough=no /ip route add dst-address=0.0.0.0/0 gateway=172.29.4.254 routi...
by nick3dos
Tue Feb 18, 2014 10:17 am
Forum: General
Topic: Hotspot + DSLAM + modem
Replies: 4
Views: 1421

Hotspot + DSLAM + modem

My setup wants to be like that: ----------------------------------------------------------------------------------------------------------- RB1100AHx2 (hotspot) --- 4 x DSLAM 48ports --- RJ11 cables --- 192 x Modems --- users 10.0.0.1/8 --- 10.0.0.2/8 --- --- 10.0.0.3-195 --- 10.0.1.1-10.0.x.x -----...
by nick3dos
Fri Feb 14, 2014 3:18 pm
Forum: General
Topic: Hotspot login without to open any browser?
Replies: 14
Views: 3677

Re: Hotspot login without to open any browser?

Thank you both
sure not the best solution for me but i will try
by nick3dos
Fri Feb 14, 2014 9:23 am
Forum: General
Topic: Hotspot login without to open any browser?
Replies: 14
Views: 3677

Re: Hotspot login without to open any browser?

First options - no way this can be done.
For the second - how i can limit EACH device with PCC queue ???
by nick3dos
Thu Feb 13, 2014 11:36 pm
Forum: General
Topic: Hotspot login without to open any browser?
Replies: 14
Views: 3677

Re: Hotspot login without to open any browser?

what i do until now, is a simple hotspot with one user with 1000 shared users. the limit is 1M down and 0.3 up. in the login pages i just have a button and when the user clicks it, he is logged in. i want to keep all that. i just want to find a way to keep all this without each customer to have to o...
by nick3dos
Thu Feb 13, 2014 3:49 pm
Forum: General
Topic: Hotspot login without to open any browser?
Replies: 14
Views: 3677

Re: Hotspot login without to open any browser?

My setup is in a hotel.
One rb1100ahx2 as gateway and dhcp-server
and about 50-70 small routers or ubnt devices around the hotel as APs.

If i disable hotspot, how can i limit down and up speed by queue, in the main mikrotik router?
I want to limit per device
My network is 10.0.0.1/22.
by nick3dos
Thu Feb 13, 2014 2:57 pm
Forum: General
Topic: Hotspot login without to open any browser?
Replies: 14
Views: 3677

Re: Hotspot login without to open any browser?

:lol:
Thanks

but i want to use the hotspot's functions.
limit download/upload
check how many users online
when they logged in/out

Thats why i want to make an auto loggin script somehow
by nick3dos
Thu Feb 13, 2014 2:36 pm
Forum: General
Topic: Hotspot login without to open any browser?
Replies: 14
Views: 3677

Re: Hotspot login without to open any browser?

I dont care about that.
I want all of the devices to be connected.
I just want to avoid users with smartphones problem, most of them dont knnow that they need to open web browser for login, they go straight to open their applications.
by nick3dos
Thu Feb 13, 2014 12:23 pm
Forum: General
Topic: Hotspot login without to open any browser?
Replies: 14
Views: 3677

Hotspot login without to open any browser?

Is there any way to make my users, automatically login to my hotspot, without to open any web browser?

I can't use mac-auth.

Maybe somehow, when the user gets ip from the dhch-server, could auto log him in ????
by nick3dos
Tue Feb 11, 2014 3:06 pm
Forum: RouterBOARD hardware
Topic: Support request, How to reset if the only ether is disabled
Replies: 6
Views: 1442

Re: Support request, How to reset if the only ether is disab

You have access to the mikrotik device and not in the wireless interface???

!!! strange !!!
by nick3dos
Mon Feb 10, 2014 11:46 am
Forum: RouterBOARD hardware
Topic: Support request, How to reset if the only ether is disabled
Replies: 6
Views: 1442

Re: Support request, How to reset if the only ether is disab

try to connect from the wireless interface (if it was enabled)
by nick3dos
Mon Feb 10, 2014 11:40 am
Forum: General
Topic: Mikrotik telnet don't work
Replies: 2
Views: 950

Re: Mikrotik telnet don't work

connect an other mikrotik device to the lan interface and try to connect via mac-telent
by nick3dos
Mon Feb 10, 2014 11:00 am
Forum: Beginner Basics
Topic: Best way to configure LAN side of RB2011UAS
Replies: 2
Views: 776

Re: Best way to configure LAN side of RB2011UAS

Set master port to interfaces 3-10 -> port2
or
Make a bridge with ports 2-10 then apply to it your lan ip address and dhcp-server
by nick3dos
Fri Feb 07, 2014 10:16 am
Forum: Scripting
Topic: Date changes during bootup
Replies: 5
Views: 852

Re: Date changes during bootup

It is the time until your routeboard connects to your network and the internet and gets the correct time.
by nick3dos
Fri Feb 07, 2014 10:11 am
Forum: Scripting
Topic: Export user - email script
Replies: 20
Views: 3869

Re: Export user - email script

thanks for responding
I've tried it but i didn't get the same result , I'm on 951 RB, any changes???
thanks
What is your result in the file???
by nick3dos
Fri Jan 24, 2014 5:48 pm
Forum: General
Topic: domain name to my mikrotik router
Replies: 4
Views: 6128

Re: domain name to my mikrotik router

no-ip or change ip or dyndns is what goes on with a 3rd party server. I want some method where I purchase a domain & tag it with my router. I have public static ip's from my isp. need to tag in the domain name with that ip. Then, you just have to put your static ip address, in your no-ip account. I...
by nick3dos
Wed Jan 22, 2014 1:35 pm
Forum: General
Topic: Hotspot Doubt
Replies: 2
Views: 517

Re: Hotspot Doubt

Check:
1. ip -> hotspot - >ip bindings
and
2. ip -> hotspot -> ip walled garden ip list
by nick3dos
Wed Jan 22, 2014 10:08 am
Forum: Scripting
Topic: script run by scheduler doesn't work
Replies: 5
Views: 5343

Re: script run by scheduler doesn't work

The solution is to add to the script in Policy section: test and policy.
by nick3dos
Wed Jan 22, 2014 9:45 am
Forum: Beginner Basics
Topic: router name
Replies: 4
Views: 1451

Re: router name

Out of interest, how do you change the name from the CLI?[/quote]
/ip dns static set numbers=0 name="my_new_name"
by nick3dos
Thu Jan 16, 2014 12:27 am
Forum: General
Topic: HELP with UDP flooding
Replies: 6
Views: 2129

Re: HELP with UDP flooding

I have 40 static ips in my metwork from my ISP.
In two of them i discovered this problem, two days now.
UDP flood are from different addresses and different ports.
by nick3dos
Wed Jan 15, 2014 11:50 pm
Forum: General
Topic: HELP with UDP flooding
Replies: 6
Views: 2129

Re: HELP with UDP flooding

Thanks for your answer.
My ISP cant help me.

At least i want to stop flood connections of that ips.
If i manually drop in firewall the ips that make the connections, in some point it is all ok.

But how can these ips be dynamic added to these firewall rules, without every time to do it manually?
by nick3dos
Wed Jan 15, 2014 6:07 pm
Forum: General
Topic: HELP with UDP flooding
Replies: 6
Views: 2129

Re: HELP with UDP flooding

???
by nick3dos
Wed Jan 15, 2014 10:49 am
Forum: General
Topic: HELP with UDP flooding
Replies: 6
Views: 2129

HELP with UDP flooding

Can someone tell what i have to do to prevent UDP flooding in my router. I search the wiki and found these roules: add action=drop chain=forward disabled=no dst-address-list=udp_flooded add action=drop chain=forward disabled=no src-address-list=udp_flooder add action=jump chain=forward comment="UDP ...
by nick3dos
Mon Jan 13, 2014 10:45 am
Forum: General
Topic: Mikrotik accounting only - without authentication
Replies: 1
Views: 914

Re: Mikrotik accounting only - without authentication

ex: You can make a hotspot with one user with username: user1 and password: test1 and in login.html write this: <html> <head> <meta http-equiv="refresh" content="0; url=login?username=user1&password=test1"> <meta http-equiv="pragma" content="no-cache"> <meta http-equiv="expires" content="-1"> </head...
by nick3dos
Mon Jan 13, 2014 10:08 am
Forum: General
Topic: Hotspot Trial user uptime problem
Replies: 3
Views: 891

Re: Hotspot Trial user uptime problem

In IP -> Hotspot -> User profile, check the values in: Session Timeout, Idle Timeout, Keepalive Timeout if some of these are less than 15 minutes
by nick3dos
Mon Dec 16, 2013 12:09 pm
Forum: Scripting
Topic: Monitoring Script
Replies: 19
Views: 3770

Re: Monitoring Script

use this: http://forum.mikrotik.com/viewtopic.php ... dude+gmail
I use this over one year and email comes to me when each device is up or down.
by nick3dos
Mon Dec 16, 2013 9:42 am
Forum: Beginner Basics
Topic: Hostspot problem!
Replies: 3
Views: 911

Re: Hostspot problem!

We have a mikrotik hotspot running, people with hotspot when they are inactive for like 20 mins they get the re-auth again, is there a way to keep it longer so they dont need to auth all times ?
In hotspot -> user profile check "session-idle-keepalive timeout" settings.
by nick3dos
Mon Dec 16, 2013 9:33 am
Forum: Scripting
Topic: Monitoring Script
Replies: 19
Views: 3770

Re: Monitoring Script

you can use Dude to do it.
by nick3dos
Wed Dec 11, 2013 11:49 am
Forum: General
Topic: Interface TX, RX byte Backup every day
Replies: 5
Views: 2318

Re: Interface TX, RX byte Backup every day

Change username, password and ether1-LAN to your values /tool e-mail set address=0.0.0.0 from=username@gmail.com password=pass port=25 starttls=no user=username /system script add name=script1 policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api source="#get tx - rx\r\ \n:loc...
by nick3dos
Fri Dec 06, 2013 12:49 am
Forum: Scripting
Topic: Export user - email script
Replies: 20
Views: 3869

Re: Export user - email script

Got it, I didn't have a space right :)

Again, thanks for your help with this.
:D
by nick3dos
Fri Dec 06, 2013 12:47 am
Forum: Scripting
Topic: Export user - email script
Replies: 20
Views: 3869

Re: Export user - email script

/system script add name=email policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api source="#get name date and time\r\ \n:local name [/system identity get name];\r\ \n:local date [/system clock get date];\r\ \n:local time [/system clock get time];\r\ \n#make subject message\r...
by nick3dos
Thu Dec 05, 2013 9:31 am
Forum: Scripting
Topic: Export user - email script
Replies: 20
Views: 3869

Re: Export user - email script

As i understand you need something like that: For saving the online users to file /ip hotspot active print file=connections.txt For saving the hotspot users to file /ip hotspot user print file=connections.txt To reset the file /file set connections.txt contents="" Use this commands in scripts before...
by nick3dos
Thu Dec 05, 2013 12:26 am
Forum: Scripting
Topic: Export user - email script
Replies: 20
Views: 3869

Re: Export user - email script

what do you want to print?
usernames that have logged in during the day?

if so, you have to make a new script to keep it in a text file, but you have to check for duplicate usernames and looged out usernames.

It is more complicated script....
by nick3dos
Wed Dec 04, 2013 9:52 pm
Forum: Scripting
Topic: Export user - email script
Replies: 20
Views: 3869

Re: Export user - email script

yes, everytime someone logs in, the number in the file goes +1
by nick3dos
Wed Dec 04, 2013 8:49 pm
Forum: Scripting
Topic: Export user - email script
Replies: 20
Views: 3869

Re: Export user - email script

Thanks nick3dos, I copied your connections script, but I don't know if I'm missing something from the picture as it's running and not creating the .txt I forgot to tell you... You have to make the starting file, so... just create the text file "connections.txt" in your windows pc and just write the...
by nick3dos
Wed Dec 04, 2013 5:49 pm
Forum: Scripting
Topic: Export user - email script
Replies: 20
Views: 3869

Re: Export user - email script

use the settings below (ofcourse you have to change username and password of your email account):
by nick3dos
Wed Dec 04, 2013 11:26 am
Forum: Scripting
Topic: Export user - email script
Replies: 20
Views: 3869

Re: Export user - email script

In my setup i give free internet for 1:30 hour with trial method.
I keep a file "connections.txt" witch keeps the total number of users logged in.
I use an other program to download the file with ftp and get my daily and my total reports
by nick3dos
Mon Dec 02, 2013 1:09 pm
Forum: Beginner Basics
Topic: Loadbalancer with 4 pppoe-out interface from same provider
Replies: 3
Views: 1951

Re: Loadbalancer with 4 pppoe-out interface from same provid

This is my setup with 3 bridged modems load balancing and working very good. You can add an extra modem very easily. I use RB1100 so need to change some ethernet names and ports. Interfaces --------------- ether01-MODEM1 ether04-MODEM4 ether05-MODEM5 pppoe-MODEM1 pppoe-MODEM4 pppoe-MODEM5 ether13-GW...
by nick3dos
Thu Nov 21, 2013 3:51 pm
Forum: RouterBOARD hardware
Topic: failover with 3 WAN without balancing
Replies: 2
Views: 1219

Re: failover with 3 WAN without balancing

/ip route
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=WAN1 – PPPOE connection, static IP
add disabled=no distance=2 dst-address=0.0.0.0/0 gateway=WAN2 – static IP
add disabled=no distance=3 dst-address=0.0.0.0/0 gateway=192.168.4.4
Change WAN1 and WAN2 to your static ips...
by nick3dos
Wed Nov 06, 2013 11:08 am
Forum: Beginner Basics
Topic: Mikrotik can't ping the internet just can ping gateway (DSL)
Replies: 4
Views: 6871

Re: Mikrotik can't ping the internet just can ping gateway (

open a new terminal and paste this:
/ip firewall nat
add action=masquerade chain=srcnat disabled=no src-address=192.168.2.0/24
This should work for you.
by nick3dos
Wed Nov 06, 2013 10:50 am
Forum: Beginner Basics
Topic: How to print address-list filtered by list name?
Replies: 1
Views: 1448

Re: How to print address-list filtered by list name?

A way to do it, is to put a comment in each address list you have and type:
/ip firewall address-list print where comment="list_comment"
by nick3dos
Tue Nov 05, 2013 4:40 pm
Forum: Beginner Basics
Topic: Mikrotik can't ping the internet just can ping gateway (DSL)
Replies: 4
Views: 6871

Re: Mikrotik can't ping the internet just can ping gateway (

I think it is nat problem
In your nat rule change:
1. "src-address = 192.168.2.0" to "src-address = 192.168.2.0/24"
2. delete "out-interface = WAN".
by nick3dos
Mon Nov 04, 2013 4:00 pm
Forum: Beginner Basics
Topic: Cannot get Route to work
Replies: 6
Views: 2015

Re: Cannot get Route to work

Are you sure you want to use 192.168.1.254/ 32 and not 192.168.1.254/ 24 ??? If it is /24... 1. For your rb433 a. You must have as gateway your modem, so put it as your main gateway /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.0.1 scope=30 target-scope=10 b. You must pu...
by nick3dos
Mon Nov 04, 2013 12:31 pm
Forum: Scripting
Topic: C++ and API. HELP !!!
Replies: 3
Views: 975

Re: C++ and API. HELP !!!

I understand, thank you.
by nick3dos
Mon Nov 04, 2013 10:43 am
Forum: Scripting
Topic: C++ and API. HELP !!!
Replies: 3
Views: 975

Re: C++ and API. HELP !!!

???
by nick3dos
Fri Nov 01, 2013 4:41 pm
Forum: Scripting
Topic: C++ and API. HELP !!!
Replies: 3
Views: 975

C++ and API. HELP !!!

I am using c++ builder 6 and i want to use it to make some simple programs using mikrotik API.
I read the wiki but i didnt understand how to connect to my mikrotik device.
Is there anyone who can send me a simple project of c++ builder 6 using API?
For start i want just to login to a mikrotik device.
by nick3dos
Tue Oct 22, 2013 1:49 pm
Forum: Wireless Networking
Topic: Mikrotik RB 450 G with Bullet M2HP
Replies: 2
Views: 2013

Re: Mikrotik RB 450 G with Bullet M2HP

first of all, in your mikrotik router, you have to bridge ether4 to your lan network, and apply the dhcp server to that. the in your bullet, make it in ap-mode and for network user it in bridge mode and give an ip of your lan network ex. mikrotik bridge interface 192.168.1.1/24 ubnt lan : 192.168.1....
by nick3dos
Tue Oct 22, 2013 1:36 pm
Forum: General
Topic: Multiple IP on one WAN interface with multiple LANs
Replies: 5
Views: 6242

Re: Multiple IP on one WAN interface with multiple LANs

WAN:
eth1-gateway, with three public IP addresses: 80.53.17.54/29, 80.53.17.55/29, 80.53.17.56/29 - for all of them gateway is 80.53.17.53
what you mean by that?
what is the configuration?
by nick3dos
Tue Oct 15, 2013 12:21 pm
Forum: Wireless Networking
Topic: Router reboot
Replies: 1
Views: 1426

Re: Router reboot

check system -> resources -> uptime
by nick3dos
Tue Oct 15, 2013 11:55 am
Forum: Wireless Networking
Topic: need help in config dhcp and rout
Replies: 5
Views: 1002

Re: need help in config dhcp and rout

do you have this?
/ip firewall nat
add action=masquerade chain=srcnat disabled=no src-address=172.16.60.0/24
If not, you need it...
by nick3dos
Sat Sep 14, 2013 7:25 pm
Forum: General
Topic: Automatic link fail-over
Replies: 4
Views: 972

Re: Automatic link fail-over

hi, Its not shifting automatically because the fiber gateway is up and net was down from third hope. Then you have to do it with a script-scheduler. You have to check the main gateway ip, of the fiber gateway, by ping command. If not ping to this ip, then change to your second gateway. If ping is o...
by nick3dos
Thu Sep 12, 2013 1:52 pm
Forum: General
Topic: Automatic link fail-over
Replies: 4
Views: 972

Re: Automatic link fail-over

in your ip -> routes add two new routes for default gateway, one for your fiber with distance=1 and one for your wifi with distance=2, so everytime fiber gateway is down, it will automatically shift to your wifi gateway, and when your fiber gateway is back again automatically it will change back to ...
by nick3dos
Wed Sep 11, 2013 2:33 pm
Forum: General
Topic: Disconnetion notification
Replies: 3
Views: 655

Re: Disconnetion notification

Thanks, I don't care about the e-mail script, i already have it working. The point is, that ever with netwatch or script i couldn't "see" the disconnections if they last for less than a second. And i dont want the make my router check every second 8 pppoe connections. I needed something like hotspot...
by nick3dos
Wed Sep 11, 2013 12:14 pm
Forum: General
Topic: Disconnetion notification
Replies: 3
Views: 655

Disconnetion notification

Hello,

Is there any way so that my mikrotik router notifies me by email or something, when my pppoe-client connections are disconnected
But without a script, i don't want to force my router to check every second my connections...
by nick3dos
Thu Sep 05, 2013 3:29 pm
Forum: Wireless Networking
Topic: Mikrotik RB device as a repeater (no WDS)
Replies: 4
Views: 1440

Re: Mikrotik RB device as a repeater (no WDS)

Hello you can use both wireless interfaces as you want, station or AP. so, Yes, you can use it as "repeater", as long as you bridge these 2 interfaces. and yes, you need external antennas Can I bridge the 2 interfaces in 2.4GHz mode ? Μπορούμε να μιλάμε και Ελληνικά αλλά καλό λόγω forum να μείνουμε...
by nick3dos
Thu Sep 05, 2013 3:22 pm
Forum: The User Manager
Topic: Software to sell Logins
Replies: 1
Views: 1057

Re: Software to sell Logins

I have made a program just for this case http://forum.mikrotik.com/viewtopic.php?t=55266

you can upload csv files (of radius manager that i use)

..but... i haven't finish it totaly (due to no free time ), so it is not ready to be sold yet...

Let me know if you are looking something like this...
by nick3dos
Thu Sep 05, 2013 3:11 pm
Forum: Wireless Networking
Topic: Mikrotik RB device as a repeater (no WDS)
Replies: 4
Views: 1440

Re: Mikrotik RB device as a repeater (no WDS)

Hello

you can use both wireless interfaces as you want, station or AP.
so, Yes, you can use it as "repeater", as long as you bridge these 2 interfaces.

and yes, you need external antennas
by nick3dos
Thu Sep 05, 2013 11:45 am
Forum: General
Topic: Hotspot can not functioning
Replies: 2
Views: 549

Re: Hotspot can not functioning

For the first, are you sure your are logged out? did you check in your mikrotik hotspot that your are looged out? if yes probably your computer's browser need some refresh...

For the second, it looks like: nat - masquede problem. if you are doing it, disable it.
by nick3dos
Mon Sep 02, 2013 2:07 pm
Forum: Wireless Networking
Topic: bad link ,,but perfect download speed
Replies: 6
Views: 1535

Re: bad link ,,but perfect download speed

try to lower the wireless Tx power
by nick3dos
Mon Sep 02, 2013 11:29 am
Forum: Beginner Basics
Topic: HotSpot and AP in different networks
Replies: 1
Views: 464

Re: HotSpot and AP in different networks

Yes it is possible but all your AP must be in bridge mode and NOT give any dhcp-server, only your main MT must have dhcp-server...
by nick3dos
Fri Aug 30, 2013 7:16 pm
Forum: General
Topic: VPN Site to Site behind nat
Replies: 11
Views: 8419

Re: VPN Site to Site behind nat

you can use any protocol you want, pptp is just the most common.

can you post you config?
by nick3dos
Fri Aug 30, 2013 4:35 pm
Forum: General
Topic: VPN Site to Site behind nat
Replies: 11
Views: 8419

Re: VPN Site to Site behind nat

i haven't use it in that mode (nat) but the only i can think, is to make a port forward to your modem, the TCP port 1723, that pptp uses and check if you can make the pptp connection to your mt router like that.
by nick3dos
Fri Aug 30, 2013 3:37 pm
Forum: General
Topic: VPN Site to Site behind nat
Replies: 11
Views: 8419

Re: VPN Site to Site behind nat

make your modems in bridge mode and make the pppoe connection in your mikrotik routers, so your mt will get the internet ip. then with a script you can update your internet ip to a ddns server site like : no-ip.com, so you will always have access to your rotuers. then you can use pptp, to make your ...
by nick3dos
Fri Aug 30, 2013 10:09 am
Forum: Beginner Basics
Topic: Email script - Gmail
Replies: 3
Views: 989

Re: Email script - Gmail

try to use port=25
by nick3dos
Wed Aug 28, 2013 1:57 pm
Forum: Scripting
Topic: Script for active hotpost users - send periodically
Replies: 3
Views: 1261

Re: Script for active hotpost users - send periodically

You need something like this, you just have to change your email accounts /system script add name=active policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api source="#get time date and active users\r\ \n:local date [/system clock get date];\r\ \n:local time [/system clock get...
by nick3dos
Fri Aug 23, 2013 10:08 am
Forum: Beginner Basics
Topic: Confiuration Upload
Replies: 1
Views: 558

Re: Confiuration Upload

1. open menu "Files".
2. click "backup".
3. drag and drop in your desktop tha backup file.
4. open menu "Files" in the new mikrotik device.
5. drag and drop the backup file from your desktop (you have to login with ip, not mac).
6. click "Restore".
7. reboot
by nick3dos
Fri Aug 23, 2013 9:25 am
Forum: General
Topic: Remote access via GSM between MT routers, advise please...
Replies: 7
Views: 2222

Re: Remote access via GSM between MT routers, advise please.

First of all, i assume that in every place you have 3g modems, you have at least one mikrotik device also. Then, you need just an other mikrotik device, in an other place (maybe your home), that will be your main pptp-server. Now, all your other mikritik devices can make pptp connections to your mai...
by nick3dos
Thu Aug 22, 2013 3:18 pm
Forum: General
Topic: Remote access via GSM between MT routers, advise please...
Replies: 7
Views: 2222

Re: Remote access via GSM between MT routers, advise please.

If i understand correctly you want to have access to your mikrotik router from far away with any of the two gateways is available. If you dont want to care about dynamik ip's of 3g provider, you can do something like i did. Make in your mikrotik router a pptp-client connection (with NOT default rout...
by nick3dos
Wed Aug 07, 2013 11:46 am
Forum: General
Topic: No-Ip with Mikrotik not working
Replies: 5
Views: 3853

Re: No-Ip with Mikrotik not working

I use this script for over two years with no problem. I run it every two hours... log info "" :local ipadd [/ip address get [find interface=pppoe-MODEM1 ] address ] :local NOIPUser "username" :local NOIPPass "password" :local NOIPDomain "yourdomain.myftp.org" :local IpCurrent ("$ipadd" .\ "/32"); #:...
by nick3dos
Mon Jul 22, 2013 4:50 pm
Forum: Beginner Basics
Topic: how to block unknown IP
Replies: 4
Views: 1479

Re: how to block unknown IP

/ip firewall filter
add action=drop chain=input src-address=118.175.15.205
or go to Ip->Services and in the SSH Service change the Available From ip range
by nick3dos
Wed Jul 17, 2013 9:56 am
Forum: General
Topic: port opened but not forwarded
Replies: 8
Views: 1638

Re: port opened but not forwarded

put 2 new rules for UDP protocol also like i did

http://forum.mikrotik.com/viewtopic.php ... 33#p358892

most cameras needs both protocols to be forwarded...
by nick3dos
Wed Jun 26, 2013 5:48 pm
Forum: General
Topic: help with mangle rules...
Replies: 3
Views: 992

Re: help with mangle rules...

other 45 rules are for QOS

even if i move these rules on the top , it's the same
by nick3dos
Wed Jun 26, 2013 3:39 pm
Forum: General
Topic: help with mangle rules...
Replies: 3
Views: 992

Re: help with mangle rules...

Anyone ???

it was working before with RB1100AH - 5.24

but now nothing...
by nick3dos
Fri Jun 21, 2013 11:28 am
Forum: General
Topic: help with mangle rules...
Replies: 3
Views: 992

help with mangle rules...

Hello all, i have made this config to redirect my list of ips "EC" to an other gateway, but not working... What is the problem ??? /ip firewall mangle add action=mark-connection chain=prerouting comment=EC disabled=no new-connection-mark=from_EC src-address-list=EC add action=mark-routing chain=prer...
by nick3dos
Tue Jun 18, 2013 1:24 pm
Forum: Scripting
Topic: Hotspot Free Trial - How to limit number of users
Replies: 3
Views: 1740

Re: Hotspot Free Trial - How to limit number of users

I think you need something like this:
by nick3dos
Thu Jun 13, 2013 4:13 pm
Forum: RouterBOARD hardware
Topic: rb Metal with angled connector?
Replies: 16
Views: 2916

Re: rb Metal with angled connector?

It's the same as with straight connection to antenna. Tighten properly and nothing moves. Just yesterday i visit a mountain, that i had installed this rb Metal with angled connector, that it was tighten properly (believe me), but it was turned a little (about 30 degrees) becouse of the strong wind....
by nick3dos
Wed Jun 12, 2013 4:14 pm
Forum: The Dude
Topic: Ping probes under 2 seconds fail
Replies: 7
Views: 1976

Re: Ping probes under 2 seconds fail

... I thing that the ping cmd needs this time to work properly and get your results... Hi nick3dos, but, when you use the right button ping tool, you can make ping under one second and it works perfectly. It seems a Dude programming bug. I think Lebowski is right :( Regards, Marcos. Yes i know that...
by nick3dos
Tue Jun 11, 2013 4:36 pm
Forum: The Dude
Topic: Ping probes under 2 seconds fail
Replies: 7
Views: 1976

Re: Ping probes under 2 seconds fail

I have made an exe program for windows, similar to dude, to reboot my devices daily and check them with ping command. what i found out is that i had to make a delay of 1.3 ms - 1.4 ms between ping commands. With 1 ms time i didn't have answer... I thing that the ping cmd needs this time to work prop...
by nick3dos
Wed May 22, 2013 4:33 pm
Forum: Wireless Networking
Topic: Any way to show CURRENT TX POWER table in terminal or ssh?
Replies: 3
Views: 2769

Re: Any way to show CURRENT TX POWER table in terminal or ss

Write in terminal
interface wireless print
Choose the number of your wireless interface (ex = 0) and write again in terminal
log info [/interface wireless get number=0 tx-power]
You should see in the log window the CURRENT TX POWER...
by nick3dos
Fri May 17, 2013 2:22 pm
Forum: Wireless Networking
Topic: self assigned ip problem
Replies: 4
Views: 1389

Re: self assigned ip problem

ok, sorry for being a complete noob here, but how do i add a defauld gateway and dns server. i have looked through the entire winbox interface but cant find it?? this is all so new to me copy paste this in a new terminal /ip route add comment=Default_Gateway disabled=no distance=1 dst-address=0.0.0...
by nick3dos
Fri May 17, 2013 2:12 pm
Forum: RouterBOARD hardware
Topic: CLOUD CORE ROUTER
Replies: 1374
Views: 1018172

Re: CLOUD CORE ROUTER

hi nick3dos one question how did you set your hotspot config?? just hope you didn't backup your old config and then put it on the new hardware/upgrade soft? because I suffered this issue while upgrading ROS every time. to solve this issue I made an export compact then after for example upgrade to (...
by nick3dos
Thu May 16, 2013 4:06 pm
Forum: Wireless Networking
Topic: self assigned ip problem
Replies: 4
Views: 1389

Re: self assigned ip problem

You can not get an ip from modem's dhcp server.

1. Make sure your bridge interface has both ether1 and wlan1 interface.

2. put an ip (ex. 192.168.1.2/24) to your bridge interface.

3. add a default gateway 192.168.1.1 and dns server 192.168.1.1

4. and don't create any dhcp server.
by nick3dos
Fri May 10, 2013 11:15 am
Forum: RouterBOARD hardware
Topic: CLOUD CORE ROUTER
Replies: 1374
Views: 1018172

Re: CLOUD CORE ROUTER

Even with the new update, i can't yet see any traffic in Hotspot's Tx Rate collum

Anyone else the same problem?
Any ideas???
by nick3dos
Mon Apr 22, 2013 6:34 pm
Forum: General
Topic: RouterOS v6.0rc13 released
Replies: 81
Views: 27959

Re: RouterOS v6.0rc13 released

Hello

I just get my new CCR1016-12G.
I have installed 6.0rc13 version.

I made my hotspot just like i had it before with RB1100AH v.5.24.
Everything works fine but in ip -> hotspot -> active, i can't see any traffic on Tx Rate collum

Anybody knows why is this happening???
by nick3dos
Mon Apr 22, 2013 12:13 pm
Forum: RouterBOARD hardware
Topic: CLOUD CORE ROUTER
Replies: 1374
Views: 1018172

Re: CLOUD CORE ROUTER

Hello

I just get my new CCR1016-12G.
I have installed 6.0rc13 version.

I made my hotspot just like i had it before with RB1100AH v.5.24.
Everything works fine but in ip -> hotspot -> active, i can't see any traffic on Tx Rate collum

Anybody knows why is this happening???
by nick3dos
Mon Apr 22, 2013 9:22 am
Forum: General
Topic: access rb with public ip with other gateway
Replies: 1
Views: 461

Re: access rb with public ip with other gateway

anyone???
by nick3dos
Fri Apr 19, 2013 10:00 am
Forum: General
Topic: access rb with public ip with other gateway
Replies: 1
Views: 461

access rb with public ip with other gateway

Hello all, i want help to solve a problem i have... One of my routerboards connects to my network. ip: 10.10.248.5 gw: 10.10.248.1 I have also give a static ip to this routerboard with pptp connection to my main vpn server. What i want is: my routerboard to keep the default gateway 10.10.248.1 but i...
by nick3dos
Thu Apr 04, 2013 2:30 pm
Forum: General
Topic: Mikrotik send current/connected IP to my email address
Replies: 15
Views: 4018

Re: Mikrotik send current/connected IP to my email address

yes
Can I delete this script any time from /system/script
You can't have two scripts with the same name.

Or you can delete the old one Or you can name the new one with other name (test_email2)...
by nick3dos
Thu Apr 04, 2013 9:27 am
Forum: General
Topic: Mikrotik send current/connected IP to my email address
Replies: 15
Views: 4018

Re: Mikrotik send current/connected IP to my email address

I am sure it will not send you like this... The script i gave you, is auto generated with export command from terminal. Remove the last script you add first. You have to open the terminal and write: system scripts and hit enter and after that copy paste the script in the terminal. If everything is o...
by nick3dos
Wed Apr 03, 2013 5:11 pm
Forum: General
Topic: Mikrotik send current/connected IP to my email address
Replies: 15
Views: 4018

Re: Mikrotik send current/connected IP to my email address

I just run the below srcipt and the email arrived with the backup file. Run this first, if email not arrive check again with a gmail account like i did. add name=test_mail policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api source="#make the backup file\r\ \n/system backup s...
by nick3dos
Wed Apr 03, 2013 9:37 am
Forum: General
Topic: Mikrotik send current/connected IP to my email address
Replies: 15
Views: 4018

Re: Mikrotik send current/connected IP to my email address

When I am exit from winbox then script automatically stop but why stop I do not understand, my server is continue running. If you want your script to run automatically you should add a scheduler to this. This is how to add it if your script named: email and want to run it every 6 hours. /system sch...
by nick3dos
Tue Apr 02, 2013 10:14 am
Forum: General
Topic: Mikrotik send current/connected IP to my email address
Replies: 15
Views: 4018

Re: Mikrotik send current/connected IP to my email address

First of all you have to be sure to write your email settings in mikrotik:
/tool e-mail
set address=0.0.0.0 from=username@gmail.com password=pass port=\
    25 starttls=no user=username
by nick3dos
Mon Apr 01, 2013 3:45 pm
Forum: General
Topic: DHCP lease without success!!! shoot me now.
Replies: 8
Views: 4441

Re: DHCP lease without success!!! shoot me now.

You have 2 networks 192.168.53.x and 192.168.50.x in dhcp1 server ???
maybe that's your problem...
by nick3dos
Mon Apr 01, 2013 11:18 am
Forum: General
Topic: Mikrotik send current/connected IP to my email address
Replies: 15
Views: 4018

Re: Mikrotik send current/connected IP to my email address

If your mikrotik router makes the pppoe connection, you should add a script like this:
:local ipadd [/ip address get [find interface=pppoe-modem  ] address ];
:local msg (" My ip is: $ipadd");
/tool e-mail send to="email@gmail.com" subject="My Ip" body=$msg  server=[:resolve smtp.gmail.com] tls=yes;
by nick3dos
Fri Mar 29, 2013 9:01 pm
Forum: General
Topic: Intranet Redirect ???
Replies: 8
Views: 1944

Re: Intranet Redirect ???

Thanks a lot man

it is working very good now

+1
by nick3dos
Fri Mar 29, 2013 4:38 pm
Forum: General
Topic: Intranet Redirect ???
Replies: 8
Views: 1944

Re: Intranet Redirect ???

Thank you for the answer, I follwed your way and now i can see all the connections mangled in the firewall->connections table but traffic can NOT be redirected. Traffic of mangled ip's have the default gateway 192.168.1.1 and not the 192.168.1.254 (different ISP). /ip firewall address-list add addre...
by nick3dos
Fri Mar 29, 2013 10:26 am
Forum: General
Topic: Intranet Redirect ???
Replies: 8
Views: 1944

Re: Intranet Redirect ???

come on !!!

I don't believe that no one knows the answer to this problem...

:?
by nick3dos
Wed Mar 27, 2013 9:24 am
Forum: General
Topic: Intranet Redirect ???
Replies: 8
Views: 1944

Re: Intranet Redirect ???

I have already made some mangle rules like this: /ip firewall mangle add action=accept chain=prerouting comment=\ 1/4-connection_from_1_1_30_x connection-mark=\ connection_from_1_1_30_x disabled=no add action=mark-routing chain=prerouting comment=2/4-to_1_1_30_x \ disabled=no new-routing-mark=to_1_1...
by nick3dos
Tue Mar 26, 2013 3:15 pm
Forum: General
Topic: Intranet Redirect ???
Replies: 8
Views: 1944

Intranet Redirect ???

Hi, My intranet network is 1.1.0.0/16. I have my main hotspot server with ip: 1.1.0.1/24 with default gateway 192.168.1.1/24 (modem). I also have an other gateway with ip: 192.168.1.254/24 (other modem). Now, my question is: How can i redirect some range of ips (example: 1.1.30.0/24 and 1.1.35.0/24)...
by nick3dos
Fri Mar 22, 2013 3:29 pm
Forum: Wireless Networking
Topic: Multiple RB433 deployment questions
Replies: 3
Views: 753

Re: Multiple RB433 deployment questions

It has been asked before,
i did it before, in my way...

maybe this will help you
http://forum.mikrotik.com/viewtopic.php?f=2&t=68881
by nick3dos
Fri Mar 08, 2013 10:30 am
Forum: General
Topic: Updating multiple routers at once
Replies: 2
Views: 925

Re: Updating multiple routers at once

I wanted to do the same, i have about 60 mikrotik devices... so the only solution i found and helped me is: I upload to a local ftp server all the changes i want to do in a script file .rsc I push all my mikrotik devices to check the ftp server every 5 minutes for this file. If file is found, is dow...
by nick3dos
Thu Mar 07, 2013 2:35 pm
Forum: General
Topic: winbox save Desktop?
Replies: 3
Views: 559

Re: winbox save Desktop?

I have always checked this, but it does not help... everytime i have to open the windows i want and resize them... i also have to tell you that we are 3 operators for our mikrotik devices with 3 different computers, so i don't know if this has to do with the different computers screen resolotions...
by nick3dos
Thu Mar 07, 2013 2:25 pm
Forum: General
Topic: winbox save Desktop?
Replies: 3
Views: 559

Re: winbox save Desktop?

I have always checked this, but it does not help...
everytime i have to open the windows i want and resize them...
by nick3dos
Thu Mar 07, 2013 2:21 pm
Forum: General
Topic: winbox save Desktop?
Replies: 3
Views: 559

winbox save Desktop?

Hello,

Is there any option to save "desktop" in winbox?
so i do not have every time to open the windows and resize them...

I just want when i open my mikrotik device with winbox, to auto open the windows i want, in position i want, in the size i want...
by nick3dos
Thu Mar 07, 2013 10:57 am
Forum: Beginner Basics
Topic: Help with first router configuration, possible NAT problem
Replies: 7
Views: 807

Re: Help with first router configuration, possible NAT probl

No I can't, 8.8.8.8 just times out. I did try pinging googles IP to try and rule out a DNS issue. The PPPoE client is set to use peer DNS, and the DHCP points the workstation to 192.168.1.1 as the default gateway and DNS server, which I've confirmed in ipconfig. So, your workstation has: Ip: 192.16...
by nick3dos
Thu Mar 07, 2013 10:09 am
Forum: Scripting
Topic: LOADBALANCING
Replies: 1
Views: 544

Re: LOADBALANCING

by nick3dos
Thu Mar 07, 2013 9:27 am
Forum: Beginner Basics
Topic: Help with first router configuration, possible NAT problem
Replies: 7
Views: 807

Re: Help with first router configuration, possible NAT probl

If your lan network in ether12 is 192.168.1.0/24
user this:
/ip firewall nat
add action=masquerade chain=srcnat disabled=no src-address=192.168.1.0/24
by nick3dos
Wed Mar 06, 2013 4:21 pm
Forum: General
Topic: I did it :(
Replies: 4
Views: 1031

Re: I did it :(

you can access via mac-telnet and remove the rule

M.
Is mac-telnet enabled by default?
YES
by nick3dos
Wed Mar 06, 2013 3:14 pm
Forum: Beginner Basics
Topic: Explination about the values
Replies: 1
Views: 484

Re: Explination about the values

Tx/Rx Signal Strength: How Higher the better???? for example -45 is better then -67????
Signal to Noise: the higher the better???? 90 is better than 74dB????
Tx/Rx CCQ: Higher is better???? 90 is better dan 73%??????
YES to all...
by nick3dos
Wed Mar 06, 2013 3:11 pm
Forum: Beginner Basics
Topic: RB750GL: two interfaces to the same network
Replies: 6
Views: 4449

Re: RB750GL: two interfaces to the same network

if i understand correct your first question of "sharing two interfaces (ether2 and ether3)"
you just have to bridge your two ethernet ports and assign your 192.168.10.0 network to the bridge interface.
by nick3dos
Wed Mar 06, 2013 2:37 pm
Forum: Beginner Basics
Topic: RB750GL: two interfaces to the same network
Replies: 6
Views: 4449

Re: RB750GL: two interfaces to the same network

bridge your 2 etherent ports 2 and 3
and don't forget to change your lan ip to the bridge interface, too...
by nick3dos
Wed Mar 06, 2013 2:34 pm
Forum: General
Topic: port forward ip cam
Replies: 6
Views: 1700

Re: port forward ip cam

your camera may need some other port to be forward also
i have seen this before with some types of cameras
check this first...
by nick3dos
Wed Mar 06, 2013 10:44 am
Forum: General
Topic: port forward ip cam
Replies: 6
Views: 1700

Re: port forward ip cam

If this help you more, here is my configuration, of my mikrotik device, with bridged modem connected with pppoe in ether1-MODEM and all the firewall rules for the 4 cameras i have. my lan network is 192.168.1.0/24. my cameras: 192.168.1.21-22-23-24. I put an ip to my modem 192.168.2.1 and 192.168.1....
by nick3dos
Tue Mar 05, 2013 4:30 pm
Forum: General
Topic: port forward ip cam
Replies: 6
Views: 1700

Re: port forward ip cam

The best solution for you: Make your modem in Bridge mode and let your mikrotik router make the pppoe connection so that your mikrotik gets the public ip:112.54.34.155 and then add: /ip firewall nat add action=dst-nat chain=dstnat disabled=no dst-address=pppoe-modem dst-port=8086 protocol=tcp to-add...
by nick3dos
Mon Mar 04, 2013 1:05 pm
Forum: Beginner Basics
Topic: RB750
Replies: 6
Views: 785

Re: RB750

if you don't have this in your mikrotik router, type it:

/ip firewall nat
add action=masquerade chain=srcnat disabled=no src-address=192.168.10.0/24
by nick3dos
Mon Feb 25, 2013 12:36 pm
Forum: RouterBOARD hardware
Topic: Recommend power supply for RB450G
Replies: 5
Views: 10035

Re: Recommend power supply for RB450G

I have 4 x RB450G ,24 hours online, for over two years now, in all of them i use 12V 1A power supply with no problem so far.
by nick3dos
Fri Feb 22, 2013 4:45 pm
Forum: Scripting
Topic: Time conditions
Replies: 1
Views: 986

Re: Time conditions

1. add filter and layer7 firewall rules, for blocking youtube /ip firewall layer7-protocol add comment=Denied_YouTube name=Denied_YouTube regexp="^.*(get|GET).+(youtube).*$" /ip firewall filter add action=drop chain=forward comment=Denied_YouTube disabled=yes layer7-protocol=\ Denied_YouTube src-ad...
by nick3dos
Fri Feb 22, 2013 1:46 pm
Forum: General
Topic: Login to Hotspot without typing username and password
Replies: 2
Views: 3056

Re: Login to Hotspot without typing username and password

Thanks a lot.

It worked.
by nick3dos
Thu Feb 21, 2013 10:49 am
Forum: General
Topic: Login to Hotspot without typing username and password
Replies: 2
Views: 3056

Login to Hotspot without typing username and password

Hello, In my login page i want to have only a button for logging users in, without editboxes for username and password, i don't want them to type anything. I have add a user in hotspot -> users with username=user and password=pass with Shared_users="500". I want the button to make the login with use...
by nick3dos
Tue Feb 05, 2013 10:42 am
Forum: Scripting
Topic: script autorun via web
Replies: 4
Views: 1327

Re: script autorun via web

I expected that there is NO other way to do it, except script-scheduler.

True, it would be very helpful if we could run a script similar like Hotspot login.

Anyway, i did it with script-scheduler.

Thanks for your time.
by nick3dos
Mon Feb 04, 2013 10:41 am
Forum: Scripting
Topic: script autorun via web
Replies: 4
Views: 1327

Re: script autorun via web

thank you,

but is there any other way to do it without to use scheduler?
by nick3dos
Fri Feb 01, 2013 1:02 pm
Forum: Scripting
Topic: script autorun via web
Replies: 4
Views: 1327

script autorun via web

Hi,

I want to automatically run a script in my mikrotik device every time i log in via web interface

anybody know how to do it???
by nick3dos
Wed Oct 24, 2012 12:59 pm
Forum: General
Topic: Sample Hotspot Page - Sticky Please
Replies: 438
Views: 309132

Re: Sample Hotspot Page - Sticky Please

by nick3dos
Thu Jun 16, 2011 2:56 pm
Forum: Scripting
Topic: download backup from other devices to mikrotik
Replies: 2
Views: 1601

download backup from other devices to mikrotik

Hello,

I have a mikrotik and a ubiquity device.
I want to write a script so i can download from my mikrotik device the ubiquity backup.
I can log in from mikrotik to ubiquity with telnet or ssh but i don't know what to do after to download the backup file.
Can anyone help me???
by nick3dos
Tue May 31, 2011 10:15 am
Forum: General
Topic: winbox auto login???
Replies: 4
Views: 812

Re: winbox auto login???

It works now,

Thank you very much.
by nick3dos
Mon May 30, 2011 10:54 pm
Forum: General
Topic: winbox auto login???
Replies: 4
Views: 812

Re: winbox auto login???

yes but how can i use that in c++?

in my program i call the function ShellExecute(handle, "open", "/winbox.exe" , NULL, NULL, SW_SHOWNORMAL);

How can i pass username, password and mikrotik ip???
by nick3dos
Mon May 30, 2011 3:52 pm
Forum: General
Topic: winbox auto login???
Replies: 4
Views: 812

winbox auto login???

I have made a program in c++ for my network similar to dude.
I want to add auto login with winbox like dude.
How do i do this???
I can open winbox as separate program, but i want to auto login too.
Is it something like ftp command "ftp://username:password@mikrotik_ip_address" ???
by nick3dos
Thu May 05, 2011 6:07 pm
Forum: Scripting
Topic: send files to network hard disk?
Replies: 4
Views: 2347

Re: send files to network hard disk?

Yes i know, so what is the problem and i can't connect to the hard disk?

is there any other way to send files from a mikrotik to a network disk???
by nick3dos
Thu May 05, 2011 5:16 pm
Forum: Scripting
Topic: send files to network hard disk?
Replies: 4
Views: 2347

Re: send files to network hard disk?

I login to my network hard disk with username and password,
but how can i put them to the script correctly, so it will make the login automaticaly?
by nick3dos
Thu May 05, 2011 4:11 pm
Forum: Scripting
Topic: send files to network hard disk?
Replies: 4
Views: 2347

send files to network hard disk?

Hello, I want to ask if i can send files to network hard disk? i use the following script but no luck. tool fetch address=10.10.0.200 src-path=new.txt user=xxx mode=ftp password=xxx dst-path=new.txt upload=yes 10.10.0.200 -> ip of network disk. when i try to send files to other mikrotiks over my net...
by nick3dos
Mon May 02, 2011 11:13 am
Forum: General
Topic: mikrotik sms
Replies: 8
Views: 2659

Re: mikrotik sms

I made the interval every 15 min and Start Time: startup and is working great.
by nick3dos
Sun May 01, 2011 1:05 pm
Forum: General
Topic: mikrotik sms
Replies: 8
Views: 2659

Re: mikrotik sms

yes that is want i did

/tool sms set receive-enabled=yes

and schedule Start Time : startup

thank anyway...
by nick3dos
Sat Apr 30, 2011 11:39 pm
Forum: General
Topic: mikrotik sms
Replies: 8
Views: 2659

Re: mikrotik sms

don't worry. i find a way to make it work
by nick3dos
Fri Apr 29, 2011 11:11 pm
Forum: General
Topic: mikrotik sms
Replies: 8
Views: 2659

mikrotik sms

Hello,

In mikrotik sms tool the option "recieve-enabled" is by default off.
I make it enable=yes and everything is ok, but when i reboot my device the option is back to OFF.
Can anyone give me an idea, how to make it enabled=on always???