Community discussions

MikroTik App

Search found 31 matches

by marria
Tue Apr 11, 2017 9:20 pm
Forum: Scripting
Topic: BW test with send message on x<50Mbps
Replies: 1
Views: 451

BW test with send message on x<50Mbps

I am trying to think how to write a script that would be something along: too bandwidth-test direction=receive protocol=tcp user=bwtest password=bwtestpw address=192.168.82.2 duration=3 then grab the number from: rx-total-average: 71.1Mbps and compare to 50 resulting in send message if below. I am u...
by marria
Wed Jan 06, 2016 9:37 pm
Forum: Forwarding Protocols
Topic: NAT and NAT again question
Replies: 3
Views: 1203

Re: NAT and NAT again question

OK the purpose is not enough Pub IPs for all clients, sometimes it is desirable to track back and assign a public IP to certain inside addresses. I can accomplish this anywhere on the inside of the NAT pretty quickly with Netmap, as it allows a way to hop over several routers directly to where I wan...
by marria
Mon Jan 04, 2016 1:41 am
Forum: Forwarding Protocols
Topic: NAT and NAT again question
Replies: 3
Views: 1203

NAT and NAT again question

OK NAT experts, here I am with this perplexing problem. I have a series of IPs say 20.20.20.1-250 Originally I had everything NAT'd behind 20.20.20.2 and used chain=dstnat action=dst-nat to-addresses=10.4.2.210 to-ports=80 protocol=tcp dst-address=20.20.20.254 dst-port=80 log=no log-prefix="" for th...
by marria
Fri Jan 01, 2016 2:45 am
Forum: Scripting
Topic: Script CLI change question
Replies: 3
Views: 637

Re: Script CLI change question

drrp!
/ip route
add dst-address=[:resolve facebook.com ] gateway=192.168.77.1 scope=10
by marria
Fri Jan 01, 2016 1:13 am
Forum: Scripting
Topic: Script CLI change question
Replies: 3
Views: 637

Script CLI change question

re:http://wiki.mikrotik.com/wiki/Advanced_Routing_Failover_without_Scripting example: /ip route add dst-address=Host1 gateway=GW1 scope=10 add dst-address=Host2 gateway=GW2 scope=10 /ip route add dst-address=facebook.com gateway=192.168.77.1 scope=10 results in : value of dst-address must contain '/...
by marria
Tue Oct 20, 2015 9:54 pm
Forum: General
Topic: EOIP occaisonal fail & how to tell neighbor router to reboot?
Replies: 2
Views: 573

Re: EOIP occaisonal fail & how to tell neighbor router to reboot?

I have to figure out the path, for sure - not sure yet how to make this link fail. It happens to be the VOIP connect at a hotel added after the fact at the request of the VOIP provider - kinda klugy really. If I get that to work, I'll repost.
by marria
Mon Oct 19, 2015 3:07 am
Forum: General
Topic: EOIP occaisonal fail & how to tell neighbor router to reboot?
Replies: 2
Views: 573

EOIP occaisonal fail & how to tell neighbor router to reboot?

I have 3 routers. A creates a EOIP to slave on C passing through B, and B creates a EOIP to another slave on C as well. Occasionally A to C breaks down showing Running on C only, not on A, while B to C continues to run. Only rebooting B will fix this. If A could tell B to reboot, that would be a wor...
by marria
Thu Jul 23, 2015 5:09 am
Forum: Beginner Basics
Topic: nslookup on Mikrotik
Replies: 17
Views: 38191

Re: nslookup on Mikrotik

to find out the IP address of some domain, just ping it. or you can use the ":resolve" command, if you need it in scripts:

ros code

[admin@MikroTik] > put [:resolve mt.lv]
159.148.147.196
This is true, but does not tell which dns server is resolving, which can be helpful...
by marria
Mon Jul 13, 2015 11:51 pm
Forum: Announcements
Topic: Manual Improvements
Replies: 94
Views: 22585

Re: Manual Improvements

is this incorrect command from the manual?.. a link? Probably from the wiki. I'll try to find it in my history - likely less than a week back. Update: and crow for dinner.... no link, bad interpretations To clarify, the original Line I questioned was from - Check if IP on interface have changed htt...
by marria
Mon Jul 13, 2015 7:54 pm
Forum: Announcements
Topic: Manual Improvements
Replies: 94
Views: 22585

Re: Manual Improvements

furthermore the variation: { :local address1 [/ip address get [/interface ethernet find name=ether1] address] :put $address1 } is likely as not to give an address from a completely different interface under that situation. that's completely incorrect command. first, you get ID of 'ether1' interface...
by marria
Mon Jul 13, 2015 4:16 pm
Forum: Announcements
Topic: Manual Improvements
Replies: 94
Views: 22585

Re: Manual Improvements

marria wrote: This is not the issue. so what is the issue? looks like you have many addresses on ether1, not a single one. check with Code: Select all :put [/ip address find interface="ether1"] Now THAT was helpful, thanks! It seems that on a interface with more than one address it tanks: Note for ...
by marria
Mon Jul 13, 2015 3:48 pm
Forum: Announcements
Topic: Manual Improvements
Replies: 94
Views: 22585

Re: Manual Improvements

Maybe before blindly copying scripts make sure that you have interface named "ether1" and that this "ether1" actually has an address to get. This is not the issue. ether1 exists on test unit with an address. your assumption is erroneous'' [Michael@Goat-on-a-Rope] > ip address p Flags: X - disabled,...
by marria
Mon Jul 13, 2015 1:47 am
Forum: Scripting
Topic: get gateway from dst-address
Replies: 4
Views: 946

Re: get gateway from dst-address

this sorta works, put doesn't give me a local to pass like $nexthop
 /ip route check dst-ip=10.4.0.0 once
which gets me:
     status: ok
  interface: ether4-WT_5AC
    nexthop: 10.251.250.4
need to grab the nexthop IP
by marria
Sun Jul 12, 2015 11:32 pm
Forum: Scripting
Topic: get gateway from dst-address
Replies: 4
Views: 946

Re: get gateway from dst-address

Something along the lines of:
{
:local gatewayWT [/ip address get [/ip route find gateway dst-address=10.4.0.0/16] ]
:put $gatewayWT
}
by marria
Sun Jul 12, 2015 3:18 pm
Forum: Scripting
Topic: get gateway from dst-address
Replies: 4
Views: 946

get gateway from dst-address

Can somebody show me a script to get gateway address from dst-address?

Can't quite figure it out....

Thanks
by marria
Sun Jul 12, 2015 1:26 pm
Forum: Scripting
Topic: help! example from wiki doesn't work - why? invalid internal item number
Replies: 1
Views: 902

Re: help! example from wiki doesn't work - why? invalid internal item number

OK, I figured this one out, but why is the other example in the Manual/wiki????

DOES WORK:
{
:local address1 [/ip address get [/interface ethernet find name=ether1] address]
:put $address1
}
by marria
Sat Jul 11, 2015 3:22 pm
Forum: Scripting
Topic: help! example from wiki doesn't work - why? invalid internal item number
Replies: 1
Views: 902

help! example from wiki doesn't work - why? invalid internal item number

{
:local address1 [/ip address get [find interface="ether1"] address]
:put $address1
}
invalid internal item number
by marria
Sat Jul 11, 2015 2:48 pm
Forum: Announcements
Topic: Manual Improvements
Replies: 94
Views: 22585

Re: Manual Improvements

Let's have script examples that actually work, example:
from manual or wiki

{
:local address1 [/ip address get [find interface="ether1"] address]
:put $address1
}

result:
invalid internal item number

This type of thing adds hours if not days to what could be a nice learning flow
by marria
Mon Jul 06, 2015 11:04 pm
Forum: General
Topic: Winbox losing MAC connection to RB850Gx2
Replies: 44
Views: 13766

Re: Winbox losing MAC connection to RB850Gx2

WHoa- Just got my hands on a RB850Gx2. I have 100+ Mikrotiks running and NONE OF THEM act like this. First tried setting up RB850Gx2, removed default config and bang! no reliable access through mac connect on winbox any port. Connect and freeze - over and over and over and over...... after repeated ...
by marria
Thu Nov 06, 2014 1:24 am
Forum: General
Topic: v6.21.1 released
Replies: 112
Views: 30780

Re: v6.21.1 released Winbox missing menu Items

After doing a download from the Web UI and upgrade and reboot, surprised to find no DHCP items on the IP menu in winbox UI or anywhere else as far as I can tell. Still working through the Terminal as AFAK, but I think I'll back down to 6.20 for now.

Michael
by marria
Sat Jun 22, 2013 8:27 pm
Forum: Wireless Networking
Topic: RB2011UAS-2HnD-IN -- Full WLAN access, but no internet
Replies: 13
Views: 3613

Re: RB2011UAS-2HnD-IN -- Full WLAN access, but no internet

Glad to see you worked this through. You might consider turning off the DHCP services, if you have another - disable in the GUI menu IP > DHCP Server > DHCP select the server which generally the first one is dhcp0 and disable it, or remove it. - disable in the CLI : > ip dhcp-server print > disable ...
by marria
Fri Jun 21, 2013 2:31 am
Forum: Wireless Networking
Topic: RB2011UAS-2HnD-IN -- Full WLAN access, but no internet
Replies: 13
Views: 3613

Re: RB2011UAS-2HnD-IN -- Full WLAN access, but no internet

Sorry, got alligators this week. Describe where the 2011 sits in relation to your lan and the Comcast feed. Are you saying that when you plug in, you can not only get around your LAN but browse the internet? What does Comcast give on DHCP, public or private - are you behind their NATed router? Is th...
by marria
Sun Jun 09, 2013 5:46 pm
Forum: Wireless Networking
Topic: RB2011UAS-2HnD-IN -- Full WLAN access, but no internet
Replies: 13
Views: 3613

Re: RB2011UAS-2HnD-IN -- Full WLAN access, but no internet

Just a comment- I found that these pretty much will work out of the box. You might try first, backup your config, reset to factory, and test. This should let you know if the problem is outside the Mikrotik box first, then, try bringing back in you config step by step. What is your out WAN port? Is m...
by marria
Wed Feb 13, 2013 10:44 pm
Forum: Beginner Basics
Topic: website blocking
Replies: 6
Views: 1825

Re: website blocking

I would like to see your example, as well.
by marria
Fri Dec 21, 2012 8:13 pm
Forum: General
Topic: mark-connection VS mark-packet
Replies: 28
Views: 68687

Re: mark-connection VS mark-packet

Breaking: if the stream shifts from on leg of the return path to the other for some reason, such as the original path becomes un available, I assume that the stream would break. On video maybe recover, on a VOIP drop the call. The "A" PCC router designates the path, the "B" knows nothing about that,...
by marria
Thu Dec 20, 2012 9:11 am
Forum: General
Topic: mark-connection VS mark-packet
Replies: 28
Views: 68687

Re: mark-connection VS mark-packet

Question: router A has 3 ports eth0 to clients, eth1 and eth2 are 2 possible paths each 3 hops to router B, B has 2 LANs and one WAN to world I set up PCC on a router A to sort of load balance between these 2 paths. Assuming that connections are initiated by clients, is it also necessary to connecti...
by marria
Tue Aug 14, 2012 1:06 am
Forum: Scripting
Topic: How initialized a variable by SMS ??
Replies: 30
Views: 9018

Re: How initialized a variable by SMS ??

Well, you got some advice. How did it work out?
by marria
Fri Mar 16, 2012 8:53 pm
Forum: General
Topic: Edit:532 stop routing internal port after a day? Bridge Issu
Replies: 1
Views: 490

Edit:532 stop routing internal port after a day? Bridge Issu

I have a rb532 ver 5.7 with 2 wlans for AP each carries about 15 clients. wlan1 10.2.2.1/24 wlan2 10.2.3.1/24 These are all good eth1 has 10.251.250.4/24 gateway 10.251.250.1, received dynamically through a pair of bridged dynamically addressed NBM5s (client 10.251.250.3, ap 10.251.250.2) from a rb4...
by marria
Tue Feb 21, 2012 6:40 pm
Forum: General
Topic: Netinstall fails-console boot reports "Demo License Expired"
Replies: 4
Views: 2578

Re: Netinstall fails-console boot reports "Demo License Expi

HaPe-
Your are 16, and very helpful. Kudos to you for solving my problem.
BTW, My mothers family came from Poland.

Are you running an WISP?

Michael
by marria
Sat Feb 11, 2012 3:40 am
Forum: General
Topic: Netinstall fails-console boot reports "Demo License Expired"
Replies: 4
Views: 2578

Netinstall fails-console boot reports "Demo License Expired"

Trying to resuscitate my "dead pile" boards - mostly rb133c that die on update (> ver5.4 = death), but that is a separate matter to be discussed. rb411 hooked up for netinstall (I have done many), boot from ethernet fails with kernel panic (see attached) and if allowed to NAND boot gets to starting ...
by marria
Sat Jun 04, 2011 8:49 pm
Forum: General
Topic: RouterOS v5.4 released
Replies: 118
Views: 34309

Re: RouterOS v5.4 released - rb532a stops some routes

My rb532a stops routing some traffic with upgrade from 4.16 to 5.4 Upgrades to several rb433 and rb433AH, all with some with wireless links, prove successful. As the rb532a is a main link in our network, I haven't had a lot of time to evaluate the problem yet, though it has been running the same rou...