Community discussions

Search found 558 matches

  • 1
  • 2
by c0d3rSh3ll
Fri Jun 09, 2017 5:40 pm
Forum: General
Topic: ££$$ paid work ££$$$
Replies: 4
Views: 639

Re: ££$$ paid work ££$$$

My email Is c0d3rSh3ll@hotmail.com
Send me any details

Sent from my x600 using Tapatalk
by c0d3rSh3ll
Thu Aug 27, 2015 9:41 am
Forum: General
Topic: Script for Hire
Replies: 2
Views: 436

tabate47:

Please send me an email to

c0d3rSh3ll [at] hotmail [dot] com




Regards
by c0d3rSh3ll
Tue Apr 28, 2015 5:37 am
Forum: General
Topic: Looking for contractor
Replies: 2
Views: 597

Hello.
In my signature you can see my email.
by c0d3rSh3ll
Sat Apr 25, 2015 4:01 am
Forum: Scripting
Topic: script change user info dose not work
Replies: 3
Views: 708

Re: script change user info dose not work

check this
/ip hotspot user
	:foreach i in=[find disabled=no] do={
		:local name [ get value-name=name $i]
			:local profile [get value-name=profile $i]
		:if ( $profile = "mm") do={set password=aaa $name}
}}
by c0d3rSh3ll
Tue Feb 03, 2015 9:23 pm
Forum: General
Topic: All ethernet ports cuts conections every few seconds
Replies: 12
Views: 2835

Re: All ethernet ports cuts conections every few seconds

Same here with 6.25 and a rb1100ahx2 and the latest firmware.

I downgraded ti 6.23 and everything is OK again
by c0d3rSh3ll
Tue Feb 03, 2015 5:52 am
Forum: Scripting
Topic: Script for adding ip adresses to whitelist
Replies: 1
Views: 1064

Re: Script for adding ip adresses to whitelist

check this

ros code

/ppp active 
	:foreach i in=[find] do={
		:local ip [get value-name=address $i]
			/ip firewall address-list add list=pptp-whitelist address=$ip
		}
by c0d3rSh3ll
Tue Feb 03, 2015 5:40 am
Forum: Scripting
Topic: Removing the colon from [/system clock get clock]?
Replies: 1
Views: 646

Re: Removing the colon from [/system clock get clock]?

this can help you

ros code

put ( [pick [system clock get time] 0 2] . [pick [system clock get time] 3 5] . [pick [system clock get time] 6 8] )
by c0d3rSh3ll
Fri Jan 30, 2015 4:19 am
Forum: The User Manager
Topic: Cannot access User Manager
Replies: 4
Views: 7032

Re: Cannot access User Manager

Maybe you not have instaled the user manager package. Check it in the system-- package menú.
by c0d3rSh3ll
Sat Jan 10, 2015 3:42 am
Forum: Scripting
Topic: script error for wan ip info
Replies: 3
Views: 1334

Re: script error for wan ip info

check this:

ros code

/ip address
		:foreach i in=[ find interface=wan] do={
	:local ip [get value-name=address $i]
		:local status [ get value-name=disabled $i]
			:if ($status = false) do={
	:log error "ip address $ip"
 }
 }


change the interface name..
by c0d3rSh3ll
Tue Dec 09, 2014 6:57 pm
Forum: General
Topic: please help!
Replies: 1
Views: 566

Re: please help!

There are some way to do it.
You can use web proxy feature for redirect only HTTP traffic to a local web server for who didnt pay.

Also you can use a dst nat for redirect only HTTP traffic to a your web server.
by c0d3rSh3ll
Tue Dec 09, 2014 6:51 pm
Forum: Beginner Basics
Topic: Help selecting right product.
Replies: 15
Views: 1806

Re: Help selecting right product.

I can recommend a rb1100ahx2. Is a good option.

For load balance the connection from your customers you can use PCC method.
by c0d3rSh3ll
Fri Oct 17, 2014 6:08 am
Forum: Scripting
Topic: Script to redirect non-payers
Replies: 3
Views: 1032

Re: Script to redirect non-payers

what is the "Butch's script " ?

https is not possible to redirect with web proxy.
by c0d3rSh3ll
Tue Oct 14, 2014 10:27 pm
Forum: Scripting
Topic: dhcp-relay responses monitoring needed
Replies: 5
Views: 1360

Re: dhcp-relay responses monitoring needed

c0d3rSh3ll thank you very much +1 ;) and maybe you can add... if responses = 0 and if requests > 0 :local resp; :local req /ip dhcp-relay monitor 0 do={ :set resp ( responses); :set req (requests ); } once; :if [ ($resp = 0 ) && ($req > 0)] do={ /system reboot; } some other thing? :D
by c0d3rSh3ll
Tue Oct 14, 2014 1:11 am
Forum: Scripting
Topic: Script Ping (Host To IP) to the variable.
Replies: 2
Views: 3727

Re: Script Ping (Host To IP) to the variable.

there are some ways to do it.
you can use resolve command, something like this

ros code

{
local host1 [resolve google.com]
put $host1 }
or

ros code

{
local host1 [resolve google.com]
log error $host1 }
by c0d3rSh3ll
Tue Oct 14, 2014 12:00 am
Forum: Scripting
Topic: dhcp-relay responses monitoring needed
Replies: 5
Views: 1360

Re: dhcp-relay responses monitoring needed

check this

ros code

:local resp
/ip dhcp-relay monitor 0  do={
:set resp ( responses) } once;
:if ($resp = 0 ) do={
/system reboot;}
by c0d3rSh3ll
Fri Oct 10, 2014 9:45 pm
Forum: Scripting
Topic: Check client IP address for pptp-client
Replies: 1
Views: 1926

Re: Check client IP address for pptp-client

may be this can help you, you can improve it with more time :D :local tmp [/ip address get value-name=address [find interface=pptp-out1]] :local ip [pick $ip 0 ([:len $ip]-3) ] :log warning "Monitoring..."; :if (ip != 10.200.13.20) do={ :log error "wrong ip" :log error $ip /interface pptp-client dis...
by c0d3rSh3ll
Fri Oct 10, 2014 9:14 pm
Forum: Scripting
Topic: Script - search queues
Replies: 4
Views: 2150

Re: Script - search queues

try this:

ros code

/queue simple 
:foreach i in=[ find ] do={
	:local max [ get value-name=max-limit $i]
		:local ip [ get value-name=target $i]
:if ($max = "2M/2M") do={
		/ip firewall address-list add list=queue address=$ip
} 
	}
by c0d3rSh3ll
Mon Oct 06, 2014 2:59 am
Forum: General
Topic: Did we loose IP cloud?
Replies: 155
Views: 26464

Re: Did we loose IP cloud?

Same here. I upgrade my router to 6.20 and routerOS can not connect.
by c0d3rSh3ll
Thu Sep 25, 2014 9:12 pm
Forum: Scripting
Topic: help with address-list script please
Replies: 2
Views: 877

Re: help with address-list script please

is wrong your script, check this:

ros code

foreach i in=[ip firewall address-list find list=blocked ] do={
local ip [ip firewall address-list get value-name=address $i]
log info ($ip) }
by c0d3rSh3ll
Thu Sep 25, 2014 9:07 pm
Forum: Scripting
Topic: Is possible to run 2 different commands at the same time?
Replies: 3
Views: 805

Re: Is possible to run 2 different commands at the same time

I dont know what do you wan to do, but if you need to run some scritp at the same time maybe you can use comma like this

ros code

/system script run script1; /system script run script2;
by c0d3rSh3ll
Thu Sep 25, 2014 8:55 pm
Forum: Scripting
Topic: Scripting Sum Count of bytes Out
Replies: 3
Views: 1663

Re: Scripting Sum Count of bytes Out

check this, may be is the solution for you

ros code

global gigabyte
:foreach name in=[/ip hotspot user find ] do={
global byte [/ip hotspot user get $name bytes-out]
:set gigabyte [($gigabyte + $byte)] 
:put $gigabyte
by c0d3rSh3ll
Tue Sep 16, 2014 6:50 am
Forum: Scripting
Topic: Getting wireless interface rx signal-strength
Replies: 7
Views: 3127

Re: Getting wireless interface rx signal-strength

Where can you read the result?
paste this in the terminal

ros code

put [/interface wireless registration-table get value-name=signal-strength 0 ]
this read the signal strength for the station 0
by c0d3rSh3ll
Sun Sep 14, 2014 7:17 am
Forum: Scripting
Topic: Need help with script to make simple queue for dhcp entries
Replies: 10
Views: 5789

Re: Need help with script to make simple queue for dhcp entr

Does this script still work with V6.19 ? I am trying to implement this script again and I cant seem to get it to work. the original scritp is for 5.x, I remove the wrong code tested in 6.19: :foreach a in=[/queue simple find] do={ :local tmpip [/queue simple get $a target] /ip dhcp-server lease :fo...
by c0d3rSh3ll
Sat Sep 13, 2014 11:47 pm
Forum: Scripting
Topic: check ip and renew
Replies: 3
Views: 948

Re: check ip and renew

there are some ways to do it while condition=([ip dhcp-client get value-name=gateway 0]!= 1.1.1.1) do={ delay 2s; ip dhcp-client disable 0; delay 5s; ip dhcp-client enable 0; delay 3s;}} or local ip [ip dhcp-client get value-name=gateway 0] if ($ip!= 1.1.1.1) do={ ip dhcp-client release 0; ip dhcp-c...
by c0d3rSh3ll
Sat Sep 13, 2014 11:07 pm
Forum: Scripting
Topic: 750up POE on/off script
Replies: 6
Views: 2910

Re: 750up POE on/off script

for power off

ros code

interface ethernet poe set poe-out=off ether5
for power on

ros code

interface ethernet poe set poe-out=auto-on ether5
or

ros code

interface ethernet poe set poe-out=forced-on ether5
by c0d3rSh3ll
Sun Sep 07, 2014 4:45 am
Forum: RouterBOARD hardware
Topic: GPIO for remote installations, why not?
Replies: 5
Views: 1943

Re: GPIO for remote installations, why not?

You can use an arduino with ethernet shield to control any device through digital/analog pins with a web control pannel.
by c0d3rSh3ll
Sun Aug 31, 2014 8:00 pm
Forum: Scripting
Topic: ˑ
Replies: 2
Views: 875

Re: wireless registration mac to hotspot user script

try this { :foreach i in=[ /int wir reg find ap=no] do={ local signal [interface wireless registration-table get value-name=signal-strength $i] local st [ :pick $signal 0 [:find $signal "dBm"]] local mac [interface wireless registration-table get value-name=mac-address $i] :if (-73 < $st) do={ /ip h...
by c0d3rSh3ll
Sun Aug 31, 2014 6:56 pm
Forum: The User Manager
Topic: delete all user expire
Replies: 1
Views: 1140

Re: delete all user expire

you can use a script daily or monthly for remove all expired users.
by c0d3rSh3ll
Sun Aug 31, 2014 6:39 pm
Forum: General
Topic: pppoe client loadbalance & pppoe server
Replies: 3
Views: 1026

Re: pppoe client loadbalance & pppoe server

yes, is possible use only 1 rb for all the task.
I suggest to use pcc instead of nth.
by c0d3rSh3ll
Sun Aug 31, 2014 6:32 pm
Forum: Scripting
Topic: ˑ
Replies: 2
Views: 875

Re: Hotspot add active user script with profile

I not understand what do you want to do.
by c0d3rSh3ll
Fri Aug 29, 2014 9:35 pm
Forum: General
Topic: Load balance PCC with ppoe problem
Replies: 9
Views: 2218

Re: Load balance PCC with ppoe problem

everything look like fine
by c0d3rSh3ll
Wed Aug 27, 2014 9:02 am
Forum: General
Topic: Load balance PCC with ppoe problem
Replies: 9
Views: 2218

Re: Load balance PCC with ppoe problem

You have a wrong setup in the mangle rule. Change in interface in the pcc rule to in interface your lan network
by c0d3rSh3ll
Tue Aug 26, 2014 2:17 am
Forum: Beginner Basics
Topic: download upgrade package file directly on Mikrotik
Replies: 2
Views: 1402

Re: download upgrade package file directly on Mikrotik

yes, you can, execute this in the terminal

this is the 6.18 for mipsbe hardware:

/tool fetch mode=http url=http://download2.mikrotik.com/routeros/ ... e-6.18.npk


you can go to mikrotik website and copy the url to the npk and replace the url in the command.
by c0d3rSh3ll
Tue Aug 26, 2014 12:23 am
Forum: Scripting
Topic: eoip script help.
Replies: 3
Views: 1206

Re: eoip script help.

add a simple script something like this

ros code

local remoteIP [resolve yourdomain.com]
interface eoip set your-eoip-tunnel remote-address=$remoteIP
}
by c0d3rSh3ll
Sun Aug 24, 2014 7:22 pm
Forum: General
Topic: PCC in-interface
Replies: 2
Views: 659

Re: PCC in-interface

Is not necessary set in-interface. You can set src-address-list where the router has every network of every vlan.
by c0d3rSh3ll
Sun Aug 24, 2014 7:19 pm
Forum: General
Topic: resolving dns via VPN?
Replies: 2
Views: 1038

Re: resolving dns via VPN?

Add a route for 8.8.8.8 through vpn with gateway the vpn interface.
by c0d3rSh3ll
Tue Jul 08, 2014 6:51 pm
Forum: Wireless Networking
Topic: https redirect issue
Replies: 12
Views: 15393

Re: https redirect issue

But everytime the device than connect to hotspot complain about unsigned - untrusted certificates, displayng warning messages, because your own cert, are not autorized by root certificates...
as he say:
can i use a self signed certificate for testing before buying a real one?
by c0d3rSh3ll
Tue Jul 08, 2014 6:46 pm
Forum: Beginner Basics
Topic: Dynamic to Static automatically
Replies: 8
Views: 2052

Re: Dynamic to Static automatically

sorry, I posted from my mobile phone.
is ok now.

rextended:

[admin@homeAP] > /ip firewall address-list set dynamic=no [find dynamic]
[admin@homeAP] >

tested in 6.15.
by c0d3rSh3ll
Tue Jul 08, 2014 6:13 pm
Forum: Beginner Basics
Topic: Dynamic to Static automatically
Replies: 8
Views: 2052

Re: Dynamic to Static automatically

Thanks. Could anybody help me with a simple script for it?

I would like to suggest to Mikrotik that
if users do address-list-timeout=0s (unlimited), the address list should be Static.
/ip firewall address-list set dynamic=no [find dynamic]
by c0d3rSh3ll
Tue Jul 08, 2014 5:59 pm
Forum: Wireless Networking
Topic: https redirect issue
Replies: 12
Views: 15393

Re: https redirect issue

Thank you Rextended for your answer,

can i use a self signed certificate for testing before buying a real one?
Yes. You can generate in linux and upload to routerOS.
by c0d3rSh3ll
Tue Jul 08, 2014 3:39 am
Forum: Beginner Basics
Topic: Reset data counter on each 10th of the month
Replies: 3
Views: 1216

Re: Reset data counter on each 10th of the month

For reset the counter for any interface is:

/interface ethernet reset-counter etherX

You can execute the script each 30 days
by c0d3rSh3ll
Tue Jul 08, 2014 2:49 am
Forum: RouterBOARD hardware
Topic: system rebooted because of kernel failure, any help?
Replies: 10
Views: 2830

Re: system rebooted because of kernel failure, any help?

everyday my mikrotik 433 borad reboots everyday @ 9 am, so sounds wired, and i do not know what is the problem, so i just logged into my borad logs, i found that "system rebooted because of kernel failure". so what is that, and how i can fix the problem, thx Reinstall routerOS with netinstall. Some...
by c0d3rSh3ll
Sun Jul 06, 2014 9:00 am
Forum: Scripting
Topic: Change Simple Queue Bytes Values
Replies: 2
Views: 876

Re: Change Simple Queue Bytes Values

byte counter is read value, so you can not change it.
by c0d3rSh3ll
Tue Jun 17, 2014 10:04 am
Forum: Beginner Basics
Topic: need help
Replies: 2
Views: 856

Re: need help

PM is not possible on this forum.
by c0d3rSh3ll
Mon Jun 16, 2014 7:08 am
Forum: Scripting
Topic: remove namefilter address-list
Replies: 4
Views: 1175

Re: remove namefilter address-list

I need a script that removes all the address-list entry's that starts with "T-"

ros code

/ip firewal address-list remove [find list~"T-"]
Here is my script that removes everything in my address-list
for remove everything in your address list the best way is

ros code

/ip firewal address-list remove [find]
by c0d3rSh3ll
Sun Jun 15, 2014 5:39 pm
Forum: General
Topic: which winbox is recommand for android?
Replies: 2
Views: 1304

Re: which winbox is recommand for android?

We not have an official version.

This app are and api client and are very limited.

You can access to your router through any browes to webfig

Is so similar to winbox.exe
by c0d3rSh3ll
Sun Jun 15, 2014 5:35 pm
Forum: Beginner Basics
Topic: Net Connected Downloads working no Browsing
Replies: 1
Views: 692

Re: Net Connected Downloads working no Browsing

I think is a dns problem

Post your export of your conf:

/export
by c0d3rSh3ll
Sun Jun 15, 2014 5:28 pm
Forum: General
Topic: Mikrotik RB 1100AHx2 and ROS 6.XX support.
Replies: 9
Views: 4674

Re: Mikrotik RB 1100AHx2 and ROS 6.XX support.

I have running and rb1100ahx2 with the same problem ( 5.26 and the latest firmware) I have a dubt if in 6.x I will have the same problem. I reported the problem with mikrotik suppuort but they suggest me "upgrade to the latest version" This device is allocated in other city (400 km) so is a problem ...
by c0d3rSh3ll
Tue Jun 10, 2014 6:51 pm
Forum: General
Topic: PING in 2 networks
Replies: 5
Views: 1080

Re: PING in 2 networks

If you need access to AP first add the mac address of each device to ip-binding section.

sent from my mobile phone using tapatalk
by c0d3rSh3ll
Tue Jun 10, 2014 12:45 am
Forum: General
Topic: Please add MONTH parameter in scheduller
Replies: 15
Views: 1926

Re: Please add MONTH parameter in scheduller

You can do it with a script like this:


:if ($actual_month = $your_month) do={anything}


You can get actual month from clock menu.




sent from my mobile phone using tapatalk
by c0d3rSh3ll
Mon Jun 09, 2014 6:50 am
Forum: General
Topic: load balancing on mikrotik with no NAT
Replies: 2
Views: 629

Re: load balancing on mikrotik with no NAT

Hi all please i need help on how can do load balancing on mikrotik with no NAT on the WAN interface , I have 3 WAN interface with 10M,5M and 25 M and want to do load balancing on them with fail over should any of the link goes down. there is cisco ASA above the there link doing the NATing which we ...
by c0d3rSh3ll
Mon Jun 09, 2014 6:38 am
Forum: General
Topic: Change password on many devices
Replies: 4
Views: 1129

Re: Change password on many devices

You need to work with a radius server for AAA on all your mikrotik devices

sent from my mobile phone using tapatalk
by c0d3rSh3ll
Sat Jun 07, 2014 11:16 pm
Forum: General
Topic: Welcome page on free wifi
Replies: 6
Views: 1951

Re: Welcome page on free wifi

You can use trial hotspot feature, so the user is redirected to hotspot login page but is not necesary to login with user and pass. The user need to click on trial link for connect.



sent from my mobile phone using tapatalk
by c0d3rSh3ll
Tue May 27, 2014 6:45 am
Forum: General
Topic: stencil visio updated
Replies: 4
Views: 12866

stencil visio updated

I want to share my stencil vss for visio 2007. is an updated idea from this post: http://forum.mikrotik.com/viewtopic.php?f=13&t=30709&hilit=stencil+visio#p149665 the list of MikroTik hardware is: RB450 and RB750 serie CRS serie RB2011 desktop and rack mount design RB1100 serie RB SXT serie Omnitik ...
by c0d3rSh3ll
Fri May 23, 2014 10:57 pm
Forum: RouterBOARD hardware
Topic: RB850Gx2 - Release date?
Replies: 193
Views: 47704

Re: RB850Gx2 - Release date?

MikroTik expected date for RB850Gx2 is middle of June.
Of what year?? I'm still waiting for the mAP...

Yeah. same here.

The expected date for mAP was for latest week of april but still nothing :-(


sent from my mobile phone using tapatalk
by c0d3rSh3ll
Fri May 23, 2014 10:41 pm
Forum: General
Topic: Feature request: Scripting language improvement
Replies: 18
Views: 4248

Re: Feature request: Scripting language improvement

When I talk about a full event trap system I mean any kind of event that occurs on a RouterOS. Whatever: a wifi client is registered/disconnected then launch an event, a dhcp lease is asigned/finished then launch another event. Think about as if it worked just like the log, something happens then t...
by c0d3rSh3ll
Mon May 19, 2014 7:38 pm
Forum: Beginner Basics
Topic: How to convert internal-id to a string
Replies: 5
Views: 725

Re: How to convert internal-id to a string

What do you want to do?

sent from my mobile phone using tapatalk
by c0d3rSh3ll
Sat May 17, 2014 4:55 am
Forum: General
Topic: v6.13 released!
Replies: 177
Views: 49239

Re: v6.13 released!

Hello Folks! Sorry to sat that CRS and simple vlans, trunk and access ports still does not work. I did reset configuration with no defaults and with defaults, result is the same. I did not to a netboot install, that test remains. However the CRS does not hang anymore when trying, otherwise it fails...
by c0d3rSh3ll
Sat May 10, 2014 6:46 pm
Forum: Scripting
Topic: how to get only ip from queue simple from script
Replies: 5
Views: 1723

Re: how to get only ip from queue simple from script

not work... foreach o in=[queue simple find] do={ {... :local fullIP value=[queue simple get value-name=target $o] {... :local onlyIP value=[:pick $fullIP -1 ([:len $fullIP] - 3)]; {... put $onlyIP {... } [admin@MikroTik] > foreach o in=[queue simple find] do={ {... :local fullIP value=[queue simple...
by c0d3rSh3ll
Fri May 09, 2014 7:59 am
Forum: Scripting
Topic: how to get only ip from queue simple from script
Replies: 5
Views: 1723

how to get only ip from queue simple from script

Hi. I am working in a script to get only the ip address from queue simple, but I have a bit problem the script what I am trying for get only ip address without the netmask is foreach i in=[queue simple find ] do={ local tmp [/queue simple get value-name=target $i] local ip [pick $tmp 0 [:find $tmp "...
by c0d3rSh3ll
Fri May 09, 2014 2:33 am
Forum: General
Topic: Peru / Ecuador wisps
Replies: 1
Views: 336

Re: Peru / Ecuador wisps

I am from Chile...
by c0d3rSh3ll
Thu May 08, 2014 9:21 pm
Forum: Scripting
Topic: bgp peer switch script
Replies: 8
Views: 2202

Re: bgp peer switch script

how are you enabling and disabling each peer?
by c0d3rSh3ll
Thu May 08, 2014 9:11 pm
Forum: Scripting
Topic: Script not running on reboot of router
Replies: 8
Views: 4636

Re: Script not running on reboot of router

first execute the script from terminal and see if the router can send you an email /sys script run emailonreboot-script check the output of terminal and see your email account if you receive the email. I have running a script to send me an email to my gmail account and work fine, but is tested in 6....
by c0d3rSh3ll
Thu May 08, 2014 7:21 am
Forum: Wireless Networking
Topic: Virtual SSID with walled garden
Replies: 2
Views: 606

Re: Virtual SSID with walled garden

Yes. You can do this. For 2 wireless network you need to configure virtual access point feature.


http://wiki.mikrotik.com/images/5/5f/Cr ... Campus.pdf
by c0d3rSh3ll
Thu May 08, 2014 6:21 am
Forum: Scripting
Topic: Print usermanager user's phone number to text file
Replies: 4
Views: 1192

Re: Print usermanager user's phone number to text file

what is your usermanager version?
by c0d3rSh3ll
Thu May 08, 2014 3:02 am
Forum: Scripting
Topic: Find address in network
Replies: 5
Views: 1383

Re: Find address in network

may be this can help you

ros code

foreach i in=[queue simple find ] do={
local ip [queue simple get value-name=target $i]
if ($ip ~"^202.*") do={
/ip firewall address-list add list=allowed address=$ip}}
by c0d3rSh3ll
Wed May 07, 2014 5:33 pm
Forum: Forwarding Protocols
Topic: OSPF type 0x09 error
Replies: 6
Views: 2240

Re: OSPF type 0x09 error

Post your conf of each router and routerOS version.

sent from my mobile phone using tapatalk
by c0d3rSh3ll
Wed May 07, 2014 7:55 am
Forum: Scripting
Topic: Change ssid script don't work
Replies: 2
Views: 915

Re: Change ssid script don't work

ros code

/tool netwatch
add host=8.8.8.8 down-script="interface wireless set 0 ssid=Is-Down" up-script="interface wireless set 0 ssid=Is-Up"
you need to change the host.
by c0d3rSh3ll
Sun May 04, 2014 10:22 am
Forum: Beginner Basics
Topic: vlan bridging
Replies: 2
Views: 1029

Re: vlan bridging

Hi.


First add a vlan interface trough ether1 in rb2011

In the ap add the same vlan through interface connected to rb2011

For untagged traffic from ap is not necessary to do anything.
by c0d3rSh3ll
Fri May 02, 2014 9:56 pm
Forum: Scripting
Topic: How to get only what i need?
Replies: 5
Views: 1404

Re: How to get only what i need?

maybe this can help you
ssh admin@ip.mikrotik ':foreach i in=[ip dhcp-server lease find ] do={; local ip [ip dhcp-server lease get value-name=address $i]; local hostname [ip dhcp-server lease get value-name=host-name $i]; put "$ip $hostname";}' > leases.txt
by c0d3rSh3ll
Fri May 02, 2014 5:33 pm
Forum: General
Topic: Backup troubles
Replies: 13
Views: 1783

Re: Backup troubles

I had the same problem with a routerboard creating a backup file and the output was the same. Later i restored the backup and the rb was unreacheable. Only netinstal help me.

I suggest reinstall routerOS with netinstall for a clean installation.

sent from my mobile phone using tapatalk
by c0d3rSh3ll
Fri May 02, 2014 3:55 am
Forum: General
Topic: Feature request: Module memory usage in Profile
Replies: 7
Views: 2894

Re: Feature request: Module memory usage in Profile

+1

I have some rb750 and the ram usage is so much in 6.x (6 mb free), in the 5.x I have 16 mb free and I dont known what proccess is eating my ram. I have only default setting.

sent from my mobile phone using tapatalk
by c0d3rSh3ll
Wed Apr 30, 2014 8:31 pm
Forum: Beginner Basics
Topic: Re : allow lan/internet access by mac address only
Replies: 3
Views: 3501

Re: Re : allow lan/internet access by mac address only

You can use arp list of each mac-address of your network and then use reply-only in the lan inyerface. So routerOS reply for all arp static list and deny other.

sent from my mobile phone using tapatalk
by c0d3rSh3ll
Wed Apr 30, 2014 12:20 am
Forum: Wireless Networking
Topic: One port for up-link and one for down-link
Replies: 6
Views: 1083

Re: One port for up-link and one for down-link

Here you can find the answer

http://forum.mikrotik.com/viewtopic.php ... 16#p421416

sent from my mobile phone using tapatalk
by c0d3rSh3ll
Tue Apr 29, 2014 7:29 pm
Forum: General
Topic: Newsletter 57
Replies: 15
Views: 6746

Re: Newsletter 57

Any news about mAP?

sent from my mobile phone using tapatalk
by c0d3rSh3ll
Mon Apr 28, 2014 8:34 pm
Forum: General
Topic: PPTP Site to Site VPN
Replies: 11
Views: 16881

Re: PPTP Site to Site VPN

Here:

http://wiki.mikrotik.com/wiki/Manual:Interface/PPTP



sent from my mobile phone using tapatalk
by c0d3rSh3ll
Mon Apr 28, 2014 5:36 pm
Forum: General
Topic: Interface grouping
Replies: 1
Views: 496

Re: Interface grouping

We not have (yet) this feature. In this thread we are requesting this feature

http://forum.mikrotik.com/viewtopic.php ... 49#p418249

sent from my mobile phone using tapatalk
by c0d3rSh3ll
Sun Apr 27, 2014 6:36 am
Forum: RouterBOARD hardware
Topic: RB951Ui-2HnD with external antennas
Replies: 18
Views: 31047

Re: RB951Ui-2HnD with external antennas

Can't do. Ruter is already sold. Why you can't it's easy to do? I think this use that part for solder or install for two external antennas left and right. I will try to do it for my RB951Ui-2HnD. Then I post new subject for my test to know how to do that. http://www.almafia.com/vb/up/1_01398562622....
by c0d3rSh3ll
Fri Apr 18, 2014 4:43 pm
Forum: Beginner Basics
Topic: How to exempt VPN traffic from PCC
Replies: 1
Views: 907

Re: How to exempt VPN traffic from PCC

Add a mangle rule in the top of your rules:

/ip firwall mangle add chain=prerouting protocol=gre in-interface=lan action=accept

With this rule your gre traffic is not forced to route through wan interface.


sent from my mobile phone using tapatalk
by c0d3rSh3ll
Tue Apr 15, 2014 6:56 pm
Forum: RouterBOARD hardware
Topic: RB951-2n memory size reported incorrectly by routerOS?
Replies: 5
Views: 1370

Re: RB951-2n memory size reported incorrectly by routerOS?

Looks like you got a CPU bump as well.
By default it have 300 mhz but you can overclock to 400 mhz.



sent from my mobile phone using tapatalk
by c0d3rSh3ll
Tue Apr 15, 2014 4:56 am
Forum: General
Topic: CCR1036 License and Software ID issue
Replies: 2
Views: 657

Re: CCR1036 License and Software ID issue

In licenses problem the only way is contact to support mikrotik and wait an answer from they. The user forum can not do anything about it.



sent from my mobile phone using tapatalk
by c0d3rSh3ll
Tue Apr 15, 2014 2:29 am
Forum: General
Topic: uPnP Dynamic NAT Rules on top
Replies: 2
Views: 1265

Re: uPnP Dynamic NAT Rules on top

You can move dynamic rules on the top of nat table with something like this:

/ip firewall nat move [find dynamic ] 0

Execute every 5 min

sent from my mobile phone using tapatalk
by c0d3rSh3ll
Wed Apr 09, 2014 10:22 pm
Forum: General
Topic: Route traffic depending on protocol - How to
Replies: 1
Views: 1889

Re: Route traffic depending on protocol - How to

You can force any traffic over specific gateway using routing mark in mangle and rouring table something like this: /ip firewall mangle add chain=prerouting protocol=tcp dst-port=22 in-interface=lan action =mark-routing new-routing-mark=ssh-route /ip route add routing-mark=ssh-route gateway=your_gat...
by c0d3rSh3ll
Wed Apr 09, 2014 8:57 pm
Forum: Beginner Basics
Topic: No DNS server for PPP clients
Replies: 4
Views: 3046

Re: No DNS server for PPP clients

Dns server is necessary in the client so you can setup your dns server or a public dns like 8.8.8.8

sent from my mobile phone using tapatalk
by c0d3rSh3ll
Mon Apr 07, 2014 12:45 am
Forum: General
Topic: Filter Rule/forwarding question
Replies: 5
Views: 1593

Re: Filter Rule/forwarding question

It ended up be an issue with a NAT rule/masquerade. It is working now. Thanks for the replies!
What were the rule nat/masquerade than help you to solve the problem ?

sent from my mobile phone using tapatalk
by c0d3rSh3ll
Tue Apr 01, 2014 11:26 pm
Forum: General
Topic: Routing selection with two gateways
Replies: 25
Views: 2600

Re: Routing selection with two gateways

Guys

Remember this is a english forum.
In your country you have routerOS italian forum

sent from my mobile phone using tapatalk
by c0d3rSh3ll
Tue Apr 01, 2014 9:59 pm
Forum: General
Topic: Load_balancing local network is unreachable
Replies: 3
Views: 670

Re: Load_balancing local network is unreachable

You need to add a mangle rule for accept traffic from local network to local network

sent from my mobile phone using tapatalk
by c0d3rSh3ll
Tue Apr 01, 2014 9:06 pm
Forum: General
Topic: Filter Rule/forwarding question
Replies: 5
Views: 1593

Re: Filter Rule/forwarding question

RouterOS has an accept default policy filter rules so if you not add any rule of block traficc it not drop this voip connection. You can accept this traffic with this rule: /ip firewall filter add chain=forward scr-address=ip_voip_phone protocol=udp dst-port=10000-20000 action accept /ip firewall fi...
by c0d3rSh3ll
Tue Apr 01, 2014 12:06 am
Forum: Beginner Basics
Topic: Reading CPU temperature through serial port ?
Replies: 6
Views: 3600

Re: Reading CPU temperature through serial port ?

Are you using an arduino module something like this ?

http://www.dx.com/es/p/rs232-to-ttl-ser ... ack-221240

It have a tx/rx for connect to arduino.


sent from my mobile phone using tapatalk
by c0d3rSh3ll
Sun Mar 30, 2014 8:15 pm
Forum: General
Topic: Domain Blacklists For Mikrotik RouterOS Web Proxy
Replies: 7
Views: 4236

Re: Domain Blacklists For Mikrotik RouterOS Web Proxy

Anyone test this list? I am setting a 5.000+ users hotspot and need to block mainly porn and web proxy sites.

you can block any website with openDNS, is more efective than squid proxy.
by c0d3rSh3ll
Sat Mar 29, 2014 5:29 pm
Forum: General
Topic: Feature request: grouping interfaces in firewall
Replies: 7
Views: 2692

Re: Feature request: grouping interfaces in firewall

+1 also

We dont need to add a rule for each interface.

sent from my mobile phone using tapatalk
by c0d3rSh3ll
Fri Mar 28, 2014 8:56 am
Forum: RouterBOARD hardware
Topic: omnitik reboot sometimes SOLVED
Replies: 3
Views: 1448

Re: omnitik reboot sometimes

You need to reinstall routerOS system with netinstall. Use netinstall and routerOS 6.11

I have this error (kernel failure) some times and I solved it with netinstall, maybe it can help you.

sent from my mobile phone using tapatalk
by c0d3rSh3ll
Thu Mar 27, 2014 10:38 pm
Forum: General
Topic: Need Help Load Balancing 1100 AHX2
Replies: 12
Views: 1688

Re: Need Help Load Balancing 1100 AHX2

Can you post your mangle rules here for see what is wrong.

sent from my mobile phone using tapatalk
by c0d3rSh3ll
Thu Mar 27, 2014 10:35 pm
Forum: General
Topic: RB1100AHX2 Need Help Please. Thanks Everyone!!!!!!
Replies: 3
Views: 812

Re: RB1100AHX2 Need Help Please. Thanks Everyone!!!!!!

You can block all port except 80 and 443 for web browser and dns also. Any p2p software can not connect.

Can you paste here an export of your conf

sent from my mobile phone using tapatalk
by c0d3rSh3ll
Thu Mar 27, 2014 9:36 pm
Forum: Beginner Basics
Topic: Bridging the WAN interface.
Replies: 6
Views: 1432

Re: Bridging the WAN interface.

Maybe you can paste here you export.

sent from my mobile phone using tapatalk
by c0d3rSh3ll
Thu Mar 27, 2014 8:45 pm
Forum: Beginner Basics
Topic: how to monitor WAN uptime?
Replies: 3
Views: 2194

Re: how to monitor WAN uptime?

You can remove the section of "file remove file.jpg"

sent from my mobile phone using tapatalk
by c0d3rSh3ll
Tue Mar 25, 2014 8:30 pm
Forum: General
Topic: Backup WAN
Replies: 4
Views: 1319

Re: Backup WAN

First create 2 routes rules to force a remote host through a specific wan. You need to change Host1 and Host2 to a public host like 8.8.8.8 and 8.8.4.4 and GW1 and GW2 to your gateway of each wan connection /ip route add dst-address=Host1 gateway=GW1 scope=10 add dst-address=Host2 gateway=GW2 scope=...
by c0d3rSh3ll
Tue Mar 25, 2014 7:42 pm
Forum: Beginner Basics
Topic: how to monitor WAN uptime?
Replies: 3
Views: 2194

Re: how to monitor WAN uptime?

you can monitoring a wan connection through downloading a file of any website, if the file is unreachable you can assume is not working. do {tool fetch mode=http url=http://www.anyhots.com/file.jpg ; file remove file.jpg} on-error={log error "the file cannot be downloaded"} you can execute every 10 ...
by c0d3rSh3ll
Tue Mar 25, 2014 6:26 pm
Forum: General
Topic: L2tP with IPSec don't works on v6.11 (Solved!)
Replies: 4
Views: 988

Re: L2tP with IPSec don't works on v6.11

Replicate the problem and send a support.rif to support@mikrotik.com

sent from my mobile phone using tapatalk
by c0d3rSh3ll
Tue Mar 25, 2014 6:01 pm
Forum: Beginner Basics
Topic: Noob question about Dual WAN
Replies: 2
Views: 1379

Re: Noob question about Dual WAN

Something like this:

/ip firewall mangle add chain=prerouting scr-address=ip_raspi action=mark-routing new-routing-mark=raspi

/ip route add gateway=gateway2 routing-mark=raspi distance=1

/ip route add gateway=gateway1 routing-mark=raspi distance=2



sent from my mobile phone using tapatalk
by c0d3rSh3ll
Tue Mar 25, 2014 4:27 pm
Forum: General
Topic: big problem
Replies: 4
Views: 1038

Re: big problem

This is the solution

http://wiki.mikrotik.com/wiki/Load_Bala ... e_Gateways


sent from my mobile phone using tapatalk
by c0d3rSh3ll
Tue Mar 25, 2014 4:24 pm
Forum: General
Topic: How to leave a free subnet in hotspot
Replies: 5
Views: 1570

Re: How to leave a free subnet in hotspot

You can bypass the pc and another devices from hotspot with ip binding option.

sent from my mobile phone using tapatalk
by c0d3rSh3ll
Mon Mar 24, 2014 7:50 am
Forum: General
Topic: Web Proxy disable scripting
Replies: 5
Views: 1212

Re: Web Proxy disable scripting

what is your proxy OS?, I am thinking to make a script for chech the squid status and add a rule for block ping if is not running. Through this method routerOS can not ping to proxy and disable the nat rule, then if squid status is running disable this rule and routerOS can enable the nat rule again.
by c0d3rSh3ll
Mon Mar 24, 2014 2:24 am
Forum: General
Topic: Best equipment for 200 users on hotspot
Replies: 3
Views: 1504

Re: Best equipment for 200 users on hotspot

The best solution and "low cost" is a rb1100ahx2 or you can buy a CCR but is more expensive.


sent from my mobile phone with tapatalk
by c0d3rSh3ll
Mon Mar 24, 2014 2:02 am
Forum: General
Topic: Web Proxy disable scripting
Replies: 5
Views: 1212

Re: Web Proxy disable scripting

With ping is not a secure method because if squid fail the proxy reply your ping packet. If you need the easy way is: Add a netwach rule with host=ip_proxy In the down tab add this : /ip firewall nat disable [find comment=squid] In the up tab add: /ip firewall nat enable [find comment=squid] Add the...
by c0d3rSh3ll
Sat Mar 22, 2014 6:05 am
Forum: Beginner Basics
Topic: how to merge 4 internet connections on RB951Ui-2HnD
Replies: 3
Views: 1480

Re: how to merge 4 internet connections on RB951Ui-2HnD

You can balance connection from your network with PCC method. Is a load balance and work fine for me.

sent from my mobile phone with tapatalk
by c0d3rSh3ll
Thu Mar 20, 2014 9:00 pm
Forum: General
Topic: IPSec Tunneling - Help needed - part 2 - Static Routes
Replies: 5
Views: 981

Re: IPSec Tunneling - Help needed - part 2 - Static Routes

Try this:
Add a static route like this
/ip route add dst-address=remote_network gateway=ip_peerIPsec


sent from my mobile phone with tapatalk
by c0d3rSh3ll
Thu Mar 20, 2014 6:05 am
Forum: General
Topic: Feature request: OpenVPN compression LZO and UDP
Replies: 200
Views: 93973

Re: Feature request: OpenVPN compression LZO and UDP

+1 for udp protocol. I need to run a pfsense machine for openvpn over udp connected to my mikrotik core router


sent from my mobile phone with tapatalk
by c0d3rSh3ll
Wed Mar 19, 2014 7:17 pm
Forum: General
Topic: Hotspot users can browse by IP but no DNS
Replies: 2
Views: 570

Re: Hotspot users can browse by IP but no DNS

You have "allow remote request=yes" in dns menu?

Post an export from your router

sent from my mobile phone with tapatalk
by c0d3rSh3ll
Tue Mar 18, 2014 7:19 pm
Forum: Beginner Basics
Topic: webproxy with hotspot
Replies: 3
Views: 742

Re: webproxy with hotspot

Post your nat rule of transparent proxy.

sent from my mobile phone with tapatalk
by c0d3rSh3ll
Sat Mar 15, 2014 5:32 am
Forum: General
Topic: New RB2011 hotspot page not working [FIXED]
Replies: 5
Views: 2658

Re: New RB2011 hotspot page not working

select birdge-local instead of ether2.
by c0d3rSh3ll
Fri Mar 14, 2014 11:33 pm
Forum: Wireless Networking
Topic: Traffic not passing from wan to lan
Replies: 3
Views: 1856

Re: Traffic not passing from wan to lan

Check the masquerade rule if your cpe is nated

sent from my mobile phone with tapatalk
by c0d3rSh3ll
Fri Mar 14, 2014 9:30 pm
Forum: Scripting
Topic: reditrect log output in script
Replies: 3
Views: 2001

Re: reditrect log output in script

you can do with action remote in system-->loggin menu for info topic.

http://wiki.mikrotik.com/wiki/Manual:System/Log


the problem is that all loging info topic are send to remote syslog.
by c0d3rSh3ll
Thu Mar 13, 2014 4:47 am
Forum: Beginner Basics
Topic: Firewall config only allow certain ports from VPN connection
Replies: 3
Views: 1295

Re: Firewall config only allow certain ports from VPN connec

When a client is connected i do see the interface "l2tp-user", and i can configure it like this: Chain:forward protocol:TCP destination port:portnr In Interface :l2tp-user Action: Accept Chain:dstnat protocol:TCP destination port:portnr In Interface :l2tp-user Action: dst-nat to adress: serverip to...
by c0d3rSh3ll
Thu Mar 13, 2014 3:51 am
Forum: Scripting
Topic: Ip hotspot active user = simple Queue
Replies: 1
Views: 928

Re: Ip hotspot active user = simple Queue

Something like this?

http://forum.mikrotik.com/viewtopic.php ... 63#p299563


sent from my mobile phone with tapatalk
by c0d3rSh3ll
Tue Mar 11, 2014 10:31 pm
Forum: Scripting
Topic: Edit values with a script
Replies: 4
Views: 3468

Re: Edit values with a script

You can set (edit) a firewall rule like this:

/ip firewall filter set action=accept number=6

sent from my mobile phone with tapatalk
Thank you c0d3rs
You understand what I mean, it works!
I edit the post for more info. Check again

sent from my mobile phone with tapatalk
by c0d3rSh3ll
Tue Mar 11, 2014 10:22 pm
Forum: Scripting
Topic: Edit values with a script
Replies: 4
Views: 3468

Re: Edit values with a script

You can set (edit) a firewall rule like this: /ip firewall filter set action=accept number=6 The same way for drop /ip firewall filter set action=drop number=6 I prefer to use find option for set a firewall rule because maybe the orden of the rules is changed so you set another rule. For this is: /i...
by c0d3rSh3ll
Tue Mar 11, 2014 9:46 am
Forum: Wireless Networking
Topic: Load Balancing 4WAN connection Turned into 1 solid link
Replies: 2
Views: 711

Re: Load Balancing 4WAN connection Turned into 1 solid link

Is this possible i have multiple connections bringing internet can i use a mikrotik router board to give out 1 sold link of the 4 internet links example each link brings 1mb of internet connectivity if i combine them i should get 1 solid output of 4mb internet link? Please advise if any one can ass...
by c0d3rSh3ll
Sun Mar 09, 2014 7:08 pm
Forum: General
Topic: redirect without loop?
Replies: 4
Views: 1297

Re: redirect without loop?

You need to add a accept rule for the website in the top of your rules and then the redirect rule

Sent from my mobile phone with Tapatalk
by c0d3rSh3ll
Sat Mar 08, 2014 9:08 pm
Forum: General
Topic: SKYPE Queue Priority
Replies: 3
Views: 1994

Re: SKYPE Queue Priority

Maybe layer 7 regex can help you. I tried it with 5.x and work fine.

Sent from my mobile phone with Tapatalk
by c0d3rSh3ll
Thu Mar 06, 2014 8:31 pm
Forum: General
Topic: Strnge DNS Cache entries from China
Replies: 5
Views: 1299

Re: Strnge DNS Cache entries from China

Protect your mikrotik dns from internet acces allowing only request from your lan

Sent from my mobile phone with Tapatalk
by c0d3rSh3ll
Tue Mar 04, 2014 3:51 am
Forum: General
Topic: mikrotik central pppoe server
Replies: 2
Views: 481

Re: mikrotik central pppoe server

What is your problem?

Sent from my mobile phone with Tapatalk
by c0d3rSh3ll
Mon Mar 03, 2014 10:01 pm
Forum: Scripting
Topic: Mikrotik and Squid(Ubuntu based)
Replies: 1
Views: 895

Re: Mikrotik and Squid(Ubuntu based)

in your nat rule you can set !scr-address=ip_mediaserver

so any ip except ip of mediaserver is redirected to squid box.
by c0d3rSh3ll
Fri Feb 21, 2014 4:41 am
Forum: General
Topic: Hotspot trial user uptime problem
Replies: 2
Views: 1170

Re: Hotspot trial user uptime problem

Set "trial uptime reset" in server profile to for example "30d 00:00:00" so they can no log in again for 30 days

Sent from my mobile phone with Tapatalk
by c0d3rSh3ll
Fri Feb 21, 2014 4:28 am
Forum: General
Topic: pptp client not work with Load Balancing pcc
Replies: 4
Views: 3800

Re: pptp client not work with Load Balancing pcc

You have a default gateway in the router? Post your export config

Sent from my mobile phone with Tapatalk
by c0d3rSh3ll
Fri Feb 21, 2014 2:34 am
Forum: General
Topic: Trouble with balanced gateways and speedtest.net
Replies: 4
Views: 1105

Re: Trouble with balanced gateways and speedtest.net

http://forum.mikrotik.com/viewtopic.php?f=2&t=81311

In this post you can add the address of speedtest in an address list and then mark routing

Sent from my mobile phone with Tapatalk
by c0d3rSh3ll
Thu Feb 20, 2014 6:42 am
Forum: General
Topic: Trouble with balanced gateways and speedtest.net
Replies: 4
Views: 1105

Re: Trouble with balanced gateways and speedtest.net

Mark route with dst-address of speedtest server like this: /ip firewall mangle add chain=prerouting dst-address-list=speedtest action=mark-routing new-routing-mark=speedtest Add all ip address of speedtes in the address list calle speddtest Then select the gateway of your wan Sent from my mobile pho...
by c0d3rSh3ll
Wed Feb 12, 2014 8:33 pm
Forum: Beginner Basics
Topic: 2 PPPoE PCC + failover, RouterOS 6.9
Replies: 4
Views: 4088

Re: 2 PPPoE PCC + failover, RouterOS 6.9

Hi.
Please contact me on my signature with your post atacched for more detail.

Regards

Sent from my mobile phone using Tapatalk.
by c0d3rSh3ll
Tue Feb 11, 2014 3:50 am
Forum: Beginner Basics
Topic: simple 2 WAN failover
Replies: 16
Views: 61124

Re: simple 2 WAN failover

If you have setup mangle correctly Never heard of it. I just wanted a router for failoever. I was choosing between tp link470+ and some used linksys with tomato firmware from ebay, but they both were 100mbps, so I went for this. Sorry. I thought you need a load balance through pcc method. "bingo220...
by c0d3rSh3ll
Tue Feb 11, 2014 12:26 am
Forum: Beginner Basics
Topic: simple 2 WAN failover
Replies: 16
Views: 61124

Re: simple 2 WAN failover

If you have setup mangle correctly in the routes select pppoe interface instead of ip addres.
In the pppoe client interface unchek use-default-route.


Sent from my mobile phone using Tapatalk.
by c0d3rSh3ll
Mon Feb 10, 2014 10:23 pm
Forum: General
Topic: free dynamic dns ?
Replies: 19
Views: 4083

Re: free dynamic dns ?

I use freedns. Is good and free until to 5 host.

Sent from my mobile phone using Tapatalk.
by c0d3rSh3ll
Mon Feb 10, 2014 8:50 am
Forum: Scripting
Topic: Script to autochange SSID when not internet
Replies: 6
Views: 3635

Re: Script to autochange SSID when not internet

You can do with netwatch tool also.
When the host is up execute the script like this:
/interface wireless set 0 ssid=Is-Up

When the host is down execute this:

/interface wireless set 0 ssid=Is-Down

Sent from my mobile phone using Tapatalk.
by c0d3rSh3ll
Mon Feb 10, 2014 8:08 am
Forum: General
Topic: mkbrutus, mikrotik access brute force to api
Replies: 1
Views: 1269

mkbrutus, mikrotik access brute force to api

are you ready for this?

http://mkbrutusproject.github.io/MKBRUTUS/


security:

1. set a strong password for api user
2. add a few filter rules for protect brute force service
3. disable api service
4. etc...
by c0d3rSh3ll
Fri Feb 07, 2014 7:21 am
Forum: Scripting
Topic: [SOLVED] Need Help Scritpting of DHCP-Client
Replies: 5
Views: 1034

Re: Need Help Scritpting of DHCP-Client

try this... { local ip [ip dhcp-client get value-name=address 0] local count [len $ip] local count1 [($count - 3)] local address [pick $ip 0 $count1] ip firewall mangle set [find comment=update] dst-address=$address } you need to have a netmask in dhcp-client of 2 digits like /24, if you have 1 digi...
by c0d3rSh3ll
Fri Feb 07, 2014 3:09 am
Forum: Scripting
Topic: [SOLVED] Need Help Scritpting of DHCP-Client
Replies: 5
Views: 1034

Re: Need Help Scritpting of DHCP-Client

You can use other method like in-interface=wan with the same result.

Sent from my mobile phone using Tapatalk.
by c0d3rSh3ll
Thu Feb 06, 2014 11:31 pm
Forum: Scripting
Topic: Need script that will pull information from simple queue
Replies: 2
Views: 720

Re: Need script that will pull information from simple queue

maybe this is a start point for you

ros code

foreach i in=[queue simple find] do={
local ip [queue simple get value-name=target $i]
local byte [queue simple get value-name=bytes $i]
put "$ip has $byte"
}
then you can save to a file.
by c0d3rSh3ll
Thu Feb 06, 2014 7:33 pm
Forum: Beginner Basics
Topic: Problem with RB450G
Replies: 6
Views: 1354

Re: Problem with RB450G

I have upgraded this to RouterOS v6.7 & reset this many time but result is same.
May be is a hardware problem. RMA to your distributor.

Sent from my mobile phone using Tapatalk.
by c0d3rSh3ll
Tue Feb 04, 2014 7:25 pm
Forum: General
Topic: Need Help Load Balancing 1100 AHX2
Replies: 12
Views: 1688

Re: Need Help Load Balancing 1100 AHX2

Load balance with PCC. In the wiki you have an example.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Tue Feb 04, 2014 4:08 am
Forum: Scripting
Topic: Mikrotik time to seconds - Tiempo Mikrotik a segundos
Replies: 4
Views: 2141

Re: Mikrotik time to seconds - Tiempo Mikrotik a segundos

Thank.. your script have some error, here is ok. Is working un 5.26 but not in 6.9. el script tiene algunos errores, aca esta corregido. Lo probe en la version 5.26 y esta funcionando pero en la 6.9 no, cuando tenga tiempo lo revizare... :local uptime [/system resource get uptime]; :local weekend 0;...
by c0d3rSh3ll
Mon Feb 03, 2014 11:19 pm
Forum: Scripting
Topic: Disable IP address script
Replies: 2
Views: 1063

Re: Disable IP address script

try this, is working for me tested in 6.9 version.

ros code

ip address remove [find address="10.0.0.1/8"]
by c0d3rSh3ll
Thu Jan 30, 2014 10:53 pm
Forum: General
Topic: Disconnect automatically after 15 minutes
Replies: 1
Views: 999

Re: Disconnect automatically after 15 minutes

May be is overloaded. Check your rules and optimize it. What is your routerOS version and firmware?

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Thu Jan 30, 2014 1:38 am
Forum: General
Topic: Limit bandwidth by mac address on RB750
Replies: 4
Views: 2151

Re: Limit bandwidth by mac address on RB750

Mikrotik routerOS can limit traffic through queue simple by ip only.


Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Thu Jan 30, 2014 1:32 am
Forum: Scripting
Topic: Interface traffic hard LIMIT monthly
Replies: 2
Views: 916

Re: Interface traffic hard LIMIT monthly

You can do a script for get traffic counter and if the limit is reached then you can block the traffic or disable 3g interface like netgeard vendor.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Tue Jan 28, 2014 2:12 am
Forum: Scripting
Topic: Processing delimiter in RouterOS
Replies: 2
Views: 842

Re: Processing delimiter in RouterOS

Use Pick command

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Mon Jan 27, 2014 1:35 am
Forum: General
Topic: how to avoid hotspot users to use connectify apps to share?
Replies: 7
Views: 4311

Re: how to avoid hotspot users to use connectify apps to sha

Only one rule with change ttl action to 1 in forward chain.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Mon Jan 27, 2014 1:12 am
Forum: Scripting
Topic: Facebook Images Missing
Replies: 5
Views: 1790

Re: Facebook Images Missing

check in the user profile if you have enabled "transparent proxy" option
by c0d3rSh3ll
Fri Jan 24, 2014 5:49 am
Forum: General
Topic: domain name to my mikrotik router
Replies: 4
Views: 6068

Re: domain name to my mikrotik router

Yes, you can do. In wiki.mikrotik.com you have some examples like no-ip, dyndns, changeip, etc.


Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Fri Jan 24, 2014 5:22 am
Forum: General
Topic: how to avoid hotspot users to use connectify apps to share?
Replies: 7
Views: 4311

Re: how to avoid hotspot users to use connectify apps to sha

Change ttl in mangle rule to 1

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Fri Jan 24, 2014 4:09 am
Forum: Scripting
Topic: Facebook Images Missing
Replies: 5
Views: 1790

Re: Facebook Images Missing

Check your dns server. Change for googleDNS or openDNS and try.
You have web proxy feature? Hotspot?

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Fri Jan 24, 2014 4:04 am
Forum: General
Topic: Can HotSpot User speedlimit be changed in realtime?
Replies: 1
Views: 620

Re: Can HotSpot User speedlimit be changed in realtime?

You can use PCQ and address-list for dynamically change the limit for your user.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Fri Jan 24, 2014 3:58 am
Forum: RouterBOARD hardware
Topic: Why not make access points already assembled?
Replies: 2
Views: 1219

Re: Why not make access points already assembled?

But you have latest routerboard like basebox2 or basebox5 for antenna sectorial dual chain ready to use.
Grove and metal is ready to use also.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Fri Jan 24, 2014 3:50 am
Forum: General
Topic: Set custom DL-UL bandwith rates
Replies: 3
Views: 744

Re: Set custom DL-UL bandwith rates

You can setup your custom limit with any number with "k" leter like this 756k, 300k etc. For megabits is "M" like this 11M, 7M etc

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Wed Jan 22, 2014 4:32 am
Forum: Scripting
Topic: Afraid.org dns script using specific wan port
Replies: 12
Views: 3224

Re: Afraid.org dns script using specific wan port

Freedns.afraid.org now for me is 178.33.33.231

So you can do this:
/ip route add dst-address=178.33.33.231 gateway=1.1.1.1

Change 1.1.1.1 for your wan3 gateway

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Sun Jan 19, 2014 3:46 pm
Forum: General
Topic: Domains whitelist few - blacklist the rest
Replies: 1
Views: 1352

Re: Domains whitelist few - blacklist the rest

You can do with transparent proxy and access list.
Firt create proxy transparent in nat firewall and then add to rule for accept your whitelist web site and other for block anything


Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Sat Jan 18, 2014 6:13 am
Forum: The User Manager
Topic: pppoe client dialing log
Replies: 2
Views: 2778

Re: pppoe client dialing log

Try with a log rule with pppoe and debug topic but I think is encripted or the routerOS can not show you.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Fri Jan 17, 2014 10:51 pm
Forum: General
Topic: Qos Lan
Replies: 1
Views: 798

Re: Qos Lan

You can use input chain for the router and add a simple queue for this packet or prerouting for packet to the router and other network. Remember put this rule in the top of you rules.


Queue tree are before of simple queue in 6.x version.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Fri Jan 17, 2014 9:16 pm
Forum: Scripting
Topic: Hotspot Help!!!
Replies: 1
Views: 565

Re: Hotspot Help!!!

Try with other web browser. Some browser not work with hotspot.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Thu Jan 16, 2014 9:09 pm
Forum: Beginner Basics
Topic: Hotel in the desert needs some help
Replies: 3
Views: 764

Re: Hotel in the desert needs some help

Hi guys, I have started a job at a hotel in the desert, (think 4 staff and 1 customer per day), and the hotel is using a MikroTik solution to allow customers to logon to the internet via a 'hotspot' login. The hotel managers, (way into their 60's) use the same login system as a customer to access t...
by c0d3rSh3ll
Tue Jan 14, 2014 8:56 pm
Forum: General
Topic: Block UDP traffic
Replies: 7
Views: 6098

Re: Block UDP traffic

/ip firewall filter add src-address=!192.168.1.0/24  protocol=udp action=drop
I not need to set chain?
Yes. You need chain forward

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Tue Jan 14, 2014 3:49 pm
Forum: Beginner Basics
Topic: gateway mac address
Replies: 1
Views: 1377

Re: gateway mac address

I am preconfiguring a Mikrotik and my ISP requires me to register my router's Mac address and will not pass traffic if they detect something else. If I set the gateway's (ether1) mac to match old router's mac they should accept this right? I have the following export under /interface ethernet: set ...
by c0d3rSh3ll
Tue Jan 14, 2014 3:45 pm
Forum: General
Topic: Problem with PCC Load Balancing !!!
Replies: 4
Views: 1198

Re: Problem with PCC Load Balancing !!!

Hi. For routing a ip through a specific wan first you need mark route from this ip in mangle and then set the gateway in routes. For the ftp is the same but with tcp protocol and dst port 20,21 and in the route set the gateway wan2 with distance 1 and other route with wan3 but with distance 2 Both m...
by c0d3rSh3ll
Mon Jan 13, 2014 8:44 pm
Forum: Beginner Basics
Topic: Limit webfig access to a single network / port on device?
Replies: 4
Views: 2270

Re: Limit webfig access to a single network / port on device

For this goal you have some way. The simple way is with firewall like this: /ip firewall filter add chain=input src-address=192.168.2.0/24 action=drop This rule block all conection to your device from network 192.168.2.0/24 If you need block only http access /ip firewall filter add chain=input src-a...
by c0d3rSh3ll
Mon Jan 13, 2014 3:55 pm
Forum: RouterBOARD hardware
Topic: concurrent hotspot users on RB433AH ?
Replies: 1
Views: 691

Re: concurrent hotspot users on RB433AH ?

Rb433ah has a level 5 licence so usermanager is limited to 50 user simultainusly. If you use hotspot database is limited to 500


Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Mon Jan 13, 2014 3:44 pm
Forum: General
Topic: RouterOS upgrade fail - no connection
Replies: 6
Views: 1146

Re: RouterOS upgrade fail - no connection

Please help, anyone...

Also "The device is dead" would be possible answer, but I need to be sure before buying a new one.
It is not nessesary. Reinstall routerOS with netinstall I think is a kernel error and can not start.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Mon Jan 13, 2014 3:41 pm
Forum: General
Topic: re: How to monitor the Upload/download rate of clients?
Replies: 7
Views: 8053

Re: re: How to monitor the Upload/download rate of clients?

What i need is real time monitor of clients, which shows realtime uplaod/download rate of clients per IP address. I found a great tool to do it here: http://forum.mikrotik.com/viewtopic.php?f=2&t=77193 (big thanks to the tool maker, its really great!!) Still i wanted to know if there is an option, ...
by c0d3rSh3ll
Mon Jan 13, 2014 3:37 pm
Forum: General
Topic: Web site allow issue
Replies: 2
Views: 511

Re: Web site allow issue

You can create 2 filter rules: /ip firewall filter chain=forward protocol=tcp dst-port=80 scr-address-list=privateip dst-address-list=jobsite action=accept And the other for block /ip firewall filter chain=forward protocol=tcp dst-port=80 scr-address-list=privateip action=drop Add the private ip of ...
by c0d3rSh3ll
Mon Jan 13, 2014 3:16 pm
Forum: Beginner Basics
Topic: Looking for a consultant.
Replies: 5
Views: 1626

Re: Looking for a consultant.

Hello Mikrotikkers. I am looking for a person willing to take a look at a RB450G configuration and help out with fixing a few things. I have been volunteering in India and Nepal several times, and during my last 6 month stay in Kathmandu, i took on the volunteer job as remote IT guy for a group of ...
by c0d3rSh3ll
Mon Jan 13, 2014 3:28 am
Forum: General
Topic: Load balancing multiple same subnet links with daily limits
Replies: 4
Views: 1063

Re: Load balancing multiple same subnet links with daily lim

For each link you can do static routes with 1.1.1.1%wan1 like this 192.168.0.1%wan1 routing-mark=towan1 192.168.0.1%wan2 routing-mark=towan2 192.168.0.1%wan3 routing-mark=towan3 With a script you can read the traffic of each wan and disable the route for this wan. Send from my mobile phone using Tap...
by c0d3rSh3ll
Sun Jan 12, 2014 7:13 pm
Forum: Beginner Basics
Topic: freeradius & access user to change own password
Replies: 2
Views: 1515

Re: freeradius & access user to change own password

Daloradius has a user portal for this purpose.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Sun Jan 12, 2014 5:50 pm
Forum: Scripting
Topic: Special Website Open Speed
Replies: 1
Views: 908

Re: Special Website Open Speed

What is the routerOS version?

For this you can do with firewall mangle and packet mark option. Then you csn limit this packet in simple queue o queue tree.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Sun Jan 12, 2014 5:47 pm
Forum: Beginner Basics
Topic: how to route specific traffic directly to the WAN bypass VPN
Replies: 3
Views: 1068

Re: how to route specific traffic directly to the WAN bypass

Thank you it worked, is there a way I can do it by hostname instead of by IP Address? thank you for your help by the way!.

Ivan.
Is not possible but with script you can use hostname

http://wiki.mikrotik.com/wiki/Use_host_ ... wall_rules

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Sun Jan 12, 2014 5:42 pm
Forum: Scripting
Topic: how i block web site
Replies: 2
Views: 759

Re: how i block web site

You can do with simple web proxy feature for block web sites.
First configure transparent proxy and then block with access list

For block the rest with firewall and for accept skype you can do with layer7 regex

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Sun Jan 12, 2014 5:38 am
Forum: Beginner Basics
Topic: how to route specific traffic directly to the WAN bypass VPN
Replies: 3
Views: 1068

Re: how to route specific traffic directly to the WAN bypass

First add a mangle rule in the top of your rules like this

/ip firewall mangle add chain=prerouting dst-address-list=bypassed action=accept

Then add the ip of the server in the bypassed address list in the address list tab.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Sun Jan 12, 2014 5:33 am
Forum: General
Topic: How can I block ping in my local network
Replies: 9
Views: 3228

Re: How can I block ping in my local network

Try this

/ip firewall filter add chain=input scr-address=yourNetwork protocol=icmp action=drop

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Thu Jan 02, 2014 7:19 am
Forum: The User Manager
Topic: Features needed
Replies: 1
Views: 790

Re: Features needed

For the item 1 is possible with dns option in hotspot profile like this http://www.hotspot.com/logout instead ip-router/logout

For the 2 maybe with a script.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Wed Jan 01, 2014 11:23 pm
Forum: Beginner Basics
Topic: RB2011UAS-2HnD Configuration Project - Consulting $$
Replies: 3
Views: 1078

Re: RB2011UAS-2HnD Configuration Project - Consulting $$

You can contact me in my signature.

Regards

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Mon Dec 30, 2013 10:23 am
Forum: General
Topic: Best load balancing method for 4 WAN links
Replies: 19
Views: 11351

Re: Best load balancing method for 4 WAN links

The best method is pcc. In the mangle pcc section use "both addres and port" or "dst address"

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Sun Dec 29, 2013 10:11 pm
Forum: Beginner Basics
Topic: Down connection and backup problem
Replies: 1
Views: 485

Re: Down connection and backup problem

You need reinstall routerOS with netinstall. This is a problem reading internal file.



Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Sun Dec 29, 2013 9:12 pm
Forum: Scripting
Topic: Help needed - Routing to connected networks doesn't work!
Replies: 6
Views: 1368

Re: Help needed - Routing to connected networks doesn't work

Add a mangle rule for all your internal network with accept action like this

add chain=prerouting dst-addres=yourNetwork action=accept

Put it in the top of your rules.


Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Sat Dec 28, 2013 10:58 pm
Forum: General
Topic: MikroTik blocks iTunes device's restore
Replies: 6
Views: 2130

Re: MikroTik blocks iTunes device's restore

Post the output of this command:
ip firewall export

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Sat Dec 28, 2013 10:54 pm
Forum: General
Topic: How direct all traffic through a PPTP interface
Replies: 2
Views: 819

Re: How direct all traffic through a PPTP interface

First add a new mark-routing rule in the mangle firewall for the trafficc from your lan network.
Add a default gateway for this mark in ip routes tab with gateway=pptp-interface.

Remember add a masquerade rule with out-interface=pptp-interface

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Sat Dec 28, 2013 10:28 pm
Forum: General
Topic: support ppp users
Replies: 2
Views: 724

Re: support ppp users

You can read this table about licenses level

http://wiki.mikrotik.com/wiki/Manual:License

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Sat Dec 28, 2013 7:53 pm
Forum: RouterBOARD hardware
Topic: Routerboard Recommendation ?
Replies: 5
Views: 1108

Re: Routerboard Recommendation ?

A rb1100 serie is better. It have a level 6 for usermanager unlimited feature.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Sat Dec 28, 2013 7:43 pm
Forum: General
Topic: How to route LAN devices via an established VPN connection ?
Replies: 4
Views: 2803

Re: How to route LAN devices via an established VPN connecti

with policy routing you can do this. first add a mangle rule like this change your interface lan /ip fi man add action=mark-routing chain=prerouting disabled=no in-interface=lan new-routing-mark=traf passthrough=yes and then add the gateway for this. change your pptp interface /ip route add disable...
by c0d3rSh3ll
Sat Dec 28, 2013 6:25 pm
Forum: The User Manager
Topic: Help Radius server not responding....
Replies: 10
Views: 11802

Re: Help Radius server not responding....

Execute this code in your routerboard

radius print.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Sat Dec 28, 2013 1:56 am
Forum: General
Topic: Incompatibility with ps4?
Replies: 24
Views: 15472

Re: Incompatibility with ps4?

Enable upnp and try.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Fri Dec 27, 2013 5:30 pm
Forum: General
Topic: user with read permissions can shut down the router
Replies: 7
Views: 2121

Re: user with read permissions can shut down the router

reboot apply to shutdown too.
by c0d3rSh3ll
Fri Dec 27, 2013 5:49 am
Forum: General
Topic: Load balancing not working for bypass users
Replies: 5
Views: 1448

Re: Load balancing not working for bypass users

bypassed user not use hotspot=auth
by c0d3rSh3ll
Fri Dec 27, 2013 5:11 am
Forum: Scripting
Topic: sending mail when ever a new file ariive in ftp
Replies: 2
Views: 867

Re: sending mail when ever a new file ariive in ftp

I am thinking in a script for check how many files you have in the server, and if a new file is arrived execute the email script. { global files local file [len [file find ]] if ($files!=file) do={ global files $file log error "new file uploaded" system script run "emailscript" }} you can improve it..
by c0d3rSh3ll
Fri Dec 27, 2013 4:57 am
Forum: General
Topic: Block Facebook & Youtube on Certain Ips - and it works
Replies: 5
Views: 8929

Re: Block Facebook & Youtube on Certain Ips - and it works

thank for the regexp, it work ¡¡
by c0d3rSh3ll
Fri Dec 27, 2013 4:49 am
Forum: General
Topic: user with read permissions can shut down the router
Replies: 7
Views: 2121

Re: user with read permissions can shut down the router

in the group permissions set reboot=no

other way if you need webfig access for this user you can setup a webfig skin
by c0d3rSh3ll
Fri Dec 27, 2013 4:39 am
Forum: Beginner Basics
Topic: nat with two proxy?
Replies: 2
Views: 995

Re: nat with two proxy?

you can redirect http traffic transparently to the mikrotik proxy and setup the parent and parent port in webproxy setting, so you need 1 dst rule. /ip firewall nat add in-interface=ether1 dst-port=80 protocol=tcp action=redirect to-ports=8080 chain=dstnat /ip proxy set enabled=yes port=8080 and the...
by c0d3rSh3ll
Fri Dec 27, 2013 12:30 am
Forum: General
Topic: 2 ISP lines -> 2 networks -> 1 RB750
Replies: 2
Views: 1687

Re: 2 ISP lines -> 2 networks -> 1 RB750

Check this wiki page.

http://wiki.mikrotik.com/wiki/Load_Bala ... e_Gateways


Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Thu Dec 26, 2013 6:02 pm
Forum: General
Topic: Block HTTPS Traffic - URGENT
Replies: 3
Views: 1948

Re: Block HTTPS Traffic - URGENT

You can not block https traffic because many website work throught this port like facebook, google, mail, bank websites.

You can do a white list for your know websites and block everything else.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Wed Dec 25, 2013 8:47 pm
Forum: Beginner Basics
Topic: Mikrotik Queue on a Bridge.
Replies: 2
Views: 1377

Re: Mikrotik Queue on a Bridge.

First add a bridge interface and put 2 interfaces (cisco router and switch) in bridge. Then set use ip firewall yes in bridge menu.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Wed Dec 25, 2013 1:10 am
Forum: General
Topic: Why the ROS backup file so big?
Replies: 4
Views: 1033

Re: Why the ROS backup file so big?

Contact to mikrotik support, maybe is a bug because backup is not a big file.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Tue Dec 24, 2013 8:08 pm
Forum: General
Topic: Happy X-mas
Replies: 4
Views: 839

Re: Happy X-mas

Nice...
What is that? A lab setup?

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Mon Dec 23, 2013 6:20 pm
Forum: General
Topic: how to create web proxy on routeros 6.7
Replies: 6
Views: 2124

Re: how to create web proxy on routeros 6.7

RouterOS is not good idea for cache feature, try other alternative like squid or payment solution like thundercache, cachevideo etc

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Mon Dec 23, 2013 4:32 pm
Forum: General
Topic: Disable communication between subnets but allow net access
Replies: 4
Views: 2725

Re: Disable communication between subnets but allow net acce

Your nat rule (masquerade) set as follow:
Ip firewall nat add chain=scr-nat out-interface=wan action=masquerade

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Mon Dec 23, 2013 4:27 pm
Forum: The User Manager
Topic: Help Radius server not responding....
Replies: 10
Views: 11802

Re: Help Radius server not responding....

Add a logging radius item in the mikrotik for see what happend. Maybe you not have the mikrotik router as a nas in the freeradius.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Sat Dec 21, 2013 8:21 pm
Forum: General
Topic: need good algoritm
Replies: 4
Views: 817

Re: need good algoritm

With pcc load balance you can asding 30% and 70% to the other connection.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Sat Dec 21, 2013 3:19 pm
Forum: General
Topic: Load balancing not working for bypass users
Replies: 5
Views: 1448

Re: Load balancing not working for bypass users

What you have in mangle load balancr rule?

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Sat Dec 21, 2013 3:17 pm
Forum: Beginner Basics
Topic: Load Balancing on Static IPs
Replies: 11
Views: 2725

Re: Load Balancing on Static IPs

Try with pcc "both address and port".



Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Fri Dec 20, 2013 11:30 pm
Forum: General
Topic: limit bandwidth on the RB750 WAN
Replies: 5
Views: 1535

Re: limit bandwidth on the RB750 WAN

Add a simple queue with download/upload rate and select interface=wan.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Fri Dec 20, 2013 11:24 pm
Forum: Beginner Basics
Topic: Script to change disconnect Eth interface to connected one
Replies: 6
Views: 1131

Re: Script to change disconnect Eth interface to connected o

Add 2 default routes, the first with distance 1 and other with distance 2.

When the route with distance 1 is not reachable the router use the second route with distance 2.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Fri Dec 20, 2013 11:13 pm
Forum: General
Topic: Userman userman cannot be remove?
Replies: 1
Views: 419

Re: Userman userman cannot be remove?

What is your command line you are trying?

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Fri Dec 20, 2013 11:08 pm
Forum: General
Topic: Mikrotik Firewall issue
Replies: 2
Views: 480

Re: Mikrotik Firewall issue

From your lan or wan? You can add a filter rule like this for block this connection ip firewall filter add chain=forward scr-address=1.1.1.1 action=drop Also you can add other rule for input chain (to the router) from this ip addres Remeber change the ip address. Send from my mobile phone using Tapa...
by c0d3rSh3ll
Fri Dec 20, 2013 11:07 pm
Forum: General
Topic: Many connections to port 80 from LAN
Replies: 1
Views: 463

Re: Many connections to port 80 from LAN

Add a filter firewall rule like this

Ip firewall filter add chain=forward scr-address=1.1.1.1 action=drop

Or
Io firewall filter add chain=forward dst-address=1.1.1.1 action=drop

Change 1.1.1.1

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Fri Dec 20, 2013 11:02 pm
Forum: General
Topic: CCR1036-12G-4S as PPTP NAS
Replies: 3
Views: 1062

Re: CCR1036-12G-4S as PPTP NAS

Report to mikrotik support this error. They need to know it.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Fri Dec 20, 2013 10:59 pm
Forum: General
Topic: how to create web proxy on routeros 6.7
Replies: 6
Views: 2124

Re: how to create web proxy on routeros 6.7

This routerboard and other also can not save cache in the flash. For webproxy and cache you need other solution like squid in linux machine.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Fri Dec 20, 2013 6:29 am
Forum: Beginner Basics
Topic: helpful about RB1100ahx2 about 6wan
Replies: 1
Views: 661

Re: helpful about RB1100ahx2 about 6wan

post your pcc rules.
by c0d3rSh3ll
Wed Dec 18, 2013 8:44 am
Forum: General
Topic: 2 LAN 2 gateways
Replies: 6
Views: 1916

Re: 2 LAN 2 gateways

http://wiki.mikrotik.com/wiki/Load_Bala ... e_Gateways

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Fri Dec 13, 2013 5:34 pm
Forum: General
Topic: Migration from RB450G to RB2011
Replies: 1
Views: 681

Re: Migration from RB450G to RB2011

You can use "export compact" command. And edit for import in the other rb.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Tue Dec 10, 2013 8:25 pm
Forum: General
Topic: Bandwidth limit on Ethernet port
Replies: 5
Views: 17324

Re: Bandwidth limit on Ethernet port

For use queue feature in a bridge first you need setup enabled use-firewall- bridge in bridge menu.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Mon Nov 25, 2013 9:36 pm
Forum: General
Topic: Feature request: Timeout and Uptime columns in Address-Lists
Replies: 5
Views: 1674

Re: Feature request: Timeout and Uptime columns in Address-L

+1
Also add a same feature like this

ip firewall adress-list add list=list time-out=00:00:01


thank for heard me support team, in 6.7v we have this feature

ros code

ip fi address-list add 
address  comment  copy-from  disabled  timeout  lis
by c0d3rSh3ll
Mon Nov 25, 2013 3:45 pm
Forum: Wireless Networking
Topic: Simple and low cost pingable device
Replies: 3
Views: 1368

Re: Simple and low cost pingable device

A low cost router like d-link or tp-link or any-think

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Sun Nov 24, 2013 1:06 am
Forum: General
Topic: How to block some websites (e.g. facebook,google,msn, ect..)
Replies: 7
Views: 3126

Re: How to block some websites (e.g. facebook,google,msn, ec

Use openDNS. Is more better for web filter.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Sat Nov 23, 2013 11:23 pm
Forum: General
Topic: Load Balancing Wan with dynamic IP Adress
Replies: 3
Views: 1921

Re: Load Balancing Wan with dynamic IP Adress

I already have 2 Routerboards running with load balancing enabled. Now I have a new Project at a different location, but one of there Wan Providers only offers dynamic Ip Adresses. Is it possible to have routeros to loadbalance with a wan connection only offering dynamic IP? You can do with a scrip...
by c0d3rSh3ll
Sat Nov 23, 2013 11:00 pm
Forum: Forwarding Protocols
Topic: Specific routes using BGP with default route
Replies: 4
Views: 1498

Re: Specific routes using BGP with default route

Hi mrz,
Should I use content youtube or an address-list?

Thanks,
With address-list.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Sat Nov 23, 2013 10:46 pm
Forum: General
Topic: DHCP Error
Replies: 5
Views: 2104

Re: DHCP Error

I keep getting this error: nov/22/2013 01:29:20 dhcp,critical,error dhcp-client on ether1-gateway lost IP add ress 172.251.52.151 - received NAK from dhcp server 192.168.100.1 Does anyone know what this means? Could this have anything to do with Safari not loading pages and having errors? Thanks. I...
by c0d3rSh3ll
Sat Nov 23, 2013 10:43 pm
Forum: General
Topic: Overriding simple queues applied to interfaces?
Replies: 4
Views: 1098

Re: Overriding simple queues applied to interfaces?

yes you can...

mark what you need in mangle, create a simple queue for it and put it in the top
Yes or you can use dst option too.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Sat Nov 23, 2013 3:49 pm
Forum: General
Topic: ROUTERBOARD 750GL 4-WAN
Replies: 2
Views: 1505

Re: ROUTERBOARD 750GL 4-WAN

Export your mangle rules. You can see load balancing when you have more connection.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Sat Nov 23, 2013 3:39 pm
Forum: General
Topic: ECMP (Equal Cost Multi-Path) question
Replies: 2
Views: 565

Re: ECMP (Equal Cost Multi-Path) question

In the wiki you have a example.

http://wiki.mikrotik.com/wiki/Load_Bala ... e_Gateways


Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Sat Nov 23, 2013 4:30 am
Forum: General
Topic: HotSpot and VPN Question
Replies: 1
Views: 511

Re: HotSpot and VPN Question

You can add dinamic address-list for your hotspot client and add a few firewall rules for block the traffic from user to vpn.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Fri Nov 22, 2013 11:30 pm
Forum: Scripting
Topic: copy and paste: difference between ssh and winbox terminal
Replies: 2
Views: 1678

Re: copy and paste: difference between ssh and winbox termin

I not have problem with putty ssh client. I copy and paste your script.
by c0d3rSh3ll
Thu Nov 21, 2013 11:50 pm
Forum: General
Topic: Watchdog issue with mobile broadband
Replies: 2
Views: 630

Re: Watchdog issue with mobile broadband

With a script you can do, like this ( sorry I not have a routerOS)

If [ ( ping 8.8.8.8 count=3) = 0 ] do={system reboot}

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Thu Nov 21, 2013 11:41 pm
Forum: General
Topic: Address list to redirect slow payers
Replies: 2
Views: 821

Re: Address list to redirect slow payers

This error is because the connection still is saved in the connection tracking, so you need remove this connection.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Wed Nov 20, 2013 5:50 pm
Forum: General
Topic: RouterOS Amazon Web Services
Replies: 4
Views: 1100

Re: RouterOS Amazon Web Services

RouterOS on AWS for what ?

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Tue Nov 19, 2013 11:20 pm
Forum: Beginner Basics
Topic: How to bypass skype from limition ??
Replies: 6
Views: 1991

Re: How to bypass skype from limition ??

First mark skype in the mangle and add a simple queue in the top with these mark with ilimit BW or in the queue tree.

Send from my mobile phone using Tapatalk.
As far as I know, skype can't be marked.
I can mark with layer 7 regex.
Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Thu Nov 14, 2013 7:20 pm
Forum: Beginner Basics
Topic: How to bypass skype from limition ??
Replies: 6
Views: 1991

Re: How to bypass skype from limition ??

First mark skype in the mangle and add a simple queue in the top with these mark with ilimit BW or in the queue tree.

Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Thu Nov 14, 2013 7:18 pm
Forum: Beginner Basics
Topic: 3 WAN Setup. 2 to load Balance, 3 for failover
Replies: 3
Views: 4469

Re: 3 WAN Setup. 2 to load Balance, 3 for failover

Hi. You can do this in the same mikrotik harware. For the load balancing you can do by pcc and the fiber connection with distance like 3 and you have for backup this.


Send from my mobile phone using Tapatalk.
by c0d3rSh3ll
Sat Nov 09, 2013 2:18 am
Forum: General
Topic: OpenWRT for Webserver functionality on Mikrotik
Replies: 1
Views: 818

Re: OpenWRT for Webserver functionality on Mikrotik

rb7xx and 411 they have a low memory (ram) so you need a rb450G or 2011 series for metarouter.

in the virtualization section you have some post from the user @NathanA. He have a repository for openWRT.
by c0d3rSh3ll
Sat Nov 09, 2013 1:32 am
Forum: General
Topic: How to block android phone by hostame
Replies: 6
Views: 6969

Re: How to block android phone by hostame

you can create a script for get the MAC address from the leases and add it to the access list and block those mac address
by c0d3rSh3ll
Fri Nov 08, 2013 8:21 pm
Forum: Scripting
Topic: renaming backups
Replies: 3
Views: 1027

Re: renaming backups

like this?

ros code

{
local id [sys identity get name]
local date [sys clock get date ]
local time [sys clock get time]
sys backup save name="$id;$date;$time"
}
by c0d3rSh3ll
Thu Nov 07, 2013 7:56 pm
Forum: Beginner Basics
Topic: Load Balancing on Static IPs
Replies: 11
Views: 2725

Re: Load Balancing on Static IPs

Check load balancer by PCC. In the wiki you have a example with 2 isp.
by c0d3rSh3ll
Thu Nov 07, 2013 3:59 pm
Forum: Scripting
Topic: Routerboard simple que priority
Replies: 2
Views: 759

Re: Routerboard simple que priority

Hi.
in 5.x version you have only one priority, in 6.x you have one for download and one for upload


for change priority to 7 for all queue simple in 5.x:

ros code

queue simple set priority=7 [find ]
by c0d3rSh3ll
Mon Nov 04, 2013 11:58 pm
Forum: Beginner Basics
Topic: One RB for Load balancing, LAN router and Hotspot
Replies: 1
Views: 548

Re: One RB for Load balancing, LAN router and Hotspot

Hi.
You can do load balance and hotspot in the same routerboard.
by c0d3rSh3ll
Thu Oct 31, 2013 6:57 am
Forum: Scripting
Topic: Script to Exclude some sites from Web proxy
Replies: 9
Views: 2622

Re: Script to Exclude some sites from Web proxy

hello.
please contact me, I can help you.

see my signature...
by c0d3rSh3ll
Thu Oct 24, 2013 7:49 pm
Forum: Beginner Basics
Topic: what are the best proxys can integrate with Mikrotik router
Replies: 4
Views: 1756

Re: what are the best proxys can integrate with Mikrotik rou

You can connect to a vpn like strongvpn
by c0d3rSh3ll
Wed Oct 23, 2013 6:51 pm
Forum: Beginner Basics
Topic: Ping outside LAN not working with Mikrotik router
Replies: 8
Views: 2296

Re: Ping outside LAN not working with Mikrotik router

Check your filter rules and if you have a default gateway for the router
by c0d3rSh3ll
Sat Oct 12, 2013 6:37 am
Forum: General
Topic: 3x dsl in PCC working, but 4th line in parallel does not
Replies: 1
Views: 425

Re: 3x dsl in PCC working, but 4th line in parallel does not

Post your mangle rules and routes
by c0d3rSh3ll
Wed Oct 09, 2013 12:18 am
Forum: Beginner Basics
Topic: Freelance Mikrotik RB1200 Programmer Needed
Replies: 2
Views: 879

Re: Freelance Mikrotik RB1200 Programmer Needed

Check my signature and send me and email

Regards
by c0d3rSh3ll
Tue Oct 01, 2013 4:48 pm
Forum: Scripting
Topic: Mikrotik Custom OS !
Replies: 6
Views: 2196

Re: Mikrotik Custom OS !

But you have a other board low cost like alix or any other thin client like neoware.
by c0d3rSh3ll
Sun Sep 29, 2013 9:31 am
Forum: RouterBOARD hardware
Topic: RB951Ui-2HnD with external antennas
Replies: 18
Views: 31047

Re: RB951Ui-2HnD with external antennas

see us photo from inside :) thanks
+1

I have a rb751U-2hnd and I want add a external antenna for more gain.
by c0d3rSh3ll
Fri Sep 27, 2013 10:00 am
Forum: General
Topic: Site to Site tunnel... how ?
Replies: 7
Views: 1542

Re: Site to Site tunnel... how ?

in the vpn server you hace a pptp-user, and in the client is pptp-out.
by c0d3rSh3ll
Fri Sep 27, 2013 6:21 am
Forum: Beginner Basics
Topic: IP Firewall Mangle, how to correctly mark.
Replies: 3
Views: 941

Re: IP Firewall Mangle, how to correctly mark.

In the routing rule set in-bridge port=ether5

First set the bridge for use ip firewall
  • 1
  • 2