Community discussions

Search found 52 matches

by aTan
Thu Apr 26, 2018 12:00 pm
Forum: Scripting
Topic: API and RoMON
Replies: 1
Views: 471

API and RoMON

Hi, is it possible to use access API through RoMON. If not, is it going to be implemented? It would be possible to configure a device completely using API with just RoMON enabled.
by aTan
Fri Jul 28, 2017 10:51 am
Forum: Announcements
Topic: The Dude, v6.39rc test builds.
Replies: 121
Views: 28277

Re: The Dude, v6.39rc test builds.

No changes in 6.40?
by aTan
Fri Jun 16, 2017 9:23 am
Forum: Announcements
Topic: v6.40rc [release candidate] is released!
Replies: 231
Views: 45399

Re: v6.40rc [release candidate] is released!

Version 6.40rc21 has been released.
*) dude - fixed server crash;
I guess it is not [Ticket#2017021722001071].
by aTan
Wed Apr 12, 2017 10:21 am
Forum: Announcements
Topic: The Dude, v6.39rc test builds.
Replies: 121
Views: 28277

Re: v6.39rc [release candidate] is released

it's not a big problem. just copy your device to Clipboard and paste to Notepad - here's the password even without calling WinBox :)
Unbelievable. :shock:
by aTan
Thu Mar 09, 2017 10:08 am
Forum: Announcements
Topic: The Dude, v6.39rc test builds.
Replies: 121
Views: 28277

Re: The Dude, v6.39rc test builds.

What if you execute Dude as administrator from any account ? Maybe it will grant permissions to be updated.
It works when it is run as Administrator. But it is not correct behavior. It should prompt for elevation (UAC) before update.
by aTan
Wed Mar 01, 2017 4:40 pm
Forum: Announcements
Topic: The Dude, v6.39rc test builds.
Replies: 121
Views: 28277

Re: The Dude, v6.39rc test builds.

I still can't auto upgrade the Dude client under Windows 10. It does the same under Administrator account and under non-Administrator account. Tries to download some dlls and then nothing. Surprisingly it successfully auto upgrades under Linux and Wine. No problems at all. After downloading dlls the...
by aTan
Mon Jan 16, 2017 4:12 pm
Forum: Announcements
Topic: The Dude, v6.39rc test builds.
Replies: 121
Views: 28277

Re: The Dude, v6.39rc test builds.

well, as I can see, a device can have multiple parents
OK, I didn't know it.
by aTan
Mon Jan 16, 2017 11:57 am
Forum: Announcements
Topic: The Dude, v6.39rc test builds.
Replies: 121
Views: 28277

Re: The Dude, v6.39rc test builds.

Not every network is linear. We have a lot of locations with more than one uplink (mixed ring topology), so you cant have a parent device. I think it should be better to have an option to set a watchdog device for the hole submap. So when it is set and is down, the hole submap is marked as offline w...
by aTan
Fri Jan 13, 2017 2:42 pm
Forum: Announcements
Topic: The Dude, v6.39rc test builds.
Replies: 121
Views: 28277

Re: The Dude, v6.39rc test builds.

What about updating the Dude client without Administrator rights? Some kind of portable version maybe?
by aTan
Thu Jan 12, 2017 10:38 am
Forum: Announcements
Topic: The Dude, v6.39rc test builds.
Replies: 121
Views: 28277

Re: The Dude, v6.39rc test builds.

When I click the right mouse button, I can no longer find the Winbox device access option. In RouterOS Dude Tools I also do not see it anymore. 7th post above yours. Default Winbox tool is removed, please use tools to specify path to your Winbox.exe file: http://wiki.mikrotik.com/wiki/Manual:The_Du...
by aTan
Mon Jan 02, 2017 4:05 pm
Forum: The Dude
Topic: The Dude, v6.38rc test builds.
Replies: 189
Views: 39236

Re: The Dude, v6.38rc test builds.

Is there a changelog for the Dude 6.38 final release?
by aTan
Wed Dec 21, 2016 3:00 pm
Forum: The Dude
Topic: The Dude, v6.38rc test builds.
Replies: 189
Views: 39236

Re: The Dude, v6.38rc test builds.

Note that you can still use Winbox in the Dude, by simply adding it as a custom tool: %HOMEPATH%\Desktop\winbox.exe doesn't work (Windows 10) in Tools, works in File Explorer. Ordinary users can place files only inside of their windows profile and each profile has its own path based on username. Sh...
by aTan
Wed Dec 21, 2016 2:26 pm
Forum: The Dude
Topic: The Dude, v6.38rc test builds.
Replies: 189
Views: 39236

Re: The Dude, v6.38rc test builds.

Is the Dude client autoupdate functional? I've tried it with several 6.38rc and it downloads something and then just shutdowns.
by aTan
Tue Dec 20, 2016 4:52 pm
Forum: The Dude
Topic: The Dude, v6.38rc test builds.
Replies: 189
Views: 39236

Re: The Dude, v6.38rc test builds.

Version 6.38rc51 has been released. deathmagicmedia - Please give us more details what would be the best HTTP Notification method Calling https url with custom uri part with replaceable variables would be enough for me. And it should be usable in functions. e.g. https://example.com/?api_key=my_api_...
by aTan
Tue Dec 20, 2016 3:05 pm
Forum: The Dude
Topic: The Dude, v6.38rc test builds.
Replies: 189
Views: 39236

Re: The Dude, v6.38rc test builds.

Version 6.38rc51 has been released. deathmagicmedia - Please give us more details what would be the best HTTP Notification method Calling https url with custom uri part with replaceable variables would be enough for me. And it should be usable in functions. e.g. https://example.com/?api_key=my_api_...
by aTan
Wed Dec 14, 2016 3:52 pm
Forum: The Dude
Topic: The Dude, v6.38rc test builds.
Replies: 189
Views: 39236

Re: The Dude, v6.38rc test builds.

I managed to "fix" SSL high cpu problem (Ticket#2016111422000785) by increasing Connection timeout from 10s to 1m in Settings-RouterOS. On CCR it took a couple of minutes to get rid of SSL load after reboot, but it took much more time on x86 (4 cores). The problem was caused by hundreds parallel tim...
by aTan
Wed Dec 07, 2016 10:25 am
Forum: The Dude
Topic: The Dude, v6.38rc test builds.
Replies: 189
Views: 39236

Re: The Dude, v6.38rc test builds.

I've already reported high cpu load by SSL problem (the Dude is unusable) on both CCR and x86 to Mikrotik support three weeks ago. But I can't give a remote access for now. So if anyone has the same issue, please provide a remote access, so it can be investigated and solved.
by aTan
Wed Nov 16, 2016 11:37 am
Forum: The Dude
Topic: The Dude, v6.38rc test builds.
Replies: 189
Views: 39236

Re: The Dude, v6.38rc test builds.

Is there a changelog for 6.38rc31? Or nothing have been changed?
by aTan
Mon Nov 14, 2016 6:43 pm
Forum: General
Topic: MT Full changelog
Replies: 3
Views: 887

Re: MT Full changelog

change in link versions
But it is not the full changelog. I'd also love to have all changelogs in one file. Now it is not possible to search for some changes. E.g. when were romon and dude user policies added?
by aTan
Thu Oct 06, 2016 2:30 pm
Forum: Announcements
Topic: v6.37.1 [current] is released!
Replies: 144
Views: 37842

Re: v6.37.1 [current] is released!

What does 'passive' in 'dfs,passive' mean?
by aTan
Fri Sep 23, 2016 3:00 pm
Forum: The Dude
Topic: The Dude, v6.37rc test builds.
Replies: 92
Views: 17631

Re: The Dude, v6.37rc test builds.

What about any polling multi-thread support? So all CPUs on CCR are used at least for polling? Now it goes 100% on one CPU all the way.
by aTan
Wed Sep 07, 2016 10:02 am
Forum: The Dude
Topic: The Dude, v6.37rc test builds.
Replies: 92
Views: 17631

Re: The Dude, v6.37rc test builds.

There is a bug in 4b3 when you delete somehow a combination of device and link. I don't know how to reproduce it exactly. But the result is a deleted link in upper left corner of each map. It appears there after several seconds after switching to a map. It can't be moved, but you can double click it...
by aTan
Wed Aug 31, 2016 5:12 pm
Forum: The Dude
Topic: The Dude, v6.37rc test builds.
Replies: 92
Views: 17631

Re: The Dude, v6.37rc test builds.

Would it be possible to enable/disable a submap state propagation to all (or defined number) upper levels? In The Dude 4b3 with this configuration Map -> Submap1 -> Submap2, if Submap2 has outages it is red in Submap1, but Submap1 is not red in Map. If there are a lot of devices in one area (Submap1...
by aTan
Fri Jul 29, 2016 3:28 pm
Forum: The Dude
Topic: The Dude, v6.37rc test builds.
Replies: 92
Views: 17631

Re: The Dude, v6.37rc test builds.

Hi, automatic client downgrade doesn't work? I've set the old port, but it is connecting without a result or an error. rc10.
by aTan
Wed Feb 03, 2016 3:31 pm
Forum: The Dude
Topic: The Dude, work continues: v6.35rc test builds.
Replies: 103
Views: 34779

Re: The Dude, work continues: v6.35rc test builds.

I've installed the Dude 6.34 on CCR1016 and have imported a db archive (the dude's db file path is on a usb pen drive) with several hundreds devices and several tens of maps. There are some small issues, but the biggest one is the slowness. Each map opens very slowly, some devices doesn't have data ...
by aTan
Wed Jan 13, 2016 11:07 am
Forum: Scripting
Topic: How to get data from print with a parameter, eg. 'print rate'
Replies: 2
Views: 1120

Re: How to get data from print with a parameter, eg. 'print rate'

:put [/queue tree get ("qos_" . $ifame) rate]
ends with no such item.

But this code works perfectly! I didn't know about getting data from print in script in a such way.
:put (([:pick [/queue tree print from=("qos_" . $ifame) rate as-value] 0])->"rate")
Thank you!
by aTan
Mon Jan 11, 2016 7:12 pm
Forum: Scripting
Topic: How to get data from print with a parameter, eg. 'print rate'
Replies: 2
Views: 1120

How to get data from print with a parameter, eg. 'print rate'

Hi, to get max limit of a queue I use this: :foreach iname in=[/interface find where running] do={ :local ifname [/interface get $iname name] :put [/queue tree get ("qos_" . $ifame) max-limit] } How can I gate current rate? In Terminal I would use 'print rate' to get a table. But how to get the rate...
by aTan
Wed Dec 09, 2015 4:33 pm
Forum: The Dude
Topic: The Dude is back! v6.34rc test build released
Replies: 269
Views: 73869

Re: The Dude is back! v6.34rc test build released

...
Thanks.
What about CCR performance with the Dude? Is it multi threaded? Will it work well with a network of hundreds or thousands devices?

UPD: Another good feature would be vacuuming of the sqlite3 database.
by aTan
Wed Dec 09, 2015 4:00 pm
Forum: The Dude
Topic: The Dude is back! v6.34rc test build released
Replies: 269
Views: 73869

Re: The Dude is back! v6.34rc test build released

Is 2GB database size limit fixed?
It can be used on CCR, that is nice, but what about disk space? CCR has only 1GB (at least 1036 has) and flash is not good for heavy writes. Is it possible to store the Dude data to an external storage?
by aTan
Wed Sep 23, 2015 1:42 pm
Forum: Scripting
Topic: "find" with two parameters
Replies: 1
Views: 452

Re: "find" with two parameters

And the answer is:

[/system logging find where topics~"info" and action="memory"]
by aTan
Wed Sep 23, 2015 1:33 pm
Forum: Scripting
Topic: "find" with two parameters
Replies: 1
Views: 452

"find" with two parameters

Hi. Is it somehow possible to us find with two parameters?

eg: [/system logging find topics=info action=memory]
which doesn't work.
by aTan
Fri Sep 18, 2015 1:08 pm
Forum: Virtualization
Topic: Cloud Hosted Router
Replies: 583
Views: 186941

Re: Cloud Hosted Router

Any plans to add fake/dummy wlan interface? I'd like to use chr for script testing and I need to read/write wlan properties.
by aTan
Thu May 28, 2015 10:46 am
Forum: Scripting
Topic: API get wireles hw info
Replies: 6
Views: 1447

Re: API get wireles hw info

I see, thanks. For now I do it through /interface wireless info, but the problem is that since some ROS version it has hw-info function and before this it had just print function. I don't even know which version changed it. 6.10 has print but 6.28 has hw-info. So some between them.
by aTan
Wed May 27, 2015 10:51 am
Forum: Scripting
Topic: API get wireles hw info
Replies: 6
Views: 1447

Re: API get wireles hw info

From what I'm seeing on the CLI (I haven't actually tried issuing that command...), it appears "interface" is a normal argument, not something to be specified via "where", so you should be able to simply remove the "?". If the ID is correct, the first should work. Even if it does, I'd recommend the...
by aTan
Mon May 25, 2015 6:20 pm
Forum: Scripting
Topic: API get wireles hw info
Replies: 6
Views: 1447

API get wireles hw info

Hi, I need to get hw info of a wireless interface with PHP API Class ( http://wiki.mikrotik.com/wiki/API_PHP_class ) or it can be PEAR2_Net_RouterOS. I try: $api->comm('/interface/wireless/info/hw-info', ['?interface' => '*2']); or $api->comm('/interface/wireless/info/hw-info', ['?interface' => 'wla...
by aTan
Thu Nov 06, 2014 1:01 pm
Forum: General
Topic: v6.21.1 released
Replies: 112
Views: 27361

Re: v6.21.1 released

After update OpenVPN clients can't connect to updated server. On server log says TCP connection established and then it timeouts on a client (OpenVPN native or ROS client). supout is sent to support. Ticket#2014110666000355
by aTan
Mon Jun 16, 2014 11:42 am
Forum: Beginner Basics
Topic: How to set up openVPN ?
Replies: 5
Views: 1974

Re: How to set up openVPN ?

failure: wrong CA key usage with CRL
You need to set crl sign key usage.
by aTan
Tue Apr 22, 2014 4:06 pm
Forum: Wireless Networking
Topic: NV2 locked to 6,5Mbit --> Known issue
Replies: 72
Views: 17870

Re: NV2 locked to 6,5Mbit --> Known issue

I have a similar problem. After upgrading to 6.12 from 6.9 there was bad connection between two sxts (about 300m) for several days, than Tx locked on 6mbps on an AP and Rx on a client without any real throughput. Restart and downgrade to 6.9 didn't help. It was set to 5Ghz-A/N, 40Mhz, NV2. I've trie...
by aTan
Fri Mar 07, 2014 2:28 pm
Forum: General
Topic: v6.10 released
Replies: 248
Views: 82066

Re: v6.10 released

You can temporary get rid of this TLS error by setting reneg-sec 0 on ovpn server.
Problem will be fixed in next release.
I can't find it in:
 /interface ovpn-server> server print
by aTan
Fri Feb 28, 2014 4:53 pm
Forum: General
Topic: v6.10 released
Replies: 248
Views: 82066

Re: v6.10 released

(Some?) Windows clients cannot connect to OpenVPN: Fri Feb 28 15:09:40 2014 TCP connection established with x.x.x.x:1194 Fri Feb 28 15:09:40 2014 TCPv4_CLIENT link local: [undef] Fri Feb 28 15:09:40 2014 TCPv4_CLIENT link remote: x.x.x.x:1194 Fri Feb 28 15:10:40 2014 TLS Error: TLS key negotiation f...
by aTan
Fri Feb 28, 2014 10:15 am
Forum: General
Topic: v6.10 released
Replies: 248
Views: 82066

Re: v6.10 released

OpenVPN disconnects every hour. OpenVPN doesn't release ip addresses from pool, there are many old connections in PPP Active connections. At least VPN part is since 6.8 very broken.
by aTan
Sun May 26, 2013 5:00 pm
Forum: General
Topic: v6.0 released
Replies: 321
Views: 67812

Re: v6.0 released

I just upgraded from 6.0rc14 to 6.0 final and found that IPv6 conntrack is not working. None of the rules appear to create state (in the Connections tab in Winbox) and reply packets all hit my default drop rules at the end of each chain, instead of the "accept established/related" rules. This is on...
by aTan
Sun May 26, 2013 4:53 pm
Forum: General
Topic: IPv6 statefull firewall
Replies: 12
Views: 2092

Re: IPv6 statefull firewall

So I'm not alone. It must be some ugly bug.
http://forum.mikrotik.com/viewtopic.php ... 62#p369705
by aTan
Fri May 24, 2013 10:19 pm
Forum: General
Topic: IPv6 statefull firewall
Replies: 12
Views: 2092

Re: IPv6 statefull firewall

I would see established and related states from new connections coming from LAN, because only new connection from internet are blocked. I've been using CCR with 6RCs for several months, but only now I've tried to enable IPv6.
by aTan
Fri May 24, 2013 9:16 pm
Forum: General
Topic: IPv6 statefull firewall
Replies: 12
Views: 2092

Re: IPv6 statefull firewall

Inet is an internet bridge interface, Intra is a LAN bridge interface. I blocked NEW because I don't want any new connection to access LAN from internet. In the end it doesn't even matter if I block only NEW or all states. The problem is that firewall doesn't hit connections with the state establish...
by aTan
Fri May 24, 2013 4:47 pm
Forum: General
Topic: IPv6 statefull firewall
Replies: 12
Views: 2092

Re: IPv6 statefull firewall

Yes, there is traffic. Without the drop rule I can access any ipv6 enabled webpage on my pc. But with it enabled everything timeouts and the drop rule counter is increasing. And it is the last rule in a list. It behaves like it can't hit connections by state. Because everything is dropped even with ...
by aTan
Fri May 24, 2013 12:59 pm
Forum: General
Topic: IPv6 statefull firewall
Replies: 12
Views: 2092

Re: IPv6 statefull firewall

Icmp is vital for ipv6 fragmentation and neighbor discovery capabilities. Udp rule can be ignored. What do you mean by they are not applicable in ipv4?
by aTan
Fri May 24, 2013 11:38 am
Forum: General
Topic: IPv6 statefull firewall
Replies: 12
Views: 2092

Re: IPv6 statefull firewall

Drop rule is for internet->intranet only, so reverse traffic must be accepted by default. There is nothing special, just basic firewall rules. I have the same for IPv4.
by aTan
Fri May 24, 2013 10:59 am
Forum: General
Topic: IPv6 statefull firewall
Replies: 12
Views: 2092

IPv6 statefull firewall

Hi, I have a native IPv6 connection which works fine. But problems start when I create firewall rules to secure inner network. It looks like IPv6 firewall is not stateful. First two rules don't capture any packets and the last one drops everything. Am I doing wrong something? CCR, ROS v6.0. /ipv6 fi...
by aTan
Wed Apr 17, 2013 1:48 pm
Forum: RouterBOARD hardware
Topic: CLOUD CORE ROUTER
Replies: 1374
Views: 1014144

Re: CLOUD CORE ROUTER

Does Master port feature works? I have RC13 and for me it doesn't. I can set Master port, but it doesn't work, and after restart setting vanishes.
by aTan
Tue Oct 09, 2012 11:37 am
Forum: General
Topic: Slow single TCP upload connection
Replies: 0
Views: 693

Slow single TCP upload connection

Hello, I have 40/40mbps internet connection and I use 450G as gateway router. ether1 is WAN with NAT for LAN subnets, ether2 is LAN (has public ip subnet). The problem is that when I download outside (upload form inside) from a web server with public ip (no NAT) in LAN, the speed is only a quarter (...
by aTan
Tue Nov 01, 2011 12:01 pm
Forum: General
Topic: Openvpn unusual error
Replies: 1
Views: 1310

Re: Openvpn unusual error

Same here with 5.7. I have RB450G with OVPN enabled on port 443 and about 15 clients. Most of them can connect, but at least 3 cannot connect with TLS timeout. We have even tried Windows re-installation (all clients are Windows), but it doesn't help. Errors are the same as ramin110.