Community discussions

Search found 586 matches

  • 1
  • 2
by skot
Fri Sep 01, 2017 9:52 pm
Forum: General
Topic: Login failture via FTP
Replies: 9
Views: 2209

Re: Login failture via FTP

I recently had the same issue, and I believe it is Avast's Wi-Fi Inspector , which checks for threats on the network including default router passwords. The only way for Avast to test for this is to make brute force login attempts to the router. According to this article : Wi-Fi Inspector exposes th...
by skot
Fri Jun 19, 2015 7:49 am
Forum: General
Topic: Methods to possibly blocking all IP traffic based on Location?
Replies: 13
Views: 1667

Re: Methods to possibly blocking all IP traffic based on Location?

If you don't want to add them one by one, you should take the IP files from that website and automate using PHP, bash, or something else to output a properly formatted .rsc script that can be imported into the router and automatically add the address list entries. You'd also have to add firewall rul...
by skot
Sat Jun 13, 2015 2:41 am
Forum: Scripting
Topic: how can i delete such a specific line from comment and replace it
Replies: 5
Views: 1380

Re: how can i delete such a specific line from comment and replace it

You are using RouterOS v5, and the script uses an array function that only works in RouterOS v6. You'll have to upgrade to use this script.
by skot
Sat Jun 06, 2015 1:10 am
Forum: General
Topic: Stats on single filter rule only?
Replies: 3
Views: 476

Re: Stats on single filter rule only?

Add a comment to your filter rule, then edit the script below to match. Run this in the terminal to output a sample. Remove starting/ending curly braces in your final script as they are only needed for the local variables when running in the terminal. { /ip firewall filter :local cmt "my Comment" :l...
by skot
Sat Jun 06, 2015 12:51 am
Forum: Scripting
Topic: how can i delete such a specific line from comment and replace it
Replies: 5
Views: 1380

Re: how can i delete such a specific line from comment and replace it

It's possible.... but would take some ugly coding. Do you have to use \r\n to separate the values? If you used comma separated strings, then this could be done using arrays. First, all comments would need to be a string like this: rich,man,john The main script loops through all comments, extracts va...
by skot
Fri May 29, 2015 2:51 am
Forum: Scripting
Topic: Changing CPU in script after kernel failure.
Replies: 2
Views: 662

Re: Changing CPU in script after kernel failure.

I've seen this happen before, and it's like the script executes before everything is started. Adding a short delay at the beginning of the script has worked for me in the past.
:delay 5s
by skot
Wed May 27, 2015 8:52 pm
Forum: Scripting
Topic: check uptime of last host entry in hotspot and send mail
Replies: 5
Views: 934

Re: check uptime of last host entry in hotspot and send mail

You can also use the count-only argument of print, e.g. :if ([/ip hotspot host print count-only where uptime <10m] = 0) do={ /tool email ... } (and that should be slightly more efficient that "[:len [find]]" too) Oh yes, I forgot about that. Good call. I got into the habit of using :len and don't u...
by skot
Wed May 27, 2015 8:48 pm
Forum: General
Topic: Showing "comments" of Active users
Replies: 4
Views: 694

Re: Showing "comments" of Active users

I assume your setup is like this: 1. Users in [/ip hotspot user], with name = MAC 2. Comment with their name Interestingly, in the Active tab there is a "comment" column, but I don't know where this comment is coming from or how to set it. The comment from the user account does not show up here... Y...
by skot
Wed May 27, 2015 8:01 pm
Forum: Scripting
Topic: how can i delete such a specific line from comment and replace it
Replies: 5
Views: 1380

Re: how can i delete such a specific line from comment and replace it

We need more information. I assume you're trying to do this to multiple comments, but we need to see them to be able to make a script.
by skot
Wed May 27, 2015 7:53 pm
Forum: Scripting
Topic: check uptime of last host entry in hotspot and send mail
Replies: 5
Views: 934

Re: check uptime of last host entry in hotspot and send mail

You can check for the number of items using [:len] and [find]. I like to do it in steps. First, just show the returned entries: :put [/ip hotspot host find where uptime <10m] Then, test using [:len], to show the number of entries: :put [:len [/ip hotspot host find where uptime <10m]] Put it all toge...
by skot
Tue May 26, 2015 10:48 pm
Forum: General
Topic: Possible to run custom python application?
Replies: 5
Views: 3560

Re: Possible to run custom python application?

Thank you for mentioning Metarouter. It seems like an interesting solution. Does it run anything other than OpenWRT? I was trying to avoid OpenWRT, dd-WRT and the like for stability reasons. Any experience on how stable OpenWRT runs as a Metarouter image? I've only seen OpenWRT but others might be ...
by skot
Wed May 13, 2015 2:47 am
Forum: General
Topic: Is it possible to run a script on login?
Replies: 44
Views: 14829

Re: Is it possible to run a script on login?

You're welcome, glad you found it useful. :)
by skot
Wed May 13, 2015 2:33 am
Forum: Scripting
Topic: How can I log failures importing configuration
Replies: 9
Views: 1511

Re: How can I log failures importing configuration

What I would do is look through the config and try to find the setting that is kicking you out. Then, just comment the line(s) out with pound signs #, and copy/paste the whole script into the terminal. It's probably an /interface related setting...
by skot
Tue May 12, 2015 6:23 pm
Forum: General
Topic: Possible to run custom python application?
Replies: 5
Views: 3560

Re: Possible to run custom python application?

Is it possible to run a custom python application on RouterOS on boot? I want to use a tunneling (reverse proxy) service such as Pagekite ( https://pagekite.net ) allowing me to access devices connected to a RouterBoard without having to open ports on upstream firewalls. To do this it would be nice...
by skot
Tue May 12, 2015 2:59 am
Forum: RouterBOARD hardware
Topic: PoE Injector directionality
Replies: 3
Views: 655

Re: PoE Injector directionality

Do the PoE injectors supply power on both directions? I may need to do a back-to-back AP scenario and would prefer to power both APs from 1 injector/power supply.
You could use an RB750UP, which has 4 POE out ports. http://routerboard.com/RB750UP
by skot
Mon May 11, 2015 6:21 pm
Forum: Beginner Basics
Topic: Hotspot Username
Replies: 3
Views: 616

Re: Hotspot Username

This post does what you want, except it's converting to upper case. To convert to lower case, change toUpperCase() to toLowerCase()
http://forum.mikrotik.com/viewtopic.php ... 03#p384573
by skot
Sat May 09, 2015 12:34 am
Forum: General
Topic: Is it possible to run a script on login?
Replies: 44
Views: 14829

Re: Is it possible to run a script on login?

so my question is: can i/we use this script (or edit it) to do following steps: 1 check ("realize") when a user logs on to the ROUTER (not hotspot! no hotspot use is intended at all) 2 on succesful login get the IP and name of the active user (as in "/user active get 0 address") 3 add its IP addres...
by skot
Fri May 08, 2015 11:54 pm
Forum: Scripting
Topic: Help with simple script to email current user's info
Replies: 6
Views: 828

Re: Help with simple script to email current user's info

how can I convert "downbyte " to MiB???
Divide by 1048576 (which is 1024 * 1024). One thing to keep in mind is that RouterOS will round to whole numbers, so doing something like 3000000/1048576 = 2.
:local downMB ($downbyte / 1048576)
by skot
Wed May 06, 2015 1:45 am
Forum: Scripting
Topic: Get script name or prevent script from beeing executed again when it is still running
Replies: 4
Views: 855

Re: Get script name or prevent script from beeing executed again when it is still running

From within the script itself, you could set a global variable to track whether the script is running or not.
:global running
:if ($running != true) do={
  :set running true
  ... script content here
  :set running false
}
by skot
Tue May 05, 2015 7:26 pm
Forum: General
Topic: Is it possible to run a script on login?
Replies: 44
Views: 14829

Re: Is it possible to run a script on login?

1 check ("realize") when a user logs on to the ROUTER (not hotspot! no hotspot use is intended at all) So, you are using the hotspot, but you don't want any hotspot logins found by the script, only logins directly to the router, right? Generally you would compare the normal login logs with the hots...
by skot
Thu Apr 30, 2015 7:42 pm
Forum: Scripting
Topic: Replace characters in string (url encode)
Replies: 14
Views: 9825

Re: Replace characters in string (url encode)

I tried to replace a url "0/24" from "192.168.1.0/24" Unfortunately it doesnt work with your script. I have tried to do a test with urlstring, it works. Only when comes to replacing IP it doesnt work. It only replace 1 character and not more than that? Correct. That script above loops through the u...
by skot
Thu Apr 30, 2015 7:29 pm
Forum: General
Topic: Export DHCP Server Lease Table
Replies: 2
Views: 2920

Re: Export DHCP Server Lease Table

I would run a script that outputs a CSV formatted list that you can copy/paste into a text document, save as myFile.csv, and then open that in Excel. Example: /ip dhcp-server lease :foreach i in=[find] do={ :put ([get $i address].",".[get $i mac-address].",".[get $i client-id].",".[get $i server]) }...
by skot
Thu Jan 15, 2015 9:00 pm
Forum: General
Topic: improve hotspot login page
Replies: 9
Views: 2110

Re: improve hotspot login page

if i want to disable capital litters and @#$% can anyone help me :shock: Edit login.html and replace the doLogin() function with the code below. I assume you want to disallow all special characters, so this allows only lowercase and numbers. function doLogin() { if (!/^[a-z0-9]+$/.test(document.log...
by skot
Thu Jan 15, 2015 6:43 pm
Forum: Scripting
Topic: Foreach iterate through each line in a txt file
Replies: 2
Views: 2796

Re: Foreach iterate through each line in a txt file

You can do this by checking for line endings "\n" (linux)or "\r\n" (windows). Something like this: { :local content [/file get [/file find name=file.txt] contents] ; :local contentLen [:len $content]; :local lineEnd 0; :local line ""; :local lastEnd 0; :while ($lineEnd < $contentLen) do={ # dependin...
by skot
Wed Jan 14, 2015 6:31 pm
Forum: Scripting
Topic: Script required for change wan ip
Replies: 9
Views: 2579

Re: Script required for change wan ip

You need to do something like this:
/interface/wireless/set
=ssid=mikro_test
=.id=wlan1
by skot
Wed Jan 14, 2015 6:23 pm
Forum: Scripting
Topic: PHP API - documentation suggestion
Replies: 2
Views: 658

Re: PHP API - documentation suggestion

The updates you made look good. Thanks :D
by skot
Wed Jan 14, 2015 9:10 am
Forum: Scripting
Topic: PHP API - documentation suggestion
Replies: 2
Views: 658

PHP API - documentation suggestion

boen_robot, I recently enjoyed using your PHP client for a project. Initially the documentation seemed a bit confusing, so I have a couple suggestions. I went for the quickest setup method, which was using the .phar file, but the wiki left me scratching my head as including the phar file did not mak...
by skot
Sat Jan 10, 2015 12:51 am
Forum: Scripting
Topic: Script needed to send log data by HTTP POST (or GET)
Replies: 3
Views: 2705

Re: Script needed to send log data by HTTP POST (or GET)

You could adapt my gpt-to-url script to do this. It's on GitHub:- https://github.com/timmay2/mikrotik-gps/ In addition to the URL code from Tim's script, you will also need a script that monitors the logs and keeps track of new and old entries. The following script was created for that purpose, exc...
by skot
Thu Jan 08, 2015 2:31 am
Forum: Scripting
Topic: Script for get new ip internet
Replies: 2
Views: 596

Re: Script for get new ip internet

Add a comment to your /ip dhcp-client entry. Then change the comment in the code below to match. Decide how you want to send the file (email, ftp), and finish the code at the bottom. Finally, create a schedule that runs the script every 6 hours. A new file will be send if the address has changed. { ...
by skot
Thu Jan 08, 2015 1:41 am
Forum: Scripting
Topic: Script required for change wan ip
Replies: 9
Views: 2579

Re: Script required for change wan ip

In the script, replace /ip add disable [find comment="ether1_wan_ip_1"] /ip add enable [find comment="ether1_wan_ip_2"] and /ip add disable [find comment="ether1_wan_ip_2"] /ip add enable [find comment="ether1_wan_ip_1"] with this (in both spots) /ip address :if ([get [find comment="ether1_wan_ip_1"...
by skot
Thu Jan 08, 2015 12:29 am
Forum: Scripting
Topic: Automatic bandwidth test
Replies: 5
Views: 2514

Re: Automatic bandwidth test

Here is a script that does what you want. It may be a bit overkill, but should point you in the right direction. I think it was used in 5.x. Edit the details at the top, and the "/tool email" line at the bottom. Use the scheduler to run it at the desired interval. :local desc "Bandwidth test" :local...
by skot
Tue Dec 30, 2014 6:26 pm
Forum: Scripting
Topic: export command question
Replies: 4
Views: 1628

Re: export command question

When I attempt a straight export to file, I don't get the counters.
Use print command instead.
/queue simple print stats file=queueStats
by skot
Tue Dec 23, 2014 9:03 pm
Forum: General
Topic: improve hotspot login page
Replies: 9
Views: 2110

Re: improve hotspot login page

Edit the login.html page, find the line that says:
document.sendin.username.value = document.login.username.value;
and change to:
document.sendin.username.value = document.login.username.value.trim();
by skot
Tue Dec 23, 2014 8:43 pm
Forum: Beginner Basics
Topic: /system ntp client get status returns no state
Replies: 1
Views: 769

Re: /system ntp client get status returns no state

Using get doesn't return anything on it's own... you'll have to set it to a variable, or use :put, something like this: :put [/system ntp client get status] What I would do is enclose the whole script in curly braces { } (because you're using local variables) and paste into the terminal. See if ther...
by skot
Tue Dec 23, 2014 8:29 pm
Forum: Scripting
Topic: Global variable doesn't keep its value
Replies: 1
Views: 626

Re: Global variable doesn't keep its value

It should work as long as you declare the global variable in the script:
:global myVar
If you've already done that... show the script and maybe someone can take a look.
by skot
Tue Dec 23, 2014 8:25 pm
Forum: General
Topic: How split the variable?
Replies: 14
Views: 3899

Re: How split the variable?

Thanks for your help! It works! My script has name QTY_Signal /interface ppp-client info ppp-out1 user-command="AT^HCSQ\?" do={ :if ([:len $manufacturer] > 0 ) do={ :set HCSQ $"manufacturer" /system script job remove [find script=QTY_Signal] } } Well done, good solution. Sorry. Can you hep me yet? ...
by skot
Mon Dec 22, 2014 10:20 pm
Forum: General
Topic: How split the variable?
Replies: 14
Views: 3899

Re: How split the variable?

You could try just sending the letter, or echoing it with :put, but I doubt either of these will work... /interface ppp-client info ppp-out1 user-command="AT^HCSQ\?" do={ :if ([:len $manufacturer] > 0) do={ :put $manufacturer q } } /interface ppp-client info ppp-out1 user-command="AT^HCSQ\?" do={ :i...
by skot
Mon Dec 22, 2014 6:18 pm
Forum: Scripting
Topic: How to make MikroTik beep if there's error on logs
Replies: 5
Views: 2343

Re: How to make MikroTik beep if there's error on logs

You need to tell the schedule how often to run in the Interval field. Like 00:01:00 would be running once every minute. Also, I think you need to have the write policy enabled on the schedule.
by skot
Fri Dec 19, 2014 6:23 pm
Forum: Scripting
Topic: How to make MikroTik beep if there's error on logs
Replies: 5
Views: 2343

Re: How to make MikroTik beep if there's error on logs

how to make it even simpler, like just to beep when someone failed logging in, so it will notify our on-spot technician. You can use same approach as here: http://forum.mikrotik.com/viewtopic.php?f=2&t=60616 That script was created to do what you're looking for. Latest version is here: http://forum...
by skot
Fri Dec 19, 2014 6:05 pm
Forum: General
Topic: How split the variable?
Replies: 14
Views: 3899

Re: How split the variable?

For the one that works, does it take some time before the information shows up?
by skot
Thu Dec 18, 2014 9:26 pm
Forum: Scripting
Topic: limit export to one or two address-list?
Replies: 3
Views: 1471

Re: limit export to one or two address-list?

You can't export it directly... but you could run a script that extracts those lists and prints them to the console. Then you could copy/paste the text and save it to a text document. { /ip firewall address-list :local myList {"DHCP";"CutOff"} :local output "/ip firewall address-list\r\n" :foreach i...
by skot
Thu Dec 18, 2014 8:48 pm
Forum: General
Topic: How split the variable?
Replies: 14
Views: 3899

Re: How split the variable?

I don't think you can send Q from a script, but you can tell it to just run once. And from there you can get data. Paste this in the terminal and it should output ^HCSQ:"LTE",52,47,156,26. { :local mf /interface ppp-client info ppp-out1 user-command="AT^HCSQ\?" once do={ :set mf $manufacturer } :put...
by skot
Thu Dec 18, 2014 2:58 am
Forum: General
Topic: Is it possible to run a script on login?
Replies: 44
Views: 14829

Re: Is it possible to run a script on login?

v4 - tested on v5.26 and v6.20 Script now catches all matching logs since the last detection. Date/time checking updated to look for 3 possible formats. Added comments for easier readability Changed time stamp to now be date/time stamp NOTE : On the removeThese array, if you don't want any logs fil...
by skot
Tue Dec 16, 2014 9:42 pm
Forum: General
Topic: Is it possible to run a script on login?
Replies: 44
Views: 14829

Re: Is it possible to run a script on login?

Great script! But why only the last log message is send by e-mail? How to set that script to send all monitored messages from last change? This is a good idea. Aside from the benefit of not missing any "inbetween" logs, it also provides more flexibility. If you only want the script to check for new...
by skot
Tue Dec 16, 2014 9:18 pm
Forum: General
Topic: Is it possible to run a script on login?
Replies: 44
Views: 14829

Re: Is it possible to run a script on login?

Quick question. Script runs flawlessly on 6.2 as you stated. Any way if you have a free moment you could take a look see and try on 6.13. I can't get the script to complete outside of 6.2. I don't know why it didn't work on 6.13. Just now ran it on 6.20 without any problems. Glad rextended's edit g...
by skot
Mon Dec 15, 2014 11:16 pm
Forum: General
Topic: restriction mac address contol
Replies: 3
Views: 802

Re: restriction mac address contol

If the wireless access point is a MikroTik, then you can use the instructions in my first post. If the wireless is coming from a different device, but passes through a MikroTik router, you could set up firewall rules that allow the MAC addresses you want, followed by a final rule that drops all othe...
by skot
Mon Dec 15, 2014 10:56 pm
Forum: Beginner Basics
Topic: delete all users usermanager
Replies: 4
Views: 2843

Re: delete all users usermanager

With the API, you will need to get all items and then loop through and remove them. Something like this: http://forum.mikrotik.com/viewtopic.php?f=13&t=47274#p239737, except this is in different API client. This .net code looks like it loops through items, might be helpful: http://forum.mikrotik.com...
by skot
Mon Dec 15, 2014 10:16 pm
Forum: Scripting
Topic: Terminal Script vs Importing Script
Replies: 4
Views: 860

Re: Terminal Script vs Importing Script

Yes, you are correct. After tons of research and trial / error, I figured that out. Thanks for your reply. I wish this forum didn't take forever to post your topics....ughhh... I think there is some kind of a "new user" policy on the forums. A moderator has to approve all new posts from users who h...
by skot
Sat Dec 13, 2014 1:22 am
Forum: General
Topic: restriction mac address contol
Replies: 3
Views: 802

Re: restriction mac address contol

Open the wireless interface, disable Default Authentication and Default Forward (on the Wireless tab).

Then, open Wireless > Access List and add the MAC addresses you want to have access.
by skot
Fri Dec 12, 2014 6:41 pm
Forum: Scripting
Topic: Terminal Script vs Importing Script
Replies: 4
Views: 860

Re: Terminal Script vs Importing Script

I think you need to declare the global variables outside of the :if statement. :global systemName [/system identity get name] :global spPrimary :global spSSL :if ( $systemName ~ "^ccg_(orf|ord|jfk|lgw|dtw|c9)" ) do= { :set spPrimary 192.168.1.20 :set spSSL 192.168.1.21 } else= { :set spPrimary 192.1...
by skot
Thu Dec 11, 2014 7:46 pm
Forum: Scripting
Topic: where i paste my script to show output instantly
Replies: 1
Views: 577

Re: where i paste my script to show output instantly

To see output in Winbox terminal, the commands are slightly different than the API.
/system resource print
/system resource print oid 
by skot
Thu Dec 11, 2014 7:39 pm
Forum: Scripting
Topic: how can I check if a user exist
Replies: 1
Views: 901

Re: how can I check if a user exist

To find exact match:
/tool user-manager user print where name="JohnDoe"
To find partial match:
/tool user-manager user print where name~"John"
by skot
Thu Dec 11, 2014 7:18 pm
Forum: General
Topic: Prevent SSH login to be write in ROS system log
Replies: 1
Views: 490

Re: Prevent SSH login to be write in ROS system log

You can disable all login logs by changing /system logging info to info,!account, but this disables all such logs (telnet login, web login, etc). I don't think it's possible to only disable SSH login logs and keep the rest.
by skot
Thu Dec 11, 2014 7:08 pm
Forum: General
Topic: Access to different routers, same public IP
Replies: 3
Views: 742

Re: Access to different routers, same public IP

On the main router, use /IP > Firewall > NAT dst-nat rules to forward traffic to the private ones.

Example:
http://wiki.mikrotik.com/wiki/Forwardin ... nternal_IP

Wiki:
http://wiki.mikrotik.com/wiki/Manual:IP ... nation_NAT
by skot
Thu Dec 11, 2014 6:31 pm
Forum: Scripting
Topic: central based database for winbox login
Replies: 1
Views: 828

Re: central based database for winbox login

Yes, you can use Radius for user authentication.

Enable it for user login:
http://wiki.mikrotik.com/wiki/Manual:Ro ... Remote_AAA

Configure server info:
http://wiki.mikrotik.com/wiki/Manual:RADIUS_Client
by skot
Wed Dec 10, 2014 6:52 pm
Forum: Scripting
Topic: Mikrotik API: Query ONE(single) parameter's value of many
Replies: 8
Views: 1970

Re: Mikrotik API: Query ONE(single) parameter's value of man

The only thing I missed what "=number" means in case of "get"? There is no such parameter in list of profile properties.
It is actually referring to the item name instead a number.
by skot
Wed Dec 10, 2014 6:41 pm
Forum: General
Topic: How split the variable?
Replies: 14
Views: 3899

Re: How split the variable?

You can split the string to get rid of the prefix, and then convert the remaining string into an array. { :local var "^HCSQ:\"LTE\",56,47,101,18" :local myArray [:toarray [:pick $var ([:find $var ":"]+1) [:len $var]]] :local signal [:pick $myArray 0] :put "Signal: $signal" :local rssi [:pick $myArra...
by skot
Tue Dec 09, 2014 11:58 pm
Forum: General
Topic: Change all my custemors cpe WPA key
Replies: 8
Views: 1167

Re: Change all my custemors cpe WPA key

A simple .bat example: @echo off SETLOCAL ENABLEDELAYEDEXPANSION set user=admin set pass=password set ip[1]=192.168.88.2 set ip[2]=192.168.88.3 set ip[3]=192.168.88.4 :: mikrotik script echo /log info ("testing " . [/system clock get time])>script.auto.rsc echo :delay 1s>>script.auto.rsc echo /file ...
by skot
Tue Dec 09, 2014 7:07 pm
Forum: General
Topic: Change all my custemors cpe WPA key
Replies: 8
Views: 1167

Re: Change all my custemors cpe WPA key

hi, thanks for the reply. I want more than this. i dont want to login to every cpe and change it. i want a script like ex .bat, that will run on its own and change all cpe's passwords. i know that there are different methods to access a microtik router ssh, telnet.. can i use one of these methods t...
by skot
Tue Dec 09, 2014 6:51 pm
Forum: Scripting
Topic: [ASK] SCRIPT FOR EDITING RULES
Replies: 3
Views: 736

Re: [ASK] SCRIPT FOR EDITING RULES

Nice! I had not heard of these methods before. Good to know.
by skot
Tue Dec 09, 2014 6:37 pm
Forum: Beginner Basics
Topic: Disabling / enabling interface with scheduler?
Replies: 3
Views: 1477

Re: Disabling / enabling interface with scheduler?

I like your solution, much simpler! I think start date needs to be Jan/07/1970 to be on a Wed
by skot
Tue Dec 09, 2014 3:02 am
Forum: General
Topic: Change all my custemors cpe WPA key
Replies: 8
Views: 1167

Re: Change all my custemors cpe WPA key

Probably the simplest way would be to create a script that does all the work for you. So, then all you have to do is log in and paste the code into terminal. Something like this: /interface wireless security-profiles set default wpa-pre-shared-key=abc123 That's assuming you're using the default prof...
by skot
Tue Dec 09, 2014 2:33 am
Forum: Scripting
Topic: Can someone explain this?
Replies: 1
Views: 530

Re: Can someone explain this?

That weird. You can get rid of it by un[bracket]ing one or both of the called functions: {:local x do={:put "Hi $1"};$x "Mom";:set x [:parse ":put \"Hello \$1\""];$x "Dad"} After a bit of testing, looks like the first one you bracket is then re-echoed without the argument, after the next bracketed o...
by skot
Tue Dec 09, 2014 2:05 am
Forum: Beginner Basics
Topic: Disabling / enabling interface with scheduler?
Replies: 3
Views: 1477

Re: Disabling / enabling interface with scheduler?

Since RouterOS doesn't have a way to get the day of the week automatically, you'll have to use a script like this one: http://wiki.mikrotik.com/wiki/Script_to_find_the_day_of_the_week, example below. Go into System > Scripts, and create a new one. Name the script whatever and select all the Policies...
by skot
Tue Dec 09, 2014 12:13 am
Forum: The User Manager
Topic: delete actual profile of users in cli mode?
Replies: 3
Views: 2454

Re: delete actual profile of users in cli mode?

i wnat delete||remove||desable bolded text I don't know if this can be deleted or disabled for a user because the user account is tied to a profile that determines speed / data limits. Changing the profile is possible (change "ProfileName" to match the one you want to change to): /tool user-manager...
by skot
Mon Dec 08, 2014 10:40 pm
Forum: Beginner Basics
Topic: delete all users usermanager
Replies: 4
Views: 2843

Re: delete all users usermanager

I think one solution is delete all the users from user manager and after insert one by one. That would probably be the easiest as long as you don't need to keep any of the existing usermanager users. It's possible to send one command from .net to delete all the records? I don't know about .net, but...
by skot
Mon Dec 08, 2014 10:01 pm
Forum: Scripting
Topic: [ASK] SCRIPT FOR EDITING RULES
Replies: 3
Views: 736

Re: [ASK] SCRIPT FOR EDITING RULES

Are you trying to change ALL queues or just a range of them? If you only want to change a range, your code is fine. But, first you must use the print command to generate the number for each item. If you don't use the print command, it doesn't know what item corresponds to which number. Something lik...
by skot
Mon Dec 08, 2014 9:30 pm
Forum: Scripting
Topic: "File already exist" only with User_manager database
Replies: 1
Views: 546

Re: "File already exist" only with User_manager database

You can overwrite the backup file with: overwrite=yes
/tool user-manager database save name=$bbddfile overwrite=yes
by skot
Mon Dec 08, 2014 7:21 pm
Forum: Scripting
Topic: script help for simple failover (no bonding)
Replies: 2
Views: 630

Re: script help for simple failover (no bonding)

An easy way to do this is in IP > Routes. Add your routes, making the Distance value larger on the secondary route. Something like this example: http://wiki.mikrotik.com/wiki/Two_gateways_failover
by skot
Mon Dec 08, 2014 3:05 am
Forum: Scripting
Topic: Mikrotik API: Query ONE(single) parameter's value of many
Replies: 8
Views: 1970

Re: Mikrotik API: Query ONE(single) parameter's value of man

In RouterOS v6.0 and later, you can also use the the "get" command, similarly as you do from terminal, except that you need to explicitly use the argument names, e.g. /interface/wireless/security-profiles/get =number=default =value-name=wpa2-passphrase Nice. Is that on the wiki? I couldn't seem to ...
by skot
Sat Dec 06, 2014 1:42 am
Forum: Scripting
Topic: Mikrotik API: Query ONE(single) parameter's value of many
Replies: 8
Views: 1970

Re: Mikrotik API: Query ONE(single) parameter's value of man

I'm not very skilled with the API :), but taking a stab at this... I think you want to do something like this to get id by name: /interface/wireless/security-profiles/print =.proplist=.id ?name=default And this to get name by id: /interface/wireless/security-profiles/print =.proplist=name ?.id=*0
by skot
Sat Dec 06, 2014 12:51 am
Forum: The User Manager
Topic: delete actual profile of users in cli mode?
Replies: 3
Views: 2454

Re: delete actual profile of users in cli mode?

If you are referring to the hotspot user and profile, they can be deleted like so:

User:
/ip hotspot user remove [find name="userName"]
User profile:
/ip hotspot user profile remove [find name="profileName"]
by skot
Fri Dec 05, 2014 6:30 pm
Forum: General
Topic: 6.19 - console change?
Replies: 2
Views: 594

Re: 6.19 - console change?

Ah, ok that makes sense. Thanks.
by skot
Thu Dec 04, 2014 2:33 am
Forum: General
Topic: winbox shortcut to specific IP
Replies: 2
Views: 678

Re: winbox shortcut to specific IP

2. Shortcut to certain IP. Now we have to open winbox loader, fill or search or pick from the list an IP (or mac) and click on it to open it. If you have several PC that are monitoring several units, and the main link to all fails (power cut, ethernet cable loose, PC crash, switch/router crash etc....
by skot
Thu Dec 04, 2014 2:22 am
Forum: Beginner Basics
Topic: Schedule script not working for new pppoe clients
Replies: 2
Views: 633

Re: Schedule script not working for new pppoe clients

When setting a variable, don't use the $ in front of it. Remove these and see if it works... :set $ lunaclient [:pick [ppp secret get $i comment] 0 2]; :set $ username [ppp secret get $i name]; :set $ password [ppp secret get $i password]; On a practical note, you could simplify the code by using :f...
by skot
Wed Dec 03, 2014 6:17 pm
Forum: General
Topic: 6.19 - console change?
Replies: 2
Views: 594

6.19 - console change?

What's new in 6.19 (2014-Aug-26 14:05):

*) console - added unary operator 'any' that evaluates to true if argument
I can't seem to find any documentation or posts about this addition. What exactly is this?
by skot
Wed Dec 03, 2014 2:26 am
Forum: Scripting
Topic: Scripting problem since 6.19
Replies: 2
Views: 766

Re: Scripting problem since 6.19

It could be a bug... in which case you will want to email support: http://www.mikrotik.com/support.html In the meantime you could change the script to check for length, something like this: :foreach i in=[/queue simple find] do={ :local content [/queue simple get $i comment] :if ([:len $content] != ...
by skot
Sat Nov 29, 2014 12:10 am
Forum: Scripting
Topic: Api to connect to router, disable queue simple
Replies: 7
Views: 1534

Re: Api to connect to router, disable queue simple

You could use fetch and upload something. auto.rsc file from the first router to the second via FTP. The script is automatically executed after upload. Docs here . This example is more complicated than what you want, but at it's core is doing what I described above. http://forum.mikrotik.com/viewtop...
by skot
Thu Nov 20, 2014 7:04 pm
Forum: Scripting
Topic: reset the counters exception two users
Replies: 2
Views: 734

Re: reset the counters exception two users

Try this. Tested on v6.20
/ip hotspot user
:foreach i in=[find] do={
  :local name [get $i name]
  :if ($name != "Jone" && $name != "rayan") do={
    reset-counters $name
  }
}
by skot
Tue Nov 04, 2014 1:53 am
Forum: Scripting
Topic: How do I check if a variable is empty?
Replies: 2
Views: 2727

Re: How do I check if a variable is empty?

You could check variable length, something like:
:if ([:len $var] = 0) do={
  ... your code here
}
by skot
Sat Nov 01, 2014 12:15 am
Forum: Scripting
Topic: Replace characters in string (url encode)
Replies: 14
Views: 9825

Re: Replace characters in string (url encode)

I just need something to handle spaces in sms text...
What does the SMS text look like that you are receiving?
by skot
Tue Oct 28, 2014 11:07 pm
Forum: Scripting
Topic: Script Ping (Host To IP) to the variable.
Replies: 2
Views: 1209

Re: Script Ping (Host To IP) to the variable.

To log the IP, do this:
:log info [:resolve www.google.com]
by skot
Tue Oct 28, 2014 10:13 pm
Forum: General
Topic: limit-bytes-out
Replies: 1
Views: 586

Re: limit-bytes-out

You'll need to use a script that changes the user to a different profile:
http://forum.mikrotik.com/viewtopic.php ... 36#p453734

Or changes the profile speeds:
http://forum.mikrotik.com/viewtopic.php ... 67#p362669
by skot
Tue Oct 28, 2014 10:09 pm
Forum: Beginner Basics
Topic: 4 connections from one user
Replies: 1
Views: 536

Re: 4 connections from one user

Do you have Terminal windows open? These create telnet connections...
by skot
Tue Oct 28, 2014 10:07 pm
Forum: General
Topic: Interface monitor-traffic column width
Replies: 1
Views: 577

Re: Interface monitor-traffic column width

For something like this, you should email MikroTik support directly: support@mikrotik.com
by skot
Tue Oct 28, 2014 10:04 pm
Forum: General
Topic: address-list not saving after reboot?
Replies: 2
Views: 1547

Re: address-list not saving after reboot?

By design, static address list entries are saved over a reboot, but dynamic ones are not. If you're losing the dynamic ones, this is normal. The firewall filter rules will re-create them. If you want to save the dynamic ones, you'll need to change them to static, something like this: http://forum.mi...
by skot
Tue Oct 28, 2014 9:02 pm
Forum: Beginner Basics
Topic: basic firewall rules
Replies: 1
Views: 658

Re: basic firewall rules

ICMP is used for a number of things, ping being the most common which is useful for troubleshooting a network. You're basically sending an "are you there?" packet and receiving a "yep, I'm here, this is how long it took" response. In IPv4, ICMP is optional. If this is a home router and you have no n...
by skot
Tue Oct 28, 2014 8:19 pm
Forum: Scripting
Topic: distribute firewall rules to multiple router
Replies: 1
Views: 708

Re: distribute firewall rules to multiple router

It is possible. See these threads:

Script only on the "master" router
http://forum.mikrotik.com/viewtopic.php ... 97#p388888

Scripts are put on all routers
http://forum.mikrotik.com/viewtopic.php ... 40#p307665
by skot
Tue Oct 28, 2014 7:34 pm
Forum: Scripting
Topic: Change Profile Script???
Replies: 2
Views: 1730

Re: Change Profile Script???

One of the scripts in this thread are close to what you want to do, but they would need some changes. http://forum.mikrotik.com/viewtopic.php?f=9&t=71267 Probably the simplest would be a script like this. Paste it in Hotspot > User Profiles > Open user's current profile > Scripts tab. You could prob...
by skot
Tue Oct 28, 2014 6:56 pm
Forum: Scripting
Topic: [Req] Script for Restoring Backup File (Configuration)
Replies: 10
Views: 6147

Re: [Req] Script for Restoring Backup File (Configuration)

Instead of using the "backup" option, export the router configuration , which saves a plain text file, which then can be imported to the router. Export the configuration to a file: /export file=myFile-A1 To apply this configuration, reset the router and run the script after reboot: /system reset-con...
by skot
Tue Oct 28, 2014 6:27 pm
Forum: Scripting
Topic: notification when someone attempt to login to ap with winbox
Replies: 1
Views: 907

Re: notification when someone attempt to login to ap with wi

Yes, this is possible. You'll need to use a script and the scheduler, check this thread:
http://forum.mikrotik.com/viewtopic.php?f=2&t=60616
by skot
Thu Oct 16, 2014 2:36 am
Forum: Scripting
Topic: Example of enable/disable a rule based on time
Replies: 4
Views: 2843

Re: Example of enable/disable a rule based on time

You could create a schedule that runs a script like this every 30 minutes. It checks the time and enables / disables the firewall rule with comment "My Comment" if the times match. :local time [:pick [/system clock get time] 0 5] :if ($time = "10:30") do={ /ip firewall filter disable [find comment="...
by skot
Wed Oct 15, 2014 11:32 pm
Forum: Scripting
Topic: limit-bytes-out
Replies: 2
Views: 1537

Re: limit-bytes-out

by skot
Wed Oct 15, 2014 11:26 pm
Forum: Scripting
Topic: Password change problem
Replies: 3
Views: 944

Re: Password change problem

/user set admin password=abc123
by skot
Wed Oct 15, 2014 11:07 pm
Forum: Scripting
Topic: Example of enable/disable a rule based on time
Replies: 4
Views: 2843

Re: Example of enable/disable a rule based on time

You could use a script... or an easier way would be to use 2 duplicate firewall rules that are only activated during the said times. Something like this: /ip firewall filter add action=accept chain=forward time=11h-12h30m,sun,mon,tue,wed,thu,fri,sat add action=accept chain=forward time=13h-22h30m,su...
by skot
Sat Oct 04, 2014 11:50 pm
Forum: RouterBOARD hardware
Topic: RB1100 Fan issue
Replies: 46
Views: 17874

Re: RB1100 Fan issue

I found that the fans are much quieter holding in my hand than when they are in the case. Simply touching the fan body to the case causes vibration sounds. So, I added some self adhesive padding where the fans touched the case and each other. s1.png s2.png After putting screws back in, there was som...
by skot
Sat Oct 04, 2014 12:29 am
Forum: Wireless Networking
Topic: Exporting and Importing Configuration Files To Diff Router
Replies: 3
Views: 1634

Re: Exporting and Importing Configuration Files To Diff Rout

There's probably enough syntax / command differences between the versions that there will be errors. And with particular blocks of commands relying on previous blocks, the issue can compound. What I would do is export the config from the first router (6.19), preferably to a file: /export file=myFile...
by skot
Fri Oct 03, 2014 9:11 pm
Forum: Scripting
Topic: Notify on data rate records
Replies: 1
Views: 759

Re: Notify on data rate records

The scripting syntax and variable difference between v2.8 and 6.x is why the script is failing. The first black mark is a warning. There should be an equals sign = instead of a blank space; using a space is deprecated I assume. The red marks are errors. Copy paste this line into the terminal: /inter...
by skot
Tue Sep 30, 2014 9:54 pm
Forum: Scripting
Topic: Script to limit according to number of packets
Replies: 7
Views: 1556

Re: Script to limit according to number of packets

Thanks for the help skot, I will use your way of testing scripts in future, will certainly be better. Thanks for the advice on target-addresses as well. I like the way the re-worked script is, however there are certain queues that I don't want to be part of this. Is there a way to exclude some queu...
by skot
Fri Sep 26, 2014 2:29 am
Forum: Scripting
Topic: First script need a little guidance
Replies: 1
Views: 466

Re: First script need a little guidance

Have you tested the "/tool email" line in the terminal? Make sure you've configured correct server info in Tools > Email. Other than that, the script worked fine for me.
by skot
Fri Sep 26, 2014 2:16 am
Forum: Scripting
Topic: Script to limit according to number of packets
Replies: 7
Views: 1556

Re: Script to limit according to number of packets

To troubleshoot a script, I start by enclosing the whole script in brackets and pasting into the terminal (right-click, paste). This allows you to use local variables and also see errors in the script. These brackets can be removed when script is ready for production: { script... .... } I re-worked ...
by skot
Fri Sep 26, 2014 12:07 am
Forum: General
Topic: do I need to use a crossover cable?
Replies: 4
Views: 1339

Re: do I need to use a crossover cable?

I'm pretty sure you can use a straight through or crossover cable, either will work.
by skot
Thu Sep 25, 2014 11:49 pm
Forum: Beginner Basics
Topic: remove part of a config line?
Replies: 1
Views: 937

Re: remove part of a config line?

You can search using the IP and protocol... but be careful in case any other rules contain the same IP & protocol (they will be unset as well): /ip firewall filter unset [find dst-address="192.0.2.12" protocol="gre"] dst-address Or change it by using the item number you get after doing a print (in y...
by skot
Mon Sep 08, 2014 6:26 pm
Forum: Scripting
Topic: Find command with "Ipv6 Address List - from pool"
Replies: 2
Views: 614

Re: Find command with "Ipv6 Address List - from pool"

In v5.24 I had the same results as you, but in v6.10 everything worked as expected. So, apparently they fixed it at some point in v6...
by skot
Thu Aug 21, 2014 12:28 am
Forum: General
Topic: DHCP Client Renew Script
Replies: 3
Views: 2527

Re: DHCP Client Renew Script

You can add a schedule that will run every 6 hours and renew the IP. Change the interface name below to match yours. Then, paste this in the terminal. /system scheduler add interval=6h name=renewIP on-event="/ip dhcp-client renew [find interface=INTERFACENAME]" policy=ftp,reboot,read,write,policy,te...
by skot
Thu Aug 21, 2014 12:15 am
Forum: Scripting
Topic: Logical Operator “!” , “not” a :global variable
Replies: 4
Views: 1124

Re: Logical Operator “!” , “not” a :global variable

I think you can do something like this:
/ip firewall filter add in-interface=("!" . $hsinterface) dst-port=53 protocol=udp place-before=1 action=drop
by skot
Mon Aug 18, 2014 10:17 pm
Forum: Scripting
Topic: Uptime script
Replies: 8
Views: 4281

Re: Uptime script

You can save uptime to a variable with: :local upTime [/system resource get uptime] You can test it in the terminal with: { :local upTime [/system resource get uptime] :put $upTime } (starting and ending brackets are for testing in the terminal when using local variables and can be removed in the fi...
by skot
Sat Jun 14, 2014 2:36 am
Forum: Scripting
Topic: ping script problem
Replies: 2
Views: 1313

Re: ping script problem

Something like this will loop through the sequence of numbers you specify, ping that IP, and then run whatever code you add. You'll need to change the "from=1 to=20" to the last first/last IP octet in your range, and change the first three octets in "8.8.8.$i" to be the public IPs you want. As for t...
by skot
Tue Jun 03, 2014 9:00 pm
Forum: Beginner Basics
Topic: why doesn't NTP client accept named domains?
Replies: 10
Views: 2678

Re: why doesn't NTP client accept named domains?

I think this doesn't solve the problem in the long term. The 0.asia.pool.nts.org link refers to a pool of IP's of NTS servers. This means if the IP of a NTS server goes offline, the domain (0.asia....) will automatically link to the IP address of another NTS server. The IP of the domain is dynamic....
by skot
Wed May 21, 2014 2:30 am
Forum: Beginner Basics
Topic: How to convert internal-id to a string
Replies: 5
Views: 703

Re: How to convert internal-id to a string

I don't know if there is a way to do this with the export command.

With the print command:
/queue tree print where max-limit="1351000"
by skot
Mon May 19, 2014 10:38 pm
Forum: Beginner Basics
Topic: How to convert internal-id to a string
Replies: 5
Views: 703

Re: How to convert internal-id to a string

Like c0d3rSh3ll said, it really depends on what you want to do... but this might get you started. Use :foreach to loop through all matching entries, and then display a particular attribute, the name for example:
/queue tree
:foreach i in=[find max-limit=1351000] do={
  :put [get $i name]
}
by skot
Mon May 19, 2014 10:28 pm
Forum: Scripting
Topic: buckup to filters in bridge
Replies: 1
Views: 615

Re: buckup to filters in bridge

If you want to export your Bridge Filters config, copy / paste this into the terminal, and then copy / paste the output into a text editor: /interface bridge filter export Or you can export it to a file that can be dragged + dropped from Winbox, or copied by ftp: /interface bridge filter export file...
by skot
Mon May 19, 2014 10:22 pm
Forum: Beginner Basics
Topic: Keyword "where" doesn't work for command "print"
Replies: 2
Views: 534

Re: Keyword "where" doesn't work for command "print"

Try quoting it, see if that works:
print where action="accept"
by skot
Wed May 07, 2014 6:14 pm
Forum: Scripting
Topic: Replace characters in string (url encode)
Replies: 14
Views: 9825

Re: Replace characters in string (url encode)

You can loop through the string, checking each character and substituting as needed. Add additional :if statements for any other desired characters. The starting and ending brackets are for copying / pasting into the terminal (because of :local variables), and they can be removed in your final scrip...
by skot
Wed Apr 16, 2014 6:22 pm
Forum: Scripting
Topic: Import list of IP's to ammend Address List
Replies: 12
Views: 6901

Re: Import list of IP's to ammend Address List

I was getting the same results as you, and I think I figured out what is happening. The text file line breaks are \r\n, but the script is only checking for \n, so the variables contain line breaks, which are causing the script to fail. Try this code instead. The starting and ending brackets are nece...
by skot
Sat Apr 12, 2014 2:03 am
Forum: Scripting
Topic: Import list of IP's to ammend Address List
Replies: 12
Views: 6901

Re: Import list of IP's to ammend Address List

Unfortunately, there is a 4096 byte read/write limit when working with text files inside RouterOS: http://forum.mikrotik.com/viewtopic.php?f=9&t=40830&p=202842#p203311 Reduce your file size, and then pasting this in the terminal. It will show the file contents, unless the file size is too big and th...
by skot
Fri Apr 04, 2014 9:45 pm
Forum: Scripting
Topic: Creating text file help
Replies: 3
Views: 979

Re: Creating text file help

You're on the right track. What would work better is using [find] instead of targeting the item number. Then you are only looping through the entries that match your query. The following code loops through all firewall filter rules that contain # in the comment. The delay is there because for some r...
by skot
Thu Mar 27, 2014 7:01 pm
Forum: Scripting
Topic: Command stopped working in ROS 6.x: !routing-mark
Replies: 1
Views: 1310

Re: Command stopped working in ROS 6.x: !routing-mark

This topic was talked about here: http://forum.mikrotik.com/viewtopic.php ... 09#p395035, but the solution seems more like a workaround... "If routing mark is not nothing"?? But it works...

ros code

:put [/ip route find dst-address=0.0.0.0/0 and !routing-mark~""]
by skot
Thu Mar 27, 2014 5:36 pm
Forum: Scripting
Topic: Change SRC-NAT with simple script?
Replies: 2
Views: 1137

Re: Change SRC-NAT with simple script?

To change those rules, you can do something like this:

ros code

/ip firewall nat
set [find comment="vlan 2 (Public Area 2)"] to-addresses=*.*.*.4
set [find comment="vlan 3 (Public Area 3)"] to-addresses=*.*.*.5
by skot
Wed Mar 05, 2014 7:23 pm
Forum: Scripting
Topic: Scripting editor
Replies: 5
Views: 2605

Re: Scripting editor

As i have just purchased a RB2011U series Mikrotik router, i got a bit into the scripting language of RouterOS. I was wondering if there is a better way of writing scripts than to write every line of the code in the CLI. What do you guys use for third party programs to write these scripts and then ...
by skot
Mon Mar 03, 2014 6:27 pm
Forum: Wireless Networking
Topic: HELP!
Replies: 2
Views: 840

Re: HELP!

UPDATE: I'm pretty sure I should have gone with a RB2011UiAS-2HnD-IN ... the wiki about product naming conventions helped. So, once I return this board and order the right unit, I should be fine. Yes, the RB2011UiAS-2HnD-IN is the one you want. It comes in a case and with a power supply. There are ...
by skot
Sat Mar 01, 2014 8:57 pm
Forum: Scripting
Topic: Functions and function parameters
Replies: 38
Views: 23037

Re: Functions and function parameters

Hi dear Mikrotik Team, I create function , and can't retrieve datas [misha@test] > ip route print where 172.16.2.1 in dst-address dynamic Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit # DST-AD...
by skot
Fri Feb 28, 2014 6:48 pm
Forum: General
Topic: Winbox - issues and bugs - a list
Replies: 7
Views: 1739

Re: Winbox - issues and bugs - a list

Issue: When adding a new Access List item comment before adding the item, all associated clients reconnect. Completly normal functionality, when you add an Access-list rule, all clients get disconnected always. So when adding a comment to a non-existent item, the item is first created (and all clie...
by skot
Thu Feb 27, 2014 9:08 pm
Forum: General
Topic: Winbox - issues and bugs - a list
Replies: 7
Views: 1739

Re: Winbox - issues and bugs - a list

This seems like a winbox bug, but I can't say for sure. Issue: When adding a new Access List item comment before adding the item, all associated clients reconnect. Description: Adding a comment to a new wireless Access List item before OK-ing the new entry causes all associated wireless clients to r...
by skot
Thu Feb 27, 2014 6:55 pm
Forum: Scripting
Topic: BandWidth Test for email
Replies: 12
Views: 4788

Re: BandWidth Test for email

Make sure the "/tool bandwidth ... do={" is all on one line, and the variables with dashes are quoted. You could do something like this: /tool bandwidth-test 192.168.1.1 protocol=udp direction=both duration=12s local-tx-speed=50M remote-tx-speed=50M user=login password=senha do={ :if ($status="done ...
by skot
Tue Feb 25, 2014 2:35 am
Forum: Scripting
Topic: [SOLVED] Script to export users from PPP to Userman
Replies: 5
Views: 3189

Re: Script to export users from PPP to Userman

This should be possible. You just need to know which PPP items you want to transfer over. I would test with one user first. The following example transfers user, pass, and ip address. Edit the "ppp1" to be an existing ppp user. Then copy/paste this into the terminal: { :local testName "ppp1" /ppp se...
by skot
Mon Feb 24, 2014 7:33 pm
Forum: Scripting
Topic: File Manipulation
Replies: 2
Views: 887

Re: File Manipulation

Give this a try. It finds "wlan-students.ssid", then based on the following space and the new line "\r\n" it determines the value. Depending on how the file is saved, "\r\n" might need to be "\n". The starting and ending brackets {} are for testing in the terminal, otherwise they can be removed in y...
by skot
Fri Feb 21, 2014 6:52 pm
Forum: Scripting
Topic: [SOLVED] FIND with WILDCARD syntax HELP required
Replies: 3
Views: 2756

Re: FIND with WILDCARD syntax HELP required

print where !(name~"special") I couldn't get :if !() to work, it just gives syntax errors. Greetings, I wan to print (:log info) all hotspot users account who DO NOT have word "special" in comments. For example, Currently users have following comments: user1 = special library user2 = special xyz ga...
by skot
Thu Feb 20, 2014 7:04 pm
Forum: Scripting
Topic: Manage script errors in rsc file
Replies: 2
Views: 1651

Re: Manage script errors in rsc file

Hm... the example script seems to work for me (on v6.10), either by copy/paste or by /import. With bad url: [admin@MikroTik] > /import test.rsc resolver failed Script file loaded and executed successfully With good url: [admin@MikroTik] > /import test.rsc 93.184.216.119 Script file loaded and execut...
by skot
Thu Feb 20, 2014 6:56 pm
Forum: Beginner Basics
Topic: New user progressing with setup - question about console
Replies: 3
Views: 611

Re: New user progressing with setup - question about console

Using the console via the web interface has not been reliable for me. I prefer winbox / telnet / ssh.
by skot
Thu Feb 06, 2014 6:21 pm
Forum: Scripting
Topic: Monitor MAC address returned from arp-ping
Replies: 5
Views: 2192

Re: Monitor MAC address returned from arp-ping

If you just want the mac associated with a particular IP, you can do this (the :put statement and enclosing brackets are for testing in the terminal and can be removed for final script): { :local mac [/ip arp get [find address="192.168.88.14"] mac-address] :put $mac } If there is the possibility of ...
by skot
Tue Feb 04, 2014 2:11 am
Forum: Scripting
Topic: Reboot when no wifi network available
Replies: 8
Views: 3644

Re: Reboot when no wifi network available

Can this script be edited to detect (1) PPP active clients - if 0 reboot - email this action has taken place This is untested, but I assume the active clients show up in /ppp active, so something like this might work: /ppp active :if ([:len [find]] = 0) do={ /tool email send ... /system reboot } (1...
by skot
Tue Jan 28, 2014 7:54 am
Forum: Scripting
Topic: Reboot when no wifi network available
Replies: 8
Views: 3644

Re: Reboot when no wifi network available

So I make little change in your script. I'm change " :put" to "/log info" string. Or I still need ":put" ? /log info is a good way to do it. :put is helpful for testing in the terminal, but you don't need those statements for the final script. The script looks good. Only change is to remove the $ i...
by skot
Tue Jan 28, 2014 6:37 am
Forum: Scripting
Topic: PASSING SCHEDULE NAME TO SCRIPT
Replies: 4
Views: 927

Re: PASSING SCHEDULE NAME TO SCRIPT

So, I could put that command in a script or put it in the event area of a schedule?
Yep, either one will work.
by skot
Tue Jan 28, 2014 6:36 am
Forum: Scripting
Topic: Reboot when no wifi network available
Replies: 8
Views: 3644

Re: Reboot when no wifi network available

You can do some testing in a few ways. Paste these into the terminal. Return how many clients are in registration table: :put [:len [/interface wireless registration-table find]] Add some additional checks for testing, only pause for a few seconds, reboot line commented out { :local numClients [:len...
by skot
Mon Jan 27, 2014 9:33 pm
Forum: Scripting
Topic: Hotspot on login script for counter and auto change image
Replies: 2
Views: 2762

Re: Hotspot on login script for counter and auto change imag

This is possible... probably could be done a few ways. Here is an example to get you started. Put this script in /ip hotspot user profile > On Login box. If you have multiple profiles, this would have to be put in all of them. The "counter" is stored in the comment field of hotspot user "myUser" to ...
by skot
Mon Jan 27, 2014 8:27 pm
Forum: Scripting
Topic: How to execute a startup script
Replies: 1
Views: 984

Re: How to execute a startup script

You cannot change the default script, but a possible alternative method is to upload your custom script to the router as Something.rsc. Then issue the following command in the terminal to reset configuration and run the script:

ros code

/system reset-configuration run-after-reset=Something.rsc
by skot
Mon Jan 27, 2014 8:18 pm
Forum: Scripting
Topic: PASSING SCHEDULE NAME TO SCRIPT
Replies: 4
Views: 927

Re: PASSING SCHEDULE NAME TO SCRIPT

To delete a schedule based on the name, do this:

ros code

/system scheduler remove [find name="00:0C:42:12:34:56"]
by skot
Mon Jan 27, 2014 8:09 pm
Forum: General
Topic: /ip address get not working anymore?
Replies: 2
Views: 843

Re: /ip address get not working anymore?

Hm... your script seems to work fine for me in 6.7, however I'm not testing the afraid.org part. If that part is failing for some reason, the code below it (which updates the global currentIP var) might not run. I would comment out the # /system script... line and try again just to see if the global...
by skot
Mon Jan 27, 2014 7:17 pm
Forum: Beginner Basics
Topic: Firewall time shedule inactive (written by red font) upgrade
Replies: 3
Views: 2909

Re: Firewall time shedule inactive (written by red font) upg

Everything is all right, but firewall rules, in which is use time shedule (drop traffic from 00:00:00 to 06:00:00) are written by red font. I think, these rules are inactive. ... Is there any option to change these firewall rules font from red to black? Yes, these rules are inactive when red becaus...
by skot
Mon Jan 27, 2014 6:57 pm
Forum: Scripting
Topic: TX-BYTE and RX-BYTE
Replies: 2
Views: 1706

Re: TX-BYTE and RX-BYTE

You can do something like this. I'm assuming your interfaces are ether1, wlan1, and wlan2. :global e1tx [/interface get ether1 tx-byte] :global e1rx [/interface get ether1 rx-byte] :global w1tx [/interface get wlan1 tx-byte] :global w1rx [/interface get wlan1 rx-byte] :global w2tx [/interface get wl...
by skot
Mon Jan 27, 2014 6:35 pm
Forum: Scripting
Topic: Reboot when no wifi network available
Replies: 8
Views: 3644

Re: Reboot when no wifi network available

I found script here viewtopic.php?f=3&t=72229#p393705, but i don't understand how does it work. Why there is :pick $a +4 ? The script you mentioned won't do what you want... it gets the last-activity value of associated client number 0, which doesn't exist if there are no associated clients. You wo...
by skot
Fri Jan 24, 2014 12:11 am
Forum: Beginner Basics
Topic: why doesn't NTP client accept named domains?
Replies: 10
Views: 2678

Re: why doesn't NTP client accept named domains?

Use the [:resolve] function to set NTP... like this:
/system ntp client set primary-ntp=[:resolve 0.asia.pool.ntp.org]
by skot
Tue Jan 14, 2014 6:53 pm
Forum: Scripting
Topic: script with terminal OK with button or scheduler NO help
Replies: 2
Views: 881

Re: script with terminal OK with button or scheduler NO help

Use [find] instead of the number to select the interface, something like this:

ros code

/interface virtual-ethernet set [find name=vif1] name="name"
by skot
Thu Jan 09, 2014 12:59 am
Forum: Scripting
Topic: Watchdog script not working after upgrading to 6.7
Replies: 1
Views: 1044

Re: Watchdog script not working after upgrading to 6.7

When I try the script, I get a different error, but the script seems to work: script,error script error: action timed out - try again, if error continues contact MikroTik support and send a supout file (13) script,info Lost contact with neighbor, rebooting... If I run the script in the terminal, no ...
by skot
Tue Jan 07, 2014 6:34 pm
Forum: Scripting
Topic: Get variable from registration-table problem
Replies: 2
Views: 1628

Re: Get variable from registration-table problem

If you paste this into a terminal with an an existing MAC, it should return 1, and a non-existing should return 0. :put [:len [/interface wireless registration-table find where mac-address=00:0C:42:12:34:56]] So then, you could change your script to first check to see if that MAC exists in the table...
by skot
Sat Jan 04, 2014 8:58 pm
Forum: Scripting
Topic: Script Hotspot Password Daily using preset values
Replies: 5
Views: 1641

Re: Script Hotspot Password Daily using preset values

I didn't realize until just now that in the original code there are two :if ($result = "sun") blocks, which efaden fixed. However, I think the following code will cause issues. If today is "fri", the password will be set correctly. Any other day (mon,tues,etc) will get the "sat" password. :if ($resu...
by skot
Sat Jan 04, 2014 7:48 pm
Forum: Scripting
Topic: Script Hotspot Password Daily using preset values
Replies: 5
Views: 1641

Re: Script Hotspot Password Daily using preset values

I think the problem is in your :if statements. They all need to have a starting bracket { and an ending one }

Also, the first :if statement is missing the = sign after the word "do" like the other ones.

HTH
by skot
Sat Jan 04, 2014 7:33 pm
Forum: Scripting
Topic: Ping to a router and send mail notifications.
Replies: 2
Views: 1329

Re: Ping to a router and send mail notifications.

Something like this should work. Create a new schedule in /system scheduler that runs every minute, and paste this code into it. Change the first line so that it matches the name of the schedule. Also edit the two /tool e-mail lines further down. :local scheduleName "mySchedule" :local result [/ping...
by skot
Sat Jan 04, 2014 2:25 am
Forum: General
Topic: Dynamic DNS with credentials in URL.
Replies: 1
Views: 469

Re: Dynamic DNS with credentials in URL.

I don't think it is possible, except with password-less admin login.

Official word: http://forum.mikrotik.com/viewtopic.php ... 71#p399603
by skot
Sat Jan 04, 2014 2:15 am
Forum: General
Topic: question about command line
Replies: 1
Views: 516

Re: question about command line

can I presume the first one is using network logic to say what route matches and the second one is doing some sort of string search. It appears that is correct. I did not know the first option existed, and I can't seem to dig up if it is explained somewhere on the wiki. so why doesn't this work /ip...
by skot
Sat Jan 04, 2014 1:49 am
Forum: General
Topic: Reset Counters IP Hotspot Users?
Replies: 1
Views: 695

Re: Reset Counters IP Hotspot Users?

"Reset counters" only resets them for the user you have selected. "Reset all counters" resets them for all users.
by skot
Sat Jan 04, 2014 1:39 am
Forum: Virtualization
Topic: MetaROUTER possibilities?
Replies: 1
Views: 1945

MetaROUTER possibilities?

I have been trying to understand MetaRouter, and I have some questions. 1. Seeing as OpenWRT contains php, apache, etc, am I correct in thinking this could be used as a web server for using with the API on the main router? ...instead of needing an external server? 2. In that same light, I assume the...
by skot
Sat Jan 04, 2014 1:13 am
Forum: General
Topic: finding WDS in registration-table
Replies: 2
Views: 647

Re: finding WDS in registration-table

Maybe instead use [:len] to count the number of matching entries in the registration table. If there are more than 0, log it.

ros code

:if ([:len [/interface wireless registration-table find wds=no]] > 0) do={/log warning message="connected"} else={:log warning message="not conneced"}
by skot
Fri Jan 03, 2014 8:09 pm
Forum: Scripting
Topic: Help please, How to auto delete oldest file
Replies: 2
Views: 1408

Re: Help please, How to auto delete oldest file

I don't have a usb flash drive to test at the moment, but I assume the disk space free shows up in /system resources. If not, the script will need to be changed. Add this script to a new schedule to run however often you want. # if free disk space is less than 1GB :if ([/system resource get free-hdd...
by skot
Fri Jan 03, 2014 1:56 am
Forum: Beginner Basics
Topic: Accessing MT router from 127.0.0.1
Replies: 1
Views: 986

Re: Accessing MT router from 127.0.0.1

As far as I know 127.x.x.x address is available once you get into the box, this IP is not available to access router from outside. Yes, that is correct. How do I access over 127.x.x.x from outside of the router ? what is the 'local terminal' ? serial connection ? You can use a serial cable + softwa...
by skot
Thu Jan 02, 2014 10:27 pm
Forum: Scripting
Topic: :len returns 1 when counting target-address from queue
Replies: 2
Views: 895

Re: :len returns 1 when counting target-address from queue

Since the queue allows you to set multiple target addresses, they are stored in an array even if there is only one. So, when you check the length, it's just checking how many items are in the array. In v6, you can get the length by selecting the first array item (position 0) with [:pick], something ...
by skot
Tue Dec 31, 2013 7:10 pm
Forum: General
Topic: see number with 1 number after the .
Replies: 3
Views: 638

Re: see number with 1 number after the .

Ok, this one works: http://forum.mikrotik.com/viewtopic.php?f=9&t=24596#p164499 For testing, change the top part of the script to: :local dividend 10414452 :local divisor 1048576 :local decimalplaces 2 Enclose the whole script in brackets {} and paste into the terminal. Output: 10414452 / 1048576 = ...
by skot
Tue Dec 31, 2013 6:23 pm
Forum: General
Topic: see number with 1 number after the .
Replies: 3
Views: 638

Re: see number with 1 number after the .

Unfortunately, RouterOS rounds everything to integers, but I found this script which calculates decimals: http://wiki.mikrotik.com/wiki/Calculate_with_decimal_numbers I tested it on 6.7, and it works with adding, subtracting, and multiplying, but dividing seems to be broken! Which is what you're loo...
by skot
Tue Dec 31, 2013 6:00 pm
Forum: Scripting
Topic: send log file to email need help to fix
Replies: 9
Views: 7059

Re: send log file to email need help to fix

Try entering a from="name" or email address when you send the message.

ros code

/tool e-mail send to="xxxx@xxxx.com" from="from@domain.com" subject=...
by skot
Tue Dec 31, 2013 5:53 pm
Forum: Scripting
Topic: printing just the names in the access list
Replies: 2
Views: 753

Re: printing just the names in the access list

Try this:

ros code

/ip proxy access;:foreach i in=[find action=deny] do={:put [get $i dst-host]}
by skot
Mon Dec 30, 2013 9:11 pm
Forum: Scripting
Topic: how to check the status of the interface
Replies: 2
Views: 5387

Re: how to check the status of the interface

If you want to check if the interface is "running" and something is plugged in, you can do:

ros code

:if ([/interface get ether9 running] = false) do={
  /log info "ether9 is not running"
  /do something else
}
by skot
Wed Dec 25, 2013 2:38 am
Forum: General
Topic: sending mail when I get a new file-possible?
Replies: 4
Views: 855

Re: sending mail when I get a new file-possible?

This is how I would do it. This script stores the "date/time stamp" into the schedule's comment field (to survive reboots, which a global variable won't do). It gets the date and time values from the comment and then checks all "FTP....log" files for any that are newer, and sends email if any are fo...
by skot
Wed Dec 18, 2013 7:21 pm
Forum: Scripting
Topic: send log file to email need help to fix
Replies: 9
Views: 7059

Re: send log file to email need help to fix

please also include a command to delete this log from mikrotik memory after emailing this script coz mikrotik have very low memory as u know already.. thanks and regards You can use the same code that created the file to remove it: /file remove ([/system identity get name] . "Log-" . [:pick [/syste...
by skot
Wed Dec 18, 2013 7:09 pm
Forum: General
Topic: sending mail when I get a new file-possible?
Replies: 4
Views: 855

Re: sending mail when I get a new file-possible?

how can I write a script that whenever the file is copied he will send it to me to mail? how do I make the script "choose" the latest file that was created? and them continue to other file ,and so on and on.... Does the file name stay the same (and a new one overwrites the old one)? Or are you tryi...
by skot
Mon Dec 16, 2013 7:16 pm
Forum: Scripting
Topic: How to write and read string to serial port from script?
Replies: 3
Views: 1813

Re: How to write and read string to serial port from script?

I don't about receiving from the serial port, but you can send commands with this workaround: http://wiki.mikrotik.com/wiki/Sending_t ... erial_port

This article might also be informative: http://wiki.mikrotik.com/wiki/Serial_Port_Usage
by skot
Sun Dec 15, 2013 10:34 am
Forum: Beginner Basics
Topic: hotspot smartphone login
Replies: 2
Views: 848

Re: hotspot smartphone login

I think you're looking for the "idle-timeout" setting in the user profile. See wiki here: http://wiki.mikrotik.com/wiki/Manual:IP/Hotspot/User
by skot
Wed Dec 11, 2013 10:54 pm
Forum: Scripting
Topic: Scripts policy
Replies: 1
Views: 655

Re: Scripts policy

How I can (or maybe can't) protect script from other users? How I can remove read and write to some user to: /system scripts /system scheduler The permissions aren't very flexible, so I don't think what you are trying to do is possible. You could turn off "read" access in the user's group policy, b...
by skot
Wed Dec 11, 2013 10:41 pm
Forum: General
Topic: Creating a private ssl certificate
Replies: 2
Views: 3320

Re: Creating a private ssl certificate

by skot
Sat Dec 07, 2013 9:14 pm
Forum: Scripting
Topic: Script to change frequencies based on Rx/Tx CCQ
Replies: 4
Views: 2247

Re: Script to change frequencies based on Rx/Tx CCQ

Use a script like this to cycle through frequencies: /interface wireless :local interface "wlan1" :local freqList {2412;2417;2422;2427;2432;2437;2442;2447;2452;2457;2462} :local freqListLen [:len $freqList] :local freq [get $interface frequency] :local pos [:find $freqList $freq] monitor $interface ...
by skot
Sat Dec 07, 2013 9:42 am
Forum: RouterBOARD hardware
Topic: RB493-CB750
Replies: 0
Views: 417

RB493-CB750

I had a spare RB493 laying around without a case and discovered that... a RB750 box fits almost exactly! I had to clip off the bottom wireless card clips for it to fit since they stick out beyond the edge of the board.

Thanks gsloop for the idea :) http://gregsowell.com/?p=690
RB493-CB750.jpg
by skot
Tue Dec 03, 2013 7:46 pm
Forum: Beginner Basics
Topic: WiFi problem with 1 specific device
Replies: 8
Views: 1620

Re: WiFi problem with 1 specific device

I have had similar issues with some phones. Security was set on WPA2, and they would not connect and I was getting logs similar to yours.

I found that they would work with WPA, so I created a virtual wlan for those devices only with a separate WPA security profile and they are working fine.
by skot
Mon Dec 02, 2013 1:37 am
Forum: Beginner Basics
Topic: automatic Shutdown script
Replies: 9
Views: 12081

Re: automatic Shutdown script

As fewi said, you have to physically unplug and plug back in the power.

Or, remotely you could use a networked UPS or power strip like the ones from digital loggers: http://www.digital-loggers.com/lpc.html
by skot
Thu Nov 28, 2013 8:06 pm
Forum: Wireless Networking
Topic: How to disable Hotspot logs?
Replies: 2
Views: 1048

Re: How to disable Hotspot logs?

In /system logging, change the "info" rule to be info,!wireless. Off to the right of the "info" drop down box, there are up and down arrows. Click the down arrow, change the new topic to wireless and them click what looks like a checkbox to the left, which is actually the "not" box.
by skot
Thu Nov 28, 2013 10:42 am
Forum: Scripting
Topic: netwatch and beep script
Replies: 6
Views: 3943

Re: netwatch and beep script

Ok. In that case you can just do what you originally intended. Just paste the script from the first part of your first post into the Down tab.
by skot
Thu Nov 28, 2013 1:20 am
Forum: Scripting
Topic: netwatch and beep script
Replies: 6
Views: 3943

Re: netwatch and beep script

Copy paste in the terminal?
Yes, if you paste the script in my previous post into the terminal (or via telnet/SSH) it will add the netwatch item. Before you paste it, make sure and edit the script with the correct host=X.X.X.X IP address of your gateway.

Are you using SSH/telnet? Or Winbox?
by skot
Wed Nov 27, 2013 11:06 pm
Forum: Scripting
Topic: Ultra Newb question
Replies: 1
Views: 490

Re: Ultra Newb question

That functionality is not built in, but people have scripted workarounds: http://forum.mikrotik.com/viewtopic.php ... 83#p284764
by skot
Wed Nov 27, 2013 9:51 pm
Forum: Beginner Basics
Topic: pppoe+firewal+soho
Replies: 1
Views: 545

Re: pppoe+firewal+soho

I assume you already have basic rules set up that block all outside access, unless initiated from inside. Examples here: http://wiki.mikrotik.com/wiki/Manual:IP/Firewall/Filter#Basic_examples IP > Services Restrict which IP addresses services can be accessed from, disable services you don't want to ...
by skot
Wed Nov 27, 2013 7:54 pm
Forum: Scripting
Topic: netwatch and beep script
Replies: 6
Views: 3943

Re: netwatch and beep script

Just copy and paste this in netwatch down? Yes. When I copy/paste the script in winbox, and then export using CLI, I get this: /tool netwatch add down-script="/log info \"GATEWAY\"\r\ \n{\r\ \n:local count\r\ \n:local freq\r\ \n\r\ \n\r\ \n:for c from=1 to=50 step=1 \\\r\ \n\r\ \ndo={ \\\r\ \n:set ...
by skot
Wed Nov 27, 2013 7:21 pm
Forum: General
Topic: Changelog RouterOS 6.7
Replies: 27
Views: 16315

Re: Changelog RouterOS 6.7

*) address-list - allow manually adding timeoutable entries;
*) address-list - show dynamic entry timeout;

Glad to get these features. They show up in CLI but not winbox/webfig.
by skot
Wed Nov 27, 2013 6:17 am
Forum: Scripting
Topic: Export to File - Filename Variable
Replies: 4
Views: 3605

Re: Export to File - Filename Variable

The date contains forward slashes which can't be used in file names. You could use [:pick] and extract the date out, something like:
:local date ([:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 4 6] . [:pick [/system clock get date] 7 11]);
by skot
Sun Nov 24, 2013 11:31 pm
Forum: Scripting
Topic: lua is not intalled in my board
Replies: 1
Views: 903

Re: lua is not intalled in my board

Lua support was dropped on v4.0rc1, but apparently they are planning to bring it back at some point.
by skot
Sat Nov 23, 2013 1:22 am
Forum: Scripting
Topic: fetch problem
Replies: 2
Views: 1118

Re: fatch problem

Try escaping the ? with a backslash:

ros code

/tool fetch url="http://ip_address/control.cgi\?bitrate...."
by skot
Fri Nov 22, 2013 2:35 am
Forum: General
Topic: BLOCK DHCP
Replies: 2
Views: 493

Re: BLOCK DHCP

And protocol should be UDP, not TCP
by skot
Wed Nov 20, 2013 8:02 pm
Forum: General
Topic: HTML form inside mikrotik
Replies: 1
Views: 448

Re: HTML form inside mikrotik

This is not possible using the router alone. It can be done using an external web server + php api
by skot
Wed Nov 20, 2013 10:22 am
Forum: General
Topic: Feature request: Run script from firewall event
Replies: 4
Views: 2834

Re: Feature request: Run script from firewall event

Lol, nice screen. While this option doesn't explicitly exist, you can do it a couple ways that I can think of. The thing to keep in mind is that often a filter rule doesn't just match one packet but who knows how many, and you need a way to make sure your script is only being run once and not many t...
by skot
Tue Nov 19, 2013 7:51 pm
Forum: General
Topic: Known issues and bugs - a list
Replies: 283
Views: 110399

Re: Known issues and bugs - a list

I like your idea behind this post and also agree with pcunite that we need a good way to track and organize the bugs. A forum post gets bloated and tedious quickly imo. We need something 1) easy to use and 2) easy to find, especially for people new to the forum. Even something as simple a having a n...
by skot
Mon Nov 18, 2013 10:24 am
Forum: Scripting
Topic: assign value to array
Replies: 2
Views: 1956

Re: assign value to array

It looks like you are trying to add / edit array items in the array, but there is no way currently to do this, though it sounds like there are plans: http://forum.mikrotik.com/viewtopic.php?f=9&t=75810#p395914 You can add values to the end of an array, but this probably isn't helpful in your situati...
by skot
Mon Nov 18, 2013 8:49 am
Forum: General
Topic: distribute config to multiple devices
Replies: 5
Views: 1133

Re: distribute config to multiple devices

/system upgrade upgrade-package-source export there is no passwords i need distribute these settings with passwords There doesn't seem to be a script-able way to export/import the passwords, however people have found a workaround. You can manually copy/paste code into the terminal followed by the p...
by skot
Sat Nov 16, 2013 9:02 am
Forum: General
Topic: Known issues and bugs - a list
Replies: 283
Views: 110399

Re: Known issues and bugs - a list

There's another bug list here: http://bugs.mikrotik-routeros.com/view_all_bug_page.php. I don't know how active it is though...
by skot
Thu Nov 14, 2013 7:41 pm
Forum: General
Topic: Disable/Hide buttons
Replies: 6
Views: 1096

Re: Disable/Hide buttons

As shown on the second image, that user has the login form, and my system doesn't. I have seen this also, but I was using standard RouterOS npk files on all routers, and for some reason the pages were different. I do not know of a way to change the web page. You could ask MikroTik support http://ww...
by skot
Thu Nov 14, 2013 4:37 am
Forum: Beginner Basics
Topic: Network diagram software
Replies: 7
Views: 2605

Re: Network diagram software

I have used Pencil in the past, open source and cross-platform: http://pencil.evolus.vn/
by skot
Sun Nov 10, 2013 1:34 am
Forum: Scripting
Topic: Ping fail + ping fail + send sms
Replies: 6
Views: 3761

Re: Ping fail + ping fail + send sms

Create a schedule in System > Scheduler to run every 30s with the following script. :local result [/ping 192.168.88.1 count=3] :global status :if ($result = 3 && $status != true) do={ /tool sms send message="link up" phone-number=12345 :set status true } else={ :if ($result = 0 && $status != false) ...
by skot
Fri Nov 08, 2013 9:51 pm
Forum: General
Topic: interface wireless monitor interval
Replies: 1
Views: 414

Re: interface wireless monitor interval

It means "how often the data should be refreshed"
by skot
Fri Nov 08, 2013 7:52 pm
Forum: Scripting
Topic: Regex to NOT find something...
Replies: 5
Views: 5062

Re: Regex to NOT find something...

can i do in with if condition? because this code just doesn't seems to be right :) :if ($lastip ~"168."=true) do={ :log error "test test" } It works for me, tested in 5.26 and 6.4. How are you testing this? I enclose the whole script in curly braces and run in the terminal (so that local variables ...
by skot
Fri Nov 08, 2013 1:04 am
Forum: General
Topic: saving clock without internet connection
Replies: 7
Views: 2190

Re: saving clock without internet connection

The answer is the same as when you asked previously , there is no reliable way to do this without NTP. That said, you could run a schedule every X seconds that saves the date/time/tz in the schedule's comment field. Then, when the router reboots, it checks the comment and sets the date/time/tz. Firs...
by skot
Thu Nov 07, 2013 10:30 am
Forum: Beginner Basics
Topic: How do I setup RB750 with my pocket wifi?
Replies: 6
Views: 2087

Re: How do I setup RB750 with my pocket wifi?

what do you mean by wireless cards? http://routerboard.com/R52H (a/b/g) + u.fl antenna -or- http://routerboard.com/R52Hn (a/b/g/n) + MMCX antenna . These would go into something like a http://routerboard.com/RB433 or http://routerboard.com/RB433AH (there are other boards that would work too...). Yo...
by skot
Mon Nov 04, 2013 7:37 pm
Forum: Beginner Basics
Topic: How do I setup RB750 with my pocket wifi?
Replies: 6
Views: 2087

Re: How do I setup RB750 with my pocket wifi?

I suppose you could get an RB433 and 2 wireless cards, one for connecting to pocket wifi, and another for broadcasting as AP to the people (http://forum.mikrotik.com/viewtopic.php?f=7&t=61256#p313238). Internet --> pocket wifi --> [wlan1 client] RB433 [wlan2 AP] --> 15 people However, some people on...
by skot
Sat Nov 02, 2013 8:23 am
Forum: General
Topic: Keep bandwidth usage at interface and queue after restarting
Replies: 4
Views: 893

Re: Keep bandwidth usage at interface and queue after restar

SNMP + external server http://forum.mikrotik.com/viewtopic.php?f=6&t=10154#p281901 Netflow + external server http://forum.mikrotik.com/viewtopic.php?f=13&t=50997#p260157 Save stats on router in comment field of queue / interface, would need to be scripted http://forum.mikrotik.com/viewtopic.php?f=13...
by skot
Fri Nov 01, 2013 11:45 pm
Forum: General
Topic: Web proxy generate 100 % CPU
Replies: 4
Views: 3162

Re: Web proxy generate 100 % CPU

Proxy on a 493 is probably too much for it to handle. if it works on 750 and 450 should work on 493 too ! :) I thought maybe you were running the proxy on the 493 itself, without parent proxy, and that could cause high cpu. Cache on Disk is not setup. Should be setup on disk ? No. If you're using p...
by skot
Fri Nov 01, 2013 11:31 pm
Forum: Beginner Basics
Topic: How do I setup RB750 with my pocket wifi?
Replies: 6
Views: 2087

Re: How do I setup RB750 with my pocket wifi?

1. How do I connect my pocket WIFI to Mikro Tik RB750? Does pocket wifi have ethernet port? RB750 is ethernet only. Even if it does have an ethernet port, it would not be in line with the people. Internet --> pocket wifi --> 15 people \ ---> RB750 2. Can I then manage the bandwidth of each gadget c...
by skot
Fri Nov 01, 2013 10:43 pm
Forum: General
Topic: Web proxy generate 100 % CPU
Replies: 4
Views: 3162

Re: Web proxy generate 100 % CPU

Proxy on a 493 is probably too much for it to handle. how can I investigate this ? where can be seen what sites actually access the users ? Go to IP > Web Proxy. What are Parent Proxy, Max Cache Size and Cache on Disk set to? where can be seen what sites actually access the users ? Click Cache Conte...
by skot
Fri Nov 01, 2013 10:09 pm
Forum: Wireless Networking
Topic: wireless network
Replies: 1
Views: 538

Re: wireless network

From searching the internet, the general answer was "very poorly". This thread was interesting: http://www.network-builders.com/wifi-range-under-water-t38480.html But there are people working on it, though it's very slow at this point "a few kilobits per second at most": http://www.wired.com/wireden...
by skot
Fri Nov 01, 2013 9:02 pm
Forum: Scripting
Topic: Can I release the global variable?
Replies: 3
Views: 1017

Re: Can I release the global variable?

If by release you mean remove, yes, that can be done:
:global myVar "some value"
...
...
/system script environment remove myVar
Or you can remove them all:
/system script environment remove [find]
by skot
Fri Nov 01, 2013 5:59 pm
Forum: RouterBOARD hardware
Topic: Hotspot Restriction
Replies: 3
Views: 740

Re: Hotspot Restriction

Server profile rate limits (search for "rate-limit" setting): http://wiki.mikrotik.com/wiki/Manual:IP/Hotspot/Profile#Properties User profile rate limits (search for "rate-limit" setting): http://wiki.mikrotik.com/wiki/Manual:IP/Hotspot/User#Properties_2 User data limits limits (search for "limit-by...
by skot
Fri Nov 01, 2013 5:47 pm
Forum: Scripting
Topic: Modification of filter lists
Replies: 2
Views: 929

Re: Modification of filter lists

So the question is if this can be done by a script maybe? This should be possible. As long as you're able to get the basic data into a text file on the PC (via IRRPT, retrieving it using wget, or whatever), you could then use a bash script to modify and output a properly formatted RouterOS script. ...
by skot
Thu Oct 31, 2013 5:27 pm
Forum: General
Topic: need script send ping output to mail
Replies: 3
Views: 1140

Re: need script send ping output to mail

What kind of "ping output" are you looking for? Number of successful/failed pings?

And what do you mean by "after system startup with 5 min"? Do you want the script to run once, 5 minutes after startup, or run every 5 minutes after startup? Or something else?
by skot
Wed Oct 30, 2013 7:35 pm
Forum: General
Topic: Webfig Design Skin
Replies: 7
Views: 3174

Re: Webfig Design Skin

I tried the reset config script you suggested but when unit rebooted had no IP address, ports were missing from the bridge ... all that remained was the wireless settings. Now that you mention it, I had forgotten that during my testing I ran across a similar problem, which I'll explain in a bit. Wh...
by skot
Wed Oct 30, 2013 8:04 am
Forum: General
Topic: Too many smilies?
Replies: 1
Views: 373

Too many smilies?

too many smilies.png
Lol, I guess there's a limit.
by skot
Wed Oct 30, 2013 7:59 am
Forum: General
Topic: Webfig Design Skin
Replies: 7
Views: 3174

Re: Webfig Design Skin

I am not able to assign the skin to the user in the basic config script as it doesn't recognise the skin which has not yet been branded to the unit so I named the user skin default instead which has helped so at least after a reset config the skin is assigned to the user. You can upload the skin to...
by skot
Tue Oct 29, 2013 5:36 pm
Forum: General
Topic: How to make sense of "Bytes Out" OID
Replies: 3
Views: 2376

Re: How to make sense of "Bytes Out" OID

Assuming 3263003375 is bytes, dividing by 1024 gives you kilobytes, and dividing again by 1024 gives you megabytes = 3111.84 MB / 1024 = 3.03 GB
by skot
Fri Oct 25, 2013 8:38 pm
Forum: General
Topic: Webfig Design Skin
Replies: 7
Views: 3174

Re: Webfig Design Skin

One option would be to do this: 1. Create a basic default script that at minimum sets the IP address of the router so the customer can log back in using the skin. Upload this script to the router. 2. Create a script that resets the config, something like: /system reset-configuration no-defaults=yes ...
by skot
Fri Oct 25, 2013 7:22 pm
Forum: Scripting
Topic: print simple queue name and stats in the same command..
Replies: 9
Views: 5586

Re: print simple queue name and stats in the same command..

If you want the total bytes of ALL simple queues added together, try this (edit the /tool email line with your info): /queue simple :local upload 0 :local download 0 :foreach i in=[find] do={ :local bytes [get $i bytes] :set upload ($upload + [:pick $bytes 0 [:find $bytes "/"]]) :set download ($down...
by skot
Tue Oct 22, 2013 8:35 pm
Forum: Scripting
Topic: Symbol ! - logical negation in script to find comments
Replies: 2
Views: 1614

Re: Symbol ! - logical negation in script to find comments

The command is working, but you have to use some other commands to work with the results. For example, in the console, you can return the items found (not very useful, but shows you the command is working): :put [/ip proxy access find where comment!="VALUE"] You can loop through these items, and do ...
by skot
Tue Oct 22, 2013 8:13 pm
Forum: Scripting
Topic: how to escape unknown commands
Replies: 2
Views: 762

Re: how to escape unknown commands

Use [:parse] to create a function, something like this:

ros code

:if ([/system resource get version] > 5.11) do={
  :global runExport [:parse "/export compact"];
} else={
  :global runExport [:parse "/export"];
}
$runExport;
by skot
Mon Oct 21, 2013 11:17 pm
Forum: General
Topic: Webfig Skins - Hidden Fields Unhidden on Index
Replies: 7
Views: 2423

Re: Webfig Skins - Hidden Fields Unhidden on Index

I'm seeing the same thing with the Quick Set page. It also seems kind of pointless that there are certain items you can't even turn off (graphs, buttons). Attached is a sample skin where I've tried to create a setup like you're looking for. The Status page shows the read-only items, and the other me...
by skot
Mon Oct 21, 2013 9:48 pm
Forum: Scripting
Topic: this script not working when wireless freezing -HELP-
Replies: 19
Views: 3291

Re: this script not working when wireless freezing -HELP-

but i try to paste the last code in new terminal And the result Ask to reboot the router In the terminal, this is normal behavior, it will ask if you want to reboot. In a script, it will reboot without the prompt. When the wireless is freezing, what do the logs say? Does it indicate the scheduler/s...
by skot
Mon Oct 21, 2013 9:02 pm
Forum: Wireless Networking
Topic: Want to run onitik on Solar Energy
Replies: 11
Views: 2853

Re: Want to run onitik on Solar Energy

Enjoyed the article, thanks.
An electric fence shock in the small of your back can make you nauseous
LOL, I feel your pain, been shocked by a few of those myself.
by skot
Sun Oct 20, 2013 9:50 am
Forum: Scripting
Topic: this script not working when wireless freezing -HELP-
Replies: 19
Views: 3291

Re: this script not working when wireless freezing -HELP-

In your example, all the OK lines should have the time value just like the reboot entry. s.png If you run the script in the terminal with :local variables, make sure to enclose the entire script in brackets: { /log info "[LAST-ACTIVITY] START" :local a [/in wi reg get number=0 last-activity] :if ($a...
by skot
Sun Oct 20, 2013 5:47 am
Forum: Scripting
Topic: delete this
Replies: 7
Views: 1759

Re: sent to email - too many emails

Connect to the router with Winbox or Webfig. Go to System > Scheduler and add a new schedule. For this example, I'll name it mySchedule. I always set Start Date to Jan/01/1970 in case for whatever reason NTP doesn't work after a reboot. Set the Start Time to 00:00:00, and the Interval to however oft...
by skot
Sun Oct 20, 2013 3:31 am
Forum: Scripting
Topic: this script not working when wireless freezing -HELP-
Replies: 19
Views: 3291

Re: this script not working when wireless freezing -HELP-

Did the script work after you changed the time to 70s? I wonder if this might have something to do with it. Because the returned last-activity time is in the format of: 00:00:10.000, 70s would be returned as 00:01:10.000. Interesting that if I do :put 70s, it returns 00:01:10 I would troubleshoot by...
by skot
Sat Oct 19, 2013 8:43 am
Forum: General
Topic: RB951ui change WAN port from port 1 to port 5 in AP mode
Replies: 5
Views: 4133

Re: RB951ui change WAN port from port 1 to port 5 in AP mode

I tested your edited config on a RB450G and it worked great for me, so I don't think the RB951ui-2hnd is the issue. It may be a config issue further down the line. Are you able to get out to the internet if you plug directly into the Groove with a PC? I would start by plugging a PC into one of the L...
by skot
Sat Oct 19, 2013 3:57 am
Forum: Scripting
Topic: this script not working when wireless freezing -HELP-
Replies: 19
Views: 3291

Re: this script not working when wireless freezing -HELP-

What is the result if you paste this into the terminal?
:put [/in wi reg get number=0 last-activity]
by skot
Sat Oct 19, 2013 2:34 am
Forum: Scripting
Topic: delete this
Replies: 7
Views: 1759

Re: sent to email - too many emails

So just question, is mikrotik able to make very simple email logs, mainly about vpn information (log in, log out and so...) I use a script like this to search for specific words in the logs and email me when new logs show up. It has the ability to also filter out ones you don't want, for more granu...
by skot
Fri Oct 18, 2013 7:13 pm
Forum: General
Topic: Webfig Skins - Hidden Fields Unhidden on Index
Replies: 7
Views: 2423

Re: Webfig Skins - Hidden Fields Unhidden on Index

I have a user with the following policy permissions (!local,!telnet,!ssh,reboot,read,!test,!winbox,password,web,!sniff,sensitive,!api,!ftp,write,!policy) and they have the webfig skin below but immediately upon login they are sent to http://routerIPhere/webfig/ and all the skin Quick Set fields I'v...
by skot
Fri Oct 18, 2013 2:35 am
Forum: The User Manager
Topic: Removing several users from the user-manager
Replies: 1
Views: 1044

Re: Removing several users from the user-manager

If you want to remove ALL users, you can do this:

ros code

/tool user-manager user remove [find]
by skot
Thu Oct 17, 2013 11:14 pm
Forum: General
Topic: RB951ui change WAN port from port 1 to port 5 in AP mode
Replies: 5
Views: 4133

Re: RB951ui change WAN port from port 1 to port 5 in AP mode

I tested your config and it and it was working for me. I used the command "/system reset-configuration no-defaults=yes skip-backup=yes run-after-reset=default-mod-wan5.rsc" to load the modified rsc file. After loading the configuration the WebFig "Quick Set" page shows the "Configuration Mode" is Br...
by skot
Thu Oct 17, 2013 6:27 pm
Forum: Scripting
Topic: this script not working when wireless freezing -HELP-
Replies: 19
Views: 3291

Re: this script not working when wireless freezing -HELP-

while(true) is generally not a good idea.
I assume you're referring to the script itself to which I agree. I think the script will be rebooting unnecessarily too often.
by skot
Thu Oct 17, 2013 1:47 am
Forum: Scripting
Topic: this script not working when wireless freezing -HELP-
Replies: 19
Views: 3291

Re: this script not working when wireless freezing -HELP-

Your script is causing a never ending while loop that causes the Metal's CPU to peg out at 100%. And then five minutes later it does the same thing, adding another one. Get rid of the loop for starters. And when comparing times, you can do something like this (2s being "2 seconds", and decimals are ...
by skot
Wed Oct 16, 2013 6:42 pm
Forum: RouterBOARD hardware
Topic: Hotspot Restriction
Replies: 3
Views: 740

Re: Hotspot Restriction

Yes, you can limit overall Server Profile Rx/Tx rates, User Profile rates, and individual user bandwidth limits.
by skot
Wed Oct 16, 2013 6:16 pm
Forum: Beginner Basics
Topic: firewall list
Replies: 3
Views: 886

Re: firewall list

Yes, I think that is correct. More information can be found here: http://wiki.mikrotik.com/wiki/Manual:Sc ... mmand_line
by skot
Wed Oct 16, 2013 6:08 pm
Forum: General
Topic: Mikrotik 6.4 - FullLogging
Replies: 3
Views: 908

Re: Mikrotik 6.4 - FullLogging

You can add debugging and pppoe logging rules in System > Logging.
by skot
Tue Oct 15, 2013 11:44 pm
Forum: General
Topic: mangle p2p traffic
Replies: 3
Views: 1933

Re: mangle p2p traffic

by skot
Tue Oct 15, 2013 11:06 pm
Forum: General
Topic: RB951ui change WAN port from port 1 to port 5 in AP mode
Replies: 5
Views: 4133

Re: RB951ui change WAN port from port 1 to port 5 in AP mode

It would probably be easiest to see your current config. In Webfig or winbox, open a terminal and type /export, then copy/paste it here.
by skot
Tue Oct 15, 2013 7:10 pm
Forum: General
Topic: help with queue
Replies: 1
Views: 944

Re: help with queue

You might look through other forum posts, other people are trying to do the same thing: https://encrypted.google.com/search?q=+ ... 20priority
by skot
Tue Oct 15, 2013 6:08 pm
Forum: Beginner Basics
Topic: firewall list
Replies: 3
Views: 886

Re: firewall list

You want to remove all firewall filter entries from the router? Run this in the terminal / command line:

ros code

/ip firewall filter remove [find]
by skot
Tue Oct 15, 2013 5:34 pm
Forum: General
Topic: see the RB version
Replies: 2
Views: 621

Re: see the RB version

If you're trying to print it in the terminal, you can do:

ros code

:put [/system resource get version]
:put [/ip hotspot user get [find name=david] uptime]
by skot
Tue Oct 15, 2013 7:53 am
Forum: Scripting
Topic: Keywords in logs to activate script
Replies: 10
Views: 4562

Re: Keywords in logs to activate script

But on a router which has several issue like no PPPoE profile local-address or DNS errors "No route to host" or OSPF "OSPFv2 neighbor 10.111.XX.XX: state change from full to 2-way This occurs on APs which have used version V5.20 , V5.25, V6.1, A simple reboot normally solves this but I am more conc...
by skot
Tue Oct 15, 2013 7:47 am
Forum: Scripting
Topic: Disable items from the address list with a .txt file
Replies: 3
Views: 1663

Re: Disable items from the address list with a .txt file

Make sure this line doesn't have the colon before "thisline": :local thisline; And, insert this line before the /ip firewall disable line: /ip firewall address-list print A downside to using this method is that it generates the "numbers" based on the order the address-list entries were created, so i...
by skot
Fri Oct 11, 2013 2:32 am
Forum: Scripting
Topic: Bandwidth Cap question
Replies: 1
Views: 780

Re: Bandwidth Cap question

http://wiki.mikrotik.com/wiki/Limiting_a_user_to_a_given_amount_of_traffic_II That way is fine except that a reboot/power failure will reset all stats. The example is on a daily basis, so this is probably fine, but if you wanted to keep track over a longer period, you might look into using the hots...
by skot
Thu Oct 10, 2013 7:20 pm
Forum: Beginner Basics
Topic: How to allocate fixed bandwidth for one user for 30days?
Replies: 2
Views: 1299

Re: How to allocate fixed bandwidth for one user for 30days?

Hello, I am facing problem to allocate a fixed bandwidth for specific user. I mean I want to allocate 1GB/2GB bandwidth for a user for 30 days. A user can download/upload maximum 1GB or 2GB bandwidth within 30 days and it will be allocated by userwise or ip wise. Any one can tell me how could I do ...
by skot
Thu Oct 10, 2013 6:56 pm
Forum: General
Topic: Scheduler Question
Replies: 2
Views: 526

Re: Scheduler Question

You could also use this script: http://wiki.mikrotik.com/wiki/Script_to_find_the_day_of_the_week Schedule it to run every day, and it will skip the day you choose. :local date [/system clock get date] :local result "" :local months [:toarray "jan,feb,mar,apr,may,jun,jul,aug,sep,oct,nov,dec"] :local ...
by skot
Thu Oct 10, 2013 6:42 pm
Forum: Scripting
Topic: how to get log records for last 5 mins?
Replies: 4
Views: 1528

Re: how to get log records for last 5 mins?

YW :D
by skot
Thu Oct 10, 2013 6:39 pm
Forum: General
Topic: Script to count the number of users from Hotspot cookies
Replies: 1
Views: 586

Re: Script to count the number of users from Hotspot cookies

Give this a try:

ros code

:local myFile "hotspotCookies.txt";

:if ([:len [/file find name=$myFile]] = 0) do={
  /file print file=$myFile;
  :delay 2s;
}

/file set $myFile contents="$[:len [/ip hotspot cookie find]]"
  • 1
  • 2