Community discussions

Search found 43 matches

by huigezi
Fri Feb 21, 2014 2:04 pm
Forum: General
Topic: what mean this ?
Replies: 1
Views: 832

what mean this ?

i dont know how to use

please
by huigezi
Wed Aug 21, 2013 2:07 pm
Forum: Wireless Networking
Topic: Which is better?please
Replies: 2
Views: 761

Re: Which is better?please

Hi there, in general, a larger signal to noise ratio is better. However, looking at your signal levels, the signal level in the top picture is too high at around -39dBm. The signal levels in the bottom picture are much better. I believe you want to get around -60 or so for your level and try to min...
by huigezi
Wed Aug 21, 2013 6:43 am
Forum: Wireless Networking
Topic: Which is better?please
Replies: 2
Views: 761

Which is better?please

Does the noise ratio which is better? Is greater or smaller is better
Thank you for your answer
Which is better?
by huigezi
Fri Aug 16, 2013 3:39 pm
Forum: General
Topic: Excuse me, why not make a list of ports?
Replies: 5
Views: 1293

Re: Excuse me, why not make a list of ports?

You mean the equivalent of Address Lists but for Ports instead of Addresses?
Dear
i mean add a port list function
by huigezi
Thu Aug 15, 2013 6:41 pm
Forum: General
Topic: Excuse me, why not make a list of ports?
Replies: 5
Views: 1293

Excuse me, why not make a list of ports?

Excuse me, why not make a list of ports?
As long as there is a list of ports can be very good to do routing strategy
Such as adding a lot of game port define a list of ports arranged routing
If the game too many ports
Mangle tags can have a lot of strategies
Add a list of ports as a marker is good
by huigezi
Fri Jul 26, 2013 6:42 am
Forum: Wireless Networking
Topic: CPE connection quality monitoring
Replies: 3
Views: 855

Re: CPE connection quality monitoring

like this ? :do { :local a 54 :foreach i in=[/interface wireless registration-table find] do={ :local tx [/interface wireless registration-table get $i tx-rate] :local rx [/interface wireless registration-table get $i rx-rate] :set tx [:pick $tx 0 [:find $tx "."]];:set rx [:pick $rx 0 [:find $rx "."...
by huigezi
Thu May 16, 2013 7:29 am
Forum: Scripting
Topic: bakup script
Replies: 1
Views: 654

bakup script

:do { :local date [/system clock get date] :local d [:pick $date 4 6] :local m [:pick $date 0 3] :local y [:pick $date 7 11] :if ($m="jan") do={:set m "01"}; :if ($m="feb") do={:set m "02"}; :if ($m="mar") do={:set m "03"}; :if ($m="apr") do={:set m "04"}; :if ($m="may") do={:set m "05"}; :if ($m="...
by huigezi
Thu Aug 02, 2012 8:19 am
Forum: Wireless Networking
Topic: ROS SXT and ubnt In contrast to delay
Replies: 11
Views: 2102

Re: ROS SXT and ubnt In contrast to delay

it is because of different parameters that cmd uses for ping and what mikrotik does.
未命名.jpg

----------------------
I want to say

use nv2 of mikrotik is get high delay

and use ubnt it'is not this ping delay
by huigezi
Thu Aug 02, 2012 4:04 am
Forum: Wireless Networking
Topic: ROS SXT and ubnt In contrast to delay
Replies: 11
Views: 2102

ROS SXT and ubnt In contrast to delay

1.jpg
2.jpg
ROS delay than the UBNT gap is too big
by huigezi
Fri Feb 17, 2012 4:07 am
Forum: Scripting
Topic: ping timeout ... disable
Replies: 2
Views: 841

Re: ping timeout ... disable

i know your means
for example if you ping http://www.google.com and ping count 8 yes?
:if ([/ping http://www.google.com count=8]!=8) do={
/interface disable [/interface find name=ether1]
}
by huigezi
Sun Jan 29, 2012 8:05 pm
Forum: General
Topic: HTB script
Replies: 0
Views: 968

HTB script

/ip firewall mangle add action=accept chain=forward comment=icmp_options disabled=no protocol=\ icmp add action=mark-packet chain=forward comment=all_up_classifier disabled=no \ new-packet-mark=all-up-p passthrough=no src-address=192.168.1.0/24 add action=mark-packet chain=forward comment=all_down_...
by huigezi
Thu Jan 26, 2012 10:53 am
Forum: Scripting
Topic: How to make scheduler based on days of the week ?
Replies: 10
Views: 4771

Re: How to make scheduler based on days of the week ?

today is thu i test is on thu

script is working fine
by huigezi
Thu Jan 26, 2012 10:26 am
Forum: Scripting
Topic: How to make scheduler based on days of the week ?
Replies: 10
Views: 4771

Re: How to make scheduler based on days of the week ?

:do { :local date [/system clock get date] :local result "" :local months [:toarray "jan,feb,mar,apr,may,jun,jul,aug,sep,oct,nov,dec"] :local monthtbl [:toarray "0,3,3,6,1,4,6,2,5,0,3,5"] :local daytbl [:toarray "sun,mon,tue,wed,thu,fri,sat"] :local month [:pick $date 0 3] :local day [:pick $date 4...
by huigezi
Tue Jan 24, 2012 9:35 am
Forum: Scripting
Topic: how to know if ethernet is not running
Replies: 9
Views: 1565

Re: how to know if ethernet is not running

I really don't know what you do
ether1 disabled and disable ether5?

ether1 enabled and enable ether5?
by huigezi
Tue Jan 24, 2012 9:31 am
Forum: Scripting
Topic: how to know if ethernet is not running
Replies: 9
Views: 1565

Re: how to know if ethernet is not running

What i want to know if the interface ether1 is unpluged the it should disable ether5 and when it is pluged again then ether5 is enabled

it's your ??

http://forum.mikrotik.com/viewtopic.php?f=9&t=58461
by huigezi
Tue Jan 24, 2012 9:18 am
Forum: Scripting
Topic: how to know if ethernet is not running
Replies: 9
Views: 1565

Re: how to know if ethernet is not running

use script to log display?
:do {
:local status
:set status [/interface get [/interface find name="ether1"] running]
:if ($status=true) do={
:log warning ("ether1 is running")}
:if ($status=false) do={
:log warning ("ether1 is no run")
}}
by huigezi
Tue Jan 24, 2012 8:49 am
Forum: Scripting
Topic: Compare dates
Replies: 3
Views: 2699

Re: Compare dates

compare the comment of firewall rules and [system clock get date] ???
by huigezi
Sun Jan 22, 2012 3:35 pm
Forum: Scripting
Topic: script for change public IP every hour
Replies: 12
Views: 3362

Re: script for change public IP every hour

the code mean is: every hour the to-addresses be set to 8.8.8.129 8.8.8.130 8.8.8.131 8.8.8.132 8.8.8.133.....until to 8.8.8.254 if ithe to-addresses is 8.8.8.254 the code will set to-addresses is 8.8.8.129 restart ROS cannot be set random address but You can set different address per hour if you us...
by huigezi
Sun Jan 22, 2012 3:30 pm
Forum: Scripting
Topic: script for change public IP every hour
Replies: 12
Views: 3362

Re: script for change public IP every hour

first you must add a rules for: /ip firewall nat add action=src-nat chain=srcnat comment=1 disabled=no src-address=192.168.11.0/24 to-addresses=8.8.8.129 :do { #set rules comment :local com "1" #set start count :local start "129" #set ip address prefix :local prefix "8.8.8." /ip firewall nat :foreac...
by huigezi
Sun Jan 22, 2012 12:58 pm
Forum: Scripting
Topic: Script to log firewall address list
Replies: 11
Views: 4054

Re: Script to log firewall address list

click the [run script] or copy the script to the [system scheduler] for certain interval time run
by huigezi
Sun Jan 22, 2012 12:16 pm
Forum: Scripting
Topic: Script to log firewall address list
Replies: 11
Views: 4054

Re: Script to log firewall address list

ip address-list must have some dynamic or static address
by huigezi
Sun Jan 22, 2012 11:06 am
Forum: Scripting
Topic: Script to log firewall address list
Replies: 11
Views: 4054

Re: Script to log firewall address list

yes ,click the log you will find
by huigezi
Sun Jan 22, 2012 10:25 am
Forum: Scripting
Topic: Script to log firewall address list
Replies: 11
Views: 4054

Re: Script to log firewall address list

hi i want to look your script or i don't know how to hlep you , is this ??? :foreach a in=[/ip firewall address-list find dynamic=yes] do={ :local dyip [/ip firewall address-list get $a address]; :log warning ("the dynamic ip is : ".$dyip)} :foreach a in=[/ip firewall address-list find dynamic=no] d...
by huigezi
Sun Jan 22, 2012 4:52 am
Forum: Beginner Basics
Topic: PCC ISSUE 3 WAN
Replies: 6
Views: 1032

Re: PCC ISSUE 3 WAN

Need not be in such trouble use the code can set all configuration :global adsl “9” :global address “172.168.1.0/24” /interface pppoe-client :for a from=1 to=$adsl do= {add add-default-route=no dial-on-demand=no use-peer-dns=no name=("pppoe-out".$a) user=$a password=$a interface=(“ether”.($a+1)) } /...
by huigezi
Fri Jan 20, 2012 2:46 pm
Forum: Scripting
Topic: How to resolve and "NOT" (!) an address in 1 line
Replies: 13
Views: 1713

Re: How to resolve and "NOT" (!) an address in 1 line

:do {
:local com "drop"
:local ip [:resolve mysite.com]
:set ip ("!".$ip)
/ip firewall filter
:foreach a in=[find comment=$com] do={
:local cuip [get $a src-address];
:if ($cuip!=$ip) do={
set $a src-address=$ip
:log warning ("new ip is: ".$ip."src-address update is sucess")
}}};/;
by huigezi
Fri Jan 20, 2012 2:12 pm
Forum: Scripting
Topic: How to resolve and "NOT" (!) an address in 1 line
Replies: 13
Views: 1713

Re: How to resolve and "NOT" (!) an address in 1 line

use the code :do { :local com "drop" :local ip [:resolve mysite.com] /ip firewall filter :foreach a in=[find comment=$com] do={ :local cuip [get $a src-address]; :set cuip [:pick $cuip ([:find $cuip "!"]+1) ([:len $cuip])] :if ($cuip!=$ip) do={ set $a src-address=("!".$ip) :log warning ("new ip is: ...
by huigezi
Fri Jan 20, 2012 2:01 pm
Forum: Scripting
Topic: How to resolve and "NOT" (!) an address in 1 line
Replies: 13
Views: 1713

Re: How to resolve and "NOT" (!) an address in 1 line

can not use the "!" so

My English is not good to express much

I'm so sorry

Ok, Thanks.

So how to use the "!" ?
/ip firewall filter
add action=drop chain=forward comment=drop disabled=no src-address=!10.10.10.10
With the use of script
by huigezi
Fri Jan 20, 2012 1:39 pm
Forum: Scripting
Topic: How to resolve and "NOT" (!) an address in 1 line
Replies: 13
Views: 1713

Re: How to resolve and "NOT" (!) an address in 1 line

can not use the "!" so

My English is not good to express much

I'm so sorry
by huigezi
Fri Jan 20, 2012 1:29 pm
Forum: Scripting
Topic: How to resolve and "NOT" (!) an address in 1 line
Replies: 13
Views: 1713

Re: How to resolve and "NOT" (!) an address in 1 line

add a rule at [ip firewall filter] for example: /ip firewall filter add action=drop chain=forward comment=drop disabled=no src-address=10.10.10.10 the comment must be "drop" Of course you can modify their own then copy the script to scheduler and set 1m-10m interval for exambple the code is : :do { ...
by huigezi
Fri Jan 20, 2012 1:19 pm
Forum: Scripting
Topic: How to resolve and "NOT" (!) an address in 1 line
Replies: 13
Views: 1713

Re: How to resolve and "NOT" (!) an address in 1 line

hi
See your filter rules

Wait for me to help you write a script
by huigezi
Fri Jan 20, 2012 1:03 pm
Forum: Scripting
Topic: How to resolve and "NOT" (!) an address in 1 line
Replies: 13
Views: 1713

Re: How to resolve and "NOT" (!) an address in 1 line

hi

to say ,what you're going to do
by huigezi
Fri Jan 20, 2012 8:33 am
Forum: Scripting
Topic: Script/schedule to enable wlan1 on certain days
Replies: 5
Views: 2142

Re: Script/schedule to enable wlan1 on certain days

In week time to revise the strategy, hard work
by huigezi
Thu Jan 19, 2012 4:12 pm
Forum: Scripting
Topic: Need help with script to make simple queue for dhcp entries
Replies: 10
Views: 5789

Re: Need help with script to make simple queue for dhcp entr

/queue simple :foreach a in=[find] do={ :local tmpip [get $a target-addresses] /ip dhcp-server lease :foreach i in=[find] do={ :local oldip ([get $i address]."/32") :if ($oldip!=$tmpip && [:typeof $tmpip]!="nil") do={ /queue simple add name=[:pick $oldip 0 [:find $oldip "/"]] target-address=\ $oldi...
by huigezi
Thu Jan 19, 2012 10:40 am
Forum: General
Topic: ROS 5.11 x86 problem - unstable version
Replies: 29
Views: 5379

Re: ROS 5.11 x86 problem - unstable version

Since there are so many problems at 5.11

So I have been fortunate in 5.8
by huigezi
Wed Jan 18, 2012 5:24 am
Forum: Scripting
Topic: script for change public IP every hour
Replies: 12
Views: 3362

Re: script for change public IP every hour

Hello
This is for the Routeros cannot achieve However, you can create a rule for different to-addresses
Opening and closing to achieve through script
by huigezi
Tue Jan 17, 2012 1:14 pm
Forum: Scripting
Topic: how to know if ethernet is disabled
Replies: 3
Views: 1433

Re: how to know if ethernet is disabled

hi copy the script to system sheduler and set a certain time interval :/1m :do { :local int1 ether1 :local int5 ether5 :foreach a in=[/interface find name=$int1] do={ :local status [/interface get $a disabled]; :if ($status=true) do={ /interface disable [/interface find name=$int5];}; :if ($status!=...
by huigezi
Mon Jan 16, 2012 2:50 pm
Forum: Scripting
Topic: pppoe-client
Replies: 2
Views: 627

Re: pppoe-client

:do {
:local a [:len [/ppp active find name="test"]]
:if ($a="1") do={
/ppp secret disable test
}}
by huigezi
Mon Jan 16, 2012 2:21 pm
Forum: Scripting
Topic: Detecting user using service - need script help
Replies: 2
Views: 535

Re: Detecting user using service - need script help

hi first you must add a rules for example: /ip firewall filter add action=add-src-to-address-list address-list=list address-list-timeout=10s chain=forward comment="" disabled=no \ dst-address=10.10.20.1 dst-port=520 protocol=tcp src-address=10.10.10.1 then copy the script to system scheduler / set 1...
by huigezi
Sun Jan 08, 2012 10:21 am
Forum: General
Topic: Simple queue
Replies: 11
Views: 1570

Re: Simple queue

256k can do what?
by huigezi
Sun Jan 08, 2012 10:20 am
Forum: Scripting
Topic: IP Pool Statistics
Replies: 15
Views: 16682

Re: IP Pool Statistics

thanks
by huigezi
Sun Jan 08, 2012 10:15 am
Forum: Scripting
Topic: :resolve function and multiple ip addresses
Replies: 11
Views: 4295

Re: :resolve function and multiple ip addresses

find where

why to use the where? what mean?
by huigezi
Sat Dec 24, 2011 4:49 am
Forum: General
Topic: HTB,control all P2P upload
Replies: 1
Views: 689

HTB,control all P2P upload

效果2.jpg total upload=1M total download =8M script: :global count1 11 :global count2 21 :global count3 31 :global count4 41 :global count5 51 :global up0 200000 :global up1 160000 :global up2 128000 :global up3 100000 :global up4 64000 :global down0 0 :global down1 4000000 :global down2 3000000 :glo...