Community discussions

MUM Europe 2020

Search found 7 matches

by EtienneO
Wed May 18, 2016 4:33 pm
Forum: Scripting
Topic: How do you clear a global variable?
Replies: 11
Views: 12642

Re: How do you clear a global variable?

Script to clear all variables :if ([:len [/system script environment find]] != 0) do={ :for E from=0 to=([:len [/system script environment find]] - 1) do={ /system script environment remove $E }} Could just use: /system script environment remove [find] The command doesn't complain if nothing is fou...
by EtienneO
Wed May 18, 2016 11:06 am
Forum: Scripting
Topic: How do you clear a global variable?
Replies: 11
Views: 12642

Re: How do you clear a global variable?

Script to clear all variables

:if ([:len [/system script environment find]] != 0) do={
:for E from=0 to=([:len [/system script environment find]] - 1) do={
/system script environment remove $E
}}
by EtienneO
Thu May 14, 2015 3:43 am
Forum: Scripting
Topic: Issue with variables
Replies: 2
Views: 562

Re: Issue with variables

Thanks, that works, now I just have to figure out why :-) (It works)
by EtienneO
Thu May 14, 2015 12:23 am
Forum: Scripting
Topic: Issue with variables
Replies: 2
Views: 562

Issue with variables

How do I get this to return;
Hello
World

instead of;
1
2

:global Test1 Hello
:global Test2 World

:for n from 1 to 2 do={
:put "$Test$n"
}
by EtienneO
Fri Oct 04, 2013 1:20 pm
Forum: General
Topic: ChangeIP
Replies: 16
Views: 3087

Re: ChangeIP

I just reset my ChangeIP password now and it started working again. My details weren't working for the site anymore either though.
by EtienneO
Wed Oct 02, 2013 4:50 pm
Forum: General
Topic: ChangeIP
Replies: 16
Views: 3087

Re: ChangeIP

Reply on a ticket I submitted.
We have identified a problem that is affecting use of updates via devices and scripts. A fix is being implemented and should be in place within the next 24 hours. In the meantime, manual updates via DNS Manager are working. Thank you for your patience.
by EtienneO
Tue Jan 15, 2013 8:34 pm
Forum: Scripting
Topic: ChangeIP and Mikrotik 5.0
Replies: 22
Views: 9360

Re: ChangeIP and Mikrotik 5.0

Hy. From the beginning of MT 5.x I am using the script that is tested on MT3.x and MT4.x that is published on the adress http://www.changeip.com/MikroTik/ It worked great for me until 2 days ago. Since then I can not update IP adress and there is an error in MT Log: ddns error connect error. I also...