Community discussions

Search found 43 matches

by shdwmstff
Wed Mar 27, 2019 7:09 pm
Forum: The Dude
Topic: Fearute request - Polling multiple IP of the device
Replies: 3
Views: 1039

Re: Fearute request - Polling multiple IP of the device

I Agree.. this is needed. I have some remote locations that I monitor that has 2 connections. I need to poll both interfaces so I can see if one of the connections is down. if they could ad a little option with the PROBE or ping section that would allow you to specify either an ip address or "Defaul...
by shdwmstff
Tue Mar 26, 2019 9:14 pm
Forum: The Dude
Topic: NO IP ADDRESS?
Replies: 1
Views: 473

NO IP ADDRESS?

Using the DUDE I remotely monitor some devices that have Dynamic DNS ip's Just to see if they are up. In the DUDE it will not let me setup a device with out an IP address. And it won't poll using something other than an ip address. Am I missing something. I can't make the ip address in the Settings ...
by shdwmstff
Fri Mar 15, 2019 8:35 pm
Forum: The Dude
Topic: Dude notification queue pause or clear?
Replies: 0
Views: 379

Dude notification queue pause or clear?

Have a couple hundred devices running in the dude. If a device goes down it uses an email notification to let me know about the outage. Any way to manage the notification queue... If something tragic happens ( connectivity at the dude server) the dude server will send me 200+ down emails.. then 200+...
by shdwmstff
Mon Jan 07, 2019 10:04 pm
Forum: Forwarding Protocols
Topic: BGP Over GRE-- HOLD Timer Expired Subcode Zero
Replies: 8
Views: 1073

Re: BGP Over GRE-- HOLD Timer Expired Subcode Zero

Could it be related to having 2 Loopbacks on this router? One for GRE Tunnels and another for peering sessions? I clipped out all the unnecessary routing lines.. would make this a unnecessarily long post Ip scheme is as follows Router A Interface IP 192.168.1.1/24 Loopback1 192.168.2.1/32 (used for ...
by shdwmstff
Mon Jan 07, 2019 4:21 pm
Forum: Forwarding Protocols
Topic: BGP Over GRE-- HOLD Timer Expired Subcode Zero
Replies: 8
Views: 1073

Re: BGP Over GRE-- HOLD Timer Expired Subcode Zero

In the situation that I have there are no firewall rules..
This device is just routing.
So three should be no reason anything should be blocked.
by shdwmstff
Fri Jan 04, 2019 8:14 pm
Forum: Forwarding Protocols
Topic: BGP Over GRE-- HOLD Timer Expired Subcode Zero
Replies: 8
Views: 1073

Re: BGP Over GRE-- HOLD Timer Expired Subcode Zero

More--INFO I did some debugging trying to see where the keepalives are being lost. Here is a snippet of the log data. Every 3 minutes the process just repeats It looks like router B is sending and receiving. But router A is sending only? ---------------------------------------------------- ROUTER A ...
by shdwmstff
Fri Jan 04, 2019 5:38 pm
Forum: Forwarding Protocols
Topic: BGP Over GRE-- HOLD Timer Expired Subcode Zero
Replies: 8
Views: 1073

Re: BGP Over GRE-- HOLD Timer Expired Subcode Zero

Just to confirm. what should I be looking for? Ip scheme is as follows Router A Interface IP 192.168.1.1/24 Tunnel 10.10.1.1/30 OSPF Neighbor 10.10.1.2 (UP, and passing routes) Bgp Peer 10.10.1.2 Router B Interface IP 192.168.1.50/24 Tunnel IP 10.10.1.2/30 OSPF Neighbor 10.10.1.1 (UP, and passing ro...
by shdwmstff
Fri Jan 04, 2019 4:48 pm
Forum: Forwarding Protocols
Topic: BGP Over GRE-- HOLD Timer Expired Subcode Zero
Replies: 8
Views: 1073

BGP Over GRE-- HOLD Timer Expired Subcode Zero

Have a GRE tunnel between 2 locations. All works fine has been for years.. Have multiple connections into this location so wanted to setup bgp like I have in the rest of my network. Tunnel is stable... passes static routes fine.. and I have OSPF running over it also.. When I went to setup BGP .. it ...
by shdwmstff
Fri Apr 20, 2018 10:57 pm
Forum: Scripting
Topic: Built in function library
Replies: 52
Views: 12472

Re: Built in function library

SNMP-GET
I would like to poll external devices and have based on the results change routes, enable/disable interfaces.
It would be a nice feature.
by shdwmstff
Thu Apr 19, 2018 12:23 am
Forum: Scripting
Topic: Mikrotik Polling rssi via SNMP
Replies: 0
Views: 338

Mikrotik Polling rssi via SNMP

I have an instance where a radio link that is connected to a Mikrotik router flaps some times, during heavy rain fade. When it does it causes the expected problems with route flapping. The router has 2 upstream links. I wanted to know if the scripting in the Mikrotik could poll the radio and if it s...
by shdwmstff
Fri Dec 18, 2015 10:49 pm
Forum: Scripting
Topic: dump traceroute to file
Replies: 12
Views: 4222

Re: dump traceroute to file

ok I have been having a problem where a remote circuit fails intermittently and is causing packet loss. but by the time I get to the device I don't see any of the errors and can't pinpoint where the failure is occuring. And as always the upstream gives me the DE-FACTO "Everything is running clean" l...
by shdwmstff
Fri Dec 18, 2015 7:29 pm
Forum: Scripting
Topic: dump traceroute to file
Replies: 12
Views: 4222

Re: dump traceroute to file

WHOLEY FANTASTIC-NESS!!!!


it works on 6.33
but not on 6.29
I suspect some weird version bug... but that gets me in the right direction.
curious if it will append...for me but , I'm not complaining.!

Thank you
by shdwmstff
Thu Dec 17, 2015 5:16 pm
Forum: Scripting
Topic: dump traceroute to file
Replies: 12
Views: 4222

Re: dump traceroute to file

Did you ever find a solution for dumping the traceroute to a file.
I have a similar situation where I see a GRE tunnel dropping and want to confirm where in the traceroute it is
getting dropped.

Thanx
by shdwmstff
Tue Aug 25, 2015 7:24 pm
Forum: General
Topic: WINBOX Loading IP/pw info on start
Replies: 1
Views: 743

WINBOX Loading IP/pw info on start

Have many mikrotik routers/switches have them all mapped using whatsup Gold. to manage just have to click on link and it will start winbox on selected router. Runs this command winbox.exe 192.168.1.1 It puts the ip in the "Connect To" box would like it to populate the password and other fields also ...
by shdwmstff
Tue Aug 25, 2015 6:37 pm
Forum: Forwarding Protocols
Topic: MPLS/VPLS/MTU Question
Replies: 5
Views: 1115

Re: MPLS/VPLS/MTU Question

Been running through the logging/debug of LDP, it doesn't give much output. I have this working fine in a test bed environment. When I implemented it on live network, the VPLS interfaces didn't come up.. R1 says "Running,Slave" R3 says "Slave" NOTE: I think I mislabeled the pic at the beginning of p...
by shdwmstff
Fri Aug 21, 2015 6:26 pm
Forum: Forwarding Protocols
Topic: MPLS/VPLS/MTU Question
Replies: 5
Views: 1115

Re: MPLS/VPLS/MTU Question

There was not documentation on how to include the vlans into the ldp and mpls setup. This link shows how to setup the VPLS connection on basic router to router Although if their is a switch and vlans in between the routers... I doesn't explain how you would set the vlans in the LDP interface and the...
by shdwmstff
Fri Aug 21, 2015 6:01 pm
Forum: Forwarding Protocols
Topic: MPLS/VPLS/MTU Question
Replies: 5
Views: 1115

Re: MPLS/VPLS/MTU Question

The L2MTU on all the physical interfaces are 5198 .. so that should be safe. Another question. I don't need to have the VLANS that the routers are peering on in the MPLS Interface? Just in the LDP Interfaces? should I have them in both... this is where things get confusing on where they should be ad...
by shdwmstff
Thu Aug 20, 2015 11:43 pm
Forum: Forwarding Protocols
Topic: MPLS/VPLS/MTU Question
Replies: 5
Views: 1115

MPLS/VPLS/MTU Question

I know that this has been asked previously and I can't seem to get a definitive answer on this... so I would like to ask the question using the below diagram. Try to do a simple setup here. The part of the MTU Question I think I'm getting lost at is.. MTU is listed in 5 different places .. and want ...
by shdwmstff
Fri Apr 03, 2015 10:41 pm
Forum: Forwarding Protocols
Topic: What BGP setups need to be optimized
Replies: 58
Views: 20970

Re: What BGP setups need to be optimized

Anyway to Bind more cores to the routing processes?
Currently see only core dealing with this... would like to see more CPU for this.
by shdwmstff
Mon Mar 30, 2015 11:56 pm
Forum: Forwarding Protocols
Topic: CCR - BGP performance
Replies: 45
Views: 20054

Re: CCR - BGP performance

Sorry to jump in last minute... I am using 1000's and 1100AHx2's ..(just added in a CCr1036) Is bgp still only being done on one core? Has Mikrotik addressed this? If only one core can do the bgp process... the other 35 are not as usefull also Is there benchmarkes on the CCr cores? 1.2ghz ? If I can...
by shdwmstff
Thu Apr 24, 2014 7:06 pm
Forum: General
Topic: SNMP Doesn't respond on all IP's/Interfaces
Replies: 9
Views: 2225

Re: SNMP Doesn't respond on all IP's/Interfaces

I removed what I had to for security reasons... hope it doesn't make this info Unusable. I have it working on an interface now... just preffered to use the loopback address, making it easier. in the long run. /snmp community set [ find default=yes ] addresses=x.x.x.x/x name=xxxxxxxxx /snmp set conta...
by shdwmstff
Thu Apr 24, 2014 6:26 pm
Forum: General
Topic: SNMP Doesn't respond on all IP's/Interfaces
Replies: 9
Views: 2225

Re: SNMP Doesn't respond on all IP's/Interfaces

no firewall.. just routing...
we don't block traffic on these routers.. they just move traffic... customers routers further downstream deal with all the firewalling etc..
by shdwmstff
Thu Apr 24, 2014 5:51 pm
Forum: General
Topic: SNMP Doesn't respond on all IP's/Interfaces
Replies: 9
Views: 2225

Re: SNMP Doesn't respond on all IP's/Interfaces

Was using 5.16 and it was doing the same thing.. so I upgraded to 6.12 before I started asking questions... assumed I'de get the defacto "Upgrade to newest version first" request .. :)
by shdwmstff
Thu Apr 24, 2014 5:38 pm
Forum: General
Topic: SNMP Doesn't respond on all IP's/Interfaces
Replies: 9
Views: 2225

Re: SNMP Doesn't respond on all IP's/Interfaces

yes.. we use ospf with BGP on the network..
I can ssh/winbox/telnet/tracreoute to all the interfaces on the router... but it just won't respond via snmp on all of the interfaces.
by shdwmstff
Thu Apr 24, 2014 4:43 pm
Forum: General
Topic: SNMP Doesn't respond on all IP's/Interfaces
Replies: 9
Views: 2225

SNMP Doesn't respond on all IP's/Interfaces

Running new 6.12 on routers. Using routers with multiple paths in our network. SNMP only responds on the current active interfaces.. so if routes change and traffic goes a different direction my mrtg stats fail. What I would like to do is have the snmp respond on a loopback address and do all the po...
by shdwmstff
Tue Apr 01, 2014 8:19 pm
Forum: General
Topic: Queue on VPLS
Replies: 6
Views: 1553

Re: Queue on VPLS

I have tried to setup the traffic eng.. but I don't see how it relates to the VPLS Tunnel. Primary path says "unknown" This is the VPLS Config. rtr1 0 R name="test1" mtu=1500 l2mtu=1500 mac-address=02:02:B8:0D:93:CE arp=enabled disable-running-check=no remote-peer=a.b.c.d vpls-id=0:1 cisco-style=no ...
by shdwmstff
Fri Jan 03, 2014 2:47 pm
Forum: General
Topic: Queue on VPLS
Replies: 6
Views: 1553

Re: Queue on VPLS

can you elaborate on the method of queuing the traffic with a mpls tag?
is there any example?

thanx
by shdwmstff
Mon Dec 30, 2013 6:38 pm
Forum: General
Topic: Queue on VPLS
Replies: 6
Views: 1553

Re: Queue on VPLS

I have also tried to set the interface to be the actual VPLS Tunnel .. and it doesn't work either
by shdwmstff
Thu Dec 26, 2013 5:22 pm
Forum: General
Topic: Queue on VPLS
Replies: 6
Views: 1553

Queue on VPLS

have a vpls connection running across network..(works fine) customer wants 10mb usage currently. Currently I have controlled the Bandwidth by setting the port speeds on both end devices as 10mb Full duplex. if I set them to 100 full duplex and try to queue the traffic it doesn't queue the traffic at...
by shdwmstff
Thu Oct 25, 2012 8:14 pm
Forum: Forwarding Protocols
Topic: OSPF Maximum Paths
Replies: 4
Views: 1907

Re: OSPF Maximum Paths--RESOLVED--

Ahh I see.the multiple gateways defined to the right of the default route.. I wasn't paying attention.
Thanx so much for the clarification
by shdwmstff
Thu Oct 25, 2012 4:13 pm
Forum: Forwarding Protocols
Topic: OSPF Maximum Paths
Replies: 4
Views: 1907

Re: OSPF Maximum Paths

I have 2 routers connected to the internet and both announce a default route with OSPF to the internal Network Routers. The internal network routers are peered to both edge routers and only has one default OSPF route in the routing table. I would like it to see both default paths and pass traffic to...
by shdwmstff
Wed Oct 24, 2012 10:52 pm
Forum: Forwarding Protocols
Topic: OSPF Maximum Paths
Replies: 4
Views: 1907

OSPF Maximum Paths

Trying to setup Maximum path ospf scenario between my RB1100 and 2 Cisco 7200's

should be able to receive 2 ospf default routes and load balance the traffic.

Any Ideas on what Mikrotik calls the maximum paths ?

Thanx
by shdwmstff
Mon Sep 10, 2012 4:23 pm
Forum: General
Topic: V6 How Close to Stable?
Replies: 3
Views: 1669

V6 How Close to Stable?

How Close is The V6 Beta to being considered stable.
by shdwmstff
Thu Sep 06, 2012 10:26 pm
Forum: RouterBOARD hardware
Topic: Routerboard Diagnostic tests
Replies: 2
Views: 1696

Routerboard Diagnostic tests

Is there a Downloadable set of Diagnostic tests for routerboards? I suspect they QC tested before they leave the factory? Can we get the software that they run on them to confirm they work correctly? every once in a while I have one fail .. and it requires reboot. it all works fine .. sometimes it j...
by shdwmstff
Fri Aug 31, 2012 10:38 pm
Forum: Beginner Basics
Topic: Routerboard 230 New os install problem.
Replies: 3
Views: 703

Re: Routerboard 230 New os install problem.

I don't have the option update-license-key... below are the options.. I tried the update-key option and it gives an error. See below --------------------------- import Import a key file output Exports the current key to a key file loose-key print Show license information get Gets value of item's pro...
by shdwmstff
Fri Aug 31, 2012 9:50 pm
Forum: Beginner Basics
Topic: Routerboard 230 New os install problem.
Replies: 3
Views: 703

Routerboard 230 New os install problem.

Have RB230 running 2.8 still it works but would like to update it to new OS version. Unlike the new 8 digit licenses it is still only 7 and has a date that says only good till oct/1/2005 from what I read it can be update .. the license can be upgraded , after I ran a net install and got it up to 3.3...
by shdwmstff
Tue Aug 14, 2012 7:12 pm
Forum: Wireless Networking
Topic: WISP Radius accounting for minutes/Traffic
Replies: 1
Views: 910

WISP Radius accounting for minutes/Traffic

Looking to setup a wifi hotspot that authenticates off radius and is time based, or traffic based.
Pretty much selling minutes or total traffic.

Using the hotspot "Iterim update" option would that notify the radius server of actual time or data/MBs used to know when to disconnect the user?

thanx
by shdwmstff
Tue Aug 14, 2012 4:33 pm
Forum: General
Topic: Simple QUEUE
Replies: 1
Views: 3556

Simple QUEUE

Using simple queue to limit bandwidth on an interface, And user is complaining that they can only receive total bandwidth in one direction at a time. this is the config. When doing a transfer currently using almost 10mb upload for an hour.. they were unable to pull more than 3 megs down at the same ...
by shdwmstff
Mon Jun 25, 2012 5:18 pm
Forum: Forwarding Protocols
Topic: VPLS requires reset after upstream circuit failure.
Replies: 4
Views: 1582

VPLS requires reset after upstream circuit failure.

Running 2 Routerboard 1100's have vpls tunnel connecting 2 locations.
after a circuit failure upstream,between the 2 locations , the link didn't come back up, till it was manually reset.
Running ROS 5.15 on router A and 5.11 On router B
by shdwmstff
Fri Jun 22, 2012 5:34 pm
Forum: General
Topic: Clear Port/Interface Counters
Replies: 2
Views: 1287

Clear Port/Interface Counters

Recommendation for the new OS..
A way to clear port/interface counters?
its a simple option... but can't seem to do it without rebooting.. which doens't seem good for uptime
by shdwmstff
Thu Jun 07, 2012 2:02 pm
Forum: Forwarding Protocols
Topic: VPLS having problems passing traffic
Replies: 13
Views: 9862

Re: VPLS having problems passing traffic

Try finding out what the largest mtu you can pass correctly is.. using the ping command start dropping the mtu by 10 till it works. After that... set the MTU on the VPLS interfaces to be 10 less ... That worked for me... It increased the fragmentation making all the packet sizes work. Wish there was...
by shdwmstff
Wed Jun 06, 2012 4:22 pm
Forum: Forwarding Protocols
Topic: VPLS having problems passing traffic
Replies: 13
Views: 9862

Re: VPLS having problems passing traffic

I was able to get mine to work by dropping down the VPLS MTU to be 1440 for the time being I'm leaving it be. and will work more on this via test bed... it would be good it there was a basic config in the Mikrotik site/manual/wiki on how to set this up. something as basic as 2 routers connected toge...
by shdwmstff
Wed May 30, 2012 12:02 am
Forum: RouterBOARD hardware
Topic: Routerboard hardware diagnostics
Replies: 3
Views: 2713

Re: Routerboard hardware diagnostics

That would be a nice option.