Community discussions

MUM Europe 2020

Search found 18 matches

by headshoter
Fri Jan 06, 2017 1:08 am
Forum: General
Topic: Marking Socks Connections
Replies: 7
Views: 1089

Re: Marking Socks Connections

Where in the diagram above is the SOCKS proxy located?
Proxy client is located on LAN, and the server is mikrotik. Do you have a solution for this case?


Sent from my iPhone using Tapatalk
by headshoter
Fri Jan 06, 2017 1:06 am
Forum: General
Topic: Marking Socks Connections
Replies: 7
Views: 1089

Re: Marking Socks Connections

I understand what you want, but I don't think it's possible (in a clean no-sideeffects way). Unless there's a feature that I don't know about, that would mark connections made by proxy (I'm pretty sure there isn't, but it could be interesting if it was), you can't tell proxy traffic from other traf...
by headshoter
Thu Jan 05, 2017 9:22 am
Forum: General
Topic: Marking Socks Connections
Replies: 7
Views: 1089

Re: Marking Socks Connections

assume that mikrotik has 192.168.1.1 as default gateway, but for socks traffic i want to route the traffic through 10.1.1.1 instead of 192.168.1.1. i mean on a single LAN, users not using SOCKS should route to 192.168.1.1, and users that are using SOCKS need to be routed to 10.1.1.1 i've also attach...
by headshoter
Wed Jan 04, 2017 11:14 am
Forum: General
Topic: Marking Socks Connections
Replies: 7
Views: 1089

Marking Socks Connections

Hello, I need to Route Mark the Socks connections to my router, so after that i can do some PBR. But i could not get any success. i've tried marking by source address but couldn't get any luck. P.S:when i dont use socks, and route normally through the MikroTik, the marking and PBR work fine based on...
by headshoter
Thu Feb 12, 2015 1:05 pm
Forum: General
Topic: monitor PPP Connections traffic usage
Replies: 0
Views: 279

monitor PPP Connections traffic usage

Hello,
i'm wondering if there is a way to monitor each ppp client (pptp,l2tp,..defined in ppp/secrets) traffic usage and get some weekly/daily report on that?
do you have any suggestions?
by headshoter
Mon Sep 15, 2014 5:25 pm
Forum: General
Topic: LoadBalancing ISA Traffic using PCC
Replies: 0
Views: 489

LoadBalancing ISA Traffic using PCC

Hello, I have 3 WAN link (1MB,2MB,4MB). my clients get access to the internet by setting proxy on their pc and their traffic will be sent to the ISA server and ISA will ... http://upload7.ir/imgs/2014-09/01418954784161718331.jpg I'm going to config PCC on my MikroTik router so the clients can use al...
by headshoter
Mon Aug 04, 2014 8:02 pm
Forum: Scripting
Topic: Daily traffic limit on userman
Replies: 1
Views: 1208

Re: Daily traffic limit on userman

I got a problem with the above script , if i enter wrong profile name in comment of some user , the rest of my loop will be interrupted, for example i have one profile named "512(500MB)" , if i add for example 512(500) to some user (for example user number 5) as comment, the rest of loop will not wo...
by headshoter
Sun Aug 03, 2014 11:24 pm
Forum: Scripting
Topic: Daily traffic limit on userman
Replies: 1
Views: 1208

Daily traffic limit on userman

Hello, i want to use an script to add some traffic to userman users daily, then i wrote the below script , in this sample i set profiles validity to 1 day , and add the profile to each user daily . i used comment attribute to save the profile that should be added to users daily (i didnt use actual-p...
by headshoter
Sun Jul 13, 2014 12:54 pm
Forum: Scripting
Topic: Null value returning instead of Usernam!
Replies: 1
Views: 536

Null value returning instead of Usernam!

Hello ,
i ran this line of script to get my userman users's username, but it will show null in log! if i switch username attribute to comment it'll work like a charm :)
do you have any idea of why this happening ?
:log info [tool user-manager user get 1 username]
by headshoter
Fri Mar 21, 2014 11:52 am
Forum: General
Topic: Netwatch issue
Replies: 5
Views: 990

Re: Netwatch issue

i can not get clear about what you gonna do , but
im thinking your problem is you are watching your modem ip (for example 192.168.1.1) instead of something like 8.8.8.8.
by headshoter
Wed Mar 19, 2014 8:54 pm
Forum: General
Topic: Feature request: OpenVPN compression LZO and UDP
Replies: 200
Views: 94591

Re: Feature request: OpenVPN compression LZO and UDP

+1
what the developer/support team does is not about anything but not caring/listening to user voices
by headshoter
Thu Mar 13, 2014 6:36 pm
Forum: General
Topic: Netwatch issue
Replies: 5
Views: 990

Re: Netwatch issue

would you please give me more information ?
why you use netwatch ? ...
by headshoter
Wed Mar 12, 2014 9:02 pm
Forum: General
Topic: Netwatch issue
Replies: 5
Views: 990

Re: Netwatch issue

in case u r using for failover :
/ip route add dst-address=8.8.4.4 gateway=FISRT MODEM IP
/ip route add dst-address=4.2.2.2 gateway=SECOND MODEM IP
then you should watch 8.8.4.4 and 4.2.2.2 and ...
by headshoter
Tue Mar 04, 2014 4:32 pm
Forum: Scripting
Topic: CPU 100% during a for loop
Replies: 5
Views: 1120

Re: CPU 100% during a for loop

Ok, I rewrite from 0 with more logical order: :foreach queueTest in=[ /queue simple find where total-bytes > 50000 ] do={ :if ( [/queue simple get $queueTest target] in 192.168.7.0/24) do={ /ip firewall address-list add address=[/queue simple get $queueTest target] list=No_internet; } }; the if sta...
by headshoter
Tue Mar 04, 2014 1:00 pm
Forum: Scripting
Topic: CPU 100% during a for loop
Replies: 5
Views: 1120

Re: CPU 100% during a for loop

Fixed logical problem. Your version have target-addresses instead of target!!! ROS 6.7: /queue simple :for i from=1 to=254 do={ :if ([get [find where target=[:toip ("192.168.7.".$i)] ] total-bytes] > 50000) do={ /ip firewall address-list add address=("192.168.7.".$i) list=No_internet } } upgraded m...
by headshoter
Tue Mar 04, 2014 10:23 am
Forum: Scripting
Topic: CPU 100% during a for loop
Replies: 5
Views: 1120

CPU 100% during a for loop

Hello , i wrote this script to add target address of simple queues that have total bytes greater than 50000 to a firewall address list, but during performing the script my cpu usage stands at 100% for about 3 minutes !!! p.s : im using rb750G as my router . does anyone have better idea to get handle...
by headshoter
Fri Mar 29, 2013 6:11 pm
Forum: General
Topic: OpenVPN between Mikrotik and Windows
Replies: 0
Views: 318

OpenVPN between Mikrotik and Windows

Hello , I've already configured an Mikrotik-to-Mikrotik OpenVPN tunnel and it works fine . But I thing I should have a client certificate in case I would like to connect to Mikrotik from Windows. can anyone please tell me how can I get certificate for my windows or does client-certificate really ne...
by headshoter
Thu Mar 28, 2013 11:58 pm
Forum: General
Topic: How to connect windows to mikrotik using Openvpn
Replies: 0
Views: 311

How to connect windows to mikrotik using Openvpn

Hi , I've already can establish a tunnel between two Mikrotiks by OpenVPN... I've got my server certificates from comodo , and imported them into my Mikrotik (server side) I know when I want to connect two Mikrotiks together by OpenVPN , I do not need any certificate for my client side , but it seem...