Community discussions

MikroTik App

Search found 53 matches

by dotnet
Sat Jun 22, 2013 1:21 pm
Forum: Beginner Basics
Topic: simple web proxy crashes after about ten seconds
Replies: 2
Views: 1084

Re: simple web proxy crashes after about ten seconds

i think you will re-setup your web-proxy in your Mikrotik. if you again face the same problem, please show your configuration.
by dotnet
Sat Jun 22, 2013 10:13 am
Forum: Beginner Basics
Topic: P2p limiting
Replies: 15
Views: 12349

Re: P2p limiting

To configure 10k for p2p traffic.

/queue simple
add target-address=<network_address_of_your_local_network> max-limit=10k/10k p2p=all-p2p

It limits widely used p2p protocols, except encrypted p2p.


best regards
by dotnet
Sun May 26, 2013 7:27 am
Forum: General
Topic: Traffic Slow with webproxy transparent
Replies: 13
Views: 6451

Re: Traffic Slow with webproxy transparent

@karina We made a RB1100 with full BGP feed on it. Routing traffic from clients to up to 10 000 random Internet IPs a) Connection tracking disabled - 1200-1300Mbps b) Connection tracking enabled, but no firewall rules - 680-750Mbps c) Connection tracking enabled, all traffic passes trough 100 firewa...
by dotnet
Sat May 25, 2013 11:16 am
Forum: General
Topic: Traffic Slow with webproxy transparent
Replies: 13
Views: 6451

Re: Traffic Slow with webproxy transparent

@karina

how much Traffic is passing ???
its depend on your Router (Firewall filter & configuration)
Actually micro sd card is not suitable for heavy data transfer.


best regards
by dotnet
Fri May 24, 2013 8:07 am
Forum: General
Topic: 2 Lan's, 2 Wan's, PCC load balancing and proxy
Replies: 1
Views: 24708

Re: 2 Lan's, 2 Wan's, PCC load balancing and proxy

@xtrego / ip address add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local add address=192.168.2.1/24 network=192.168.2.0 broadcast=192.168.2.255 interface=wan1 add address=192.168.4.1/24 network=192.168.4.0 broadcast=192.168.4.255 interface=wan2 /ip route add dst-ad...
by dotnet
Fri May 24, 2013 7:34 am
Forum: General
Topic: Web Proxy for small network
Replies: 36
Views: 9604

Re: Web Proxy for small network

@max

it's a basic upgrade or upload system for Mikrotik Router.
you may follow the link for reference:
http://wiki.mikrotik.com/wiki/Manual:Upgrading_RouterOS


best regards
by dotnet
Wed May 22, 2013 6:53 am
Forum: General
Topic: Web Proxy for small network
Replies: 36
Views: 9604

Re: Web Proxy for small network

@max open your winbox then drag & drop all package of 6.0 in you winbox file menu. then go to system >> upgrade >> upgrade package source >> click + sign >> router ip address >> admin >> password (router password) >> Apply. then you will reboot the system. i hope your system will upgrade automatical...
by dotnet
Fri May 17, 2013 6:17 pm
Forum: General
Topic: Web Proxy for small network
Replies: 36
Views: 9604

Re: Web Proxy for small network

@max i don't know what's your actual hotspot configuration. Here is a Example: /ip address add address=192.168.0.1/24 comment=Out to users disabled=no interface=LAN network=192.168.0.0 add address=192.168.1.6/24 comment=INTERNET disabled=no interface=WAN network=192.168.1.0 /ip pool add name=hs-pool...
by dotnet
Thu May 16, 2013 7:16 am
Forum: General
Topic: Web Proxy for small network
Replies: 36
Views: 9604

Re: Web Proxy for small network

@max

what's your method for internet user ?
pppoe or ip base ???
have you any load balancing ?
pls export your configuration ...

best regards
by dotnet
Tue May 14, 2013 6:51 am
Forum: General
Topic: Web Proxy for small network
Replies: 36
Views: 9604

Re: Web Proxy for small network

@max You can block file download by Mikrotik Proxy. Example /ip proxy access add path=*.avi action=deny /ip proxy access add path=*.flv action=deny /ip proxy access add path=*.mkv action=deny You can block any web site via domain name. Example: /ip proxy access add action=deny disabled=no dst-host=f...
by dotnet
Sun May 12, 2013 6:46 am
Forum: General
Topic: Web Proxy for small network
Replies: 36
Views: 9604

Re: Web Proxy for small network

@ max

what about your Mikrotik-Proxy ?
by dotnet
Tue May 07, 2013 6:30 am
Forum: General
Topic: Web Proxy for small network
Replies: 36
Views: 9604

Re: Web Proxy for small network

@ karina

Don't use "always from cache" for Mikrotik Web-proxy.
This is one kind of force command.
So it will be missing sometimes & user will be get an error page (By default).
Bcoz Mikrotik Web-proxy is a Basic Web-proxy.


Best regards
by dotnet
Sat May 04, 2013 7:12 am
Forum: General
Topic: Web Proxy for small network
Replies: 36
Views: 9604

Re: Web Proxy for small network

/ ip address add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local add address=192.168.2.1/24 network=192.168.2.0 broadcast=192.168.2.255 interface=Wan (Connected with Mikrotik & Proxy-server by Cross cable which is your Wan) /ip route add dst-address=0.0.0.0/0 gatew...
by dotnet
Sat May 04, 2013 6:32 am
Forum: General
Topic: Web Proxy for small network
Replies: 36
Views: 9604

Re: Web Proxy for small network

@max please install the Mikrotik Software in your pc. then you will active Web-proxy & activate your secondary hard disk for data caching. Then what's your method for your client pc's ? I will solve your problem with your method or policy. please show me your previous Router configuration. best rega...
by dotnet
Mon Apr 29, 2013 6:50 am
Forum: General
Topic: How to Block Hotspot Shield
Replies: 10
Views: 9884

Re: How to Block Hotspot Shield

ok. Actually you have to need more customization in firewall rules. Here is the solution. Detect and Block Hotspot Shield program traffic (vpn application) /ip firewall mangle add action=add-dst-to-address-list address-list=WhiteList \ address-list-timeout=4d4h chain=prerouting comment=WhiteList con...
by dotnet
Sun Apr 28, 2013 6:30 am
Forum: General
Topic: Web Proxy for small network
Replies: 36
Views: 9604

Re: Web Proxy for small network

@ reinerotto

Thanks. i know what is Squid/LUSCA (Nginx,Ruby,storeurl.pl)
if anyone want to advise from me, i will try to give him suggestion.


best regards
by dotnet
Sat Apr 27, 2013 7:12 am
Forum: General
Topic: Web Proxy for small network
Replies: 36
Views: 9604

Re: Web Proxy for small network

@ ba7abak Actually Mikrotik Web-proxy is a Basic proxy-server. Not for customization proxy service. So Master pc have (1 LAN - 2 WAN ) the second pc have 2 LAN (if it's Mikrotik) Otherwise second pc have to need (1 Lan - 1 WAN) [for Squid server] @ reinerotto New user can not properly setup & mainta...
by dotnet
Fri Apr 26, 2013 10:03 am
Forum: General
Topic: How to Block Hotspot Shield
Replies: 10
Views: 9884

Re: How to Block Hotspot Shield

please try this link. i hope you have got something.

http://wiki.mikrotik.com/wiki/How_to_De ... ication%29



best regards
by dotnet
Fri Apr 26, 2013 8:36 am
Forum: General
Topic: Web Proxy for small network
Replies: 36
Views: 9604

Re: Web Proxy for small network

if you want to build an external Mikrotik web server for caching,
so you have to need a pc which have P3 or P4 Processor, 2GB Ram, 2 hard disk
(one is for operating system & 2nd is for data caching), 2 Lan Card & Thermal casing.
then you will make a good web-proxy server.


best regards
by dotnet
Wed Apr 24, 2013 6:42 am
Forum: General
Topic: Web Proxy for small network
Replies: 36
Views: 9604

Re: Web Proxy for small network

ok. I think your mikrotik product RB951-2n is not support any Memory card or Usb stick. So you have to need an external PC that will be caching content. Otherwise you can't do it. Now you will make a Squid server or External Mikrotik Web proxy server for giving your client this type of service. I wi...
by dotnet
Sun Apr 21, 2013 7:28 am
Forum: General
Topic: Web Proxy for small network
Replies: 36
Views: 9604

Re: Web Proxy for small network

http://forum.mikrotik.com/viewtopic.php?f=2&t=70400


*** just try to follow the rules & don't copy-paste.


then give me feedback what do you want actually & send me your configuration



best regards
by dotnet
Tue Mar 19, 2013 11:48 am
Forum: Beginner Basics
Topic: Problems with PCC and Web Proxy
Replies: 11
Views: 3839

Re: Problems with PCC and Web Proxy

I hope it will be work for you. Bcoz i have solve some problem with this nat for web proxy. Please don't copy-pase. Just follow the rule: /ip firewall nat add action=redirect chain=dstnat comment="redirekt port 80 na web proxy port 8080" disabled=no dst-port=80 in-interface=!ether4 protocol=tcp to-p...
by dotnet
Tue Mar 19, 2013 11:26 am
Forum: Beginner Basics
Topic: 2xWAN,2xLAN, internal servers with full balancing/failover
Replies: 7
Views: 2914

Re: 2xWAN,2xLAN, internal servers with full balancing/failov

Here is describes 2 Method for your load balancing (PCC & ECMP) Please don't copy-paste. Just follow the rules: ++++ PCC ++++ / ip address add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local add address=192.168.2.1/24 network=192.168.2.0 broadcast=192.168.2.255 int...
by dotnet
Mon Mar 18, 2013 6:57 am
Forum: Beginner Basics
Topic: qos with pcc
Replies: 3
Views: 1273

Re: qos with pcc

1st your have to need setup a bridge then it will be ok
pls follow the rules :

/ interface bridge
add name="bridge1"
/ interface bridge port
add interface=ether2 bridge=bridge1
add interface=ether3 bridge=bridge1

/interface bridge settings
set use-ip-firewall=yes


Best regards
by dotnet
Thu Mar 14, 2013 12:49 pm
Forum: Beginner Basics
Topic: P2p limiting
Replies: 15
Views: 12349

Re: P2p limiting

already i told that 1mb = 1024000 so you will multiply your acutual bandwidth quantity. *** just for example 50 mb = (1024000 x 50)= 51200000 (Max Limit for Main) Now try yourself. I hope you will success ... you have to setup Bridge in your Router for Better performances. just follow the rules / in...
by dotnet
Thu Mar 14, 2013 12:09 pm
Forum: Beginner Basics
Topic: P2p limiting
Replies: 15
Views: 12349

Re: P2p limiting

yes it will be work. if your line is 1 mb *** 1mb = 1024000 *** 2mb = 2048000 just change your requirement /queue simple add name="main" target-addresses=192.168.0.0/24 max-limit=2048000/2048000 *** you can specific also your ssl connections. /queue simple add name="ssl" parent=main packet-marks=htt...
by dotnet
Thu Mar 14, 2013 11:57 am
Forum: Beginner Basics
Topic: Simple and basic configuration are not working
Replies: 7
Views: 787

Re: Simple and basic configuration are not working

few change in your configuration : pls follow this rules /ip firewall filter add chain=input connection-state=established comment="Accept established connections" add chain=input connection-state=related comment="Accept related connections" add chain=input connection-state=invalid action=drop commen...
by dotnet
Thu Mar 14, 2013 11:23 am
Forum: Beginner Basics
Topic: P2p limiting
Replies: 15
Views: 12349

Re: P2p limiting

your user's network address
by dotnet
Thu Mar 14, 2013 10:22 am
Forum: Beginner Basics
Topic: P2p limiting
Replies: 15
Views: 12349

Re: P2p limiting

yes you can limiting p2p pls follow the rules : /queue simple add name="main" target-addresses=192.168.0.0/24 max-limit=512000/512000 add name="http" parent=main packet-marks=http max-limit=256000/256000 priority=1 add name="p2p" parent=main packet-marks=p2p max-limit=56000/56000 priority=8 add name...
by dotnet
Wed Mar 13, 2013 10:26 am
Forum: Beginner Basics
Topic: qos with pcc
Replies: 3
Views: 1273

Re: qos with pcc

i think you don't need to block p2p. it will be open but bandwidth will set as your requirement ... just follow the rule ... /queue simple add name="main" target-addresses=192.168.0.0/24 max-limit=512000/512000 add name="http" parent=main packet-marks=http max-limit=256000/256000 priority=1 add name...
by dotnet
Wed Mar 13, 2013 7:02 am
Forum: General
Topic: load balancing two wan link
Replies: 3
Views: 1607

Re: load balancing two wan link

Here is describes 2 Method for your load balancing. ++++ PCC ++++ / ip address add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local add address=192.168.2.1/24 network=192.168.2.0 broadcast=192.168.2.255 interface=wan1 add address=192.168.4.1/24 network=192.168.4.0 b...
by dotnet
Tue Mar 12, 2013 1:06 pm
Forum: General
Topic: Load Balancing, how can I add a squid server?
Replies: 7
Views: 3356

Re: Load Balancing, how can I add a squid server?

In this scenario , Mikrotik have Three interface card. Description is as follows 1) LAN interface = Connected with user switch 2) WAN interface = Connected with ISP WAN 3) Proxy interface = Connected with SQUID PROXY Server via Crossover cable *** SQUID Server have two lan cards. One is connected wi...
by dotnet
Tue Mar 12, 2013 12:09 pm
Forum: General
Topic: Web proxy on rb1200
Replies: 2
Views: 820

Re: Web proxy on rb1200

that's true.
find your solution with Firewall filter, mangle, Traffic Shaper, Load balancing, queue rule & Block your proxy for open network.
by dotnet
Tue Mar 12, 2013 10:35 am
Forum: Beginner Basics
Topic: Routing Help !!!
Replies: 6
Views: 1126

Re: Routing Help !!!

I hope this will be work for you /ip route add dst-address=0.0.0.0/0 gateway=113.20.16.20 routing-mark=to_wan1 check-gateway=ping add dst-address=0.0.0.0/0 gateway=227.30.32.30 routing-mark=to_wan2 check-gateway=ping add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=1 check-gateway=ping add dst...
by dotnet
Mon Mar 04, 2013 10:15 am
Forum: General
Topic: web-proxy error gateway timeout
Replies: 1
Views: 2723

Re: web-proxy error gateway timeout

your configuration is ok. but something may be edit. just try this way. /ip proxy enabled: yes src-address: 0.0.0.0 port: 8085 parent-proxy: 0.0.0.0 parent-proxy-port: 0 cache-administrator: Dotnet max-cache-size: unlimited cache-on-disk: yes max-client-connections: 1000 max-server-connections: 1000...
by dotnet
Sun Mar 03, 2013 12:58 pm
Forum: General
Topic: Traffic Slow with webproxy transparent
Replies: 13
Views: 6451

Re: Traffic Slow with webproxy transparent

thx for your configuration. But some change in your /ip firewall Filter or Nat i am sharing my configuration for your reference: With PCC or ECMP Load Balancing Method : ++++ PCC ++++ / ip address add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local add address=192....
by dotnet
Sun Mar 03, 2013 11:42 am
Forum: General
Topic: Traffic Slow with webproxy transparent
Replies: 13
Views: 6451

Re: Traffic Slow with webproxy transparent

pls show your full configuration.
May be something wrong in your setup ....

Best regards
by dotnet
Sun Mar 03, 2013 11:38 am
Forum: Scripting
Topic: dynDNS over PPPoE
Replies: 1
Views: 1532

Re: dynDNS over PPPoE

CONFIGURE DDNS SCRIPT AND SCHEDULER ON MIKROTIK ddns-script-modem-in-pppoe-mode- code. (For your copy & paste facility) :global ddnsuser "user-id from changeip.com" :global ddnspass "passwd" :global ddnshost "full hostname" :global ddnsinterface "ether1" # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ #...
by dotnet
Sun Mar 03, 2013 10:13 am
Forum: General
Topic: Traffic Slow with webproxy transparent
Replies: 13
Views: 6451

Re: Traffic Slow with webproxy transparent

you should need 1 mangle rule in starting .. /ip firewall mangle add action=mark-packet chain=output comment="Cache Hits" disabled=no dscp=4 new-packet-mark=cache-hits passthrough=no /ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000KiB max-udp-packet-size=512 servers=8.8.8.8, 8....
by dotnet
Sun Mar 03, 2013 8:53 am
Forum: General
Topic: Traffic Slow with webproxy transparent
Replies: 13
Views: 6451

Re: Traffic Slow with webproxy transparent

is it single Wan Link ?
PCC or ECMP ???
Then what's your Mangle ?
Pls show your complete Configuration with Web-proxy..


Best regards
by dotnet
Thu Feb 28, 2013 1:21 pm
Forum: The User Manager
Topic: recharge an userman account with pin & password
Replies: 3
Views: 12633

Re: recharge an userman account with pin & password

I don't know what's your configuration? PPPoE or Hotspot .. i am described here only PPPoE & user manager setup for your pin & password This guide will illustrate howto create PPPoE server in MIKROTIK RouterOS (I used v 5.21 in this example). This article will also demonstrate on how you can create ...
by dotnet
Thu Feb 28, 2013 11:00 am
Forum: The User Manager
Topic: Server configuration for 9000 users
Replies: 5
Views: 3296

Re: Server configuration for 9000 users

200mb & 10000 user ....

i think you must be used 3rd party Radius Server.
Mikrotik User Manger is so good but not in Big Environment.
you have to need DMAsoftlab Radius Manger for better result & as per your customization.


best regards
by dotnet
Thu Feb 28, 2013 9:19 am
Forum: Scripting
Topic: i need a scripts automatic change ip pool 1 to ip pool??
Replies: 2
Views: 4768

Re: i need a scripts automatic change ip pool 1 to ip pool??

I think Mikrotik has not proper automatic script for pppoe or hotspot expired user. May be following these rules for your expired user. Adding IP pool for Expired / Non Payment Users /ip pool add name=Expired-Pool ranges=192.168.30.1-192.168.30.254 Adding Profile for Expired / Non Payment Users /ppp...
by dotnet
Thu Feb 28, 2013 7:53 am
Forum: General
Topic: Mikrotik Usermanager V.4.17
Replies: 2
Views: 886

Re: Mikrotik Usermanager V.4.17

pls show your configuration of Hotspot & User Manager ....
by dotnet
Thu Feb 28, 2013 7:18 am
Forum: General
Topic: Load Balancing questions
Replies: 1
Views: 576

Re: Load Balancing questions

I think your mangle rule should be some changed /ip firewall mangle add action=mark-connection chain=input disabled=no in-interface=wan1 new-connection-mark=wan1_conn passthrough=yes add action=mark-connection chain=input disabled=no in-interface=wan2 new-connection-mark= wan2_conn passthrough=yes a...
by dotnet
Tue Feb 26, 2013 12:18 pm
Forum: General
Topic: Load balancing with mikrotik Web proxy
Replies: 6
Views: 14092

Re: Load balancing with mikrotik Web proxy

I have already used my Mikrotik below setup for PCC Load Balancing with Web Proxy. I hope it will be work for all. I am working on MikriTik RouterOS 5.23 (X86) My Mikrotik has 3 interface. / ip address add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local add address...