Community discussions

MikroTik App

Search found 22 matches

by randomwalk
Thu Oct 21, 2021 9:36 pm
Forum: Announcements
Topic: v6.48.5 [long-term] is released!
Replies: 101
Views: 18476

Re: v6.48.5 [long-term] is released!

@Mikrotik product managers: Here is the real problem to solve during your next product update meeting: Suppose one itchy finger decided to tweak, improve, and add "new features" to the firmware that was not broken. As a direct result (and within 2 weeks) of the change 10 clients who upgrad...
by randomwalk
Thu Oct 14, 2021 9:23 pm
Forum: Announcements
Topic: v6.48.5 [long-term] is released!
Replies: 101
Views: 18476

Re: v6.48.5 [long-term] is released!

Also it seems that version of routerboot matters and obviously routerboot doesn't care if you run DNS or anything else... so likely other software performance is also affected. I would take a close look at routerboot as it lies below the radar. Let me hypothesize here for a moment: Suppose an embed...
by randomwalk
Wed Oct 13, 2021 10:57 pm
Forum: Announcements
Topic: v6.48.5 [long-term] is released!
Replies: 101
Views: 18476

Re: v6.48.5 [long-term] is released!

It is all true about regexp, and 80K+ records sure is a lot as these alone require 300MB of RAM. At the same time the dns only uses a single core, with other remaining cores available. I find the built-in dns quite a gem on its own, which, when paired with the power of RouterOS scripting provides an...
by randomwalk
Tue Oct 12, 2021 8:12 pm
Forum: Announcements
Topic: v6.48.5 [long-term] is released!
Replies: 101
Views: 18476

Re: v6.48.5 [long-term] is released!

"Noticeable" screams placebo and/or other issues. You need to back up that claim with some hard data homie Agree that DNS may not be the root cause, and an issue may be something else. The important detail here is that the issue goes away after downgrade to 6.47.10, or 6.46.8. I reported ...
by randomwalk
Tue Oct 12, 2021 10:07 am
Forum: Announcements
Topic: v6.48.5 [long-term] is released!
Replies: 101
Views: 18476

Re: v6.48.5 [long-term] is released!

You need to back up that claim with some hard data I took some time to capture a full 1 hour video to demonstrate the difference between 2 versions: ---------------------------------------------------------------------- total_dns_boot time_version 6.46.8___~ 1 minute total_dns_boot time_version 6.4...
by randomwalk
Mon Oct 11, 2021 8:17 pm
Forum: Announcements
Topic: v6.48.5 [long-term] is released!
Replies: 101
Views: 18476

Re: v6.48.5 [long-term] is released!

I discussed about this with Normis some time ago and he insisted Mikrotik does it properly, there shouldn't be cumulative changelogs, we should read all changelogs by ourselves. Certainly Mikrotik has the authority to choose the best RouterOS release and upgrade cycle in the best interest of their ...
by randomwalk
Sat Oct 09, 2021 7:26 am
Forum: Announcements
Topic: v6.48.5 [long-term] is released!
Replies: 101
Views: 18476

Re: v6.48.5 [long-term] is released!

... so I found this change not documented in Long -Term 6.48.5   What's new in 6.48 (2020-Dec-22 11:20): *) dns - do not use type "A" for static entries with unspecified type;   ...And did some more tests... Here are my findings: adding a new record like that: /ip dns static add name=www.e...
by randomwalk
Sat Oct 09, 2021 6:11 am
Forum: Announcements
Topic: v6.48.5 [long-term] is released!
Replies: 101
Views: 18476

Re: v6.48.5 [long-term] is released!

Hi, I think I found what seems to be a bug in the dns, although I'm not sure what versions are affected. (here, I ran 'nslookup' to get the actual IP addresses of www.example.com used for demonstration purposes. # first let's add some new A and AAAA dns records for www.example.com /ip dns static add...
by randomwalk
Wed Oct 06, 2021 10:43 am
Forum: Scripting
Topic: Fast and Accurate Leap Year calculation
Replies: 0
Views: 378

Fast and Accurate Leap Year calculation

Hi, The forum has helped me a lot over the past several years, and I thought I would give something back. Hope you find this useful. { # Fast and accurate Leap Year calculation :local months [:toarray "jan,feb,mar,apr,may,jun,jul,aug,sep,oct,nov,dec"]; :local CurrentDate [system clock get ...
by randomwalk
Tue Jan 05, 2021 2:44 am
Forum: Announcements
Topic: v6.48 [stable] is released!
Replies: 324
Views: 82337

Re: v6.48 [stable] is released!

Image
Do not post link to image. Upload them to the forum use the Attachments button below the post window. It will then stay in the forum.
I tried, but don't have the privilege according to forum faq. Thanks anyway.
by randomwalk
Sun Jan 03, 2021 1:22 am
Forum: Announcements
Topic: v6.48 [stable] is released!
Replies: 324
Views: 82337

Re: v6.48 [stable] is released!

6.46.8 LTS --> 6.48 Stable --> 6.46.8 LTS Did you also upgrade the firmware. No i did not upgrade the firmware. The firmware was v6.47.8 (i forgot that I switched to Stable channel ~4 weeks ago.) Here is my exact (more accurate) update path: 6.46.8 (FW 6.46.8) LTS --> 6.47.8 (FW 6.47.8) Stable --> ...
by randomwalk
Sat Jan 02, 2021 10:33 am
Forum: Announcements
Topic: v6.48 [stable] is released!
Replies: 324
Views: 82337

Re: v6.48 [stable] is released!

we are waiting for 6.48.5 .. stable release is beta channel
Agree, The "stable" channel should be called Beta.
by randomwalk
Sat Jan 02, 2021 10:21 am
Forum: Announcements
Topic: v6.48 [stable] is released!
Replies: 324
Views: 82337

Re: v6.48 [stable] is released!

DNS regression after 6.48 update RB450Gx4 edited --> 6.46.8 (FW 6.46.8) LTS --> 6.47.8 (FW 6.47.8) Stable --> 6.48 (FW 6.47.8) Stable --> 6.46.8 (FW 6.46.8) <--- edited 1. CPU utilization during reboot spiked higher, and stayed high for much longer. 2. RouterOS took 15 min to parse ~83,000 static DN...
by randomwalk
Wed Dec 16, 2020 9:44 am
Forum: Scripting
Topic: [SOLVED] Using Dynamic Variable Names
Replies: 8
Views: 3543

Re: Using Dynamic Variable Names

Works with global, but not possible with local. Is the any solution for local variables? Store the dynamically created local variables in an array. { :local qty 9; # number of variables to create :local varname "myvar"; # name for the variables :local myarray [:toarray ""]; # cr...
by randomwalk
Mon Dec 14, 2020 3:05 am
Forum: General
Topic: [Feature Request] split DNS
Replies: 6
Views: 3417

Re: [Feature Request] split DNS

the feature made available in RouterOS v6.47 stable
/ip dns static
add forward-to=192.168.88.3 regexp=".*\\.test1\\.localdomain" type=FWD
add forward-to=192.168.88.56 regexp=".*\\.test2\\.localdomain" type=FWD
according to source
by randomwalk
Sat Apr 13, 2019 11:28 pm
Forum: Scripting
Topic: [SOLVED] Using Dynamic Variable Names
Replies: 8
Views: 3543

Re: Using Dynamic Variable Names

   
by randomwalk
Mon Mar 18, 2019 11:06 pm
Forum: General
Topic: DHCPv6 Prefix Request Response not happening. How to Trace Debug?
Replies: 9
Views: 2343

Re: DHCPv6 Prefix Request Response not happening. How to Trace Debug?

Hi MasterJames,
Thanks for sharing your findings on IPv6. I'm in Alberta and share your pain on Telus/Bell/Rogers/Shaw :)
by randomwalk
Tue Feb 27, 2018 7:45 am
Forum: Scripting
Topic: Dates manipulation module
Replies: 4
Views: 4089

Re: Dates manipulation module

"The selected attachment does not exist anymore."
by randomwalk
Thu Nov 23, 2017 7:45 am
Forum: Scripting
Topic: Syntax highlighting and completions for Sublime Text
Replies: 41
Views: 41613

Re: Syntax highlighting and completions for Sublime Text

Hi, Just found that MikrotikScript have disappeared from the available syntax options in my instance of Sublime Text What is more interesting, is that after I add the MikrotikScript package, Sublime Text will forcefully delete it, and this occurs only within few seconds after launch... Purchasing a ...
by randomwalk
Mon Mar 13, 2017 12:25 am
Forum: Announcements
Topic: v6.37.5 [bugfix] is released!
Replies: 35
Views: 18552

Re: v6.37.5 [bugfix] is released!

Aha..got it.
Thanks for helping me to understand what I did wrong
by randomwalk
Sun Mar 12, 2017 10:00 pm
Forum: Announcements
Topic: v6.37.5 [bugfix] is released!
Replies: 35
Views: 18552

Re: v6.37.5 [bugfix] is released!

and it gets more interesting...
input:
:put [:if ([:tonum [:find "Canada/Edmonton" "/"]]!=0) do={:log info "works"};]
output in the terminal:
;
output in the log:
works
/winbox 3.11 / RouterOS v6.37.5/ Routerboard RB493G
by randomwalk
Sun Mar 12, 2017 9:55 pm
Forum: Announcements
Topic: v6.37.5 [bugfix] is released!
Replies: 35
Views: 18552

Re: v6.37.5 [bugfix] is released!

Not sure if this belongs to this thread .
Installed v6.37.5.
Input:
:put [:if ([:find "Canada/Edmonton" "/"]=6) do={:put "works"}]
output:
works
;works
I'm puzzled at what I'm seeing in the terminal. How can this output be explained?
Is this a bug?
Thanks,