Community discussions

MUM Europe 2020

Search found 13 matches

by er
Mon Dec 21, 2009 10:22 am
Forum: Scripting
Topic: write to file
Replies: 5
Views: 3352

Re: write to file

I use P.C.Q, simple queues is only for graphing. I will look at SNMP
In the meantime I will use your script
by er
Mon Dec 21, 2009 1:44 am
Forum: Scripting
Topic: write to file
Replies: 5
Views: 3352

Re: write to file

Thank you for the reply
I have 400 queues and that is more then 4Kb, so I try to divide in 3 files, but that do not the trick
by er
Sun Dec 20, 2009 11:48 pm
Forum: Scripting
Topic: write to file
Replies: 5
Views: 3352

write to file

Hello! I am trying to make a script like this. :global test; :global tekst1; :global tekst2; :global tekst3; :global tekst4 ","; /file set test.txt contents=" " :for i from=0 to=10 do={/queue simple find comment=0 :set tekst1 [/queue simple get $i bytes] :set tekst2 [/queue simple get $i target-addr...
by er
Sat Nov 28, 2009 11:40 am
Forum: Beginner Basics
Topic: Save Rx Byte and Tx Biyte in a file
Replies: 1
Views: 793

Save Rx Byte and Tx Biyte in a file

I try, in Simple Queues, to save Target-Address and Total Rx Bytes and Total Tx bytes in a file, but when I use:
/queue simple print bytes file=bytes
I can only see Rx and Tx like this: 46825438/6...

Is there a way so I can see the whole number of bytes
Erik
by er
Sat Nov 07, 2009 11:44 pm
Forum: General
Topic: How to email when IP added to address list?
Replies: 5
Views: 2494

Re: How to email when IP added to address list?

Hi
I use this script
:foreach i in [/ip firewall address-list find list=spamm] do={ /tool e-mail send to=xxx@xxxx.xx subject="Spamm" body=("Spamm fra " . [/ip firewall address-list get $i  address])}
by er
Fri Sep 19, 2008 11:47 am
Forum: Beginner Basics
Topic: Mangle in ROS 3.11
Replies: 4
Views: 1079

Re: Mangle in ROS 3.11

I will try this
thankyou

ErikR
by er
Thu Aug 28, 2008 9:06 pm
Forum: Beginner Basics
Topic: Mangle in ROS 3.11
Replies: 4
Views: 1079

Re: Mangle in ROS 3.11

Yes, there are a problem, when I set the outgoing interfaces, then it stops marking
I will like to mark the packet which go to the internet, and the packet which go to the customer, and then use it in a PCQ queues.
I have a bridge between ether1 and wlan1
In bridge I have set “use ip firewall”

ErikR
by er
Wed Aug 27, 2008 11:47 am
Forum: Beginner Basics
Topic: Mangle in ROS 3.11
Replies: 4
Views: 1079

Mangle in ROS 3.11

Hej In a ap bridge I do this # aug/27/2008 10:14:33 by RouterOS 2.9.49 # / ip firewall mangle add chain=forward action=mark-connection new-connection-mark=con-33 \ passthrough=yes comment="" disabled=no add chain=forward action=mark-packet new-packet-mark=packet-33down \ passthrough=yes out-interfac...
by er
Mon May 19, 2008 12:50 pm
Forum: Scripting
Topic: script to save logs and send via email
Replies: 27
Views: 26857

Re: script to save logs and send via email

hej itsh.net When I copy your script in terminal, I receive this ??? Ros = 2.9.49 [erik@Trekanten] > #read log [erik@Trekanten] > :local logcontent [erik@Trekanten] > :foreach int in=[/log find ] do={ {... :set logcontent ("$logcontent\r\n" .[/log get $int time]. " - " .[/log get $int message]) {......
by er
Mon May 12, 2008 3:04 pm
Forum: Scripting
Topic: help:email send
Replies: 4
Views: 1159

Re: help:email send

Hej
Thanks for your help, it works now

Erik
by er
Sun May 11, 2008 11:17 pm
Forum: Scripting
Topic: help:email send
Replies: 4
Views: 1159

Re: help:email send

hej'
Thank you for your help, but I think the problem is in this part.
:foreach i in [/ip firewall address-list find list=spam]
by er
Sun May 11, 2008 8:15 pm
Forum: Scripting
Topic: help:email send
Replies: 4
Views: 1159

help:email send

hej
In ip firewall address-list I have list name spam with a number of items. I will like to have en email for each item. I have tried with this
:foreach i in ([/ip firewall address-list find list=spam] do=(/tool e-mail send to=myname@myaddress.dk))
by er
Tue Aug 28, 2007 2:55 pm
Forum: Scripting
Topic: script: remove access-list
Replies: 1
Views: 1195

script: remove access-list

Hi
I wish to have a script to remove all in " /interface wireless access-list " and replace it with
a file "newmembers.rsc"

thanks
ErikR