Community discussions

MikroTik App

Search found 41 matches

by tberg
Fri May 22, 2020 5:36 pm
Forum: General
Topic: ECMP LoadBalancing
Replies: 15
Views: 1987

Re: ECMP LoadBalancing

Not sure if there are other ways to do this, but one is to use firewall mangle rules and PCC (per connection classifier). Here is a link to a MUM presentation on the topic. https://mum.mikrotik.com/presentations/ ... 038928.pdf
by tberg
Sun Apr 19, 2020 2:11 am
Forum: Forwarding Protocols
Topic: BGP route issue
Replies: 2
Views: 1929

Re: BGP route issue

Sorry so long to respond. Didn't realize you replied. I think the issue might have been hardware related. My original lab was some old 450/450Gs we had laying around. I tried to re-create with some 4011s we were getting ready to deploy and everything worked as expected.
by tberg
Thu Apr 16, 2020 11:15 pm
Forum: Forwarding Protocols
Topic: Default route OSPF or BGP?
Replies: 0
Views: 1248

Default route OSPF or BGP?

I am re-designing our network to use OSPF for transit subnets between sites and eBGP to advertise customer subnets at each site. Many of our sites have multiple hops to our core with at least 2 paths at each site. This will give me greater control over traffic paths. Anyway, wondering whether the de...
by tberg
Thu Mar 19, 2020 12:31 am
Forum: Beginner Basics
Topic: forwarding a VPN another router
Replies: 1
Views: 1039

Re: forwarding a VPN another router

It looks like the VPN server is outside the NAT firewall of the Orbi. If the Mikrotik is doing NAT, you might be able to change the Orbi to AP/bridge mode. I don't know if Orbi supports this mode, but most Netgear routers do.
by tberg
Wed Mar 18, 2020 11:20 pm
Forum: Forwarding Protocols
Topic: BGP route issue
Replies: 2
Views: 1929

BGP route issue

I am testing a new design we are planning to implement and running into a strange issue. The network consists of 2 edge routers each connected to a different upstream peer and an iBGP connection between them. Everything works fine until I disable the iBGP connection between the 2 edge routers. After...
by tberg
Wed Mar 04, 2020 11:39 pm
Forum: General
Topic: IPsec problem
Replies: 4
Views: 1573

Re: IPsec problem

Looks like your sa-src-address should be 1.1.1.1, not 0.0.0.0
by tberg
Mon Mar 02, 2020 9:23 pm
Forum: Forwarding Protocols
Topic: OSPF Drops when adding a comment?
Replies: 13
Views: 3595

Re: OSPF Drops when adding a comment?

Same thing with BGP peer I recently learned the hard way. Took about a minute for all the routes to come back.
by tberg
Mon Feb 17, 2020 6:14 pm
Forum: General
Topic: CRS Ethernet TX Drops
Replies: 4
Views: 1884

Re: CRS Ethernet TX Drops

Thanks! Yes I'm sure that is it. On the worst port, it is about .1%. We're moving to switch centric architecture and upgrading routers. Once routers are all 10G, part of the problem should go away. However, it's got me thinking about uplink to access switches with 1G backhaul and APs. It might be be...
by tberg
Mon Feb 17, 2020 3:57 pm
Forum: General
Topic: CRS Ethernet TX Drops
Replies: 4
Views: 1884

Re: CRS Ethernet TX Drops

Looking closer, they must be buffer overruns. They are only happening on 1G ports on switches that have 10G ingress and multiple 1G egress. I assume you cannot change interface queue type without breaking hardware offload.
by tberg
Sun Feb 16, 2020 10:44 pm
Forum: General
Topic: CRS Ethernet TX Drops
Replies: 4
Views: 1884

CRS Ethernet TX Drops

We recently installed a few CRS317 and 328P switches. I am noticing TX Drops incrementing on some Ethernet interfaces. What are TX drops? Are they buffer overflows or filtered traffic with incorrect/unallowed VLAN tags?
by tberg
Sat Feb 08, 2020 10:24 pm
Forum: Forwarding Protocols
Topic: HELP - Network Mikrotik with Radwin (SMALL ISP)
Replies: 2
Views: 1722

Re: HELP - Network Mikrotik with Radwin (SMALL ISP)

It's hard to say without more info, but most WISPs that size use OSPF to control routing across the ring/rings and BGP to their upstream Internet provider. The guys at IP Architechs have a few write ups and presentations on their blog page at: https://stubarea51.net/. You will also find some relevan...
by tberg
Tue Nov 26, 2019 11:34 pm
Forum: RouterOS v7 BETA
Topic: CRS3xx MC-LAG in RouterOS 7
Replies: 19
Views: 5001

Re: CRS3xx MC-LAG in RouterOS 7

+MC-LAG
by tberg
Fri Nov 22, 2019 3:58 am
Forum: Wireless Networking
Topic: 60G 500M link
Replies: 7
Views: 1762

Re: 60G 500M link

I agree, and often the best way to know what to do as an engineer is test for yourself. I guess I don't understand your statement that you should use the same on both ends because they have different radiation patterns. What do you mean by that? I know they have very different antenna patterns. I ca...
by tberg
Thu Nov 21, 2019 4:52 pm
Forum: Wireless Networking
Topic: 60G 500M link
Replies: 7
Views: 1762

Re: 60G 500M link

I can see using same on both side for P2P, but if you're doing multipoint and need to go more than 200M you would want the larger gain on the client end. Maybe shouldn't use Mikrotik for any multipoint? That's part of what we're trying to learn. This link is just a backup and we wanted to test multi...
by tberg
Wed Nov 20, 2019 8:45 pm
Forum: Wireless Networking
Topic: 60G 500M link
Replies: 7
Views: 1762

60G 500M link

Installing our first 60G link. 500M link with a wAP AP on one end and LHG60 on the other. I'm wondering what we should expect for RSSI. I tried the Mikrotik wireless link calculator but don't see where it shows any signal levels. It just says the link status is reliable. We are getting -62 at the wA...
by tberg
Mon Jul 08, 2019 4:36 pm
Forum: The Dude
Topic: Interface graph > 600Mbps
Replies: 5
Views: 2438

Re: Interface graph > 600Mbps

That worked. Thank you very much!!
by tberg
Fri Jul 05, 2019 7:51 pm
Forum: The Dude
Topic: Interface graph > 600Mbps
Replies: 5
Views: 2438

Re: Interface graph > 600Mbps

I think you are right on the snmp counter, but I don't see how to change the default for graphing bit rate on a link. I just have the 'Graph bit rate' box checked for the link and using SNMP for mastering type. The SNMP profile for the device is SNMP v2. Also, the monitoring interval is 1 min and se...
by tberg
Thu Jun 20, 2019 7:40 pm
Forum: The Dude
Topic: Interface graph > 600Mbps
Replies: 5
Views: 2438

Interface graph > 600Mbps

I haven't tested this in a lab to verify yet, but it seems like our Dude interface graphs start cutting out at around 575 Mbps. At first I thought this was an issue with the Cisco 3750 we were using for the graphing. But I changed to graph the interface on a CRS317 and get the same results. Graphing...
by tberg
Sun Apr 07, 2019 8:48 pm
Forum: The Dude
Topic: Monitor edge router traffic
Replies: 0
Views: 1814

Monitor edge router traffic

We are unable to monitor interface traffic on our edge routers because the Dude pulls the entire bgp routing table from the router. Is there a way to prevent the Dude from walking the entire MIB on a device but still poll interface stats?
by tberg
Wed Feb 20, 2019 12:48 am
Forum: General
Topic: Traffic generator
Replies: 5
Views: 1270

Re: Traffic generator

It's a little confusing, but for the traffic generator set up you don't need to be concerned with GW 1 & 2. Assuming you have a route from 1.1.1.1 to 4.4.4.4 and back, your packet template in 1.1.1.1 would have ip-dst=1.1.1.1 and ip-gateway=4.4.4.4. In my case GW1 and GW1 are Mikrotik routers, but I...
by tberg
Mon Feb 18, 2019 7:43 pm
Forum: General
Topic: Traffic generator
Replies: 5
Views: 1270

Re: Traffic generator

Yes, that is possible. I've not done it over the public Internet, but don't see why it wouldn't work. I've done it across multiple router hops in our ISP network.
by tberg
Mon Feb 18, 2019 2:52 am
Forum: General
Topic: Traffic generator
Replies: 5
Views: 1270

Re: Traffic generator

Set the Dst to be the IP of the generator and the Gateway to be the IP of the remote Mikrotik you are testing to. You can leave the Src blank.
by tberg
Thu Aug 30, 2018 6:26 pm
Forum: The Dude
Topic: Modify mouse hover info
Replies: 0
Views: 1540

Modify mouse hover info

Is there a way to modify what is displayed when you hover mouse over a device or link?
by tberg
Thu May 25, 2017 6:45 am
Forum: The Dude
Topic: DENVER MUM
Replies: 5
Views: 967

Re: DENVER MUM

Where are you located? I'm just North of Denver.
Todd
by tberg
Thu Apr 20, 2017 12:30 am
Forum: The Dude
Topic: Interface bit rate graphing
Replies: 3
Views: 1128

Re: Interface bit rate graphing

Thanks!!
I set up a graph of rate(diff32(oid("1.3.6.1.2.1.2.2.1.10.1")))*8 and compared to the standard link graph that gets created when you check 'Graph bit rate' on the History tab of the link. Both graphs looked the same.
Todd
by tberg
Fri Apr 14, 2017 8:15 pm
Forum: The Dude
Topic: Interface bit rate graphing
Replies: 3
Views: 1128

Interface bit rate graphing

Anyone know how the Interface.OutBitRate and InBitRate are calculated? In the case of out, is it difference in out octets between consecutive polls / poll interval / 8 bits/octet? So if poll interval is 1 min., it would be avg over the minute?

Thanks,
Todd
by tberg
Thu Jan 12, 2017 8:04 pm
Forum: Announcements
Topic: The Dude, v6.39rc test builds.
Replies: 121
Views: 33137

Re: The Dude, v6.39rc test builds.

asik, I'm having similar or same issue with devices on the same map and I've set the Parents field with upstream device. I'm getting mixed results and haven't had time to try to isolate exactly what is happening. We monitor independent customer sites. At some sites I seem to get a notification for a...
by tberg
Wed Jan 04, 2017 10:17 pm
Forum: The Dude
Topic: Setting Up A Second Email Address To Be Notified With Only One Device-NOT ALL DEVICES
Replies: 1
Views: 574

Re: Setting Up A Second Email Address To Be Notified With Only One Device-NOT ALL DEVICES

Haven't tried this for individual devices, but sometimes use different emails for different networks. Should work the same. Go to Notifications and create a new email notification. Can copy existing email notification and change to address. Then go to the settings for the specific device, select Pol...
by tberg
Wed Jan 04, 2017 1:21 am
Forum: The Dude
Topic: Cambium ePMP MIB issue
Replies: 2
Views: 1009

Cambium ePMP MIB issue

I am unable to get the Cambium ePMP MIBs to show textual OIDs when doing a snmpwalk on an ePMP device. It appears that the Dude is picking up the older CANOPY-SYS-MIB that is included with the default MIBs instead of the Cambium MIB I copied into the mibs folder on the Dude server. They both have th...
by tberg
Wed Nov 09, 2016 4:54 pm
Forum: The Dude
Topic: The Dude, v6.38rc test builds.
Replies: 189
Views: 42894

Re: The Dude, v6.38rc test builds.

Try putting the image files in the dude/files/images dir. Mibs go in the dude/files/mibs dir. I found it much easier to use ftp than Winbox.
by tberg
Tue Nov 01, 2016 4:35 pm
Forum: The Dude
Topic: The Dude, v6.38rc test builds.
Replies: 189
Views: 42894

Re: The Dude, v6.38rc test builds.

More info. SNMP values are being collected and displayed correctly in appearance and SNMP tab of device. It is just snmpwalk tool that times out.
dude_snmp.png
by tberg
Mon Oct 31, 2016 10:42 pm
Forum: The Dude
Topic: The Dude, v6.38rc test builds.
Replies: 189
Views: 42894

Re: The Dude, v6.38rc test builds.

The Snmpwalk tool appears to not work with 6.38rc19. I've tried on a number of devices and get a timeout for all of them. All of these devices have various SNMP services working correctly. Snmpwalk was working with 6.37.
by tberg
Sat Oct 29, 2016 5:49 pm
Forum: The Dude
Topic: put device wlan frequency in dude custom field
Replies: 1
Views: 1314

Re: put device wlan frequency in dude custom field

There are a few good tutorials on this if you do a google search. But the process in general is: 1. Do a SNMP Walk of the access point to find the oid for the wlan channel/freq you are looking for. 2. Then create a function to use that oid. Here's an example for Ubiquiti Airmax channel and frequency...
by tberg
Tue Jun 21, 2016 9:19 pm
Forum: The Dude
Topic: Visual C++ Runtime Error! Windows 10 Help!!!
Replies: 17
Views: 8002

Re: Visual C++ Runtime Error! Windows 10 Help!!!

We are also having this problem on Windows 8.1 & 10.  One WIn8 machine works fine and the other doesn't.  Tried on 4 different Win10 machines.  None worked initially, but I was able to get one of them to work after removing a few other programs.  I thought the problem program was Wireshark, but one ...
by tberg
Sun May 22, 2016 5:55 pm
Forum: The Dude
Topic: Issues/Questions with links
Replies: 2
Views: 1042

Re: Issues/Questions with links

Boy do I feel dumb. Thank you!!
by tberg
Thu May 19, 2016 8:04 pm
Forum: The Dude
Topic: Issues/Questions with links
Replies: 2
Views: 1042

Issues/Questions with links

When I manually add a link to a map, it does not show up on the map, but does show up on the Link table. It does not matter what type I choose. If I do a discover, the links are automatically added and show on the map as expected. I select Add - Link and click on a device on the map and set the appr...
by tberg
Wed May 18, 2016 12:28 am
Forum: The Dude
Topic: The Dude for beginners!
Replies: 2
Views: 1212

Re: The Dude for beginners!

Correct, Dude now needs to be installed on Routerboard with Tile or ARM processor. Better yet, install ROS x86 or CHR on a VM. Install the Dude server on 1 of these devices and Dude client on a WIndows machine and set up to connect to the server.
Todd
by tberg
Tue May 17, 2016 5:28 am
Forum: The Dude
Topic: Dude x86 send email using host name
Replies: 2
Views: 1056

Re: Dude x86 send email using host name

Thanks Geoff. I wasn't sure how to add smtp software to RouterOS, but I did get it set up on another Linux server on the same network using postfix.
Todd
by tberg
Thu May 12, 2016 9:11 pm
Forum: The Dude
Topic: Dude x86 send email using host name
Replies: 2
Views: 1056

Dude x86 send email using host name

Anybody have suggestions for how I could setup email notifications using a host name for SMTP server instead of IP address. I've seen examples using Windows server and scripts to resolve IP from host name. But I'm not sure how to update dude smtp server.

Thank you,
Todd
by tberg
Fri Aug 15, 2014 7:14 pm
Forum: General
Topic: Stop router WAN IP address being spoofed
Replies: 0
Views: 463

Stop router WAN IP address being spoofed

I have client that is at a minimum, amplifying an attack. Their router is setup as a NAT router with a single WAN and single LAN interface. The firewall connections list shows many connections with its WAN IP address as the source address. I put a firewall rule to log the connections. They are in th...
by tberg
Mon Sep 23, 2013 1:21 am
Forum: The Dude
Topic: Can't connect to RouterOS Agent
Replies: 0
Views: 948

Can't connect to RouterOS Agent

I must be missing something basic. I am unable to get a Dude server to connect to a Mikrotik RB4XX running the Dude package. For the server, I've tried both Dude 3.6 & 4.0b3 on both Win7 & Win 2k3 server with firewall turned off. The router is a 450G w/ 5.24 s/w and I put it on the same local subnet...