Community discussions

Search found 124 matches

by bingo220
Wed Feb 13, 2019 12:02 am
Forum: Wireless Networking
Topic: cAP ac (Found the bug)
Replies: 1
Views: 405

cAP ac (Found the bug)

cAP ac (ROS 6.43.12, 6.44b75) 1. Create a Wireless virtual interface: Winbox: "Wireless" > "WiFi Interfaces" > "+" > "Virtual" > ... 2. Add a graph for this virtual interface: Winbox: "Tools" > "Graphing" > "Interface Rules" > "+" > "Choice a virtual interface" Now all work fine. 3. Reboot device. N...
by bingo220
Fri Oct 30, 2015 10:49 pm
Forum: General
Topic: Winbox losing MAC connection to RB850Gx2
Replies: 42
Views: 11255

Re: Winbox losing MAC connection to RB850Gx2

Have same problem.
RB850Gx2, ROS 6.32.3
by bingo220
Wed May 20, 2015 5:52 pm
Forum: Beginner Basics
Topic: Loadbalincing with PCC: how to set rules to force ip addresses to a specific connection
Replies: 10
Views: 1298

Re: Loadbalincing with PCC: how to set rules to force ip addresses to a specific connection

something like this: /ip firewall address-list add list=ip_wan1 address=192.168.1.5 /ip firewall mangle add action=mark-routing chain=prerouting new-routing-mark=static-wan1 src-address-list=ip_wan1 passthrough=no /ip route add distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out1 routing-mark=static...
by bingo220
Tue May 12, 2015 12:32 am
Forum: Beginner Basics
Topic: can't access my dvr from outsite
Replies: 26
Views: 3538

Re: can't access my dvr from outsite

any help ... please
1. configure the modem (linksys wag 120n) in bridge mode
2. set up external IP on the RB (ppp.., dhcp, static, or what required your ISP)
by bingo220
Mon May 11, 2015 11:57 am
Forum: Beginner Basics
Topic: can't access my dvr from outsite
Replies: 26
Views: 3538

Re: can't access my dvr from outsite

1. configure the modem (linksys wag 120n) in bridge mode
2. set up external IP on the RB (ppp.., dhcp, static, or what required your ISP)
by bingo220
Sat May 09, 2015 6:45 pm
Forum: Beginner Basics
Topic: downgrading from 6.28 to 6.27 on rb951g
Replies: 2
Views: 1315

Re: downgrading from 6.28 to 6.27 on rb951g

http://download2.mikrotik.com/routeros/ ... e-6.27.npk
copy to the RB and do
/system package downgrade
by bingo220
Thu May 07, 2015 9:11 pm
Forum: Beginner Basics
Topic: can't access my dvr from outsite
Replies: 26
Views: 3538

Re: can't access my dvr from outsite

Try instead "dst-address=197.XXX.XXX.XXX" to use "in-interface=NAMEofWANinterface"
by bingo220
Fri Apr 24, 2015 6:40 pm
Forum: Beginner Basics
Topic: RB "CCR1016-12g" and UPS "APC Back-Ups RS550VA LCD"
Replies: 2
Views: 489

Re: RB "CCR1016-12g" and UPS "APC Back-Ups RS550VA LCD"

InoX , thank you for the reply. I have some doubts. Wikipedia says: offline-time > 0 - the router will go into hibernate mode according the min-runtime setting and 10% of battery power event. In this case, the router will wait until the UPS reports that the battery power is below 10% If I understoo...
by bingo220
Fri Apr 24, 2015 1:47 pm
Forum: Beginner Basics
Topic: RB "CCR1016-12g" and UPS "APC Back-Ups RS550VA LCD"
Replies: 2
Views: 489

RB "CCR1016-12g" and UPS "APC Back-Ups RS550VA LCD"

Hi All! There is a need to monitor the state of the power supply (220V). I plugged usb-cable from UPS to RB. Also to this UPS are connected cameras, switches etc. I made setup and now I can control some UPS parameters. But have problem. I don't know what arguments I need to write to Winbox>System>UP...
by bingo220
Mon Apr 20, 2015 2:22 pm
Forum: Beginner Basics
Topic: Shared bandwidth between two local subnets
Replies: 4
Views: 715

Re: Shared bandwidth between two local subnets

exactly, the alone vlan can use the full bandwidth of internet.
upd: I was guided this manual, but it is russian.
by bingo220
Fri Apr 17, 2015 11:27 pm
Forum: Beginner Basics
Topic: Shared bandwidth between two local subnets
Replies: 4
Views: 715

Re: Shared bandwidth between two local subnets

I did it using Queue Tree (share bandwidth of 2 WAN between 24 VLAN).
Your situation is easier.
My example.
by bingo220
Thu Apr 16, 2015 9:00 pm
Forum: Beginner Basics
Topic: NAT Routerboard IP cam
Replies: 5
Views: 800

Re: NAT Routerboard IP cam

It's possible that the ip-stream uses UDP protocol.
You need to switch to TCP protocol, if the camera has this setting.
Anyway, I couldn't use the cameras remotely until switched to TCP.
by bingo220
Mon Apr 13, 2015 10:21 am
Forum: Beginner Basics
Topic: Hard reset is not working
Replies: 1
Views: 2731

Re: Hard reset is not working

The most complete reset is NetInstall.
Video guide.
by bingo220
Fri Apr 03, 2015 11:27 am
Forum: Beginner Basics
Topic: Syntax Error Line 1 Column 87.
Replies: 2
Views: 1131

Re: Syntax Error Line 1 Column 87.

Start with:
/ip firewall filter
by bingo220
Wed Apr 01, 2015 9:59 pm
Forum: Beginner Basics
Topic: Load Balancing Questions and Help
Replies: 14
Views: 1694

Re: Load Balancing Questions and Help

Would this work with default configuration or do i need to erase entire config and start over?
You can test it with default config.
by bingo220
Wed Apr 01, 2015 10:22 am
Forum: Beginner Basics
Topic: Load Balancing Questions and Help
Replies: 14
Views: 1694

Re: Load Balancing Questions and Help

I think you need something like this: /ip firewall address-list add list=static-wan1 address=10.0.1.2-10.0.1.245 comment="LAN-IPs to WAN1" add list=static-wan2 address=10.0.1.246-10.0.1.254 comment="LAN-IPs to WAN2" /ip firewall mangle add action=mark-routing chain=prerouting src-address-list=static...
by bingo220
Mon Mar 30, 2015 8:41 pm
Forum: Beginner Basics
Topic: Dynamic DNS scripting and global variables
Replies: 10
Views: 1391

Re: Dynamic DNS scripting and global variables

I once showed my scripts for "no-ip" service, it may interest you.
http://forum.mikrotik.com/viewtopic.php ... 44#p419745
by bingo220
Thu Mar 05, 2015 12:28 am
Forum: Beginner Basics
Topic: Advanced routing failover
Replies: 1
Views: 3899

Re: Advanced routing failover

by bingo220
Wed Jan 28, 2015 12:26 pm
Forum: Beginner Basics
Topic: Winbox Download
Replies: 7
Views: 15365

Re: Winbox Download

by bingo220
Thu Jan 22, 2015 2:47 pm
Forum: Beginner Basics
Topic: how to block discovery on mikrotik
Replies: 9
Views: 3407

Re: how to block discovery on mikrotik

if i'm right you need to block (udp)5678.
by bingo220
Wed Jan 21, 2015 8:45 pm
Forum: Beginner Basics
Topic: non-beta winbox
Replies: 1
Views: 482

Re: non-beta winbox

1. Winbox can be downloaded directly from the router.
2. http://download2.mikrotik.com/winbox.exe
by bingo220
Tue Jan 20, 2015 12:06 pm
Forum: Beginner Basics
Topic: Mikrotik and TP Link
Replies: 1
Views: 759

Re: Mikrotik and TP Link

At first, if I understood right, you have a double NAT (why do you use a tp-link?).
At second, do you have a public addresses on each computers? 193.x.x.x and 194.x.x.x aren't local addresses.
by bingo220
Mon Jan 19, 2015 6:59 pm
Forum: Beginner Basics
Topic: DHCP server Static lease
Replies: 3
Views: 1038

Re: DHCP server Static lease

Make more then one DHCP server (for each VLAN a DHCP server) It's possible. I use 24 DHCP servers for 24 VLANs with managed switch. Add a DHCP POOL but only known mac addresses can get a IP from the pool? I don't want to bind a specific IP to a MAC addres but use the DHCP POOL and only allow know M...
by bingo220
Wed Jan 14, 2015 9:06 am
Forum: Beginner Basics
Topic: Access DSL from LAN Side
Replies: 4
Views: 1943

Re: Access DSL from LAN Side

Scrummy , I made an access to the ADSL-modem from WAN and from LAN (using access rights). I'll just show my config. ADSL-modem is in bridge mode. modem's Web-port was changed from 80 to 9080 mikrotik's ethernet port connected to modem has a name "eth2", and ip 172.16.18.22/30 modem's ip = 172.16.18...
by bingo220
Tue Jan 13, 2015 10:18 pm
Forum: Beginner Basics
Topic: Auto connect to second provider
Replies: 9
Views: 4552

Re: Auto connect to second provider

hossain2004a, I have no ping problem (just checked).
Try to use the other hosts.
I think public NTP servers are good choice.
by bingo220
Sun Jan 11, 2015 9:26 pm
Forum: Beginner Basics
Topic: Failover Scripting
Replies: 5
Views: 1240

Re: Failover Scripting

I think it is because your connection is marked, in my example default-routes are non-marked.
by bingo220
Sat Jan 10, 2015 1:02 pm
Forum: Beginner Basics
Topic: DDNS - Update multiple interface
Replies: 4
Views: 1755

Re: DDNS - Update multiple interface

Try do it with "no-ip" ddns.
I think it has to work, because I can send even fake-ip to the server.
http://forum.mikrotik.com/viewtopic.php ... 44#p419745
by bingo220
Sat Jan 10, 2015 12:25 pm
Forum: Beginner Basics
Topic: Failover Scripting
Replies: 5
Views: 1240

Re: Failover Scripting

by bingo220
Wed Dec 31, 2014 2:26 pm
Forum: Beginner Basics
Topic: Cutwail Spambot
Replies: 2
Views: 1138

Re: Cutwail Spambot

/ip firewall filter add chain=forward prot=tcp dst-port=25 src-address-list=spammer act=drop comment="Block port-25 for SPAMMERS from spammer-list" add chain=forward prot=tcp dst-port=25 connection-limit=30,32 limit=50,5 src-address-list=!spammer action=add-src-to-address-list address-list=spammer ...
by bingo220
Wed Dec 24, 2014 11:54 am
Forum: Beginner Basics
Topic: Sharing Bandwidth
Replies: 2
Views: 655

Re: Sharing Bandwidth

by bingo220
Sat Dec 20, 2014 2:22 am
Forum: Beginner Basics
Topic: block all net but some sites no proxy
Replies: 5
Views: 3135

Re: block all net but some sites no proxy

/ip firewall address-list add list=blocked-comp address=192.168.1.20-192.168.1.35 comment="Blocked computers" /ip firewall filter add chain=forward src-address-list=blocked-comp dst-address-list=allow-www protocol=tcp dst-port=80 action=accept comment="Allow http for some sites" add chain=forward s...
by bingo220
Tue Dec 16, 2014 9:46 pm
Forum: Beginner Basics
Topic: script: check and reconnect pppoe-session.
Replies: 5
Views: 14431

Re: script: check and reconnect pppoe-session.

tpfresh , I use the same script. It's already corrected for you. Three steps... At first, add the routes: /ip route add dst-address=213.180.193.58 gateway=49.48.216.1 scope=10 comment="Static PING way by ISP1-host1" add dst-address=198.41.213.157 gateway=49.48.216.1 scope=10 comment="Static PING wa...
by bingo220
Tue Dec 16, 2014 3:22 pm
Forum: Beginner Basics
Topic: block all net but some sites no proxy
Replies: 5
Views: 3135

Re: block all net but some sites no proxy

/ip firewall address-list add list=blocked-comp address=192.168.1.20-192.168.1.35 comment="Blocked computers" add list=allow-www address=159.148.147.196 comment="Allow http://www.mikrotik.com" /ip firewall filter add chain=forward src-address-list=blocked-comp dst-address-list=allow-www protocol=tc...
by bingo220
Sun Dec 14, 2014 7:15 pm
Forum: Beginner Basics
Topic: Connect a Tenda Router to a ROS v5
Replies: 6
Views: 2668

Re: Connect a Tenda Router to a ROS v5

I think you need to disable DHCP-server on the Tenda LAN-setup. Then setup Tenda LAN ip-address as dhcp-client. Next step - connect Mikrotik-ether3 to LAN-port of Tenda.
I'll repeat again, don't use the WAN port of Tenda. Use LAN-port.
by bingo220
Tue Dec 09, 2014 11:56 am
Forum: Beginner Basics
Topic: Disabling / enabling interface with scheduler?
Replies: 3
Views: 1478

Re: Disabling / enabling interface with scheduler?

I would have made it easier System-Sheduler: Name: enable-eth Start Date: Jan/04/1970 Start Time: 05:30:00 Interval: 7d 00:00:00 On Event: /interface enable ether2 Policy: write,test,read System-Sheduler: Name: disable-eth Start Date: Jan/04/1970 Start Time: 21:45:00 Interval: 7d 00:00:00 On Event: ...
by bingo220
Thu Nov 20, 2014 3:41 pm
Forum: Beginner Basics
Topic: Loadbalancing multiple DHCP assigned Wan Interfaces to LAN
Replies: 4
Views: 2350

Re: Loadbalancing multiple DHCP assigned Wan Interfaces to L

I use 3 hosts for each ISP to check the availability of the Internet. This script changes the gateways in the routes if they are changed in the pppoe. ##### Script Settings ##### :local Wan1Name "pppoe1" :local Wan2Name "pppoe2" :local ComW1H1 "Static PING way by ISP1-host1" :local ComW1H2 "Static P...
by bingo220
Wed Nov 12, 2014 8:39 pm
Forum: Beginner Basics
Topic: Can't Remove prefix /32 Address List
Replies: 2
Views: 695

Re: Can't Remove prefix /32 Address List

:local vpnIP [/ip address get [find interface="vpn_Interface"] address]; :for i from=( [:len $vpnIP] - 1) to=0 do={:if ( [:pick $vpnIP $i] = "/") do={:set vpnIP [:pick $vpnIP 0 $i]}}; /ip firewall address-list add list="MY NETWORK" address=$vpnIP; /ip firewall address-list remove [/ip firewall addr...
by bingo220
Thu Oct 30, 2014 10:22 am
Forum: Beginner Basics
Topic: Safe firewall Settings
Replies: 5
Views: 2232

Re: Safe firewall Settings

miramanee, this is a standard rules. You can use it without problem.
by bingo220
Wed Oct 29, 2014 6:51 pm
Forum: Beginner Basics
Topic: Safe firewall Settings
Replies: 5
Views: 2232

Re: Safe firewall Settings

Change 192.168.88.0/24 if you are using different subnet. /ip firewall filter add chain=input connection-state=invalid action=drop comment="Drop input invalid connection packets" add chain=input connection-state=established action=accept comment="Allow input established connections" add chain=input ...
by bingo220
Mon Oct 27, 2014 3:15 pm
Forum: Beginner Basics
Topic: Block all ports but 80 and 1723
Replies: 7
Views: 26530

Re: Block all ports but 80 and 1723

...I just want it to allow all ports...
For allow all ports you need no rules.
by bingo220
Sun Oct 26, 2014 12:31 pm
Forum: Beginner Basics
Topic: Multiwan portforward
Replies: 3
Views: 907

Re: Multiwan portforward

I haven't time to test. /ip firewall mangle add action=mark-packet chain=forward comment="Mark forward from WAN1 to Server" in-interface=wan1 protocol=tcp dst-port=22,25,80,443 new-packet-mark=w1-srv add action=mark-packet chain=forward comment="Mark forward from WAN2 to Server" in-interface=wan2 pr...
by bingo220
Tue Oct 21, 2014 10:22 pm
Forum: Beginner Basics
Topic: Network Printer with 6.20
Replies: 5
Views: 848

Re: Network Printer with 6.20

I ve rb2100
What is rb2100?
how can i connect a usb printer
Not sure, but you can try metarouter+OpenWRT
http://wiki.mikrotik.com/wiki/Manual:Metarouter
by bingo220
Tue Oct 21, 2014 1:40 am
Forum: Beginner Basics
Topic: Port Forwarding Not working ... Confused
Replies: 4
Views: 1492

Re: Port Forwarding Not working ... Confused

pennytone,
Try to change a port. I think that 80 is busy by RB (web interface).
Or change www-port in "Winbox-IP-Services".
by bingo220
Fri Oct 17, 2014 2:14 pm
Forum: Beginner Basics
Topic: Port Forwarding Not working ... Confused
Replies: 4
Views: 1492

Re: Port Forwarding Not working ... Confused

chain=srcnat action=masquerade out-interface= pppoe-out1 log=no log-prefix="" chain=dstnat action=dst-nat to-addresses=192.168.88.252 to-ports=9987 protocol=udp in-interface= ether1-gateway dst-port=9987 log=no log-prefix="" Feel the difference? Your internet connection is "pppoe-out1". Use this nam...
by bingo220
Thu Oct 16, 2014 7:43 pm
Forum: Beginner Basics
Topic: pcc 4 wan to lan
Replies: 1
Views: 744

Re: pcc 4 wan to lan

...Can someone could give me some hints...? a little hint: 8) 4 WAN = "wan1-pppoe","wan2-pppoe","wan3-pppoe","wan4-pppoe" 1 LAN = "lan" /ip route add check-gateway=arp comment="WAN 4 - Distance 1" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wan4-pppoe routing-mark=wan4 add check-gateway=ar...
by bingo220
Sat Oct 11, 2014 12:19 am
Forum: Beginner Basics
Topic: Move config from x86 to routerboard
Replies: 5
Views: 1111

Re: Move config from x86 to routerboard

I would suggest next steps:
1. Terminal> /export file=file_name
2. Edit the created file.
3. Use this file on the new RB.
by bingo220
Fri Oct 10, 2014 12:03 pm
Forum: Beginner Basics
Topic: Port 25
Replies: 8
Views: 1906

Re: Port 25

first way: WinBox>Ip>Firewall>Address Lists
second way: Terminal> /ip fi addr export
third,fourth... script, log, etc.
by bingo220
Fri Oct 10, 2014 11:15 am
Forum: Beginner Basics
Topic: Port 25
Replies: 8
Views: 1906

Re: Port 25

Copy all text and paste it into terminal, then lift both of these rules in the top (Winbox>Ip>Firewall>Filter Rules). / ip firewall filter add action=drop chain=forward comment=\ "Block port-25 for SPAMMERS from spammer-list (rule-1)" dst-port=25 \ protocol=tcp src-address-list=spammer add action=ad...
by bingo220
Fri Oct 10, 2014 11:08 am
Forum: Beginner Basics
Topic: Router needs to be rebooted daily
Replies: 4
Views: 1486

Re: Router needs to be rebooted daily

If I understood right, you need reboot the router 1 time for a day:
/system scheduler
add interval=1d name=auto_reboot on-event="/system reboot" policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
    start-date=oct/10/2014 start-time=03:00:00
by bingo220
Thu Oct 09, 2014 7:50 pm
Forum: Beginner Basics
Topic: Port 25
Replies: 8
Views: 1906

Re: Port 25

/ ip firewall filter add action=drop chain=forward comment=\ "Block port-25 for SPAMMERS from spammer-list (rule-1)" dst-port=25 \ protocol=tcp src-address-list=spammer add action=add-src-to-address-list address-list=spammer address-list-timeout=\ 3d chain=forward comment=\ "Add SPAMMERS to spammer...
by bingo220
Fri Sep 26, 2014 9:19 pm
Forum: Beginner Basics
Topic: WIKI DDOS attack
Replies: 2
Views: 792

Re: WIKI DDOS attack

If I understood right,
"LIMIT" has to be a numbers.
Wiki says: "LIMIT should be a value of 100 or..."
by bingo220
Mon Sep 22, 2014 1:01 am
Forum: Beginner Basics
Topic: [SOLVED] VLAN cannot access internet
Replies: 9
Views: 2065

Re: VLAN cannot access internet

Log in modem's web interface - static routes and add the route for 192.168.253.0/255.255.255.0
Just look the active routes, you have route for 192.168.254.0, make same.
by bingo220
Mon Sep 22, 2014 12:03 am
Forum: Beginner Basics
Topic: [SOLVED] VLAN cannot access internet
Replies: 9
Views: 2065

Re: VLAN cannot access internet

clients on guest wifi network are unable to access internet...
assume ...
modem has an address in the subnet 192.168.254.x
requests come from a subnet 192.168.253.x
modem rejects those requests.
I think you should add to the modem a local route.
by bingo220
Sun Sep 21, 2014 6:32 pm
Forum: Beginner Basics
Topic: [SOLVED] VLAN cannot access internet
Replies: 9
Views: 2065

Re: VLAN cannot access internet

The first step, I propose to set up ppp-session on the RB. ADSL-modem has to be in the bridge-mode.
by bingo220
Tue Sep 16, 2014 2:15 pm
Forum: Beginner Basics
Topic: Winbox freeze when other wan disabled
Replies: 6
Views: 1093

Re: Winbox freeze when other wan disabled

I use these rules: /ip firewall mangle add action=mark-connection chain=input comment="Mark WINBOX incoming (isp2)" \ dst-port=8291 in-interface=wan2 new-connection-mark=winbox-isp2 \ passthrough=no protocol=tcp src-address-list=remote-admin add action=mark-routing chain=output comment="Mark WINBOX ...
by bingo220
Tue Sep 16, 2014 12:04 am
Forum: Beginner Basics
Topic: Winbox freeze when other wan disabled
Replies: 6
Views: 1093

Re: Winbox freeze when other wan disabled

Because default gateway is WAN1.
by bingo220
Sat Aug 30, 2014 3:15 pm
Forum: Beginner Basics
Topic: Need help on how to setup RB411 to be a AP on a RB2011
Replies: 2
Views: 712

Re: Need help on how to setup RB411 to be a AP on a RB2011

1. Create the bridge on RB411 (eth+wlan) with ip-address=192.168.0.2/24
2. Add the default route on the RB411 with gateway=192.168.0.1

I think that's enough.
by bingo220
Wed May 21, 2014 9:00 am
Forum: Beginner Basics
Topic: 2wans via rb951g,, not work,, this's code:
Replies: 4
Views: 833

Re: 2wans via rb951g,, not work,, this's code:

You have very different connections.
I would use a failover method, not a loadbanacing.
http://forum.mikrotik.com/viewtopic.php ... 20#p427103
by bingo220
Tue May 20, 2014 3:13 pm
Forum: Beginner Basics
Topic: Auto connect to second provider
Replies: 9
Views: 4552

Re: Auto connect to second provider

Many people use it and do not complain :) Just try it. Ok, I'll try explain about second method. Make sure that your internet-connections don't use "Add default route". To avoid problems, use the public DNS on the router, like 8.8.8.8. Choose four ping-hosts for check an internet accessibility (2 ho...
by bingo220
Tue May 20, 2014 1:59 pm
Forum: Beginner Basics
Topic: Auto connect to second provider
Replies: 9
Views: 4552

Re: Auto connect to second provider

Both my ISP use a PPPoE connections. PPPoE automatically adds the default-route. Because of it I need to disable this (uncheck "use-default-route"). If your connections is not added the default-route, you can skip this step. I suggest you start with a simple method http://wiki.mikrotik.com/wiki/Two_...
by bingo220
Tue May 20, 2014 11:27 am
Forum: Beginner Basics
Topic: Auto connect to second provider
Replies: 9
Views: 4552

Re: Auto connect to second provider

In the both interfaces uncheck "use-default-route"
next step:
simplest method http://wiki.mikrotik.com/wiki/Two_gateways_failover
the best method (for me) http://wiki.mikrotik.com/wiki/Advanced_ ... _Scripting
by bingo220
Fri Apr 25, 2014 11:51 pm
Forum: Beginner Basics
Topic: 2 wan pcc problem
Replies: 23
Views: 4214

Re: 2 wan pcc problem

Read my answer (config) here http://forum.mikrotik.com/viewtopic.php ... 99#p409010
Maybe it will be useful.
by bingo220
Mon Apr 14, 2014 4:26 pm
Forum: Beginner Basics
Topic: script: check and reconnect pppoe-session.
Replies: 5
Views: 14431

script: check and reconnect pppoe-session.

Sometimes I have the situation when pppoe-session is connected, but hasn't an internet. To fix it the pppoe must be reconnected. Made a script for myself. Maybe someone has the same problem. script's steps: 1. Check pppoe-session status connected (if not connected - stop script) 2. Ping "8.8.8.8" fi...
by bingo220
Sat Apr 05, 2014 7:17 pm
Forum: Beginner Basics
Topic: vlan + dhcp server
Replies: 9
Views: 4903

Re: vlan + dhcp server

I have 24 vlans with 24 dhcp servers, as yet works fine.
CCR-1016, ROS 6.11.
by bingo220
Fri Apr 04, 2014 5:46 pm
Forum: Beginner Basics
Topic: freedns.afraid.org Script
Replies: 36
Views: 29231

Re: freedns.afraid.org Script

By :local WANInter "WriteHereWanInterfaceName"
What name must i set there? the name from ether1 for example?
I use name "pppoe2-isp2"
If you don't use a ppp-session you need to use name of interface - ether1 etc.
The fake ip makes that you do not need to visit their re-activation page?
exactly.
by bingo220
Fri Apr 04, 2014 4:22 pm
Forum: Beginner Basics
Topic: freedns.afraid.org Script
Replies: 36
Views: 29231

Re: freedns.afraid.org Script

I've never used "freedns.afraid.org". I use "no-ip.com" (".biz" domain). I'll show my script. System-Scripts: Name: noip Policy: write,test,read Source: ##############Script Settings################## :local NOIPUser "WriteHereName" :local NOIPPass "WriteHerePassword" :local WANInter "WriteHereWanIn...
by bingo220
Thu Apr 03, 2014 12:52 pm
Forum: Beginner Basics
Topic: Port 80 always open
Replies: 12
Views: 2784

Re: Port 80 always open

subseven, port 80 takes "www" service.
It has to be closed if you followed this post:
You should consider disabling the www service for your wan port under IP -> Services:

/ip service
set www address=192.168.88.0/24

or even disable it completely:

/ip service
set www disabled=yes
by bingo220
Thu Apr 03, 2014 10:45 am
Forum: Beginner Basics
Topic: Port 80 always open
Replies: 12
Views: 2784

Re: Port 80 always open

I put in all the rules but now not only port 80 is open (tcp). Now even port 53 (udp) is open :D
udp 53 is open because of:
add chain=input protocol=udp action=accept comment=”Allow UDP”
Disable it if you need.
by bingo220
Wed Apr 02, 2014 7:32 pm
Forum: Beginner Basics
Topic: Port 80 always open
Replies: 12
Views: 2784

Re: Port 80 always open

/ip firewall filter add chain=input protocol=icmp action=accept comment=”Allow Ping” add chain=forward protocol=icmp action=accept add chain=input connection-state=established action=accept comment=”Accept established connections” add chain=forward connection-state=established action=accept add cha...
by bingo220
Tue Mar 25, 2014 12:00 am
Forum: Beginner Basics
Topic: vlan + dhcp
Replies: 22
Views: 3830

Re: vlan + dhcp

Maybe it's really bug.
I found this question http://forum.mikrotik.com/viewtopic.php ... 8&#p416264
Have anyone tried DHCP server on VLAN yet ? Any comments ?
Try to downgrade routerboard to ROS 6.7
by bingo220
Mon Mar 24, 2014 11:04 pm
Forum: Beginner Basics
Topic: vlan + dhcp
Replies: 22
Views: 3830

Re: vlan + dhcp

I'm not sure but try to delete those bridges:

/interface bridge port
add bridge=bridge-local disabled=yes interface=ether2
add bridge=bridge-local disabled=yes interface=ether3

then add "authoritative" options to dhcp servers and reboot router.
by bingo220
Mon Mar 24, 2014 9:26 pm
Forum: Beginner Basics
Topic: vlan + dhcp
Replies: 22
Views: 3830

Re: vlan + dhcp

/ip dhcp-server
add authoritative=yes address-pool=dhcp_vlan1_pool disabled=no interface=vlan1 name=dhcp_vlan1
add authoritative=yes address-pool=dhcp_vlan2_pool disabled=no interface=vlan2 name=dhcp_vlan2
by bingo220
Mon Mar 24, 2014 5:15 pm
Forum: Beginner Basics
Topic: vlan + dhcp
Replies: 22
Views: 3830

Re: vlan + dhcp

I showed the part of my own configuration.
24 vlans are using the 24 dhcp servers and it works fine.
by bingo220
Mon Mar 24, 2014 1:21 pm
Forum: Beginner Basics
Topic: vlan + dhcp
Replies: 22
Views: 3830

Re: vlan + dhcp

Sample: /interface vlan add name=vlan1 vlan-id=1001 interface=eth2 add name=vlan2 vlan-id=1002 interface=eth3 /ip address add address=192.168.1.1/24 interface=vlan1 add address=192.168.2.1/24 interface=vlan2 /ip pool add name=pool1 ranges=192.168.1.10-192.168.1.254 add name=pool2 ranges=192.168.2.1...
by bingo220
Thu Mar 13, 2014 7:31 pm
Forum: Beginner Basics
Topic: Force client over specific WAN on PPC load balancing
Replies: 3
Views: 5052

Re: Force client over specific WAN on PPC load balancing

I think so... /ip firewall address-list add list=stat-isp1 address=192.168.2.52 /ip firewall mangle add action=mark-routing chain=prerouting comment="Mark STATIC route to ISP1" dst-address-type=!local in-interface=BRIDGE new-routing-mark=to_ISP1 src-address-list=stat-isp1 Move this mangle-rule to th...
by bingo220
Sat Feb 15, 2014 7:40 pm
Forum: Beginner Basics
Topic: help me on VLANs settings
Replies: 7
Views: 1409

Re: help me on VLANs settings

i think you need to configure dsl modem in bridge mode.
by bingo220
Thu Feb 13, 2014 7:33 pm
Forum: Beginner Basics
Topic: 2 PPPoE PCC + failover, RouterOS 6.9
Replies: 4
Views: 4033

Re: 2 PPPoE PCC + failover, RouterOS 6.9

I have no wifi on the RB now. This config doesn't use a wifi module. Follow this guide: System - Reset Configuration (check "No Default Configuration) - Yes Plug ISP1 to port-1 Plug ISP2 to port-2 Plug computer to port-5 (5=master; 3+4=slave) Winbox (connect by mac-address) login:admin password: "N...
by bingo220
Tue Feb 11, 2014 9:25 pm
Forum: Beginner Basics
Topic: simple 2 WAN failover
Replies: 16
Views: 59194

Re: simple 2 WAN failover

Теоретически, проблем быть не должно. 1. Проверьте, что убраны галочки "use-default-route" на обоих интерфейсах pppoe. 2. Убеждаемся, что в ДНС записаны общедоступные серверы, дабы к ним был доступ с обоих подключений. 3. Нормальная реакция, если не разорвались старые сессии (фактически же маршрут с...
by bingo220
Tue Feb 11, 2014 1:51 am
Forum: Beginner Basics
Topic: simple 2 WAN failover
Replies: 16
Views: 59194

Re: simple 2 WAN failover

In the both pppoe-interfaces uncheck "use-default-route". (thx c0d3rSh3ll ) In the "IP-Services" disable unnecessary services. Delete all firewall rules. Delete all NAT rules. /ip route add distance=1 gateway=PPPoE1 comment="Default route to WAN1 (distance1)" add distance=2 gateway=PPPoE2 comment="D...
by bingo220
Wed Feb 05, 2014 5:35 pm
Forum: Beginner Basics
Topic: cannot ping router
Replies: 17
Views: 3089

Re: cannot ping router

1) Hide all ip-addresses in your previous post (cameras etc.)!!!
2) Add those rules to top and try ping.
add chain=input action=accept protocol=icmp comment="Allow input Ping"
add chain=forward action=accept protocol=icmp comment="Allow forward Ping"
by bingo220
Mon Jan 06, 2014 4:22 pm
Forum: Beginner Basics
Topic: IP address on eth port with vlans.
Replies: 7
Views: 1767

Re: IP address on eth port with vlans.

boo9 , I have no problem. 25 DHCP-servers work fine. My config (mikrotik eth12-port is connected to D-Link port-26) D-LINK SETUP: config vlan default delete 1-24 create vlan k01 tag 1001 config vlan k01 add untagged 1 config vlan k01 add tagged 26 create vlan k02 tag 1002 config vlan k02 add untagg...
by bingo220
Mon Jan 06, 2014 12:42 pm
Forum: Beginner Basics
Topic: IP address on eth port with vlans.
Replies: 7
Views: 1767

Re: IP address on eth port with vlans.

My config has 24 vlans on eth12-port. eth12-port has dhcp-server (192.168.200.0/24) vlan01 has dhcp-server (192.168.201.0/24) vlan02 has dhcp-server (192.168.202.0/24) ... vlan24 has dhcp-server (192.168.224.0/24) ----------------------------------------------- Network scheme is here http://forum.mi...
by bingo220
Wed Dec 25, 2013 3:38 pm
Forum: Beginner Basics
Topic: Wired connected Clients list
Replies: 2
Views: 2427

Re: Wired connected Clients list

IP-ARP
by bingo220
Mon Dec 16, 2013 7:35 pm
Forum: Beginner Basics
Topic: Is my firewall setup ok?
Replies: 17
Views: 2588

Re: Is my firewall setup ok?

I think the minimal protection has to look so: /ip firewall filter add chain=input protocol=icmp action=accept comment=”Allow Ping” add chain=forward protocol=icmp action=accept add chain=input connection-state=established action=accept comment=”Accept established connections” add chain=forward conn...
by bingo220
Sun Dec 01, 2013 2:08 pm
Forum: Beginner Basics
Topic: Same subnet wan problem
Replies: 1
Views: 941

Re: Same subnet wan problem

I'm not sure, but can try to change gateway-ip to the interface-name. /ip route add dst-address=0.0.0.0/0 gateway=WAN1 routing-mark=to_WAN1 check-gateway=ping add dst-address=0.0.0.0/0 gateway=WAN2 routing-mark=to_WAN2 check-gateway=ping add dst-address=0.0.0.0/0 gateway=WAN1 distance=1 check-gatewa...
by bingo220
Sun Dec 01, 2013 12:20 am
Forum: Beginner Basics
Topic: Locked out of mu Mikrotik 450g
Replies: 1
Views: 1272

Re: Locked out of mu Mikrotik 450g

If I right understood...
We have 3 ethernet ports:
1) eth1-"wan"
2) eth2-"lan1"
3) eth3-"lan2"
We need to use 1 "forward" rule for two lan intefaces:
add chain=forward action=accept in-interface=!wan
by bingo220
Sat Nov 30, 2013 2:30 pm
Forum: Beginner Basics
Topic: Cannot open websites
Replies: 11
Views: 2046

Re: Cannot open websites

chain=dstnat action=dst-nat to-addresses=192.168.xxxx to-ports=80 protocol=tcp dst-port=80
Try add to this rule "in-interface=pppoe"
p.s. and do the same for all "dst-nat" rules.
by bingo220
Thu Nov 28, 2013 4:44 pm
Forum: Beginner Basics
Topic: Cannot open websites
Replies: 11
Views: 2046

Re: Cannot open websites

Ok. I think we need to do next: 1. Download firmware here http://download2.mikrotik.com/routeros/6.6/routeros-mipsbe-6.6.npk 2. Restore RB to the Factory settings: WinBox-System-Reset Configuration - Keep User Configuration + No Default Configuration + Do Not Backup Reset Configuration,Yes. 3. Conne...
by bingo220
Thu Nov 28, 2013 2:09 pm
Forum: Beginner Basics
Topic: Cannot open websites
Replies: 11
Views: 2046

Re: Cannot open websites

it's really strange.
try connect computer directly to ISP - open PPPoE session on computer without RB.
Maybe ISP has a problem.
by bingo220
Thu Nov 28, 2013 1:26 pm
Forum: Beginner Basics
Topic: Cannot open websites
Replies: 11
Views: 2046

Re: Cannot open websites

I would suggest using a simple configuration and complicate it gradually, step by step. /ip firewall address-list add list=lan-ip address=192.168.XXX.XXX-192.168.XXX.XXX comment="All IP of my LAN" /ip firewall filter add chain=input connection-state=invalid action=drop comment="Drop input invalid co...
by bingo220
Thu Nov 28, 2013 12:05 pm
Forum: Beginner Basics
Topic: Cannot open websites
Replies: 11
Views: 2046

Re: Cannot open websites

try make a rule easier:
add action=masquerade chain=srcnat out-interface=pppoe src-address=192.168.0.0/16 to-addresses=0.0.0.0
add action=masquerade chain=srcnat out-interface=pppoe
by bingo220
Mon Nov 18, 2013 8:52 pm
Forum: Beginner Basics
Topic: Load Balancing on Static IPs
Replies: 11
Views: 2670

Re: Load Balancing on Static IPs

try this config: /ip address add address=10.1.1.1/24 interface=Lan network=10.1.1.0 add address=192.168.1.3/24 interface=WAN1 network=192.168.1.0 add address=192.168.2.2/24 interface=WAN2 network=192.168.2.0 /ip route add check-gateway=arp comment="WAN 1 – Distance 1" disabled=no distance=1 dst-addr...
by bingo220
Fri Nov 08, 2013 12:57 pm
Forum: Beginner Basics
Topic: 2 WAN WITHOUT LOAD BALANCING
Replies: 6
Views: 2865

Re: 2 WAN WITHOUT LOAD BALANCING

your configuration really has the Failover-mode for VPN with IPsec ?
I use 2 PPPoE connections, and failover works wonderful.
My example is based on this page.
by bingo220
Wed Nov 06, 2013 4:44 pm
Forum: Beginner Basics
Topic: 2 WAN WITHOUT LOAD BALANCING
Replies: 6
Views: 2865

Re: 2 WAN WITHOUT LOAD BALANCING

This config has to work. It hasn't the loadbalancing-mode, but has the Failover-mode. You have to change "x" in 10.x.5.1 and 10.x.7.254. Uncheck box "Add default route" in both ISP-connections, if it's using now. Also change AAA.AAA.AAA.AAA to ip-address of Gateway ISP1 (only IP! not interface-name ...
by bingo220
Tue Nov 05, 2013 5:59 pm
Forum: Beginner Basics
Topic: Mikrotik RouterBoard 1200 support spam blocker or not?
Replies: 2
Views: 621

Re: Mikrotik RouterBoard 1200 support spam blocker or not?

/ ip firewall filter add chain=forward prot=tcp dst-port=25 src-address-list=spammer act=drop comment="Block port-25 for SPAMMERS from spammer-list" add chain=forward prot=tcp dst-port=25 connection-limit=30,32 limit=50,5 src-address-list=!spammer action=add-src-to-address-list address-list=spammer...
by bingo220
Thu Oct 31, 2013 12:53 am
Forum: Beginner Basics
Topic: Failover with 4xWAN
Replies: 3
Views: 1099

Re: Failover with 4xWAN

Try this config: (Changing the default route takes 20 seconds) /ip route add dst-address=151.197.0.38 gateway=192.168.2.2 scope=10 comment="Static PING way by ISP1-host1" add dst-address=4.2.2.1 gateway=192.168.2.2 scope=10 comment="Static PING way by ISP1-host2" add dst-address=151.197.0.39 gateway...
by bingo220
Tue Oct 29, 2013 12:40 am
Forum: Beginner Basics
Topic: NO-IP DDNS Script - help please
Replies: 4
Views: 2109

Re: NO-IP DDNS Script - help please

I have no problem with this script.
It makes ddns-record only when ip-address was changed.
Just try to create a new script and run it manually (1 time in 2 minutes).
Sorry for my bad english.
by bingo220
Mon Oct 28, 2013 7:39 pm
Forum: Beginner Basics
Topic: NO-IP DDNS Script - help please
Replies: 4
Views: 2109

Re: NO-IP DDNS Script - help please

I use this script (for "name.no-ip. BIZ ") Change ".BIZ" to your domain. ##############Script Settings################## :local NOIPUser "username" :local NOIPPass "password" :local WANInter "wan-interface-name" ############################################### :local NOIPDomain "$NOIPUser.no-ip.biz" ...
by bingo220
Fri Oct 25, 2013 1:15 am
Forum: Beginner Basics
Topic: netwatch help
Replies: 1
Views: 483

Re: netwatch help

I used this guide.
It works wonderful.
One thing: each "gateway=xxx.xxx.xxx.xxx" you have to use only IP! Don't use "interface-name"!
by bingo220
Wed Oct 16, 2013 1:48 pm
Forum: Beginner Basics
Topic: Router Configuration
Replies: 5
Views: 1269

Re: Router Configuration

Try to add "out-interface=ether1" to each nat-rule.
by bingo220
Sun Oct 13, 2013 1:23 pm
Forum: Beginner Basics
Topic: need help config DHCP
Replies: 2
Views: 539

Re: need help config DHCP

What interface is registered in the dhcp-server?
like this?:
/ ip dhcp-server
add name="dhcp-server-name" interface=bridge-name address-pool="dhcp-pool-name" disabled=no
by bingo220
Sun Oct 13, 2013 10:42 am
Forum: Beginner Basics
Topic: 6.4 cant login via webfig (FIXED)
Replies: 4
Views: 1208

Re: 6.4 cant login via webfig

I get server error
I think you tried log in webbox.
webfig and webbox are different things.
Try to use this link: http://your_router_ip/webfig/
by bingo220
Sat Oct 12, 2013 8:02 pm
Forum: Beginner Basics
Topic: Bonding 2 WAN Connections
Replies: 13
Views: 45465

Re: Bonding 2 WAN Connections

2) Redundancy/Failover doesnt work, if i disconnect one Link on either Wan, internet continues to be supplied to LAN but on returning the link, it remains "down" until router is rebooted. This happens for whichever WAN i do. I'm not sure, but read please " Workaround 1 " here http://wiki.mikrotik.c...
by bingo220
Sat Oct 12, 2013 12:01 pm
Forum: Beginner Basics
Topic: Monitor ADSL Speed via Mikrotik ?
Replies: 2
Views: 1692

Re: Monitor ADSL Speed via Mikrotik ?

I bad know english, but will try explain how I made it. I need control ADSL-parameters by modem's web-interface from LAN and from internet (only from ip:123.123.123.123). My LAN-ip: 192.168.200.0/24 My Internet-connection name: pppoe-wan My remote-internet-ip (This is ip-address of other office): 12...
by bingo220
Wed Oct 02, 2013 2:48 pm
Forum: Beginner Basics
Topic: Problem with configuration PPoE
Replies: 12
Views: 2304

Re: Problem with configuration PPoE

Все заработало
Мои поздравления, удачи в дальнейшей настройке.
by bingo220
Wed Oct 02, 2013 2:32 pm
Forum: Beginner Basics
Topic: Problem with configuration PPoE
Replies: 12
Views: 2304

Re: Problem with configuration PPoE

Понизить именно так, как описал в предыдущем посте.
Для начала желательно сбросить настроики RB в дефолт, отказавшись от предустановленного конфига.
Качаем 4-ю версию с сайта микротика (естественно, под правильный процессор).
Закидываем файл на RB в "Files".
В теминале вводим /system package downgrade
by bingo220
Wed Oct 02, 2013 1:34 pm
Forum: Beginner Basics
Topic: Problem with configuration PPoE
Replies: 12
Views: 2304

Re: Problem with configuration PPoE

Если удачно все работало на старой прошивке, откатитесь, проверьте работоспособность конфига еще раз.
Это возможно только при понижени до версии не ниже 2.7.20. Загрузите пакеты более старой версии на маршрутизатор через FTP и затем используйте команду /system package downgrade.
by bingo220
Wed Oct 02, 2013 12:34 pm
Forum: Beginner Basics
Topic: Problem with configuration PPoE
Replies: 12
Views: 2304

Re: Problem with configuration PPoE

Дабы исключить аппаратную поломку, я бы протестировал описанную конфигурацию на vmware (с идентичной ROS).
Если конфиг отрабатывает свое назначение, то сброс в дефолт и перепрошивка RB.
Прошивка не решает проблему - RB в мусор, покупка нового RB. М.б. резковато, но действенно ;)
by bingo220
Wed Oct 02, 2013 11:46 am
Forum: Beginner Basics
Topic: Problem with configuration PPoE
Replies: 12
Views: 2304

Re: Problem with configuration PPoE

Попробуйте упростить правило маскарадинга
/ip firewall nat
вместо:
add action=masquerade chain=srcnat dst-address=!192.168.0.0 src-address=192.168.88.0
прописать:
add chain=srcnat out-interface=pppoe-out1 action=masquerade
by bingo220
Tue Oct 01, 2013 10:59 pm
Forum: Beginner Basics
Topic: Client's Browsing history(log) view and store in windows PC
Replies: 14
Views: 21720

Re: Client's Browsing history(log) view and store in windows

nawshad , thank you very much for this description. I tried to save web-surfing history into rb-memory (without a remote log-server). Unfortunately, log-file contains a lot garbage. Opening the one page is logged about 30 rows (even with option "!debug") Is it possible to make it more readable, lik...
by bingo220
Mon Sep 30, 2013 2:22 am
Forum: Beginner Basics
Topic: Queues setup.
Replies: 2
Views: 1562

Re: Queues setup.

what is the result of this configuration? Thanks for the reply. This config makes all vlans receive a dynamicaly-identical internet speed. And when I'll add restriction (Limit at) to any vlans the others will divide the remained speed. It works. But I'm not sure about some parameters - "queue types...
by bingo220
Sun Sep 22, 2013 11:24 pm
Forum: Beginner Basics
Topic: Queues setup.
Replies: 2
Views: 1562

Queues setup.

Hi all. Very hope to get a help here. Will use a google-translator, sorry. I need equally divide the internet speed between vlans. And if it's possible equally divide speed between vlan users. Have 2 ISP in failover mode. ISP1 (cable)- 100/20 mbit/s ISP2 (ADSL) - 17/1 mbit/s For example, what I want...