Community discussions

MikroTik App

Search found 32 matches

by paris9
Sat Jun 30, 2018 10:42 pm
Forum: Scripting
Topic: STATEFULL FIREWALL RULE QUESTION [SOLVED]
Replies: 2
Views: 712

Re: STATEFULL FIREWALL RULE QUESTION [SOLVED]

There's also relatively new state "untracked". It's meant for packets you want to get through router without connection tracking. The usual way to deal with them is to accept untracked together with established and related, and it's safe, because packets don't become untracked unless you tell them ...
by paris9
Sat Jun 30, 2018 11:58 am
Forum: Scripting
Topic: STATEFULL FIREWALL RULE QUESTION [SOLVED]
Replies: 2
Views: 712

STATEFULL FIREWALL RULE QUESTION [SOLVED]

Would there ever be a reason to use “connection-state=new” below the line “action=drop connection-state=invalid” ? For example, if at the top of my forward rules I say: add chain=forward action=accept connection-state=established,related add chain=forward action=drop connection-state=invalid Is it n...
by paris9
Wed Jun 20, 2018 6:13 pm
Forum: Scripting
Topic: protected-routerboot=enabled
Replies: 2
Views: 1946

Re: protected-routerboot=enabled

It seems like something is not right because this article (https://wiki.mikrotik.com/wiki/Manual:RouterBOARD_settings) states that "protected-routerboot=enabled will disable any access to the RouterBOOT configuration settings over a console cable and disables operation of the reset button to change ...
by paris9
Wed Jun 20, 2018 11:38 am
Forum: Scripting
Topic: protected-routerboot=enabled
Replies: 2
Views: 1946

protected-routerboot=enabled

I am shipping a configured vanilla RouterBoard 850Gx2 to a customer and I want to ensure that if the router ends up in the wrong hands that only the hardware is stolen. In other words, I want to ensure the best possible protection for the /system scripts which contains secret keys, etc. I read in an...
by paris9
Thu Dec 22, 2016 9:41 pm
Forum: General
Topic: /IP DNS QUESTION
Replies: 12
Views: 1579

Re: /IP DNS QUESTION

It works! When the Internet is disconnected and I browse to http://www.local.net, the site stumbles at first because it's looking for one remote javascript lib that's not being served locally (this is my issue) and then everything else loads lightning fast. Then, when I connect the Internet everythi...
by paris9
Thu Dec 22, 2016 8:55 pm
Forum: General
Topic: /IP DNS QUESTION
Replies: 12
Views: 1579

Re: /IP DNS QUESTION

Ok, I will try on the Input chain.
by paris9
Thu Dec 22, 2016 8:54 pm
Forum: General
Topic: /IP DNS QUESTION
Replies: 12
Views: 1579

Re: /IP DNS QUESTION

Thanks! I made the changes to the regexp and layer7 is working now, but there is still no speed improvement. Here are the results: Setup: /ip firewall filter chain=output action=reject reject-with=icmp-port-unreachable protocol=udp layer7-protocol=local.net dst-port=53 log=yes log-prefix="(53 reject...
by paris9
Thu Dec 22, 2016 8:06 pm
Forum: General
Topic: /IP DNS QUESTION
Replies: 12
Views: 1579

Re: /IP DNS QUESTION

Thanks for the explanation and help. I just got the last reply while about to reply with the below info, so I will send this anyway and still look into the new information. I am not seeing anything in the OUTPUT chain while the Internet is disconnected. I only see the OUTPUT chain when the Internet ...
by paris9
Thu Dec 22, 2016 10:10 am
Forum: General
Topic: /IP DNS QUESTION
Replies: 12
Views: 1579

Re: /IP DNS QUESTION

Can anyone reproduce my original post? I am wondering if this is a ROS issue?
by paris9
Thu Dec 22, 2016 9:14 am
Forum: General
Topic: /IP DNS QUESTION
Replies: 12
Views: 1579

Re: /IP DNS QUESTION

Thanks for the help, unfortunately that has not solved my issue. I tried adding local.net to the static address and also the layer7 suggestion. The problem as originally described still stands. I should note that I have tried on several PC's and a MacBook all with the firewalls and virus protection ...
by paris9
Wed Dec 21, 2016 1:00 pm
Forum: General
Topic: /IP DNS QUESTION
Replies: 12
Views: 1579

/IP DNS QUESTION

Hello! This is a DNS Server related issue. Thanks for any help:) Problem: I have a web server named http://www.local.net on the LAN. I have entered a static dns entry for this server into /ip dns static. I am accessing http://www.local.net from a PC that is also on the LAN. When the Internet is conn...
by paris9
Fri Apr 15, 2016 2:22 am
Forum: Scripting
Topic: /interface ethernet get tx-bytes is now an Array with three items?
Replies: 4
Views: 1160

Re: /interface ethernet get tx-bytes is now an Array with three items?

The output is one array because one bug is present??? if the value is 9,364,244,108 the output is treated as array, because "," are present??? 9 364 244 108 or the final number can be greather than one integer number and array is used to storing the value? integer can be only between +2,147,483,647...
by paris9
Fri Apr 15, 2016 1:48 am
Forum: Scripting
Topic: /interface ethernet get tx-bytes is now an Array with three items?
Replies: 4
Views: 1160

Re: /interface ethernet get tx-bytes is now an Array with three items?

The output is one array because one bug is present??? if the value is 9,364,244,108 the output is treated as array, because "," are present??? 9 364 244 108 or the final number can be greather than one integer number and array is used to storing the value? integer can be only between +2,147,483,647...
by paris9
Fri Apr 15, 2016 12:58 am
Forum: Scripting
Topic: /interface ethernet get tx-bytes is now an Array with three items?
Replies: 4
Views: 1160

/interface ethernet get tx-bytes is now an Array with three items?

ROS Version: 6.34.3 (stable) /interface ethernet :put [:typeof [get ether1 tx-bytes]] This used to produce an integer as shown in this documentation, but now it's a three-part array. http://wiki.mikrotik.com/wiki/Manual:Interface/Ethernet Can anyone help with the documentation/definition for the out...
by paris9
Tue Mar 15, 2016 7:18 pm
Forum: General
Topic: https check-certificate howto with self-created ca/cert
Replies: 2
Views: 1158

Re: https check-certificate howto with self-created ca/cert

It says that it can't get CRL (revocation list). So from the look of it, without any testing, I'd it's either: a) you included CRL URL in your certificate, it's not accessible and RouterOS is probably right to complain b) there is no such thing in your certificate, RouterOS invented it out of nothi...
by paris9
Tue Mar 15, 2016 10:34 am
Forum: General
Topic: https check-certificate howto with self-created ca/cert
Replies: 2
Views: 1158

https check-certificate howto with self-created ca/cert

Hello, Any help would be appreciated :D I created my own CA and server certificate and installed them into apache2. Note that this is not a self-signed certificate, but a CA and server certificate signed by the CA. Firefox, Internet Explorer, and Chrome all recognizing the server certificate and CA ...
by paris9
Mon Mar 31, 2014 7:59 am
Forum: Scripting
Topic: Please help with a string conversion
Replies: 3
Views: 851

Re: Please help with a string conversion

Thank you! You solved my problem :D
by paris9
Sun Mar 30, 2014 9:26 pm
Forum: Scripting
Topic: Please help with a string conversion
Replies: 3
Views: 851

Please help with a string conversion

The output below currently gives me the hex to ascii conversion for one and a string for the other.
How can I get "A" as the result for both of the statements below?

{
:put "\41";

:local a "41";
:put "\\$a";
}

Output:
A
\41
by paris9
Sun Mar 30, 2014 12:47 am
Forum: Scripting
Topic: Script MD5 Hash Generator
Replies: 7
Views: 9429

Re: Script MD5 Hash Generator

I have been trying out your script and was wondering if you could help me with a problem. I have been unable to get a match with php's md5 for messages lengths over 55 chars. If you could provide any insight as to why this might be it would be greatly appreciated. I have included two debug logs, one...
by paris9
Thu Mar 20, 2014 10:24 am
Forum: General
Topic: DHCP FOR ETHER3 WORKS ON WINDOWS7 BUT NOT ON LINUX - HELP
Replies: 1
Views: 693

Re: DHCP FOR ETHER3 WORKS ON WINDOWS7 BUT NOT ON LINUX - HEL

Update: I configured the same device with RouterOS 6.10 with NO change in results - same problems. Next, I configured my Linux Laptop for 100m full duplex no negotiation - same problems. Next, I noticed that the light for ether3 was not coming on like for ether2, 4, and 5. -The interface is not show...
by paris9
Thu Mar 20, 2014 5:49 am
Forum: General
Topic: DHCP FOR ETHER3 WORKS ON WINDOWS7 BUT NOT ON LINUX - HELP
Replies: 1
Views: 693

DHCP FOR ETHER3 WORKS ON WINDOWS7 BUT NOT ON LINUX - HELP

Help! :D ENVIRONMENT: -RouterBoard 952-2n -RouterOS 6.9 PROBLEM: I have been trying to setup dhcp-server for ether3, 4 and 5. -When I connect my Windows7 laptop, ether3,4, and 5 deliver an appropriate dhcp address- no problem! -When I connect my Linux laptop, ether4 and 5 deliver an appropriate dhc...
by paris9
Sat Feb 08, 2014 2:42 am
Forum: Scripting
Topic: Performance Problems with /System routerboard get model
Replies: 1
Views: 762

Re: Performance Problems with /System routerboard get model

So here is an update on this: I have worked around the problem by reading the "/system routerboard" values into global variables- I read them once now. However, it is my guess that this is a firmware related issue.
by paris9
Sat Feb 08, 2014 2:37 am
Forum: Scripting
Topic: Date changes during bootup
Replies: 5
Views: 956

Re: Date changes during bootup

Thanks everyone for the responses. It makes sense, no battery.. I can work around that :)
by paris9
Fri Feb 07, 2014 10:53 am
Forum: Scripting
Topic: Date changes during bootup
Replies: 5
Views: 956

Re: Date changes during bootup

So the clock defaults to dec/31/2001 until its fully booted?
by paris9
Fri Feb 07, 2014 9:10 am
Forum: Scripting
Topic: Date changes during bootup
Replies: 5
Views: 956

Date changes during bootup

Hello again :) This is my environment: # ROS version: 6.9 # RB firmware: 3.10 When I boot the router and look at my log, I see that the clock shows December 31, 2001 for the first 14 seconds or so and then changes to the correct date and time. Is this by design or do I need to configure something? h...
by paris9
Fri Feb 07, 2014 9:05 am
Forum: Scripting
Topic: Performance Problems with /System routerboard get model
Replies: 1
Views: 762

Performance Problems with /System routerboard get model

Hi, This is my environment: # ROS version: 6.9 # RB firmware: 3.10 I am running a simple repetition test on the following commands. After reboot the script takes less than a second to execute. However, after numerous repetitions it takes minutes and eventually my router freezes and reboots. This is ...
by paris9
Tue Feb 04, 2014 11:40 pm
Forum: Scripting
Topic: Array Problem
Replies: 5
Views: 1486

Re: Array Problem

Thanks for verifying this :)
I am going to update!

I just updated and it works great!!!
by paris9
Mon Feb 03, 2014 9:53 pm
Forum: Scripting
Topic: Array Problem
Replies: 5
Views: 1486

Re: Array Problem

Thank you :)

I am running version 6.7
by paris9
Mon Feb 03, 2014 9:04 pm
Forum: Scripting
Topic: Array Problem
Replies: 5
Views: 1486

Re: Array Problem

Anyone? What am I doing wrong here?
by paris9
Mon Feb 03, 2014 10:01 am
Forum: Scripting
Topic: Array Problem
Replies: 5
Views: 1486

Array Problem

This is the output that I would like to see: pear=Mikrotik peach=Abe apple=12345 However, the script below is giving me this output: 0=pear;0=Mikrotik 1=peach;1=Abe apple=12345 Any ideas why? { :local arr {""}; \ :set arr {\ "apple"=12345 ;\ "pear"=[/system identity get name;] ;\ "peach"="Abe" }; \ ...
by paris9
Mon Feb 03, 2014 9:52 am
Forum: Scripting
Topic: Data Type: Array, os 6.7, key => value
Replies: 1
Views: 1017

Data Type: Array, os 6.7, key => value

This is the output that I would like to see: pear=Mikrotik peach=Abe apple=12345 However, this is what I am receiving: 0=pear;0=Mikrotik 1=peach;1=Abe apple=12345 Any ideas why? The script: { :local arr {""}; \ :set arr {\ "apple"=12345 ;\ "pear"=[/system identity get name;] ;\ "peach"="Abe" }; \ :p...