Community discussions

MikroTik App

Search found 12485 matches

  • 1
  • 2
  • 3
  • 4
  • 5
  • 42
by rextended
Tue Feb 27, 2024 12:49 am
Forum: Scripting
Topic: export scripts from the repository saved under a specific owner
Replies: 8
Views: 327

Re: export scripts from the repository saved under a specific owner

False, already are implemented the export of specific scripts... /system script export where owner=admin or /system script export where name=<script name> The problem is to import it for specific user... ******************************* I write this to extract at least all possible commands and param...
by rextended
Sun Feb 25, 2024 1:41 pm
Forum: Scripting
Topic: $PIANO - interactive "player piano" & studio-quality recorder using :beep
Replies: 6
Views: 638

Re: $PIANO - interactive "player piano" & studio-quality recorder using :beep

$PIANO - interactive "player piano" & studio-quality recorder using :beep

Bravo. 👏👏👏👏👏👏
by rextended
Sun Feb 25, 2024 1:39 pm
Forum: Scripting
Topic: Creating a script for sending SMS
Replies: 14
Views: 1385

Re: Creating a script for sending SMS

Since SMS are free, send one sms each 12h... or you use more than 60GB every 12h? https://telemach.hr/poslovni/mobilna-telefonija Pravi je problem što 5G nije osmišljen kao rješenje za zamjenu optičkih vlakana, to se tako prenosi, ali onda svaka firma na ovaj ili onaj način pokušava omesti one koji ...
by rextended
Sat Feb 24, 2024 10:15 am
Forum: General
Topic: removing remote address from all pppoe secret [SOLVED]
Replies: 2
Views: 184

Re: removing remote address from all pppoe secret [SOLVED]

At your own risk:

/ppp secret set [find] !remote-address
by rextended
Fri Feb 23, 2024 11:11 pm
Forum: General
Topic: A place for poetry
Replies: 60
Views: 246258

Re: A place for poetry

A new light in the sky.
there are fewer and fewer of us here –
We are not alone.
by rextended
Fri Feb 23, 2024 2:53 pm
Forum: General
Topic: Restarting interface when it's down ( based on status, not the ping )
Replies: 3
Views: 184

Re: Restarting interface when it's down ( based on status, not the ping )

Try manually setting the speed of the SFP port
... on both side.

The same thing I would have answered.
by rextended
Fri Feb 23, 2024 2:24 pm
Forum: Scripting
Topic: Automatic Simple Queue based on IPv6 Neighbors [SOLVED]
Replies: 3
Views: 312

Re: Automatic Simple Queue based on IPv6 Neighbors [SOLVED]

Writing that "Apparently MikroTik doesn't understand <insert wrong syntax here>" is quite arrogant. It's not up to RouterOS (MikroTik is the company) to figure out what you wanted to do and try to guess the commands you wanted executed. Apparently you doesn't understand script syntax. This...
by rextended
Wed Feb 21, 2024 4:18 pm
Forum: Beginner Basics
Topic: Site access problem
Replies: 4
Views: 257

Re: Site access problem

How can I fix it?
Nothing to do with any MikroTik products.

Ask/Change the ISP.
by rextended
Wed Feb 21, 2024 4:14 pm
Forum: Scripting
Topic: Scripts cannot run with permission denied V7.13.4
Replies: 8
Views: 609

Re: Scripts cannot run with permission denied V7.13.4

Please Suggest me any one how to fix netwatch host script 0) Do not hijack other people topic. 1) Read changelog before update. And not only the one for the <version you use>, but all changelogs between <previous version> and <version you use>. 2) If work, why upgrade? 3) Add "ftp" policy...
by rextended
Wed Feb 21, 2024 4:11 pm
Forum: Scripting
Topic: Scripts cannot run with permission denied V7.13.4
Replies: 8
Views: 609

Re: Scripts cannot run with permission denied V7.13.4

@mozerd
@rextended ... so why are you stateing point # 3) ?

@sims
FTP is needed to version 7.13 for dynu script to work
Thank you all for your input
by rextended
Wed Feb 21, 2024 4:03 pm
Forum: General
Topic: Public-Mikrotik-Bandwidth-Test-Server(s)
Replies: 1006
Views: 1108696

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

He was telling me it was the official bandwith test from mikrotik. He's a storyteller or you probably misunderstood. About ping: EDIT: May 16'th 2022 - ICMP Ping has been disabled. in the btest server. ( This was done to prevent ping-speed tests against this btest server ) Is the first line of the ...
by rextended
Mon Feb 19, 2024 6:51 pm
Forum: Scripting
Topic: Scripts cannot run with permission denied V7.13.4
Replies: 8
Views: 609

Re: Scripts cannot run with permission denied V7.13.4

1) Read changelog before update. And not only the one for the 7.13, but all changelogs between 7.11 and 7.13.

2) If work, why upgrade?

3) Add "ftp" policy.
by rextended
Thu Feb 15, 2024 9:52 pm
Forum: Scripting
Topic: Script MD5 Hash Generator
Replies: 20
Views: 17392

Re: Script MD5 Hash Generator

Thanks for sharing, There are very few errors, and the writing style is acceptable. I like that you are inspired from my scripts... https://forum.mikrotik.com/viewtopic.php?t=177551#p965201 just at the start... :local strMessage [:tostr "$1"] is like :local strMessage [:tostr [:tostr $1 ]]...
by rextended
Thu Feb 15, 2024 9:48 pm
Forum: Scripting
Topic: MikroTik Script to restore backup in scheduler [SOLVED]
Replies: 7
Views: 2330

Re: MikroTik Script to restore backup in scheduler [SOLVED]

In this case, it is of no use,
otherwise if you have to do multiple operations on the same file
it is simpler to write a script using a variable/constant that represents the name of the file,
without rewriting it entirely each time.
by rextended
Thu Feb 15, 2024 1:26 pm
Forum: Scripting
Topic: MikroTik Script to restore backup in scheduler [SOLVED]
Replies: 7
Views: 2330

Re: MikroTik Script to restore backup in scheduler [SOLVED]

/y at the end is wrong and useless. Not working without it though Still wrong, becayse "/" before the y is useless, and is still useless inside the scheduler. "y" only can be used just if the script is tested on terminal. It's like this and there's nothing you can do about it.
by rextended
Thu Feb 15, 2024 10:24 am
Forum: Scripting
Topic: Script breaks on ROS 7 due to changes in date format
Replies: 4
Views: 345

Re: Script breaks on ROS 7 due to changes in date format

Or without errors:

RouterOS 7.10+ code

{
:local ds    [/system clock get date]
:local mm    [:tonum [:pick $ds 5  7]]
:local dd    [:tonum [:pick $ds 8 10]]
:local senha "user*$($mm * $dd)"
/ip hotspot user set "user" password=$senha
}
by rextended
Wed Feb 14, 2024 1:47 pm
Forum: Scripting
Topic: /port using the used-by property
Replies: 20
Views: 706

Re: /port using the used-by property

With where and the "and"s:
Rex, thank you. Please explain for me (so that I understand for the future)- why do you still need where?

Without where and the "and"s:
Rx tk u pl. exp. 4 me so that I u-stand 4 future why u still need where?
by rextended
Wed Feb 14, 2024 11:38 am
Forum: Scripting
Topic: /port using the used-by property
Replies: 20
Views: 706

Re: /port using the used-by property

I can't have any usb port to test, only serials, but the syntax is this:
/port
:foreach item in=[find where name~"usb" and used-by="" and inactive=no] do={:put [get $item name]}
by rextended
Tue Feb 13, 2024 7:12 pm
Forum: Scripting
Topic: Test if array is associative, multi-dimensional, or simple list [SOLVED]
Replies: 15
Views: 765

Re: Test if array is associative, multi-dimensional, or simple list [SOLVED]

All possible cases inside one function. II skipped the recursive check to see how many sub-arrays there are within the sub-arrays and so on, it seemed excessive to me. :global testArray do={ :local isNumeric false :local isMapped false :local arrayNumeric false :local mappedNumeric false :foreach tm...
by rextended
Tue Feb 13, 2024 5:56 pm
Forum: Scripting
Topic: /port using the used-by property
Replies: 20
Views: 706

Re: /port using the used-by property

(don't worry, I'm only offended by those who plot behind my back, cowards and traitors...)

********************

As already written...
What you really want is
/port print where used-by=""
:put [/port find where used-by=""]
by rextended
Tue Feb 13, 2024 3:47 pm
Forum: Scripting
Topic: /port using the used-by property
Replies: 20
Views: 706

Re: /port using the used-by property

You still not read what I write.

Retry.
by rextended
Tue Feb 13, 2024 3:46 pm
Forum: Scripting
Topic: if / else in telnet
Replies: 6
Views: 484

Re: if / else in telnet

You want create a port scanner or test if http service is up on one server?
by rextended
Tue Feb 13, 2024 3:19 pm
Forum: Scripting
Topic: /port using the used-by property
Replies: 20
Views: 706

Re: /port using the used-by property

/port :foreach item in=[find] do={ :put [get $item "used-by"] } First, use right syntax Second, the "find" results are ids, not field value. I do not have usb2, only serial0: :put [/port find where name=serial0] *1 ok, *1 is the id of the serial0 :put [/port find name=serial0 !i...
by rextended
Mon Feb 12, 2024 3:48 pm
Forum: Scripting
Topic: Test if array is associative, multi-dimensional, or simple list [SOLVED]
Replies: 15
Views: 765

Re: Test if array is associative, multi-dimensional, or simple list [SOLVED]

[some concepts I already know you know, but the explanation is for others who don't know] I do not understand what you mean :global x [:toarray ""] create the array :set ($x->9) 9 set the index 9 (zero based) to 9 :put [:len $x] the lenght is 10 (from 0 to 9) because previous instruction a...
by rextended
Mon Feb 12, 2024 2:50 pm
Forum: Scripting
Topic: Test if array is associative, multi-dimensional, or simple list [SOLVED]
Replies: 15
Views: 765

Re: Test if array is associative, multi-dimensional, or simple list [SOLVED]

One array can contain all types of data, can only be used "foreach" for search if a sub-array exist. if ->0 is undefined ("nothing"), but the lenght is > 0, the array have only key pairs, if last ->n is defined (can also be "nil"), and is the same length (- 1) of the ar...
by rextended
Sat Feb 10, 2024 1:11 pm
Forum: Wireless Networking
Topic: Set COUNTRY parameter - WAP ac LTE6 [SOLVED]
Replies: 8
Views: 428

Re: Set COUNTRY parameter - WAP ac LTE6 [SOLVED]

The most important thing in Italy is that you cannot transmit beyond your property with excessive residue, or create point-to-point connections that cross public land or other private property not of the same starting owner (no mater the power or the scope). (WISPs and those who can install them pay...
by rextended
Fri Feb 09, 2024 7:35 pm
Forum: General
Topic: Howto locate the parent address entry (subnet/range definition) of an IP ?
Replies: 3
Views: 302

Re: Howto locate the parent address entry (subnet/range definition) of an IP ?

Is for find the IP in-side x.x.x.0/something, not exact IP.

The default firewall already drop all not allowed.
by rextended
Fri Feb 09, 2024 1:19 pm
Forum: General
Topic: Howto locate the parent address entry (subnet/range definition) of an IP ?
Replies: 3
Views: 302

Re: Howto locate the parent address entry (subnet/range definition) of an IP ?

I find it wrong to put the blacklist before the whitelist. First of all must pass the whitelisted IPs, then block the blacklisted IPs. Or do something like this, that prevent IP on whitelist to be blocked if one range on blacklist include them. /ip firewall filter add action=drop chain=forward dst-a...
by rextended
Thu Feb 08, 2024 11:36 am
Forum: General
Topic: How to query the entry by "unset" parameter [SOLVED]
Replies: 4
Views: 313

Re: How to query the entry by "unset" parameter [SOLVED]

In all of your attempts, everytime what is after the = is everytime one string: "", nil, nill, nul, null, unset, with or without "".

Easy:
/ip firewall nat print where !src-address

or:
/ip firewall nat print where src-address=[:nothing]
by rextended
Mon Feb 05, 2024 10:54 am
Forum: Scripting
Topic: How should the local variable be called in if? [SOLVED]
Replies: 11
Views: 553

Re: How should the local variable be called in if? [SOLVED]

Instead of insisting with useless ";", understand that all variables, local and global, must be defined at the start of the script, not on subsection. { :local q 0 :local yys 134 :local gsd 1936 :if ([:len [/file find where name="Save$yys$"gsd".txt"] ] > 0) do={ :set q ...
by rextended
Sat Feb 03, 2024 10:49 pm
Forum: General
Topic: [Discussion] MikroTik configuration abstraction complexity
Replies: 72
Views: 3924

Re: [Discussion] MikroTik configuration abstraction complexity

Probably if RouterOS had been open source,
ForumOS64 would now exist with everything it needed...
Even the useless Dark-Mode...
by rextended
Wed Jan 31, 2024 8:01 pm
Forum: General
Topic: 7.13 wireless package split question
Replies: 74
Views: 16233

Re: 7.13 wireless package split question

   
by rextended
Wed Jan 31, 2024 7:48 pm
Forum: General
Topic: 7.13 wireless package split question
Replies: 74
Views: 16233

Re: 7.13 wireless package split question

@infabo We have no guarantee that the staff who PROGRAM RouterOS will ignore our comments. Probably our reports and proposals on the forum are not even passed on to the programmers, just because those of the staff who read the forum do not consider them worthy of note. Like this: https://forum.mikr...
by rextended
Wed Jan 31, 2024 7:42 pm
Forum: Announcements
Topic: Newsletter #116 | January 2024
Replies: 90
Views: 25807

Re: Newsletter #116 | January 2024

When I initially "discovered" ...
Let's not confuse the NAND of previous products with the 16MiB Flash used now...

Now that I think about it, I've never found a MikroTik device with Flash greater than 16MiB...
by rextended
Wed Jan 31, 2024 7:40 pm
Forum: Announcements
Topic: Newsletter #116 | January 2024
Replies: 90
Views: 25807

Re: Newsletter #116 | January 2024

Fact: The design used for that processor prevented it from using more than 640kB of memory.

So someone decided that limit, it could be there, but the worst thing was that it was FORCED TO MAINTAIN IT even afterwards, for "decades"...
by rextended
Wed Jan 31, 2024 7:33 pm
Forum: General
Topic: 7.13 wireless package split question
Replies: 74
Views: 16233

Re: 7.13 wireless package split question

is dumb If I worked at MikroTik as a programmer the problem would have already been solved, in fact, it probably would never have been created, because I would have done everything in a more logical way: you only download the drivers (and optional features) you need based on the model, without down...
by rextended
Wed Jan 31, 2024 7:21 pm
Forum: Announcements
Topic: Newsletter #116 | January 2024
Replies: 90
Views: 25807

Re: Newsletter #116 | January 2024

Bill Gates said: you don't need more than 640kB. MT, can you explain to us why you are so in love with such small 16 MB flash? I think there isn't a person in the world (who knows what they're talking about) who reads that specification and doesn't wonder why the damned thing they keep doing this b...
by rextended
Wed Jan 31, 2024 7:05 pm
Forum: Announcements
Topic: Newsletter #116 | January 2024
Replies: 90
Views: 25807

Re: Newsletter #116 | January 2024

@sirbryan Bad idea to buy a product without knowing if they will put the remaining part on the market and without any test that all parts (AP+CPE) are working as expected... Would you buy an electric car first, without knowing if they would ever make batteries for that model? But you're right about...
by rextended
Wed Jan 31, 2024 5:44 pm
Forum: Announcements
Topic: Newsletter #116 | January 2024
Replies: 90
Views: 25807

Re: Newsletter #116 | January 2024

   
by rextended
Wed Jan 31, 2024 5:01 pm
Forum: Announcements
Topic: Newsletter #116 | January 2024
Replies: 90
Views: 25807

Re: Newsletter #116 | January 2024

mANTBox ax for WISP without any CPE (except "Build your own") is completely useless...
by rextended
Wed Jan 31, 2024 4:21 pm
Forum: Announcements
Topic: Newsletter #116 | January 2024
Replies: 90
Views: 25807

Re: Newsletter #116 | January 2024

Now I understand what market MikroTik products from v7 are aimed at...
by rextended
Wed Jan 31, 2024 3:21 pm
Forum: Scripting
Topic: Can you control the length of the generated string? In ROS 6.XX.
Replies: 3
Views: 443

Re: Can you control the length of the generated string? In ROS 6.XX.

:local num 00 ; is completely useless the ; and the 00 if not inside quotes, because numeric 000000000000000000000000000 is 0 (add "" is useless, if "00" is added to 1, first "00" is converted on a number, and is 0 + 1 = 1 // adding "1" as string to "00&q...
by rextended
Wed Jan 31, 2024 2:45 pm
Forum: Announcements
Topic: Newsletter #116 | January 2024
Replies: 90
Views: 25807

Re: Newsletter #116 | January 2024

mANTBox ax 15s? Is not the correct name "mANTBox 52 ax 15s"? Any plans for the mANTBox ax 1 9 s or for sell directly the L22UGS-5HaxD(2HaxD) or should I buy the mANTBox ax 15s just for the internal RouterBOARD and replace the internal radios on the old mANTBox ac 19s? (no matter the 2,4GHz...
by rextended
Fri Jan 26, 2024 11:49 am
Forum: Scripting
Topic: ✂ Rextended Fragments of Snippets
Replies: 92
Views: 58900

Re: ✂ Rextended Fragments of Snippets

@jaclaz and the others: I can't continue to comment this in my topic, this on this topic is off-topic in... my topic. So I'm not answering this anymore. You will only see me as a normal user who reports bugs and reads the forum. I will still continue to fix my scripts if there is an error. I will no...
by rextended
Fri Jan 26, 2024 10:17 am
Forum: Scripting
Topic: ✂ Rextended Fragments of Snippets
Replies: 92
Views: 58900

Re: ✂ Rextended Fragments of Snippets

Very sad, that such basic ask like "can you please not use swear words" is taken as "ingratitude" What you write is not true, and by deleting the posts, as you have already done, you erase the evidence. You deleted my reply post, it was the first: https://forum.mikrotik.com/view...
by rextended
Thu Jan 25, 2024 3:28 pm
Forum: Scripting
Topic: ✂ Rextended Fragments of Snippets
Replies: 92
Views: 58900

Re: ✂ Rextended Fragments of Snippets

Given the continued ingratitude of the forum's administrative staff, I will stop. Did it cost so much to admit that, even if in good faith, the moderator had been wrong? Someone will finally celebrate this event and be happy (is not one allusion for the administrative staff). I feel sorry for the ot...
by rextended
Thu Jan 25, 2024 11:55 am
Forum: Announcements
Topic: v7.14beta [testing] is released!
Replies: 510
Views: 144732

Re: v7.14beta [testing] is released!

CNAME records and the name they are pointing to having a different TTL.
What should the resolver do when the client requests an A record, the record in the cache is a CNAME and it points to a record that already has expired.

The Playstation problem plague...
by rextended
Thu Jan 25, 2024 10:38 am
Forum: Beginner Basics
Topic: Antivirus Firewall Filter Rules [SOLVED]
Replies: 1
Views: 407

Re: Antivirus Firewall Filter Rules [SOLVED]

The demo config is very old,
Default firewall rules on new device are perfect.
by rextended
Thu Jan 25, 2024 10:32 am
Forum: RouterBOARD hardware
Topic: Default password sticker wrong!!! [SOLVED]
Replies: 16
Views: 1356

Re: Default password sticker wrong!!! [SOLVED]

The flap of the label, at the top right, is raised... Typical of when the label is removed and reattached. Use netinstall with both the option to NOT keep the previous configuration AND not apply the default. This way you can have access to the device without a password. Once logged in via MAC addre...
by rextended
Thu Jan 25, 2024 10:14 am
Forum: Beginner Basics
Topic: DHCP doesn't deliver an address for a gateway
Replies: 89
Views: 3027

Re: DHCP doesn't deliver an address for a gateway

Facts:
Winbox for Mac does not exist,
unless your name is @Normis and you want to tease.
You have not specified either the version of Winbox used, nor the version of netinstall, nor the exact name of the packages downloaded.
by rextended
Wed Jan 24, 2024 10:49 pm
Forum: Scripting
Topic: How to make Mikrotik beep on adding new log entry
Replies: 9
Views: 707

Re: How to make Mikrotik beep on adding new log entry

where I'm checking the logs every 1 second, the CPU usage sits at a constant 20%
10 seconds suggested is not a random time...
by rextended
Wed Jan 24, 2024 10:42 pm
Forum: General
Topic: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8
Replies: 427
Views: 118759

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

it's ridiculous that these are still being sold with so many problems.
You have no concrete method of comparison,
Only those who complain write here on the forum,
not all those satisfied who had no problems...
by rextended
Wed Jan 24, 2024 6:34 pm
Forum: Beginner Basics
Topic: DHCP doesn't deliver an address for a gateway
Replies: 89
Views: 3027

Re: DHCP doesn't deliver an address for a gateway

@holvoetn 1) The CRS112-8P-4S is a PoE switch, not a router. 2) There is a total lack of professionalism in the user's speeches which makes me believe he is here to act as a troll, rather than actually wanting help. He took this forum as one vent because he doesn't know the product. 3) The device c...
by rextended
Wed Jan 24, 2024 5:25 pm
Forum: Beginner Basics
Topic: ISP subnet distribution [SOLVED]
Replies: 5
Views: 550

Re: ISP subnet distribution [SOLVED]

Something like this: /interface bridge add name=bridge /interface bridge port add bridge=bridge interface=sfp1 add bridge=bridge interface=ether1 add bridge=bridge interface=ether2 add bridge=bridge interface=ether3 add bridge=bridge interface=ether4 /ip address add address=150.15.130.66/29 interfac...
by rextended
Wed Jan 24, 2024 4:58 pm
Forum: Beginner Basics
Topic: DHCP doesn't deliver an address for a gateway
Replies: 89
Views: 3027

Re: DHCP doesn't deliver an address for a gateway

What you have made clear about yourself is sufficient. I'm sorry, but before I get banned for what I could answer you, I better stop writing on this topic. Addendum: Exact words https://help.mikrotik.com/docs/display/ROS/Netinstall#Netinstall-Introduction In short, the Netinstall procedure goes like...
by rextended
Wed Jan 24, 2024 4:50 pm
Forum: Beginner Basics
Topic: DHCP doesn't deliver an address for a gateway
Replies: 89
Views: 3027

Re: DHCP doesn't deliver an address for a gateway

(see my next post)
by rextended
Wed Jan 24, 2024 4:40 pm
Forum: Beginner Basics
Topic: DHCP doesn't deliver an address for a gateway
Replies: 89
Views: 3027

Re: DHCP doesn't deliver an address for a gateway

It says "no package included".
Better you read the netinstall guide: If you don't download the packages and select on the netinstall the right folder, how do you install them?
by rextended
Wed Jan 24, 2024 4:37 pm
Forum: General
Topic: SNMP IPv6
Replies: 1
Views: 282

Re: SNMP IPv6

Apaprently not exposed on SNMP
by rextended
Wed Jan 24, 2024 4:32 pm
Forum: General
Topic: ⚠️WARNING: RouterOS v7.10+ will break all scripts based on [/system clock get date] or other date(s)
Replies: 63
Views: 12325

Re: ⚠️WARNING: RouterOS v7.10+ will break all scripts based on [/system clock get date] or other date(s)

Instead of :pick $date 4 6, the new date format you do :pick $date 8 10
Thank you so much! It works now.
Instead of blindly copying and pasting, try to understand what that command is for and why it was used that way.
by rextended
Wed Jan 24, 2024 4:19 pm
Forum: Announcements
Topic: v7.13.5 [stable] is released!
Replies: 909
Views: 247960

Re: v7.13.2 [stable] is released!

No terminal, go on winbox/webfig "Log"
by rextended
Wed Jan 24, 2024 4:18 pm
Forum: Announcements
Topic: v6.49.12 [stable] is released!
Replies: 23
Views: 10971

Re: v6.49.12 [stable] is released!

6.50 will probably never come out,
so obviously now we'll go forward for example as x.x.13 long-term and x.x.14 stable...
I hope they don't release 6.49.12 long-term at the same time as 6.49.12 stable to avoid the same mess that happened previously...
by rextended
Wed Jan 24, 2024 4:16 pm
Forum: Beginner Basics
Topic: DHCP doesn't deliver an address for a gateway
Replies: 89
Views: 3027

Re: DHCP doesn't deliver an address for a gateway

One example:
Upgrading from 7.12 to 7.13.2 and do a reset-configuration disk space is 7% free.
Netinstalling directly the 7.13.2 disk space free is 9%...
Something is left regardlessly the "reset"...
by rextended
Wed Jan 24, 2024 3:49 pm
Forum: Announcements
Topic: v7.13.5 [stable] is released!
Replies: 909
Views: 247960

Re: v7.13.2 [stable] is released!

i updated 7.13.2 but i cant downrage back . its not work like before i downrage
What device is it and what is written in the logs?
by rextended
Wed Jan 24, 2024 3:38 pm
Forum: General
Topic: Blocking IP's by region [SOLVED]
Replies: 22
Views: 34318

Re: Blocking IP's by region [SOLVED]

Precisely... Trusting something like that is foolish... Nobody forbids to add on the .rsc instruction to how bypass firewall, create new superuser, do whatever you want with that device... Let's pretend I create the list, mischievously I start providing it free for months, there are even those who s...
by rextended
Wed Jan 24, 2024 3:35 pm
Forum: Beginner Basics
Topic: mangle "reply dst.address"
Replies: 2
Views: 408

Re: mangle "reply dst.address"

The port 10000-20000 are not on exclusive use for VoIP.
Mark your VoIP provider IPs, not generic ports.
by rextended
Wed Jan 24, 2024 3:19 pm
Forum: General
Topic: Blocking IP's by region [SOLVED]
Replies: 22
Views: 34318

Re: Blocking IP's by region [SOLVED]

Script to download current country IP list
[...]
💀⚠️CRITICAL: Never trust who provides scripts containing "/import" from "/tool fetch" from external sources.
viewtopic.php?t=203733#p1051321
by rextended
Wed Jan 24, 2024 3:06 pm
Forum: General
Topic: 💀⚠️CRITICAL: Never trust who provides scripts containing "/import" from "/tool fetch" from external sources.
Replies: 2
Views: 540

💀⚠️CRITICAL: Never trust who provides scripts containing "/import" from "/tool fetch" from external sources.

💀⚠️CRITICAL: Never trust who provides scripts containing " /import " from " /tool fetch " from external sources. NEVER TRUST , there is no guarantee that the remote site will not be modified on purpose to execute arbitrary commands on your router. It's one thing to download and i...
by rextended
Wed Jan 24, 2024 2:49 pm
Forum: General
Topic: Warning message "<network> not a bridge port" after upgrade to RouterOS 13.2
Replies: 4
Views: 418

Re: Warning message "<network> not a bridge port" after upgrade to RouterOS 13.2

Please change wrong info in the title The message says exactly what it says: "apnet not a bridge port". /interface bridge vlan # apnet not a bridge port add bridge=bridge1 tagged=bridge1, apnet ,ether1 vlan-ids=20 In fact, you configured the device as if the interface were part of it, even...
by rextended
Wed Jan 24, 2024 2:47 pm
Forum: Beginner Basics
Topic: DHCP doesn't deliver an address for a gateway
Replies: 89
Views: 3027

Re: DHCP doesn't deliver an address for a gateway

It is true, goto point 4)
The internal configuration database is damaged and the device must be netinstalled.
If the problem persist, ask RMA from your distributor.
by rextended
Wed Jan 24, 2024 2:39 pm
Forum: General
Topic: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8
Replies: 427
Views: 118759

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

After reading this topic, I was expecting similar problems, but I've been waiting for 3 years for something to stop working...

Probably users who have problems have caused the device to overheat because it is in a place with little replacement or covered by other peripherals...
by rextended
Wed Jan 24, 2024 2:35 pm
Forum: Beginner Basics
Topic: impossible to log in using old account
Replies: 8
Views: 640

Re: impossible

There are two problems: The first is that nowhere in the forum is there "something" with which you can contact the administrators, everything left to itself or you deduce to contact support@mikrotik.com The second, that a title like "impossible" it doesn't help anyone, on the con...
by rextended
Wed Jan 24, 2024 2:09 pm
Forum: The User Manager
Topic: Credentials Password
Replies: 1
Views: 741

Re: Credentials Password

if making this change
What change?
by rextended
Wed Jan 24, 2024 1:52 pm
Forum: Wireless Networking
Topic: ACL for one Client is not working
Replies: 2
Views: 336

Re: ACL for one Client is not working

Remove that rule, paste this one below into the terminal, then replace the fake address with the correct MAC address:
/interface wireless access-list
add authentication=no interface=wlan1 signal-range=-120..-41 mac-address=DE:AD:BE:EF:00:00
by rextended
Wed Jan 24, 2024 1:33 pm
Forum: Beginner Basics
Topic: DHCP doesn't deliver an address for a gateway
Replies: 89
Views: 3027

Re: DHCP doesn't deliver an address for a gateway

Also I don't understand, that the crs112 accepts its internetfacing port only on eth1. With eth8 it's not working. Though the rest of the config was adapted... But this is no important. I'm sorry, but objectively it's definitely a configuration error on your part. As 0.0.0.0/24 came up in one point...
by rextended
Wed Jan 24, 2024 1:30 pm
Forum: Beginner Basics
Topic: DHCP doesn't deliver an address for a gateway
Replies: 89
Views: 3027

Re: DHCP doesn't deliver an address for a gateway

3) Remove that line on dhcp-server network . Most likely that is exactly the problem, but I don't rule out anything else because obviously, it's just a small piece of the configuration. 4) If you don't write things down, we don't know them. 5) Instead my experience, since 2007, with the exception of...
by rextended
Wed Jan 24, 2024 11:41 am
Forum: Beginner Basics
Topic: DHCP doesn't deliver an address for a gateway
Replies: 89
Views: 3027

Re: DHCP doesn't deliver an address for a gateway

https://forum.mikrotik.com/viewtopic.php?t=203686 Since my CRS112-8G-4S (specified the model in full, since there are multiple versions of "crs112") with software and firmware version 7.13.2, completely empty, except the dhcp-server, ip and pool configured, with a directly connected Asus l...
by rextended
Wed Jan 24, 2024 10:56 am
Forum: Scripting
Topic: How to make Mikrotik beep on adding new log entry
Replies: 9
Views: 707

Re: How to make Mikrotik beep on adding new log entry

Good morning. What device do you have? As @holvoetn already wrote, if it doesn't have a beeper it's all useless. Is possible use this as a basis: https://forum.mikrotik.com/viewtopic.php?p=1004552#p1004546 To obtain this: :global lastLog :if ([:typeof $lastLog] != "num") do={:set lastLog 0...
by rextended
Wed Jan 24, 2024 10:46 am
Forum: Wireless Networking
Topic: Link SXTsq 5 ac - OmniTIK 5 ac
Replies: 6
Views: 503

Re: Link SXTsq 5 ac - OmniTIK 5 ac

It's unrealistic speed (without knowing "number of clients, interference, government regulation, etc.") You have an omnidirectional antenna that senses disturbances coming from any direction... It's not like a point-to-point link made with two SXTs... Max speed, ignoring "number of cl...
by rextended
Wed Jan 24, 2024 10:41 am
Forum: Scripting
Topic: Delete all connection in Firewall-Connections
Replies: 10
Views: 19068

Re: Delete all connection in Firewall-Connections

I already answered 1 year ago...
You must add "where timeout>60" like my example because closed connections during the run of the script break anything.
by rextended
Tue Jan 23, 2024 11:32 pm
Forum: Announcements
Topic: v7.14beta [testing] is released!
Replies: 510
Views: 144732

Re: v7.14beta [testing] is released!

This is a beta and should not be used in production.
I quote
by rextended
Tue Jan 23, 2024 11:31 pm
Forum: General
Topic: CCR2004-16G-2S+ no hosts on bridge ROS v7.11
Replies: 8
Views: 1747

Re: CCR2004-16G-2S+ no hosts on bridge ROS v7.11

It's not a configuration issue. In reality I was thinking of the internal configuration database being corrupt, rather than your mistake. And I realized now that "How many entries are there inside?" could be misunderstood: I meant how many static entries you added, not how many are presen...
by rextended
Tue Jan 23, 2024 7:24 pm
Forum: Wireless Networking
Topic: Separating clients on a LAN is important in a wifi network.
Replies: 2
Views: 480

Re: Separating clients on a LAN is important in a wifi network.

Using the split-horizon on bridge disables hardware offloading on all switch chips present, so all traffic passes through the CPU.
So using split-horizon also depends on what you use and how... but I totally agree about isolating each different wifi.
by rextended
Tue Jan 23, 2024 7:02 pm
Forum: General
Topic: Upgrade to 7.13.2 drops WLAN1 on Metal 2SHPn
Replies: 1
Views: 335

Re: Upgrade to 7.13.2 drops WLAN1 on Metal 2SHPn

You didn't write that you did the update "by hand". You didn't write whether or not you also installed the separate wireless package during or after the update. You didn't write that you didn't read the release notes before upgrading. Notice - Starting from RouterOS version 7.13, significa...
by rextended
Tue Jan 23, 2024 6:57 pm
Forum: Wireless Networking
Topic: Link SXTsq 5 ac - OmniTIK 5 ac
Replies: 6
Views: 503

Re: Link SXTsq 5 ac - OmniTIK 5 ac

1) Obviously.
2) At sight. The further you go, the less is the capacity...
3) The question assumes that is already know the distance, number of clients, interference, government regulation, etc.
4) The same reply for point 3)
by rextended
Tue Jan 23, 2024 6:46 pm
Forum: Wireless Networking
Topic: Configure WIFI v.7.13 [SOLVED]
Replies: 15
Views: 5265

Re: Configure WIFI v.7.13 [SOLVED]

lets not produce "empty" posts.
Your is another one, don't be rude: viewtopic.php?t=203686

The question I asked you, which you obviously didn't answer, probably because it was uncomfortable for you, is useful.
by rextended
Tue Jan 23, 2024 6:39 pm
Forum: General
Topic: hEX POE not doing POE
Replies: 8
Views: 525

Re: hEX POE not doing POE

802.3af = ~48V, so...
by rextended
Tue Jan 23, 2024 6:34 pm
Forum: General
Topic: CCR2004-16G-2S+ no hosts on bridge ROS v7.11
Replies: 8
Views: 1747

Re: CCR2004-16G-2S+ no hosts on bridge ROS v7.11

How many entries are there inside /interface bridge host?
by rextended
Tue Jan 23, 2024 6:22 pm
Forum: General
Topic: CCR2004-16G-2S+ no hosts on bridge ROS v7.11
Replies: 8
Views: 1747

Re: CCR2004-16G-2S+ no hosts on bridge ROS v7.11

If reboot do not solve,
reload last working backup, install 7.13.2 and retry.
by rextended
Tue Jan 23, 2024 6:19 pm
Forum: General
Topic: IP and route configuration for /28
Replies: 12
Views: 1318

Re: IP and route configuration for /28

You must disable hardware offload on each port on the bridge.
by rextended
Tue Jan 23, 2024 6:00 pm
Forum: Announcements
Topic: v7.14beta [testing] is released!
Replies: 510
Views: 144732

Re: v7.14beta [testing] is released!

Just compare .npk... 2.686.976 - 2.244.753 byte = 442.223 byte... Removed the file wil6436-cube-sa-tg.brd 13.472 byte wil6436-cube-tg.brd 13.472 byte wil6436-tg.fw 986.764 byte So, uncompressed on NAND/Flash are 1.013.663 byte (~1MiB) less This compensate for some device this: !) rose-storage - move...
by rextended
Tue Jan 23, 2024 5:58 pm
Forum: General
Topic: Wrong country when selecting Time Zone Autodetect
Replies: 16
Views: 1171

Re: Wrong country when selecting Time Zone Autodetect

different users to have different time zones as other systems allow.
This should be done from webfig/winbox based on how the OS is set up, not a router setting...
by rextended
Tue Jan 23, 2024 5:34 pm
Forum: General
Topic: Wrong country when selecting Time Zone Autodetect
Replies: 16
Views: 1171

Re: Wrong country when selecting Time Zone Autodetect

Useless call home.
It should be done once and off the first successfull time you turn on the device on internet, not other times.
by rextended
Tue Jan 23, 2024 5:27 pm
Forum: Beginner Basics
Topic: Cant get into my Mikrotik
Replies: 5
Views: 674

Re: Cant get into my Mikrotik

This is only true for some devices, not all. Documentation can always be improved, but often what is not read is in the eyes of the observer... My suggestion is to look at what you use, it's written on it... https://i.mt.lv/cdn/rb_images/1059_hi_res.png In the OP's case, this is the device, and clea...
by rextended
Tue Jan 23, 2024 5:22 pm
Forum: Announcements
Topic: v6.49.12 [stable] is released!
Replies: 23
Views: 10971

Re: v6.49.12 [stable] is released!

I don't understand, 6.49.12 was never long-term, and 6.50 will probably never come out, so obviously now we'll go forward for example as x.x.13 long-term and x.x.14 stable... I hope they don't release 6.49.12 long-term at the same time as 6.49.12 stable to avoid the same mess that happened previousl...
by rextended
Tue Jan 23, 2024 5:16 pm
Forum: Wireless Networking
Topic: Configure WIFI v.7.13 [SOLVED]
Replies: 15
Views: 5265

Re: Configure WIFI v.7.13 [SOLVED]

distant upgrade
No matter the productor of the device, a distant update CAN fail, so upgrade CAN go worse...
Always keep the car engine running... you might leave...

Ask yourself a question: Do you really need v7 on those working devices instead of 6.49.12?
by rextended
Tue Jan 23, 2024 5:11 pm
Forum: Scripting
Topic: Firmware upgrade script not working w/ 7.11.2
Replies: 2
Views: 392

Re: Firmware upgrade script not working w/ 7.11.2

Why first post is deleted?
by rextended
Tue Jan 23, 2024 5:07 pm
Forum: General
Topic: Wrong country when selecting Time Zone Autodetect
Replies: 16
Views: 1171

Re: Wrong country when selecting Time Zone Autodetect

...and disable autodetect, unless you constantly move the router from one time zone to another.
Autodetect on/off do not influence DST, the change is still automatic, if the time zone set use it.
by rextended
Tue Jan 23, 2024 4:49 pm
Forum: Announcements
Topic: v6.49.12 [stable] is released!
Replies: 23
Views: 10971

Re: v6.49.12 [stable] is released!

Are we going backward now?
In what sense? I do not understand...
by rextended
Tue Jan 23, 2024 4:40 pm
Forum: Scripting
Topic: Firmware upgrade script not working w/ 7.11.2
Replies: 2
Views: 392

Re: Firmware upgrade script not working w/ 7.11.2

We've never had an issue with our script running the updates until this version that the routers are stuck on. It is impossible to evaluate what you do not display. But from what we read in the screenshot of the logs, if they are generated by the script, I assume it is poorly done. We also noticed ...
by rextended
Tue Jan 23, 2024 4:36 pm
Forum: Beginner Basics
Topic: How to chainge forums skin? [SOLVED]
Replies: 3
Views: 520

Re: How to chainge forums skin? [SOLVED]

Direct link:
ucp.php?i=165
by rextended
Tue Jan 23, 2024 10:14 am
Forum: Announcements
Topic: WinBox v3.40 released!
Replies: 109
Views: 103109

Re: WinBox v3.40 released!

you can always just keep using the old one :)
This is fundamental
by rextended
Mon Jan 22, 2024 2:37 pm
Forum: Announcements
Topic: WinBox v3.40 released!
Replies: 109
Views: 103109

Re: WinBox v3.40 released!

For historical purposes only...
felice.png
by rextended
Mon Jan 22, 2024 2:34 pm
Forum: Scripting
Topic: Questions about generating valid random MAC? [SOLVED]
Replies: 17
Views: 1095

Re: Questions about generating valid random MAC? [SOLVED]

or directly
:local t [$rndMAC]
by rextended
Mon Jan 22, 2024 11:18 am
Forum: Announcements
Topic: WinBox v3.40 released!
Replies: 109
Views: 103109

Re: WinBox v3.40 released!

What do you mean "teaser"? That is just a wine install, that has been possible for a long time.
The Winbox icon...? (not the winbox64.exe)

Is just a wine link with custom icon?
by rextended
Mon Jan 22, 2024 11:11 am
Forum: Scripting
Topic: Questions about generating valid random MAC? [SOLVED]
Replies: 17
Views: 1095

Re: Questions about generating valid random MAC? [SOLVED]

00:00:00.4 = 400ms

What are the benefits of your writing style?
In what sense? I'm confused.

May I ask for your advice?
This is why the forum is here, anyone can answer you.
by rextended
Mon Jan 22, 2024 11:05 am
Forum: Announcements
Topic: WinBox v3.40 released!
Replies: 109
Views: 103109

Re: WinBox v3.40 released!

@normis, when? :))
by rextended
Mon Jan 22, 2024 10:57 am
Forum: Scripting
Topic: Questions about generating valid random MAC? [SOLVED]
Replies: 17
Views: 1095

Re: Questions about generating valid random MAC? [SOLVED]

You use the script on x86 or CHR?

There is no random number generator on v6, and using an extremely fast CPU produces the same number.
I add one artificious delay on previous sript (please remove quoted scripts on your post) that apparently on my CHR/x86 fix the problem (and work on both v6 and v7)
by rextended
Mon Jan 22, 2024 2:38 am
Forum: Scripting
Topic: Questions about generating valid random MAC? [SOLVED]
Replies: 17
Views: 1095

Re: Questions about generating valid random MAC? [SOLVED]

I have decided to choose V6.49.10. In this version, I would like to ask the forum experts how to use the most concise script to generate a valid random MAC? Forget the endless writings of @vingjfg who doesn't read my posts, so he doesn't know that simply 2 lines are enough to generate MAC address w...
by rextended
Sat Jan 20, 2024 2:10 am
Forum: The Dude
Topic: How do I get the flag status
Replies: 4
Views: 669

Re: How do I get the flag status

/dude device print detail where !.dead

/dude device print detail where .dead
by rextended
Fri Jan 19, 2024 5:08 pm
Forum: Scripting
Topic: Netwatch with fetch stopped working after 7.13
Replies: 16
Views: 1267

Re: Netwatch with fetch stopped working after 7.13

???

try to replace the line
:local MessageText "$VarLocal $DevNameGlobal is Down";
with this line
:local MessageText "$VarLocal $DevNameGlobal is NOT UP";

I have one suspect...
by rextended
Fri Jan 19, 2024 3:34 pm
Forum: Scripting
Topic: Netwatch with fetch stopped working after 7.13
Replies: 16
Views: 1267

Re: Netwatch with fetch stopped working after 7.13

Script :global testg :local testl "script-test" :log info "testg is $testg and testl is $testl" on-up on netwatch :log info "test netwatch up start" :global testg "nw-test" /system script run scriptnw :log info "test netwatch up end" the export /syst...
by rextended
Fri Jan 19, 2024 3:17 pm
Forum: Scripting
Topic: Netwatch with fetch stopped working after 7.13
Replies: 16
Views: 1267

Re: Netwatch with fetch stopped working after 7.13

Function_Telegram source is here?
viewtopic.php?p=1050038#p1050021


What quotes you use??? These are WRONG...
name

MUST be "name"
by rextended
Fri Jan 19, 2024 3:07 pm
Forum: Scripting
Topic: Netwatch with fetch stopped working after 7.13
Replies: 16
Views: 1267

Re: Netwatch with fetch stopped working after 7.13

" call this script from Netwatch " mean that you must RUN the script, not READ the script... Otherwise it makes no sense, you could have put the source script directly inside the event in Netwatch... Read again the response from Support, and don't INTERPRET it, but try to UNDERSTAND it... ...
by rextended
Fri Jan 19, 2024 2:58 pm
Forum: Announcements
Topic: v7.14beta [testing] is released!
Replies: 510
Views: 144732

Re: v7.14beta [testing] is released!

is perfect as a backup connection
for use an LTE modem?

Buy one of these directly:
https://mikrotik.com/product/chateau_lte6_ax
https://mikrotik.com/product/chateaulte18_ax
so you don't go crazy about compatibility...
by rextended
Fri Jan 19, 2024 2:20 pm
Forum: Beginner Basics
Topic: use CLI to change /ip service
Replies: 4
Views: 571

Re: use CLI to change /ip service

What command should I use to change by CLI what is above to what is below?
You have already below the list of the commands....................
Simply paste the below on terminal...

and also this:
/ip service
set ssh address=""
set winbox address=""
by rextended
Fri Jan 19, 2024 1:55 pm
Forum: Announcements
Topic: v7.14beta [testing] is released!
Replies: 510
Views: 144732

Re: v7.14beta [testing] is released!

Whether or not there is a USB port or speaker, it all depends on whether it is supported by the chipset or not. Adding speakers or USB to a chip that doesn't support them entails a significant increase in cost, which 99.999_% of those who buy it don't give a damn about the USB port. In fact, only th...
by rextended
Fri Jan 19, 2024 1:32 pm
Forum: Scripting
Topic: help for this script
Replies: 14
Views: 814

Re: help for this script

Write a detailed description, and maybe some volunteer will rewrite it for you. But until it is perfectly clear how it is used, and where it is written, based only on what you have written so far, the logical conclusion is what I wrote on previous post... Instead of modify everytime the date inside ...
by rextended
Fri Jan 19, 2024 1:25 pm
Forum: Scripting
Topic: help for this script
Replies: 14
Views: 814

Re: help for this script

Do you have a script for each user, and in each one you change the date, name and IP??
by rextended
Fri Jan 19, 2024 1:22 pm
Forum: Scripting
Topic: help for this script
Replies: 14
Views: 814

Re: help for this script

Read previous post
by rextended
Fri Jan 19, 2024 1:20 pm
Forum: Scripting
Topic: help for this script
Replies: 14
Views: 814

Re: help for this script

Or probably the script is useless, given how it is written and from the little we understand what it is for,
just program this line below every 28th of the month at 23:59...
/ip hotspot ip-binding set [find where address=10.0.0.95] disabled=yes ; :log error "CL67 has been Disabled"
by rextended
Fri Jan 19, 2024 1:13 pm
Forum: Scripting
Topic: help for this script
Replies: 14
Views: 814

Re: help for this script

Someone must rewrite the script, near from scratch.
by rextended
Fri Jan 19, 2024 12:50 pm
Forum: Scripting
Topic: help for this script
Replies: 14
Views: 814

Re: help for this script

If you want test the script on terminal, you must put all the script between { } else each line is treated as single script, and you give errors. And when you paste terminal output, do not use "code", is not one scipt, and do not remove prompt... [rex@do-not-remove-prompt] > :local date1 &...
by rextended
Fri Jan 19, 2024 10:15 am
Forum: Scripting
Topic: Max Concurrent Router to NAS FTP Download
Replies: 3
Views: 784

Re: Max Concurrent Router to NAS FTP Download

In general it is just wrong to have all the equipment do something like this at the same time. 1) There may be a limit. 2) There may be a limit in the future. 3) Unnecessary peak in traffic and resources The solution is simple: spread requests over a longer period of time, where each device download...
by rextended
Fri Jan 19, 2024 9:56 am
Forum: Scripting
Topic: help for this script
Replies: 14
Views: 814

Re: help for this script

by rextended
Fri Jan 19, 2024 1:04 am
Forum: General
Topic: Help me - make script change ip adress every rto
Replies: 11
Views: 932

Re: Help me - make script change ip adress every rto

Probably yes... […] because perhaps the traffic assigned to that address has run out. To overcome this limit, he wants to deceive the service provider by changing the IP address to a different one. […] But I think in the end it's the usual language problem that causes misunderstandings, and the requ...
by rextended
Fri Jan 19, 2024 12:04 am
Forum: Useful user articles
Topic: Solving the problem mikrotik router freeze in Calculating download size in update to os v7
Replies: 3
Views: 777

Re: Solving the problem mikrotik router freeze in Calculating download size in update to os v7

Just watch the video, and monetize with ads.
I could understand if it was a complex operation, but making a video for this thing,
is like making a video on how to insert the power plug into the wall socket and the power jack into the routerboard...
There's no manual for that...
by rextended
Thu Jan 18, 2024 11:50 pm
Forum: General
Topic: Help me - make script change ip adress every rto
Replies: 11
Views: 932

Re: Help me - make script change ip adress every rto

If this is the case adding one to the last part (or last two parts) of the old address (and wrapping around to 1 when 255 is reached) will cycle through all possibile addresses without needing to check for collisions. Yes, but is more easy write on this way :local newIP "10.130.$[:rndnum from=...
by rextended
Thu Jan 18, 2024 11:30 pm
Forum: Useful user articles
Topic: Solving the problem mikrotik router freeze in Calculating download size in update to os v7
Replies: 3
Views: 777

Re: Solving the problem mikrotik router freeze in Calculating download size in update to os v7

Why not write it directly instead of monetizing with YouTube videos? It also takes less time... "Router freeze in Calculating download size in update to os v7" Since users, who have no idea what the packages are for, needlessly install all the v6 packages, the RouterBOARD does not have eno...
by rextended
Thu Jan 18, 2024 11:17 pm
Forum: Beginner Basics
Topic: Lost management
Replies: 9
Views: 2371

Re: Lost management

But your's reply was really nice, rextended :D For that response I got a warning from an anonymous moderator. Instead of warning me in a post where perhaps I had "offended" someone, he admonished me here because I pointed out the ingratitude of those who helped, he didn't even say thank y...
by rextended
Thu Jan 18, 2024 10:49 pm
Forum: General
Topic: Help me - make script change ip adress every rto
Replies: 11
Views: 932

Re: Help me - make script change ip adress every rto

The "name" in [/interface find name] is completely useless. Is easy obtain a random number between 1 to 254 (or 0 to 255)... v7 only :put [:rndnum from=1 to=254] v6 only https://forum.mikrotik.com/viewtopic.php?f=9&t=175453&p=858629#p858629 :global randomnum do={ /system resource i...
by rextended
Thu Jan 18, 2024 6:05 pm
Forum: General
Topic: Forum broken?
Replies: 31
Views: 2223

Re: Forum broken?

Also settings for notifications doesn't work!
Any form of notification/pm is removed on purpose, regardless if is present on GUI.
by rextended
Thu Jan 18, 2024 3:34 pm
Forum: General
Topic: Forum broken?
Replies: 31
Views: 2223

Re: Forum broken?

At the moment it uses 159.148.147.239
If I force IPv4 I have same problem (blank page), is the same IPv4...
by rextended
Thu Jan 18, 2024 3:22 pm
Forum: Announcements
Topic: v7.14beta [testing] is released!
Replies: 510
Views: 144732

Re: v7.14beta [testing] is released!

7.14beta7
Spero non fosse in produzione...
I hope it wasn't in production...
by rextended
Thu Jan 18, 2024 3:19 pm
Forum: Announcements
Topic: v7.14beta [testing] is released!
Replies: 510
Views: 144732

Re: v7.14beta [testing] is released!

@pe1chl for sure is referring to the fact than on v6 the router still do basic routing without the need of mpls and routing package (that add only BGP, OSPF, RIP & Co.)
by rextended
Thu Jan 18, 2024 2:55 pm
Forum: General
Topic: Forum broken?
Replies: 31
Views: 2223

Re: Forum broken?

Not here either. When I open the forum I now get a jumble of icons in sort of the right colors, instead of the plain white page.
Can I please have the IP your browser use?
I use IPv6 forum.mikrotik.com [2a02:610:7501:3000::239] and for me the problem stop some day ago...
by rextended
Thu Jan 18, 2024 2:36 pm
Forum: Announcements
Topic: v7.14beta [testing] is released!
Replies: 510
Views: 144732

Re: v7.14beta [testing] is released!

probably 99.9% of users don´t need MPLS/BGP/PPP/... on an AP.
Exactly, v6 was better...
by rextended
Thu Jan 18, 2024 2:34 pm
Forum: Announcements
Topic: v7.14beta [testing] is released!
Replies: 510
Views: 144732

Re: v7.14beta [testing] is released!

store packages on external storage
Before onsider anything else,
This is a very serious source of security breach.
by rextended
Thu Jan 18, 2024 2:26 pm
Forum: General
Topic: Forum moderation volunteers
Replies: 238
Views: 34432

Re: Forum moderation volunteers

Quoting shoold to be used limited... I'm perfectly agree with you, but the only rule in this regard is not harass people about it... @Normis had written that way because is already happened on the past various times: Some new users who didn't care about quoting correctly had complained about @Barto...
by rextended
Thu Jan 18, 2024 2:03 pm
Forum: General
Topic: Forum moderation volunteers
Replies: 238
Views: 34432

Re: Forum moderation volunteers

From @normis , post #160 on current topic. This is the last time I'm saying this. There is no rule that forbids quoting the above post. If you harass people about it, ban for you I'm not involved this time, but is yet another moderator war against quotas starting? (just for 4 more lines on post...) ...
by rextended
Thu Jan 18, 2024 1:51 pm
Forum: General
Topic: Forum moderation volunteers
Replies: 238
Views: 34432

Re: Forum moderation volunteers

Which documents?
He was referring to all the documentation and guides made by @Anav, which were often always better than the MikroTik documentation.
by rextended
Thu Jan 18, 2024 1:17 pm
Forum: General
Topic: Forum moderation volunteers
Replies: 238
Views: 34432

Re: Forum moderation volunteers

I don't use Discord ... I just enter Discord and clearly see "same toxic reply", if not more toxic, also there... From Discord: If you're going to be an asshole who just wants to aggravate the moderators, maybe just go away? https://discord.com/channels/936294190948687922/9362941909486879...
by rextended
Thu Jan 18, 2024 1:15 pm
Forum: General
Topic: Forum moderation volunteers
Replies: 238
Views: 34432

Re: Forum moderation volunteers

no. some other things were attempted. some people got banned, some got demoted from moderator status and got really mad :D
For the ways used, not for himself of no longer being a moderator, if it wasn't clear yet.
by rextended
Thu Jan 18, 2024 1:06 pm
Forum: General
Topic: Forum broken?
Replies: 31
Views: 2223

Re: Forum broken?

It appears that MikroTik have implemented a more aggressive request rate limit on the forum […]

All these suspicious requests could limit the bandwidth available to real users and guests.
by rextended
Thu Jan 18, 2024 1:05 pm
Forum: General
Topic: Forum broken?
Replies: 31
Views: 2223

Re: Forum broken?

https://forum.mikrotik.com/viewonline.php?sk=c&sd=a&sg=1 568 Guests (at time I write) Many do something that Guests shouldn't be allowed to do... "Viewing member profile" "Replying to message in " "Viewing user control panel" So they could be unidentified spider...
by rextended
Thu Jan 18, 2024 12:36 pm
Forum: Announcements
Topic: v7.13.5 [stable] is released!
Replies: 909
Views: 247960

Re: v7.13.2 [stable] is released!

I guess MikroTik now must focus on the random reboots issue...
If it was a reply to my post,
I probably expressed myself badly:
it solved the problem, but it's not written in the changelog.
by rextended
Thu Jan 18, 2024 11:25 am
Forum: General
Topic: Help me - make script change ip adress every rto
Replies: 11
Views: 932

Re: Help me - make script change ip adress every rto

[…] :rand […] i ask chat gpt to help me make the script , but didnt work. It is useless to ask the artificial deficiency. ChatGPT invents the script just to please you . The instructions are invented (like :rand) and do not exist. Obviously they don't work... Explaining what the OP wants for others...
by rextended
Thu Jan 18, 2024 10:57 am
Forum: Announcements
Topic: v7.13.5 [stable] is released!
Replies: 909
Views: 247960

Re: v7.13.2 [stable] is released!

Missing on changelog 7.13.1 (or 7.13.2):
*) fetch - treat any 2xx HTTP return code as success (introduced in v7.13)
by rextended
Thu Jan 18, 2024 10:49 am
Forum: Scripting
Topic: tool/fetch status code 204 throws error [SOLVED]
Replies: 2
Views: 638

Re: tool/fetch status code 204 throws error [SOLVED]

You should make a support request for this. This forum is a user-to-user channel, not user-to-MikroTik. Already know, the bug is introduced in v7.13 and on 7.14beta3 (2023-Dec-19 13:31) is already resolved. *) fetch - treat any 2xx HTTP return code as success (introduced in v7.13) https://forum.mik...
by rextended
Wed Jan 17, 2024 7:46 pm
Forum: General
Topic: Forum moderation volunteers
Replies: 238
Views: 34432

Re: Forum moderation volunteers

The real moderators of the forum are the newly registered users who complain about nothing.
They make long-lasting users disappear easier than moderators...
by rextended
Wed Jan 17, 2024 7:45 pm
Forum: Beginner Basics
Topic: Lost management
Replies: 9
Views: 2371

Re: Lost management

Hello,

I have bridge with vlans.I added trunk vlan 20,40,240,250 to eth and wlan. I made mistake and set up in bridge vlan ip filtering with pvid 10. Now bridge works okay but I lost access to management. It is possible to access to management?
Thanks for the nice reply.
by rextended
Wed Jan 17, 2024 7:07 pm
Forum: Scripting
Topic: Correctly determine the status of PPPOE connection?
Replies: 2
Views: 581

Re: Correctly determine the status of PPPOE connection?

Flip the forum and watch the discussion with the experts~I solved it myself~

:if (:typeof [([/interface pppoe-client monitor $pppoename once as-value]->"status")] = "disconnected") do={}
Take it sarcastically... What did you smoke?
by rextended
Wed Jan 17, 2024 6:29 pm
Forum: Scripting
Topic: Can the content written to the file be added? [SOLVED]
Replies: 17
Views: 1291

Re: Can the content written to the file be added? [SOLVED]

on some 7.13.something is 64KB

use

/interface pppoe-client export file=exportuserandpassword

the export is "dirty" of other values, but export all users.
by rextended
Wed Jan 17, 2024 6:23 pm
Forum: Scripting
Topic: POE Power Script
Replies: 13
Views: 2319

Re: POE Power Script

Is it so difficult to understand that it doesn't work on your model?
What did I write wrong or rude in my previous answer?
by rextended
Wed Jan 17, 2024 6:00 pm
Forum: Scripting
Topic: Help post Is it possible to write a Chinese to URLencode function script? [SOLVED]
Replies: 2
Views: 699

Re: Help post Is it possible to write a Chinese to URLencode function script? [SOLVED]

朋友你好 (Hello friend) URL encoded on UTF-8 is %E6%9C%8B%E5%8F%8B%E4%BD%A0%E5%A5%BD

And \c5\f3\d3\d1\c4\e3\ba\c3 on UTF-8 is not 朋友你好

\c5\f3\d3\d1\c4\e3\ba\c3 is 朋友你好 only on EUC-CN encoding format, and I do not realize anything with that encoding.
https://en.wikipedia.org/wiki/Extended_Unix_Code


对不起
by rextended
Tue Jan 16, 2024 11:43 pm
Forum: Scripting
Topic: POE Power Script
Replies: 13
Views: 2319

Re: POE Power Script

Hello,

I am getting this one below. Is this normal ? I am using Mikrotik hex S
That model do not have standard "4 PoE port" block, but "i" PoE out on ether5 that act differently.
by rextended
Tue Jan 16, 2024 9:38 pm
Forum: Scripting
Topic: Can the content written to the file be added? [SOLVED]
Replies: 17
Views: 1291

Re: Can the content written to the file be added? [SOLVED]

After reading the link provided by my friend below, I can understand what you're saying now. Oh, finally you understand and now I can help you without brainless cut-and-paste { :local filename "history_users_and_passwords.txt" :local pppoeArr [/interface pppoe-client print detail as-value...
by rextended
Tue Jan 16, 2024 2:57 pm
Forum: Beginner Basics
Topic: Subnet isolation help needed
Replies: 1
Views: 515

Re: Subnet isolation help needed

Paste this on terminal /interface list member add interface=work-bridge list=LAN But for my point of view, and also for other consideration about experience, 10./8 is really excessive. In some cases your router can hang or reboot... also for some AV installed on devices... You can use 192.168.9.x/24...
by rextended
Tue Jan 16, 2024 2:51 pm
Forum: General
Topic: Brute Force Attacks
Replies: 16
Views: 2161

Re: Brute Force Attacks

When will they start doing it with IPv6............. When easy IPV4 targets are not available for starters and if you have something considered of value and exploitable the level of interest climbs......regardless of IPV.... Then, if you leave doors, windows, skylights and manholes open, it is obvi...
by rextended
Tue Jan 16, 2024 2:44 pm
Forum: General
Topic: Background image on radvert.html
Replies: 8
Views: 860

Re: Background image on radvert.html

I do not know well css, but one section replace another? You have two time "body" on css, move the background line on the body section, and remove duplicate body at the start: <style type="text/css"> <!-- textarea,input,select { background-color: #FDFBFB; border: 1px #BBBBBB soli...
by rextended
Tue Jan 16, 2024 1:32 pm
Forum: Announcements
Topic: v7.14beta [testing] is released!
Replies: 510
Views: 144732

Re: v7.14beta [testing] is released!

!) rose-storage - moved SMB service in the RouterOS bundle;
!) smb - removed legacy SMB service (replaced with newer and faster ROSE SMB service);
Be careful before updating: you can't add users or edit sharing from Winbox!
I do not test it, only on terminal???
by rextended
Tue Jan 16, 2024 1:19 pm
Forum: General
Topic: Brute Force Attacks
Replies: 16
Views: 2161

Re: Brute Force Attacks

When will they start doing it with IPv6.............
by rextended
Tue Jan 16, 2024 1:09 pm
Forum: General
Topic: IP and route configuration for /28
Replies: 12
Views: 1318

Re: IP and route configuration for /28

You need to clarify the basic ideas... If the servers must each have their own PUBLIC IP, without increasing latency, you would have done better by putting a switch there and configuring each machine with its own IP 180.2.220.[50..62], subnet /28 (255.255.255.240) gateway 180.2.220.49, etc. If the M...
by rextended
Tue Jan 16, 2024 12:29 pm
Forum: General
Topic: Background image on radvert.html
Replies: 8
Views: 860

Re: Background image on radvert.html

CaptureBackG.JPG
Capture.jpeg

Check exact file names, is case sensitive.


(Wellcome on english is only with one "L" I suppose...)
by rextended
Tue Jan 16, 2024 12:08 pm
Forum: Beginner Basics
Topic: Help i couldn't Login page
Replies: 4
Views: 854

Re: Help i couldn't Login page

Questions: I do not see any SSID in your configuration so I suspect this is provided by another device. Question: CCR2004-16G-2S+ do not have any wireless interface AND not have capsman configured, so is obvious that wifi is configured elsewhere. With this settings, the user provide FULL AND UNLIMI...
by rextended
Tue Jan 16, 2024 11:41 am
Forum: Wireless Networking
Topic: Finally success - 802.11r/k/v fast roaming works reliably with WifiWave2
Replies: 46
Views: 11434

Re: Finally success - 802.11r/k/v fast roaming works reliably with WifiWave2

Given the amount of yelling Mikrotik users have been doing about the previous lack of 802.11r, check out this stat from the recent Wireless LAN Professionals conference in Prague. This is from a Cisco employee directly: Of 8.7 million known SSIDS on Meraki gear, only 1.45% have enabled 802.11r. fin...
by rextended
Tue Jan 16, 2024 11:35 am
Forum: Announcements
Topic: v7.14beta [testing] is released!
Replies: 510
Views: 144732

Re: v7.14beta [testing] is released!

Services like SMB should be moved into a separate package. Those who want to use it can install it and those who not need it (99% of the users) can gain some space. To facilitate this, extend the "system->packages" menu with a list of not installed packages with associated button to insta...
by rextended
Tue Jan 16, 2024 11:24 am
Forum: Announcements
Topic: v7.14beta [testing] is released!
Replies: 510
Views: 144732

Re: v7.14beta [testing] is released!

!) rose-storage - moved SMB service in the RouterOS bundle;
!) smb - removed legacy SMB service (replaced with newer and faster ROSE SMB service);
Sorry, also for SMIPS?
by rextended
Tue Jan 16, 2024 11:16 am
Forum: Forwarding Protocols
Topic: BGP Filters translate from ros6 to ros7 not working
Replies: 9
Views: 1262

Re: BGP Filters translate from ros6 to ros7 not working

Don't get hung up on just checking the filter rules, just because you think that's where the mistake lies. Maybe the rest of the address-list configuration in the firewall and the other BGP parameters can be also wrong... Simple test: remove all filters. On default, if a filter is present, the actio...
by rextended
Tue Jan 16, 2024 10:54 am
Forum: Scripting
Topic: Can the content written to the file be added? [SOLVED]
Replies: 17
Views: 1291

Re: Can the content written to the file be added? [SOLVED]

Rosa, I think your answer is in […]
And when you write that that method is limited to 4kB or 64kB? (depending on RouterOS version)
by rextended
Tue Jan 16, 2024 10:34 am
Forum: Scripting
Topic: How to read text content exceeding 10000 lines?
Replies: 3
Views: 513

Re: How to read text content exceeding 10000 lines?

Have you read at least the existing part of the manuals regarding scripting
and the topics already present on the forum that talk about file management?
by rextended
Tue Jan 16, 2024 10:14 am
Forum: Scripting
Topic: Can the content written to the file be added? [SOLVED]
Replies: 17
Views: 1291

Re: Can the content written to the file be added? [SOLVED]

Sorry, maybe you didn't understand what I meant! So if you can't do something, is it my fault that I don't understand you? I'm sorry, but as usual, instead of trying to understand how it should be done, you want to do it the way you think it should be done, so I can't help you understand how it sho...
by rextended
Tue Jan 16, 2024 10:08 am
Forum: Scripting
Topic: ✂ Rextended Fragments of Snippets
Replies: 92
Views: 58900

Re: ✂ Rextended Fragments of Snippets

Open a separate topic.
by rextended
Mon Jan 15, 2024 4:45 pm
Forum: Scripting
Topic: Can the content written to the file be added? [SOLVED]
Replies: 17
Views: 1291

Re: Can the content written to the file be added? [SOLVED]

add the actual content before add the new value?

on your way:
x = 3
x is 3

x = 4
x is 4

x can't be 7 (or 3,4) on this way




as numbers
x = 3
x = x + 4
x is 7

as strings:
x = "3"
x = x + "<CR><LF>4"
x is "3<CR><LF>4"
by rextended
Mon Jan 15, 2024 4:34 pm
Forum: General
Topic: User poll about using Winbox
Replies: 91
Views: 39699

Re: User poll about using Winbox

3) i'd always wanted to take an existing layout and make it the default for new sessions, every single new device i acess i have to fix window sizes and sometimes fix shown options from context menus. Then save it with a specific name, and use it as " default " instead of using " <ow...
by rextended
Mon Jan 15, 2024 4:08 pm
Forum: Beginner Basics
Topic: DDoS help
Replies: 42
Views: 2389

Re: DDoS help

KO: Enable tcp syn cookies
OK: Disable loose tcp tracking

Enable tcp syn cookies break some items that I do not want rewrite again at this moment.
viewtopic.php?p=1000378&hilit=tcp+syn+cookies#p1000378
by rextended
Mon Jan 15, 2024 4:01 pm
Forum: General
Topic: Feature requests
Replies: 1712
Views: 618185

Re: Feature requests

(done)
give me a hint on how to use sessions windows or why it would be good for me.
Just for memorize windows positions, colum size, colum order, filed present on colums and tab open...
by rextended
Mon Jan 15, 2024 3:46 pm
Forum: Announcements
Topic: v7.13.5 [stable] is released!
Replies: 909
Views: 247960

Re: v7.13.2 [stable] is released!

@normis are you planning to revert the modification with spaces? We have THOUSAND of MT on the network with spaces in the "system identity", and they are without backup. Don't tell me you made the mistake of installing an update in production before waiting at least 3 months in testing???
by rextended
Mon Jan 15, 2024 3:35 pm
Forum: The User Manager
Topic: Log error msg "database disk image is malformed"
Replies: 9
Views: 7106

Re: Log error msg "database disk image is malformed"

Hey all, im just facing the same issue and im trying to troubleshoot it without reinstall the router, ill let you know when i have results
After... 8 years, no results?
by rextended
Mon Jan 15, 2024 3:34 pm
Forum: The User Manager
Topic: Log error msg "database disk image is malformed"
Replies: 9
Views: 7106

Re: Log error msg "database disk image is malformed"

Resolved

/tool user-manager database clear-log
I do clear log the error hide
Image
You still use RouterOS 3.22????
by rextended
Mon Jan 15, 2024 3:30 pm
Forum: General
Topic: Feature requests
Replies: 1712
Views: 618185

Re: Feature requests

Use session / windows layout:
viewtopic.php?t=203402
by rextended
Mon Jan 15, 2024 2:08 pm
Forum: General
Topic: Why am I seeing IPv6 packets?
Replies: 7
Views: 609

Re: Why am I seeing IPv6 packets?

I don't speak English, I mean, get over it, they don't go out,
but investigate what traffic they're doing, maybe some peripheral is compromised... ;)

Google is your friend (sometime)...
https://en.wikipedia.org/wiki/Multicast_DNS
by rextended
Mon Jan 15, 2024 1:18 pm
Forum: Beginner Basics
Topic: doh server connection error network is unreachable over DNS 1.1.1.1
Replies: 54
Views: 4300

Re: doh server connection error network is unreachable over DNS 1.1.1.1

But again... if you open the certificate property, is also present that... (do not trust forum, moderators can modify my post without any notice) the solution is already inside the certificate (1.3.6.1.5.5.7.48.1) URL=http://ocsp.digicert.com (1.3.6.1.5.5.7.48.2) URL=http://cacerts.digicert.com/Digi...
by rextended
Mon Jan 15, 2024 12:53 pm
Forum: General
Topic: User poll about using Winbox
Replies: 91
Views: 39699

Re: User poll about using Winbox

   
by rextended
Mon Jan 15, 2024 12:49 pm
Forum: General
Topic: Why am I seeing IPv6 packets?
Replies: 7
Views: 609

Re: Why am I seeing IPv6 packets?

But what do you care about IPv6 packets if they can't go out on the Internet anyway?

The link local fe80:.... addresses can't be routed on Internet also if you have IPv6 enabled on router.
by rextended
Mon Jan 15, 2024 12:35 pm
Forum: Beginner Basics
Topic: doh server connection error network is unreachable over DNS 1.1.1.1
Replies: 54
Views: 4300

Re: doh server connection error network is unreachable over DNS 1.1.1.1

Above, a member wrote about three certificates: Above, one member obscure public availabledata on image, so who trust? Someone who has posted little on the forum, just registered, or someone who has written more and is member from long time? Installing the three certificates in the PEM chain that y...
by rextended
Mon Jan 15, 2024 12:32 pm
Forum: General
Topic: Why am I seeing IPv6 packets?
Replies: 7
Views: 609

Re: Why am I seeing IPv6 packets?

Using words already written by others on the forum: You can prevent the router from generating or interpreting IPv6 packets, but you cannot prevent devices connected to the router from exchanging any Internet protocol packets, even IPv6, with each other. At most with rules on the router, completely ...
by rextended
Mon Jan 15, 2024 12:23 pm
Forum: Beginner Basics
Topic: doh server connection error network is unreachable over DNS 1.1.1.1
Replies: 54
Views: 4300

Re: doh server connection error network is unreachable over DNS 1.1.1.1

Don't trust links in forum. Go to 1.1.1.1 yourself and download it yourself.
Correct, but if someone have problems or doubt finding it,
in the certificate properties displayed in the browser there is the precise link without going crazy looking for it...
by rextended
Mon Jan 15, 2024 12:15 pm
Forum: Beginner Basics
Topic: doh server connection error network is unreachable over DNS 1.1.1.1
Replies: 54
Views: 4300

Re: doh server connection error network is unreachable over DNS 1.1.1.1

the solution is already inside the certificate (1.3.6.1.5.5.7.48.1) URL=http://ocsp.digicert.com (1.3.6.1.5.5.7.48.2) URL=http://cacerts.digicert.com/DigiCertGlobalG2TLSRSASHA2562020CA1-1.crt http://cacerts.digicert.com/DigiCertGlobalG2TLSRSASHA2562020CA1-1.crt It could be a security flaw to trust t...
by rextended
Mon Jan 15, 2024 12:02 pm
Forum: Beginner Basics
Topic: doh server connection error network is unreachable over DNS 1.1.1.1
Replies: 54
Views: 4300

Re: doh server connection error network is unreachable over DNS 1.1.1.1

All you need is the certificate that you already put in the link in your previous post.

Who said you need to install 3 of them to make it work?

I can install up to 40 of them, but as long as there is the right one among them.
by rextended
Mon Jan 15, 2024 11:44 am
Forum: Scripting
Topic: L2TP get ip on 0.0.0.0 in remote ip?
Replies: 3
Views: 787

Re: L2TP get ip on 0.0.0.0 in remote ip?

why { }?
use " ".
/system scheduler
add interval=15m name="drop l2tp stale connections" on-event="/ppp active remove [find where service=l2tp and address=0.0.0.0]"
by rextended
Mon Jan 15, 2024 11:40 am
Forum: Announcements
Topic: v7.13.5 [stable] is released!
Replies: 909
Views: 247960

Re: v7.13.2 [stable] is released!

*) wifi - fixed issue with setting country profile (introduced in v7.13.1);
Thanks...
by rextended
Mon Jan 15, 2024 11:35 am
Forum: Announcements
Topic: v7.14beta [testing] is released!
Replies: 510
Views: 144732

Re: v7.14beta [testing] is released!

I guess for some people it is always possible to invent a new problem...
+1000
by rextended
Mon Jan 15, 2024 11:30 am
Forum: General
Topic: User poll about using Winbox
Replies: 91
Views: 39699

Re: User poll about using Winbox

1) Continuosly 2) Fix the bad default winbox visual choice (like right colums to display, column size, windows position, etc.) 3) It's impossible to please everyone, there's always someone who isn't happy, and as usual they are the ones who write on the forum. Others who think it works don't care ab...
by rextended
Sat Jan 13, 2024 11:11 am
Forum: Announcements
Topic: v7.13.5 [stable] is released!
Replies: 909
Views: 247960

Re: v7.13.1 [stable] is released!

:-D
chi sei, da che operatore?
A small one ;)
This topic is strictly moderated (or at least it should be...) let's stop this off-topic here ;)
by rextended
Sat Jan 13, 2024 11:07 am
Forum: Announcements
Topic: v7.13.5 [stable] is released!
Replies: 909
Views: 247960

Re: v7.13.1 [stable] is released!

we have spaces in ALL our system identities.
Non siete da soli..............
by rextended
Sat Jan 13, 2024 11:01 am
Forum: Announcements
Topic: v7.13.5 [stable] is released!
Replies: 909
Views: 247960

Re: v7.13.1 [stable] is released!

I have issues with the backup script. I made an export then upload via FTP. 7.12.1 works, from 7.13 no. As usual MikroTik does things without doing in-depth tests of what changing object names entails... Ah no, I'm wrong: we are the testers... for free... You didn't test the script on the command l...
by rextended
Sat Jan 13, 2024 10:19 am
Forum: Scripting
Topic: Export non-DHCP devices
Replies: 6
Views: 914

Re: Export non-DHCP devices

Do I ask too much?
Hire someone, it's a job, not a command to explain...
by rextended
Sat Jan 13, 2024 10:13 am
Forum: Announcements
Topic: v7.13.5 [stable] is released!
Replies: 909
Views: 247960

Re: v7.13.1 [stable] is released!

I have issues with the backup script.
Open separate topic, and post the script
by rextended
Fri Jan 12, 2024 3:30 pm
Forum: Beginner Basics
Topic: doh server connection error network is unreachable over DNS 1.1.1.1
Replies: 54
Views: 4300

Re: doh server connection error network is unreachable over DNS 1.1.1.1

So RouterOS should also implement an additional package with the list of trusted root certificates...
by rextended
Thu Jan 11, 2024 5:09 pm
Forum: General
Topic: v7 to 6 any chance to downgrade?
Replies: 27
Views: 4592

Re: v7 to 6 any chance to downgrade?

that for obvious reasons replace 7.7 with 7.13.1 wherever it is in that guide.
So, actually must be "If I had to migrate from CCR1036 v6.49.10 to CCR2112 v7.13.1...." ;)
by rextended
Thu Jan 11, 2024 3:07 pm
Forum: Announcements
Topic: WinBox v3.40 released!
Replies: 109
Views: 103109

Re: WinBox v3.40 released!

So, more than obviously at this point, given what you write, you need to contact those who develop Wine...
by rextended
Thu Jan 11, 2024 2:53 pm
Forum: Announcements
Topic: WinBox v3.40 released!
Replies: 109
Views: 103109

Re: WinBox v3.40 released!

It is not MikroTik's responsibility to operate third-party software. Did you ask Gcenx and Apple instead? Only they at most can say something about it, not just any person passing through the forum... It's called WinBox, not MacBox or... er... WineBox ... so if you want to run it on another platform...
by rextended
Thu Jan 11, 2024 2:41 pm
Forum: Beginner Basics
Topic: doh server connection error network is unreachable over DNS 1.1.1.1
Replies: 54
Views: 4300

Re: doh server connection error network is unreachable over DNS 1.1.1.1

The situation is simple: Cloudflare updates the https certificate every 2 years (last time done on 30 Dec 2023). This time DigiCert did not sign the certificate with the old key, but with the new one, so the root certificate is no longer valid. So probably every 2 years or less (it can happen at any...
by rextended
Thu Jan 11, 2024 1:44 pm
Forum: Beginner Basics
Topic: DDoS help
Replies: 42
Views: 2389

Re: DDoS help

The router probably crashes after some time when the memory is full... I only see different IPs:ports and a form of blacklist that after a while fills the memory and crashes the router. The best way to protect yourself is to ignore attacks and leave your firewall configured well. However, the best w...
by rextended
Thu Jan 11, 2024 1:00 pm
Forum: Scripting
Topic: Syntax difference in versions, how to handle? [SOLVED]
Replies: 12
Views: 1150

Re: Syntax difference in versions, how to handle? [SOLVED]

Don't read what I didn't write, that is in general, not in this specific case.
by rextended
Thu Jan 11, 2024 12:37 pm
Forum: Scripting
Topic: Syntax difference in versions, how to handle? [SOLVED]
Replies: 12
Views: 1150

Re: Syntax difference in versions, how to handle? [SOLVED]

get 0
Please stop writing on this way, no matter if is only one example.
by rextended
Thu Jan 11, 2024 12:34 pm
Forum: Scripting
Topic: Syntax difference in versions, how to handle? [SOLVED]
Replies: 12
Views: 1150

Re: Syntax difference in versions, how to handle? [SOLVED]

False and misinformation. An example of all the things that are missing on v7, which are instead present on v6, which therefore do not make it possible to install v7, (ignoring BGP & Co.)... Where is user-manager on v7? Not something called "use-manager", but something that have same ...
by rextended
Thu Jan 11, 2024 10:49 am
Forum: Scripting
Topic: Useful scripts
Replies: 116
Views: 292905

Re: Useful scripts

Both work only on v7.?.? (where ":convert" is added) because inside is present :convert :global cyrb53a do={ :local imul do={ :local s1 [:tonum $1] :local s2 [:tonum $2] :local ah (($s1 >> 16) & 0xffff) :local al ( $s1 & 0xffff) :local bh (($s2 >> 16) & 0xffff) :local bl ( $s2 ...
by rextended
Wed Jan 10, 2024 1:21 pm
Forum: Scripting
Topic: Why is this so hard???
Replies: 24
Views: 3528

Re: Why is this so hard???

It seems that the final goal is to have that file, not to print something on screen...
Yes, as OP is written, but can then as-string and file arguments be mixed to be sync call since is suggested? Don't have time to test that now.
The same, not noticed, not tested...
by rextended
Wed Jan 10, 2024 1:19 pm
Forum: Scripting
Topic: Why is this so hard???
Replies: 24
Views: 3528

Re: Why is this so hard???

Ha! I hope your WISP customers substantially less idiotic than programming clients?
NO... but this time I pay someone for follow that :lol: :lol: :lol:
by rextended
Wed Jan 10, 2024 11:18 am
Forum: Scripting
Topic: Why is this so hard???
Replies: 24
Views: 3528

Re: Why is this so hard???

Why not just perform commands without :execute then?
It seems that the final goal is to have that file, not to print something on screen...
by rextended
Wed Jan 10, 2024 11:16 am
Forum: Scripting
Topic: Why is this so hard???
Replies: 24
Views: 3528

Re: Why is this so hard???

Do you do this professionally?
Once upon a time, I got annoyed at how idiotic customers are, so I opened a WISP business and stopped programming for work.
by rextended
Wed Jan 10, 2024 11:07 am
Forum: Scripting
Topic: Why is this so hard???
Replies: 24
Views: 3528

Re: Why is this so hard???

@infabo see docs for ":execute" command - https://help.mikrotik.com/docs/display/ROS/Scripting Execute the script in the background. The result can be written in the file by setting a "file" parameter or printed to the CLI by setting "as-string". When using the "a...
by rextended
Wed Jan 10, 2024 11:03 am
Forum: Scripting
Topic: `conditional not boolean` bug with :onerror (new in 7.13)
Replies: 24
Views: 2598

Re: Possible bugs with :onerror (new in 7.13)

This bug can be worked around by declaring the variable used for :onerror before each :onerror... If I try the workaround that I suggested (declaring the variable before each :onerror), it works. Did you figure it out!!! I already answered you (and I suggest the correct way, not you) in post #2, bu...
by rextended
Tue Jan 09, 2024 9:50 pm
Forum: Scripting
Topic: New command in RouterOs 7
Replies: 34
Views: 5845

Re: New command in RouterOs 7

I forgot:

Both $cmdtree and $cmdtreeVar accept path as parameter, both on /ip/address and ip,address format
by rextended
Tue Jan 09, 2024 9:33 pm
Forum: Scripting
Topic: New command in RouterOs 7
Replies: 34
Views: 5845

Re: New command in RouterOs 7

The function was created to save a file, to be taken outside the routerboard and then compared between those of different installed versions/packages. It takes little to modify it and use it to create a variable. :global cmdtreeVar do={ :global cmdtreeVar ; # declared again for the recursive call :l...
by rextended
Tue Jan 09, 2024 9:18 pm
Forum: Scripting
Topic: Why is this so hard???
Replies: 24
Views: 3528

Re: Why is this so hard???

Yes, read my snippets... https://forum.mikrotik.com/viewtopic.php?f=9&t=87589&p=861988#p861988 { :local jobID [:execute file=temp1.txt \ "/ip dhcp-server lease; :foreach i in=[find] do={:put (\"\$[get \$i mac-address],\$[get \$i address],\$[get \$i host-name],\$[get \$i comment]\&q...
by rextended
Tue Jan 09, 2024 2:25 pm
Forum: Scripting
Topic: Why is this so hard???
Replies: 24
Views: 3528

Re: Why is this so hard???

In the meantime, write the script in a decent way, then the rest comes. :execute file=temp1.txt \ "/ip dhcp-server lease; :foreach i in=[find] do={:put (\"\$[get \$i mac-address],\$[get \$i address],\$[get \$i host-name],\$[get \$i comment]\")}" You can't obtain host-name or comm...
by rextended
Tue Jan 09, 2024 2:09 pm
Forum: General
Topic: MUM plans for 2023?
Replies: 52
Views: 8611

Re: MUM plans for 2023?

Until the 7.23.5 (long-term) is not ready and have aligned feature with v6, can't do any MUM...
They would risk finding a lot of pissed off cats and users...
by rextended
Tue Jan 09, 2024 1:41 pm
Forum: Scripting
Topic: New command in RouterOs 7
Replies: 34
Views: 5845

Re: New command in RouterOs 7

The file are too big for the forum, first 466 lines of all_cmd_7.13.1 (stable).txt / beep (a) as-value (a) frequency (a) length convert (a) from (a) from-scheme (a) to (a) to-scheme (a) transform (a) transform-scheme (a) value delay (a) delay-time deserialize (a) from (a) value do (a) command (a) if...
by rextended
Tue Jan 09, 2024 12:30 pm
Forum: Scripting
Topic: New command in RouterOs 7
Replies: 34
Views: 5845

Re: New command in RouterOs 7

Some useful to compare news on different versions.... :global cmdtree do={ :global cmdtree ; # declared again for the recursive call :local start [:tostr $1] :local qpath "" :local temp "" :local spac "" :local arrPath [:toarray ""] :local arrDir [:toarray &qu...
by rextended
Tue Jan 09, 2024 10:34 am
Forum: Scripting
Topic: DynDNS.com Update
Replies: 7
Views: 3343

Re: DynDNS.com Update

It is probably a write of less than 1 KiB in size and would typically repeat every 5 minutes. Assuming it a 1 KiB write every 5 minutes, It would take 56.8889 days to write 16 MiB. I have no idea how wear leveling works for the kinds of flash used in MikroTik products or what their write endurance ...
by rextended
Mon Jan 08, 2024 9:36 am
Forum: Scripting
Topic: `conditional not boolean` bug with :onerror (new in 7.13)
Replies: 24
Views: 2598

Re: Possible bugs with :onerror (new in 7.13)

There are situations where currently "on-error-resume-next" must be used because it is poorly managed by RouterOS , such as ":resolve", for everything else, error-proof scripts must be written, preventing any errors that may occur, such as a missing parameter in a called function...
by rextended
Mon Jan 08, 2024 1:11 am
Forum: Scripting
Topic: `conditional not boolean` bug with :onerror (new in 7.13)
Replies: 24
Views: 2598

Re: Possible bugs with :onerror (new in 7.13)

Any idea if this is a bug or just undocumented behavior? The problem is not RouterOS, but what you expect. If there is no error, the variable is not defined, so if you don't define it first, it's obvious that it's nothing . :put [:local errorName "empty"; :onerror errorName in={:put "...
by rextended
Sun Jan 07, 2024 10:52 am
Forum: Scripting
Topic: 7.12.1 NAT Rule script bug
Replies: 2
Views: 1909

Re: 7.12.1 NAT Rule script bug

/ip firewall nat remove [find where to-ports="1001"]
by rextended
Fri Jan 05, 2024 5:14 pm
Forum: Scripting
Topic: Sync interface ON\OFF with POE
Replies: 11
Views: 1776

Re: Sync interface ON\OFF with POE

[find mac-address=

1 + 1 = 2
but also
1 + 88 - 99 + 12 = 2

The point is that do not have any sense if interface name (or default interface name) can be used directly...
by rextended
Fri Jan 05, 2024 2:19 pm
Forum: Scripting
Topic: Sync interface ON\OFF with POE
Replies: 11
Views: 1776

Re: Sync interface ON\OFF with POE

or
/interface ethernet disable [find <some field>=<some value>]
by rextended
Fri Jan 05, 2024 12:18 pm
Forum: Scripting
Topic: Sync interface ON\OFF with POE
Replies: 11
Views: 1776

Re: Sync interface ON\OFF with POE

When the script disable/enable the interface, add a line for off/auto the poe...
by rextended
Fri Jan 05, 2024 12:14 pm
Forum: Scripting
Topic: DDNS Script don't work since update to 7.13 [SOLVED]
Replies: 5
Views: 1923

Re: DDNS Script don't work since update to 7.13 [SOLVED]

Downgrade or wait for the final version 7.14.
Since you don't bother reading the relevant topics before upgrade, there's no point in wasting my time explaining why.
by rextended
Thu Jan 04, 2024 6:11 pm
Forum: Scripting
Topic: Trigger script on NTP Client Sync
Replies: 2
Views: 829

Re: Trigger script on NTP Client Sync

Normally only a loss of power can cause a loss of time.

Turn off your device [not reboot], turn it back on and check how many seconds it takes for the NTP to sync,
then add (for example if it takes 30 seconds, add 10 seconds for tolerance)
:delay 40s
at the beginning of the script.
by rextended
Wed Jan 03, 2024 4:09 pm
Forum: Scripting
Topic: hotspot new active
Replies: 2
Views: 891

Re: hotspot new active

As already written two thousand and twenty-four times, number= (and related) must absolutely never be used in scripts.

Hint: Read the documentation:
https://wiki.mikrotik.com/wiki/Manual:I ... er_Profile
by rextended
Tue Jan 02, 2024 7:09 pm
Forum: Scripting
Topic: Add array element inside for / foreach
Replies: 18
Views: 1837

Re: Add array element inside for / foreach

Yes, if there is no need for some other commands in iteration block while populating interfaces array...
For sure, but the user, as example, want just obtain one array with all port interfaces data inside, and whay I have proposed is the fast way without cycles...
by rextended
Tue Jan 02, 2024 7:00 pm
Forum: Scripting
Topic: Add array element inside for / foreach
Replies: 18
Views: 1837

Re: Add array element inside for / foreach

Or simply, as already wrote on post #6....

example code

:global interfaces [/interface bridge port print detail as-value where pvid=10]

:put $interfaces

:foreach i in=$interfaces do={
    :put "$($i->"interface") is on the bridge $($i->"bridge")"
}
EDIT: Changed pvid
by rextended
Tue Jan 02, 2024 3:31 pm
Forum: Scripting
Topic: Add array element inside for / foreach
Replies: 18
Views: 1837

Re: Add array element inside for / foreach

And it's perfectly logical, you can't have two keys with the same name in the same array... :global example [:toarray ""] :set example ($example,{"interface"="ether1";"arr1"="yes"}) :set example ($example,{"interface"="ether2";&qu...
by rextended
Mon Jan 01, 2024 3:31 pm
Forum: General
Topic: The VoIP odyssey [SOLVED]
Replies: 16
Views: 2294

Re: The VoIP odyssey [SOLVED]

CRS326-24G-2S+ as my edge router and main switch It's all wrong from the start, if you use a product created to be a switch as a edge router. Try this, and use static DHCP lease for VoIP phone, with renewal each 10 minutes, instead of fixed address inside the phone. /ip firewall connection tracking...
by rextended
Mon Jan 01, 2024 3:05 pm
Forum: Scripting
Topic: Add array element inside for / foreach
Replies: 18
Views: 1837

Re: Add array element inside for / foreach

Just that ? :global interfaces [/interface bridge port print detail as-value where pvid=80] :put $interfaces :put "$($interfaces->0->"interface") is on the bridge $($interfaces->0->"bridge")" Obviously " put " print results on terminal only if something with p...
by rextended
Mon Jan 01, 2024 1:47 pm
Forum: Scripting
Topic: DynDNS Script from Mikrotik Wiki (correction)
Replies: 28
Views: 29760

Re: DynDNS Script from Mikrotik Wiki (correction)

uff I can't get used to those manners ;-) but I like him... Happy new year and please, it doesn't cost work to be a little kind. It probably depends on the fact that I am NOT a native English speaker and I don't use automatic translators... :lol: At least if I make a mistake it's my fault... And in...
by rextended
Mon Jan 01, 2024 4:18 am
Forum: Scripting
Topic: Add array element inside for / foreach
Replies: 18
Views: 1837

Re: Add array element inside for / foreach

Check errors... "$" after :set , useless ";" and $bport is not the interface/port name Is not clear what is wanted at the end: one array with only all the interfaces name only (where pvid=80), or other? Better this: :global interfaces [:toarray ""] /interface bridge por...
by rextended
Sun Dec 31, 2023 6:04 pm
Forum: Scripting
Topic: DynDNS Script from Mikrotik Wiki (correction)
Replies: 28
Views: 29760

Re: DynDNS Script from Mikrotik Wiki (correction)

With the latest versions of RouterOS the "fetch" command does not work https anymore. False... and define what is "latest versions" for you. [vmtest@] > :put ([/tool fetch url="https://upgrade.mikrotik.com/routeros/NEWESTa7.stable" as-value output=user]->"data&quo...
by rextended
Sat Dec 30, 2023 1:35 pm
Forum: Scripting
Topic: DynDNS Script from Mikrotik Wiki (correction)
Replies: 28
Views: 29760

Re: DynDNS Script from Mikrotik Wiki (correction)

Interface can have multiple addresses, so the script is bad at the start...
by rextended
Sat Dec 30, 2023 1:29 pm
Forum: Announcements
Topic: v7.13.5 [stable] is released!
Replies: 909
Views: 247960

Re: v7.13 [stable] is released!

When launching export file="$[system identity get name]" commands ROS is adding in underscores for any spaces in the name. So a device called "this is a test" would generate a file "this_is_a_test.rsc". Is this expected behaviour? Just read, and understand what are the...
  • 1
  • 2
  • 3
  • 4
  • 5
  • 42