Community discussions

MUM Europe 2020

Search found 25 matches

by chrisw
Thu Oct 27, 2016 8:05 pm
Forum: General
Topic: Feature Req. - Preview Commands
Replies: 6
Views: 1219

Feature Req. - Preview Commands

In Cisco ASDM there is an option to preview commands of changes made in the GUI before they are applied. Adding a feature like this would help in a number of ways: Newbies get to see their actions in the GUI played out in the command line, thus helping them learn commands. Commands are easily copy/p...
by chrisw
Thu Aug 20, 2015 8:45 pm
Forum: RouterBOARD hardware
Topic: RB1000 closing tens of pppoe connections at once
Replies: 51
Views: 18785

Re: RB1000 closing tens of pppoe connections at once

It's rather discouraging seeing how old this thread is when I'm having the same problem here, five years later on a CCR1036-12G-4S running RouterOS v6.31. 2,000 PPPoE clients. Sometimes if a node drops during maintenance, we expect lose about 200 sessions. Those sessions do drop, and then the REST O...
by chrisw
Tue Jun 30, 2015 9:17 pm
Forum: Scripting
Topic: Simple queue burst set from radius
Replies: 8
Views: 3364

Re: Simple queue burst set from radius

I know a lot of time have passed, but if you still interested ...
"Framed-IP-Address=172.24.54.15,Mikrotik-Rate-Limit='64k/64k 256k/256k 128k/128k 10/10'"
Works well!
Beautiful. Thanks for that.
by chrisw
Tue Mar 31, 2015 11:08 pm
Forum: General
Topic: PPPoE - DNS not passing to some clients
Replies: 1
Views: 927

Re: PPPoE - DNS not passing to some clients

I set the max UDP packet size to 512. Still no effect. DNS traffic seems to pass for a while, then nothing again. Any ideas are greatly appreciated.
by chrisw
Mon Jan 19, 2015 8:33 pm
Forum: General
Topic: PPPoE - DNS not passing to some clients
Replies: 1
Views: 927

PPPoE - DNS not passing to some clients

CCR1036-12G-4S v6.24 PPPoE server set up on the CCR, client routers can authenticate successfully and resolve DNS and ping public IP's. Client routers get assigned appropriate DNS servers, but that information fails to pass to client devices. Client devices behind client routers can ping public IP'...
by chrisw
Tue Dec 09, 2014 8:15 pm
Forum: General
Topic: Simple Queues not limiting download speed
Replies: 1
Views: 1017

Re: Simple Queues not limiting download speed

I've managed to get download working now, but lost my upload limit. Here's my config: Mangle [admin@MikroTik] > /ip firewall mangle print Flags: X - disabled, I - invalid, D - dynamic 0 ;;; 2m up chain=forward action=mark-connection new-connection-mark=2mbps_up passthrough=no src-address-list=10-2_l...
by chrisw
Tue Dec 09, 2014 8:14 pm
Forum: General
Topic: v6.22 download traffic limit problems
Replies: 7
Views: 2790

Re: v6.22 download traffic limit problems

I've managed to get download working now, but lost my upload limit. Here's my config: Mangle [admin@MikroTik] > /ip firewall mangle print Flags: X - disabled, I - invalid, D - dynamic 0 ;;; 2m up chain=forward action=mark-connection new-connection-mark=2mbps_up passthrough=no src-address-list=10-2_l...
by chrisw
Mon Dec 08, 2014 9:01 pm
Forum: General
Topic: v6.22 download traffic limit problems
Replies: 7
Views: 2790

Re: v6.22 download traffic limit problems

Hi aharrison, I'm having the same issue. Your suggested mangle rules proved ineffective. Both packet and connection marking work only for upload. The download packet and connection marking fail to mark a single packet.
by chrisw
Mon Dec 08, 2014 8:06 pm
Forum: General
Topic: Simple Queues not limiting download speed
Replies: 1
Views: 1017

Simple Queues not limiting download speed

I have a simple queue configured to limit upload to 2mbps and download to 10mbps on a specific IP address. It limits the upload speed perfectly, but the download traffic remains unthrottled. Download packets are not graphed in the simple queue Traffic tab, yet the interface itself shows Tx speeds th...
by chrisw
Thu Dec 04, 2014 8:09 pm
Forum: Forwarding Protocols
Topic: BGP - Too many advertisements
Replies: 4
Views: 2241

Re: BGP - Too many advertisements

Agreed. I think it's a bug. Same thing happens on my CCR1036 running 6.20. BGP Advertisements claim there are too many to display, but when I select "Click here to see them all" it shows all FOUR advertisements for two seconds, then goes back to "There are too many advertisements to show them all. P...
by chrisw
Wed Dec 03, 2014 8:54 pm
Forum: Forwarding Protocols
Topic: Any outside ping appears to flap
Replies: 1
Views: 704

Re: Any outside ping appears to flap

I figured this one out. After taking a look at the route filters in place, I noticed our (now offline) Edge 2 was in "Set In Nexthop" for the inbound BGP filters along with our Edge 1 router. After taking Edge 2 out, everything works great.
by chrisw
Wed Dec 03, 2014 3:13 am
Forum: Forwarding Protocols
Topic: Any outside ping appears to flap
Replies: 1
Views: 704

Any outside ping appears to flap

A few months ago I had a CCR1036 configured just fine with BGP with a public AS getting a full route table in a lab. I let it sit up until recently and now it appears like any outbound pings from the CCR experience roughly 50% loss. It'll be successful for one minute, then completely time out the ne...
by chrisw
Fri Nov 28, 2014 8:51 pm
Forum: General
Topic: x86: 105 (no buffer space available )
Replies: 6
Views: 3781

Re: x86: 105 (no buffer space available )

I had a similar issue on a CCR1036. We tried to put it into production with approximately 1700 pppoe clients, once peak hours came along, it topped off about 450mbps (normal peak for us is 650mbps) and then the packet loss started. Having to scramble to put our old router in place was no fun.
by chrisw
Thu Apr 17, 2014 3:00 am
Forum: Beginner Basics
Topic: Can't Ping
Replies: 4
Views: 881

Re: Can't Ping

Seeing as you don't remember the IP address you assigned the MikroTik, is it possible you are attempting to ping the wrong IP address? Also, make sure your client computer has a subnet mask capable of "seeing" the MikroTik. (eg 255.255.255.0)
by chrisw
Wed Apr 16, 2014 7:57 pm
Forum: Scripting
Topic: Import list of IP's to ammend Address List
Replies: 12
Views: 7142

Re: Import list of IP's to ammend Address List

UPDATE

If you're trying to parse tab-delimited text instead of line-delimited, simply replace every instance of "\r\n" and "\n" in the script with "\t".
by chrisw
Wed Apr 16, 2014 6:50 pm
Forum: Scripting
Topic: Import list of IP's to ammend Address List
Replies: 12
Views: 7142

Re: Import list of IP's to ammend Address List

RESOLVED Shoutout to /user/netsx on the MikroTik subreddit for the solution. The problem is because my .txt file is MSDOS line formatted ( "\r\n" ) but it's expecting a Linux/Unix, etc. line format ( "\n" ). Working code is here: :if ( [/file get [/file find name=suspendedaccts.txt] size] > 0 ) do=...
by chrisw
Wed Apr 16, 2014 6:46 pm
Forum: Scripting
Topic: Import list of IP's to ammend Address List
Replies: 12
Views: 7142

Re: Import list of IP's to ammend Address List

The list is for non-paying customers whose IP addresses get added to an address list filtered by a dstNAT rule that redirects all traffic to our pay portal page.
by chrisw
Sat Apr 12, 2014 2:08 am
Forum: Scripting
Topic: Import list of IP's to ammend Address List
Replies: 12
Views: 7142

Re: Import list of IP's to ammend Address List

Unfortunately, there is a 4096 byte read/write limit when working with text files inside RouterOS: http://forum.mikrotik.com/viewtopic.php?f=9&t=40830&p=202842#p203311 Reduce your file size, and then pasting this in the terminal. It will show the file contents, unless the file size is too big and t...
by chrisw
Sat Apr 12, 2014 2:03 am
Forum: Scripting
Topic: Import list of IP's to ammend Address List
Replies: 12
Views: 7142

Re: Import list of IP's to ammend Address List

Coming along, but still having issues. I found another website that had slightly different code and it successfully Imports the first IP address on my list - but only the first. Then it throws up the error message "value of address expects range of ip addresses". :if ( [/file get [/file find name=su...
by chrisw
Fri Apr 11, 2014 9:55 pm
Forum: Scripting
Topic: Import list of IP's to ammend Address List
Replies: 12
Views: 7142

Re: Import list of IP's to ammend Address List

It seems the script is hanging at this point at the end: :if ( [:pick $line 0 1] != "\n" ) do={ :if ( [:len $line ] > 0 ) do={ /ip firewall address-list add list=suspendedaccts address=$line } } } while ($lineEnd < $contentLen) } This is where it goes line by line and adds each IP address to an addr...
by chrisw
Fri Apr 11, 2014 7:16 pm
Forum: Forwarding Protocols
Topic: BGP is working - can't ping out
Replies: 5
Views: 2388

Re: BGP is working - can't ping out

Thanks for your help,
Looks like this issue was caused by some misinformation from our network administrator. Once I got the proper settings I was golden.
by chrisw
Fri Apr 11, 2014 2:54 am
Forum: Scripting
Topic: Import list of IP's to ammend Address List
Replies: 12
Views: 7142

Import list of IP's to ammend Address List

EDIT: Solution Here: http://forum.mikrotik.com/viewtopic.php?f=9&t=83910#p421517 I have a list of banned IP's that I update all the time for customers who are overdue on their payments. I'm following the instructions on this page http://wiki.mikrotik.com/wiki/Using_Fetch_and_Scripting_to_add_IP_Add...
by chrisw
Thu Mar 06, 2014 2:24 am
Forum: Forwarding Protocols
Topic: BGP is working - can't ping out
Replies: 5
Views: 2388

Re: BGP is working - can't ping out

Traceroutes get to my immediate bgp peer and then fail.
by chrisw
Wed Mar 05, 2014 8:04 pm
Forum: Forwarding Protocols
Topic: BGP is working - can't ping out
Replies: 5
Views: 2388

Re: BGP is working - can't ping out

Not using OSFP and both routers are getting routes from each other.

From the mikrotik terminal, I can resolve domains' IP addresses, but pings time out.
by chrisw
Tue Mar 04, 2014 11:59 pm
Forum: Forwarding Protocols
Topic: BGP is working - can't ping out
Replies: 5
Views: 2388

BGP is working - can't ping out

First time setting up BGP and I'm sure this is something simple. I've successfully peered my MikroTik router to my existing core router. All 480,000-ish routes have poured in - it's talking just fine. That said, I can't even ping the outside from the terminal in Winbox. I can ping my DNS servers and...