Community discussions

MikroTik App

Search found 25 matches

by aleksis
Wed Aug 31, 2022 9:09 pm
Forum: Forwarding Protocols
Topic: ROSv7 routing filter make an accept all rule?
Replies: 1
Views: 1149

Re: ROSv7 routing filter make an accept all rule?

Add 'accept' as the last statement.
For example:
/routing/filter/rule add rule="if (dst == 1.1.1.0/24 || dst == 2.2.2.0/24 ) { reject } if ( dst-len > 28) { reject } accept"
by aleksis
Mon Jul 04, 2022 11:25 am
Forum: Forwarding Protocols
Topic: How to filter routes that are advertised via OSPF? [SOLVED]
Replies: 4
Views: 1417

Re: How to filter routes that are advertised via OSPF? [SOLVED]

Filter default action is 'reject'.
rule="if ( protocol ospf && dst in 1.1.1.1 ) { reject } else { accept }"
by aleksis
Thu May 19, 2022 2:41 pm
Forum: Forwarding Protocols
Topic: v.7.3beta40 OSPF possible BUG. Default route not created in STUB Intra-Area Router [SOLVED]
Replies: 3
Views: 1875

Re: v.7.3beta40 OSPF possible BUG. Default route not created in STUB Intra-Area Router [SOLVED]

In v7 "default-cost" must be configured for the stub area to get the default route originated.
by aleksis
Fri Apr 08, 2022 9:58 am
Forum: Forwarding Protocols
Topic: OSPFv3 Type 9 LSA Behavior and Extra /128s
Replies: 3
Views: 983

Re: OSPFv3 Type 9 LSA Behavior and Extra /128s

Those addresses are included for virtual links. Currently they are included unconditionally.
by aleksis
Fri Mar 25, 2022 1:42 pm
Forum: Forwarding Protocols
Topic: Control OSPF static redistribution (ROS v6 vs v7)
Replies: 11
Views: 5495

Re: Control OSPF static redistribution (ROS v6 vs v7)

"redistribute=..." overrides filter decision now so try to unset that.
by aleksis
Tue Mar 01, 2022 8:45 am
Forum: RouterOS beta
Topic: ROSv7 RIP doesn't distribute routes
Replies: 4
Views: 2925

Re: ROSv7 RIP doesn't distribute routes

Try redistribute=rip,connected.
by aleksis
Fri Jan 21, 2022 10:32 am
Forum: Forwarding Protocols
Topic: OSPF load balancing broken in v7.1.1 ? [SOLVED]
Replies: 7
Views: 5793

Re: OSPF load balancing broken in v7.1.1 ? [SOLVED]

Load balancing should work. Is the ecmp route missing from the routing table?
by aleksis
Fri Jan 21, 2022 9:48 am
Forum: Forwarding Protocols
Topic: 7.1.1, 7.2rc1, wireguard, ospf, nmba - problem
Replies: 9
Views: 5243

Re: 7.1.1, 7.2rc1, wireguard, ospf, nmba - problem

For nbma and also ptmp network types static-neighbor configuration must be set.
by aleksis
Tue Dec 14, 2021 1:06 pm
Forum: RouterOS beta
Topic: Testing OSPF in simple configuration: bugs detected
Replies: 8
Views: 3896

Re: Testing OSPF in simple configuration: bugs detected

BUG: Looking at R1 neighbors I can see that R4 has been selected as the new DR (why? DR was previously elected) R4 will elect itself as the DR after it looses adjacency with other neighbours. After the link is repaired a new election will happen with 2 DR present and R4 wins because of 'higher' rou...
by aleksis
Mon Dec 13, 2021 7:28 pm
Forum: RouterOS beta
Topic: ros7 routing filter rules unusable - missing move functionality [SOLVED]
Replies: 2
Views: 2309

Re: ros7 routing filter rules unusable - missing move functionality [SOLVED]

move command argument 'destination' works like "place-before" so to move rule 1 one place further you have to do 'move 1 3'.
by aleksis
Mon Dec 13, 2021 7:54 am
Forum: RouterOS beta
Topic: V7 OSPF Default Route Metric
Replies: 7
Views: 3717

Re: V7 OSPF Default Route Metric

Yes, then filter should be sufficient and 'originate-default=' is not necessary.
by aleksis
Fri Dec 10, 2021 5:18 pm
Forum: RouterOS beta
Topic: V7 OSPF Default Route Metric
Replies: 7
Views: 3717

Re: V7 OSPF Default Route Metric

Sorry for not being clear.
Currently it is not possible to change metric for default originated with 'originate-default=always' as the filters are not applied in that case.
In my case I had default route within my routing table (static) and so the filter worked as expected.
by aleksis
Fri Dec 10, 2021 11:54 am
Forum: RouterOS beta
Topic: V7 OSPF Default Route Metric
Replies: 7
Views: 3717

Re: V7 OSPF Default Route Metric

Unfortunately the problem here is that the filters wont work on default dst originated from 'originate-default=always'.
In my case the default is originated from routing table dst.
by aleksis
Fri Dec 10, 2021 11:23 am
Forum: RouterOS beta
Topic: V7 OSPF Default Route Metric
Replies: 7
Views: 3717

Re: V7 OSPF Default Route Metric

Setting metric in v7 is possible only with filters and it looks like you did everything correctly. Are you using 'originate-default=always'? It works for me: /routing/ospf/instance/print name="default-v2" version=2 vrf=main router-id=main out-filter-chain=ospf-test /routing/filter/rule/pri...
by aleksis
Wed Dec 08, 2021 8:28 am
Forum: RouterOS beta
Topic: BGP + ECMP
Replies: 17
Views: 10403

Re: BGP + ECMP

Edit: I stand corrected, BGP multi path is not supported at the moment.
ECMP is supported. You should look at '/routing/route/print detail' to debug this.
by aleksis
Wed Dec 08, 2021 8:09 am
Forum: RouterOS beta
Topic: Does PIM work AT ALL on 7.1?
Replies: 12
Views: 6902

Re: Does PIM work AT ALL on 7.1?

PIM is implemented but currently broken due to some regressions and mikrotik is fixing them now.

RIPv2 and RIP-ng is implemented but the configuration is different. 'networks' configuration is replaced with 'redistribute' and 'out-filter-chain'. RIPv1 is removed for now.
by aleksis
Tue Nov 09, 2021 4:57 pm
Forum: RouterOS beta
Topic: v7.1rc6 [development] is released!
Replies: 145
Views: 57282

Re: v7.1rc6 [development] is released!

using RouterOS 7.1RC6 with EVE-NG, when we configure OSPFv3 when starting the routers, everything works perfectly when turning off the lab and turning on OSPV3 again stops working, and does not form a neighbor @mrz Can you show the output of these commands when ospf adjacency is not forming? /routi...
by aleksis
Mon Oct 11, 2021 10:43 am
Forum: RouterOS beta
Topic: Help migrating filter rules from v6 to v7
Replies: 13
Views: 5952

Re: Help migrating filter rules from v6 to v7

You can match chain like this:
add chain=MyTransitCustomer-IN rule="if (chain MyTransitCustomerAS) { set bgp-local-pref 300; set distance 10; accept; }"
by aleksis
Wed Sep 22, 2021 6:40 pm
Forum: RouterOS beta
Topic: v7.1rc4 [development] is released!
Replies: 276
Views: 84681

Re: v7.1rc4 [development] is released!

And this is not even accepted: [admin@MikroTik] /routing/filter/rule> add chain=ospf_out rule="if (dst in 10.0.0.0/8 && dst-len >= 20 && dst-len <= 22 && protocol static) { accept }" failure: "Word {dst-len} > Word {=} Word {20} " - invalid argument Also ...
by aleksis
Wed Sep 22, 2021 6:38 pm
Forum: RouterOS beta
Topic: v7.1rc4 [development] is released!
Replies: 276
Views: 84681

Re: v7.1rc4 [development] is released!

Currently this causes a crash. Will be fixed in rc5.
by aleksis
Tue Aug 05, 2014 10:35 am
Forum: Forwarding Protocols
Topic: Ip-tv igmp or pim?
Replies: 4
Views: 4430

Re: Ip-tv igmp or pim?

To get things straight - after you have everything set up and the source and client running you have MFC entry for group 224.0.23.10 with source 192.168.7.254. Does the ether3 interface appears in active-downstream-interfaces list or the list is empty? If the list is empty then you need to check if ...
by aleksis
Mon Jun 30, 2014 11:06 am
Forum: General
Topic: RouterOS 6.9 IGMP proxy stop working
Replies: 58
Views: 26677

Re: RouterOS 6.9 IGMP proxy stop working

Do you also have similar setup with PPPoE server on that router?
by aleksis
Thu Jun 26, 2014 12:04 pm
Forum: General
Topic: RouterOS 6.9 IGMP proxy stop working
Replies: 58
Views: 26677

Re: RouterOS 6.9 IGMP proxy stop working

On which of the two routerboards the igmp proxy stops working? The 1100 or 2011?
What is the output of "/routing igmp-proxy mfc print" on both routers when this happens?
by aleksis
Wed Apr 30, 2014 1:16 pm
Forum: General
Topic: Bonjour multicast - How to do it with VLANs ?
Replies: 21
Views: 14820

Re: Bonjour multicast - How to do it with VLANs ?

Post your igmp-group print detail.
by aleksis
Wed Apr 30, 2014 12:29 pm
Forum: General
Topic: Bonjour multicast - How to do it with VLANs ?
Replies: 21
Views: 14820

Re: Bonjour multicast - How to do it with VLANs ?

Can you see any IGMP joins on vlan200-private interface?