Community discussions

MUM Europe 2020

Search found 77 matches

by ahmedalmi
Tue Aug 28, 2018 10:55 am
Forum: Scripting
Topic: Mikrotik.php file scripts
Replies: 26
Views: 10372

Re: Mikrotik.php file scripts

then i disabled port 2000 form tools Btest server and i disabled the socks and i exported backup and read all code, nothing bad i don't know if will hacked after that Hi ahmedalmi , If you want to make your routers secure, make sure you setup your firewall to only allow acces from known IP adresses...
by ahmedalmi
Tue Aug 28, 2018 10:43 am
Forum: Scripting
Topic: Mikrotik.php file scripts
Replies: 26
Views: 10372

Re: Mikrotik.php file scripts

No, default config has firewall on the internet port. i mean the default config of bandwidth-test port "2000" is opend the firewall filter you talking about has exception for winbox port 8291 and the Vulnerability exploiting the Winbox port you said that on last photo the version 6.40.9 and it may ...
by ahmedalmi
Tue Aug 28, 2018 10:34 am
Forum: Scripting
Topic: Mikrotik.php file scripts
Replies: 26
Views: 10372

Re: Mikrotik.php file scripts

And definitely do not leave bandwidth test server open on the internet! Looks like you had done that.
of course
the default config is opened
by ahmedalmi
Tue Aug 28, 2018 10:32 am
Forum: Scripting
Topic: Mikrotik.php file scripts
Replies: 26
Views: 10372

Re: Mikrotik.php file scripts

then i disabled port 2000 form tools Btest server and i disabled the socks and i exported backup and read all code, nothing bad i don't know if will hacked after that Hi ahmedalmi , If you want to make your routers secure, make sure you setup your firewall to only allow acces from known IP adresses...
by ahmedalmi
Tue Aug 28, 2018 10:18 am
Forum: Scripting
Topic: Mikrotik.php file scripts
Replies: 26
Views: 10372

Re: Mikrotik.php file scripts

then i disabled port 2000 form tools Btest server
and i disabled the socks
and i exported backup and read all code, nothing bad
i don't know if will hacked after that
by ahmedalmi
Tue Aug 28, 2018 10:13 am
Forum: Scripting
Topic: Mikrotik.php file scripts
Replies: 26
Views: 10372

Re: Mikrotik.php file scripts

The fact is the following. The bug is fixed 100% but anyone can log in, if you did not correct the configuration that the hacker applied before your upgrade. This could have been 7 months ago even. You will not know about it. It is 99% likely that this person accessed your device before you upgrade...
by ahmedalmi
Tue Aug 28, 2018 9:38 am
Forum: Scripting
Topic: Mikrotik.php file scripts
Replies: 26
Views: 10372

Re: Mikrotik.php file scripts

The fact is the following. The bug is fixed 100% but anyone can log in, if you did not correct the configuration that the hacker applied before your upgrade. This could have been 7 months ago even. You will not know about it. It is 99% likely that this person accessed your device before you upgrade...
by ahmedalmi
Tue Aug 28, 2018 9:14 am
Forum: Scripting
Topic: Mikrotik.php file scripts
Replies: 26
Views: 10372

Re: Mikrotik.php file scripts

How do you know that nobody connected a month ago also? because I upgraded the version a month ago and I always follow the router and I know very well my RouerOS I always follow this bug from 6 month ago, and i know it , and i know the program can do this, but if i disable port www the program can'...
by ahmedalmi
Tue Aug 28, 2018 9:00 am
Forum: Scripting
Topic: Mikrotik.php file scripts
Replies: 26
Views: 10372

Re: Mikrotik.php file scripts

Hi everybody I thought the bug was closed in the 6.40.8 release but today more than 30 RouterOS hacked though version 6.40.8 bugfix only and 6.42.6 i saw this http://max-upgrade.com/mikrotikphotos/mikrotik-fuck-hacker.jpg Possibly your device was compromised earlier, before you upgraded. They only ...
by ahmedalmi
Tue Aug 28, 2018 6:54 am
Forum: Scripting
Topic: Mikrotik.php file scripts
Replies: 26
Views: 10372

Re: Mikrotik.php file scripts

Hi everybody
I thought the bug was closed in the 6.40.8 release
but today more than 30 RouterOS hacked though version 6.40.8 bugfix only and 6.42.6
i saw this
Image
by ahmedalmi
Sat Jun 09, 2018 1:55 am
Forum: General
Topic: progaram get any mikrotik system usernam and passowrd in 3 second
Replies: 35
Views: 7616

Re: progaram get any mikrotik system usernam and passowrd in 3 second

Good, but now try for real with two existing real admin accounts. :)
change your user name and password for admin user and he will know it
by ahmedalmi
Tue Oct 31, 2017 1:34 am
Forum: The User Manager
Topic: add user in Terminal/API
Replies: 5
Views: 5542

Re: add user in Terminal/API

on old version like 4 . there are no customer with all script on usermanager
you should use subscriber no customer
by ahmedalmi
Tue Oct 31, 2017 1:30 am
Forum: The User Manager
Topic: API MIkrotik
Replies: 4
Views: 1603

Re: API MIkrotik

there is no script to do this . just by user manager web
but you can remove the user then add new with your new profile
by ahmedalmi
Tue Oct 24, 2017 2:19 am
Forum: The User Manager
Topic: add user in Terminal/API
Replies: 5
Views: 5542

Re: add user in Terminal/API

if your RouterOS version up to 6.17 you should change name to username in this line Send("=username=" + varName); and in activate profile used "numbers" not "user" like previous versions Send("/tool/user-manager/user/create-and-activate-profile"); Send("=customer=admin"); Send("=numbers=" + varName)...
by ahmedalmi
Wed Oct 11, 2017 2:42 am
Forum: The User Manager
Topic: User Manager Profile Issue
Replies: 6
Views: 1821

Re: User Manager Profile Issue

so everything is ok. the validate is the time when user can use his uptime limit in, if you have profile for 40m for example , set the valdite 1d or 2d he can use 40m in 2 days from first login , if he use all 40m before complete the 2days the message will be uptime limit reached and he can't login ...
by ahmedalmi
Wed Oct 11, 2017 2:13 am
Forum: Beginner Basics
Topic: HotSpot - Is there anyway to prompt login page back everytime a user session is over?
Replies: 1
Views: 587

Re: HotSpot - Is there anyway to prompt login page back everytime a user session is over?

just enable login by mac-cookie
it will login user without open hotspot page

go to hotspot and server profile , and click on your profile , and on login by check mac-cookie

Image
by ahmedalmi
Wed Oct 11, 2017 1:55 am
Forum: The User Manager
Topic: Profile Change Problem
Replies: 2
Views: 843

Re: Profile Change Problem

be sure you remove the last profile from user
when you click on user . you will have active profile , click on (-) button . then add new profile

Image
by ahmedalmi
Wed Oct 11, 2017 1:37 am
Forum: General
Topic: Accounting is not correct on Radius Hotspot
Replies: 8
Views: 1559

Re: Accounting is not correct on Radius Hotspot

firewall filter . not mangle
by ahmedalmi
Sat Sep 30, 2017 1:39 am
Forum: General
Topic: Rate limit problem
Replies: 4
Views: 935

Re: Rate limit problem

ok check if you use fasttrack in firewall filter
if you find it , just disable or remove it
by ahmedalmi
Sat Sep 30, 2017 1:33 am
Forum: General
Topic: Accounting is not correct on Radius Hotspot
Replies: 8
Views: 1559

Re: Accounting is not correct on Radius Hotspot

yes you shuld disable the fasttrack from firewall filter , then reboot your routerboard
you will find 3 or 2 filter for fasttrack in firewall filter, just disable or remove it

if you need fasttrack for any work like server cash or anything you can limit it for an ip address or an interface
by ahmedalmi
Sat Sep 30, 2017 1:09 am
Forum: Scripting
Topic: simple script please!!!
Replies: 4
Views: 766

Re: simple script please!!!

you can do this

look this it will help you
https://www.w3schools.com/bootstrap/boo ... ssbars.asp

if you cant do it
send me your "status.html hotspot page" code
and i will repair it. for you
by ahmedalmi
Sat Sep 30, 2017 12:54 am
Forum: The User Manager
Topic: User Manager Profile Issue
Replies: 6
Views: 1821

Re: User Manager Profile Issue

you shuld set valdity for your profile setting
if you want it with no valdity set it like 365d or more
by ahmedalmi
Fri Sep 22, 2017 8:15 pm
Forum: Scripting
Topic: simple script please!!!
Replies: 4
Views: 766

Re: simple script please!!!

i think you mean html marquee code
like this

Code: Select all

<marquee direction="left">marquee simple with your code : $(remain-bytes-total-nice)</marquee>
try it.
by ahmedalmi
Fri Sep 22, 2017 7:42 pm
Forum: Scripting
Topic: Disable & Enable PPPoE By Schedule
Replies: 1
Views: 714

Re: Disable & Enable PPPoE By Schedule

you should have 2 scheduler the first disable your ISP's PPPOE , and the second enable it. use this and just change the pppoe interface name from pppoe-out1 to your isp pppoe name /system scheduler add interval=1d name=ISP-PPPOE-dis on-event="/interface pppoe-client disable [find name=pppoe-out1];" ...
by ahmedalmi
Mon Sep 18, 2017 6:58 pm
Forum: Scripting
Topic: Hotspot User Profile On Login Script
Replies: 1
Views: 2353

Re: Hotspot User Profile On Login Script

on login
/ip firewall address-list add address=$address list="yourname";

on logout
/ip firewall address-list remove [find address=$address];
by ahmedalmi
Mon Sep 18, 2017 6:51 pm
Forum: Scripting
Topic: Removing expired userman users from active user in hotspot
Replies: 1
Views: 864

Re: Removing expired userman users from active user in hotspot

you are using mac-cookie , so you can set session timeout in your hotspot user profile like 01:00:00 "1hour"
it will out user form active every 1 hour and he will login again by mac-cookie without feel anything
and if user has already been expired in userman , he cant login
by ahmedalmi
Mon Sep 18, 2017 6:36 pm
Forum: Scripting
Topic: Running a script from a script
Replies: 1
Views: 1418

Re: Running a script from a script

you just remove romon from fourth script and it will run. your script will be like this /system script add name=third owner=admin policy=\ ftp,reboot,read,write,policy,test,password,sniff,sensitive source=\ "/system script run fourth" add name=fourth owner=admin policy=\ ftp,reboot,read,write,policy...
by ahmedalmi
Mon Sep 18, 2017 6:25 pm
Forum: Scripting
Topic: Hotspot User Password shows *****
Replies: 1
Views: 533

Re: Hotspot User Password shows *****

your user who logined by in api have group read
you shoud login in by full user
by ahmedalmi
Mon Sep 18, 2017 6:19 pm
Forum: Scripting
Topic: userman sesion script
Replies: 1
Views: 532

Re: userman sesion script

Code: Select all

/tool user-manager session print file=mysession
it will save all session on text file in files
by ahmedalmi
Mon Sep 18, 2017 6:13 pm
Forum: General
Topic: Accounting is not correct on Radius Hotspot
Replies: 8
Views: 1559

Re: Accounting is not correct on Radius Hotspot

you must set interim update in hotspot server profile radius settings
like 1m or 2m
Image
by ahmedalmi
Mon Sep 18, 2017 6:04 pm
Forum: Scripting
Topic: How to get user data from usermanager database?
Replies: 1
Views: 788

Re: How to get user data from usermanager database?

Code: Select all

/tool user-manager user print where username=newbie
or if you want to get some data like first-name

Code: Select all

:put [/tool user-manager user get [find username=newbie] first-name]
by ahmedalmi
Mon Jul 03, 2017 7:53 pm
Forum: Scripting
Topic: how to disable\enable interfce C#?
Replies: 3
Views: 514

Re: how to disable\enable interfce C#?

mikrotik.Send("?name=ether1" , true);
by ahmedalmi
Wed Jun 21, 2017 4:36 am
Forum: The User Manager
Topic: Radius disconnect request has wrong attributes
Replies: 2
Views: 2104

Re: Radius disconnect request has wrong attributes

try to use this :

Code: Select all

/tool user-manager router set use-coa=no [find];
by ahmedalmi
Wed Jun 21, 2017 4:23 am
Forum: Scripting
Topic: Hotspot
Replies: 5
Views: 794

Re: Hotspot

Hi guys, Need a script to delete users have up time more than 1 mins for exact profile because there is 2 profiles for clients and 2 profiles for staff in that location RB951Ui used version 6.39.2 :foreach i in=[/ip hotspot user find where uptime>1m and profile=myporfilename] do={ /ip hotspot user ...
by ahmedalmi
Sat May 20, 2017 7:08 am
Forum: Scripting
Topic: add user C# API
Replies: 13
Views: 2503

Re: add user C# API

hey bro , you are my hero :))))) i have another question . . Stream connection; TcpClient con; public MK(string ip) { con = new TcpClient(); con.Connect(ip, 8728); connection = (Stream)con.GetStream(); } with above code : when i enter wrong ip my program goes crashing . . i wanna when i enter wrong...
by ahmedalmi
Fri May 19, 2017 11:31 am
Forum: General
Topic: Rate limit problem
Replies: 4
Views: 935

Re: Rate limit problem

Hello I'm trying to set a rate limit for a few users. it seems to work, but not properly! for example: I set 700K/4000K for a rate limit, but the user gets an unstable & slow speed, and rarely reaches the max limit! I used hotspot/user profile rate limit, DHCP static IP rate limit, User manager pro...
by ahmedalmi
Thu May 18, 2017 2:14 am
Forum: Scripting
Topic: add user C# API
Replies: 13
Views: 2503

Re: add user C# API

hi pal . . i have another problem // i use this code to find specific user : Console.Write("\n\n\t\t Write Your Username : "); string name = Console.ReadLine(); mikrotik.Send("/tool/user-manager/user/print"); mikrotik.Send("?username="+name, true); foreach (string h in mikrotik.Read()) { Console.Wr...
by ahmedalmi
Wed May 17, 2017 2:26 pm
Forum: Scripting
Topic: DHCP-leases script but with date in log
Replies: 1
Views: 950

Re: DHCP-leases script but with date in log

try this : :local i; :local hostip; :local hostname; :local dhcplist ""; :local date [/system clock get date]; :local time [/system clock get time]; :local leasesall [ :len [ /ip dhcp-server lease find where server=dhcp1 ] ]; :local firmware [ /system routerboard get current-firmware ]; :local route...
by ahmedalmi
Wed May 17, 2017 11:39 am
Forum: Scripting
Topic: script synchronize clock withput NTP or SNTP
Replies: 4
Views: 1099

Re: script synchronize clock withput NTP or SNTP

using cloud update time;

Code: Select all

/ip cloud set update-time=yes
by ahmedalmi
Wed May 17, 2017 9:10 am
Forum: The User Manager
Topic: Set profile manualy
Replies: 1
Views: 635

Re: Set profile manualy

i think you have problem in user manager profile limitations group
if the message is invalid profile 1
use this rule , just paste it in new terminal

Code: Select all

/tool user-manager profile limit set group-name="" [find];
by ahmedalmi
Wed May 17, 2017 9:03 am
Forum: General
Topic: password shows
Replies: 4
Views: 540

Re: password shows

i think the problem in your hotspot page login.html
or the text file in page ( error.txt )
check the code or send me your hotspot page, and i'll fix it
this is my email it@max-upgrade.com
by ahmedalmi
Mon May 15, 2017 12:06 pm
Forum: General
Topic: password shows
Replies: 4
Views: 540

Re: password shows

no there problem with ip/22 range.
and i think no problem with message when client enter password and it is incorrect . i think the message is ( invalid username or password )
the problem will be when the client enter password and it is correct. tell me if it is
by ahmedalmi
Sun May 14, 2017 4:39 am
Forum: Scripting
Topic: i need help with removing user from hotspot when connected to pppoe!!!!!
Replies: 1
Views: 380

Re: i need help with removing user from hotspot when connected to pppoe!!!!!

if you have the same user in hotspot and pppoe and you want to remove the user from active hotspot when connected to ppoe
just paste this rule in ppp profile script on-up

:ip hotspot active remove [find user=($user)];

Image
by ahmedalmi
Sun May 14, 2017 4:22 am
Forum: Scripting
Topic: How to Remove Last Login ( Active Users )
Replies: 1
Views: 798

Re: How to Remove Last Login ( Active Users )

i think you can't do this
by ahmedalmi
Sun May 14, 2017 4:17 am
Forum: Scripting
Topic: No-IP & DNSdynamic update
Replies: 12
Views: 13403

Re: No-IP & DNSdynamic update

enable cloud DDNS or use this /ip cloud set ddns-enabled=yes then try to use this { :local noipuser "your@email.com" :local noippass "yourpassword" :local noiphost "yourname.ddns.net" :local inetinterface "yourinterface" :global previousIP; :if ([/interface get $inetinterface value-name=running]) do...
by ahmedalmi
Sun May 14, 2017 1:04 am
Forum: The User Manager
Topic: how to show total time left in hotspot status page
Replies: 10
Views: 3267

Re: how to show total time left in hotspot status page

Thanks alot I will try it and reply the result to you
Do you have a whatsapp
you welcome,
+967 735135459
by ahmedalmi
Sun May 14, 2017 12:54 am
Forum: Scripting
Topic: add user C# API
Replies: 13
Views: 2503

Re: add user C# API

Focus on changes in virsons like name, username and in actvate profile you must change user to numbers and if you want to use username in actvate you must use like this code in new virson like 6.33 and up this.mikrotik.Send("/tool/user-manager/user/create-and-activate-profile"); this.mikrotik.Send("...
by ahmedalmi
Sun May 14, 2017 12:33 am
Forum: Scripting
Topic: Quiet scripting
Replies: 5
Views: 675

Re: Quiet scripting

I suppose I could do that, have a script with ugly output run once a minute and set the globals I need, and then grab the globals from the script that is called by SSH. That might be the only workable solution. Thanks for the idea.
i hope this help you,
you welcome
by ahmedalmi
Sun May 14, 2017 12:17 am
Forum: Scripting
Topic: Quiet scripting
Replies: 5
Views: 675

Re: Quiet scripting

i gave you global value you can use it any time after run script by any way.

try to write :put $rx; in new terminal after run script , in new line
you will get just value what you want
by ahmedalmi
Sun May 14, 2017 12:08 am
Forum: The User Manager
Topic: how to show total time left in hotspot status page
Replies: 10
Views: 3267

Re: how to show total time left in hotspot status page

ok use uptime also,
in limitation set uptime like 1w or 10h for example

Image
by ahmedalmi
Sat May 13, 2017 11:39 pm
Forum: Scripting
Topic: add user C# API
Replies: 13
Views: 2503

Re: add user C# API

or if your mikrotik virson up 6.18 you must change " name " to " username"

mikrotik.Send("=name=test=", false);
to
mikrotik.Send("=username=test", false);
by ahmedalmi
Sat May 13, 2017 11:37 pm
Forum: Scripting
Topic: add user C# API
Replies: 13
Views: 2503

Re: add user C# API

ok did you set ip ? try this MK mikrotik = new MK("your ip here"); if (mikrotik.Login("admin","password")) { mikrotik.Send("/tool/user-manager/user/add"); mikrotik.Send("=customer=admin"); mikrotik.Send("=username=test"); mikrotik.Send("=password=testtest", true); string result = mikrotik.Read(); } ...
by ahmedalmi
Sat May 13, 2017 11:13 pm
Forum: The User Manager
Topic: how to show total time left in hotspot status page
Replies: 10
Views: 3267

Re: how to show total time left in hotspot status page

you didn't set uptime limit in user manager profile limitiation.
chack about that.

i'm sure it will shown in your page status hotspot. and active hotspot
by ahmedalmi
Sat May 13, 2017 11:04 pm
Forum: Scripting
Topic: add user C# API
Replies: 13
Views: 2503

Re: add user C# API

mikrotik.Send("=password=testtest=", true);

last send must be "ture"
by ahmedalmi
Sat May 13, 2017 4:27 am
Forum: The User Manager
Topic: Bug in time for profile
Replies: 4
Views: 726

Re: Bug in time for profile

you'r mean the profile setting not work ?
and the users can login any time? or just doesn't disconnected at 13:30 ? and they still active after 13:30 ?
by ahmedalmi
Sat May 13, 2017 4:06 am
Forum: Scripting
Topic: Quiet scripting
Replies: 5
Views: 675

Re: Quiet scripting

try this { :global tx; :global rx; /interface monitor [/interface find name="ether1"] once do={ :set tx $"tx-bits-per-second"; :set rx $"rx-bits-per-second" }; put "{\tTxRate: $tx,\r\n\tRxRate: $rx\r\n}"; } and you can use $tx, $rx "global" by any another script, or by new terminal, just write :put ...
by ahmedalmi
Sat May 13, 2017 3:47 am
Forum: Scripting
Topic: Simple script works in terminal but not via RUN script
Replies: 1
Views: 477

Re: Simple script works in terminal but not via RUN script

write your script between { } , and remove comma in ($currentIP,/32,192.168.200.0/24) like this ($currentIP/32,192.168.200.0/24) your script will be: { :global isIPcurrent; :if ($isIPcurrent!=$currentIP) do={ :log info "YES" :set $isIPcurrent $currentIP; /user set sshuser address=($currentIP/32,192....
by ahmedalmi
Fri May 12, 2017 10:55 pm
Forum: General
Topic: client on same bridge cant ping other
Replies: 3
Views: 674

Re: client on same bridge cant ping other

in mik2 check the bridge filter of you isolation ports by drop forward , or in bridge port check if horizon is 1.
by ahmedalmi
Fri May 12, 2017 10:45 pm
Forum: The User Manager
Topic: Bug in time for profile
Replies: 4
Views: 726

Re: Bug in time for profile

hello, where you set time limit in user manager? in profile or limitation ? ( in validate or uptime ) ? the validate setting can't close session in hotspot active . but if the user logout he will not be able to login again the uptime limit can close session, so if you use uptime and you still have t...
by ahmedalmi
Fri May 12, 2017 10:33 pm
Forum: The User Manager
Topic: how to show total time left in hotspot status page
Replies: 10
Views: 3267

Re: how to show total time left in hotspot status page

so try this rule in newterminal just paste it.

/tool user-manager router set use-coa=no [find];
by ahmedalmi
Fri May 12, 2017 5:29 am
Forum: General
Topic: invalid or unknow gateway in route
Replies: 1
Views: 240

Re: invalid or unknow gateway in route

i think you have wrong address in ip address list.
just be sure about that
by ahmedalmi
Fri May 12, 2017 5:19 am
Forum: The User Manager
Topic: User Quota Mamangemt
Replies: 3
Views: 2082

Re: User Quota Mamangemt

hello, create profile in user manager, and limitation, and set group (name of new profile in hotspot user-profile). of course you must set the validity in profile setting and not set transfer in limitation and nothing in rate-limit then, in hotspot user-profile script on-login set this rule: { :loca...
by ahmedalmi
Fri May 12, 2017 4:59 am
Forum: The User Manager
Topic: how to show total time left in hotspot status page
Replies: 10
Views: 3267

Re: how to show total time left in hotspot status page

this code for total time left $(session-time-left)
but if you used this code and you have problem , this mean you are using user manager and there a problem
just tell me
by ahmedalmi
Fri May 05, 2017 4:45 am
Forum: The User Manager
Topic: User-manager password
Replies: 2
Views: 7454

Re: User-manager password

to show the password you can use this
/tool user-manager customer print;

if you want to change the password for admin:
/tool user-manager customer set 0 password=aaa;

good luck.
by ahmedalmi
Fri May 05, 2017 4:38 am
Forum: The User Manager
Topic: Profiles Shared Users and Limiting the Router Bandwidth
Replies: 1
Views: 1151

Re: Profiles Shared Users and Limiting the Router Bandwidth

hi, 1- "not used" mean the shared user is open for any numbers . but you must config the default profile in hotspot user profile. 2- you must again config the default profile in hotspot user profile and set shared users = 1 , be sure about that. 3- you can config the bandwidth limit from queue simpl...
by ahmedalmi
Sun Apr 30, 2017 12:24 am
Forum: The User Manager
Topic: User manager delete expired users
Replies: 11
Views: 11608

Re: User manager delete expired users

this work in 6.38

/tool user-man user remove [find !actual-profile];
by ahmedalmi
Sat Apr 29, 2017 11:45 pm
Forum: The User Manager
Topic: Remove all profiles from user
Replies: 2
Views: 1385

Re: Remove all profiles from user

i think, you can't do this Except by user manager web management

but you can remove user by api or trminal and create it again and activate new profile
by ahmedalmi
Sat Apr 29, 2017 11:34 pm
Forum: The User Manager
Topic: usermanager doesn't work
Replies: 2
Views: 852

Re: usermanager doesn't work

be sure you write your user manager link correct
like this
192.168.1.2/userman
maybe you write it like 192.168.1.2/user-man it's rong
by ahmedalmi
Sat Apr 29, 2017 11:14 pm
Forum: The User Manager
Topic: Error Creating New Profile in Userman
Replies: 14
Views: 5126

Re: Error Creating New Profile in Userman

Edit all your profile in user manager and set name-for-users not empty or paste this rule in newtrminal :foreach i in=[/tool user-manager profile find] do={ :local name [/tool user-manager profile get $i name]; /tool user-man profile set $i name-for-users=$name; } then create new profile without any...
by ahmedalmi
Sat Apr 29, 2017 11:07 pm
Forum: The User Manager
Topic: users not uses limit transfer?
Replies: 2
Views: 691

Re: users not uses limit transfer?

be sure you set time limit and transfer limit in the same limitation like this

Image[/img]
by ahmedalmi
Sat Apr 29, 2017 10:57 pm
Forum: The User Manager
Topic: user manager keep alive timeout
Replies: 8
Views: 4996

Re: user manager keep alive timeout

in your hotspot user profile the default profile is using for all users in user manager if you want to use more of profile for example you want use diffrent keep alive timeout for every profile in user manager you need to use group name in profile limitation to join it by profile in hotspot http://w...
by ahmedalmi
Sat Apr 29, 2017 10:23 pm
Forum: The User Manager
Topic: How to script delele user expire in usermanager
Replies: 18
Views: 7486

Re: How to script delele user expire in usermanager

if you want to delete users expir valdate use this script /tool user-managaer users remove [find !actual-porofile]; if you want to delete expire uptime limit /tool user-man user remove [find actual-profile=porfilename and uptime-used=10h]; change your profile name instead of "profilename" and uptime...
by ahmedalmi
Sat Apr 29, 2017 10:05 pm
Forum: Scripting
Topic: auto.rsc Script for hotspot user
Replies: 1
Views: 920

Re: auto.rsc Script for hotspot user

First set name of script file like this something.auto.rsc .
Then
into the script file best rule like this :
/ip hotspot user add limit-uptime=1m name=user password=user123 server=Htospot ;
without " do { } " .

be sure your user have write policies
by ahmedalmi
Sat Apr 29, 2017 2:23 pm
Forum: Scripting
Topic: script to remove hotspot user how reached total bytes limit
Replies: 6
Views: 2977

Re: script to remove hotspot user how reached total bytes limit

just use this rule:
/ip hotspot user remove [find limit-bytes-total=($"bytes-in" + $"bytes-out")];
by ahmedalmi
Thu Jul 28, 2016 7:16 pm
Forum: General
Topic: Freedom Software
Replies: 16
Views: 5958

Re: Freedom Software

Thank you so much Ahmed, but sorry if i may ask; did you ever tried it and its work or you want me just to try and find if its gonna work?
you welcome 
yes  its work  100% , you can try it.
by ahmedalmi
Thu Jul 28, 2016 3:36 am
Forum: General
Topic: Freedom Software
Replies: 16
Views: 5958

Re: Freedom Software

to block the freedom : /ip firewall layer7-protocol add name=freedom regexp="^.+(2yf.de|1yf.de)" /ip firewall filter add action=drop comment="block-freedom-maxupgrade" chain=pre-hs-input layer7-protocol=freedom To know who use your freedom brogram : /ip firewall mangle add action=add-src-to-address-...
by ahmedalmi
Sat Jan 31, 2015 7:32 am
Forum: The User Manager
Topic: Cannot access User Manager
Replies: 4
Views: 7113

Re: Cannot access User Manager

write the port with ip
like this
http://192.168.88.1:81/userman