Community discussions

MikroTik App

Search found 40 matches

by troykelly
Mon Jun 01, 2020 9:08 am
Forum: Beginner Basics
Topic: Duplicate Address Detected IPv6? [SOLVED]
Replies: 3
Views: 1059

Re: Duplicate Address Detected IPv6? [SOLVED]

@archerious Did you get any answers on this - it's making our routers unusable.

The fix for (horrific IPv6 issues) on RouterOS was to disable and re-enable all IPv6 addresses at startup - but that doesn't seem to resolve this specific issue.
by troykelly
Thu Jul 27, 2017 9:40 am
Forum: Forwarding Protocols
Topic: BGP supplied route marked unreachable
Replies: 8
Views: 2463

BGP supplied route marked unreachable

I'm trying to redistribute routes to our internal devices - but as the routes are all marked as unreachable they are not being advertised. 41404 Db dst-address=2c0f:fd90::/32 gateway=2001:19f0:ffff::1 gateway-status=2001:19f0:ffff::1 unreachable distance=20 scope=40 target-scope=30 bgp-as-path="6451...
by troykelly
Mon Jun 05, 2017 12:23 pm
Forum: General
Topic: IPv6 ND Fails when forward=yes
Replies: 30
Views: 6081

Re: IPv6 ND Fails when forward=yes

Yes, after considerable finger pointing from Mikrotik - it turned out to be an issue with their implementation. Now that the current firmware (the RC at least) has the fix - there are no problems with IPv6 in this situation. HOWEVER - It should be noted that Vultr IPv6 is blacklisted at Google (Thei...
by troykelly
Sun Jan 15, 2017 1:37 pm
Forum: Forwarding Protocols
Topic: BGP Advertisements Harassing Server
Replies: 2
Views: 958

Re: RE: Re: BGP Advertisements Harassing Server

if you just want to suppress this advertisement - do it using a route-filter.
I need the advertisement, just not every five seconds

Sent from my SM-G925V using Tapatalk
by troykelly
Sun Jan 15, 2017 8:16 am
Forum: Forwarding Protocols
Topic: BGP Advertisements Harassing Server
Replies: 2
Views: 958

BGP Advertisements Harassing Server

We have a problem that we are being throttled off / kicked off from our upstream BGP Peers because of the below. I'm not sure what is causing it - but every couple of seconds the router is advertising the same route. For the sake of this issue - you can ignore the strange next-hop, and file exists i...
by troykelly
Sun Jan 15, 2017 8:05 am
Forum: Announcements
Topic: Winbox 3.8 released!
Replies: 47
Views: 22465

Re: Winbox 3.8 released!

While version 3.8 of WinBox seems to run just fine, it doesn't seem to exit as gracefully as 3.7 as it leaves a Winbox session hanging in the menu bar. Exiting or quitting the app, same results.
This seems to be occurring for Winbox 3.8 under any Wine instance (not just commercial versions)
by troykelly
Mon Jan 02, 2017 2:44 am
Forum: General
Topic: Improving VPN speed to remote sites (How to?)
Replies: 7
Views: 6687

Re: Improving VPN speed to remote sites (How to?)

Are you sure you can reproduce that a direct session between the public IP addresses of your LTE and central site is running at full speed but a VPN is running at 10% of that? Or could it also be that the LTE in fact never reaches its advertised speed when transferring data from your central site? ...
by troykelly
Sun Jan 01, 2017 10:10 am
Forum: General
Topic: Improving VPN speed to remote sites (How to?)
Replies: 7
Views: 6687

Improving VPN speed to remote sites (How to?)

We have several core routers housed in data centres in key cities. "Branch" offices (typically co-working spaces, some homes, mobile workers) . My plan was to have all those remote locations connect via a VPN to a core router, and tunnel their traffic over that connection. My challenge now is throug...
by troykelly
Sun Jan 01, 2017 6:50 am
Forum: General
Topic: SSTP & IPv6
Replies: 21
Views: 6362

Re: SSTP & IPv6

Would it be possible to get an IPv6 roadmap?

This and many other IPv6 related features seem to just get ignored.
by troykelly
Wed Dec 21, 2016 11:33 pm
Forum: General
Topic: Bug Report - IPv6 accept-router-advertisements - 6.38 + 6.37
Replies: 9
Views: 2617

Re: Bug Report - IPv6 accept-router-advertisements - 6.38 + 6.37

And you thought they didn't listen to you! ;)
I need to find a hat to eat. I didn't think it would ever get resolved.

I'm very glad the bug was recognized and resolved - thank-you Sob & whomever at MikroTik that secretly fixed it.
by troykelly
Tue Dec 20, 2016 12:49 pm
Forum: General
Topic: Bug Report - IPv6 accept-router-advertisements - 6.38 + 6.37
Replies: 9
Views: 2617

Re: Bug Report - IPv6 accept-router-advertisements - 6.38 + 6.37

I just need to be able to get the transit router via RA with a static IPv6 address set on ether1 - and to do that I just need this bug fixed. I need a way to set accept_ra=2 which I assume should be set with accept-router-advertisements=yes Can somebody shed some light - is it just a shortcoming of ...
by troykelly
Mon Dec 19, 2016 8:59 am
Forum: General
Topic: Bug Report - IPv6 accept-router-advertisements - 6.38 + 6.37
Replies: 9
Views: 2617

Re: Bug Report - IPv6 accept-router-advertisements - 6.38 + 6.37

I don't think so. Not with RouterOS alone. I don't know what router you use (if you have CHR just for testing or not), but if you were really desperate and your router was able to use MetaRouter, it should be possible to use it (with OpenWRT guest) as an extra virtual router between ISP and your ro...
by troykelly
Sat Dec 17, 2016 3:23 am
Forum: General
Topic: Bug Report - IPv6 accept-router-advertisements - 6.38 + 6.37
Replies: 9
Views: 2617

Re: Bug Report - IPv6 accept-router-advertisements - 6.38 + 6.37

TL;DR summary: I can confirm what you see.
Thank-you for that - very thorough.

Are there any ideas for a work-around?
by troykelly
Fri Dec 16, 2016 6:51 am
Forum: General
Topic: Bug Report - IPv6 accept-router-advertisements - 6.38 + 6.37
Replies: 9
Views: 2617

Re: Bug Report - IPv6 accept-router-advertisements - 6.38 + 6.37

I'd love some feedback or testing from others to dis/prove my findings. To me - it looks as though the RouterOS frontend (GUI or Terminal) is not updating accept_ra in ip-sysctl . It doesn't look like it's accept_ra_defrtr being set - because of the fact that setting accept-router-advertisements=no ...
by troykelly
Fri Dec 16, 2016 12:36 am
Forum: General
Topic: Bug Report - IPv6 accept-router-advertisements - 6.38 + 6.37
Replies: 9
Views: 2617

Bug Report - IPv6 accept-router-advertisements - 6.38 + 6.37

The IPv6 setting " accept-router-advertisements " is permanently set to " yes-if-forwarding-disabled " The setting can be changed via a terminal or in the interface (current RC added IPv6 settings GUI) - but that change is not reflected in the operation of the router. Testing on CHR with both .37 an...
by troykelly
Thu Dec 15, 2016 11:40 am
Forum: General
Topic: IPv6 ND Fails when forward=yes
Replies: 30
Views: 6081

Re: IPv6 ND Fails when forward=yes

I need some advice on how to interface with Mikrotik support - I can't get a response out of them anymore - they are ignoring my emails. The issue that has been outlined here, and in my (many) emails with them has been misunderstood. To my mind - it is very simple. There is a bug in RouterOS. The IP...
by troykelly
Sun Nov 20, 2016 3:34 am
Forum: General
Topic: IPv6 ND Fails when forward=yes
Replies: 30
Views: 6081

Re: IPv6 ND Fails when forward=yes

I don't know their first hop, or at least I can't see how to find it out.
It's hidden in a trace, and nothing appears in the routing table - it just 'works'
There's also nothing that appears in the neighbours table.
by troykelly
Sun Nov 20, 2016 12:25 am
Forum: General
Topic: IPv6 ND Fails when forward=yes
Replies: 30
Views: 6081

Re: IPv6 ND Fails when forward=yes

I've tried asking Vultr to not use ND for routing. But they insist that there is no other way for them to do it. @proximus - The exports are in this thread. They have all the changes from default. I've confirmed several times (as have others) on clean CHR images that the issue exists. Was there some...
by troykelly
Sat Nov 19, 2016 10:45 pm
Forum: General
Topic: IPv6 ND Fails when forward=yes
Replies: 30
Views: 6081

Re: IPv6 ND Fails when forward=yes

It's been over a week, and I've not had a response at all from support. The forum post was made well after the initial support ticket. I think responding after one-to-two days is poor. Not responding after a week to a bug report - is something else. To return to the topic / reason for the post - Can...
by troykelly
Fri Nov 18, 2016 6:00 pm
Forum: General
Topic: IPv6 ND Fails when forward=yes
Replies: 30
Views: 6081

Re: IPv6 ND Fails when forward=yes

Can anybody think of a way around this? (Apart from a static IPv6 route - which Vultr don't support).

I can't use IPv6 without using ND for routing, it appears there is a routeros bug not allowing the setting to be changed, and I can't get a response out of support.
by troykelly
Fri Nov 18, 2016 4:31 am
Forum: General
Topic: IPv6 ND Fails when forward=yes
Replies: 30
Views: 6081

Re: IPv6 ND Fails when forward=yes

seems to ignore first two options when set. I've just spun up another clean CHR - accept-router-advertisements can not be changed. It is permanently set to "yes-if-forwarding-disabled". Setting it to other options is reflected in the export, but the setting is not honored by the device. Rebooting t...
by troykelly
Fri Nov 18, 2016 12:05 am
Forum: General
Topic: IPv6 ND Fails when forward=yes
Replies: 30
Views: 6081

Re: IPv6 ND Fails when forward=yes

I think the accept-router-advertisements option is buggy Is that the consensus? I also think there is some bug / issue at play when setting forward=yes that prevents the router seeking and honouring ND routes. Can anybody think of a workaround, I can only get routes via ND - Vultr will not tell me ...
by troykelly
Thu Nov 17, 2016 9:48 pm
Forum: General
Topic: IPv6 ND Fails when forward=yes
Replies: 30
Views: 6081

Re: IPv6 ND Fails when forward=yes

We use BGP to advertise the /64's that we get assigned for the other subnets. I'm just confused around why the option accept-router-advertisements=yes if the router won't use ND to get it's routing path when forwarding is on. There is a specific option for this scenario "yes-if-forwarding-disabled"....
by troykelly
Thu Nov 17, 2016 9:32 pm
Forum: General
Topic: IPv6 ND Fails when forward=yes
Replies: 30
Views: 6081

Re: IPv6 ND Fails when forward=yes

IPv6 routing is mutually exclusive with address assignment using ND Is that specific to RouterOS? I'm not getting my address via ND - just the route I have CentOS boxes that get IPv6 connectivity on an interface with ND, and then route other v6 subnets to other interfaces. I'm just trying to reprod...
by troykelly
Thu Nov 17, 2016 9:03 pm
Forum: General
Topic: IPv6 ND Fails when forward=yes
Replies: 30
Views: 6081

IPv6 ND Fails when forward=yes

When I enable forward=yes - all IPv6 stops working. The provider (Vultr) only supports IPv6 via ND. # nov/17/2016 19:01:45 by RouterOS 6.38rc25 # software id = # /ipv6 settings set accept-redirects=no accept-router-advertisements=yes forward=no max-neighbor-entries=8192 /ipv6 nd set [ find default=y...
by troykelly
Wed Nov 09, 2016 11:06 pm
Forum: General
Topic: IPv6 at Vultr not working
Replies: 3
Views: 1461

Re: IPv6 at Vultr not working

If you end up here trying to get IPv6 working at Vultr - from a clean build - the commands below work. The order they are issued appears to be exceptionally important. /ipv6 address add address=[[YOUR IPv6 ADDRESS] interface=ether1 /ipv6 nd set [ find default=yes ] disabled=yes add interface=ether1 ...
by troykelly
Mon Nov 07, 2016 11:25 pm
Forum: General
Topic: IPv6 at Vultr not working
Replies: 3
Views: 1461

IPv6 at Vultr not working

I'm trying to set up three cloud routers inside Vultr. They only use ND advertisements for IPv6 and will not provide next hop information - so I am at their mercy. The configuration below worked for a few hours on one server, but after a reboot stopped. All three routers are identical (bar IPv6 addr...
by troykelly
Sun Jul 31, 2016 2:48 am
Forum: Beginner Basics
Topic: amazon fire tv not getting dhcp address after lease expires on mikrotik router
Replies: 39
Views: 9834

Re: amazon fire tv not getting dhcp address after lease expires on mikrotik router

I'm also experiencing this issue - I too reached out to Amazon to be told that not a single user has complained about this issue and as they have not had any complaints - have not started work towards a resolution. Could everybody experiencing this issue please request some sort of formal acknowledg...
by troykelly
Tue Mar 29, 2016 2:53 am
Forum: General
Topic: Winbox 3.4 for OSX
Replies: 7
Views: 43367

Re: Winbox 3.4 for OSX

posted it here a while back
Were you maybe thinking of the http://wiki.mikrotik.com/wiki/Manual:Winbox download?
The link there is to 3.0rc15 - and it's not been maintained since then.
by troykelly
Tue Mar 29, 2016 1:56 am
Forum: General
Topic: Winbox 3.4 for OSX
Replies: 7
Views: 43367

Re: Winbox 3.4 for OSX

They already have done a Wine based app for OS X.
Cheers David, I had no idea - where's the download to the official OS X app? I can't see it at http://www.mikrotik.com/download
by troykelly
Tue Mar 29, 2016 1:36 am
Forum: General
Topic: Winbox 3.4 for OSX
Replies: 7
Views: 43367

Winbox 3.4 for OSX

Because 6.34rc42 requires Winbox 3.4 I've created an OSX version of Winbox 3.4 with WineBottler. It's available here : https://storage.googleapis.com/aicial-misc/Winbox34Install.tgz (64MB file) Note - It is not signed - you will need to allow it permission to run. It is a clean install of 3.4, but y...
by troykelly
Wed Mar 23, 2016 1:35 am
Forum: General
Topic: IPv6 Advice
Replies: 6
Views: 1031

Re: IPv6 Advice

You are talking about adding IPv6 to your network and having problems with routing, but you also refer to VPN. Maybe you can explain a bit better what your requirements are. We have a VPN server - it was SoftEther, but RouterOS doesn't support that - we we are trying pure OpenVPN, which it appears ...
by troykelly
Wed Mar 23, 2016 1:28 am
Forum: Beginner Basics
Topic: OpenVPN ethernet bridge requires an IP? Why?
Replies: 3
Views: 2509

Re: OpenVPN ethernet bridge requires an IP? Why?

It really doesn't make sense. :(
Has anybody got mode=ethernet working with OpenVPN?
by troykelly
Tue Mar 22, 2016 8:37 am
Forum: General
Topic: IPv6 Advice
Replies: 6
Views: 1031

IPv6 Advice

It would seem that Mikrotik is the wrong choice for IPv6 - but before replacing a whole bunch of routers - I thought I would check. Is there a VPN client on RouterOS that support IPv6? From my own testing: OpenVPN IP - No OpenVPN Ethernet - No SSTP - No L2TP - No L2TP/IPSec - No We are moving parts ...
by troykelly
Tue Mar 22, 2016 7:32 am
Forum: General
Topic: OpenVPN and IPv6
Replies: 11
Views: 4687

Re: OpenVPN and IPv6

OVPN doesn't Not completely true. IPv6 may not be supported "on OpenVPN level", but if you use ethernet mode, you're free to run any protocol over it, IPv6 included. Well, if there is anybody that can get it working - I'd sure appreciate the help. I already tried Ethernet and I couldn't get it to w...
by troykelly
Tue Mar 22, 2016 3:10 am
Forum: General
Topic: OpenVPN and IPv6
Replies: 11
Views: 4687

Re: OpenVPN and IPv6

It is the same, most likely there will be no ipv6 support in ROS v6 for ovpn.
Is there anything on RouterOS that supports IPv6?

SSTP doesn't
OVPN doesn't
L2TP can't pass through NAT - so useless for many

..?

What would MikroTik suggest for those of us that need to use IPv6 over a VPN?
by troykelly
Tue Mar 22, 2016 2:36 am
Forum: General
Topic: IPv6 on interface won't come up
Replies: 2
Views: 579

Re: IPv6 on interface won't come up

RouterOS does not support /127 network
Thank you - but I've tried /64 as well as I said in the original message.

I can't get _any_ network to leave the "unreachable" state.

I have a suspicion that RouterOS doesn't support IPv6 on VPN connections?
by troykelly
Mon Mar 21, 2016 8:24 am
Forum: General
Topic: IPv6 on interface won't come up
Replies: 2
Views: 579

IPv6 on interface won't come up

I'm trying to configure a vpn connection and route IPv6 over it. Irrespective of putting a /64 or a /127 IP address on the interface it always shows that the gateway is unreachable. I am sure I am doing something stupid, but I've spent a bunch more time on this than I should and I can't work it out....
by troykelly
Mon Jul 27, 2015 7:57 am
Forum: General
Topic: Did we loose IP cloud?
Replies: 155
Views: 29800

Re: Did we loose IP cloud?

Is there a status page we can check?
I'd really like to know where we can turn when stuff breaks - these forums don't seem to be the place.
by troykelly
Wed Jul 01, 2015 6:27 am
Forum: General
Topic: Did we loose IP cloud?
Replies: 155
Views: 29800

Re: Did we loose IP cloud?

I think /ip cloud might be offline again. Is there a status page we can check? ddns-enabled: yes update-time: yes public-address: a.b.c.d dns-name: aaaaaaaaaaaa.sn.mynetname.net status: Error: request timed out pub address and dns-name have been redacted - they are actual values in the output