Community discussions

Search found 283 matches

by PaulsMT
Fri Mar 15, 2019 9:48 am
Forum: SwOS
Topic: CRS328-24P-4S+RM forced POE missing voltage option defaults to 24V, 48V not selectable
Replies: 4
Views: 1535

Re: CRS328-24P-4S+RM forced POE missing voltage option defaults to 24V, 48V not selectable

CRS328-24P-4S+RM have had voltage set option from almost the beginning of production.

Voltage set option is useful in cases, when PD support high voltage passive power source, but does not support IEEE 802.3at/af.
https://wiki.mikrotik.com/wiki/Manual:P ... t_Settings
by PaulsMT
Tue Jun 19, 2018 4:36 pm
Forum: Announcements
Topic: v6.43rc [release candidate] is released!
Replies: 557
Views: 113454

Re: v6.43rc [release candidate] is released!

Version 6.43rc32 has been released. *) dude - fixed client auto upgrade (broken since 6.43rc17); still need to upgrade dude client manually. Client crashes after each upgrade via client ui Thank you for a report, but can you please confirm that your Dude client (executed with the administrator righ...
by PaulsMT
Tue May 08, 2018 5:39 pm
Forum: RouterBOARD hardware
Topic: Powerbox Pro Grounding
Replies: 6
Views: 1309

Re: Powerbox Pro Grounding

Hello, sorry for my English. Could someone please tell me what would be the correct way to ground the connected equipment in a Powerbox Pro using the outgoing POE function? The housing has a connector apparently for that purpose, but it is not attached to anything, just threads in the plastic. Rega...
by PaulsMT
Tue May 08, 2018 5:20 pm
Forum: RouterBOARD hardware
Topic: Can cAP ac and hEX PoE power Hikvision cameras ?
Replies: 5
Views: 1763

Re: Can cAP ac and hEX PoE power Hikvision cameras ?

Since mentioned cameras support PoE (802.3af Class3), you should be able to power them from hEX PoE using a 48-57V power adapter: https://mikrotik.com/product/RB960PGS Since cAP AC supports Passive PoE-Out up to 57 V, you can try to power cameras, it might work. more information about high voltage p...
by PaulsMT
Mon May 07, 2018 9:59 am
Forum: RouterBOARD hardware
Topic: CRS328-24P-4S+RM - 24x7 fans or temperature sensitive?
Replies: 64
Views: 9249

Re: CRS328-24P-4S+RM - 24x7 fans or temperature sensitive?

FANs speed depends from the PoE load, so in your case, if a very little PoE load will be used, you will hardly hear the FANs. About the SwOS - The FAN control is set to spin at least with middle speed, so it just not as advanced as in the RouterOS, but we plan to add the same FAN speed control to ne...
by PaulsMT
Wed Apr 04, 2018 8:41 am
Forum: RouterBOARD hardware
Topic: WAP R burn out?
Replies: 6
Views: 938

Re: WAP R burn out?

Got my WAP LTE kit today. both has loose heatsink. Luckily I inspected mine before powering it up. the heatsink is rubbing against solder, parts and antenna. pretty sure it will cause overheating or short. We haven't seen similar reports, can you please send us the serial numbers of these units to ...
by PaulsMT
Thu Mar 22, 2018 1:10 pm
Forum: Announcements
Topic: v6.42rc [release candidate] is released!
Replies: 538
Views: 97329

Re: v6.42rc [release candidate] is released!

atlanticd - Yes, that is the fix for the problem. Please test it and report back to us with the results. Hi strods, I can confirm that the RouterBOOT firmware upgrade to 6.42rc46 works, and it is not causing boot loop anymore. However I noticed that after firmware upgrade (and only after Firmware u...
by PaulsMT
Tue Mar 20, 2018 12:10 pm
Forum: Beginner Basics
Topic: CRS112-8P-4S-IN - PoE Problem
Replies: 8
Views: 1566

Re: CRS112-8P-4S-IN - PoE Problem

Both standards have their pros and cons and affect only non-standard PD which support only one of these modes. If PSE supports only mode B (non-standard mode-A PD will not receive power) If PSE supports only mode A (non-standard mode-B PD will not receive power) In the same way, by using another ven...
by PaulsMT
Mon Mar 19, 2018 1:21 pm
Forum: Beginner Basics
Topic: CRS112-8P-4S-IN - PoE Problem
Replies: 8
Views: 1566

Re: CRS112-8P-4S-IN - PoE Problem

Please note that CRS112-8P-4S-IN uses af/at mode B standard, passing PoE over 4,5 (+) and 7,8 (-) pins https://mikrotik.com/product/crs112_8p_4s_in However in this case it seems that Doorbird is not fully compatible with the standard, because: PDs that implement only Mode A or Mode B are specificall...
by PaulsMT
Thu Jan 18, 2018 11:41 am
Forum: Scripting
Topic: How to open a url using script?
Replies: 3
Views: 3786

Re: How to open a url using script?

If you want to do this FROM the RouterOS, then you can use fetch to send a simple GET request to the specified web page: /tool fetch url="www.domain.com/url.php?id=2" keep-result=no More about the fetch command: https://wiki.mikrotik.com/wiki/Manual:Tools/Fetch Similar example based no HTTP GET requ...
by PaulsMT
Thu Nov 23, 2017 6:15 pm
Forum: Scripting
Topic: Some help with script [SOLVED]
Replies: 2
Views: 357

Re: Some help with script [SOLVED]

hello everybody i need some help i have mikrotik and 75 radio vendor "ubnt" i want get just identity from /ip neighbor and use command "put" in terminal to show the radios as list with just identity name and here is my code { :local identity [/ip neighbor get value-name=identity number=[/ip neighbo...
by PaulsMT
Thu Nov 23, 2017 3:26 pm
Forum: RouterBOARD hardware
Topic: mAP and wAP 48v DC Jack 8-57v - FALSE
Replies: 2
Views: 570

Re: mAP and wAP 48v DC Jack 8-57v - FALSE

Ok so the problem here is that mAP and wAP products state that they can go up to 57v from DC-in Jack. This is false advertising as we have attempted to feed proper conditioned positive 54v from a meanwell power supply that effectively burned both mAP and wAP that we have tested. We have also tested...
by PaulsMT
Fri Sep 15, 2017 9:40 am
Forum: Scripting
Topic: Get pppoe in interface
Replies: 4
Views: 913

Re: Get pppoe in interface

You can use PPPoE server monitor command to see this value in CLI:
/interface pppoe-server monitor <pppoe-user> once do={:put $"interface"}

And store it in the global variable
/interface pppoe-server monitor <pppoe-user> once do={:global i $"interface"}
by PaulsMT
Thu Sep 14, 2017 4:39 pm
Forum: Scripting
Topic: Stop a running background /tool fetch
Replies: 2
Views: 1038

Re: Stop a running background /tool fetch

First of all I would suggest to use tools which are specially designed for traffic testing: Bandwidth Test: https://wiki.mikrotik.com/wiki/Manual:Tools/Bandwidth_Test Traffic Generator: https://wiki.mikrotik.com/wiki/Manual:Performance_Testing_with_Traffic_Generator If you still want to use describe...
by PaulsMT
Mon Sep 04, 2017 1:06 pm
Forum: RouterBOARD hardware
Topic: Mikrotik RB951ui-2hnd red led in port 5
Replies: 1
Views: 1019

Re: Mikrotik RB951ui-2hnd red led in port 5

By default you should see red LED only if the PoE-Out is set on forced-on or powering interface on auto mode.

If the LED lights without both two mentioned states, upgrade your RouterOS to the latest RC version, to see the PoE status in the logs.
by PaulsMT
Mon Sep 04, 2017 12:39 pm
Forum: RouterBOARD hardware
Topic: Port flapping PowerBox RB 750P r2
Replies: 19
Views: 2402

Re: Port flapping PowerBox RB 750P r2

There is not confirmed hardware problems related with the PoE-Out on these devices. PoE out status is dependent on multiple factors, for example, the voltage drop on the wires which powers your PowerBox, and the voltage drop in the wires that goes to the powered devices, both will cause current flow...
by PaulsMT
Thu Aug 31, 2017 12:38 pm
Forum: Scripting
Topic: Tracking MAC-Address / Interface Pairs
Replies: 2
Views: 921

Re: Tracking MAC-Address / Interface Pairs

I'm not sure if the following is possible, I certainly have failed to make it work with my limited scripting knowledge, and was hoping someone can point me in the right direction or tell me it's not feasible. I'd like to track MAC-Address to port's for reference, and to avoid manual lookup when nee...
by PaulsMT
Thu Aug 31, 2017 10:19 am
Forum: Scripting
Topic: Read info from log [SOLVED]
Replies: 4
Views: 1724

Re: Read info from log [SOLVED]

Hello, I need some script to read info from System Log and sent to value and use to other scripts. I need to read this parameters: RSSI and HCSQ. For example: /log get... not work. Maybe other solution? Thanks https://image.ibb.co/h5oiRk/gsm.png :foreach log in=[log print where message~"RSSI"] do={...
by PaulsMT
Wed Aug 09, 2017 4:04 pm
Forum: RouterBOARD hardware
Topic: RB750Gr3 (hEX r3) protected routerboot trouble
Replies: 10
Views: 5293

Re: RB750Gr3 (hEX r3) protected routerboot trouble

Thank you very much for reporting, we found that there might be some "protected routerboot" issues on RB750Gr3 (hEX r3), and only on some specific backup booter versions. If you have any related problems, please write to support@mikrotik.com Updated bakup BIOS for RB750Gr3 (hEX r3) can be found her...
by PaulsMT
Wed Aug 09, 2017 1:47 pm
Forum: RouterBOARD hardware
Topic: RB750Gr3 (hEX r3) protected routerboot trouble
Replies: 10
Views: 5293

Re: RB750Gr3 (hEX r3) protected routerboot trouble

Thank you very much for reporting, we found that there might be some "protected routerboot" issues on RB750Gr3 (hEX r3), and only on some specific backup booter versions. If you have any related problems, please write to support@mikrotik.com Updated bakup BIOS for RB750Gr3 (hEX r3) can be found here...
by PaulsMT
Wed Feb 22, 2017 11:58 am
Forum: Announcements
Topic: The Dude, v6.38 [current] release.
Replies: 77
Views: 23806

Re: The Dude, v6.38 [current] release.

New current version have been released. Changes in v6.38.3: *) Fixed - winbox/webfig ping probe used retry interval in retry count field. *) Fixed - wireless registration table didn't show values in all fields. *) Fixed - Device tree notification system were not working properly. *) Fixed - Client s...
by PaulsMT
Wed Jan 25, 2017 1:14 pm
Forum: The Dude
Topic: Charts in Panels
Replies: 4
Views: 776

Re: Charts in Panels

What version of Dude are you using ? Please test with the latest version.
by PaulsMT
Wed Jan 25, 2017 10:43 am
Forum: Announcements
Topic: The Dude, v6.39rc test builds.
Replies: 121
Views: 28562

Re: The Dude, v6.39rc test builds.

Quick tests didn't show problems. Make sure that you are dividing only integers.
by PaulsMT
Wed Jan 25, 2017 10:36 am
Forum: The Dude
Topic: ping problem from Dude with READ group
Replies: 2
Views: 554

Re: ping problem from Dude with READ group

Hello.
What policies i need to set for ping from Dude?
Group full make it.
Thank you.
Try with enabled test policy
by PaulsMT
Wed Jan 25, 2017 10:13 am
Forum: Announcements
Topic: The Dude, v6.39rc test builds.
Replies: 121
Views: 28562

Re: The Dude, v6.39rc test builds.

Changes in v6.39rc17: *) Fixed - wireless registration table didn't show values in all fields. *) Fixed - Device tree notification system were not working properly. *) Fixed - Client started from shortcut with added arguments tried to use 2210/2211 ports joanllopart - at the moment I can only sugges...
by PaulsMT
Tue Jan 24, 2017 10:01 am
Forum: The Dude
Topic: Add mib file failed
Replies: 5
Views: 1415

Re: Add mib file failed

Use only "(data-path)/files/" directory. All other directories have read only permissions
http://wiki.mikrotik.com/wiki/Manual:The_Dude_v6/Files
by PaulsMT
Mon Jan 23, 2017 6:02 pm
Forum: The Dude
Topic: How to set Default Network Map for Users?
Replies: 2
Views: 737

Re: How to set Default Network Map for Users?

Hi there, i been looking at dude settings and i couldn't find anywhere how to set default Network Map for user that has only Read rights. What am trying to achieve is, to have separate user that has read rights, and once that user logins to The Dude he will load by default Network Map that has all ...
by PaulsMT
Mon Jan 23, 2017 5:58 pm
Forum: The Dude
Topic: Change map-submap
Replies: 4
Views: 1122

Re: Change map-submap

Does anybody have an idea how to change the map or submap of the device? The idea is that i have a map with devices, a little bit later a had made submaps and wont to move some devices from main map to submaps and i can't find where anf how to do that At the moment it's not possible to move devices...
by PaulsMT
Mon Jan 23, 2017 12:21 pm
Forum: The Dude
Topic: Dude client v6.35 connection timeout
Replies: 5
Views: 1708

Re: Dude client v6.35 connection timeout

At first I would suggest you to use only latest release version, e.g. 6.37.4
Make sure you are running the same version client, and connecting to winbox port
by PaulsMT
Mon Jan 23, 2017 12:19 pm
Forum: The Dude
Topic: SNMP
Replies: 12
Views: 3000

Re: SNMP

Did you take a look at this article:
http://wiki.mikrotik.com/wiki/Manual:The_Dude_v6/Files

The SNMP problem with other vendor is know, we will try to fix it. Please try latest bugfix version 6.37.4, can you repeat the SNMP issue ?
by PaulsMT
Thu Jan 19, 2017 1:58 pm
Forum: The Dude
Topic: dude execute on server missing
Replies: 2
Views: 672

Re: dude execute on server missing

Tell me why it is missing "execute on server" ?
dude.png
Dude server is running on chr.
What Dude version are you running ?
by PaulsMT
Thu Jan 19, 2017 11:39 am
Forum: The Dude
Topic: Adding Winbox Tool
Replies: 26
Views: 14105

Re: Adding Winbox Tool

Please do so that you can select multiple types of devices Tools
You mean to allow specific tool for multiple devices ?
dude.png

At the moment you can also specify device type. By this way you can allow tools only for specific device group.
by PaulsMT
Wed Jan 18, 2017 1:23 pm
Forum: Announcements
Topic: The Dude, v6.38 [current] release.
Replies: 77
Views: 23806

Re: The Dude, v6.38 [current] release.

Network = Mikrotik router 6.38.1 tage vlan125 -> taged valn125 TPLINK managed switch taged vlan125-> taged vlan125 Mikrotik router WIFI 6.38.1 WIFI router ether1 -- vlan125 wlan1 BRIDGE --vlan1 --wlan With brodge rstp or stp cant get DHCP or connectivity. without protocol mode all are OK. IT is OK?...
by PaulsMT
Wed Jan 18, 2017 12:45 pm
Forum: The Dude
Topic: Ligowave/Cambium snmpwalk in dude not working
Replies: 5
Views: 1190

Re: Ligowave/Cambium snmpwalk in dude not working

I have made a virtual mikrotik x86 and installed the last dude on this VM. The snmpwalk is working I see the list about the oid numbers, but if I put the numbers in the "Appearance" menu nothing happens. I will try it later with a Cambium device too.
Please test 6.37.4, can you repeat the problem ?
by PaulsMT
Wed Jan 18, 2017 10:42 am
Forum: Announcements
Topic: The Dude, v6.38 [current] release.
Replies: 77
Views: 23806

Re: The Dude, v6.38 [current] release.

what about memory eating od HEX ROS v 6.38.1 and older too - after 1day uptime is memory 27MiB free and drain continue until HEX reboot (because of watchdog timer) Make sure you have fast storage drive (USB/SD card), if the storage drive will be too slow, data will not be saved in time, and will sl...
by PaulsMT
Wed Jan 18, 2017 10:01 am
Forum: General
Topic: backup script
Replies: 2
Views: 1872

Re: backup script

If there is no set password, you should be able to restore it with blank password:
/system backup load name=<name>.backup password=""
by PaulsMT
Wed Jan 18, 2017 8:27 am
Forum: The Dude
Topic: Adding Winbox Tool
Replies: 26
Views: 14105

Re: Adding Winbox Tool

Please do so that you can select multiple types of devices Tools
You mean to allow specific tool for multiple devices ?
by PaulsMT
Wed Jan 18, 2017 8:25 am
Forum: Announcements
Topic: The Dude, v6.38 [current] release.
Replies: 77
Views: 23806

Re: The Dude, v6.38 [current] release.

dnelson - Where do you see 4GB limit ? You can set your custom link speed under Links => Types nje431 - some quick tests didn't show any problems using Webfig Dude>Server Config (6.38.1) from Chrome/Firefox. Can you repeat this from different PC ? honnnza - Can you please write mail to support@mikro...
by PaulsMT
Wed Jan 18, 2017 8:16 am
Forum: Announcements
Topic: The Dude, v6.39rc test builds.
Replies: 121
Views: 28562

Re: The Dude, v6.39rc test builds.

joanllopart - Seems like there is a small bug with SNMP and UBNT devices, can you please test with just releases 6.37.4 version ? If you get the same results, then its not related and we would need remote access (support@mikrotik.com) Chupaka - Only [CTRL]+[V] will not show > sign, you will see it i...
by PaulsMT
Tue Jan 17, 2017 10:59 am
Forum: Announcements
Topic: The Dude, v6.39rc test builds.
Replies: 121
Views: 28562

Re: The Dude, v6.39rc test builds.

When will you add support for custom fonts (cyrillic)?
The problem is known, at the moment can't promise you any dates.
by PaulsMT
Tue Jan 17, 2017 10:59 am
Forum: Announcements
Topic: The Dude, v6.38 [current] release.
Replies: 77
Views: 23806

Re: The Dude, v6.38 [current] release.

When will you add support for custom fonts (cyrillic)?
The problem is known, at the moment can't promise you any dates.
by PaulsMT
Tue Jan 17, 2017 10:53 am
Forum: Scripting
Topic: simple IF doesn't work
Replies: 4
Views: 604

Re: simple IF doesn't work

"If" line looks good, check logs with /log print, maybe it's Winbox log display bug (fixed in winbox 3.9) Its not a /log problem, because i have the same issue when i replace logging by using a global var: :local date [/system clock get date] :local time [/system clock get time] :global test "" :gl...
by PaulsMT
Tue Jan 17, 2017 10:17 am
Forum: Scripting
Topic: Print Command
Replies: 1
Views: 662

Re: Print Command

Hello there
i want to get in print command only the one column results.
ip interface print , BUT to get only the NAME
or
ip hotspot user print , and AGAIN ONLY the usernames
How is that possible?
Thank you!
foreach a in=[/interface find] do={:put [interface get $a name]}
by PaulsMT
Tue Jan 17, 2017 10:12 am
Forum: Scripting
Topic: simple IF doesn't work
Replies: 4
Views: 604

Re: simple IF doesn't work

I use v6.38 (stable) ----------------------------------- Sorry, im a new in scripting, but if i run a simple script(system-scripts-run script), there's nothing in the log: my script: :log info ("Test: start script.") :if ( true ) do={ :log info ("Test: from if.") } :log info ("Test: end script.") i...
by PaulsMT
Tue Jan 17, 2017 9:59 am
Forum: The Dude
Topic: Ligowave/Cambium snmpwalk in dude not working
Replies: 5
Views: 1190

Re: Ligowave/Cambium snmpwalk in dude not working

Any idea?
Please write to support@mikrotik.com
MIB file and remote access will be needed.
by PaulsMT
Tue Jan 17, 2017 9:36 am
Forum: The Dude
Topic: Dude fails for "not an error"...??
Replies: 2
Views: 1870

Re: Dude fails for "not an error"...??

I just bought a hEX to allow me to offload the Dude server from my CCR, so I can get and use all the Dude fixes in the "experimental" releases without compromising my production edge router. I did an export-db on the CCR, FTPed the file to the hEX, and did an import-db, with no errors. When I try t...
by PaulsMT
Tue Jan 17, 2017 9:33 am
Forum: The Dude
Topic: x86 ROS Device SSL process spikes router CPU to 100%
Replies: 14
Views: 3594

Re: x86 ROS Device SSL process spikes router CPU to 100%

I am using version 6.39. I have already tried with version 6.38 and also did not work, the SSL gets very high and the CPU goes to 100%. I am using a virtual machine and running on x86.
Please write to support@mikrotik.com
We will need a remote access.
Thanks.
by PaulsMT
Tue Jan 17, 2017 9:32 am
Forum: The Dude
Topic: [solved] The Dude - Router OS option bug
Replies: 5
Views: 1389

Re: The Dude - Router OS option bug

HI Just moved to Dude 6.38 from 3.6, everything working smoothly so far except one issue, On some devices, if I select the Router OS option, I get the following error: recv failed: Connection reset by peer(104) (6), next attempt at 15:08:42 This only happens on some devices, I've ofc made sure pass...
by PaulsMT
Tue Jan 17, 2017 9:30 am
Forum: The Dude
Topic: [Q] Add new tools
Replies: 1
Views: 495

Re: [Q] Add new tools

Dears

I need to know which programing language use to make own tool with using variables like [Device.FirstAddress]

And can i use with batch file (.bat)

Thanks
You can use any which can accept arguments.
This means you simply need to specify how much arguments your .bat will accept.
by PaulsMT
Tue Jan 17, 2017 9:16 am
Forum: Announcements
Topic: The Dude, v6.39rc test builds.
Replies: 121
Views: 28562

Re: The Dude, v6.39rc test builds.

Changes in v6.39rc13: *) Fixed - winbox/webfig ping probe used retry interval in retry count field. aTan - Administrator rights is necessary just in case, if your Dude client fails to update (so far haven't seen problem with using the Dude without administrator rights). Percanta, Chupaka - Disabling...
by PaulsMT
Tue Jan 17, 2017 8:13 am
Forum: Announcements
Topic: The Dude, v6.38 [current] release.
Replies: 77
Views: 23806

Re: The Dude, v6.38 [current] release.

Changes in v6.38.1: *) Fixed - Tool fetch didn't work with notification - execute on server *) Fixed - Link type speed was not recognised *) Fixed - Broken Simple queue edit/delete feature *) Fixed - Dude showed only part of all Simple queue *) Fixed - Submap icon wasn't placed on map if "New Map" o...
by PaulsMT
Fri Jan 13, 2017 2:13 pm
Forum: The Dude
Topic: Dude don't show new submaps
Replies: 4
Views: 796

Re: Dude don't show new submaps

Problem is fixed in the latest release.

mschreiner - so your request would be to create hierarchical map structure with parent/child map tree structure ? Where parent map notifies about all issues on their submaps ?
by PaulsMT
Fri Jan 13, 2017 1:46 pm
Forum: Announcements
Topic: The Dude, v6.39rc test builds.
Replies: 121
Views: 28562

Re: The Dude, v6.39rc test builds.

Changes up to v6.39rc12: *) Fixed - Submap icon wasn't placed on map if "New Map" option was used. *) Fixed - Custom tool wasn't accessible from Devices-> List *) Fixed - Device -> RouterOS didn't show interfaces in interface dropdown list *) Fixed - Error was displayed when tried to edit multiple s...
by PaulsMT
Thu Jan 12, 2017 2:40 pm
Forum: The Dude
Topic: Adding Winbox Tool
Replies: 26
Views: 14105

Re: Adding Winbox Tool

You have to point the Dude client to a folder on the Windows PC. You have "/disk1" in there, this does not seem like a Windows path. You must use something like "C:\\" Thanks Normis, this clears it up. What I will have to do is inform other users that they must store their mikrotik.exe in the exact...
by PaulsMT
Thu Jan 12, 2017 2:15 pm
Forum: The Dude
Topic: How to give access to Read Users?
Replies: 2
Views: 568

Re: How to give access to Read Users?

Try with enabled FTP policy
by PaulsMT
Wed Jan 11, 2017 1:03 pm
Forum: Announcements
Topic: The Dude, v6.39rc test builds.
Replies: 121
Views: 28562

Re: The Dude, v6.39rc test builds.

asik - thanks, reporeted.

pitersss2 - To avoid some problems related to Dude, follow these suggestions:

*) It is suggested to use only ext3 file format for the Dude data directory, it's more stable for the Dude.
*) Store your custom files Only in dude/files directory
by PaulsMT
Wed Jan 11, 2017 12:04 pm
Forum: Announcements
Topic: The Dude, v6.38 [current] release.
Replies: 77
Views: 23806

Re: The Dude, v6.38 [current] release.

On a system x86 based, I have some problem of memory leak using dude v6.38....every minute dude eat lot of ram until router crash...someone has this issue??
Some server crash is fixed on 6.38, but just to be sure that it's the same problem, please send us supout file
by PaulsMT
Wed Jan 11, 2017 9:53 am
Forum: The Dude
Topic: Dude Server on Windows
Replies: 12
Views: 36699

Re: Dude Server on Windows

Yes, the license level will not affect your Dude performance/functionality, you will get the same features.
by PaulsMT
Tue Jan 10, 2017 4:53 pm
Forum: Scripting
Topic: capture output of ssh remote command
Replies: 5
Views: 2194

Re: capture output of ssh remote command

SSH command output can be saved with "output-to-file" option. Any other script/command output you can save with :execute command: For example - save output of your script: The script: /system script add name=ScriptExample source={ /system clock print } Execute script, and save output: {:local a [/sy...
by PaulsMT
Tue Jan 10, 2017 4:28 pm
Forum: The Dude
Topic: x86 ROS Device SSL process spikes router CPU to 100%
Replies: 14
Views: 3594

Re: x86 ROS Device SSL process spikes router CPU to 100%

My problem persists, does anyone have the solution?
Should be fixed in 6.38
What version are you using ?
by PaulsMT
Tue Jan 10, 2017 2:02 pm
Forum: Announcements
Topic: The Dude, v6.39rc test builds.
Replies: 121
Views: 28562

Re: The Dude, v6.39rc test builds.

Chupaka - Thanks, but I wasn't able to reproduce. I can reproduce it via WinBox from 2 PCs and via WebFig: as soon as I change Retry Interval and press 'Apply', Retry Count is set to that new number. it's x86, checked v6.38 and v6.39rc7 (two different routers). will supout help you? or I can give y...
by PaulsMT
Tue Jan 10, 2017 12:40 pm
Forum: Announcements
Topic: The Dude, v6.39rc test builds.
Replies: 121
Views: 28562

Re: The Dude, v6.39rc test builds.

AiroSam - Thanks, Interface dropdown will be fixed in next rc version. Also the server crash on 6.38 is fixed, and will be included in next 6.38.x version. maviaelsilva - Default Winbox tool is removed, please use tools to specify path to your Winbox.exe file: http://wiki.mikrotik.com/wiki/Manual:Th...
by PaulsMT
Tue Jan 10, 2017 12:05 pm
Forum: Scripting
Topic: Scheduler problem on RouterOS v6.38
Replies: 2
Views: 849

Re: Scheduler problem on RouterOS v6.38

Your scheduler does not have the same policies as your script.

If you don't need to enable some specific policies, you can simply add wireless disable command without script:

/system scheduler add interval=1D on-event={/interface wireless disable wlan1} disabled=no start-time=22:30:00
by PaulsMT
Tue Jan 10, 2017 11:56 am
Forum: Announcements
Topic: The Dude, v6.38 [current] release.
Replies: 77
Views: 23806

Re: The Dude, v6.38 [current] release.

rzirzi - to see last time the device was online (to see if it is used at all). It can be seen in Device -> History graph, or in Services -> Outages (show down times) Also you could make notification, and apply to this device (log, email...) Would you need some additional way ? - schedule an update i...
by PaulsMT
Tue Jan 10, 2017 11:01 am
Forum: The Dude
Topic: Dude Server on Windows
Replies: 12
Views: 36699

Re: Dude Server on Windows

Hi All, Long time passed since I have been to this forum. A lot has changed, but relying on the Dude server in my work has not changed till now. Now I need to install the new version (windows version started to fail multiple times), hoping it is more robust than the windows version. I know it now n...
by PaulsMT
Mon Jan 09, 2017 11:24 am
Forum: The Dude
Topic: New device that supports The Dude server package: RB750r3 hEX [SOLVED]
Replies: 86
Views: 14549

Re: New device that supports The Dude server package: RB750r3 hEX [SOLVED]

The last version with syslog is the 4b3. Not the previous like you wrote. And it is well known. Mikrotik promised to put it back somehow one day... You can still use Dude as syslog server. The difference is that the syslog messages will be stored under Log section. https://s30.postimg.org/40y30875t...
by PaulsMT
Mon Jan 09, 2017 11:06 am
Forum: The Dude
Topic: "get settings failed: std failure: broken path (2)"
Replies: 4
Views: 2507

Re: "get settings failed: std failure: broken path (2)"

Dude can't be installed on RB2011UiAS-2HnD (MIPSBE)

The Dude server can be installed on following platforms:

ARM (RB3011)
TILE (CCR line)
CHR
X86 RouterOS
MMIPS

If you are using Windows, then the easiest way would be to install the CHR with Dude server on virtual machine.
by PaulsMT
Mon Jan 09, 2017 11:03 am
Forum: The Dude
Topic: Launch script from notification don't work well
Replies: 2
Views: 480

Re: Launch script from notification don't work well

Please test it with the latest Dude 6.39rc, there are fix related to tool fetch. Let us know if the problem is resolved.
by PaulsMT
Mon Jan 09, 2017 10:59 am
Forum: The Dude
Topic: Dude Telegram notification example
Replies: 56
Views: 26696

Dude Telegram notification example

Currently it's not possible to use HTTP POST method from Dude/RouterOS, so here is some workaround example how to use Telegram, to send messages using HTTP GET method:

http://wiki.mikrotik.com/wiki/Manual:Th ... am_Example

Suggestions / requests will be appreciated.
by PaulsMT
Fri Jan 06, 2017 9:28 am
Forum: Announcements
Topic: The Dude, v6.39rc test builds.
Replies: 121
Views: 28562

Re: The Dude, v6.39rc test builds.

At the moment we can't promise any date about CLI Dude.

AiroSam - Please update your Dude server to the latest RC (6.39rc7), and check if device Status=up and RouterOS Status=ok
by PaulsMT
Thu Jan 05, 2017 2:57 pm
Forum: Announcements
Topic: The Dude, v6.39rc test builds.
Replies: 121
Views: 28562

The Dude, v6.39rc test builds.

Changes in v6.39rc7: *) Fixed - Tool fetch didn't work with notification - execute on server *) Fixed - Link type speed was not recognised *) Fixed - Charts made some strange peaks *) Added - Right click tool option under Devices -> RouterOS -> simple queues *) Fixed - Broken Simple queue edit/delet...
by PaulsMT
Wed Jan 04, 2017 9:26 am
Forum: General
Topic: v6.38 RB3011 does not boot after update
Replies: 17
Views: 3469

Re: v6.38 RB3011 does not boot after update

Netinstall should work if your VM is bridged with your network. Netinstall on Linux can be used with wine. At first try to netinstall this device with option "Keep old configuration", this will leave your old configuration. Also please try to start the board with the Backup BIOS by holding the Reset...
by PaulsMT
Mon Jan 02, 2017 4:42 pm
Forum: The Dude
Topic: The Dude, v6.38rc test builds.
Replies: 189
Views: 39501

Re: The Dude, v6.38rc test builds.

Version 6.38 is released

Full changelog and discussions will be on this topic:
http://forum.mikrotik.com/viewtopic.php?f=21&t=116356
by PaulsMT
Mon Jan 02, 2017 4:40 pm
Forum: Announcements
Topic: The Dude, v6.38 [current] release.
Replies: 77
Views: 23806

The Dude, v6.38 [current] release.

Version 6.38 has been released. Major changes: *) Added - AES encryption method for snmp v3 *) Added - Dude now have configuration interface in Winbox/Webfig *) Added - Network maps now are viewable from web interface (Webfig) *) Agents - Now any RouterOS device can be used as The Dude agent. It no ...
by PaulsMT
Mon Jan 02, 2017 12:58 pm
Forum: The Dude
Topic: The Dude, v6.38rc test builds.
Replies: 189
Views: 39501

Re: The Dude, v6.38rc test builds.

Hello everyone, I want to report a problem with the upload file function in v6.38RC52 on mmips RB750GR3 - in this version and with this device, traditional "drag and drop" does not work, but there is a new button "upload" http://pawinski.info/PLIKI/up123.png because the device has only 15 megabytes...
by PaulsMT
Fri Dec 30, 2016 4:20 pm
Forum: The Dude
Topic: Why the dude shows the specifications not of devices in a different subnet
Replies: 4
Views: 712

Re: Why the dude shows the specifications not of devices in a different subnet

Quick test didn't show problems, if the monitored device is reachable from Dude server.
Just in case try to update your Dude server.

If problem remains, write to support@mikrotik.com
by PaulsMT
Fri Dec 30, 2016 12:56 pm
Forum: The Dude
Topic: The Dude, v6.38rc test builds.
Replies: 189
Views: 39501

Re: The Dude, v6.38rc test builds.

macsrwe - Yes you can also place your custom folder under dude/files sparrow - check if you can receive RouterOS data from that device - under RouterOS -> Interface. You should see the same results as in your link label https://s24.postimg.org/4bzkmtred/Router_OS.png "?" will be shown if no data has...
by PaulsMT
Thu Dec 29, 2016 11:57 am
Forum: The Dude
Topic: The Dude, v6.38rc test builds.
Replies: 189
Views: 39501

Re: The Dude, v6.38rc test builds.

I can confirm our map background images randomly disappear from disk, too. We are on 6.38rc40 and have had to replace a background image twice and it ultimately disappears from disk. It is missing again now. 1. Please update your Dude server to the latest - 6.38rc version 2. If you can reproduce th...
by PaulsMT
Tue Dec 27, 2016 8:56 am
Forum: The Dude
Topic: The Dude, v6.38rc test builds.
Replies: 189
Views: 39501

Re: The Dude, v6.38rc test builds.

Devs: thanks for all the work so far, appreciate it! Sorry I didn't reply with update to email notification issue not working. Original email problem (post #104) was resolved. Was originally on CHR. Loaded new x86 VM and email notifications started working so seemed to be something with that specif...
by PaulsMT
Thu Dec 22, 2016 10:41 am
Forum: The Dude
Topic: The Dude, v6.38rc test builds.
Replies: 189
Views: 39501

Re: The Dude, v6.38rc test builds.

Should be fixed in next release: %HOMEPATH% variable resolve from Dude tool Typo: "Authetication Failed Winbox->Dude->Notification->Command: Reported: bandwith_test - auth. fail aTan - Autoupgrade tested with multiple devices, multiple versions, should be something specific. asik - background image ...
by PaulsMT
Wed Dec 21, 2016 2:29 pm
Forum: The Dude
Topic: The Dude, v6.38rc test builds.
Replies: 189
Views: 39501

Re: The Dude, v6.38rc test builds.

Is the Dude client autoupdate functional? I've tried it with several 6.38rc and it downloads something and then just shutdowns.
Should be fine to autoupdate from all recent versions, just make sure that you run the Dude as administrator. Does anybody else have seen similar problems recently ?
by PaulsMT
Wed Dec 21, 2016 2:11 pm
Forum: The Dude
Topic: The Dude, v6.38rc test builds.
Replies: 189
Views: 39501

Re: The Dude, v6.38rc test builds.

Version 6.38rc52 has been released. Changes since last version *) Removed - Since default Winbox used in the Dude wasn't fully compatible with all RouterOS devices, we removed it completely. *) Fixed - Increased default ping packet size to 54bytes - there was some devices who wasn't able to respond ...
by PaulsMT
Tue Dec 20, 2016 2:34 pm
Forum: The Dude
Topic: Cannot connect Dude 10061
Replies: 2
Views: 3571

Re: Cannot connect Dude 10061

Check if you have permissions for dude user, the port is not restricted with firewall.
If this does not help, send supout to support@mikrotik.com

Also remember to update your RouterOS version to the latest.
by PaulsMT
Tue Dec 20, 2016 2:31 pm
Forum: The Dude
Topic: Stuck on "getting stuff"
Replies: 1
Views: 701

Re: Stuck on "getting stuff"

Try 6.38rc
Also send mail with report to support@mikrotik.com
by PaulsMT
Tue Dec 20, 2016 2:11 pm
Forum: The Dude
Topic: The Dude, v6.38rc test builds.
Replies: 189
Views: 39501

Re: The Dude, v6.38rc test builds.

Version 6.38rc51 has been released. Changes since 6.38rc41 *) Fixed - Changed SSL connection timeouts. SSL connections caused CPU overload *) Fixed - Minor changes in Dude fonts *) Added - Dude icon in Winbox/Webfig The SSL problem should be fixed with this version, please test and report if problem...
by PaulsMT
Tue Dec 06, 2016 3:08 pm
Forum: The Dude
Topic: The Dude, v6.38rc test builds.
Replies: 189
Views: 39501

Re: The Dude, v6.38rc test builds.

Changes since 6.38rc37 *) Fixed - File upload to dude/file directory caused client crash *) Fixed - Background images could disappear on version change *) Fixed - Snmpwalk was not working properly in recent versions asik At the moment it's not in schedule, but the request is stored, thanks. dcolli F...
by PaulsMT
Wed Nov 30, 2016 2:26 pm
Forum: The Dude
Topic: The Dude, v6.37 [current] release.
Replies: 47
Views: 14854

Re: The Dude, v6.37 [current] release.

New current version is released! Changes in v6.37.3: *) Fixed - Broken auto update on dude client *) Fixed - Memory leak caused by dude server *) Fixed - Client radius authentication *) Fixed - Device tooltip windows wasn't able to show all info *) Fixed - Dude client might stay in 'getting stuff' s...
by PaulsMT
Mon Nov 28, 2016 9:37 am
Forum: The Dude
Topic: DUDE EVENTS [SOLVED]
Replies: 1
Views: 644

Re: DUDE EVENTS [SOLVED]

With this command you will also see event logs on your Dude server RouterOS logs.

/system logging add topics=dude action=memory
by PaulsMT
Mon Nov 28, 2016 9:33 am
Forum: The Dude
Topic: The Dude, v6.38rc test builds.
Replies: 189
Views: 39501

Re: The Dude, v6.38rc test builds.

Version 6.38rc37 has been released. *) Fixed - default files will be stored in dude files folder if the file system does not support symlinks (fat32) *) Fixed - avoid going into loop (Dude client could get stuck in loading phase) Note ! Since dude has received major changes in recent versions, some ...
by PaulsMT
Wed Nov 23, 2016 3:11 pm
Forum: The Dude
Topic: The Dude, v6.38rc test builds.
Replies: 189
Views: 39501

Re: The Dude, v6.38rc test builds.

Version 6.38rc35 has been released. Changes since v6.38rc32: *) Fixed - Dude client stuck on "getting stuff state". *) Fixed - Disk name were changed on RB hEX if the dude was used on USB flash or mSD card. For security reasons it's suggested to make backups before upgrade. http://wiki.mikrotik.com/...
by PaulsMT
Tue Nov 22, 2016 11:01 am
Forum: The Dude
Topic: The Dude, v6.37 [current] release.
Replies: 47
Views: 14854

Re: The Dude, v6.37 [current] release.

New current version is released 6.37.2. !!! Please note that the Dude client auto-upgrade to this version will not work. To update Dude client manually use installation file from http://www.mikrotik.com/download Changes in v6.37.2: *) Fixed - History charts graph issues on popup window. *) Fixed - N...
by PaulsMT
Tue Nov 22, 2016 9:39 am
Forum: The Dude
Topic: 6.37.2 Warning Dude doesn't work! Wait for 37.3?
Replies: 10
Views: 1734

Re: 6.37.2 Warning Dude doesn't work! Wait for 37.3?

The changelog is updated, thanks.
by PaulsMT
Tue Nov 22, 2016 8:52 am
Forum: The Dude
Topic: 6.37.2 Warning Dude doesn't work! Wait for 37.3?
Replies: 10
Views: 1734

Re: 6.37.2 Warning Dude doesn't work! Wait for 37.3?

The Dude still works in version 6.37.2, but the auto upgrade will not. This means you can still upgrade your Dude server, but for Dude client you will need to use manual installation.

6.37.2 Client can be found here:
http://www.mikrotik.com/download

This will be fixed in 6.37.3
by PaulsMT
Thu Nov 17, 2016 1:23 pm
Forum: The Dude
Topic: The Dude, v6.38rc test builds.
Replies: 189
Views: 39501

Re: The Dude, v6.38rc test builds.

Thank you for correcting the snmpwalk. I found other bug in rc31: missing graph captions in device history panel. Very good, thanks, and can you please clarify, is this problem only in device pop-up window (history graphs), or you also see the same in device > history charts ? Seems like there is i...
by PaulsMT
Wed Nov 16, 2016 1:56 pm
Forum: The Dude
Topic: The Dude, v6.38rc test builds.
Replies: 189
Views: 39501

Re: The Dude, v6.38rc test builds.

Changes since v6.38rc29: *) Fixed - Snmpwalk was broken starting from 6.38rc27 *) Fixed - Dude db-import failed if dude wasn't enabled amt - such error is showed if the connection is restricted from the router side, I wasn't able to reproduce such problem, maybe it's because of monitored device conf...
by PaulsMT
Wed Nov 16, 2016 12:17 pm
Forum: The Dude
Topic: Metal9 Spectral Scan support
Replies: 1
Views: 618

Re: Metal9 Spectral Scan support

Asking for Metal9 support in Spectral Scan tool in the Dude.

Thanks!
Thank you for suggestion, this feature will be included in the next RouterOS RC version.
by PaulsMT
Mon Nov 14, 2016 9:41 am
Forum: The Dude
Topic: The Dude, v6.38rc test builds.
Replies: 189
Views: 39501

Re: The Dude, v6.38rc test builds.

Changes since v6.38rc25: *) Fixed - Error on dude RADIUS authentication. *) Fixed - In some setups dude server caused memory leak on X86/CHR. *) Added - Dude server now supports spectral scan up to 7Ghz. Hello, I upgraded from 6.37.1 to 6.38rc29 and moved from CCR router to vSphere x86 CHR VM becaus...
by PaulsMT
Fri Nov 11, 2016 11:25 am
Forum: The User Manager
Topic: um 6.37.1 timezone issue
Replies: 6
Views: 1225

Re: um 6.37.1 timezone issue

Thank you for reporting, seems like the backup save time needs a fix. But I did not saw any problem with the session from time. Can you give more examples ?

Sessions/logs/reports show correct from time, if the customer time zone is set (6.37.1/6.38rcX)
by PaulsMT
Fri Nov 04, 2016 1:57 pm
Forum: The Dude
Topic: The Dude, v6.38rc test builds.
Replies: 189
Views: 39501

Re: The Dude, v6.38rc test builds.

Hello, i still trying to figure out how i can make the dude server to read RouterOS info on a RB device that dont use the default Winbox Port There are two opttions available to read RouterOS info: 1) Use default Winbox port. 2) Make firewall NAT rule on your monitored RouterOS device, to redirect ...
by PaulsMT
Fri Nov 04, 2016 1:37 pm
Forum: The Dude
Topic: The Dude, v6.38rc test builds.
Replies: 189
Views: 39501

Re: The Dude, v6.38rc test builds.

Thanks for reporting, links are updated now.
http://www.mikrotik.com/download
by PaulsMT
Thu Nov 03, 2016 5:07 pm
Forum: The Dude
Topic: The Dude, v6.38rc test builds.
Replies: 189
Views: 39501

Re: The Dude, v6.38rc test builds.

New release candidate version (6.38rc24) is available! http://www.mikrotik.com/download Changes since v6.38rc19: *) Removed - Link label will not change colour on link speed change. *) Fixed - Allow users without FTP policy to connect to dude server (access to files will be restricted). *) Fixed - D...
by PaulsMT
Tue Nov 01, 2016 12:24 pm
Forum: The Dude
Topic: File upload
Replies: 2
Views: 771

Re: File upload

Starting from 6.37 file upload option is removed from dude, for the file management use Winbox, Webfig or ftp.
by PaulsMT
Fri Oct 28, 2016 12:28 pm
Forum: The Dude
Topic: dude client Problem
Replies: 6
Views: 834

Re: dude client Problem

At first make sure you are using latest RouterOS/Dude server and dude client version, make sure you are using winbox port.
by PaulsMT
Fri Oct 28, 2016 10:34 am
Forum: The Dude
Topic: The Dude, v6.38rc test builds.
Replies: 189
Views: 39501

Re: The Dude, v6.38rc test builds.

raffav wrote: Yes i know but i dont use default winobox port 8291 for security reason it will be very nice to be possible to tell dude on witch winbox port connect You can specify probe port under device settings => Services => routeros mangement => Probe Port Lakis wrote: If Dude lose connection t...
by PaulsMT
Thu Oct 06, 2016 3:01 pm
Forum: The Dude
Topic: The Dude, v6.38rc test builds.
Replies: 189
Views: 39501

Re: The Dude, v6.38rc test builds.

Thank you all for testing and reporting. For some reason Dude stop reading values from device - Dude cant reprobe or cant get new values from the Device These values will keep updating, but it might take some time, we will see if we can improve it. Another thing on Device label as u can see two from...
by PaulsMT
Mon Sep 26, 2016 1:36 pm
Forum: The Dude
Topic: The Dude, v6.37 [current] release.
Replies: 47
Views: 14854

Re: The Dude, v6.37 [current] release.

Some variables in notifications seem to be missing, for example :
[Service.Status]
[Service.ProblemDescription]
Thank you. The fix for this will be included in next release.
by PaulsMT
Fri Sep 23, 2016 11:28 am
Forum: The Dude
Topic: The Dude, v6.37rc test builds.
Replies: 92
Views: 17782

Re: The Dude, v6.37rc test builds.

Changes in 6.37rc42 *) Fixed - network label scaling issue, when movied. *) Fixed - minimap issues. *) Fixed - incorrect link graph data, when interface was changed. *) Fixed - shown wrong interface on link menu dropdown. *) Fixed - various server/client cashes - Disabled upload and drag&drop featur...
by PaulsMT
Thu Sep 01, 2016 9:33 am
Forum: Announcements
Topic: Winbox3.4 released!
Replies: 54
Views: 19328

Re: Winbox3.4 released!

Winbox 3.5 is released! Please upgrade.

Continue discussions here:
http://forum.mikrotik.com/viewtopic.php?f=21&t=111719
by PaulsMT
Thu Sep 01, 2016 9:30 am
Forum: Announcements
Topic: Winbox 3.5 released!
Replies: 20
Views: 9487

Winbox 3.5 released!

What's new in v3.5: *) fixed file upload via Upload button; *) do not disconnect from router if none of the windows are open; *) report error if telnet failed; *) handle properly romon authentication failures; If you experience version related issues, then please report them to support@mikrotik.com....
by PaulsMT
Fri Aug 19, 2016 11:54 am
Forum: Scripting
Topic: Help to get [/interface ethernet get ether1 rx-byte] !!
Replies: 2
Views: 645

Re: Help to get [/interface ethernet get ether1 rx-byte] !!

:put [/interface ethernet get ether1 rx-bytes]
by PaulsMT
Thu Aug 04, 2016 3:53 pm
Forum: Scripting
Topic: Script - check configuration before apply it again
Replies: 2
Views: 593

Re: Script - check configuration before apply it again

For example - check with if there exists user with name "*adm*"
:if ([:len [user find name~"adm"]]>0) do={:put "exists"}

Or for those setting where you are not allowed to add same records - catch run-time errors
:do {user add group=full name=admin} on-error={:put "can't add user admin"}
by PaulsMT
Wed Aug 03, 2016 4:29 pm
Forum: Scripting
Topic: Export Last-IP
Replies: 3
Views: 636

Re: Export Last-IP

To get "last-ip" from every connected device us foreach loop:
:foreach w in=[/interface wireless registration-table find] do={
        :put ([/interface wireless registration-table get $w]->"last-ip");
    }
by PaulsMT
Wed Aug 03, 2016 11:09 am
Forum: RouterBOARD hardware
Topic: RB433 KEEPS FREEZING AND HOW TO SPLIT THE LAN ON RB433 BOARD
Replies: 1
Views: 425

Re: RB433 KEEPS FREEZING AND HOW TO SPLIT THE LAN ON RB433 BOARD

What does log says after reboot ? Make sure you are using power supply with inaf output power, also install the latest RouterOS on your device: http://www.mikrotik.com/download If the problem repeats, generate supout file after reboot, and send it to support@mikrotik.com http://wiki.mikrotik.com/wik...
by PaulsMT
Wed Aug 03, 2016 10:17 am
Forum: RouterBOARD hardware
Topic: SXT G-5HPacD REBBOOTING WHEN CONNECTED TO SWITCH
Replies: 4
Views: 726

Re: SXT G-5HPacD REBBOOTING WHEN CONNECTED TO SWITCH

Are you using same power source - when connected to PC and Switch ?

Best option would be to generate supout file after reboot, and send it to support@mikrotik.com
http://wiki.mikrotik.com/wiki/Manual:Su ... utput_File
by PaulsMT
Sun Jun 12, 2016 10:04 pm
Forum: General
Topic: Port flapping (ether6 link down/up) on RB3011UiAS-RM
Replies: 29
Views: 14550

Re: Port flapping (ether6 link down/up) on RB3011UiAS-RM

Please try to install the latest RouterOS bugfix version, there are several improvements for RB3011, including port flapping fix.
by PaulsMT
Wed Apr 27, 2016 2:01 pm
Forum: RouterBOARD hardware
Topic: No sound
Replies: 2
Views: 1052

Re: No sound

No this device comes without a beeper.
by PaulsMT
Tue Mar 22, 2016 3:03 pm
Forum: General
Topic: Port Fowarding Issue
Replies: 4
Views: 514

Re: Port Fowarding Issue

Doesn't this accept it before it gets to that line? chain=forward action=accept in-interface=ether3 log=no log-prefix="" You have to add accept rule for allowed (knocked) ip, and the interface should be your external (pppoe-out1) Here are good port knock configuration example: http://wiki.mikrotik....
by PaulsMT
Tue Mar 22, 2016 2:32 pm
Forum: General
Topic: Protected RouterBOOT
Replies: 116
Views: 28444

Re: Protected RouterBOOT

Hello All, As it is mentioned in the wiki " The backup RouterBOOT version can not be older than v3.22 version. A special package is provided to upgrade the backup RouterBOOT (DANGEROUS). Newer devices will have this new backup loader already installed at the factory." However, what is the way to up...
by PaulsMT
Fri Feb 26, 2016 3:57 pm
Forum: Scripting
Topic: [help] Ask how to get variable into single line
Replies: 2
Views: 792

Re: [help] Ask how to get variable into single line

:put (“concatenate” . “ “ . “string”);

or

:put ($var . “string” . $var2);

http://wiki.mikrotik.com/wiki/Manual:Sc ... _Operators



body=("Interface=".$name." TX is ".$tx-bits-per-second);
by PaulsMT
Mon Feb 22, 2016 2:19 pm
Forum: Scripting
Topic: scripting with for each loop
Replies: 2
Views: 1938

Re: scripting with for each loop

:local filename;
:foreach file in=[/file find where name~"mikrotik"] do={
:set $filename [/file get $file name];
/tool fetch src-path=$filename ............
}
by PaulsMT
Fri Feb 12, 2016 11:51 am
Forum: Scripting
Topic: get supported-bands not working in 6.33
Replies: 5
Views: 1650

Re: get supported-bands not working in 6.33

/interface wireless info allowed-channels <Wlan iface> Will show you all available settings depending on your current configuration, but /interface wireless info hw-info <Wlan iface> Will show all possible settings allowed by hardware, the output will be: ranges: 2312-2732/5/b,g,gn20,gn40 Where "231...
by PaulsMT
Thu Feb 11, 2016 11:00 am
Forum: Beginner Basics
Topic: How to instal router 950 G with v6.8
Replies: 4
Views: 717

Re: How to instal router 950 G with v6.8

Please read this article:
http://wiki.mikrotik.com/wiki/Manual:Netinstall

Also use only the latest Netinstall and RouterOS from:
http://www.mikrotik.com/download
by PaulsMT
Thu Feb 11, 2016 10:43 am
Forum: RouterBOARD hardware
Topic: Reformatting device?
Replies: 24
Views: 2782

Re: Reformatting device?

Thanks for the correction, the wiki page has been updated to: As an emergency recovery option, it is possible to reset everything by pressing the button at power-on for longer than reformat-hold-button time. Even if reformat-hold-button time is forgotten, holding the reset button for more than 300s ...
by PaulsMT
Wed Feb 10, 2016 3:35 pm
Forum: RouterBOARD hardware
Topic: Reformatting device?
Replies: 24
Views: 2782

Re: Reformatting device?

You will still be able to reformat these devices by holding reset button more than XYX value.
by PaulsMT
Thu Feb 04, 2016 2:18 pm
Forum: RouterBOARD hardware
Topic: Replace UBNT Toughswitch with RouterOS Device????
Replies: 16
Views: 1850

Re: Replace UBNT Toughswitch with RouterOS Device????

If you are using included 24v 2.5A power adapter, then with enabled "forced-on" mode and ether1-poe-in-long-cable, all powered devices should work stable.
http://wiki.mikrotik.com/wiki/Manual:Po ... ed-on_mode
by PaulsMT
Wed Feb 03, 2016 11:35 am
Forum: Scripting
Topic: User of hotspot sheduled to removal
Replies: 1
Views: 488

Re: User of hotspot sheduled to removal

Hi, i'm new here and using mikrotik, i'm looking for a script that eliminates certains user of my hotspot on the date i choose. For example: I've created the user "William" today, I want to (if it's possible) put a script that automatically eliminate that user the 2 of march of next month. If it po...
by PaulsMT
Wed Feb 03, 2016 11:25 am
Forum: RouterBOARD hardware
Topic: RB750P-PBr2 mAP_lite
Replies: 4
Views: 782

Re: RB750P-PBr2 mAP_lite

PowerBox comes with 24v 2,5Amp power supply, which is completely fine to power four mAPL. While PowerBox output voltage is the same as input voltage (24V), one mAPL at max power consumption will require 0.145A

http://routerboard.com/RB750P-PBr2
by PaulsMT
Wed Feb 03, 2016 11:09 am
Forum: RouterBOARD hardware
Topic: mAP lite
Replies: 58
Views: 19603

Re: mAP lite

Hello! I also got one device. Can anybody explain why this device consumes so much power 3,5W. I planned to use PowerBOX to connect 4 mAP lite, but it looks like that in this case it is not possible to use it. Even original power supplier provides 2000mA. I'm right? If so what the best practice to ...
by PaulsMT
Wed Feb 03, 2016 10:56 am
Forum: Beginner Basics
Topic: Cacti Graph Problem.
Replies: 2
Views: 583

Re: Cacti Graph Problem.

Thanks for reporting. This problem will be resolved in next RouterOS releases.
by PaulsMT
Tue Feb 02, 2016 2:36 pm
Forum: General
Topic: How i can kill connection?
Replies: 2
Views: 2701

Re: How i can kill connection?

What if you use: && instead of & ?
/ip firewall connection remove [find protocol=udp && dst-address=192.168.250.100 && .........
by PaulsMT
Tue Feb 02, 2016 11:41 am
Forum: General
Topic: routerboard rb260gsp how to bridge sfp port to a switch with fiber?
Replies: 2
Views: 1033

Re: routerboard rb260gsp how to bridge sfp port to a switch with fiber?

Swithing menu can be found under this link:
http://192.168.88.1/index.html#forwarding

Check if all SFP checkboxes are marked (from - to)
by PaulsMT
Mon Feb 01, 2016 1:31 pm
Forum: Scripting
Topic: Help needed to understand wiki example
Replies: 3
Views: 689

Re: Help needed to understand wiki example

In your example, if ip firewall address-list is empty, then [/ip firewall address-list find ] will return nothing - "", so conditions for: :if ( [/ip firewall address-list find ] = "") will be TRUE. Find command won't output any result to the terminal, to do so - use command :put [/ip firewall addre...
by PaulsMT
Mon Feb 01, 2016 12:25 pm
Forum: General
Topic: Get "Link Downs:" parameter in CLI
Replies: 7
Views: 1473

Re: Get "Link Downs:" parameter in CLI

:put [/interface get ether1 link-downs ];
by PaulsMT
Wed Jan 27, 2016 2:35 pm
Forum: General
Topic: Change SFP MAC
Replies: 1
Views: 645

Re: Change SFP MAC

/interface ethernet set sfp1 mac-address=AA:AA:AA:AA:AA:AA
by PaulsMT
Wed Jan 27, 2016 1:48 pm
Forum: Beginner Basics
Topic: Issue Using RB2011UiAS-2HnD as Access Point for RB3011UiAS
Replies: 12
Views: 1098

Re: Issue Using RB2011UiAS-2HnD as Access Point for RB3011UiAS

Are you using original power supply to power 3011 ?

Please try to enable forced POE mode on RB3011:
/interface ethernet poe set ether10 poe-out=forced-on


http://wiki.mikrotik.com/wiki/Manual:Po ... ed-on_mode
(Note that the power will stay on until this mode will be changed to auto or off )
by PaulsMT
Mon Jan 25, 2016 4:27 pm
Forum: Scripting
Topic: Why does time value in /log return different formats?
Replies: 8
Views: 824

Re: Why does time value in /log return different formats?

There will be no Date if log is created in current day.
by PaulsMT
Mon Jan 25, 2016 2:22 pm
Forum: Scripting
Topic: Script broken by upgrade to 6.32.3
Replies: 3
Views: 750

Re: Script broken by upgrade to 6.32.3

You can also use simple command to change queues with unset max limit:
/queue simple set [find max-limit="0/0"] max-limit=8M/8M

Or do foreach loop:
:foreach i in=[/queue simple find where max-limit="0/0"] do={/queue simple set $i max-limit= "8M/8M"}
by PaulsMT
Mon Jan 25, 2016 1:06 pm
Forum: RouterBOARD hardware
Topic: RB2011 2in1 Reset no working
Replies: 7
Views: 5229

Re: RB2011 2in1 Reset no working

Here you can see step by step instructions how to use Netinstall to reinstall you router. http://wiki.mikrotik.com/wiki/Manual:Netinstall Configure your PC IP address manually, use same subnet on both - Netinstall and PC. If the board will successfully start etherboot mode, you should see "ether boo...
by PaulsMT
Mon Jan 25, 2016 12:47 pm
Forum: Scripting
Topic: Voltage Monitoring
Replies: 14
Views: 5835

Re: Voltage Monitoring

Where must $ comming in the line? Can you make the last line please :if ($thishour = "23") do={:execute $voltreport} $voltreport is the second script or function which is not defined here. Here you will find step by step instructions how this script works: http://wiki.mikrotik.com/wiki/Monitor_inpu...
by PaulsMT
Mon Jan 25, 2016 12:24 pm
Forum: Scripting
Topic: automatic ip configuration
Replies: 11
Views: 1424

Re: automatic ip configuration

This command will add all received ping src addresses to address list called "PING" /ip firewall filter add chain=input action=add-src-to-address-list address-list=PING protocol=icmp Scheduler will start the script at startup /system scheduler add start-time=startup on-event={"Your script with while...
by PaulsMT
Mon Jan 25, 2016 12:02 pm
Forum: Scripting
Topic: Voltage Monitoring
Replies: 14
Views: 5835

Re: Voltage Monitoring

There is an error in last line:
:if ($thishour = "23") do={:execute voltreport}

if voltreport is supposed to a variable - then it is missing $ and also it is not defined.

If you change this line, then the script works fine in 6.33.5
by PaulsMT
Thu Jan 21, 2016 11:39 am
Forum: General
Topic: Protected RouterBOOT
Replies: 116
Views: 28444

Re: Protected RouterBOOT

Thanks PaulsMT, but I need an install package for smips... jan/01 00:00:04 system,info verified protected_routerboot_v3_24_enable_6_29_1_mipsbe.dpk 13:36:09 system,error can not install protected-router-6.29: it is not made for smips, but for mips 13:36:09 system,info router rebooted [admin@RB941-2...
by PaulsMT
Mon Jan 18, 2016 4:05 pm
Forum: General
Topic: Protected RouterBOOT
Replies: 116
Views: 28444

Re: Protected RouterBOOT

To enable protected RouterBOOT, you have to update board backup BIOS to v3.24. This backup BIOS package can be downloaded here: http://www.mikrotik.com/download/share/protected_routerboot_v3_24_enable_6_29_1_mipsbe.dpk More info here: http://wiki.mikrotik.com/wiki/Manual:RouterBOARD_settings#Protect...
by PaulsMT
Mon Jan 18, 2016 1:27 pm
Forum: RouterBOARD hardware
Topic: RB260GSP sporadic PoE Issue
Replies: 7
Views: 1989

Re: RB260GSP sporadic PoE Issue

You can try the following things to make 260GSP work more stable: Use only original power supply 24v 2,5 A. In most cases when input or output voltage is not stable (caused by unstable PSU, using long cables which causes voltage drop, or by powered device), the PoE In long cable can fix the reboot p...
by PaulsMT
Fri Jan 15, 2016 2:26 pm
Forum: Scripting
Topic: Return value of /ppp secret find command
Replies: 1
Views: 738

Re: Return value of /ppp secret find command

Find command - Returns list of internal numbers for items that are matched by given expression: To get values, you can use get+find command: :put [/ppp secret get [/ppp secret find name="myPPPOEClient"]] of "if" operator: :if ([:len [/ppp secret find name="myPPPOEClient"]]>0) do={:put "Do something"}
by PaulsMT
Fri Jan 15, 2016 2:23 pm
Forum: Scripting
Topic: What is wrong with this Script ????
Replies: 14
Views: 1858

Re: What is wrong with this Script ????

Since RouterOS 6.x simple queues target-addresses and interface parameters are joined into one "target" parameter. This code will work if there will be target with adrress=(192.168.100." . $i."/32) and total-bytes more than 5242880 { :local traf; :for i from=1 to= 254 do={ :if ([:len [/queue simple ...
by PaulsMT
Thu Jan 14, 2016 12:59 pm
Forum: RouterBOARD hardware
Topic: Cannot netinstall a CRS125 due to reboot loop
Replies: 4
Views: 1975

Re: Cannot netinstall a CRS125 due to reboot loop

First please try to boot the board with backup BIOS: Enter BIOS settings while board boots (Press any key within 2 seconds to enter setup), and press: b - booter options 2 - force backup-booter loading And exit bios (x - exit setup) If the board is able to find kernel, log in and update your BIOS to...
by PaulsMT
Wed Jan 13, 2016 12:05 pm
Forum: Wireless Networking
Topic: slow nv2, big ping, unstable speed, low tx speed
Replies: 24
Views: 3028

Re: slow nv2, big ping, unstable speed, low tx speed

Wireless-cm2 is the latest wireless package, it contains more optimizations compared to the wireless-fp. We suggest to use cm2 package if it's possible.
by PaulsMT
Wed Jan 13, 2016 11:52 am
Forum: Beginner Basics
Topic: DynaDish as a Bridge
Replies: 3
Views: 1180

Re: DynaDish as a Bridge

Using AP-bridge mode you have to simply create a bridge, and add both - wlan and ether to this created bridge: /interface bridge add /interface bridge port add bridge=bridge1 interface=wlan1 /interface bridge port add bridge=bridge1 interface=ether1 If you want to bridge from station side, you also ...
by PaulsMT
Wed Jan 13, 2016 11:01 am
Forum: Wireless Networking
Topic: slow nv2, big ping, unstable speed, low tx speed
Replies: 24
Views: 3028

Re: slow nv2, big ping, unstable speed, low tx speed

Are you using default wireless settings on both sides ? Check if there is set max channel-width, also look if on both ends is enabled fastest bands, try to repeat tests with whole range of supported frequencies. Check if both chains are enabled (tx-chains=0,1 rx-chains=0,1): /interface wireless prin...
by PaulsMT
Mon Jan 11, 2016 4:33 pm
Forum: RouterBOARD hardware
Topic: RB260GSP POE max output?
Replies: 2
Views: 1384

Re: RB260GSP POE max output?

With original power supply RB260GSP should power these devices without problems.

Note, that there can situations, when powered device requires more current at the starting moment, then on regular load, in such situation you should set PoE Out to "on" mode.
by PaulsMT
Mon Jan 11, 2016 4:21 pm
Forum: RouterBOARD hardware
Topic: [Wanted] small ethernet switch - passive PoE in + out
Replies: 4
Views: 1220

Re: [Wanted] small ethernet switch - passive PoE in + out

Stable issues have been seen in cases when 260GSP are powered with weak power supply, and in cases when powered devices are attached with long ethernet cables.

In combination with the original power supply and enbaled long cable feature, it will be completely stable.
by PaulsMT
Mon Jan 11, 2016 3:24 pm
Forum: General
Topic: Reset for RB-2011L-IN ??
Replies: 1
Views: 461

Re: Reset for RB-2011L-IN ??

Instruction here is correct, if there is problem with reset button, you can also use CLI to reset the board: /system reset-configuration and if this is not possible, use jumper hole to erease configuration : http://wiki.mikrotik.com/wiki/Manual:Reset#Jumper_hole_reset If the reset button is working ...
by PaulsMT
Tue Jan 05, 2016 8:13 am
Forum: Scripting
Topic: get supported-bands not working in 6.33
Replies: 5
Views: 1650

Re: get supported-bands not working in 6.33

You can use "hw-info" to see all possible bands, channel widths, and frequency ranges of device:

:put [interface wireless info hw-info wlan1]
by PaulsMT
Mon Dec 21, 2015 9:55 am
Forum: Scripting
Topic: dump traceroute to file
Replies: 12
Views: 4301

Re: dump traceroute to file

WHOLEY FANTASTIC-NESS!!!! it works on 6.33 but not on 6.29 I suspect some weird version bug... but that gets me in the right direction. curious if it will append...for me but , I'm not complaining.! Thank you :execute is a new feature, you will find it only starting from RouterOS 6.30 By the way, t...
by PaulsMT
Fri Dec 18, 2015 10:13 am
Forum: Scripting
Topic: dump traceroute to file
Replies: 12
Views: 4301

Re: dump traceroute to file

You can also save console output with :execute command. With this example you will get 5 second traceroute output saved to TRACEROUTE.txt.

:execute {/tool traceroute 8.8.8.8 duration=5} file=TRACEROUTE
by PaulsMT
Mon Dec 07, 2015 3:10 pm
Forum: General
Topic: # BUG !!! INTERFACE - ETHER - POWER-CYCLE-PING-ADDRESS #
Replies: 14
Views: 3324

Re: # BUG !!! INTERFACE - ETHER - POWER-CYCLE-PING-ADDRESS #

I've upgraded bridging RB750UP to 6.33.2, Power-Cycle-Ping is fixed -- THANKS MT! I wonder how often powered devices are pinged? Power Cycle Ping Timeout value? What if my device starts to reply ping in 5-10-15 minutes after powered on (f.e. Cambium heater applied when cold weather), but I want to ...
by PaulsMT
Mon Dec 07, 2015 12:00 pm
Forum: Beginner Basics
Topic: Problems setting DNS?
Replies: 3
Views: 629

Re: Problems setting DNS?

Can you please provide steps how to repeat this issue? I didn't found any problems using Webfig with RouterOS 6.33.3
by PaulsMT
Mon Dec 07, 2015 11:11 am
Forum: Scripting
Topic: Error sending Email AUTH method not support
Replies: 6
Views: 1738

Re: Error sending Email AUTH method not support

Please try to add email debugging:

/system logging add topics=e-mail,debug

Run email send command from terminal, and with scheduler, look at the log output.

Also please check if server address is still the same in /tool e-mail print
by PaulsMT
Tue Dec 01, 2015 8:20 am
Forum: RouterBOARD hardware
Topic: PoE with 750UP r2
Replies: 9
Views: 1911

Re: PoE with 750UP r2

Also please check IP phone POE-in pinout, if it differs from Mikrotik used standard ( 4,5 (+) and 7,8 (-). ), you should use a crossover cable.

If this does not help check the output of:

/interface ethernet poe monitor [find]
by PaulsMT
Mon Nov 30, 2015 5:42 pm
Forum: Scripting
Topic: Get dhcp-client gateway
Replies: 2
Views: 1196

Re: Get dhcp-client gateway

Should work with:
{
:local dhcpIP [/ip dhcp-client get [find interface=ether1] gateway];
:local Gateways "$dhcpIP,192.168.10.1,192.168.10.2"
:put $Gateways
}


Check with
:put [/ip dhcp-client get [find interface=ether1] gateway]


(in your case interface=ether1-gateway)
by PaulsMT
Mon Nov 30, 2015 1:45 pm
Forum: General
Topic: # BUG !!! INTERFACE - ETHER - POWER-CYCLE-PING-ADDRESS #
Replies: 14
Views: 3324

Re: # BUG !!! INTERFACE - ETHER - POWER-CYCLE-PING-ADDRESS #

At the moment fix for this bug is available in our RC version, and also will be included in the next bugfix version.
by PaulsMT
Fri Nov 20, 2015 5:29 pm
Forum: General
Topic: # BUG !!! INTERFACE - ETHER - POWER-CYCLE-PING-ADDRESS #
Replies: 14
Views: 3324

Re: # BUG !!! INTERFACE - ETHER - POWER-CYCLE-PING-ADDRESS #

Thanks for reporting, I just reproduced this bug. We will try to fix this soon.
by PaulsMT
Thu Nov 19, 2015 3:03 pm
Forum: Scripting
Topic: script for interface traffic
Replies: 3
Views: 2352

Re: script for interface traffic

If you don't use snmp, you can get these values with scripting. Use this script as an example, modify it to send the output over sms, email or other..: { :local iname; :local monitor; :local speedRX; :local speedTX; :local mbpsRX; :local mbpsTX; :foreach interface in=[/interface find] do={ :delay 10...
by PaulsMT
Tue Nov 17, 2015 1:51 pm
Forum: Scripting
Topic: PING LOSS TEST for all ip in arp table and log/email
Replies: 2
Views: 1197

Re: PING LOSS TEST for all ip in arp table and log/email NEED HELP

This should work:


{
:local re
:local relo 99

:foreach i in=[/ip arp find interface=bridge2wew] do={
:local address [/ip arp get $i address]
:set $re [/ping address="$address" size=1500 interval=20ms count=100]
:if ($relo > $re) do={/log info "IP $address Received $re"}
}
}
by PaulsMT
Tue Nov 17, 2015 12:13 pm
Forum: General
Topic: Web Proxy not working .. with screenshoot
Replies: 14
Views: 4069

Re: Web Proxy not working .. with screenshoot

Your NAT rule will capture only port 80, coming from interface ether2, with source address 192.168.13.0/24. Make sure that NAT parameters are set correctly.

Web proxy should work fine.
by PaulsMT
Fri Nov 13, 2015 10:22 am
Forum: RouterBOARD hardware
Topic: Are Mikrotik solutions selectable or simultaneous dual band?
Replies: 2
Views: 436

Re: Are Mikrotik solutions selectable or simultaneous dual band?

With 2 wireless cards you will get simultaneous dual band.
by PaulsMT
Wed Nov 11, 2015 12:15 pm
Forum: General
Topic: # BUG !!! INTERFACE - ETHER - POWER-CYCLE-PING-ADDRESS #
Replies: 14
Views: 3324

Re: # BUG !!! INTERFACE - ETHER - POWER-CYCLE-PING-ADDRESS #

PeterDoBrasil - You should try with 6.33 version. Another bug? 2015-11-09 16-56-23 Скриншот экрана.png Why does it reboot my PoE device while it's online? And what about "grace period" to NOT reboot while device is starting just after power cycle and before it become ready to ping reply? Poe board s...
by PaulsMT
Wed Nov 11, 2015 9:31 am
Forum: Scripting
Topic: Script to generate ISP fault complaint.
Replies: 4
Views: 907

Re: Script to generate ISP fault complaint.

You can use this as an example, Here is down script - will start count timeout in seconds: { :global work true :global timeout 0 :while ($work=true) do={ :set $timeout ($timeout +1); :delay 1s; } } Up script, will stop down script loop by changing $work state, and read timeout value, if uptime is mo...
by PaulsMT
Tue Nov 10, 2015 12:24 pm
Forum: Beginner Basics
Topic: Redirect HTTP traffic to internal proxy
Replies: 3
Views: 1985

Re: Redirect HTTP traffic to internal proxy

This should fix the problem:
http://wiki.mikrotik.com/wiki/Hairpin_NAT


In your case:
/ip firewall nat add chain=srcnat src-address=192.168.88.0/24 dst-address=192.168.88.252 protocol=tcp dst-port=3128 out-interface=<SERVER INTERFACE> action=masquerade
by PaulsMT
Tue Nov 10, 2015 9:22 am
Forum: RouterBOARD hardware
Topic: rb433 reboot loop
Replies: 2
Views: 625

Re: rb433 reboot loop

Try to reinstall this device with Netinstall:
http://wiki.mikrotik.com/wiki/Manual:Netinstall

After installation upgrade board BIOS:
/system routerboard upgrade
by PaulsMT
Tue Nov 10, 2015 8:31 am
Forum: General
Topic: port forwarding issue
Replies: 1
Views: 284

Re: port forwarding issue

/ip firewall nat add action=dst-nat chain=dstnat dst-address=202.59.70.90 port=<ANY PORT> protocol=tcp to-addresses=192.168.5.155 to-ports=5551 Also add masquerade or src-nat rule for returning packets, for example: add action=masquerade chain=srcnat out-interface=ether1 Mikrotik NAT: http://wiki.mi...
by PaulsMT
Tue Nov 10, 2015 8:15 am
Forum: General
Topic: ether2 as gateway
Replies: 3
Views: 661

Re: ether2 as gateway

It is possible to see the board default configuration with command: /system default-configuration print You can do little changes in this script to change WAN and LAN ports, after modifying the script do: 1. remove any configuration you have: /system reset-configuration skip-backup=yes no-defaults=y...
by PaulsMT
Tue Nov 10, 2015 7:36 am
Forum: RouterBOARD hardware
Topic: RB mAP2n can't boot
Replies: 1
Views: 538

Re: RB mAP2n can't boot

Try to use latest Netinstall: http://www.mikrotik.com/download The board appears, try to reinstall with latest RouterOS. If you are able to login to your board, you can try with command: /system routerboard settings set boot-device=try-ethernet-once-then-nand Restart the board with connected ether1 ...
by PaulsMT
Mon Nov 09, 2015 5:20 pm
Forum: Scripting
Topic: script for change public IP every hour
Replies: 12
Views: 3341

Re: script for change public IP every hour

$IP&0.0.0.255 Very cool!!! IMHO, this should be documented in the Wiki, preferably with some example like that. Right now, the bitwise operators give off the impression they work only for integers, and not between two IPs (which I understand are treated as integers "under the hood", but still - the...
by PaulsMT
Mon Nov 09, 2015 4:50 pm
Forum: Scripting
Topic: script for change public IP every hour
Replies: 12
Views: 3341

Re: script for change public IP every hour

The problem here is with pick command - picking from 6th digit to 9th digit works fine with "8.8.8.x" but it fails with higher IPs because starting from 6th to 9th digit for IP "192.168.16.x" will give you different output (6.1) Best solution is to use Bitwise operators to only take specific part of...
by PaulsMT
Mon Nov 09, 2015 1:44 pm
Forum: Scripting
Topic: script send uptime my routeros to email
Replies: 2
Views: 1099

Re: script send uptime my routeros to email

First you should configure your email: http://wiki.mikrotik.com/wiki/Manual:Tools/email Then use script, you can also add any other information or file to this script... { :local uptime [/system resource get uptime]; /tool e-mail send to="xxxxxxxx@xxxxx.com" subject="Some text" body="$uptime" start-...
by PaulsMT
Mon Nov 09, 2015 12:07 pm
Forum: Scripting
Topic: Address-list
Replies: 1
Views: 412

Re: Address-list

So you want to print only AllowInet lists ?

Can do this with
/ip firewall address-list print where list=AllowInet
by PaulsMT
Mon Nov 09, 2015 12:03 pm
Forum: Scripting
Topic: how to activate an SSTP interface only until next reboot?
Replies: 1
Views: 477

Re: how to activate an SSTP interface only until next reboot?

You can do this with scheduler:

/system scheduler add name=SSTP start-time=startup on-event={/interface sstp-client set sstp-out1 disabled=yes}

So on every startup SSTP will be disabled
by PaulsMT
Fri Nov 06, 2015 3:43 pm
Forum: General
Topic: PORT FORWARDING TO INNER NETWORK
Replies: 2
Views: 560

Re: PORT FORWARDING TO INNER NETWORK

You can forward already forwarded packets from your ADSL router, if the specified destination address/port will match, then the packets will be forwarded: 1. Packet from public network will reach your ADSL router with destination-ip= <ADSL public IP> on port 7777 2. Packet will be forwarded from ADS...
by PaulsMT
Fri Oct 30, 2015 3:12 pm
Forum: General
Topic: queue simple max-limit working with UDP but not with TCP on 2011UiAS-2HnD
Replies: 6
Views: 715

Re: queue simple max-limit working with UDP but not with TCP on 2011UiAS-2HnD

Do you get the same results if you create manually TCP traffic (downloading files...)? Are you using latest rOS ? You should check if the configuration and test conditions are exactly the same on both devices. If you still see queues performance differences, you should write to Mikrotik support, wit...
by PaulsMT
Fri Oct 30, 2015 12:01 pm
Forum: Beginner Basics
Topic: Needing help on clearing DHCP Leases after Reboot
Replies: 7
Views: 1820

Re: Needing help on clearing DHCP Leases after Reboot

You can also set lease time to very small time interval, it should solve the problem.

for e.g.
/ip dhcp-server set lease-time=15s
by PaulsMT
Fri Oct 30, 2015 10:50 am
Forum: General
Topic: queue simple max-limit working with UDP but not with TCP on 2011UiAS-2HnD
Replies: 6
Views: 715

Re: queue simple max-limit working with UDP but not with TCP on 2011UiAS-2HnD

Configuration is correct if you send packets trough ether1-gateway

/queue simple
add max-limit=15M/15M name=queue1 target=ether1-gateway

I have tested simple queues with iperf and also with regular TCP traffic, and on 6.32.3 everything seems to be working correctly.
by PaulsMT
Fri Oct 30, 2015 9:14 am
Forum: RouterBOARD hardware
Topic: Mikrotik DynaDish 5
Replies: 85
Views: 30803

Re: Mikrotik DynaDish 5

Can you please specify in more detail about this issue, which RouterOS verision are you using, how the board locks, are you unable to connect the board trough wifi and ether ? The board stops responding to pings. On the DynaDish, it will stop passing traffic and be non-resposive to anything other t...
by PaulsMT
Fri Oct 30, 2015 9:10 am
Forum: RouterBOARD hardware
Topic: crs125-24g-1s-2hnd-in
Replies: 4
Views: 869

Re: crs125-24g-1s-2hnd-in

By default all CRS interfaces are switched, this allows you to use wire speed switching, also this means that packets will not bet sent to CPU, and your RouterOS configurations will not apply to switched ports. To use all RouterOS features on CRS you have to send packets to CPU, or tu use regular ro...
by PaulsMT
Fri Oct 30, 2015 8:51 am
Forum: RouterBOARD hardware
Topic: Mikrotik DynaDish 5
Replies: 85
Views: 30803

Re: Mikrotik DynaDish 5

I have one 6.81km (4.23mi) link going right now. I have had it up for a month or two. I would say that it performs about as well as the rest of our MT BHs. We generally use ARC dual polarity panels in an ARC integrated enclosure with RB922s. I do like the mount for the DynaDish. The capability to a...
by PaulsMT
Thu Oct 29, 2015 10:50 am
Forum: RouterBOARD hardware
Topic: Omnitik Radio stops working
Replies: 1
Views: 393

Re: Omnitik Radio stops working

Please try to use latest RouterOS version:
http://www.mikrotik.com/download

Also enable wireless-cm package:
/system package enable wireless-cm2

If the problem remains, write to Mikrotik Support:
http://www.mikrotik.com/support.html
by PaulsMT
Thu Oct 29, 2015 10:43 am
Forum: General
Topic: how to make my x86 sntp server?
Replies: 2
Views: 294

Re: how to make my x86 sntp server?

Yes it's possible, you only have to download NTP package:

More info can be found here:
http://wiki.mikrotik.com/wiki/Setup_local_NTP_servers

Extra packages can be downloaded here:
http://www.mikrotik.com/download
by PaulsMT
Thu Oct 29, 2015 9:03 am
Forum: General
Topic: RB951G-2HnD with DLINK DWM-157
Replies: 10
Views: 3580

Re: RB951G-2HnD with DLINK DWM-157

Guys I am so much frustrated!!!! I have DWM-157 Hardware revision D (latest) I also have RB951G-2HnD with latest RouterOs (6.32.3) on it... I can't get it to work... I can see the device under System->Resources->USB However there are no new ports created, and I can't do anything else. I have tried ...
by PaulsMT
Wed Oct 28, 2015 7:38 pm
Forum: General
Topic: v6.33rc release candidate (final testing)
Replies: 203
Views: 37302

Re: v6.33rc release candidate (final testing)

which version is best installed on the router (MikroTik RB951Ui-2HnD). I need a stable job, once set up and forget. It is the current version (6.33RC36) stable and reliable? or better put 6.32.3 :?: :) Definitely the most reliable version is the bugfix version, it has all known bugs fixed. Here is ...
by PaulsMT
Wed Oct 28, 2015 7:33 pm
Forum: General
Topic: RB2001Uias-RM with Somple Config Stops Routing, anyone else?
Replies: 2
Views: 598

Re: RB2001Uias-RM with Somple Config Stops Routing, anyone else?

First you should update your board to the latest RouterOS:

If the problem repeats, paste your log output here, or send the supout file to Mikrotik support department:
http://www.mikrotik.com/support.html
http://wiki.mikrotik.com/wiki/Manual:Su ... utput_File
by PaulsMT
Wed Oct 28, 2015 7:16 pm
Forum: General
Topic: router is trying to connect to this after been rebooted?
Replies: 4
Views: 819

Re: router is trying to connect to this after been rebooted?

UDP on port 53 is a DNS requests which goes to server 74.116.184.28

Check this topic if requests continues:
http://forum.mikrotik.com/viewtopic.php?t=73057
by PaulsMT
Tue Oct 27, 2015 7:37 am
Forum: Beginner Basics
Topic: Bridge configuration
Replies: 3
Views: 525

Re: Bridge configuration

All you need to do is 1. Put both interfaces in one bridge /interface bridge add name=bridge /interface bridge port add bridge=bridge interface=ether1 add bridge=bridge interface=wlan1 2. Change IP address interface from ether1 to bridge interface. 3. Create or change DHCP server on bridge interface.
by PaulsMT
Mon Oct 26, 2015 9:26 am
Forum: Scripting
Topic: Change connect-to via script - variable - failure: dns name does not exist
Replies: 2
Views: 641

Re: Change connect-to via script - variable - failure: dns name does not exist

You have to remove "http://" from $line,with this command you can leave string starting from "www"

{
:local line "http://www.google.com"
:local nline ([:pick $line [find $line "www"] [:len $line]])
:do {:put [resolve $nline]} on-error={:put "DNS Does not exist for $nline"}
}
by PaulsMT
Fri Oct 23, 2015 12:22 pm
Forum: Scripting
Topic: # Send email to User before reach limit-bytes-out #
Replies: 3
Views: 646

Re: # Send email to User before reach limit-bytes-out #

{ :foreach i in=[/ip hotspot user find where email~"@"] do={ :local mail [/ip hotspot user get $i email] :local mac [/ip hotspot user get $i mac-address ]; :put ("$mail" . " $mac"); } } This will check only users with typed some email address, and will get email and mac address for each user
by PaulsMT
Sun Oct 18, 2015 8:43 pm
Forum: General
Topic: 10G links on 600mbps only
Replies: 6
Views: 1307

Re: 10G links on 600mbps only

Traffic generator packet sizes can be changed with command /tool traffic-generator stream set packet-size= Also to make test more close real life, use random ranges feature in traffic generator, to simulate multiple streams with different source addresses/ ports: This example show how to create conf...
by PaulsMT
Sun Oct 18, 2015 8:23 pm
Forum: Beginner Basics
Topic: Block internet access for specific ip
Replies: 3
Views: 2027

Re: Block internet access for specific ip

You can use multiple drop/accept rules with multiple time parameters

/ip firewall filter add time=

Time format is described here:

Time ::= Start-End,Day
Start -- 0s..1d (time interval)
End -- 0s..1d (time interval)
Day ::= sun|mon|tue|wed|thu|fri|sat[,Day*]
by PaulsMT
Sun Oct 18, 2015 8:13 pm
Forum: Beginner Basics
Topic: Use WiFi network as WAN
Replies: 2
Views: 5592

Re: Use WiFi network as WAN

Yes it's possible, simply make same settings as neighbor AP, in wireless security profiles, and wireless interface. change mode to station.

Add DHCP client on your wireless interface.

Then configure DHCP server for your LAN interfaces.
by PaulsMT
Fri Oct 09, 2015 8:06 am
Forum: Beginner Basics
Topic: mAP 2n - Slow, need set up help
Replies: 4
Views: 673

Re: mAP 2n - Slow, need set up help

Can you please paste your wireless configuration ?

/interface wireless print advanced
by PaulsMT
Fri Oct 09, 2015 7:51 am
Forum: Scripting
Topic: Simple queue not working in mikrotik V.6.15
Replies: 8
Views: 2063

Re: Simple queue not working in mikrotik V.6.15

This example: /system script add name=queues source={ :for i from=2 to=254 do={ /queue simple add target=("192.168.168.". $i . "/32") max-limit=1000000/1000000 burst-limit=5000000/5000000 burst-threshold=900000/900000 burst-time=180/180; } } /system script run queues Will add new 253 queues with tar...
by PaulsMT
Thu Oct 08, 2015 7:34 pm
Forum: Scripting
Topic: passing variable to script
Replies: 5
Views: 1249

Re: passing variable to script

Create global variable with some value (username1)

:global variable username1

Use $variable in your script. When you need, simply change the value of specified variable:

:global variable username2

This way you will be able to run same script, by only changing one variable.
by PaulsMT
Thu Oct 08, 2015 7:20 pm
Forum: Beginner Basics
Topic: Will pay for an experienced Microtik SXT installer to examine my config
Replies: 3
Views: 548

Re: Will pay for an experienced Microtik SXT installer to examine my config

Higher channel width can increase throughput, specially in conditions when same frequency is used in the area. You can increase wireless speed by choosing most unused frequency. To see frequency usage run this command in terminal: /interface wireless spectral-scan wlan1 range=5180-5800 Try to change...
by PaulsMT
Thu Oct 08, 2015 5:44 pm
Forum: Scripting
Topic: Simple queue not working in mikrotik V.6.15
Replies: 8
Views: 2063

Re: Simple queue not working in mikrotik V.6.15

Can you specify what exactly is not working?
by PaulsMT
Thu Oct 08, 2015 4:12 pm
Forum: Scripting
Topic: Simple queue not working in mikrotik V.6.15
Replies: 8
Views: 2063

Re: Simple queue not working in mikrotik V.6.15

This should work, since V6.x "target-address=" types as "target="

{
:for i from=2 to=254 do={
/queue simple add target=("192.168.168.". $i . "/32") max-limit=1000000/1000000 burst-limit=5000000/5000000 burst-threshold=900000/900000 burst-time=180/180;
}
}
by PaulsMT
Thu Oct 08, 2015 2:15 pm
Forum: RouterBOARD hardware
Topic: RouterBOARD 260GS POE IN
Replies: 1
Views: 529

Re: RouterBOARD 260GS POE IN

Routerboard 260GS supports 6 V - 31 V input voltage, this means you can power this board only with passive POE injector:

http://routerboard.com/RBGPOE
http://routerboard.com/RB260GS
by PaulsMT
Thu Oct 08, 2015 2:01 pm
Forum: General
Topic: If PoE-in + DC power supply connected = redundant power?
Replies: 7
Views: 2676

Re: If PoE-in + DC power supply connected = redundant power?

All our devices with POE-In and DC connector supports power redundancy, and it's completely safe to use both power sources, as long they are in allowed voltage range.
by PaulsMT
Thu Oct 08, 2015 1:22 pm
Forum: General
Topic: Mikrotik 5.18, RB 450G, Speed limit for facebook, youtube, and torrent traffic
Replies: 3
Views: 2290

Re: Mikrotik 5.18, RB 450G, Speed limit for facebook, youtube, and torrent traffic

First you should mark all packets from those connections with Firewall Mangle: http://wiki.mikrotik.com/wiki/Manual:IP/Firewall/Mangle When packets are marked, you can apply queues tree on them: http://wiki.mikrotik.com/wiki/Manual:Queue Use PCQ to share bandwidth equally on every host: http://wiki....
by PaulsMT
Thu Oct 08, 2015 11:15 am
Forum: Beginner Basics
Topic: Hairpinning problem (maybe!)
Replies: 3
Views: 667

Re: Hairpinning problem (maybe!)

Your NAT rule no masqurades only one src IP: 192.168.1.0
Try to change it with src-address=192.168.1.0/24

Here is Hairpin manual for same scenarion.
http://wiki.mikrotik.com/wiki/Hairpin_NAT
by PaulsMT
Thu Oct 08, 2015 11:05 am
Forum: Beginner Basics
Topic: Load Balancing/Aggregation with 4 isp
Replies: 1
Views: 514

Re: Load Balancing/Aggregation with 4 isp

PCC load balance can be used on with multiple WANs

Here is described in detail how PCC works:
http://wiki.mikrotik.com/wiki/How_PCC_w ... eginner%29

And here is manual for configuring PCC on your Mikrotik
http://wiki.mikrotik.com/wiki/Manual:PCC
by PaulsMT
Thu Oct 08, 2015 10:59 am
Forum: Beginner Basics
Topic: Connection split to TWO different LAN
Replies: 1
Views: 440

Re: Connection split to TWO different LAN

If you want to split connection speed only between both subnets, you can use simple queues: http://wiki.mikrotik.com/wiki/Manual:Queue#Simple_Queues But if you want to split both subnets, and give equal bandwidth speed to every host, you should use Queue tree http://wiki.mikrotik.com/wiki/Manual:Que...
by PaulsMT
Thu Oct 08, 2015 10:43 am
Forum: General
Topic: RB951G-2HnD default-config doesn't get applied
Replies: 1
Views: 1317

Re: RB951G-2HnD default-config doesn't get applied

First I would suggest you to reinstall this device with Netinstall to the latest RouterOS: http://wiki.mikrotik.com/wiki/Manual:Netinstall http://www.mikrotik.com/download If default configuration is not on the board use Winbox to connect the board with MAC address http://wiki.mikrotik.com/wiki/Manu...
by PaulsMT
Thu Oct 08, 2015 10:35 am
Forum: General
Topic: NAT port forwarding issue
Replies: 1
Views: 212

Re: NAT port forwarding issue

It should work in both ways. can you paste your NAT configuration ?

/ip firewall nat export
by PaulsMT
Fri Sep 25, 2015 1:29 pm
Forum: Scripting
Topic: shutting down interfaces at a specific time
Replies: 3
Views: 916

Re: shutting down interfaces at a specific time

If You want to run only one command on specific time, you don't need a script, you can just add scheduler: to disable interface at 22:00 /system scheduler add start-time=22:00:00 on-event={:interface ethernet disable ether5} second scheduler to enable interface at 6:00 /system scheduler add start-ti...
by PaulsMT
Thu Sep 24, 2015 2:16 pm
Forum: RouterBOARD hardware
Topic: omnitik going nuts
Replies: 7
Views: 1147

Re: omnitik going nuts

Please use netinstall ro reinstall this device to the latest RouterOS version: http://wiki.mikrotik.com/wiki/Manual:Netinstall Also upgrade BIOS: /system routerboard upgrade If the problem continiues, send supout file to mikrotik support: http://www.mikrotik.com/support.html So we could see if the p...
by PaulsMT
Thu Sep 24, 2015 1:47 pm
Forum: Beginner Basics
Topic: Quistion: System Package
Replies: 2
Views: 333

Re: Quistion: System Package

Here is general Mikrotik manual:
http://wiki.mikrotik.com/wiki/Manual:TOC

And here you will find detailed info about RouterOS packages:
http://wiki.mikrotik.com/wiki/Manual:System/Packages
by PaulsMT
Thu Sep 24, 2015 1:43 pm
Forum: Beginner Basics
Topic: Router Mirkrotik 750gl
Replies: 4
Views: 620

Re: Router Mirkrotik 750gl

Facebook uses HTTPs, this means, that you will need to use /ip firewall address-list to block all facebook IPs.

Then you can simply add drop rule with specified time:

/ip firewall filter
add action=drop chain=forward time=13h41m-13h42m,mon,tue,wed,thu,fri,sat address-list=FacebookIP-LIST
by PaulsMT
Wed Sep 23, 2015 5:18 pm
Forum: Beginner Basics
Topic: 2nd IPSEC VPN not Working
Replies: 3
Views: 583

Re: 2nd IPSEC VPN not Working

Can you post your ipsec config here ? Check if both sites have the same algorithms, has the same secret, correct peer addresses, make sure you have enabled tunnel mode, and also correct addresses in ipsec policy Also if you are using NAT you have to create additional accept rule for ipsec Here is ve...
by PaulsMT
Wed Sep 23, 2015 5:05 pm
Forum: Scripting
Topic: Interface Status Script
Replies: 1
Views: 2799

Re: Interface Status Script

running can be true or false, this code should work:

{
:if ([/interface ethernet get Ethernet5 running]=true) \
do={[/interface bridge enable Bridge2]} \
else={[/interface bridge disable Bridge2]}
}
by PaulsMT
Wed Sep 23, 2015 4:53 pm
Forum: Beginner Basics
Topic: RB750UP - Change Gateway to eth5
Replies: 8
Views: 1087

Re: RB750UP - Change Gateway to eth5

This line caused to fail: /ip address add address=192.168.88.1 interface=ether2-master network=192.168.88.0 Because 192.168.88.1/32 don't know how to communicate with whole 192.168.88.0/24 subnet You can change this with command: /ip address set [find address~"192.168.88."] address=192.168.88.1/24 N...
by PaulsMT
Thu Sep 17, 2015 6:21 pm
Forum: Beginner Basics
Topic: Trying to execute a script on rb750
Replies: 2
Views: 460

Re: Trying to execute a script on rb750

Since RouterOS v6 target-addresses and interface parameters are joined into one target parameter. This script should work { :for i from=26 to=100 do={/queue simple add target=("192.168.168.".$i."/32") max-limit=384000/768000 burst-limit=768000/1024000 burst-threshold=768000/768000 burst-time=15/15} }
by PaulsMT
Wed Jul 08, 2015 2:02 pm
Forum: Beginner Basics
Topic: Mikrotik Firewall
Replies: 3
Views: 708

Re: Mikrotik Firewall

You can add first rules to accept tcp,udp traffic on port 110,25: /ip firewall filter add chain=forward src-mac-address=D4:CA:6D:99:76:CF port=110,25 action=accept protocol=tcp /ip firewall filter add chain=forward src-mac-address=D4:CA:6D:99:76:CF port=110,25 action=accept protocol=udp And then blo...
by PaulsMT
Mon Jun 22, 2015 2:55 pm
Forum: Beginner Basics
Topic: PIM Routing - Which RouterBoard
Replies: 2
Views: 796

Re: PIM Routing - Which RouterBoard

PIM Routing is supported on all Routerboards, You just need to install multicast package on your device.

You can find Multicast packages here, under "Extra packages"
http://www.mikrotik.com/download
by PaulsMT
Mon Jun 22, 2015 11:43 am
Forum: Scripting
Topic: How to detect software down line on the opposite routerboard?
Replies: 1
Views: 536

Re: How to detect software down line on the opposite routerboard?

You can use ping to monitor neighbor interface: For example: { :local PING ([/ping 10.5.115.1 count=3]); :if ($PING > 2) do={:put "Interface up"}; :if ($PING = 0) do={:put "Interface down"}; } You can also do ARP ping if you don't have an IP address on that interface: ping arp-ping=yes interface=eth...
by PaulsMT
Mon Jun 22, 2015 11:04 am
Forum: RouterBOARD hardware
Topic: hEX lite CPU Speed
Replies: 2
Views: 1066

Re: hEX lite CPU Speed

Could You please send me the SN# of this device ? Sorry, but this must be some kind of mistake, You can fix this, by updating your RouterOS to the latest version: http://www.mikrotik.com/download After rOS update, upgrade your BIOS to the latest possible version with command: /system routerboard upg...
by PaulsMT
Fri Jun 19, 2015 1:22 pm
Forum: General
Topic: Any way to use packet sniffer with switched-only traffic ?
Replies: 2
Views: 1640

Re: Any way to use packet sniffer with switched-only traffic ?

Packet sniffer can capture and analyze packets that are going to, leaving or going through the router. When you are using switch, you have to pass these packets from switch chip to 'cpu' port. All traffic will be passed trought master port. This will allow you to capture and analyze these packets fr...
by PaulsMT
Fri Jun 19, 2015 10:36 am
Forum: General
Topic: 6.29.1 Internet Speed Drop
Replies: 5
Views: 876

Re: 6.29.1 Internet Speed Drop

Can You please describe in little more detail? What routerboard model, your configuratin, what type of traffic and testing method, so we could try to reproduce the same results.
Thanks.
by PaulsMT
Fri Jun 19, 2015 10:30 am
Forum: Beginner Basics
Topic: RouterBoard boots only with reset button pushed
Replies: 1
Views: 607

Re: RouterBoard boots only with reset button pushed

Seems likt there is some issue with your Main BIOS: http://wiki.mikrotik.com/wiki/Manual:RouterBOOT#Main_and_Backup_loaders If you are able to log into your board with Backup BIOS, try to upgrade again with command: /system routerboard upgrade; /system reboot. If this does not help, you can manualy ...
by PaulsMT
Wed Jun 17, 2015 10:47 am
Forum: Beginner Basics
Topic: Not able to browse all sites properly
Replies: 10
Views: 2278

Re: Not able to browse all sites properly

Also it would be good if you could send us the supout file from your device, so we could check your router configuration and see the cause of this issue.
http://wiki.mikrotik.com/wiki/Manual:Su ... utput_File

Email:
support@mikrotik.com
by PaulsMT
Wed Jun 17, 2015 9:56 am
Forum: Scripting
Topic: Substring from Variable
Replies: 2
Views: 1997

Re: Substring from Variable

{
:local IPADDR "192.168.1.1/24"
:local TEST [:pick $IPADDR 0 [:find $IPADDR "/"]];
:put $TEST
}
by PaulsMT
Wed Jun 17, 2015 9:52 am
Forum: Scripting
Topic: Using a variable within a string
Replies: 2
Views: 724

Re: Using a variable within a string

{
:global TEST "192.168.0.1"
:put ("$TEST" . "/24");
}
by PaulsMT
Wed Jun 17, 2015 9:48 am
Forum: Beginner Basics
Topic: Not able to browse all sites properly
Replies: 10
Views: 2278

Re: Not able to browse all sites properly

Can you repeat the same issues on the same sites ? Do you get stable ping from e.g. speedtest.net ?
/ping [:resolve speedtest.net]

Please check the log file, is there some disconnection or linking records?
by PaulsMT
Mon Jun 08, 2015 11:26 am
Forum: Scripting
Topic: scheduler script won't run , manual run O.K
Replies: 2
Views: 530

Re: scheduler script won't run , manual run O.K

Does the scheduller run this script, can you see run count ?

You can try to add some :delay in your scrept beginning.
by PaulsMT
Mon Jun 08, 2015 11:15 am
Forum: Scripting
Topic: Print users count on specific or all vlan interface
Replies: 2
Views: 735

Re: Print users count on specific or all vlan interface

With this command rOS will count all active interfaces with name ~"vlan"

/interface print count-only where name~"vlan" && running=yes
by PaulsMT
Fri Jun 05, 2015 3:11 pm
Forum: Beginner Basics
Topic: Shutdown Mikrotik OS first before switch POE power to off?
Replies: 3
Views: 692

Re: Shutdown Mikrotik OS first before switch POE power to off?

No, it's safe, and won't cause any damage!
by PaulsMT
Thu May 28, 2015 3:48 pm
Forum: Wireless Networking
Topic: NetMetal 5 AC ( 921UAGS-5SHPacT ) Triple Chain after upgrade to 6.29 Issue
Replies: 9
Views: 1246

Re: NetMetal 5 AC ( 921UAGS-5SHPacT ) Triple Chain after upgrade to 6.29 Issue

Can you describe in little more detail how did You get those speeds ? So we could try to reproduce this.
by PaulsMT
Thu May 28, 2015 3:23 pm
Forum: General
Topic: CRS keeps dropping 10Gbps Interfaces
Replies: 1
Views: 298

Re: CRS keeps dropping 10Gbps Interfaces

Please update your RouterOS to the latest version, it shoud fix this:
http://www.mikrotik.com/download
by PaulsMT
Thu May 28, 2015 3:20 pm
Forum: Wireless Networking
Topic: NetMetal 5 AC ( 921UAGS-5SHPacT ) Triple Chain after upgrade to 6.29 Issue
Replies: 9
Views: 1246

Re: NetMetal 5 AC ( 921UAGS-5SHPacT ) Triple Chain after upgrade to 6.29 Issue

Can you please describe in little more detail your test method ? Also copy your link status output with command:
/interface ethernet monitor [f]
by PaulsMT
Fri May 22, 2015 12:28 pm
Forum: Wireless Networking
Topic: mikrotik NetMetal 5 unable detect wireless interface
Replies: 6
Views: 1793

Re: mikrotik NetMetal 5 unable detect wireless interface

hello I bought 12 netmetal, 4netbox and upgrade all , but 4 netmetal and 1 netbox after upgrade lost wlan interface. in package list wireless is enable for fix them i use netinstall 5.28 but not fix and wlan is unavailable. please help me what i do tanx Please check if the wireless-FP package is en...
by PaulsMT
Fri May 22, 2015 8:35 am
Forum: Scripting
Topic: ssh to mikrotik & Print Active User in File not working
Replies: 2
Views: 561

Re: ssh to mikrotik & Print Active User in File not working

I am trying this /ppp active print count-only file=activeuser.txt but it's not creating file. I have tried it in 5.x and 6.x versions. Thanks for reporting! I will check if we can do something here. You can also use simple script for that { /file print file=ppp :delay 1 :local active [/ppp active p...
by PaulsMT
Mon May 18, 2015 7:53 am
Forum: General
Topic: Does the CRS226-24G-2S+RM have a fan?
Replies: 1
Views: 537

Re: Does the CRS226-24G-2S+RM have a fan?

Yes, CRS226-24G-2S+RM comes without fans.
by PaulsMT
Mon May 18, 2015 7:45 am
Forum: RouterBOARD hardware
Topic: CRS226-24G-2S+ and CCR1016-12S-1S+
Replies: 1
Views: 572

Re: CRS226-24G-2S+ and CCR1016-12S-1S+

Thanks for reporting, we found that this issue started in 6.28, and will be fixed in 6.29.

Can you repeat this if both CRS and CCR have 6.27 ? And have you tested if both running 6.29rc 20 ?

If you can repeat this with 6.27 or 6.29rc20, please let me know.
by PaulsMT
Fri May 15, 2015 1:26 pm
Forum: Scripting
Topic: Creating backup with name of device
Replies: 1
Views: 627

Re: Creating backup with name of device

Try to add \ before $
\$sysname

....":global sysname [/system identity get name]; /system backup save name=[:put \$sysname]"
by PaulsMT
Fri May 15, 2015 12:16 pm
Forum: Scripting
Topic: Execute if wireless interface is exist.
Replies: 2
Views: 1429

Re: Execute if wireless interface is exist.

This will check if the board has wireless interface.

{
:do {
:if ([:len [/interface wireless find ]]>0) do={:put "wireless found"}} on-error={:put "No wireless interface found"};
}
by PaulsMT
Tue May 12, 2015 9:47 am
Forum: Scripting
Topic: How can I log failures importing configuration
Replies: 9
Views: 1534

Re: How can I log failures importing configuration

If you are using rsc (export file) you can paste the file content in your terminal, and you will see if there are any errors.
by PaulsMT
Mon May 11, 2015 3:18 pm
Forum: General
Topic: Omnitik Station Client
Replies: 5
Views: 770

Re: Omnitik Station Client

Can you export your configuration ?

Do you want to make bridge between your LAN and Wireless interface, or you want to use routing ?
by PaulsMT
Mon May 11, 2015 2:44 pm
Forum: The Dude
Topic: Hi there I have a problem with my RB133 and RB411
Replies: 1
Views: 878

Re: Hi there I have a problem with my RB133 and RB411

From what version did you upgraded your board ? You should update your board license, if you upgraded the rOS from RouterOS 3.25, 4.0beta3 or older version. http://wiki.mikrotik.com/wiki/Manual:License#Upgrading_from_RouterOS_v3_.282009.29 To do this, just click on "Update license key" button in Win...
by PaulsMT
Mon May 11, 2015 2:33 pm
Forum: General
Topic: RB911G-5HPacD-NB
Replies: 1
Views: 339

Re: RB911G-5HPacD-NB

Please check if the wireless package is enabled:

/system package print

If the package is disabled do:

/system package enable wireless-fp

and reboot the board:

/system reboot


Check with:

/interface wireless print