Community discussions

MikroTik App

Search found 47 matches

by woro
Thu Apr 25, 2019 12:44 pm
Forum: Scripting
Topic: recent update broke script [SOLVED]
Replies: 3
Views: 975

Re: recent update broke script [SOLVED]

Check the fetch command. From v6.44 they removed the "http-content-type" option. You must now use the option http-header-field="Content-Type: xxx". Andrej Thanks, didn't notice this and it helped. One addition/clarification though: http-header-field="Content-Type: text/plain" did not work, but http...
by woro
Mon Mar 18, 2019 6:36 pm
Forum: Scripting
Topic: recent update broke script [SOLVED]
Replies: 3
Views: 975

recent update broke script [SOLVED]

Hi, I was running a script on my CAPsMAN to report device presence to an external REST service. At some point end of January this stopped working unnoticed. Since I didn't change anything with my script at this point in time I can only guess that some upgrade in the 6.43 line broke it. The script do...
by woro
Mon Dec 03, 2018 8:31 pm
Forum: General
Topic: tool kid-control
Replies: 59
Views: 22573

Re: tool kid-control

I'm still hoping someone can bring some insight into why I do not get firewall rules created in most of the cases? Currently never.
by woro
Sun Nov 18, 2018 11:50 pm
Forum: Scripting
Topic: persist state of a variable inbetween script runs
Replies: 1
Views: 639

Re: persist state of a variable inbetween script runs

Sorry for the beginner question.
Found it now by using :global variables.
by woro
Sat Nov 17, 2018 11:55 pm
Forum: Scripting
Topic: persist state of a variable inbetween script runs
Replies: 1
Views: 639

persist state of a variable inbetween script runs

Hi, I'm implementing a script which checks some local configuration and want to notify an external (rest)api of a change via /tool fetch. This is working fine already but it should run quite often and I was wondering if I can reduce the api access to just transmit changes. But for this I would need ...
by woro
Thu Nov 01, 2018 12:05 am
Forum: General
Topic: tool kid-control
Replies: 59
Views: 22573

Re: tool kid-control

Meanwhile I'm on 6.43.4 and the Tik App was updated as well recently to provide user friendly (first level) kid control feature. But still when I'm using winbox to enable/disable/configure kid-control I see incomplete firewall rules created (e.g. just for two devices instead of the configured three)...
by woro
Sat Jul 07, 2018 7:32 am
Forum: General
Topic: hAP ac2 crashes?
Replies: 5
Views: 1199

Re: hAP ac2 crashes?

Since the problem didn't happen since I posted I could not check for a broadcast storm yet. One of the hAP indeed has a VLAN for a device connected there which has its endpoint on the 2011. What I find strange though is that everything recovers but the two hAPs. Until a reboot they are completely no...
by woro
Fri Jul 06, 2018 7:10 pm
Forum: General
Topic: hAP ac2 crashes?
Replies: 5
Views: 1199

Re: hAP ac2 crashes?

I will check next time and record packets from a connected device.
Faulty switch I do not think. I have almost the identical one spare and connected it when it first happened with the same results.
by woro
Fri Jul 06, 2018 5:30 pm
Forum: General
Topic: hAP ac2 crashes?
Replies: 5
Views: 1199

hAP ac2 crashes?

Hi, I could need a few pointers how to debug an issue I'm seeing currently in my network. My rough setup looks like (only relevant parts): RB2011 (CAPsMAN controller and central router) | Netgear Switch | | hAP ac2 hAP ac2 (both CAPs managed by the controller) All three devices serve my wifi with th...
by woro
Fri Jun 08, 2018 12:43 pm
Forum: Beginner Basics
Topic: Hotspot with Usermanager - Vouchers/Users?
Replies: 2
Views: 871

Re: Hotspot with Usermanager - Vouchers/Users?

Looks quite interesting.
Is this app OSS (haven't found that information in the references)?
Does it only work on a quite clean MikroTik or in conjunction with more advanced setups like CAPsMAN etc.?
Is there any documentation what it configures on ROS level?
by woro
Fri Jun 08, 2018 12:30 pm
Forum: General
Topic: IPv6 WAN links fail over
Replies: 9
Views: 2198

Re: IPv6 WAN links fail over

I guess nothing changed with that yet?
I'm looking into solving the same issue.
by woro
Wed Apr 25, 2018 8:53 pm
Forum: Wireless Networking
Topic: flipping wireless client
Replies: 7
Views: 1542

Re: flipping wireless client [SOLVED]

Found the issue. The wlan1 interface was locally part of the wrong bridge (actually not really as it was controlled by CAPsMAN and even if it would be a local interface it would be correct on that bridge). The bridge then decided to use exactly the MAC of the wlan1 interface while there would have b...
by woro
Wed Apr 25, 2018 4:10 pm
Forum: Wireless Networking
Topic: flipping wireless client
Replies: 7
Views: 1542

Re: flipping wireless client

Indeed the wlan1 interface and a vlan bridge share the same MAC. No idea how that happened but also stupid question wlan1 wlan 1500 1600 2290 CC:2D:E0:C2:CF:8E 8 R bridge-vlan bridge 1500 1598 CC:2D:E0:C2:CF:8E The bridge does not seem to allow me to change the MAC? At least not in Winbox. And the M...
by woro
Wed Apr 25, 2018 12:53 pm
Forum: Wireless Networking
Topic: flipping wireless client
Replies: 7
Views: 1542

Re: flipping wireless client

Latest summary after more testing: Whenever a client connects to the 2G interface on the CAP it loses connection to capsman. Problably because of 08:26:28 interface,warning ether4-Office: bridge port received packet with own address as source address (cc:2d:e0:c2:cf:8e), probably loop ? This warning...
by woro
Wed Apr 25, 2018 12:22 pm
Forum: Wireless Networking
Topic: flipping wireless client
Replies: 7
Views: 1542

Re: flipping wireless client

And even more information. The whole thing seems to only happen when this certain device 2C:0E:3D:26:75:C7 moves to this certain CAP. I'm not sure if it only happens on 2G or also the 5G interface. At least there is another device registered at 5G permanently which does not trigger the behaviour. Th...
by woro
Wed Apr 25, 2018 12:15 pm
Forum: Wireless Networking
Topic: flipping wireless client
Replies: 7
Views: 1542

Re: flipping wireless client

ok, so it's really the cap losing connection: log from the cap 08:26:35 caps,info CAP disconnected from MikroTik (::ffff:192.168.250.254:5246) 08:26:37 caps,info CAP selected CAPsMAN MikroTik (4C:5E:0C:06:EA:46/6/0) 08:26:57 caps,info CAP connect to MikroTik (4C:5E:0C:06:EA:46/6/0) failed: timeout 0...
by woro
Wed Apr 25, 2018 11:56 am
Forum: Wireless Networking
Topic: flipping wireless client
Replies: 7
Views: 1542

flipping wireless client

Hi, I have a small capsman setup with three CAPs but running into user visible issues with a wifi client. It seems to me like it switches between two CAPs very often which also results in reported breaking connections which I do not really expect with capsman at all. The logging when that happens lo...
by woro
Sun Apr 22, 2018 11:01 pm
Forum: General
Topic: vlan-filtering
Replies: 6
Views: 1393

Re: vlan-filtering

I'm useless for Winbox related questions, I use it very rarely. But your two addresses from the same subnet attached to two interfaces in different VLANs are a voucher for trouble alone :-) Interesting. Actually I had indeed two IPs on the different bridges. But both bridges are supposed to work wi...
by woro
Sun Apr 22, 2018 10:34 pm
Forum: General
Topic: vlan-filtering
Replies: 6
Views: 1393

Re: vlan-filtering

So I think I'm getting there. vlan10 and vlan11 testing still missing but vlan1 works finally.

One thing I noticed though:
Using winbox I can connect to the IP of the vlan bridge but the device does not show up under neighbors which seems a bit strange to me. Is that to be expected?
by woro
Sun Apr 22, 2018 8:41 pm
Forum: General
Topic: vlan-filtering
Replies: 6
Views: 1393

Re: vlan-filtering

Thanks for your feedback. I think I'm getting closer but still my basic testcase is failing. I cannot connect to the device when connected via the ether1 interface from regular (non-vlan) network. This is the very basic thing which obviously needs to work. Other than that my configuration now looks ...
by woro
Sat Apr 21, 2018 10:41 pm
Forum: General
Topic: vlan-filtering
Replies: 6
Views: 1393

vlan-filtering

Hi, I'm struggling with the new vlan-filtering. My desired configuration: ether1 : VLAN trunk for PVID 1, 10 and 11 where 1 should be untagged (default) and 10 and 11 tagged ether5 : VLAN with PVID 10 (untagged) but also carrying PVID 11 tagged My setup as I understood is required since 6.41: - I ha...
by woro
Tue Apr 10, 2018 6:08 pm
Forum: Announcements
Topic: v6.41.4 [current]
Replies: 37
Views: 13862

Re: v6.41.4 [current]

woro, pepek, Simono - We are working on fixes for wireless improvements. Please note that this is "user forum". In order to contact MikroTik staff, you should write to support@mikrotik.com. Please do not expect that your problem will be resolved after you have posted that on forum. Yes, we might no...
by woro
Tue Apr 10, 2018 9:32 am
Forum: Announcements
Topic: v6.41.4 [current]
Replies: 37
Views: 13862

Re: v6.41.4 [current]

Still no fix for hAP ac2 poor WiFi performance unfortunatly.
Since I just ordered a few. Is there any pointer to more information about that one?
by woro
Mon Apr 09, 2018 9:11 am
Forum: General
Topic: failure: other tool running
Replies: 3
Views: 2201

Re: failure: other tool running

Yes, good point ;-) Ok, so I have no other tools active in this or any other winbox or cli session and I cannot remember that I started any and didn't stop it.
Therefore the question is: How to find out which tool is running as written in the first post?
by woro
Fri Apr 06, 2018 1:06 pm
Forum: General
Topic: failure: other tool running
Replies: 3
Views: 2201

failure: other tool running

Hi,

how to find which tool is actually running and preventing me from using certain other tools like here:

[admin@MikroTik] /interface wireless snooper> snoop
interface: wlan1
failure: other tool running
by woro
Thu Apr 05, 2018 1:03 pm
Forum: Wireless Networking
Topic: capsman wireless configuration
Replies: 2
Views: 934

Re: capsman wireless configuration

20MHz works but I'm a bit puzzled. When I set it to 20MHz and use my frequency scanner I still see the wifi network spanning 8 channels instead of what I would expect 4? So is only the extension-channel=Ce relevant for the behaviour and what does the 20MHz mean then? Is it 20MHz just for one channel...
by woro
Thu Apr 05, 2018 12:48 pm
Forum: Wireless Networking
Topic: capsman wireless configuration
Replies: 2
Views: 934

capsman wireless configuration

Hi, I'm trying to set up capsman with a configuration like this: [admin@MikroTik] /caps-man> configuration print 0 name="cfg1" mode=ap ssid="micasa" country=germany distance=indoors security.authentication-types=wpa2-psk security.encryption=aes-ccm security.passphrase="*******" datapath.bridge=bridg...
by woro
Wed Jul 12, 2017 12:20 pm
Forum: Virtualization
Topic: OpenWRT on MetaRouter and opkg
Replies: 1
Views: 2804

Re: OpenWRT on MetaRouter and opkg

Wondering the same. Did you get any information somewhere outside of this thread?
by woro
Mon Nov 21, 2016 9:54 pm
Forum: Scripting
Topic: dns update script
Replies: 0
Views: 1084

dns update script

Hi, I'm trying to get DNS update script running which adds DNS entries for DHCP leases. As a start I've used http://wiki.mikrotik.com/wiki/Setting_static_DNS_record_for_each_DHCP_lease I'm trying to use the last example but try to change it in a way that it does not remove entries which were (based ...
by woro
Mon Nov 14, 2016 10:10 pm
Forum: Beginner Basics
Topic: routing problem
Replies: 4
Views: 904

Re: routing problem

hmm, without the route it works and according to the packet sniff it looks like: 188.195.240.x -> 192.168.100.1:80 when I capture the ether2-Cable interface So my interpretation is that the modem has the correct routing towards the public IP. Now really the only difference in my setup is to make the...
by woro
Mon Nov 14, 2016 12:05 pm
Forum: Beginner Basics
Topic: routing problem
Replies: 4
Views: 904

Re: routing problem

Thanks for the pointer. But in this case I do not think that's the solution since the explicit routing I have added is configured in main table and in my tests I made sure that I do not end up in the wrong routing table since currently the only routing mark I'm using is when a connection is made fro...
by woro
Sun Nov 13, 2016 11:40 am
Forum: Beginner Basics
Topic: routing problem
Replies: 4
Views: 904

routing problem

Hi, somehow I think I make a stupid mistake in my setup but I cannot find it. The scenario is the following: - I've got two WAN links (one DSL, one cable) - the cable WAN link is connected to a cable modem running in bridge mode - the cable modem is listening with a webinterface on 192.168.100.1 I c...
by woro
Sun Nov 13, 2016 12:39 am
Forum: Beginner Basics
Topic: Clarification on multi wan mangling
Replies: 1
Views: 491

Clarification on multi wan mangling

Hi, recently I got my 2nd WAN link and polishing my RB2011 config since. One of the topics I'm not sure about is marking connections coming from the WAN links so the replies go back to the same link. All articles I found look pretty straightforward while I haven't found them working for me. What I'v...
by woro
Mon Sep 12, 2016 1:36 am
Forum: Beginner Basics
Topic: OpenVPN routing issues
Replies: 3
Views: 1056

Re: OpenVPN routing issues

Nice catch. You are right. I disabled now the "drop invalid" rule and everything seems to work fine.
What is the best practice in that case? I guess it's better to have the "drop invalid forward" and insert a accept rules inbetween the internal and vpn ip range?

Thanks again for the quick pointer!
by woro
Sun Sep 11, 2016 11:58 pm
Forum: Beginner Basics
Topic: OpenVPN routing issues
Replies: 3
Views: 1056

OpenVPN routing issues

Hi, apparently I'm not _the_ infrastructure/routing guy because I do not understand the issue I'm seeing. I was maintaining a simple Linux gateway which I replaced almost completely with a RB2011UiAS. What I left with the Linux gateway was the OpenVPN tunnel endpoint for roadwarriors because the Rou...
by woro
Thu Jan 28, 2016 6:58 pm
Forum: General
Topic: IPv6 autoconfiguration
Replies: 6
Views: 1147

Re: IPv6 autoconfiguration

Thanks a lot. Now I got it and it's working finally.
by woro
Thu Jan 28, 2016 1:10 pm
Forum: General
Topic: IPv6 autoconfiguration
Replies: 6
Views: 1147

Re: IPv6 autoconfiguration

I'm wondering if I have seen this as well. In any case I've now defined my address from the pool. That's hopefully fine for the beginning. But I still have a misunderstanding. So in my example I get from DHCPv6-PD an assignment with a /62 network. How can I create multiple /64 pools out of this whic...
by woro
Wed Jan 27, 2016 1:25 pm
Forum: General
Topic: IPv6 autoconfiguration
Replies: 6
Views: 1147

Re: IPv6 autoconfiguration

Somehow I seem to ask the wrong questions in this forum? Nobody any hint? Also asking because I now want ROS to provide a different IPv6 subnet on another interface which I tried somehow but it didn't accept my setting. I still think something in my basic configuration is not exactly as expected.
by woro
Wed Dec 30, 2015 10:14 am
Forum: General
Topic: v6.33.3 [current] is released!
Replies: 59
Views: 20894

Re: v6.33.3 [current] is released!

Not quite sure if this is new with 6.33.3 but pretty often the webfig becomes unresponsive and does not react on any clicks anymore. An F5 reload fixes it for a bit until it fails again within a few minutes.
by woro
Tue Nov 03, 2015 11:53 am
Forum: General
Topic: IPv6 autoconfiguration
Replies: 6
Views: 1147

IPv6 autoconfiguration

Hi, I've got an RB2011 since a while in the following scenario: DSL-Router <-> RB2011 <-> Clients The DSL Router uses an IPv6 tunnel provider and also supports DHCPv6-PD which is enabled. Now a few months ago I set everything up including IPv6 which worked all the time until now. I found that my cli...
by woro
Sun Oct 11, 2015 3:11 pm
Forum: Wireless Networking
Topic: WPA EAP setup pointers
Replies: 2
Views: 899

Re: WPA EAP setup pointers

Really no hints?
by woro
Mon Oct 05, 2015 11:41 pm
Forum: Beginner Basics
Topic: Mikrotik client for a Windows OpenVPN Server
Replies: 3
Views: 1244

Re: Mikrotik client for a Windows OpenVPN Server

According to your server setup you are using comp-lzo.

Mikrotik does not support LZO compression (unfortunately!!!).
If you can change this on the server side w/o a hassle you could try.
by woro
Mon Oct 05, 2015 10:42 pm
Forum: Wireless Networking
Topic: WPA EAP setup pointers
Replies: 2
Views: 899

Re: WPA EAP setup pointers

I found hints to "security profiles" under "wireless" where some settings need to be done (like described here http://forum.mikrotik.com/viewtopic.php?t=23185) but there are no security profiles in CAPsMAN? So how to do 802.1x with that?
by woro
Sun Oct 04, 2015 6:34 pm
Forum: Wireless Networking
Topic: WPA EAP setup pointers
Replies: 2
Views: 899

WPA EAP setup pointers

Hi, I'm trying to set up a (pretty simple I thought) usecase. I would like to open a CAPsMANv2 managed wifi SSID to authenticated users for which I would expect to use WPA(2) EAP. Now I also understood that for EAP you usually require a RADIUS server and also learned that userman should provide simp...
by woro
Mon Jun 15, 2015 2:50 pm
Forum: General
Topic: Simple QOS
Replies: 0
Views: 948

Simple QOS

Hi, I'm not too bad in networking but pretty new to QOS using queues. Currently I have two modifications for QOS in my RB2011 which are SSH connection and VOIP traffic priority which I got from different tutorials available on the net. I understand some basics like marking connections and packets bu...
by woro
Tue May 26, 2015 9:48 pm
Forum: Beginner Basics
Topic: VPN on dynamic IPs and overall feedback
Replies: 1
Views: 458

Re: VPN on dynamic IPs and overall feedback

I got OpenVPN server to work now. Not sure what I changed because actually almost nothing. While it was still failing to establish a connection I enabled ovpn extra logging and afterwards it worked. This sounds even unbelievable to me. Anyway the next thing I discovered is that Mikrotik's OVPN canno...
by woro
Sun May 24, 2015 1:10 am
Forum: Beginner Basics
Topic: VPN on dynamic IPs and overall feedback
Replies: 1
Views: 458

VPN on dynamic IPs and overall feedback

Hi, I've got my first Mikrotik device a few weeks ago and I was quite enthusiastic about the possibilities of Router OS compared to many other vendors. I was hoping to solve most of my usecases but finally it seems I failed. Some things I wanted to have: - OpenVPN client to connect to my company net...