Community discussions

MikroTik App

Search found 10 matches

by eehan
Thu Aug 08, 2019 5:28 pm
Forum: Scripting
Topic: Upload file with fetch on mode http
Replies: 7
Views: 4999

Re: Upload file with fetch on mode http

Did you guys work this out? FYI, I have worked out how to control the Hikvision by the XML API from Mikrotik script - let me know if you are interested.
by eehan
Tue Apr 24, 2018 2:54 pm
Forum: Scripting
Topic: Can't launch script from Netwatch
Replies: 14
Views: 7162

Re: Can't launch script from Netwatch

Yes you can put the entire scripts in the NetWatch Up/Down script windows. However in my case - writing to a global variable - this ceased to work with the new software version no matter whether I put the function in the NetWatch script window, or I called a script with the function in it, as explai...
by eehan
Tue Apr 24, 2018 4:11 am
Forum: Scripting
Topic: Can't launch script from Netwatch
Replies: 14
Views: 7162

Re: Can't launch script from Netwatch

So my issue is still not resolved: I am no longer able to change the value of a global variable from within Netwatch. If I create a script to change the global variable, and call that from Netwatch, the global variable will not change unless the policy option "policy" is checked for the script. I ve...
by eehan
Tue Apr 24, 2018 3:54 am
Forum: Scripting
Topic: Can't launch script from Netwatch
Replies: 14
Views: 7162

Re: Can't launch script from Netwatch

OK so in your particular issue, not being able to call a script, if you go to the script itself and uncheck all policy options with the exception of read, write, test and reboot, you should be able to call the script (it worked for me). Assuming of course you script does not require other policy opt...
by eehan
Tue Apr 24, 2018 3:40 am
Forum: Scripting
Topic: Can't launch script from Netwatch
Replies: 14
Views: 7162

Re: Can't launch script from Netwatch

It might be something to do with this: What's new in 6.42 (2018-Apr-13 11:03): netwatch - limit to read, write, test and reboot policies for Netwatch script execution; I have just upgraded my router to v6.42.1 (due to the latest in a growing list of very troubling security flaws, thanks Mikrotik). N...
by eehan
Wed Jul 01, 2015 2:15 pm
Forum: General
Topic: Leap second bug present on TILE devices?
Replies: 49
Views: 11728

Re: Leap second bug present on TILE devices?

The problem happens only if the following criteria is met: 1) 64bit RouterOS (only tile) 2) any RouterOS v6.x 3) installed and synchronized NTP client from NTP package (NOT the default SNTP client) 4) synchronization to server that have proper Leap Second implementation, not just time adjustment on...
by eehan
Wed Jul 01, 2015 12:23 pm
Forum: General
Topic: Leap second bug present on TILE devices?
Replies: 49
Views: 11728

Re: Leap second bug present on TILE devices?

Hi, I can report the same issue here. I have two Routerboad CCR1036-12G-4S in operation. Only one was affected. Both routerboards synchronise with external Australian official NTP pool servers. The unit that froze up was running v6.28, wheras the unit that was not affected was running v6.15 The unit...
by eehan
Wed May 30, 2007 4:15 pm
Forum: Wireless Networking
Topic: Co-location problems
Replies: 12
Views: 2257

Re: Co-location problems

I no longer think the power supply is an issue. I first tried two other 802.11b/g wifi cards including the CM9 to see if they performed as bad as the Ubiquiti XR2 in my setup. To my surprise, all cards performed horridly, if at all, when in 802.11g mode. All worked OK in 802.11b. I am using a 24dBi ...
by eehan
Wed May 30, 2007 10:14 am
Forum: Wireless Networking
Topic: Co-location problems
Replies: 12
Views: 2257

Re: Co-location problems

2. The issue is very obviously the interference you are picking up from other AP's NOT your own. 3. DECREASE your power. The output of the XR2 is WAY too high for good throughput. Have you tried switching off 2 of the 3 APs and seeing if your throughput increases on the remaining one? This would be...
by eehan
Wed May 30, 2007 5:14 am
Forum: Wireless Networking
Topic: Co-location problems
Replies: 12
Views: 2257

Re: Co-location problems

I suggest your co-location issues are due "adjacent channel interference". Even though the 3 wifi channels are not overlapping, there is still some signal leaking over into the adjacent channels when the neighbouring APs are transmitting. Because they are so close, it does not take much leakage to r...