Community discussions

MikroTik App

Search found 15 matches

by madnet
Thu Jun 02, 2011 1:04 pm
Forum: Scripting
Topic: [API] Bug report - export command
Replies: 4
Views: 1305

[API] Bug report - export command

Hi, I've just stumbled upon a bug regarding export command and wireless interfaces. Confirmed over several routers and several software versions, mostly v3.30 and v4.x. Didn't test on v5.x When I type /export file=somename from New Terminal window in console wireless settings are exported ok. Exampl...
by madnet
Wed Jan 20, 2010 10:27 pm
Forum: Scripting
Topic: Please help - auto.rsc problem and import via API problem
Replies: 7
Views: 1959

Re: Please help - auto.rsc problem and import via API problem

Ok, let me clarify - script is correct, it executes normaly every time I call it from Terminal. Number of Queues it changes depends, as you can see from the script. Almost all of our routers are either RB433AH or Intel E6300/E7500 based so it really does not matter how many queues has to be changed,...
by madnet
Tue Jan 19, 2010 11:29 pm
Forum: Scripting
Topic: Please help - auto.rsc problem and import via API problem
Replies: 7
Views: 1959

Re: Please help - auto.rsc problem and import via API problem

Thanks, but that is not the issue here. I would like to know why this script won't autoexecute properly and why API is making issues with it also. Dude is not the answer for what we need since our network is expanding very quickly and we have custom made information system that needs to be connected...
by madnet
Tue Jan 19, 2010 8:18 am
Forum: Scripting
Topic: Please help - auto.rsc problem and import via API problem
Replies: 7
Views: 1959

Re: Please help - auto.rsc problem and import via API problem

Sorry, later two examples are in PHP, I ment to show how I am calling import from API and what I am getting as response. Main idea is to control all routers from a single server (we have 300+ routers).

Regards,
Ivan
by madnet
Tue Jan 19, 2010 1:10 am
Forum: Scripting
Topic: Please help - auto.rsc problem and import via API problem
Replies: 7
Views: 1959

Please help - auto.rsc problem and import via API problem

Hi! I've been trying all day to figure why this script doesn't work on MT v3.30 (and v3.23): :global myVar; :global lmyVar; /queue simple :set myVar [find limit-at="96k/384k"]; :set lmyVar [:len myVar]; :if ($lmyVar > 0) do={ :put $myVar; set $myVar limit-at="256k/1024k" max-limit="256k/1024k" burst...
by madnet
Wed Jun 17, 2009 1:32 am
Forum: Scripting
Topic: This is really annoying, please stop doing it or fix it ...
Replies: 1
Views: 770

This is really annoying, please stop doing it or fix it ...

I am really upset right now since all my scripts that is using =comment= field in NAT stoped working since version 3.20. Just tonight I figured that you guys simply throw out =comment= field in /ip/firewall/nat/print from API (in v3.24). At first when API was introduced you haven't implemented FIND,...
by madnet
Wed May 06, 2009 10:17 am
Forum: Beginner Basics
Topic: how to install to a cf card.
Replies: 17
Views: 8463

Re: how to install to a cf card.

You haven't said what version you are trying to install. If it is v2.9.x and you have motherboard with SATA conenctors you should have in mind that MT cannot boot from IDE (it has something to do with internal motherboard interface ID).
by madnet
Fri Nov 14, 2008 2:08 pm
Forum: General
Topic: 3.15 Problems
Replies: 4
Views: 1326

Re: 3.15 Problems

We even have situation on v3.16 (x86) that CPU is counting 3-4 times slower, and users have 3-4 times less bandwith. For example, MT queue stats show full 1Mbps and users cant get more then 256k downloads...
Is there hope that MT will fix this bug ?
by madnet
Thu Nov 13, 2008 1:09 pm
Forum: General
Topic: RouterOS v3.x and RB100 series boards problem
Replies: 4
Views: 1146

Re: RouterOS v3.x and RB100 series boards problem

Hi Henrik,

we already did that. We are running:
1. advanced-tools
2. ntp
3. routerboard
4. security
5. system
6. wireless

but CPU stays at 100%. Bad luck ...

Ivan
by madnet
Thu Nov 13, 2008 11:01 am
Forum: General
Topic: RouterOS v3.x and RB100 series boards problem
Replies: 4
Views: 1146

RouterOS v3.x and RB100 series boards problem

We had several issues while upgradin RB112 and RB133c boards to v3.x RouterOS.
1. CPU usage goes sky high
2. Board dies after upgrade. It is impossible to get it working even with serial cable.
by madnet
Thu Nov 13, 2008 10:59 am
Forum: General
Topic: 3.15 Problems
Replies: 4
Views: 1326

Re: 3.15 Problems

What platform are you working on? Is it x86? If it is, it seems that clock issue on x86 platforms with v3.1x RouterOS is the reason. With traffic growth clock speeds up and everything that depends on it fails. Queue does not limit correctly, interface traffic shows smaller data rates than real etc.....
by madnet
Fri Jun 27, 2008 12:04 am
Forum: Scripting
Topic: Scripting issue between v2.9 and v3.9
Replies: 3
Views: 1452

Re: Scripting issue between v2.9 and v3.9

OK, here's update ...

if you substitute :local with :global then everything works. When I try to define local variable it is not shown in :environment print, but all global variables are.
by madnet
Thu Jun 26, 2008 9:59 pm
Forum: Scripting
Topic: now in v3.7 i has syntax error in /SYSTEM SCRIPT
Replies: 2
Views: 1295

Re: now in v3.7 i has syntax error in /SYSTEM SCRIPT

I have same problem, and all variables are defined, so that is not reason - see

http://forum.mikrotik.com/viewtopic.php?f=9&t=24945

Ivan
by madnet
Thu Jun 26, 2008 7:55 pm
Forum: Scripting
Topic: Scripting issue between v2.9 and v3.9
Replies: 3
Views: 1452

Scripting issue between v2.9 and v3.9

:local netw "10.10.10.254/24";
:local intf [/ip address get [find address=$netw] interface];
This works fine under v2.9, but when I tried to execute it on v3.9 it shows error on the second line of code just after 'address='

What am I missing?

Thanx, Ivan.
by madnet
Thu Jun 26, 2008 12:02 pm
Forum: General
Topic: Two BUGS *** I Believe *** in configuration exporting engine
Replies: 9
Views: 1564

Re: Two BUGS *** I Believe *** in configuration exporting engine

CONFIRMED BUG - as of v3.x beta! I have spent many hours testing exports and scripts on MT and I can confirm 100% that it is a BUG but very easy to solve. For those who haven't noticed since v3.x MT has strictened syntax so if you try to for example [root@mtv3x] /queue/simple disable [find target-ad...