Community discussions

MikroTik App

Search found 10 matches

by ericksetiawan
Fri Dec 28, 2018 12:20 pm
Forum: General
Topic: failure: dns server failure
Replies: 4
Views: 2557

Re: failure: dns server failure

Without complete config no help is possible
Totally agree to this. :)
by ericksetiawan
Fri Dec 28, 2018 6:50 am
Forum: Scripting
Topic: IP address list export script
Replies: 5
Views: 24315

Re: IP address list export script

Try this: { :local listName "Server"; #change this :local fileName "exported.rsc"; #change this :local buffer; :global filteredList [/ip firewall address-list print as-value where list=$listName && dynamic=no]; :foreach i in=$filteredList do={ :set $buffer ($buffer."...
by ericksetiawan
Fri Dec 28, 2018 6:33 am
Forum: General
Topic: FastNetMon Integration with MikroTik (DDoS detection software)
Replies: 43
Views: 32088

Re: FastNetMon Integration with MikroTik (DDoS detection software)

Thank you for creating this post, it helps much.
by ericksetiawan
Tue Aug 21, 2018 8:17 am
Forum: Scripting
Topic: disable a default route that have no routing-mark
Replies: 2
Views: 3980

Re: disable a default route that have no routing-mark

You can try to use !routing-mark

Code: Select all

/ip route disable [find dst-address=0.0.0.0/0 gateway=2.2.2.2 !routing-mark]
by ericksetiawan
Wed Apr 19, 2017 12:45 pm
Forum: Scripting
Topic: POST Request with fetch
Replies: 83
Views: 118318

Re: POST Request with fetch

You can do it this way: /tool fetch mode=https url="https://yoursite.com/link/5eu1a1kkypnypbyseqzsq1ao4w" http-method=post http-data="payload={\"text\": \"Test\"}" This was added in the latest RouterOS 6.39 RC versions fetch - added "http-data" and ...
by ericksetiawan
Wed Apr 19, 2017 12:38 pm
Forum: Scripting
Topic: PPP Profile script problem ($interface var)
Replies: 3
Views: 4035

Re: PPP Profile script problem ($interface var)

OK, just trying to help. Maybe another point from my answer is that "comment" is very very useful.
by ericksetiawan
Wed Apr 19, 2017 4:38 am
Forum: Scripting
Topic: DNS conditional forward, partly successful
Replies: 5
Views: 3417

Re: DNS conditional forward, partly successful

That's what works for other clients. But when you resolve names on router itself, DNS packet comes through output chain and there's no prerouting or dstnat there.
Yeah, sorry. Looks like I've misread what OP needs to exactly redirect the request from the router itself.
by ericksetiawan
Tue Apr 18, 2017 8:36 am
Forum: Scripting
Topic: PPP Profile script problem ($interface var)
Replies: 3
Views: 4035

Re: PPP Profile script problem ($interface var)

Try this set. Hope it helps. on-up { :local ifaceName [:pick $interface 1 [:len $interface]]; /interface list member add interface=$interface comment=$ifaceName list=LAN; :log warning message=($ifaceName." added"); } on-down { :local ifaceName [:pick $interface 1 [:len $interface]]; /inter...
by ericksetiawan
Tue Apr 18, 2017 8:11 am
Forum: Scripting
Topic: DNS conditional forward, partly successful
Replies: 5
Views: 3417

Re: DNS conditional forward, partly successful

Try this : /ip firewall layer7-protocol add name=example regexp=example.com /ip firewall mangle add action=mark-connection chain=prerouting dst-port=53 protocol=udp layer7-protocol=example new-connection-mark=example.c passthrough=yes /ip firewall mangle add action=mark-packet chain=prerouting conne...
by ericksetiawan
Tue Apr 18, 2017 6:21 am
Forum: Scripting
Topic: scan active pppoe servers in script?
Replies: 1
Views: 2245

Re: scan active pppoe servers in script?

I think I've managed to find a workaround of this situation. The clue is to dump the output from interactive scan tool into text file and do parsing. :local pppoeInterface "ether1"; :local cmd ("/interface pppoe-client scan interface=".$pppoeInterface." duration=1s"); :...