Community discussions

MikroTik App

Search found 20 matches

by skyhawk
Sun Aug 19, 2018 9:44 am
Forum: Announcements
Topic: v6.42.6 [current]
Replies: 102
Views: 36531

Re: v6.42.6 [current]

Here's a fun one. Defconf is broken on hAP routers. Model RB951Ui-2nd Logs suggest that defconf is running and complete successfully, but it has almost no configuration on it. No IP, no DHCP, no NAT, no Firewall, nothing other than the Mikrotik SSID. The actual config produced by /export is identica...
by skyhawk
Sun Jul 23, 2017 10:13 pm
Forum: RouterBOARD hardware
Topic: RB750Gr3 (hEX r3) protected routerboot trouble
Replies: 10
Views: 6854

Re: RB750Gr3 (hEX r3) protected routerboot trouble

use the failsafe. Remove the power. Press and hold the reset. Apply power. Hold the reset for 300 seconds. Once the router is reformatted, you will need to NetInstall the current routerOS to boot again. No go. I held the reset button, powered the router, held reset for over 5 minutes, released. 20 ...
by skyhawk
Sun Jul 23, 2017 5:03 pm
Forum: RouterBOARD hardware
Topic: RB750Gr3 (hEX r3) protected routerboot trouble
Replies: 10
Views: 6854

Re: RB750Gr3 (hEX r3) protected routerboot trouble

Protected Routerboot is supposed to zap the flash then boot Netinstall - it's not supposed to turn the router into an unrecoverable brick.
by skyhawk
Sun Jul 23, 2017 3:37 am
Forum: RouterBOARD hardware
Topic: RB750Gr3 (hEX r3) protected routerboot trouble
Replies: 10
Views: 6854

RB750Gr3 (hEX r3) protected routerboot trouble

I've got an RB750Gr3 that had protected-routerboot enabled. I'm moderately certain it was running 6.39.2 with the latest Routerboot. I hit the pinhole, and even though I gave it lots of time after this thing now appears to be a brick. It lights up but the beeper doesnt even sound anymore on power-on...
by skyhawk
Sun Feb 19, 2017 10:14 pm
Forum: Announcements
Topic: v6.38.1 [current]
Replies: 73
Views: 27943

Re: v6.38.1 [current]

I have no idea if this is related to the VLAN/Bridge/(r)stp troubles being reported, but I just discovered a bunch of instances of something interesting on my network. A bunch of my VLAN interfaces had set on "Loop Protect" Send Interval of 00:00:00 and Disable Time of 00:00:00. Defaults are 00:00:0...
by skyhawk
Sat Jun 11, 2016 8:28 am
Forum: General
Topic: Protected RouterBOOT
Replies: 118
Views: 35418

Re: Protected RouterBOOT

05:16:31 system,info verified protected_routerboot_v3_29_enable_6_33_smips.dpk  05:16:32 system,info installed protected-router-6.33  05:16:32 system,info FAILED to enable protected RouterBOOT: wrong running booter version               model: RouterBOARD 941-2nD      serial-number: <...>      firmw...
by skyhawk
Sun Apr 10, 2016 7:33 pm
Forum: General
Topic: Simple queues unable to catch traffic to/from the router itself?
Replies: 3
Views: 841

Re: Simple queues unable to catch traffic to/from the router itself?

No change in behavior. New config export: /queue simple add dst=ether3 name=queue1 packet-marks=icmp target="" /ip settings set allow-fast-path=no /ip address add address=10.1.0.1/24 interface=ether1 network=10.1.0.0 add address=192.168.1.2/24 interface=ether3 network=192.168.1.0 /ip firewall filter...
by skyhawk
Sun Apr 10, 2016 7:09 pm
Forum: General
Topic: Simple queues unable to catch traffic to/from the router itself?
Replies: 3
Views: 841

Re: Simple queues unable to catch traffic to/from the router itself?

My understanding is that if packet-marks aren't set, Queues will match all packets that meet the other conditions - on my hAP-acLite I am marking the connections and packets that I want to catch, and Simple Queues still aren't seeing them. Nonetheless, I will update my testing configuration this eve...
by skyhawk
Sun Apr 10, 2016 4:23 am
Forum: General
Topic: Simple queues unable to catch traffic to/from the router itself?
Replies: 3
Views: 841

Simple queues unable to catch traffic to/from the router itself?

Is it possible to have Simple Queues limit/control the traffic generated by the router itself? I've recreated a simple config in CHR /queue simple add dst=ether3 name=queue1 target="" /ip settings set allow-fast-path=no /ip address add address=10.1.0.1/24 interface=ether1 network=10.1.0.0 add addres...
by skyhawk
Sat Mar 26, 2016 5:46 am
Forum: Scripting
Topic: Convert network to ip
Replies: 1
Views: 668

Re: Convert network to ip

I just wrote that. Let me dig it up If you're defining routes manually I think you'll find you may need the network address with mask as well, so this code produces both { :local tmpip 192.168.1.1/24 :local tmpmask ([:pick $tmpip ([:find $tmpip "/"] + 1) [:len $tmpip]]) :local tmpmaskInvert [:tonum ...
by skyhawk
Fri Mar 25, 2016 9:38 am
Forum: Scripting
Topic: Multi-dimensional arrays
Replies: 5
Views: 1967

Re: Multi-dimensional arrays

There's still a bit of magic required to build a matrix programmatically. I submit the following for whoever may find it useful: { :local rows 4 :local cols 4 :local fillVal 0 :local testArray :for x from=0 to=($rows - 1) do={ :for y from=0 to=($cols - 1) do={ :if ($y = 0) do={ :set testArray ($test...
by skyhawk
Mon Mar 21, 2016 3:19 am
Forum: Scripting
Topic: Multi-dimensional arrays
Replies: 5
Views: 1967

Re: Multi-dimensional arrays

Almost there, actually I can work around this, but it's not perfect, so I'm going to throw it out there: Compare this code # Statically defined array, working properly { :local testArray {11=1; 12=1; 21=1; 22=1} :local testRows 2 :local testCols 2 :local testRowSize 10 :put $testArray :for x from=1 ...
by skyhawk
Sun Mar 20, 2016 11:40 pm
Forum: Scripting
Topic: Multi-dimensional arrays
Replies: 5
Views: 1967

Re: Multi-dimensional arrays

Figured out something that works well enough for my purpose, I think. It's a bit uglier than I hoped for, but should work well enough. :local WANStatus {101=2; 102=2; 103=2; 104=2; 201=2; 202=2; 203=2; 204=2} :local ConnPrefix 100 #Display and change value 4 for connection 1 :put $WANStatus :local C...
by skyhawk
Sun Mar 20, 2016 7:32 pm
Forum: Scripting
Topic: Bug in /ip route print where [...] command?
Replies: 3
Views: 1173

Re: Bug in /ip route print where [...] command?

So RouterOS handles flags a bit differently, fair enough.

Thanks!
by skyhawk
Sat Mar 19, 2016 9:59 pm
Forum: Scripting
Topic: Bug in /ip route print where [...] command?
Replies: 3
Views: 1173

Bug in /ip route print where [...] command?

This doesn't quite look right to me.... [admin@MikroTik] /ip route> print Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit # DST-ADDRESS PREF-SRC GATEWAY DISTANCE 0 A S 0.0.0.0/0 192.168.1.1 1 1 A...
by skyhawk
Sat Mar 19, 2016 7:29 pm
Forum: Scripting
Topic: Multi-dimensional arrays
Replies: 5
Views: 1967

Multi-dimensional arrays

I'm wondering if it's possible to create a simple multidimensional fixed array and access it in a reasonable fashion.... Something like the following :local WANStatus (1,1,0; 1,2,0; 1,3,0; 1,4,0; 2,1,0; 2,2,0; 2,3,0; 2,4,0) :put $WANStatus[1,1] :set {$WANStatus[1,1] -> 3} I'm not really grokking how...
by skyhawk
Wed Feb 03, 2016 2:16 pm
Forum: General
Topic: Automating and packaging keys and certificates
Replies: 0
Views: 419

Automating and packaging keys and certificates

Is there any way at Netinstall time (or Flashfig, for that matter), to pre-populate Files? I'd like to pre-load certificates and keys, which the config script can then automatically import, saving me the extra steps to copy then apply keys and certs to a device after flash and configure from netinst...
by skyhawk
Tue Jan 19, 2016 3:44 am
Forum: General
Topic: Protected RouterBOOT
Replies: 118
Views: 35418

Re: Protected RouterBOOT

Thanks PaulsMT, but I need an install package for smips... jan/01 00:00:04 system,info verified protected_routerboot_v3_24_enable_6_29_1_mipsbe.dpk 13:36:09 system,error can not install protected-router-6.29: it is not made for smips, but for mips 13:36:09 system,info router rebooted [admin@RB941-2n...
by skyhawk
Mon Jan 18, 2016 2:48 pm
Forum: General
Topic: Protected RouterBOOT
Replies: 118
Views: 35418

Re: Protected RouterBOOT

My test-bench RB941-2nD cannot enter protected-bootloader mode. Upon factory reset the bootloader reverts to 3.19, which I'm guessing is the backup bootloader? Can I ask for a protected-bootloader-install package for smips? the -mipsbe one refuses to install. RouterOS 6.33.5, /system routerboard sho...
by skyhawk
Thu Jan 14, 2016 11:16 am
Forum: Announcements
Topic: hAP lite
Replies: 392
Views: 180637

Re: hAP lite

Congratulations Mikrotik! You've managed to sell me on plastic cases. I love how easily the hAP series devices disassemble. 10 seconds with a thin metal spudger and you're in. No hidden snap-clips to break, no screws into plastic (ugh!), there's adequate ventilation and wall-mount slots. I laughed w...