Community discussions

MUM Europe 2020

Search found 8 matches

by diodo
Wed Aug 10, 2016 4:02 am
Forum: Scripting
Topic: wait internet came back and send e-mail
Replies: 2
Views: 715

wait internet came back and send e-mail

Dear friends I have a script that generate a backup and send a email every day 4:00 AM. Some times the link is down and I did not receive the e-mail. I would like to improve the sript with a verification like: If ping 200.223.0.84 response, send e-mail, case not, wait 5 minutes and try again until p...
by diodo
Thu Jul 14, 2016 3:48 pm
Forum: Scripting
Topic: Problem with Script On Login
Replies: 4
Views: 1014

Re: Problem with Script On Login

Dear friends. I relly need some help.

Tanks
by diodo
Thu Jul 14, 2016 5:12 am
Forum: Scripting
Topic: Problem with Script On Login
Replies: 4
Views: 1014

Re: Problem with Script On Login

I hope everybody understand what I try explain. If do not, please ask me
by diodo
Thu Jul 14, 2016 5:10 am
Forum: Scripting
Topic: Problem with Script On Login
Replies: 4
Views: 1014

Problem with Script On Login

Dear friends Sorry for bad english I set a hotspot server on my 2011 router board v6.35.2 and in the user profile scripts, I create this script On Login: :local date [ /system clock get date ] :if ([/ip hotspot user find where name=$"mac-address"] = "" ) do={           :log warning ("The user ".$"ma...
by diodo
Thu Jul 07, 2016 5:15 pm
Forum: General
Topic: PPTP connection status showing as " Link established"
Replies: 12
Views: 7778

Re: PPTP connection status showing as " Link established"

I have the same problem. Did you find some solution?
by diodo
Sun May 22, 2016 7:30 am
Forum: Scripting
Topic: New variable $uptime-secs that should be avalible on user hotspot logout, does not exist
Replies: 2
Views: 558

New variable $uptime-secs that should be avalible on user hotspot logout, does not exist

Dear friends In http://wiki.mikrotik.com/wiki/Manual:IP/Hotspot/User we find on ON-LOGOUT USER PROFILE PROPERTY: "Starting with v6.34rc11 some additional variables are available: $uptime-sec, $bytes-in, ..." Any of these new variables are no available. I can get $user or $address, on-login and on-lo...
by diodo
Sun May 22, 2016 2:16 am
Forum: Scripting
Topic: Expire users a after number of days Stops Work after Upgrade to v.6.33rc11
Replies: 17
Views: 3179

Re: Expire users a after number of days Stops Work after Upgrade to v.6.33rc11

Dear @PeterDoBrasil Your script is being very useful to me. Thanks for share it on mikrotik WIKI. I´m developing a group of scripts that should create a static user with the data of dinamic "trial hotspot user" and every LOGOUT, update the "uptime variable" of him (I´m using limit-uptime field). Eve...
by diodo
Wed May 11, 2016 10:24 pm
Forum: Scripting
Topic: Expire users a after number of days Stops Work after Upgrade to v.6.33rc11
Replies: 17
Views: 3179

Re: Expire users a after number of days Stops Work after Upgrade to v.6.33rc11

:foreach i in [ /ip hotspot user find where profile=1000 ] do={
:if ([ :find [ /ip hotspot user get $i comment ] ] = 0 ) do={
:local date [ /ip hotspot user get $i comment ]
:?
Dear PeterDoBrasil

Did you reach solution for your problem? I´m trying to do a script similar to yours.