Community discussions

Search found 43 matches

by BrasDeutscher
Mon Oct 10, 2016 1:29 am
Forum: General
Topic: Prevent single IP hogging all bandwidth?
Replies: 26
Views: 5098

Re: Prevent single IP hogging all bandwidth?

Install and test it !! I recomend to not use any other scripts creating address-lists, it's possibel to have any type of Loop !!! 1. Step, run this to create schedule rule, to edit any go to schedule and edit /system scheduler add comment="Dns to Fw and Queue Tree" interval=1m name=\ "Dns to Fw and ...
by BrasDeutscher
Sun Oct 09, 2016 11:21 pm
Forum: General
Topic: Prevent single IP hogging all bandwidth?
Replies: 26
Views: 5098

Re: Prevent single IP hogging all bandwidth?

I only use this things to get more experience with mikrotik, you edit all tou other Bandwidth purposes etc, basicly the setup for me works very fine, I can open 6 YouTube Videos on Mozilla and the same time I can navegate my Facebook or each other Site without any Problems, when you have more Users ...
by BrasDeutscher
Sun Oct 09, 2016 8:37 pm
Forum: Scripting
Topic: Qos, Simple but very effectiv setup !!!
Replies: 0
Views: 1078

Qos, Simple but very effectiv setup !!!

I've find out a very simple way to Qos my network config, I've only a very slow (700k download) bandwidth and only 400 Mhz Router cpu, but it works very well, I can open 6 YouTube Videos on Mozilla and Simultany navegate my Facebook or each other Site on Chrome !!! My settings are based on the digit...
by BrasDeutscher
Sun Oct 09, 2016 8:35 pm
Forum: General
Topic: Prevent single IP hogging all bandwidth?
Replies: 26
Views: 5098

Re: Prevent single IP hogging all bandwidth?

I've find out a very simple way to Qos my network config, I've only a very slow (700k download) bandwidth and only 400 Mhz Router cpu, but it works very well, I can open 6 YouTube Videos on Mozilla and Simultany navegate my Facebook or each other Site on Chrome !!! My settings are based on the digit...
by BrasDeutscher
Sun Oct 09, 2016 3:05 am
Forum: Scripting
Topic: Other interesting fact to find a very simple command under mikrotik
Replies: 2
Views: 599

Other interesting fact to find a very simple command under mikrotik

Other interesting fact to find a very simple command under mikrotik /command Use command at the base level [1@172.16.16.1] > /ip firewall filter set [find where chain=Qos ] in-interface=0; input does not match any value of interface [1@172.16.16.1] > /ip firewall filter set [find chain=Qos] in-inter...
by BrasDeutscher
Sat Oct 08, 2016 6:47 pm
Forum: Scripting
Topic: Get Subnet Mask
Replies: 2
Views: 2246

Re: Get Subnet Mask

:lol: Zenos Solution works, You are Great Zeno, thank You very much !!! [1@172.16.16.1] > { {... :foreach q in=[/queue simple find where disabled ! dynamic ] do={ {{... :local num [/queue simple get $q name ]; {{... :if ($num = 1 ) do={ {{{... :local ml [/queue simple get $q max-limit ]; {{{... :loc...
by BrasDeutscher
Thu Oct 06, 2016 6:07 am
Forum: Scripting
Topic: Script question for Experts
Replies: 4
Views: 748

Re: Script question for Experts

Sorry my Friend, doesn't work, ports have up to 6 numbers { :global mb "1" :global mbc ($mb * 1024 *1024 ) :global dstt :global dstta :global dsttp :global dstu :global tcp :global udp :foreach TCP in=[/ip firewall connection find where confirmed srcnat \ protocol=tcp tcp-state=established ] do={ :i...
by BrasDeutscher
Wed Oct 05, 2016 11:40 pm
Forum: Scripting
Topic: Script question for Experts
Replies: 4
Views: 748

Script question for Experts

/command Use command at the base level [1@172.16.16.1] > { {... :global mb "1" {... :global mbc ($mb * 1024 *1024 ) {... :global dstt {... :global dstta {... :global dsttp {... :global dstu {... :global tcp {... :global udp {... :foreach TCP in=[/ip firewall connection find where confirmed srcnat \ ...
by BrasDeutscher
Mon Oct 03, 2016 11:39 pm
Forum: Scripting
Topic: Firewall Filter and Mangle Rules and Queue Trees for Qos
Replies: 2
Views: 1773

Firewall Filter and Mangle Rules and Queue Trees for Qos

!!-- this Script has 559 Lines --!! !!-- If your Router have a low CPU do not use this Script in New Terminal, Insert to System Scripts and Run --!! ## Firewall Filter and Mangle Rules and Queue Trees for Qos ## ## Testet under RouterOS 6.38rc7 ## ## Written by BrasDeutscher,PA,Brazil ## { ## Set yo...
by BrasDeutscher
Sat Oct 01, 2016 2:16 am
Forum: Scripting
Topic: Static Fw address-list for Facebook
Replies: 0
Views: 860

Static Fw address-list for Facebook

First you must create in ip firewall filter your add-dst-to-address-list rule ## make dynamic fw address list static ## ## Written by BrasDeutscher,PA,Brazil ## ## Testet under RouterOS v6.36.3 ## { # Set your dynamic list name here -search value # :global dl "facebook" # Set your new static list na...
by BrasDeutscher
Sun Sep 25, 2016 5:31 pm
Forum: Scripting
Topic: IPv6 auto address lists
Replies: 5
Views: 1426

Re: IPv6 auto address lists

Very good!
by BrasDeutscher
Tue Sep 20, 2016 5:17 am
Forum: Scripting
Topic: IPv6 auto address lists
Replies: 5
Views: 1426

Re: IPv6 auto address lists

I'will try this for you, the problem is I do not use this IP Range on my Router ! :?
My Question to you, You use dynamic or static IP leases ???
And why do you need this only for 9 IP addresses ???
by BrasDeutscher
Sat Sep 17, 2016 5:50 am
Forum: Scripting
Topic: IPv6 auto address lists
Replies: 5
Views: 1426

IPv6 auto address lists

## IPv6 auto address lists ## ## Written by:BrasDeutscher,PA,Brazil ## ## Testet under RouterOS v6.37rc36 ## { ## Set your list name here ## :global list "dynIPv6" ## Set your list time-out here ## :global tou "12h" ## !!-- DO NOT CHANGE ANY MORE BELOW --!! ## :global ipv4 :global ipv6 :global mac :...
by BrasDeutscher
Thu Sep 15, 2016 4:39 am
Forum: Scripting
Topic: script to save logs and send via email
Replies: 27
Views: 26036

Re: script to save logs and send via email

To Analyse use Libre Office from Apache, free and very easy to use !
by BrasDeutscher
Thu Sep 15, 2016 4:15 am
Forum: Scripting
Topic: show ip route x.x.x.x
Replies: 11
Views: 19215

Re: show ip route x.x.x.x

/ip route print detail Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit 0 ADS dst-address=0.0.0.0/0 gateway=192.168.168.1 gateway-status=192.168.168.1 reachable via e1-gateway distance=0 scope=30 ...
by BrasDeutscher
Thu Sep 15, 2016 4:08 am
Forum: Scripting
Topic: Get number of wireless clients online via SNMP?
Replies: 3
Views: 803

Re: Get number of wireless clients online via SNMP?

Try this
/interface wireless registration print detail file=Folder/WlanReg
then set your e-mail tool and make a script to send the print result to your mail address
by BrasDeutscher
Thu Sep 15, 2016 3:00 am
Forum: Scripting
Topic: Reset Hotspot User Counters Script w. T. Interval
Replies: 0
Views: 787

Reset Hotspot User Counters Script w. T. Interval

## Reset Hotspot User Counters ## ## Tested under RouterOS v6.37rc27 ## ## Written by:BrasDeutscher,PA,Brazil ## ## Let it run on Schedule with 1 Day Interval ## { ### !!-- Offset is your Time setting ex. 31 Days etc. --!! ### :global offset 31 :global today { :local date [/system clock get date ] :...
by BrasDeutscher
Wed Sep 14, 2016 11:06 pm
Forum: Scripting
Topic: Hotspot E-Mail Notifer with Byte Info
Replies: 1
Views: 524

Hotspot E-Mail Notifer with Byte Info

## Hotspot Mail Notifer Byte Info ## ## Written by:BrasDeutscher,PA,Brazil ## ## Testet under RouterOS v6.37rc34 ## { :global gm :global mac :global ip :global in :global out :global tot :global mib :global gib :global upt :global logout :global send1 :global send2 :foreach i in=[/ip hotspot user fi...
by BrasDeutscher
Tue Sep 13, 2016 2:04 am
Forum: Scripting
Topic: Little tool to change queue-simple limits for ISP's
Replies: 1
Views: 843

Little tool to change queue-simple limits for ISP's

## Queue Simple Rate Setting Tool ## ## This Tool can be helpful for ISP's to change a big number of queues simple ## ## Written by:BrasDeutscher,PA,Brazil ## ## Testet under RouterOS v6.37rc32 ## { ## Enter here the max-limit search value ## ## Required is k or M , do not use m ## :global oldmax "0...
by BrasDeutscher
Sun Sep 11, 2016 6:34 pm
Forum: Scripting
Topic: EXPIRE Hotspot User Advanced Script
Replies: 2
Views: 5281

EXPIRE Hotspot User Advanced Script

## The script sets the date in the user comment ## ## Place it in system Script and enter the path to the script in user-profile by-login ## ## Written by: BrasDeutscher,PA,Brazil ## ## Testet under RouterOS v6.37rc32 ## { ## !!-- Enter the Hotspot server name here --!! ## :global sv "1" ## !!-- PLE...
by BrasDeutscher
Sun Sep 11, 2016 12:59 pm
Forum: Scripting
Topic: Caps-Man Mac Addresses to IP-ARP and Hotspot IP Binding
Replies: 2
Views: 754

Re: Caps-Man Daten zu IP-ARP und Hotspot IP Binding Script

O.K. Ich werde alles Ueberstzen !
by BrasDeutscher
Fri Sep 09, 2016 8:44 am
Forum: Scripting
Topic: Caps-Man Mac Addresses to IP-ARP and Hotspot IP Binding
Replies: 2
Views: 754

Caps-Man Mac Addresses to IP-ARP and Hotspot IP Binding

## Caps-Man Mac Addresses to IP-ARP and Hotspot IP Binding ## ## !!-- Important, you must add each Cap's IP Address to Cap Comment --!! ## ## Written by:BrasDeutscher,PA,Brazil ## ## Testet under RouterOS v6.37rc32 ## { ## Set here the Interface or Bridge Name ## :global int "interface-name" ## Set ...
by BrasDeutscher
Thu Sep 08, 2016 11:46 pm
Forum: Scripting
Topic: Automatic Hotspot Ip-Binding and User Creator Tool
Replies: 0
Views: 1799

Automatic Hotspot Ip-Binding and User Creator Tool

## Auto Hotspot Ip Binding and User Creator for by Mac-Login Users ## ## The Script gets the Mac's from dhcp server Lease's ## ## Written by:BrasDeutscher,PA,Brazil ## ## Tested under RouterOS v6.37rc32 ## { ## Enter here the Hotspot responsive Interface bridge, ether etc. ## :global hsint "br0" ## ...
by BrasDeutscher
Wed Sep 07, 2016 12:01 am
Forum: Scripting
Topic: Caps-Man auto access-list getting mac from dhcp-lease
Replies: 0
Views: 686

Caps-Man auto access-list getting mac from dhcp-lease

## Caps-Man Automatic access-list ## ## Written by:BrasDeutscher,PA,Brazil ## ## Works on RouterOS v6.37rc27 ## ## !!-- Static Hotspot users get permission to use all Caps --!! ## ## !!-- Important, you have to set the Load Balancing Group on each Cap --!! ## ## !!-- Script Load-Balancing-Group Numb...
by BrasDeutscher
Tue Sep 06, 2016 11:57 pm
Forum: Wireless Networking
Topic: Caps-Man auto access-list getting mac from dhcp-lease
Replies: 0
Views: 407

Caps-Man auto access-list getting mac from dhcp-lease

## Caps-Man auto access-list ## ## Written by: BrasDeutscher,PA,Brazil ## ## Works on RouterOS v6.37rc27 ## { # set min signal range here - options= -80..80 -70..70 -60..60 , only copy and paste # :global rg "-80..80" ## !!-- DO NOT CHANGE ANY MORE BELOW --!! ## :global sv0 "dhcp0" :global sv1 "dhcp...
by BrasDeutscher
Tue Sep 06, 2016 7:32 am
Forum: Scripting
Topic: Block MAC without DHCP or HOTSPOT
Replies: 1
Views: 916

Re: Block MAC without DHCP or HOTSPOT

## Written by: BrasDeutscher,PA,Brazil ## ## Tested to work on RouterOS v6.37rc27 ## { # Any Device added to Bridge filter doesn't get addresses from DHCP Server # # To make this Script work go first to Interface and Create your list for Bridges # # This Step helps in Bridge-Filter # # Set your inco...
by BrasDeutscher
Tue Sep 06, 2016 6:03 am
Forum: Scripting
Topic: Help in Script
Replies: 7
Views: 1012

Re: Help in Script

Try this and then check your Logs !!! ## Script to Set client-id ## ## from BrasDeutscher, PA, Brazil ## ## Testet on RouterOS v6.37rc27 ## { # Set your Server Name here # :global sv "your-server-name" ## !!-- Do not change any below --!! ## :global action :global id :global mac :foreach d in=[/ip d...
by BrasDeutscher
Mon Sep 05, 2016 3:05 am
Forum: Beginner Basics
Topic: Recommende "IP/IP Settings"
Replies: 6
Views: 2104

Re: Recommende "IP/IP Settings"

tcp-syncookies: yes
by BrasDeutscher
Mon Sep 05, 2016 3:01 am
Forum: Beginner Basics
Topic: Network problem in mikrotik Hotspot
Replies: 3
Views: 575

Re: Network problem in mikrotik Hotspot

ip-->hotspot-->server-->address pool="none"
When you do this client was allowed to mac-spoofing, client can get a lot of IP's with the same mac-address !
by BrasDeutscher
Mon Sep 05, 2016 2:47 am
Forum: General
Topic: Hotspot Login Page not opening
Replies: 3
Views: 5392

Re: Hotspot Login Page not opening

Please check in ip-dns static, without static hotspot ip entry the Login Page doesn't work !
by BrasDeutscher
Sun Sep 04, 2016 7:29 pm
Forum: Scripting
Topic: Queue dynamic on VLAN
Replies: 1
Views: 466

Re: Queue dynamic on VLAN

Try This here, change only address, mac-address, rx-tx (Bandwidth dynamic queue), server name and at least the comment /ip dhcp-server lease add address=192.168.1.0 mac-address=FF:FF:FF:FF:FF:FF server="Vlan-server-name" \ lease-time=10m use-src-mac=yes rate-limit=1M/2M insert-queue-before=first com...
by BrasDeutscher
Sun Sep 04, 2016 3:32 pm
Forum: Scripting
Topic: Return MAC address given the IP address
Replies: 5
Views: 5384

Re: Return MAC address given the IP address

## Script v2 for Dynamic/Static arp ## ## Testet with RouterOS v6.37rc27 ## ## from BrasDeutscher,Para,Brazil ## { ## Set here yes for dynamic or no for static arp's and desired IP address ## :global state yes :global ip 10.0.0.2 ## !!-- Do not change any below, this can breake the Script --!! ## :g...
by BrasDeutscher
Sun Sep 04, 2016 3:25 pm
Forum: Scripting
Topic: Return MAC address given the IP address
Replies: 5
Views: 5384

Re: Return MAC address given the IP address

## Script for Dynamic/Static arp ## ## Testet with RouterOS v6.37rc27 ## ## from BrasDeutscher,Para,Brazil ## { ## Set here yes for dynamic or no for static arp's ## :global state yes ## !!-- Do not change any below, this can breake the Script --!! ## :global int :global ip :global mac :foreach a in...
by BrasDeutscher
Sun Sep 04, 2016 3:58 am
Forum: Scripting
Topic: sum total-bytes
Replies: 2
Views: 550

Re: sum total-bytes

try to find out the total bytes from your interface !
by BrasDeutscher
Sun Sep 04, 2016 3:43 am
Forum: Scripting
Topic: Script for remove ip-binding in hotspot
Replies: 5
Views: 3939

Re: Script for remove ip-binding in hotspot

## Ver este ai, do BrasDeutscher, Pará ## ## Script to Remove all Regular IP-Bindings ## ## RouterOS 6.37rc27 from BrasDeutscher ## { # set your server name here # :global sv "Hotspot" # set here 0 for regular, or 7 for blocked, or 8 for bypassed # :global num 0 ## !!-- Do not edit the below, this c...
by BrasDeutscher
Sun Sep 04, 2016 3:01 am
Forum: Scripting
Topic: Netwatch and SSH Script
Replies: 1
Views: 617

Re: Netwatch and SSH Script

I think it's better when you use any Script in Netwatch which change the distance Number, example Google O.k. set distance to 0 on your ping Interface, if Google was down set distance to 3, when you use two Wan's you set the second Wan to distance 2, for me work it very fine !!!
by BrasDeutscher
Sun Sep 04, 2016 2:41 am
Forum: Scripting
Topic: Expire Hotspot Users RouterOS v6.37rc27
Replies: 0
Views: 586

Expire Hotspot Users RouterOS v6.37rc27

ExpireHotspotUsers.png ## Expire Hotspot User ## ## One Script for more Profiles ## ## Testet on RouterOS v6.37rc27 ## { :global today :global prof :global offset { :local date [/system clock get date ] :local montharray ( "jan","feb","mar","apr","may","jun","jul","aug","sep","oct","nov","dec" ) :l...
by BrasDeutscher
Sat Sep 03, 2016 2:35 am
Forum: Scripting
Topic: Make Automatic static dhcp-leases
Replies: 1
Views: 3908

Make Automatic static dhcp-leases

## Part-1 Create automatic Static dhcp Leases ## ## Written by:BrasDeutscher,PA,Brazil ## ## Tested RouterOS v637rc27 ## { ## If You not run Hotspot than You can set Your own FlatRate below example "1m/10m" ## ## If no leaf it in blanc, do nothing below ## :global r "" ## Enter the dhcp server name ...