Community discussions

MikroTik App

Search found 21 matches

by teamer
Sat Mar 17, 2018 9:03 am
Forum: Scripting
Topic: ssh client in scripts
Replies: 1
Views: 509

Re: ssh client in scripts

you can't use MikroTik ssh client in script.
sorry.
by teamer
Sat Sep 02, 2017 8:46 pm
Forum: Scripting
Topic: [Q] Current ssh/web session id and on-login script autoexecution
Replies: 0
Views: 699

[Q] Current ssh/web session id and on-login script autoexecution

Hi! Is there any way to determine my current ssh or web session in /user active? I.e. I want to run script which adds my local machine (from which I connect to Mikrotik) ip address to specific address-list. Something like: /ip firewall address-list add list=FreeInternet address=[/user active get [fi...
by teamer
Sun Aug 06, 2017 10:54 am
Forum: Forwarding Protocols
Topic: Bonding with OSPF
Replies: 15
Views: 3374

Re: Bonding with OSPF

Are you really understand picture provided in the article? OSPF is only tool, convenient but not necessary here.

And so, ECMP has nothing to do with it.
by teamer
Sun Aug 06, 2017 1:15 am
Forum: Forwarding Protocols
Topic: Bonding with OSPF
Replies: 15
Views: 3374

Re: Bonding with OSPF

OSPF don't, but ECMP do.
by teamer
Sat Aug 05, 2017 8:40 am
Forum: General
Topic: Bridging all ethernet ports with isolated vlans
Replies: 3
Views: 759

Re: Bridging all ethernet ports with isolated vlans

it appears that my bridges are combining all the tagged and untagged traffic together
Sure, unless you have assigned ports especially to vlan2.
by teamer
Wed Aug 02, 2017 6:30 pm
Forum: General
Topic: Issue with VLAN and trunk ports
Replies: 4
Views: 1077

Re: Issue with VLAN and trunk ports

Try to disable RSTP on all bridges with trunk ports.
What ROS version are you using?
by teamer
Tue Jul 11, 2017 7:23 am
Forum: Forwarding Protocols
Topic: OSPF-DR,backup
Replies: 6
Views: 1391

Re: OSPF-DR,backup

Yes, until next reboot new DR or BDR.
This is by design.
by teamer
Fri Mar 03, 2017 6:07 pm
Forum: General
Topic: VRRP interface on bridge
Replies: 14
Views: 5997

Re: VRRP interface on bridge

The problem is still persists. CCR1009-8G-1S-1S+, 6.37.1.
:(
by teamer
Thu Jan 19, 2017 12:21 pm
Forum: General
Topic: double upload rate on wan when using pptp client.
Replies: 2
Views: 644

Re: double upload rate on wan when using pptp client.

On small packets (like ACKs) overhead of GRE may be noticeable...
by teamer
Sun Jan 15, 2017 2:54 pm
Forum: Beginner Basics
Topic: destination rule - src address list
Replies: 9
Views: 3238

Re: destination rule - src address list

No, it's not possible. example: address list 1: block_scanner address list 2: block_permanent_blacklisted When there are two rules (first one only allows IP addresses which are not in block_scanner , this rule will be taken without checking the second one if the IP is maybe on the block_permanent_b...
by teamer
Sun Jan 15, 2017 12:52 am
Forum: Beginner Basics
Topic: destination rule - src address list
Replies: 9
Views: 3238

Re: destination rule - src address list

Or can I add two identically destination NAT rules but only the address list is different?
Sure.
by teamer
Wed Jan 11, 2017 6:34 pm
Forum: General
Topic: Raw Accept vs IP Firewall FastTrack, which one is faster and light weight?
Replies: 8
Views: 3274

Re: Raw Accept vs IP Firewall FastTrack, which one is faster and light weight?

JFYI: accept action in raw table does not mean to bypass all others.
by teamer
Wed Jan 04, 2017 1:57 pm
Forum: General
Topic: non-continuous netmask: feature or bug?
Replies: 6
Views: 1008

Re: non-continuous netmask: feature or bug?

@normis, thank you. Sad but "do not argue with weather". Probably it would be wise to issue an error when entering not continuous netmask instead of convert it to the wrong range... This is a situation where the bitmap address lists I mentioned at the Amsterdam MUM could be useful. Could y...
by teamer
Wed Jan 04, 2017 9:26 am
Forum: General
Topic: non-continuous netmask: feature or bug?
Replies: 6
Views: 1008

non-continuous netmask: feature or bug?

[***-router] > /ip firewall filter add chain=forward src-address=10.10.0.137/255.255.0.255 [***-router] > /ip firewall filter export # jan/04/2017 09:13:52 by RouterOS 6.37.1 # software id = P3RE-KFSV # /ip firewall filter add chain=forward src-address=10.10.0.137-10.10.255.137 Easy to see that 10....
by teamer
Sat Dec 31, 2016 10:28 am
Forum: Beginner Basics
Topic: Help with a very simple queue
Replies: 7
Views: 1745

Re: Help with a very simple queue

Are you sure your queued packets are not fasttracked?
by teamer
Wed Dec 28, 2016 11:12 pm
Forum: Scripting
Topic: ipcalc
Replies: 0
Views: 719

ipcalc

On the occasion I have written functional analogue of ipcalc. This is my near the first Mikrotik script, so don't hesitate to comment. :global ipcalc do={ # # GL(c), 2016 # :local pOpt $1 :local pIpaddr $2 :local pNetmask $3 :if ([:len $pOpt] = 0) do={ :error "ipcalc usage:\n\r \$ipcalc [-m|-p|...
by teamer
Wed Dec 28, 2016 9:44 am
Forum: General
Topic: (Solved thanks) Mikrotik's DNS not working with DNScrypt
Replies: 19
Views: 4952

Re: (New problem) Mikrotik's DNS not working with DNScrypt

Try to use src-nat with dst-nat to guarantee DNS answer passed through the router and then de-nated rightly.
by teamer
Wed Dec 28, 2016 9:24 am
Forum: General
Topic: v5.5 bug: after ssh-keys password login via ssh is blocked
Replies: 20
Views: 6703

Re: v5.5 bug: after ssh-keys password login via ssh is blocked

What RouterOS version are you using?
In contemporary ones
/ip ssh set always-allow-password-login=yes
by teamer
Tue Dec 06, 2016 9:15 pm
Forum: General
Topic: ECMP with OSPF
Replies: 9
Views: 4205

Re: ECMP with OSPF

In my AS I have more than 10 different ways between some of routers. Links have different speed, many of them is redundant. OSPF costs are assigned based on link speed, which is from 100kbps to 10Gbps.
Sorry, but your solution is very inconvient for my case.
by teamer
Tue Dec 06, 2016 7:54 pm
Forum: General
Topic: ECMP with OSPF
Replies: 9
Views: 4205

Re: ECMP with OSPF

Is there a way to disable ECMP automagical behavior of OSPF?
by teamer
Mon Sep 12, 2016 9:30 am
Forum: General
Topic: Conditional DNS forwarding
Replies: 17
Views: 37943

Re: Conditional DNS forwarding

+1
Please, add DNS zone forwarding feature in the next release!