Community discussions

Search found 47 matches

by MayestroPW
Fri Apr 19, 2019 6:32 pm
Forum: General
Topic: FastTrack not working in a router-on-a-stick conf with multiple bridges. Bug?
Replies: 2
Views: 232

Re: FastTrack not working in a router-on-a-stick conf with multiple bridges. Bug?

How do you determine that fasttrack is not working fir you? Is it that facttrack counters don't increment or is it the lack of performance? Both. Either way, your bridge/vlan setup is a mess making CPU to push the same packet around just too many times. I strongly advise you to redo the whole VLAN ...
by MayestroPW
Fri Apr 19, 2019 5:51 pm
Forum: General
Topic: FastTrack not working in a router-on-a-stick conf with multiple bridges. Bug?
Replies: 2
Views: 232

FastTrack not working in a router-on-a-stick conf with multiple bridges. Bug?

Hello, For the past 2 years, I've been struggling to get FastTrack working in my config. Problem is that FastTrack is not working when you have a router-on-a-stick configuration with each VLAN in a different bridge. I don't know why is that, but it is really annoying especially when you want to send...
by MayestroPW
Thu Jun 21, 2018 1:10 pm
Forum: RouterOS v6 RC and v7 BETA
Topic: feature request: add Port List to firewall
Replies: 34
Views: 6507

Re: feature request: add Port List to firewall

+1
I hope we will get it someday, with an option to specify multiple protocols, or at least TCP and UDP, so we will not have to make two rules for services like DNS which are using TCP/54 and UDP/54.
And it would be great to have the ability to specify multiple port lists in Filter Rule.
by MayestroPW
Fri May 04, 2018 2:16 am
Forum: RouterOS v6 RC and v7 BETA
Topic: [Feaure request] IP Address to DNS name resolution for Torch and Connections tracker
Replies: 2
Views: 673

[Feaure request] IP Address to DNS name resolution for Torch and Connections tracker

Hello,
I think, that IP Address to DNS name resolution for Torch and Connections tracker in Firewall would be very useful for many.
There could be an optional switch to turn in on or off when needed (Winbox).
by MayestroPW
Tue Feb 20, 2018 10:45 pm
Forum: RouterOS v6 RC and v7 BETA
Topic: 6.41rc66 Bridge VLAN Filtering and CAPs with VLAN tags.
Replies: 4
Views: 1186

Re: 6.41rc66 Bridge VLAN Filtering and CAPs with VLAN tags.

Guys, you have to use static virtual interfaces in caps settings. It's not gonna solve all of your issues, but at least it will let it work.
by MayestroPW
Mon Jan 15, 2018 1:55 am
Forum: General
Topic: Bridge is like a hub, floods all ports.
Replies: 12
Views: 1115

Re: Bridge is like a hub, floods all ports.

I directly connected RB2011 with RB912, disabled every interface, besides those which you can see in the picture. Then set up only one Wireless interface(wireless1 on RB2011) with VLAN Tagging 221. That wireless interface is part of bridge "bridge0-ban1"(trunk) on RB2011. Then connected one PC wirel...
by MayestroPW
Mon Jan 15, 2018 12:45 am
Forum: General
Topic: Bridge is like a hub, floods all ports.
Replies: 12
Views: 1115

Re: Bridge is like a hub, floods all ports.

Right now I have only two exports. From RB2011 and RB912. Config of the third one(hEX) is quite big, so I will attach it tomorrow.

The problem occurs even with just two of them connected directly.

UPDATE BELOW
by MayestroPW
Sun Jan 14, 2018 11:23 pm
Forum: General
Topic: Bridge is like a hub, floods all ports.
Replies: 12
Views: 1115

Re: Bridge is like a hub, floods all ports.

This is not a problem. Like I said earlier, host table contains both mac-addresses.
by MayestroPW
Sun Jan 14, 2018 4:21 pm
Forum: General
Topic: Bridge is like a hub, floods all ports.
Replies: 12
Views: 1115

Re: Bridge is like a hub, floods all ports.

Sorry, my bad.
I thought that pictures in the first post show that clearly.
by MayestroPW
Sun Jan 14, 2018 4:03 pm
Forum: General
Topic: Bridge is like a hub, floods all ports.
Replies: 12
Views: 1115

Re: Bridge is like a hub, floods all ports.

I know how bridge/switch supposed to work. The problem is that this is a unicast traffic, not broadcast nor multicast.
The bridge has both mac addresses in host table and it still floods whole bridge.
When I connect my PC to that bridge I'm receiving that whole traffic as well.
by MayestroPW
Sat Jan 13, 2018 11:28 pm
Forum: General
Topic: Bridge is like a hub, floods all ports.
Replies: 12
Views: 1115

Re: Bridge is like a hub, floods all ports.

Sorry, I could not reply earlier.

I attached more detailed pictures of my setup.
I really don't know why this is happening. Surprisingly, this situation does not occur on different bridges, only on the first one(trunk).
HEX-1.JPG
HEX-2.JPG
RB2011-1.PNG
RB912UAG-1.PNG
by MayestroPW
Sat Jan 13, 2018 11:27 pm
Forum: General
Topic: Bridge is like a hub, floods all ports.
Replies: 12
Views: 1115

Re: Bridge is like a hub, floods all ports.

Sorry, I could not reply earlier.

I attached more detailed pictures of my setup.
I really don't know why this is happening. Surprisingly, this situation does not occur on different bridges, only on the first one(trunk).
HEX-1.JPG
HEX-2.JPG
RB2011-1.PNG
RB912UAG-1.PNG
by MayestroPW
Fri Dec 22, 2017 12:20 am
Forum: General
Topic: Bridge is like a hub, floods all ports.
Replies: 12
Views: 1115

Bridge is like a hub, floods all ports.

HI there,
I don't know why, but my bridge is acting as a hub. It floods every port in the bridge with packets. As far as I remember, I always had that problem.
RB2011UiAS-2HnD-IN
p1.JPG
hEX PoE connected to switch2\ether5
p2.JPG
Is this normal, this is how it should work? I hope not...
by MayestroPW
Thu Dec 21, 2017 3:20 am
Forum: RouterOS v6 RC and v7 BETA
Topic: 6.41rc66 Bridge VLAN Filtering and CAPs with VLAN tags.
Replies: 4
Views: 1186

6.41rc66 Bridge VLAN Filtering and CAPs with VLAN tags.

Hello, Right now I'm using 3 MikroTik's, which are connected together. Two of them are working as APs, and one is CAPsMAN. In total there is 4 networks, 1.JPG and every network has it's own Virtual Access Point in CAPsMAN. They are connected to the same bridge - bridge0, then there is VLAN tag on ev...
by MayestroPW
Sun Nov 19, 2017 9:32 pm
Forum: General
Topic: Can't restore backups on RB750Gr3
Replies: 17
Views: 1622

Re: Can't restore backups on RB750Gr3

So nobody knows how to restore that backup?
by MayestroPW
Sun Nov 19, 2017 7:39 pm
Forum: General
Topic: Can't restore backups on RB750Gr3
Replies: 17
Views: 1622

Re: Can't restore backups on RB750Gr3

I don't have passwords at all.
On the previous config, I had accounts with passwords, but it's not working when I'm typing them in.
Previously it was working, I was able to restore backups which were not encrypted, but right now I cannot.
by MayestroPW
Sun Nov 19, 2017 6:52 pm
Forum: General
Topic: Can't restore backups on RB750Gr3
Replies: 17
Views: 1622

Re: Can't restore backups on RB750Gr3

I don't have admin password because it's new config. On old config I didn't have a password either, I just set "allowed address" for an admin account.
My backups are not encrypted
by MayestroPW
Sun Nov 19, 2017 3:02 am
Forum: General
Topic: Can't restore backups on RB750Gr3
Replies: 17
Views: 1622

Can't restore backups on RB750Gr3

Hi, Recently I updated my hEX to 6.40.5 and it stopped working. I had to do a netinstall to recover it. When I wanted to restore a backup I found out that I couldn't. I tried different backups, from different periods, and none of them are working. I even tried different rOS verions(6.40.3, 6.40.4, 6...
by MayestroPW
Mon May 15, 2017 11:52 am
Forum: General
Topic: L7 and youtube
Replies: 17
Views: 21594

Re: L7 and youtube

You think that this discussion has a video and needs to be blocked? It has the word video all over the place. That would be no false positive for you? Of course when you access a site over https there is no match with the actual word video in the content, on the other hand it could trigger on any o...
by MayestroPW
Mon May 15, 2017 11:09 am
Forum: General
Topic: L7 and youtube
Replies: 17
Views: 21594

Re: L7 and youtube

For me this regex works fine: videoplayback|video works fine for youtube and every other online video stream even HTTPS, besides live streams ofc. It will work "fine" only when you do not count the massive false positives. It will hit on any packet with the word video in it. False positives? When a...
by MayestroPW
Fri May 05, 2017 2:45 am
Forum: Announcements
Topic: v6.39.1 [current]
Replies: 158
Views: 35950

Re: v6.39.1 [current]

There is still a problem within hotspot directory.
If I set it to:
/disk1/hotspot/hotspot1
It will be automatically changed to:
/flash/disk1/hotspot/hotspot1
by MayestroPW
Tue Apr 18, 2017 10:32 pm
Forum: Scripting
Topic: PPP Profile script problem ($interface var)
Replies: 3
Views: 2391

Re: PPP Profile script problem ($interface var)

Thank you for replay.
In 6.39rc72 they added the Interface List option to PPP Profile, so I will not need that script anymore.
*) ppp - added option to specify "interface-list" in PPP/Profile;
However, thank you.
by MayestroPW
Sun Apr 16, 2017 7:19 pm
Forum: General
Topic: Path finding problem
Replies: 0
Views: 264

Path finding problem

Hello, I have RB750Gr3. I uploaded my hotspot files on Disk1 on USB pendrive. When I select the path for that folder in Winbox it just adds /flash folder before it. Example /disk1/hotspot/hotspot1 It will change it to: /flash/disk1/hotspot/hotspot1 A similar problem is with SMB. When I add /disk1 sh...
by MayestroPW
Wed Apr 05, 2017 4:44 pm
Forum: Announcements
Topic: v6.39rc [release candidate] is released
Replies: 391
Views: 80584

Re: v6.39rc [release candidate] is released

Is there any possibility in future, that we could set other modes in cap settings than ap mode? I wish there was a station mode...
by MayestroPW
Wed Apr 05, 2017 4:40 pm
Forum: Announcements
Topic: v6.39rc [release candidate] is released
Replies: 391
Views: 80584

Re: v6.39rc [release candidate] is released

When I start background scan on cap it tells me: failure: background scan not supported in this state I ran it from cap router, not from capsman router. It will be only supported from the CAPsMAN side. Then how to run that scan? UPDATE: Ok, I found scan option, but need to add some channels to list...
by MayestroPW
Wed Apr 05, 2017 1:37 pm
Forum: Announcements
Topic: v6.39rc [release candidate] is released
Replies: 391
Views: 80584

Re: v6.39rc [release candidate] is released

When I start background scan on cap it tells me:
failure: background scan not supported in this state
I ran it from cap router, not from capsman router.
by MayestroPW
Wed Apr 05, 2017 1:25 pm
Forum: Announcements
Topic: v6.39rc [release candidate] is released
Replies: 391
Views: 80584

Re: v6.39rc [release candidate] is released

*) capsman - added support for "background-scan" and channel "reselect-interval";
How does background-scan works? In winbox I still can't run background scan on capsman interfaces.
by MayestroPW
Mon Apr 03, 2017 9:12 am
Forum: Beginner Basics
Topic: RSTP problem (6.38.1
Replies: 7
Views: 1663

Re: RSTP problem (6.38.1

Как теперь делать кольца на уровне vlan ?

Раньше все это прекрасно работало.
This is english speaking forum only.
by MayestroPW
Mon Mar 20, 2017 1:04 am
Forum: Scripting
Topic: PPP Profile script problem ($interface var)
Replies: 3
Views: 2391

PPP Profile script problem ($interface var)

Hello, I have a problem with PPP Profile up/down script. Up script is working fine, but down script doesn't work. Up: /interface list member add interface=$interface list=LAN Down: /interface list member remove numbers=[find where interface=$inteface] As you can probably, I am trying to add dynamic ...
by MayestroPW
Mon Feb 20, 2017 10:11 am
Forum: General
Topic: L7 and youtube
Replies: 17
Views: 21594

Re: L7 and youtube

YouTube uses QUIC, which uses UDP not TCP protocol.
For me this regex works fine:
videoplayback|video
works fine for youtube and every other online video stream even HTTPS, besides live streams ofc.
by MayestroPW
Fri Feb 17, 2017 4:03 pm
Forum: Announcements
Topic: v6.39rc [release candidate] is released
Replies: 391
Views: 80584

Re: v6.39rc [release candidate] is released

Nope. It was possible to added slave interface on CAPsMAN (controller), but you could not add slave interface locally on a CAP (managed board) itself. It appears to be possible now. When you connect CAP to CAPsMAN virtual interface on CAP becomes disabled. I just tested it, and it works same as 6.3...
by MayestroPW
Fri Feb 17, 2017 3:03 pm
Forum: Announcements
Topic: v6.39rc [release candidate] is released
Replies: 391
Views: 80584

Re: v6.39rc [release candidate] is released

As I understand, now you should be able to create child (virtual) interfaces under the physical interface that's being managed by CAPsMAN. I have not tried it myself yet, though.
That function was already
by MayestroPW
Fri Feb 17, 2017 2:22 pm
Forum: Announcements
Topic: v6.39rc [release candidate] is released
Replies: 391
Views: 80584

Re: v6.39rc [release candidate] is released

capsman - added support for static virtual interfaces on CAP;
What it means?
by MayestroPW
Wed Feb 08, 2017 5:24 am
Forum: RouterOS v6 RC and v7 BETA
Topic: Feature Req: Capsman Station Mode!!!
Replies: 3
Views: 979

Re: Feature Req: Capsman Station Mode!!!

+1 that would be great
by MayestroPW
Tue Feb 07, 2017 4:02 am
Forum: Beginner Basics
Topic: RSTP problem (6.38.1
Replies: 7
Views: 1663

Re: RSTP problem (6.38.1

I read it already and upgraded all of them to 6.38.1, then to 6.39rc25. Problem appeared on both versions.
I use Vlans on that bridge and those vlans are bridged to ethernet ports etc. So, as I understand, I can only use RSTP on my first bridge/trunk?
by MayestroPW
Tue Feb 07, 2017 3:24 am
Forum: Beginner Basics
Topic: RSTP problem (6.38.1
Replies: 7
Views: 1663

Re: RSTP problem (6.38.1

same here
by MayestroPW
Sun Feb 05, 2017 10:10 am
Forum: General
Topic: Loss of ARP causing bridge to function like a Hub?
Replies: 1
Views: 502

Re: Loss of ARP causing bridge to function like a Hub?

I'm dealing with the same problem. I have a RB2011UiAS-2HnD-IN, but it doesn't matter, the problem occurs on every RouterBoard I have(RB951G-2HnD, RB750Gr3, RB941-2nD, RB912UAG-5HPnD, and many more). I tested it on every RouterOS since 6.30. I don't know how to deal with it.
by MayestroPW
Wed Jan 11, 2017 7:06 pm
Forum: RouterOS v6 RC and v7 BETA
Topic: Log the right way up
Replies: 4
Views: 1029

Re: Log the right way up

+1 awesome idea!
by MayestroPW
Wed Jan 04, 2017 12:10 pm
Forum: RouterOS v7
Topic: Feature request: CAPsManager - roaming
Replies: 79
Views: 22076

Re: Feature request: CAPsManager - roaming

+1
I would love 802.11r/k/v support.
by MayestroPW
Thu Nov 03, 2016 3:15 pm
Forum: Scripting
Topic: Adding dynamic interfaces to interface list.
Replies: 8
Views: 4621

Re: Adding dynamic interfaces to interface list.

I'd rather to keep firewall like is now.
by MayestroPW
Wed Nov 02, 2016 6:43 pm
Forum: Scripting
Topic: Adding dynamic interfaces to interface list.
Replies: 8
Views: 4621

Re: Adding dynamic interfaces to interface list.

Because my firewall blocks traffic which is not coming from LAN and going to the WAN.
by MayestroPW
Tue Nov 01, 2016 10:53 pm
Forum: Scripting
Topic: Adding dynamic interfaces to interface list.
Replies: 8
Views: 4621

Re: Adding dynamic interfaces to interface list.

Actually i'm using this, but I don't know how to code it.
by MayestroPW
Tue Nov 01, 2016 7:37 pm
Forum: Scripting
Topic: Adding dynamic interfaces to interface list.
Replies: 8
Views: 4621

Adding dynamic interfaces to interface list.

Hi there, I have a problem with MikroTik. I need to make a script which adds my dynamic interface from PPTP to interface list when user connects, but I don't know how the script would look like. /interface list member add interface=[find interface=<pptp*] list=LAN MikroTik creates dynamic interface ...
by MayestroPW
Thu Oct 27, 2016 7:28 pm
Forum: Beginner Basics
Topic: Problem with hotspot and interface arp=reply-only
Replies: 6
Views: 2063

Re: Problem with hotspot and interface arp=reply-only

I have the same problem. ROS 6.37.1. Firewall Filter: clear, NAT: clear, Mangle: clear, Arp Reply-Only: ON, DHCP Add DHCP for Leases: ON. I don't know what causes the problem.
by MayestroPW
Wed Oct 26, 2016 3:46 pm
Forum: General
Topic: When Hotspot is on, firewall detects traffic within bridge (Use IP Firewall OFF)
Replies: 0
Views: 308

When Hotspot is on, firewall detects traffic within bridge (Use IP Firewall OFF)

Hello there! I have problem with my network. When I turn on hotspot, MikroTik's firewall detect my local traffic between devices in the same interface. In bridge I have WLAN and Switch. Bridge Use IP Firewall is OFF. Interface IP: 10.1.0.1/22 Hotspot IP: 10.1.0.2 Device #1 IP: 10.1.1.1 Device #2 IP:...