Community discussions

Search found 57 matches

by zivtal
Sun May 26, 2019 12:02 am
Forum: Wireless Networking
Topic: RB962UiGS-5HacT2HnT low wifi performance
Replies: 2
Views: 541

RB962UiGS-5HacT2HnT low wifi performance

Hi, I have long time Mikrotik equipment but until now I didn't understand why the wifi is soo week. I have at my home 2 access point (RB962UiGS-5HacT2HnT) distance about 7 meters and the max speed that I'm getting with my MacBook Pro is 300mbps upload and 200mbps download... I had before UniFi AP Pr...
by zivtal
Mon Apr 08, 2019 8:31 pm
Forum: General
Topic: Can mikrotik router connect to another network as hotspot client ?
Replies: 0
Views: 239

Can mikrotik router connect to another network as hotspot client ?

Can I connect Mikrotik router to another network as hotspot client, The network using http login page... I would like to create portable router for using while I'm travelling in hotels. I would like my router connect to hotel's hotspot as client for internet access and create me new network (dhcp se...
by zivtal
Sun Feb 10, 2019 7:58 pm
Forum: General
Topic: WAN static IP
Replies: 3
Views: 552

Re: WAN static IP

Is this your router providing internet to another router? OR Is this a LAN on your router connecting to a LAN on another router? If so what are the subnets for both ends?? In other words, forget rules and design for the moment, what are you trying to accomplish in functionality without talking abou...
by zivtal
Sun Feb 10, 2019 4:39 pm
Forum: General
Topic: WAN static IP
Replies: 3
Views: 552

WAN static IP

Hi, I would like to create ether port with static ip that connected to another router.... This is what I did: /ip address add address=192.168.0.19/24 interface=eth1 /ip route add gateway=192.168.0.1 /ip firewall nat add chain=srcnat out-interface=eth1 action=masquerade The problem I'm not getting ac...
by zivtal
Thu Feb 07, 2019 9:42 pm
Forum: Beginner Basics
Topic: How to block SSH attackers after 3 bad logins?
Replies: 16
Views: 2870

Re: How to block SSH attackers after 3 bad logins?

Hi Zivital, good question......... First of all, I don't have any access to my router from external sources. If I did it would be through VPN only. As for services you use API for example or SSH or winbox, the first thing I would do is change to a non-standard port if possible. Lets say you need to...
by zivtal
Thu Feb 07, 2019 9:12 pm
Forum: Beginner Basics
Topic: How to block SSH attackers after 3 bad logins?
Replies: 16
Views: 2870

Re: How to block SSH attackers after 3 bad logins?

Wow things can get complex rather quickly. If your not using SSH on the router at all, incoming or outgoing, Simply put it in raw. Same with FTP,,,,,,, /ip firewall raw add chain=prerouting dst-port=common_ssh_port action=drop /ip firewall raw add chain=prerouting dst-port=common_Ftp_port action=dr...
by zivtal
Thu Feb 07, 2019 8:15 pm
Forum: Beginner Basics
Topic: How to block SSH attackers after 3 bad logins?
Replies: 16
Views: 2870

Re: How to block SSH attackers after 3 bad logins?

I made this script, You should add scheduler every 5-10 minutes it's check if you had login failure more then 5 times from same ip it's automatically add the ip to block list. If you want only 3 attempts you can change the line: ":local attempt 5" to ":local attempt 3" #check if logging action exist...
by zivtal
Thu Jan 10, 2019 12:37 am
Forum: Scripting
Topic: Telegram BlackVS modified script
Replies: 7
Views: 3136

Re: Telegram BlackVS modified script

When I request the list of active users or the password recovery, the script does not respond, but if I ask for the information of a user, if it does. Apparently the problem is the size of the variable telegram, how can it be done so that the information is sent, it does not matter if it is fragmen...
by zivtal
Thu Jan 10, 2019 12:37 am
Forum: Scripting
Topic: hotspot manage by telegram
Replies: 0
Views: 875

hotspot manage by telegram

Telegram: https://forum.mikrotik.com/viewtopic.php?f=9&t=143828 put in ros script and call it "hotspot.cfg" # set hotspot 'Server' name # set hotspot 'Server Profile' login option(s) # set user 'Profile' name # set user 'Prefix' # set 'Expired' days # Limit upload/download bandwidth # Set max login ...
by zivtal
Thu Jan 10, 2019 12:21 am
Forum: Scripting
Topic: Telegram BlackVS modified script V2
Replies: 0
Views: 949

Telegram BlackVS modified script V2

configuration script (call it "telegram.cfg" and put it in scripts) # command should be the name of the script (default: telegram) # botapi - telegram botapi # reply - default message to (telegram id) # trusted - telegram id(s) accepted # refresh_active - change scheduler to check telegram for updat...
by zivtal
Sun Dec 09, 2018 7:29 am
Forum: General
Topic: Mikrotik to mikrotik P2P connection with Manuel IP from client
Replies: 0
Views: 245

Mikrotik to mikrotik P2P connection with Manuel IP from client

Hi,

I want P2P connection with 2 mikrotik but set manually IP from the one that is client and not from the server how can I do that?

I mean the main router IP range is 192.168.0.2-192.168.0.200 how can I set from secondary router connect to main router and get 192.168.0.2 IP manual?
by zivtal
Mon Aug 06, 2018 12:53 am
Forum: Forwarding Protocols
Topic: Bridge NAT forward device to guests' VLAN
Replies: 0
Views: 346

Bridge NAT forward device to guests' VLAN

Hi, I set in bridge's NAT several rules that accept specific MAC Addresses via ether1 and ether2 after that rules I set rule that drop all other connection witch means all other MAC Addresses will be drop from my network. It's look like that: /interface bridge nat add action=accept chain=dstnat src-...
by zivtal
Sun Aug 05, 2018 11:11 am
Forum: Scripting
Topic: Load functions from another script
Replies: 3
Views: 584

Re: Load functions from another script

Yes, you can :). 1. Make the getKeyValue and setKeyValue functions :global instead of :local 2. Run the one script defining all those global functions on startup 3. In the beginning of your script using the functions put: :global getKeyValue; :global setKeyValue; So the globals are in the memory al...
by zivtal
Wed Aug 01, 2018 4:57 pm
Forum: Scripting
Topic: Load functions from another script
Replies: 3
Views: 584

Load functions from another script

Hi, I have a lot's of scripts on-up / on-down / on-login / on-logout and etc,,... I some of them I'm using same functions that I made, Can I put the function in script and call it from those scripts (on-up/on-down and etc...) ? This is my useful functions, It's get input and return output... for exa...
by zivtal
Fri Jul 27, 2018 12:51 am
Forum: Forwarding Protocols
Topic: Dual WAN routing policy + mangle rules [not working]
Replies: 10
Views: 33894

Re: Dual WAN routing policy + mangle rules [not working]

I made a script that doing it, after running the script you should run from terminal: $WanInOut <add/remove> <wan interface name> <local lan interface name> This is the script: # WanInOut.rsc 06/03/2018 :global WanInOut do={ :if ([len $1]=0) do={:error "example: \$WanInOut <add/remove> <wan interfac...
by zivtal
Thu Apr 12, 2018 10:23 am
Forum: Scripting
Topic: on hotspot connect event (not on login)
Replies: 4
Views: 693

Re: on hotspot connect event (not on login)

whynot
This is on login, I want prelogin... I have hotspot protected by username and password (http) and I would like to do action before...

BTW- before login user not getting “user profile”...
by zivtal
Tue Apr 10, 2018 12:02 am
Forum: Scripting
Topic: on hotspot connect event (not on login)
Replies: 4
Views: 693

on hotspot connect event (not on login)

Hi, there is a way to run script on hotspot connect?, I mean to run script event not login...
While someone just connect to hotspot he is apper hosts... can I run script even he isn't login?
by zivtal
Wed Mar 28, 2018 12:05 am
Forum: Scripting
Topic: add default route
Replies: 3
Views: 764

Re: add default route

You didn't understand me I already have pppoe-out interface and l2tp-out interface, I would like to do foreach interface add to default route. and I would like to know if I can combine the command into one single foreach... the commands is not same for pppoe I should do "/interface pppoe-client set ...
by zivtal
Thu Mar 22, 2018 12:53 pm
Forum: Scripting
Topic: [:parse [/system script get SCRIPT source]]
Replies: 0
Views: 355

[:parse [/system script get SCRIPT source]]

this is work: :local run [:parse [/system script get SCRIPT source]] $run action=create user=username password=password this is not work,,... there is a way to make it work? :local param "action=create user=username password=password" :local run [:parse [/system script get SCRIPT source]] $run $para...
by zivtal
Thu Mar 22, 2018 2:49 am
Forum: Scripting
Topic: Script for generation and sending a passwords in SMS
Replies: 5
Views: 1506

Re: Script for generation and sending a passwords in SMS

your modem support sending and receiving sms via mikrotik?
by zivtal
Tue Mar 20, 2018 12:52 pm
Forum: Scripting
Topic: dynDNS Update Script
Replies: 158
Views: 109335

Re: dynDNS Update Script

I have made this script ddns.rsc , It's allow you to use dynDNS or Dynu with several dynamic domains and via specific interface(s)... :local ddns do={ :local dynhost :local dynurlv :if (([:len $provider]=0) or ([:len $host]=0) or ([:len $username]=0) or ([:len $password]=0)) do={ :error "missing par...
by zivtal
Tue Mar 20, 2018 12:12 pm
Forum: Scripting
Topic: add default route
Replies: 3
Views: 764

add default route

Hi, I would like to build a script that enable "add default route" to all interface type ending "out" such ("pppoe-out", "l2tp-out" and etc,,,)... I would like to know if there is a better way to do it,,.. attached code that I wrote, It's works but I would like to know if I can do it in another way ...
by zivtal
Mon Mar 19, 2018 3:37 pm
Forum: Scripting
Topic: remote ssh via script
Replies: 52
Views: 30743

Re: remote ssh via script

Made this long time ago, maybe it's will help you... :local router2address "192.168.88.1"; :local router2interfaces "sfpp1,sfp1,vlan9"; :local router2username "user1"; :local SetInterface do={ :local interfaces [:toarray $1]; :local mode [:tostr $2]; :local host $3; :local user [:tostr $4]; :local c...
by zivtal
Tue Mar 06, 2018 7:05 pm
Forum: Scripting
Topic: Problem while changing pppoe-client comment
Replies: 4
Views: 582

Re: Problem while changing pppoe-client comment

Indeed its happening i have seen that many times. I wonder also why. Comment is not a setting! damm, I'm tring you create wan monitor script, if there is no internet change comment to "disabled at <date and time>" and when the internet back change comment to "enabled at <date and time>" there is no...
by zivtal
Tue Mar 06, 2018 7:01 pm
Forum: Scripting
Topic: Telegram BlackVS modified script
Replies: 7
Views: 3136

Re: Telegram BlackVS modified script

called $telegram (once/if not exists). after running this script you can use commands such "$telegram action=send chat=<chatid> text=<message content>" to send telegram message or just $telegram ($telegram action=receive is same) to receive message/commands. How to use $telegram in a script, works ...
by zivtal
Tue Mar 06, 2018 4:30 pm
Forum: Beginner Basics
Topic: NAS
Replies: 12
Views: 1874

Re: NAS

Ok, I found the problem, Long time a go I made a srcnat masquerade "rollback" with Out. Interface "my-bridge". That's the problem. Anyway I disabled this NAT and it's work. But reason that I made that NAT as I remember that because I could not connect from local network to my dynamic address (dyndns...
by zivtal
Tue Mar 06, 2018 3:53 pm
Forum: Beginner Basics
Topic: NAS
Replies: 12
Views: 1874

Re: NAS

Hello Zivtal, In your mangle filter, just activate (check box) logging and you'll see in your log window the original address that was translated. Suggestion: add a logging prefix to identify those log entries faster. Regards, Sent from Tapatalk I want the ip address will forward to my NAS because ...
by zivtal
Tue Mar 06, 2018 3:42 pm
Forum: Beginner Basics
Topic: NAS
Replies: 12
Views: 1874

NAS

Hi, I have NAS and I made a firewall dst-nat rules, But I have problem, while I'm getting connection from outside (wan) I see in my NAS "connection from 192.168.1.1" (the ip of my router) there is anyway to get the ip that forwarded?
by zivtal
Sat Mar 03, 2018 2:03 pm
Forum: Scripting
Topic: Problem while changing pppoe-client comment
Replies: 4
Views: 582

Problem while changing pppoe-client comment

When I'm try to change pppoe-client comment I'm getting reconnecting ("disconnected", "initializing", "connecting", "authenticated", "connected")... any idead why?? and how to fix it?
by zivtal
Mon Feb 19, 2018 12:28 am
Forum: Scripting
Topic: Execute tool fetch on different WAN
Replies: 12
Views: 1423

Re: Execute tool fetch on different WAN

If you want you can modify my script: https://forum.mikrotik.com/viewtopic.php?f=9&t=130992 Hello, I try to better explain a tipical scenario: WAN1 IP: 192.168.1.2 Mask: 255.255.255.0 GW: 192.168.1.1 LAN IP: 192.168.10.254 Mask: 255.255.255.0 WAN2 IP: 192.168.0.2 Mask: 255.255.255.0 GW: 192.168.0.1 ...
by zivtal
Sun Feb 18, 2018 8:59 pm
Forum: Scripting
Topic: Telegram BlackVS modified script
Replies: 7
Views: 3136

Re: Telegram BlackVS modified script

Cool!
One question - what size of $telegram variable is?
Due to I thought variables in ROS could not exceed 4096 bytes... ( https://wiki.mikrotik.com/wiki/Manual:S ... #Variables )
I'm not sure, but it's work... (tested on CCR1009)...
by zivtal
Sun Feb 18, 2018 11:27 am
Forum: Scripting
Topic: Advanced Dynamic DNS script (DynDNS, Dynu) UPDATED
Replies: 1
Views: 1920

Advanced Dynamic DNS script (DynDNS, Dynu) UPDATED

ddns.rsc The script will update your dynamic dns and will create scheduler and netwatch for updates, You can update several proviaders (DynDNS and Dynu for now) and via specific interface (if you use several wan connections). :local ddns do={ :local dynhost :local dynurlv :if (([:len $provider]=0) ...
by zivtal
Sun Feb 18, 2018 11:11 am
Forum: Scripting
Topic: Set multi WAN In/Out connection
Replies: 0
Views: 451

Set multi WAN In/Out connection

wanInOut.rsc : This script will create a global command (script environment) called $WanInOut After run this script you should use terminal: Add WAN: $WanInOut add <your wan interface> <you local network/bridge> Remove WAN: $WanInOut remove <your wan interface> NOTE : If you leave <wan> and <bridge...
by zivtal
Sun Feb 18, 2018 10:59 am
Forum: Scripting
Topic: Wan Monitor (Check if internet working) -UPDATED
Replies: 1
Views: 4798

Wan Monitor (Check if internet working) -UPDATED

wanmonitor.rsc : The script check if internet available via pppoe,l2tp,ether and etc... If you not set your InternetInterface(s) the script will search automatically for pppoe,l2tp,ppp,sstp and ether with dhcp client. :if ([:len [/system scheduler find name=wanmonitor]]=0) do={ :log warning "creati...
by zivtal
Sun Feb 18, 2018 10:38 am
Forum: Scripting
Topic: Automatically generate guest's hotspot account
Replies: 0
Views: 1393

Automatically generate guest's hotspot account

genHotspot.rsc : This script creating new guest account randomly ( you should have before "Hotspot server" ), the script will create hotspot's user profile with "on-login" and random hotspot account (username and password), after someone login by this your it's will update him MAC address so no bod...
by zivtal
Sun Feb 18, 2018 10:35 am
Forum: Scripting
Topic: Telegram BlackVS modified script
Replies: 7
Views: 3136

Telegram BlackVS modified script

tgConfig.rsc : this is the configuration files - your bot's API, default chatID (will send message to this IDs when chat=<empty>), trusted will receive commands only from allowed IDs and etc...) ###################################### # Telegram bot API, VVS/BlackVS 2017 # Config file ##############...
by zivtal
Fri Feb 16, 2018 8:36 am
Forum: Scripting
Topic: Mikrotik and Telegram
Replies: 40
Views: 15863

Re: Mikrotik and Telegram

Great thanks ! Started to work on addons (cmd): viewtopic.php?f=9&t=130984
by zivtal
Wed Feb 14, 2018 1:58 am
Forum: Scripting
Topic: Mikrotik and Telegram
Replies: 40
Views: 15863

Re: Mikrotik and Telegram

Any idea how to build string for telegram message (new line and etc,,..), for example I would like to do foreach on every hotspot active connection create $str and send it by telegram message... Attached example code that I would like to send, I'm getting failed when I'm trying to send $mailBody via...
by zivtal
Tue Feb 13, 2018 5:58 pm
Forum: Scripting
Topic: Mikrotik and Telegram
Replies: 40
Views: 15863

Re: Mikrotik and Telegram

I'm trying to make telegram available by global (enviroment), This is the complete script: tgSendMessage work from mikrotik's terminal command line, But from another script it's not running :\ Any idea why? How do you call another script - from terminal manualy or , for example, via scheduler? If f...
by zivtal
Tue Feb 13, 2018 11:30 am
Forum: Scripting
Topic: Mikrotik and Telegram
Replies: 40
Views: 15863

Re: Mikrotik and Telegram

I'm trying to make telegram available by global (enviroment), This is the complete script: :global tgBotAPI "XXXXXXXXXXXXXXXXXXXXXXXXXXXXX"; :global tgDefaultChatID "AAAAAAAA,BBBBBBBB,CCCCCCC"; :global tgTrusted "AAAAAAAA,BBBBBBBB,CCCCCCC"; :global tgStorage ""; :global tgTimeout 1; :global tgSendMe...
by zivtal
Tue Feb 13, 2018 11:14 am
Forum: Scripting
Topic: Mikrotik and Telegram
Replies: 40
Views: 15863

Re: Mikrotik and Telegram

Command must start from /, i.e "/hi" but not "hi". Also this command should be set for you bot via @BotFarther's /setcommands. PS: sample commands done in lowercase, i.e "/hi", not "/Hi". Case makes difference too. Great, Thanks. I'm new with telegram :)... More question how I'm sending $cmd and $p...
by zivtal
Tue Feb 13, 2018 2:03 am
Forum: Scripting
Topic: Mikrotik and Telegram
Replies: 40
Views: 15863

Re: Mikrotik and Telegram

I tried the script, Nice job. But I have got problem with updates, It's seems like tgGetkey not working well... I'm allways getting: command= cmd=<> params=<> When I'm opening the file I see the incoming message ("Hi" in this example)... {"ok":true,"result":[{"update_id":44584376, "message":{"messag...
by zivtal
Mon Feb 12, 2018 1:38 pm
Forum: Beginner Basics
Topic: Port forwarding to multi IP addresses
Replies: 2
Views: 490

Port forwarding to multi IP addresses

Hi, I just made a firewall dst-nat port X to several ip range (example 192.168.1.81-192.168.1.84), It's working but I don't really know how the router decide witch ip address to use. I have been disconnected ports 192.168.1.82-192.168.1.84 and try to connect but it's not connecting... anything to do...
by zivtal
Sun Feb 11, 2018 10:13 pm
Forum: General
Topic: Script for interface LTE to restart [SOLVED]
Replies: 9
Views: 6339

Re: Script for interface LTE to restart [SOLVED]

I don't really know the SXT LTE, but you can try (disable and enable lte interface):
:if ([/ping 8.8.8.8 count=10 size=64 interval=2s]=0) do={
	:log error "LTE DOWN";
	/interface disable <interface>
	/delay 1s
	/interface enable <interface>
} else={
	:log info "LTE FINE";
}
by zivtal
Sun Feb 11, 2018 10:08 pm
Forum: General
Topic: Script for interface LTE to restart [SOLVED]
Replies: 9
Views: 6339

Re: Script for interface LTE to restart [SOLVED]

enable/disable to lte interface not help? if you need restart, just reboot the device it's only stadalone lte device...
:if ([/ping 8.8.8.8 count=10 size=64 interval=2s]=0) do={
	:log error "LTE DOWN";
	/system reboot;
} else={
	:log info "LTE FINE";
}
by zivtal
Sun Feb 11, 2018 9:55 pm
Forum: Scripting
Topic: Search mangle by command contain script...
Replies: 5
Views: 648

Re: Search mangle by command contain script...

Thanks!
by zivtal
Sun Feb 11, 2018 7:51 pm
Forum: Forwarding Protocols
Topic: Block unknown MAC address from wired network
Replies: 5
Views: 1821

Block unknown MAC address from wired network

Hi,

I would like to know if there is a way to block unknown devices by mac address from my local wired lan.

I mean if someone connect cable to my local port (wired) today he is getting dhcp pool ip and have access to my network, there is a way to block it ?
by zivtal
Sat Feb 10, 2018 6:33 pm
Forum: Scripting
Topic: Find specific firewall nat
Replies: 1
Views: 377

Find specific firewall nat

I would like to check if firewall nat is exists, I would like to find it by 3 parameters "chain,action,out-interface" and get return only if there is no other parameters except the 3 parameters that I wrote... /ip firewall nat find where chain=srcnat and action=masquerade and out-interface="bridge-l...
by zivtal
Sat Feb 10, 2018 3:57 pm
Forum: Scripting
Topic: Search mangle by command contain script...
Replies: 5
Views: 648

Re: Search mangle by command contain script...

Just check it and got an error :/ "missing value for where (line 1 column 48)" There is, but you don't have to use foreach at all. You can just use "find" to match the correct items: /ip firewall mangle remove [find where comment~="incoming from"] The "find" gets you IDs of all items that contain "i...
by zivtal
Fri Feb 09, 2018 10:52 pm
Forum: Scripting
Topic: Search mangle by command contain script...
Replies: 5
Views: 648

Search mangle by command contain script...

Hi, I have several mangles that contain the work "incoming from" in his comment (for example: "prerouting incoming from 'eth08client' outgoing to 'bridge-local'"), I would like to remove all [/ip firewall mangle] that contain the works "incoming from" in comment... there is a way to do it with forea...
by zivtal
Fri Feb 09, 2018 10:47 pm
Forum: Scripting
Topic: Force DDNS update out WAN1
Replies: 10
Views: 1881

Re: Force DDNS update out WAN1

This is script that I made, Hope it will help you... You can update DDNS via main wan or via specific PPPoE/L2TP/Ethernet/Lte etc,,,.. # Script name (must be same as you called the script) :local ScriptName "dDNS" # Define dynamic hosts [example 'INTERFACE|PROVAIDER@DYNAMICHOST' (via interface), exa...
by zivtal
Fri Feb 09, 2018 10:42 pm
Forum: Scripting
Topic: DynDNS script that works?
Replies: 8
Views: 6287

Re: DynDNS script that works?

This is script that I made, Hope it will help you... # Script name (must be same as you called the script) :local ScriptName "dDNS" # Define dynamic hosts [example 'INTERFACE|PROVAIDER@DYNAMICHOST' (via interface), example 'PROVAIDER@DYNAMICHOST' (via default gateway/interface)] :local Hosts "dyndns...
by zivtal
Tue Mar 21, 2017 12:07 pm
Forum: RouterBOARD hardware
Topic: Looking for LTE/4G modem USB (or MiniPCIe with Adapter to USB) that support PPP
Replies: 1
Views: 653

Looking for LTE/4G modem USB (or MiniPCIe with Adapter to USB) that support PPP

Hi, I'm using Mikrotik CCR1009-8G-1S-1S+PC and I'm looking for LTE/4G modem that support PPP connection and SMS sending/receiving function, Has I know I don't have internal option such Mini PCIe, So I'm looking for USB solution, it's can be Mini PCIe with Adapter to USB. Prefer maximum speed and som...
by zivtal
Tue Mar 21, 2017 10:47 am
Forum: Scripting
Topic: Advanced dynDNS script
Replies: 0
Views: 832

Advanced dynDNS script

# Script name (must be same as you called the script) :local scriptname "dynDNS" # Define DynDNS' username :local ddnsuser "username" # Define DynDNS' password :local ddnspass "password" # Define DynDNS' hosts (seperate by ',' and if you want send request via specific wan interface, add prefix to h...
by zivtal
Tue Mar 21, 2017 10:16 am
Forum: Scripting
Topic: Allow incoming connection from several wan ports
Replies: 0
Views: 358

Allow incoming connection from several wan ports

:global WanInOut do={ :if ([len $1]=0) do={:error "example: \$WanInOut <add/remove> <wan interface name> <local lan interface name>";} :local todo [:tostr $1]; :local wans [:tostr $2]; if ([:len $wans]=0) do={ :foreach idn in=[/interface find where type="pppoe-out" and disabled=no or type="l2tp-out...
by zivtal
Mon Feb 06, 2017 3:58 pm
Forum: Scripting
Topic: How to get current script's filename ? [Help]
Replies: 1
Views: 542

How to get current script's filename ? [Help]

Hi, I would like to know if there is away to check the script name.

I mean I want to write log prefix "MyScriptName" (variable, I mean it's will change when i'll change name).
by zivtal
Sun Feb 05, 2017 6:27 pm
Forum: Beginner Basics
Topic: script: check and reconnect pppoe-session.
Replies: 5
Views: 14593

Re: script: check and reconnect pppoe-session.

tpfresh , I use the same script. It's already corrected for you. Three steps... At first, add the routes: /ip route add dst-address=213.180.193.58 gateway=49.48.216.1 scope=10 comment="Static PING way by ISP1-host1" add dst-address=198.41.213.157 gateway=49.48.216.1 scope=10 comment="Static PING wa...