Community discussions

Search found 42 matches

by iperezandres
Thu Jul 18, 2019 5:47 pm
Forum: Announcements
Topic: v6.45.1 [stable] is released!
Replies: 416
Views: 56458

Re: v6.45.1 [stable] is released!

No idea. As far as I am reading, everyone seams to be experiencing different issues, but for me they look completely unrelated. Maybe v6.45.1 is not that stable?
by iperezandres
Wed Jul 17, 2019 7:26 pm
Forum: Announcements
Topic: v6.45.1 [stable] is released!
Replies: 416
Views: 56458

Re: v6.45.1 [stable] is released!

The process for the API, is the same one that follows winbox for the user authentication? May that be related to the issue with incorrect user and password error?
by iperezandres
Wed Jul 17, 2019 8:10 am
Forum: Announcements
Topic: v6.45.1 [stable] is released!
Replies: 416
Views: 56458

Re: v6.45.1 [stable] is released!

Is it me or 6.45.1 is giving everyone a different type of headache? I don't remember an update with soooo many problems, right?

Any fix coming soon?

Thanks.
by iperezandres
Tue Jul 16, 2019 5:41 pm
Forum: Announcements
Topic: v6.45.1 [stable] is released!
Replies: 416
Views: 56458

Re: v6.45.1 [stable] is released!

The first time I updated a RB951 to 6.45.1, I started receiving the error of invalid user and password. I somehow managed to access it via web access, downgraded to 6.44.3, and everything started working again. Then I tried again, updated the RB951 to 6.45.1 and winbox to 3.19. Everything seamed ok,...
by iperezandres
Wed Jun 19, 2019 10:27 am
Forum: RouterBOARD hardware
Topic: Usage GPON module SFP in Spain
Replies: 183
Views: 39806

Re: Usage GPON module SFP in Spain

Good to know, we will have to wait...
by iperezandres
Sat Jun 15, 2019 10:32 am
Forum: RouterBOARD hardware
Topic: Usage GPON module SFP in Spain
Replies: 183
Views: 39806

Re: Usage GPON module SFP in Spain

I've seen it in alibaba for 60-70$, minimum 1 unit.
by iperezandres
Wed Jan 30, 2019 4:32 pm
Forum: Beginner Basics
Topic: IP Sec tunnel alive but no traffic (NAT and Firewall rules are added)
Replies: 9
Views: 555

Re: IP Sec tunnel alive but no traffic (NAT and Firewall rules are added)

I have seen in your screenshots that you open 4500 UDP port, but I believe you are missing protocol 50 (IPSEC-ESP). That is used to transport de encrypted traffic once the tunnel is establish, so if you don't allow it, the tunnel is established, but the data does not flow. /ip firewall filter add ac...
by iperezandres
Wed Jan 16, 2019 3:01 pm
Forum: RouterOS v6 RC and v7 BETA
Topic: Feature requests
Replies: 1098
Views: 192592

Re: Feature requests

Please add temperature and voltage to the dashboard of the Winbox. Often it is necessary to monitor the parameters and the location on the dashboard would simplify this at times. winbox upg.jpg Now that you mention this, what about being able to personalize the parameters being shown on the dashboa...
by iperezandres
Tue Jan 08, 2019 12:40 pm
Forum: General
Topic: How to limit interface with monthly quota (GB)
Replies: 3
Views: 506

Re: How to limit interface with monthly quota (GB)

Why don't you use scripts? You can check the MBytes consumed in your WAN interface every 30 minutes or so, and disable the interface after the quota is exceeded, or use queues to limit the BW.
by iperezandres
Fri Dec 28, 2018 12:22 pm
Forum: Scripting
Topic: Type "nothing" [SOLVED]
Replies: 15
Views: 1361

Re: Type "nothing" [SOLVED]

Such a good explanation, that was the feeling I was getting from my tests but it is great to have a confirmation. The thing is that "execute" is a very useful command, even though it has its limitations, and lets you manage code in a dynamically fashion. Thanks! Declaring global variable works as it...
by iperezandres
Fri Dec 28, 2018 12:14 pm
Forum: Scripting
Topic: how to set an element in an array
Replies: 5
Views: 3905

Re: how to set an element in an array

You are right, haven't tried that approach!
Not necessarily. If you know which index you want to edit you can go like this:

set ($arrayVariable->$arrayIndex) $newValue

Where $arrayIndex is an integer.
by iperezandres
Wed Dec 26, 2018 12:35 pm
Forum: Scripting
Topic: how to set an element in an array
Replies: 5
Views: 3905

Re: how to set an element in an array

Yes, you can, but you need to assign "names" to each value in the array:
:global x {"1"="a";"2"="b";"3"="c";"4"="d"}
:put $x
Output: 1=a;2=b;3=c;4=d
:set ($x->"3") "ccc"
:put $x
Output: 1=a;2=b;3=ccc;4=d

Hope it helps.
by iperezandres
Sun Dec 09, 2018 6:57 pm
Forum: Scripting
Topic: Type "nothing" [SOLVED]
Replies: 15
Views: 1361

Re: Type [SOLVED]

Mmm, interesting approach! Let me give it a try... Thanks!
by iperezandres
Sun Dec 09, 2018 5:19 pm
Forum: Scripting
Topic: Type "nothing" [SOLVED]
Replies: 15
Views: 1361

Re: Type "nothing" [SOLVED]

Don't think that is the problem, I tried as admin with every policy selected, and same result. Unless the terminal runs the code with different permissions; that, I don't know.
by iperezandres
Sun Dec 09, 2018 5:12 pm
Forum: Scripting
Topic: Type "nothing" [SOLVED]
Replies: 15
Views: 1361

Re: Type "nothing" [SOLVED]

Thank you Jotne, I will keep on trying different approaches and I will try support@mt as well.
Keep you posted!
by iperezandres
Sun Dec 09, 2018 3:13 pm
Forum: Scripting
Topic: Type "nothing" [SOLVED]
Replies: 15
Views: 1361

Re: Type "nothing" [SOLVED]

It works from the terminal but it does not work from a script. This code in the terminar returns "type=num": [admin@MK] > { {... :local i 1; {... :execute ":global TrafWAN$i"; {... :global type [:typeof $TrafWAN1]; {... } But the same code in a script returns "type=nothing": :local i 1; :execute ":g...
by iperezandres
Sun Dec 09, 2018 2:36 am
Forum: Scripting
Topic: Type "nothing" [SOLVED]
Replies: 15
Views: 1361

Type "nothing" [SOLVED]

With this code: :global X1 1 :global type1 [:typeof $X1] The type of X1 is "num". But with this other code: :global i 1 :execute ":global X$i" :global type2 [:typeof $X1] The type of X1 is "nothing" instead of "num", with X1 being previously declared as a global variable from other script. ¿Why the ...
by iperezandres
Wed Dec 05, 2018 12:42 pm
Forum: Forwarding Protocols
Topic: Set default view in Winbox...
Replies: 6
Views: 1000

Re: Set default view in Winbox...

Awesome! I didn't know about this option, it works like a charm! Thanks a lot.
by iperezandres
Wed Dec 05, 2018 10:51 am
Forum: RouterOS v6 RC and v7 BETA
Topic: Feature requests
Replies: 1098
Views: 192592

Re: Feature requests

It would be awesome to be able to save the winbox personalized views, instead of having to rearrange every window every time we connect to a new device.

UPDATE: as it turns out, it already exists the solution: viewtopic.php?f=14&t=120033 :)
by iperezandres
Wed Dec 05, 2018 10:28 am
Forum: General
Topic: 2011UiAS Ethernet Interface Flapping
Replies: 11
Views: 2332

Re: 2011UiAS Ethernet Interface Flapping

The same here, a long time has passed and we already have v6.43.4 and nothing has changed. I think it might be related to the device connected to the port that flaps. In my case it is an smart TV, so I suspect that when it is in standby mode, it connects and disconnects from time to time.
by iperezandres
Wed Dec 05, 2018 10:21 am
Forum: General
Topic: Port flapping (ether6 link down/up) on RB3011UiAS-RM
Replies: 27
Views: 13042

Re: Port flapping (ether6 link down/up) on RB3011UiAS-RM

The same here, a long time has passed and we already have v6.43.4 and nothing has changed. I think it might be related to the device connected to the port that flaps. In my case it is an smart TV, so I suspect that when it is in standby mode, it connects and disconnects from time to time.
by iperezandres
Wed Dec 05, 2018 10:16 am
Forum: Forwarding Protocols
Topic: Set default view in Winbox...
Replies: 6
Views: 1000

Re: Set default view in Winbox...

Still expecting some progress about this... It would be awesome to be able to save the winbox personalized view, instead of having to rearrange every window every time we connect to a new device.
by iperezandres
Wed Dec 05, 2018 10:12 am
Forum: General
Topic: Match Router originated traffic
Replies: 5
Views: 787

Re: Match Router originated traffic

I found another approach using mangle rules, to capture the traffic going from your connected IPs (router and LAN) to the not connected IPs: /ip firewall address-list add address=192.168.1.0/24 list=Connected # WAN network add address=192.168.100.0/24 list=Connected # LAN network add address=192.168...
by iperezandres
Wed Dec 05, 2018 10:07 am
Forum: General
Topic: How to combine 3 WAN speed
Replies: 10
Views: 6609

Re: How to combine 3 WAN speed

I solved my issue, but it is related to the type of WAN I use, which is an LTE connection. The problem has to do with the different types of SIM cards used, meaning the different contracts that you can have with the Operator. We are using for this project SIMs of M2M data contracts and regular data ...
by iperezandres
Wed Dec 05, 2018 10:05 am
Forum: Beginner Basics
Topic: PCC Load Balancing 2 WAN on Mikrotik HEX
Replies: 16
Views: 2128

Re: PCC Load Balancing 2 WAN on Mikrotik HEX

Solved it! Thank you WeWiNet, you gave the clue. The problem has to do with the different types of SIM cards used, meaning the different contracts that you can have with the Operator. We are using for this project SIMs of M2M data contracts and regular data contracts. The problem arises when we use ...
by iperezandres
Wed Nov 21, 2018 11:04 pm
Forum: Beginner Basics
Topic: PCC Load Balancing 2 WAN on Mikrotik HEX
Replies: 16
Views: 2128

Re: PCC Load Balancing 2 WAN on Mikrotik HEX

With the hAP ac^2, 180 DHCP users and 4000 connections, the CPU is at always below 30%. Now, I have just got today the brand new RB4011. Using the same script, I have the same issue when the 2 WANs are 4G routers. But if I try it at home, using my 100M symmetric fiber as the first WAN, and one of th...
by iperezandres
Wed Nov 21, 2018 8:12 pm
Forum: Beginner Basics
Topic: PCC Load Balancing 2 WAN on Mikrotik HEX
Replies: 16
Views: 2128

Re: PCC Load Balancing 2 WAN on Mikrotik HEX

And yes, you were right and there was an error in the pcc lines, it should be 1:1 balancing. Let me edit the post and correct it for future references.
by iperezandres
Wed Nov 21, 2018 8:11 pm
Forum: Beginner Basics
Topic: PCC Load Balancing 2 WAN on Mikrotik HEX
Replies: 16
Views: 2128

Re: PCC Load Balancing 2 WAN on Mikrotik HEX

I've donde that already. Both wans reach independently 60-80Mbps, but once they work together only add up to 60-70Mbps. All the test were done at night with the network more or less free, at least not congested.
by iperezandres
Wed Nov 21, 2018 4:23 pm
Forum: Beginner Basics
Topic: PCC Load Balancing 2 WAN on Mikrotik HEX
Replies: 16
Views: 2128

Re: PCC Load Balancing 2 WAN on Mikrotik HEX

Following this thread, I have a script for 2 WANs, very similar to the one posted earlier here, using PCC. If each WAN can reach around 80Mbps individually, I was expecting to get an aggregated sum of 160Mbps, but when I try to aggregate them, I get a total of 60Mbps: 30Mbps in each one. - Each WAN ...
by iperezandres
Wed Nov 21, 2018 3:19 pm
Forum: General
Topic: matching traffic from the router itself in mangle
Replies: 8
Views: 1292

Re: matching traffic from the router itself in mangle

I found another approach instead of creating the fake-bridge. First, you add a route with as many WANs as you have, so it also gives you fail over. /ip route add dst-address=0.0.0.0/0 gateway=ether1-wan1,ether2-wan2 distance=1 check-gateway=ping comment="ros route" And then you add a rule in mangle ...
by iperezandres
Mon Nov 12, 2018 11:28 pm
Forum: General
Topic: How to combine 3 WAN speed
Replies: 10
Views: 6609

Re: How to combine 3 WAN speed

I suffer a similar situation. I have a script for 2 WANs, very similar to the one posted earlier here, using PCC. If each WAN can reach around 60Mbps individually, I was expecting to get an aggregated sum of 120Mbps, but when I try to aggregate them, I get a total of 60Mbps: 30Mbps in each one. One ...
by iperezandres
Sat Apr 21, 2018 1:21 am
Forum: General
Topic: matching traffic from the router itself in mangle
Replies: 8
Views: 1292

Re: matching traffic from the router itself in mangle

Thank you Sob, that was very fine coding! It worked like a charm. With the fake bridge, any connection from the router itself now shows up in the firewall connection tab, and once you have it there, it is catched by the mangle rules and it is easy to route it through the WAN that you want. Awesome s...
by iperezandres
Fri Apr 20, 2018 10:15 am
Forum: General
Topic: matching traffic from the router itself in mangle
Replies: 8
Views: 1292

Re: matching traffic from the router itself in mangle

Very interesting approach, let me try it and get back to you. Thanks!
by iperezandres
Thu Apr 19, 2018 12:42 pm
Forum: General
Topic: matching traffic from the router itself in mangle
Replies: 8
Views: 1292

Re: matching traffic from the router itself in mangle

Not yet, I have the same problem. I have tried output chain and mark-routing but it is not working. If there is no default route, the packets originated from the router itself do not get catched in any of the mangle rules and they do not show up in the connection tab. Any suggestion? I have tried ma...
by iperezandres
Thu Apr 19, 2018 12:36 pm
Forum: General
Topic: Match Router originated traffic
Replies: 5
Views: 787

Re: Match Router originated traffic

I have the same problem. I have tried output chain and mark-routing but it is not working. If there is no default route, the packets originated from the router itself do not get catched in any of the mangle rules and they do not show up in the connection tab. Any suggestion? I have tried many differ...
by iperezandres
Wed Mar 21, 2018 12:54 pm
Forum: Forwarding Protocols
Topic: Set default view in Winbox...
Replies: 6
Views: 1000

Re: Set default view in Winbox...

I totally agree with you, once you like a specific view (columns, etc...), it should be possible to use it for every device you connect to.

Also, it would be nice to be able to personalize the winbox "skin", as in the web page interface.
by iperezandres
Wed Feb 22, 2017 7:36 pm
Forum: General
Topic: 2011UiAS Ethernet Interface Flapping
Replies: 11
Views: 2332

Re: 2011UiAS Ethernet Interface Flapping

I agree, as soon as there is traffic, the flapping stops.
by iperezandres
Tue Feb 21, 2017 12:40 pm
Forum: General
Topic: 2011UiAS Ethernet Interface Flapping
Replies: 11
Views: 2332

Re: 2011UiAS Ethernet Interface Flapping

I have the same issue with a 962UiGS-5HacT2HnT connected to the 1GB ports on a RB2011UAS. The fix for me is to reboot the RB2011UAS last. In other words, the last device to be rebooted (by a space of at least a minute or so or whenever the other switch is up and running fully) must be the MikroTik....
by iperezandres
Mon Feb 20, 2017 12:11 pm
Forum: General
Topic: Port flapping (ether6 link down/up) on RB3011UiAS-RM
Replies: 27
Views: 13042

Re: Port flapping (ether6 link down/up) on RB3011UiAS-RM

Sorry, didn't work setting the loop protection to "off", same link down / link up situation.
The frequency is not constant, sometimes it happens every minute, every 2 minutes, 5 minutes...
UPDATE: it happens in both switches, 1 and 2. What I have in that port is a Sony Bravia TV with Android TV.
by iperezandres
Mon Feb 20, 2017 12:07 pm
Forum: General
Topic: Port flapping (ether6 link down/up) on RB3011UiAS-RM
Replies: 27
Views: 13042

Re: Port flapping (ether6 link down/up) on RB3011UiAS-RM

Same issue here. My model is a 2011UiAS-2HnD, firmware 3.33 and v6.38.1.
Only see the flapping in the second switch (eth 6-10).
I have tried many things without success. I have just disabled loop protection, let's see how it goes...
Thanks!
by iperezandres
Fri Feb 17, 2017 11:14 am
Forum: RouterBOARD hardware
Topic: Usage GPON module SFP in Spain
Replies: 183
Views: 39806

Re: Usage GPON module SFP in Spain

Hello, I am another user pretty interested in having my Mikrotik as the unique device connected to my ISP fiber optic network, instead of having an ONT in the middle. The solution for this problem relies on Mikrotik developing a firmware capable of changing the SN of the SFP module with our ONT's SN...
by iperezandres
Mon Feb 13, 2017 1:20 pm
Forum: General
Topic: 2011UiAS Ethernet Interface Flapping
Replies: 11
Views: 2332

Re: 2011UiAS Ethernet Interface Flapping

Hello,

Any news about this thread? I have the same situation with the 2011UiAS and a TPLINK WPA4220. Constant flapping of the mikrotik interface every 2 minutes or so.

I have tried restricting auto negotiation to one option (100M full duplex) and doing it manually, without succes.

Thanks.