I can confirm @ploquets behaviour about CCS326-24G-2S+RM having RX pauses with Flow control enabled on the SFP1 with 10GB 3M DAC cable to CRS328-24P-4S SFP1. Both running SWOS 2.10, the RX pauses on the CCS326 are the exact double amount of the TX pauses on the CRS328.
have you tried no flow control at all?
No, indeed haven’t disabled flow control I’m already glad I don’t see any errors anymore. Haven’t had any real issues either since there is almost no traffic on these switches some voip/webbrowsing.
The first thing I’m will to try is change the original 3m mikrotik DAC 10GB cable with another one even optical and than change the trunk port from sfp to a regular 1GB copper port on the switch.
If you look at my screen grab above you can see a list of 3M DAC’s that also seem to have this same issue with Flow control enabled. I am really leaning towards trying optics out, if you try optics I would be interested to hear if that fixed it.
@chechito I have never had to disable flow control before, but I have also never used Mikrotik. In my case with 10G host to Switch communication on a single switch with active LACP between the host and the switch, Do you think I should try to disable flow control? I know I need it on my SFP7 link that links my two Mikrotik switches since the devices on the second switch are all 1g.
Thank you all for your time
-Fred
i always use flow control disabled on all installations
i dont understand Why MikroTik do not publish buffer size of any switch on their product line
that info its very important to forecast switch performance
I agree, i’d like to see buffer numbers on all the switching chips to be able to plan.
The Marvell Prestera chipset this switch is based on (98DX3236) is used in a few other platforms and the listed buffer space is 12MB for the 24 port model.
https://eltex-co.com/upload/iblock/9af/MES_2324P_2348P_datasheet_4.0.10.1_en.pdf
I have a CRS317-1G-16S+RM as my main switch in my rack, extended via 10GBase-SR and OM3 fiber (Finisar Transducers) to two remote CSS326-24G-2S+RM and one CRS305-1G-4S+.
All the clients attached to the secondary switches are gigabit only.
I have a large number of RX pauses on the SFP+ port on the CRS317 which goes to one of the CSS326 switches. The corresponding SFP+ port on the CSS326 has TX Pauses, (but only about half as many as the CRS317 switch has RX pauses for some reason. I would have thought these would match)
The other CRS326 and the CRS305 are both fine without any pauses.
All of my switches are running SWOS.
Not sure if I am having the same issue as those of you in this thread, if it is a switch hardware issue, a switch software issue, my choice of transducer, or bad fiber that is causing this.
I only used the Finisar transducers because they are what I already had, and they seemed to work.
Signal between the two switches seems perfect with TX dBm on one almost identically matching RX dBm on th eother and vice versa.
Appreciate any thoughts or suggestions.
Try mention above on 317:
Boot RouterOS on it, upgrade it to latest version. upgrade system firmware too. Boot SwOS and upgrade it to latest version. Remove TX/RX flow control on all switches.
Cheers
I’ll have to try that when I have some light usage some time. Thnaks for the suggestions.
So are you saying that there is firmware on the router that is not updated when you update SwOS and only updated when you update RouterOS?
Well, I figured out why it was only affecting the ports of one of the two CRS326’s was connected to.
Turns out I somehow missed updating it. It was still on SwOS 2.07, or something like that. When I caught it, an dupdated it to 2.12, I now have paus frames on th eports of both the CRS326’s
I’m guessing the CRS326 added flow control support somewhere between 2.07 and 2.11.
Fixed on a CSS326-24G-2S+
Downloaded lastest 2.13 and disabled flow control on the port that was giving me errors.
Turns out that port was being used by a PC that was connecting via client to my vivotek camera server (VAST version), the RX overrun errors would start appearing as soon the VAST client initialized and started streaming the cameras.
The switch would eventualy HANG when the user leaves the client running for a day or two, sometimes.
So far no more errors at least.
As of today the RX overflows didnt came back (left the camera client running since yesterday). I did try to replicate the error by reenabling flowcontrol Tx on the same port and still no errors… only a few Tx pauses here and there
Just to clarify, initially I had 2 of these switches with SwOS on them:
- One worked flawlessly for almost 2 years (the one I posted about before)
- The other crapped the bed in less than 6 months. It was hanging for the same reasons, overruns caused from another PC which was ALSO streaming the camera feeds though the VAST client and the user would forgot to turn it off.
I replaced the last one i mentioned (after a year of issues, bought same model for some reason…), and I didn’t need to change anything other than upgrading the software to 2.09 at the time, not a single problem after a year and that guy still keeps forgetting to turn off the camera client…
Right now both are upgraded to 2.13.
Both have some connections negotiating at 1G and others at 100Mb, somebody mentioned that could be the cause.
I’ll keep testing both and switching the ports around to see what happens.