Community discussions

 
g22113
just joined
Topic Author
Posts: 4
Joined: Sat Aug 19, 2017 3:21 pm

6.41rc61: DHCP server ignores dns-servers?

Thu Dec 07, 2017 10:48 am

Hi,

Under "/ip dhcp-server network" I have my LAN network configured with "dns-server=8.8.8.8", but RouterOS is completely ignoring that and advertising its own IP address plus the gateway's IP address as domain servers.

Yes, I know for most LANs that would be normal, but then what's the point of that dns-server parameter? If I have it set to 8.8.8.8, I really expect the actual offers to have 8.8.8.8 in them.

I'm fairly sure it used to work in previous versions. But I don't know how to downgrade to rc56 and check...
> /ip dns print 
                      servers: 8.8.8.8,8.8.4.4
              dynamic-servers: 192.168.1.254
        allow-remote-requests: yes

> /ip dhcp-server network export
add address=192.168.1.0/24 dns-server=8.8.8.8 gateway=192.168.1.254

> /log print
06:15:22 dhcp,debug,packet homelan sending offer with id 4235275550 to 192.168.1.65
.....
06:15:22 dhcp,debug,packet     Subnet-Mask = 255.255.255.0 
06:15:22 dhcp,debug,packet     Router = 192.168.1.254 
06:15:22 dhcp,debug,packet     Domain-Server = 192.168.1.37,192.168.1.254
(.37 is the mikrotik DHCP server, .254 is the gateway router)
Last edited by g22113 on Fri Dec 08, 2017 10:04 am, edited 2 times in total.
 
toxiczka
just joined
Posts: 4
Joined: Tue Oct 18, 2016 11:25 pm

Re: 6.41rc61: DHCP server ignores dns-servers?

Thu Dec 07, 2017 10:10 pm

Hi,

I have the same problem here. DHCP Server is offering DNS servers configured under "/ip dns"

Code: Select all

> /ip dns print
servers: 9.9.9.9,8.8.8.8,8.8.4.4
and NTP servers configured under "/system ntp client"

Code: Select all

> /system ntp client print
enabled: yes
mode: unicast
primary-ntp: 192.168.1.2
instead of them configured under for the network "/ip dhcp-server network"

Code: Select all

/ip dhcp-server network print value-list
address: 192.168.1.0/24
gateway: 192.168.1.1
netmask: 24
dns-server: 192.168.1.2,192.168.1.3,192.168.1.4
wins-server:
ntp-server: 192.168.1.250
caps-manager:
domain:
dhcp-option:

Log example:

Code: Select all

20:52:29 dhcp,debug,packet lan received request with id 2733563153 from 0.0.0.0
20:52:29 dhcp,debug,packet ciaddr = 0.0.0.0
20:52:29 dhcp,debug,packet chaddr =
20:52:29 dhcp,debug,packet Msg-Type = request
20:52:29 dhcp,debug,packet Address-Request = 192.168.1.50
20:52:29 dhcp,debug,packet Parameter-List = Subnet-Mask,Broadcast-Address,Unknown(2),Classless-Route,Domain-Name,Domain-Server,Host-Name,Unknown(40),Unknown(41),NTP-Server,Interface-MTU,Domain-Search,Router
20:52:29 dhcp,debug,packet Client-Id =
20:52:29 dhcp,debug,packet lan sending ack with id 2733563153 to 192.168.1.50
20:52:29 dhcp,debug,packet ciaddr = 0.0.0.0
20:52:29 dhcp,debug,packet yiaddr = 192.168.1.50
20:52:29 dhcp,debug,packet siaddr = 192.168.1.1
20:52:29 dhcp,debug,packet chaddr =
20:52:29 dhcp,debug,packet Msg-Type = ack
20:52:29 dhcp,debug,packet Server-Id = 192.168.1.1
20:52:29 dhcp,debug,packet Address-Time = 864000
20:52:29 dhcp,debug,packet Subnet-Mask = 255.255.255.0
20:52:29 dhcp,debug,packet Domain-Name = ""
20:52:29 dhcp,debug,packet Domain-Server = 192.168.1.1,9.9.9.9,8.8.8.8,8.8.4.4
20:52:29 dhcp,debug,packet NTP-Server = 192.168.1.2
20:52:29 dhcp,debug,packet Router = 192.168.1.1
Any ideas?
 
lukas2511
just joined
Posts: 4
Joined: Sat Jan 07, 2017 1:19 pm

Re: 6.41rc61: DHCP server ignores dns-servers?

Fri Dec 08, 2017 2:56 am

Same issue here, router is announcing its ip + dynamic pppoe dns servers instead of the configured dns-server.
Redid the configuration about three times until I recognized that it must be a RC bug...

(Ugly but working) temporary solution would be a firewall dnat rule or just a forward-reject like this if the router should be the only dns server:
/ip firewall filter add action=reject chain=forward comment="reject dns forward (dhcp seems broken\?)" dst-port=53 in-interface=LAN-Bridge out-interface=VDSL protocol=udp reject-with=icmp-network-unreachable place-before=0
 
Zloy2452
just joined
Posts: 5
Joined: Fri Dec 08, 2017 4:12 pm

Re: 6.41rc61: DHCP server ignores dns-servers?

Fri Dec 08, 2017 4:19 pm

Hi! I can confirm this issue too. I have choosen the simplest solution and have reverted back to v6.41rc56 which works fine. I hope this issue will be fixed in the next RC.
 
RafGan
newbie
Posts: 29
Joined: Mon Jun 06, 2011 6:17 pm
Location: Poland / Silesia

Re: 6.41rc61: DHCP server ignores dns-servers?

Sat Dec 09, 2017 2:43 am

Confirm.
DNS servers from router's /ip dns settings servers are "magicaly forwarded" to hosts in my network.
Best Regards,
Raf G
 
edinorog
just joined
Posts: 23
Joined: Wed Aug 20, 2014 3:23 pm
Location: Россия

Re: 6.41rc61: DHCP server ignores dns-servers?

Tue Dec 12, 2017 5:13 am

the patch will be?
 
ranpha
newbie
Posts: 48
Joined: Mon Jan 09, 2012 3:16 am

Re: 6.41rc61: DHCP server ignores dns-servers?

Tue Dec 12, 2017 9:04 am

This also happens to me when I am testing LTE IP passthrough feature.

Sent from my SM-G935F using Tapatalk

 
pe1chl
Forum Guru
Forum Guru
Posts: 4578
Joined: Mon Jun 08, 2015 12:09 pm

Re: 6.41rc61: DHCP server ignores dns-servers?

Sun Dec 17, 2017 12:44 pm

I hope this isn't some "new direction for simplified configuration"...
It always has been like this (bad!) for IPv6, where the router advertises its own configured IPv6 DNS servers on the local network,
with no way at all to customize this (e.g. advertising the router itself as DNS server or some other DNS server on internet).

In IPv4 it worked as it should until now, but apparently it is now broken.
I think when MikroTik want to offer the capability to just relay some information (DNS, NTP) in the DHCP reply, it should
be a configurable option (can be ON by default), but it should be possible to override it with configured information as it was
before on the IPv4 DHCP server.
 
toxiczka
just joined
Posts: 4
Joined: Tue Oct 18, 2016 11:25 pm

Re: 6.41rc61: DHCP server ignores dns-servers?

Wed Jan 03, 2018 8:08 pm

Has anybody tested if is is working again in final 6.41?

I'm a little bit scared of testing it, because i could'nt find anything related to this in the changelog.
 
RafGan
newbie
Posts: 29
Joined: Mon Jun 06, 2011 6:17 pm
Location: Poland / Silesia

Re: 6.41rc61: DHCP server ignores dns-servers?

Thu Jan 04, 2018 12:11 am

Has anybody tested if is is working again in final 6.41?

I'm a little bit scared of testing it, because i could'nt find anything related to this in the changelog.

Yes, it is working again in 6.41 :-)
Best Regards,
Raf G

Who is online

Users browsing this forum: No registered users and 7 guests