Community discussions

MikroTik App
 
RavenWing71
newbie
Topic Author
Posts: 30
Joined: Thu May 12, 2011 3:52 am

v7.1Beta5 Bug: Redirect in Web Proxy causes reboot

Fri May 07, 2021 7:35 pm

I only have the Proxy enabled for 1 purpose. To redirect people in a certain IP subnet to our signup server. So my configuration is very simple:
/ip proxy
set enabled=yes
/ip proxy access
add action=redirect action-data=www.cactusinternational.com/EthernetIndependent/default.aspx src-address=100.64.0.0/26
And to enable this to work, I have NAT rules:
/ip firewall nat
add action=redirect chain=dstnat comment="RADIUS-DHCP: Send Restricted HTTP connections to internal web proxy." \
    dst-address-list=!WalledGarden dst-port=80 protocol=tcp src-address=100.64.0.0/26 to-ports=8080
add action=src-nat chain=srcnat comment="RADIUS-DHCP: NAT Restricted addresses on their way out." \
    out-interface=ether1 src-address=100.64.0.0/26 to-addresses=<WAN-IP>
When I have my laptop use an address from 100.64.0.0/26 and attempt to go to neverssl.com, the RB493AH, running v7.1beta5, reboots. Attached is the autosupout.rif the reboot creates.

PS: Winbox can not represent the redirect command. You must use the CLI to add it, and to look at it.
You do not have the required permissions to view the files attached to this post.

Who is online

Users browsing this forum: Baidu [Spider] and 13 guests